Cross Section Analysis & Design

Biaxial Analysis of Generic Cross Sections and Reinforcement Design
Contents

GENERAL .......................................................................................................................... 15
DISCLAIMER .................................................................................................................... 16
SUPPORTED ANALYSIS TYPES .................................................................................... 23
  Inertia data and section properties ............................................................................. 23
  Moment Curvature ...................................................................................................... 23
  Deformed configuration .............................................................................................. 24
  Stress state for given strain plane .............................................................................. 24
  Advanced interaction ................................................................................................. 25
Interaction as per specified Reinforced Concrete Code .............................................. 26
Reinforcement Check as per specified Reinforced Concrete Code ............................ 26
Reinforcement Design as per specified Reinforced Concrete Code ............................ 27
MAIN SCREEN LAYOUT ............................................................................................... 28
MAIN MENU DESCRIPTION ......................................................................................... 29
  File Menu ................................................................................................................ 29
    New ....................................................................................................................... 29
    New from existing .................................................................................................. 29
    Open ....................................................................................................................... 29
    Open sample project ............................................................................................. 29
    Save ....................................................................................................................... 29
    Save As ................................................................................................................. 29
    Capture picture of geometry ................................................................................. 29
    Recent projects ..................................................................................................... 29
    Exit ......................................................................................................................... 29
  Edit Menu ................................................................................................................ 30
    Edit -> Select submenu ......................................................................................... 30
Assign Material to Selected Figures ................................................................. 30
Properties ............................................................................................................. 30
Move ...................................................................................................................... 30
Copy ....................................................................................................................... 31
Rotate .................................................................................................................... 31
Mirror ................................................................................................................... 31
Replicate ............................................................................................................... 32
Delete .................................................................................................................... 32
Change Dimension Line Location ...................................................................... 32
Unlock Model ....................................................................................................... 32
Undo ..................................................................................................................... 32
Redo ....................................................................................................................... 32
View Menu ......................................................................................................... 33
Pan view ............................................................................................................... 33
Zoom In/Out ........................................................................................................ 33
Zoom Window ...................................................................................................... 33
Zoom Extends ...................................................................................................... 33
Reset toolbars ..................................................................................................... 33
Project Menu ..................................................................................................... 34
Project information ............................................................................................ 34
ReinforcedConcreteCode .................................................................................... 34
AvailableRebars ................................................................................................. 34
Materials Menu ................................................................................................. 35
Concrete ............................................................................................................... 35
Reinforcement ................................................................. 35
Linear Materials .............................................................. 35
Bilinear Materials ............................................................ 35
Trilinear Materials ............................................................ 35
Parabolic Materials .......................................................... 35
Custom Defined Materials (stress/strain curve) ..................... 35
Import from Library .......................................................... 35
Draw Menu ........................................................................ 36
Rectangle (Opposite points) ............................................... 36
Rectangle using dimensions ............................................... 36
Polygon ............................................................................ 36
Polygon from line offset ................................................... 36
Inscribed Polygon ............................................................. 36
Circle (2 Points) ............................................................... 36
Circle using Center and Diameter ....................................... 36
Circular Arc ....................................................................... 36
Donut ................................................................................. 36
Donut Segment ................................................................... 37
Fillet ................................................................................. 37
Standard Section ............................................................... 37
Rebar ................................................................................. 37
Rebar Line ......................................................................... 37
Rebar Circle ....................................................................... 37
Rebar Rectangle .......................................................... 37
Linear Dimension Line .................................................. 37
Radial Dimension Line .................................................. 37
Label ........................................................................... 37
Analysis Menu ................................................................. 38
Analysis Parameters ......................................................... 38
Calculation Parameters ..................................................... 38
Inertia Data .................................................................. 38
Moment Curvature ........................................................... 38
Deformed configuration .................................................... 38
Strain plane configuration ................................................... 38
Advanced Interaction analysis ............................................. 39
Reinforced Concrete code based interaction analysis .......... 39
Reinforcement Check ......................................................... 39
Reinforcement Design ....................................................... 40
Settings Menu ................................................................ 41
Set Units ....................................................................... 41
View Options ................................................................... 41
Reset to factory default settings ....................................... 41
Help Menu ..................................................................... 42
User Manual .................................................................... 42
Worked examples ............................................................. 42
Check for updates ............................................................... 42
1 min Tour ...................................................................... 42
Go to website .................................................................. 42
Find on facebook .............................................................. 42
Follow on twitter ........................................... 42
YouTube channel ........................................ 42
About .................................................................. 42

SOME BASIC ACTIONS ................................................ 43
Unlocking model .................................................. 43
Single selection of objects by picking ..................... 44
Relative positions of objects .................................. 46

DESCRIPTION OF FORMS .............................................. 48
Units .................................................................... 48
How to open .......................................................... 48
Description ............................................................ 48
View options .......................................................... 48
How to open .......................................................... 48
Description ............................................................ 48
Project information .................................................. 49
How to open .......................................................... 49
Description ............................................................ 49
Reinforced Concrete Code ........................................... 50
How to open .......................................................... 50
Description ............................................................ 50
Available Rebars ..................................................... 52
How to open .......................................................... 52
Description ............................................................ 52
Rebars library .......................................................... 53
How to open .......................................................... 53
Description ............................................................ 53
Replicate ............................................................... 54
How to open ........................................................................................................... 69
Description ............................................................................................................. 69
Reinforcement grade library .................................................................................... 70
How to open ............................................................................................................. 70
Description ............................................................................................................. 70
Rectangle (opposite points) ..................................................................................... 71
How to open ............................................................................................................. 71
Description ............................................................................................................. 71
Rectangle (using dimensions) ................................................................................... 72
How to open ............................................................................................................. 72
Description ............................................................................................................. 72
Polygon .................................................................................................................... 73
How to open ............................................................................................................. 73
Description ............................................................................................................. 73
Polygon from line offset ........................................................................................ 74
How to open ............................................................................................................. 74
Description ............................................................................................................. 74
Inscribed polygon .................................................................................................... 76
How to open ............................................................................................................. 76
Description ............................................................................................................. 76
Circle (2 points) ..................................................................................................... 77
How to open ............................................................................................................. 77
Description ............................................................................................................. 77
Circle (Center and Diameter) .................................................................................. 78
How to open ............................................................................................................. 78
Description ............................................................................................................. 78
Arc ............................................................................................................................. 79
How to open ............................................................................................................. 79
Description ............................................................................................................. 79
Donut ....................................................................................................................... 81
How to open ............................................................................................................. 81
Description ............................................................................................................. 81
Donut segment ....................................................................................................... 82
How to open ............................................................................................................. 82
Description ............................................................................................................. 82
Fillet .......................................................................................................................... 84
How to open ............................................................................................................. 84
Description ............................................................................................................. 84
Standard section .................................................................................................... 85
How to open ............................................................................................................. 85
Description ............................................................................................................. 85
Rebar ....................................................................................................................... 86
How to open ............................................................................................................. 86
Description ............................................................................................................. 86
Rebar line ................................................................................................................ 88
How to open ............................................................................................................. 88
Description ............................................................................................................. 88
Rebar circle ............................................................................................................. 91
How to open ............................................................................................................. 91
Description ............................................................................................................. 91
Rebar rectangle ..................................................................................................... 94
How to open ............................................................................................................. 94
Description ............................................................................................................. 94
Analysis parameters ............................................................................................ 97
How to open.......................................................................................................................................................................... 97
Description .................................................................................................................................................................................. 97
Calculation parameters ................................................................................................................................................................... 104
How to open.................................................................................................................................................................................. 104
Description .................................................................................................................................................................................. 104
Load cases for Moment Curvature .................................................................................................................................................... 108
How to open.................................................................................................................................................................................. 108
Description .................................................................................................................................................................................. 108
Load cases for deformed configuration ............................................................................................................................................ 110
How to open.................................................................................................................................................................................. 110
Description .................................................................................................................................................................................. 110
Load cases for strain plane analysis .................................................................................................................................................. 111
How to open.................................................................................................................................................................................. 111
Description .................................................................................................................................................................................. 111
Load cases for Advanced Interaction or R/C code based Interaction ............................................................................................... 112
How to open.................................................................................................................................................................................. 112
Description .................................................................................................................................................................................. 112
Load cases for reinforcement check .................................................................................................................................................... 114
How to open.................................................................................................................................................................................. 114
Description .................................................................................................................................................................................. 114
Load cases for reinforcement design .................................................................................................................................................. 115
How to open.................................................................................................................................................................................. 115
Description .................................................................................................................................................................................. 115
Options for Moment Curvature ......................................................................................................................................................... 116
How to open.................................................................................................................................................................................. 116
Description .................................................................................................................................................................................. 116
Options for Interaction ...................................................................................................................................................................... 117
How to open ........................................................................................................... 117
Description ............................................................................................................. 117
Inertia data .............................................................................................................. 118
How to open ............................................................................................................. 118
Description ............................................................................................................. 118
Moment curvature results ...................................................................................... 119
How to open ............................................................................................................. 119
Description ............................................................................................................. 119
Deformed configuration results ............................................................................ 120
How to open ............................................................................................................. 120
Description ............................................................................................................. 120
Strain plane analysis results ................................................................................ 121
How to open ............................................................................................................. 121
Description ............................................................................................................. 121
Interaction results (advanced) .............................................................................. 122
How to open ............................................................................................................. 122
Description ............................................................................................................. 122
Interaction results (as per selected R/C code) ....................................................... 123
How to open ............................................................................................................. 123
Description ............................................................................................................. 123
Reinforcement check results ................................................................................ 124
How to open ............................................................................................................. 124
Description ............................................................................................................. 124
Reinforcement design results ............................................................................... 125
How to open ............................................................................................................. 125
Description ............................................................................................................. 125
Report settings .................................................................................................... 127
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>How to open</td>
<td>127</td>
</tr>
<tr>
<td>Description</td>
<td>127</td>
</tr>
<tr>
<td><strong>CALCULATION REFERENCE</strong></td>
<td>128</td>
</tr>
<tr>
<td>General</td>
<td>128</td>
</tr>
<tr>
<td>Calculation of elasticity modulus of concrete</td>
<td>129</td>
</tr>
<tr>
<td>Eurocode 2 2004</td>
<td>129</td>
</tr>
<tr>
<td>AASHTO LRFD 2012, UBC 97, ACI 318 11</td>
<td>129</td>
</tr>
<tr>
<td>CSA A233 04</td>
<td>129</td>
</tr>
<tr>
<td>AS 3600 01</td>
<td>130</td>
</tr>
<tr>
<td>NZS 3101 95</td>
<td>130</td>
</tr>
<tr>
<td>BS 8110 97 and CP 65 1999</td>
<td>130</td>
</tr>
<tr>
<td>IS 456 2000</td>
<td>130</td>
</tr>
<tr>
<td>Rectangular stress distribution for concrete under compression in Ultimate Limit State</td>
<td>132</td>
</tr>
<tr>
<td>Eurocode 2 2004</td>
<td>132</td>
</tr>
<tr>
<td>AASHTO LRFD 2012, UBC 97, ACI 318 11</td>
<td>133</td>
</tr>
<tr>
<td>CSA A233 04</td>
<td>134</td>
</tr>
<tr>
<td>AS 3600 01</td>
<td>134</td>
</tr>
<tr>
<td>NZS 3101 95</td>
<td>135</td>
</tr>
<tr>
<td>BS 8110 97 and CP 65 1999</td>
<td>135</td>
</tr>
<tr>
<td>IS 456 2000</td>
<td>135</td>
</tr>
<tr>
<td>Calculation of strength reduction factors $\phi$ (only applicable for AASHTO, UBC, AS 3600, ACI 318, NZS 3101 codes)</td>
<td>137</td>
</tr>
<tr>
<td>AASHTO LRFD 2012</td>
<td>137</td>
</tr>
<tr>
<td>ACI 318 11</td>
<td>138</td>
</tr>
<tr>
<td>UBC 97</td>
<td>138</td>
</tr>
<tr>
<td>CSA A233 04</td>
<td>139</td>
</tr>
<tr>
<td>AS 3600 01</td>
<td>139</td>
</tr>
<tr>
<td>NZS 3101 95</td>
<td>139</td>
</tr>
</tbody>
</table>
Maximum allowable compressive axial load for reinforced concrete cross sections...... 140

AASHTO LRFD 2012, UBC 97, ACI 318 11 .............................................. 140
CSA A233 04 .......................................................................................... 140
AS 3600 01 .............................................................................................. 140
NZS 3101 95 ............................................................................................ 140
IS 456 2000 ........................................................................................... 141

Reinforcement ratio limits ($\rho_{\text{min}}, \rho_{\text{max}}$) ................................................................. 142

Eurocode 2 2004 ......................................................................................... 142
AASHTO LRFD 2012 .............................................................................. 142
UBC 97, ACI 318 11, AS 3600 01 ............................................................. 142
CSA A233 04 .......................................................................................... 142
NZS 3101 95 ............................................................................................ 143
BS 8110 97 and CP 65 1999 ................................................................. 143
IS 456 2000 ........................................................................................... 143

Material resistance limits .......................................................................... 144

Eurocode 2 2004 ......................................................................................... 144
AASHTO LRFD 2012 .............................................................................. 144
UBC 97 ....................................................................................................... 144
ACI 318 11 ............................................................................................... 144
AS 3600 01 .............................................................................................. 144
CSA A233 04 .......................................................................................... 144
NZS 3101 95 ............................................................................................ 144
BS 8110 97 .............................................................................................. 144
CP 65 1999 .............................................................................................. 145
IS 456 2000 ........................................................................................... 145

Interaction as per specified Reinforced Concrete Regulation.......................... 146

Case of Moment vs. Axial force ................................................................. 146
Case of Moment vs. Moment (Axial force is constant) ........................................ 148

Reinforcement Design ........................................................................................................ 152

Transformation of reinforcement ratio to rebar areas .................................................... 152

Advanced Interaction ........................................................................................................ 154

Case of Moment vs. Axial force ....................................................................................... 154

Case of Moment vs. Moment (Axial force is constant) ............................................... 158
User manual

GENERAL
Thank you for using Engissol products. Our R&D department which constitutes of experienced engineers and programmers can assure you that you will be provided with a robust, powerful and reliable application of high standards and guaranteed accurate results, regarding the analysis and design of any cross section (generic, built up of one or more geometric entities, composite etc.). Engissol’s know-how with respect to engineering application development is incomparable, a fact that is proven by thousands of satisfied end-users around the world.

Cross Section Analysis & Design performs all cross section calculation tasks. Among the program’s capabilities are the calculation and illustration of Moment vs. Curvature graphs, interaction surfaces, stain distributions as well as stress contour plots. Moreover, reinforcement check or design options are also supported. The application fully complies with all major codes for reinforced concrete sections (AASHTO, UBC, AS 3600, IS 456, ACI 318, BS 8110, CSA A233, EC2, NZS 3101 and CP 65) but can also handle other user-defined materials (linear, bilinear, trilinear, parabolic or fully customized materials by providing a stress/strain curve).

Cross Section Analysis & Design covers efficiently a design engineer’s everyday needs due to the program’s simplicity and the wide range of supported cases. Besides, it has been tested thoroughly to meet specific standards and is considered to be the best tool for the analysis of cross sections at a very low price.

At Engissol we are always looking for feedback on how to improve our products. You can contact us at engissol@engissol.com.
DISCLAIMER

IMPORTANT- READ CAREFULLY: This ENGINEERING SOFTWARE SOLUTIONS ("ENGISSOL") End-User License Agreement ("EULA") is a legal agreement between you, user of software applications, ("End User") and ENGISSOL for all ENGISSOL products, source code (where provided), demos, printed materials, and "online" or electronic documentation ("SOFTWARE PRODUCT(S)").

ENGISSOL grants to you a nonexclusive license to use the SOFTWARE PRODUCT(S) for the sole purposes of engineering and design calculations. By using the SOFTWARE PRODUCT(S), you agree to be bound by the terms of this EULA. If you do not agree to any part of the terms of this EULA, DO NOT USE, EVALUATE, OR REPLICATE IN ANY MANNER, ANY PART, FILE OR PORTION OF THE SOFTWARE PRODUCT(S).

All SOFTWARE PRODUCT(S) is licensed, not sold. By purchasing any of the SOFTWARE PRODUCT(S), you instantly acquire a license for the SOFTWARE PRODUCT(S) from ENGISSOL. The licenses do not expire unless explicitly stated otherwise. Each license of any SOFTWARE PRODUCT(S) can only be used on a single computer.

If the SOFTWARE PRODUCT(S) you have obtained is marked as a "DEMO" you may use one copy of the SOFTWARE PRODUCT(S) for testing purposes ("Evaluation Period"). DURING THE EVALUATION PERIOD YOU ARE NOT ENTITLED TO USE THE DEMO FOR COMMERCIAL PURPOSES.

ENFORCEMENT OF INTELLECTUAL PROPERTY RIGHTS. If the licensed right of use for this SOFTWARE PRODUCT(S) is purchased by you with any intent to reverse engineer, decompile, create derivative works, and the exploitation or unauthorized transfer of, any ENGISSOL intellectual property and trade secrets, to include any exposed methods or source code where provided, no licensed right of use shall exist, and any PRODUCT(s) created as a result shall be judged illegal by definition of all applicable law. Any sale or resale of intellectual property or created derivatives so obtained will be prosecuted to the fullest extent of all local, European and international law.

All ENGISSOL files remain ENGISSOL's exclusive property and YOU MAY NOT DISTRIBUTE ANY OF THEM.

1. GRANT OF LICENSE

This EULA, if legally executed as defined herein, licenses and so grants the single End User the following rights:

2. LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY

You may not reverse engineer, decompile, create derivative works, translate, or disassemble the SOFTWARE PRODUCT(S), and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation. You agree to take all reasonable, legal and appropriate measures to prohibit the illegal dissemination of the SOFTWARE PRODUCT(S) or any of its constituent parts.
3. RENTAL

You may not rent, lease, or lend the SOFTWARE PRODUCT(S).

6. UPDATES

You must be properly licensed to use the SOFTWARE PRODUCT(S) identified by ENGISSOL as being eligible for the update in order to use the SOFTWARE PRODUCT(S). An update of SOFTWARE PRODUCT(S) replaces the SOFTWARE PRODUCT(S) that formed the basis for your eligibility for the update, and together constitutes a single PRODUCT(S). You may use the resulting updated PRODUCT(S) only in accordance with all the terms of this EULA.

If the SOFTWARE PRODUCT(S) contains new critical features and therefore constitutes a major update, additional costs may apply in relevance and in proportion to the new features.

Any supplemental SOFTWARE PRODUCT(S) provided to you as part of the Support Services shall be considered part of the SOFTWARE PRODUCT(S) and subject to the terms and conditions of this EULA.

8. COPYRIGHT

All title and copyrights in and to the SOFTWARE PRODUCT(S) (including but not limited to any copy written documentation, demos, incorporated into any copies of the SOFTWARE PRODUCT(S)) are owned by ENGISSOL. The SOFTWARE PRODUCT(S) is protected by copyright laws and international treaty provisions and therefore, you must treat the SOFTWARE PRODUCT(S) like any other copyrighted material except that you may install the SOFTWARE PRODUCT(S) as described in this EULA.

9. DISCLAIMER OF WARRANTY

ENGISSOL expressly disclaims any warranty for the SOFTWARE PRODUCT(S). THE SOFTWARE PRODUCT(S) AND ANY RELATED DOCUMENTATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT.

10. LIMITATIONS ON LIABILITY

To the maximum extent permitted by applicable law, in no event shall ENGISSOL be liable for any special, incidental, indirect, or consequential damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use the SOFTWARE PRODUCT(S) or the provision of or failure to provide Support Services, even if ENGISSOL has been advised of the possibility of such damages.

End User understands that the SOFTWARE PRODUCT(S) may produce inaccurate results because of a failure or fault by End User to properly use and or deploy the SOFTWARE PRODUCT(S). End User assumes full and sole responsibility for any use of the SOFTWARE
PRODUCT(S), and bears the entire risk for failures or faults within the SOFTWARE PRODUCT(S). You agree that regardless the cause of failure or fault or the form of any claim, YOUR REMEDY AND ENGISSOL’S OBLIGATION SHALL BE GOVERNED BY THIS AGREEMENT AND THAT IS THE FAULT’S RESOLUTION. IN CASE OF INEFFECTIVENESS OF THE ABOVE ACTION ENGISSOL’S LIABILITY SHALL IN NO EVENT EXCEED THE PRICE PAID TO ENGISSOL FOR THE SOFTWARE PRODUCT(S). This Limited Warranty is void if failure of the SOFTWARE PRODUCT(S) has resulted from accident, abuse, alteration, unauthorized use or misapplication of the SOFTWARE PRODUCT(S).

11. TERMINATION

Without prejudice to any other rights or remedies, ENGISSOL will terminate this EULA upon your failure to comply with all the terms and conditions of this EULA. In such events, you must destroy all copies of the SOFTWARE PRODUCT(S) and all of its parts including any related documentation, and must remove ANY and ALL use of such technology immediately from any applications using technology contained in the SOFTWARE PRODUCT(S) developed by you, whether in native, altered or compiled state.

12. MISCELLANEOUS

This EULA may only be modified in writing signed by an authorized officer of ENGISSOL. If any provision of this EULA is found void or unenforceable, the remainder will remain valid and enforceable according to its terms.

ENGISSOL reserves all rights not specifically granted in this EULA.

End User acknowledges that he or she has read this Agreement, understands it, and agrees to be bound by its terms and conditions.

Should you have any questions concerning this EULA, or if you desire to contact ENGISSOL for any reason, please contact us at engissol@engissol.com.
SYSTEM REQUIREMENTS

Cross Section Analysis & Design ® is a 32 and 64 bit compatible application.

Your computer shall meet these minimum requirements so that Cross Section Analysis & Design can run properly.

<table>
<thead>
<tr>
<th>Processor</th>
<th>400 MHz</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum Processor</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RAM</th>
<th>96 MB</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum RAM</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Disk space (minimum)</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>32-bit</td>
<td>280 MB</td>
</tr>
<tr>
<td>64-bit</td>
<td>610 MB</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Operating system</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7 (all versions) x86 and x64</td>
<td></td>
</tr>
<tr>
<td>Windows Vista (all versions) x86 and x64</td>
<td></td>
</tr>
<tr>
<td>Windows XP (all versions) x86 and x64</td>
<td></td>
</tr>
<tr>
<td>Windows Millennium Edition</td>
<td></td>
</tr>
<tr>
<td>Microsoft Windows 98 Second Edition</td>
<td></td>
</tr>
<tr>
<td>Microsoft Windows 98</td>
<td></td>
</tr>
</tbody>
</table>
PROGRAM FEATURES

Cross Section Analysis & Design is a powerful application that can perform a wide range of cross section calculations, including the design of reinforced concrete sections. The given cross sections are built up of one or more geometric entities and can be drawn directly using the versatile featured user interface. The user can also import standard steel sections from a complete shape library according to all major codes (AISC, Australian-New Zealand, BS, Chinese, European, Indian, Aluminum etc.) There are no limitations regarding the shape, materials or loads of a section, since the program can handle any arbitrary cross section under biaxial bending and axial loads. Among its capabilities, Cross Section Analysis & Design can calculate all sectional properties, plot Moment - Curvature and Interaction diagrams, estimate the location of neutral axis under given sets of biaxial loads and plot the corresponding stress - strain diagrams as well as the resulting stress contours. The latter can also be calculated by providing the location of the neutral axis plane on the section. Moreover, the program fully complies with all major codes concerning reinforced concrete sections (AASHTO, UBC, AS 3600, IS 456, ACI 318, BS 8110, CSA A233, EC2, NZS 3101 and CP 65). The user can also perform a reinforcement design according to above listed codes, plot the matching interaction diagrams etc., or even check a given reinforcement amount for the specified load cases. The stress - strain curve of concrete, reinforcement and other materials is specified as per the defined Analysis Parameters Sets. Thus calculations can be performed for many design situations, such as Ultimate/Serviceability or custom defined Limit States, with an automatic adjustment of the material properties, safety factors etc. A large material library is also available according to almost all concrete/reinforcement material specifications. Apart from concrete and reinforcement materials, the user can specify custom linear, bilinear, trilinear parabolic or fully general materials.

The program features can be found below comprehensively:

Analysis:

- Section properties calculations (with regard to a user defined base material or the geometric properties of the section) including inertia data, elastic and plastic elasticity moduli etc.
- Calculation and plotting of the Moment vs. Curvature diagram for bending about a predefined axis. Accordingly, a Force vs. Axial strain diagram can be created.
- Calculation of the equivalent bilinear Moment vs. Curvature graph with predefined or no hardening, as well as reporting of yield/ultimate curvatures and moments.
- Estimation of the neutral axis, strain distribution and plotting of stress contour under given sets of biaxial applied forces. Reporting of reinforcement forces (if any) and the maximum/minimum stress locations for each material in the section.
- Estimation of the biaxial applied forces under a given neutral axis (location, orientation and curvature). As in previous case, the strain distribution and a stress contour are plotted. Moreover, the reinforcement forces (if any) are reported and the maximum/minimum stress locations for each material in the section are computed.
Advanced Interaction Diagram Analysis. The failure surface is calculated and plotted in one of the following coordinate systems, as per user defined parameters: Moment about predefined axis vs. Axial force or Moment about first axis vs. Moment about second axis. The user can specify different values for reinforcement ratios (if rebars have been provided) or axial force values, so that a multiple graphs can be plotted in one graph. This analysis type is generic and can be used to excerpt the interaction diagram of any generic section under of any material, shape etc. Apart from this, the use of Advanced Interaction Analysis is not recommended for reinforced concrete cross sections, where the following option is more appropriate.

Interaction diagram as per specified Reinforced Concrete Code. The program computes the interaction diagram as explained above, but applies all relative regulation checks, stress distributions, safety factors etc., according to the provided code (AASHTO, UBC, AS 3600, IS 456, ACI 318, BS 8110, CSA A233, EC2, NZS 3101 and CP 65).

Reinforcement Design. The provided reinforcement is designed, so that the required rebar diameters are chosen from the existing rebars defined in the project. This procedure takes place in accordance to the provided regulation (AASHTO, UBC, AS 3600, IS 456, ACI 318, BS 8110, CSA A233, EC2, NZS 3101 and CP 65).

Reinforcement Check. The given reinforcement pattern is checked and a capacity ratio of the cross section is reported.

Pre-processing:

- All major systems of units are supported (Metric, US, User defined)
- Top quality graphics rendering
- Full GUI including zoom, pan, grid, snap options
- Every user action can be done graphically at real time
- Library with all major steel section shapes
- Library with all major concrete and reinforcement grades, as well as other materials such as cold formed/hot rolled steel etc.
- Use of linear, bilinear, trilinear and parabolic materials
- Definition of custom materials by providing a relevant stress strain curve
- Definition and use of Analysis Parameters sets. In order to simulate different limit states for the analysis/design of the cross section, the user can use the existing sets ULS (Ultimate Limit State) or SLS (Serviceability Limit State), override them or add more sets of Analysis Parameters. Each set defines the concrete stress distribution at compressive or tensile zones, the safety factors (partial or resistance) to be used and all preferences regarding the steel reinforcement behavior in the calculations. Apart from these, the user can define his preferences for the remaining non steel/reinforcement materials (if any) in the section. Each load case is assigned with an Analysis Parameters set, so that the appropriate considerations are considered in the analysis/design.
- Automatic calculation of the minimum and maximum reinforcement ratio for a given cross section as per the specified Reinforced Concrete regulation. These values are considered for Reinforcement Design.
Post-processing:

- Comprehensive and versatile reporting of the results
- Automatic creation of high-quality, editable calculation report that can be exported to Word (doc), Excel (xls) and Adobe PDF (pdf) formats.
- Creation of fully customizable graphs (Moment vs. Curvature, Interaction etc.) as well as stress contours and strain distribution
- Reporting of neutral axis information, reinforcement forces and material stress information.
SUPPORTED ANALYSIS TYPES

Inertia data and section properties

\[
\begin{align*}
A \\
l_y \\
l_z \\
l_{yz} \\
W_{el} \\
W_{pl} \\
\text{etc.}
\end{align*}
\]

Input: Section geometry and materials
Output: Calculation of inertia data and remaining section properties

Moment Curvature

\[
\begin{align*}
M & \uparrow \\
N & \uparrow \text{const.} \\
\frac{1}{r} & \rightarrow \\
\varepsilon & \rightarrow
\end{align*}
\]

Input: Section geometry, materials and curve type (Curvature vs. Moment, Strain vs. Axial force etc.)
Output: The requested curve according to provided data

This analysis type is regardless of the specified Reinforced Concrete regulation. Apart from partial safety factors for materials, strength reduction factors \( \varphi \) are not applied! In order to verify the adequacy of the cross section according to a code for reinforced concrete sections, an Interaction (as per specified Reinforced Concrete Code) Analysis should be executed.
Deformed configuration

**Input:** Section geometry, materials and biaxial loads

**Output:** Strain and stress distribution

*This analysis type is regardless of the specified Reinforced Concrete regulation. Apart from partial safety factors for materials, strength reduction factors $\phi$ are not applied! In order to verify the adequacy of the cross section according to a code for reinforced concrete sections, an Interaction (as per specified Reinforced Concrete Code) Analysis should be executed.*

Stress state for given strain plane

**Input:** Section geometry, materials and strain distribution (strain plane definition by neutral axis angle, curvature and strain at origin)

**Output:** Stress distribution and biaxial loads

*This analysis type is regardless of the specified Reinforced Concrete regulation. Apart from partial safety factors for materials, strength reduction factors $\phi$ are not applied! In order to*
verify the adequacy of the cross section according to a code for reinforced concrete sections, an Interaction (as per specified Reinforced Concrete Code) Analysis should be executed.

**Advanced interaction**

**Input:** Section geometry, materials and interaction type (Moment vs. Moment or Moment vs. Axial force etc.)

**Output:** The requested interaction curve according to provided data

This analysis type is regardless of the specified Reinforced Concrete regulation. Apart from partial safety factors for materials, strength reduction factors $\varphi$ are not applied! The materials used in the section can be of any type, as the maximum response of the cross section against biaxial loads is computed. This type of analysis is suitable for generic cross sections that consist of arbitrary materials, such as composite sections with encased steel members, masonry sections etc. In order to verify the adequacy of the cross section according to a code for reinforced concrete sections, an Interaction (as per specified Reinforced Concrete Code) Analysis should be executed.
Interaction as per specified Reinforced Concrete Code

**Input:** Section geometry, materials, interaction type (Moment vs. Moment or Moment vs. Axial force etc.) and Reinforced Concrete Code (AASHTO, UBC, AS 3600, IS 456, ACI 318, BS 8110, CSA A233, EC2, NZS 3101 or CP 65)

**Output:** The requested interaction curve according to provided data

Reinforcement Check as per specified Reinforced Concrete Code

**Input:** Section geometry, materials, rebar pattern and Reinforced Concrete Code (AASHTO, UBC, AS 3600, IS 456, ACI 318, BS 8110, CSA A233, EC2, NZS 3101 or CP 65)
**Output:** Capacity ratio of the cross section under the given loads

**Reinforcement Design as per specified Reinforced Concrete Code**

![Diagram of a cross section with labeled forces and rebar area](image)

**Input:** Section geometry, materials, locations of rebars and **Reinforced Concrete Code** (AASHTO, UBC, AS 3600, IS 456, ACI 318, BS 8110, CSA A233, EC2, NZS 3101 or CP 65)

**Output:** Selection of rebars so that all relevant code checks are satisfied
MAIN SCREEN LAYOUT

The main screen layout Cross Section Analysis & Design is illustrated below.
MAIN MENU DESCRIPTION

File Menu

New

Creates a new empty file.

New from existing

Creates a new file adopting all properties, except geometry, of another specified file.

Open

Opens a file from disk.

Open sample project

Shows a dialog with all sample projects that can be opened.

Save

“Save” will save the current file under the same name in the same location. It saves the changes over the original file that has been opened.

Save As

“Save As” will always bring up a window allowing the user to change the file name and its location in disk. Assuming you make a change to name or location, the original file will still be intact in its original location after the “Save As”.

Capture picture of geometry

The user can take a picture of what is on the drawing screen by selecting this command under the File. A dialog will open where the user can specify the location and format (jpg, bmp, gif) of the image.

Recent projects

All recent projects that have been opened or saved lately will appear here. They can be directly opened by clicking on them without using the “Open” command.

Exit

Closes the application and asks for saving in case of unsaved data in current file.
Edit Menu

Edit -> Select submenu

All
Selects all geometric objects.

By Material
Selects the geometric objects that have been assigned with the specified material.

By Material Type
Selects the geometric objects of the specified material type. The supported material types are: Concrete, Reinforcement, Other Materials (all remaining defined in project).

All dimension lines
Selects all existing dimension lines.

All labels
Selects all existing dimension labels.

Boxed selection
The user can draw a rectangular window using two points. If the window is defined rightwards (from left to right), all objects which lie entirely within it, will be selected. If a window is defined leftwards (from right to left), only objects which lie entirely within the window or cross the window border, are selected.

Clear selection
Deselects all objects. This action can be invoked with the Esc button as well.

Assign Material to Selected Figures
This command is only available when at least one object has been selected. Using these options, the user can massively assign a new material to all selected geometric objects. Warning: Reinforcement objects can only be assigned with reinforcement material types.

Properties
This command is only available when only one object has been selected. “Properties” command displays the geometric data, material properties etc. of the selected entity.

Move
“Move” will allow the reposition of an entity or entities.

Description

1. Select the object(s) to be moved
2. Specify base point by left mouse click
3. Specify end point by left mouse click

**Copy**

The copy command will copy any selected drawing elements and reposition where specified by the user, without affecting the original elements.

**Description**

1. Select the object(s) to be copied
2. Specify base point by left mouse click
3. Specify end point by left mouse click

**Rotate**

The “Rotate” command allows you to rotate an object(s) around a point of reference.

**Description**

1. Select the object(s) to be rotated
2. Specify base point by left mouse click
3. Specify rotation base point by left mouse click
4. Specify rotation end point by moving the mouse and left-clicking on a point

*If option “Delete after mirroring/rotating” is enabled, then the source objects will be deleted, otherwise they will remain intact. This option can be found in the bottom toolbar of the main screen.*

**Mirror**

The “Mirror” command will create a mirror image of any selected drawing elements along a line of symmetry specified by the user.

**Description**

1. Select the object(s) to be mirrored
2. Specify starting point of symmetry axis by left mouse click
3. Specify ending point of symmetry axis by left mouse click

*If option “Delete after mirroring/rotating” is enabled, then the source objects will be deleted, otherwise they will remain intact. This option can be found in the bottom toolbar of the main screen.*
Replicate

The “Replicate” command will create one or more similar objects to the selected one(s) using linear, radial or mirroring patterns.

Delete

Deletes all selected objects.

Change Dimension Line Location

Changes the offset of a dimension line (straight or radial). The user shall first click on this command and afterwards click on a dimension line in order to modify its offset.

Unlock Model

This command unlocks the file in order to enable editing but deletes all calculation results. When the user runs an analysis, the model is locked automatically. This is done to keep the user from changing it such that calculation results are invalidated.

Undo

This command allows the user to undo a number of recent actions in a file.

Redo

This command allows the user to redo a number of recent actions in a file, which have been undone previously.
View Menu

Pan view
Panning allows you to quickly move around the drawing area at the same magnification you currently have set.

Zoom In/Out
The Zoom In/Out commands allow the user to change the display size of a drawing on the computer screen.

Zoom Window
The Zoom Window command zooms to the rectangle defined by the user in the drawing screen.

Zoom Extends
The Zoom Extends command zooms to the edges of the drawing.

Reset toolbars
Resets the layout of the toolbars located at the top of the main form.
Project Menu

**Project information**

This command displays a form where the project information (Project Name, Engineer Name, Date etc.) is available.

**Reinforced Concrete Code**

By clicking this item, a form opens where the Reinforced Concrete Code can be specified.

**Available Rebars**

By clicking this item, a form opens where the available Rebar Diameters can be specified.
Materials Menu

Concrete
This command opens a form where existing concrete materials can be added, modified or shown.

Reinforcement
This command opens a form where existing reinforcement materials can be added, modified or shown.

Linear Materials
This command opens a form where existing linear materials can be added, modified or shown.

Bilinear Materials
This command opens a form where existing bilinear materials can be added, modified or shown.

Trilinear Materials
This command opens a form where existing trilinear materials can be added, modified or shown.

Parabolic Materials
This command opens a form where existing parabolic materials can be added, modified or shown.

Custom Defined Materials (stress/strain curve)
This command opens a form where existing custom materials defined by providing their stress/strain curve can be added, modified or shown.

Import from Library
This command opens the “Materials library” form where the user can choose to include any predefined material from the application library in the project.
Draw Menu

**Rectangle (Opposite points)**

Using this command, the user can draw a rectangle object by providing two opposite points.

**Rectangle using dimensions**

Using this command, the user can draw a rectangle object by providing its dimensions.

**Polygon**

Using this command, the user can draw a polygon object by providing a sequence of edge points.

**Polygon from line offset**

Using this command, the user can indirectly draw a polygon by providing an axis line and an offset distance. The program will then create the corresponding polygon object.

**Inscribed Polygon**

Using this command, the user can draw a polygon object by providing a center point and a point on its circumscribed circle.

**Circle (2 Points)**

Using this command, the user can draw a circle object by providing its center point and one point on it.

**Circle using Center and Diameter**

Using this command, the user can draw a circle object by providing the center point and its diameter.

**Circular Arc**

Using this command, the user can draw a circular arc object by providing the center point and starting/ending arc points.

**Donut**

Using this command, the user can draw a donut object by providing its center point and two points, on internal and external circle.
Donut Segment

Using this command, the user can draw a donut segment object by providing the center point and starting/ending arc points.

Fillet

Using this command, the user can draw a fillet object by providing its center and another auxiliary point.

Standard Section

This command opens a form where existing predefined standard sections can be selected and inserted in the project.

Rebar

Using this command, the user can draw a single rebar by providing its center point.

Rebar Line

Using this command, the user can draw a sequence of collinear rebars.

Rebar Circle

Using this command, the user can draw a sequence of rebars that lie on a provided circle.

Rebar Rectangle

Using this command, the user can draw a sequence of rebars that lie on a provided rectangle.

Linear Dimension Line

Using this command, the user can draw a straight dimension line.

Radial Dimension Line

Using this command, the user can draw a radial dimension line.

Label

Using this command, the user can insert a description label.
Analysis Menu

Analysis Parameters
This command opens a form where existing Analysis Parameters sets can be added, modified or shown.

Calculation Parameters
This command opens a form where the Calculation Parameters can be viewed or modified.

Inertia Data

Analyze menu item: Calculates all sectional properties of the given cross section

Show results menu item: Displays all calculated sectional properties and shows the principal inertia system of coordinates, as well as the ellipse of inertia.

Moment Curvature

Load cases menu item: Opens a form where the user can define/modify the load case(s) and corresponding properties regarding the Moment/Curvature analysis cases.

Analyze menu item: Calculates the Moment/Curvature curve(s) under the assigned load case(s) and according to provided properties.

Show results menu item: Displays the calculated Moment/Curvature curve(s).

Deformed configuration

Load cases menu item: Opens a form where the user can define/modify the load case(s) and corresponding properties regarding the analysis cases for the computation of the neutral axes properties under given biaxial loads and normal force.

Analyze menu item: Calculates the neutral axis of the cross section under the assigned load case(s) and according to provided properties.

Show results menu item: Displays the neutral axis, strain distribution, stress contour and other properties (equivalent force couple, reinforcement forces etc.) of the cross section.

Strain plane configuration

Load cases menu item: Opens a form where the user can define/modify the load case(s) and corresponding properties regarding the analysis cases for the computation of the stress state under the given strain plane.
Analyze menu item: Calculates the stress state at the cross section under the assigned load case(s) and according to provided properties.

Show results menu item: Displays the stress contour and all remaining properties (equivalent force couple, reinforcement forces etc.) of the cross section.

**Advanced Interaction analysis**

Load cases menu item: Opens a form where the user can define/modify the load case(s) and corresponding properties regarding the analysis cases for the computation of the interaction surface using the generic, advanced, regulation non-compatible method.

Analyze menu item: Calculates the interaction surface using the generic, advanced, regulation non-compatible method under the assigned load case(s) and according to provided properties. **Warning:** Advanced interaction analysis produces the interaction surface of the given cross section according to the corresponding properties (Loads, Analysis parameters etc.). Material resistance or partial safety factors are not applied! The interaction curve represents the nominal ultimate resistance of the cross section with respect to the stress/strain curves of the assigned materials. This option should not be used for reinforcement design.

Show results menu item: Displays the calculated interaction surface for the cross section.

**Reinforced Concrete code based interaction analysis**

Load cases menu item: Opens a form where the user can define/modify the load case(s) and corresponding properties regarding the analysis cases for the computation of the interaction surface as per specified Reinforced Concrete code.

Analyze menu item: Calculates the interaction surface as per specified Reinforced Concrete code, under the assigned load case(s) and according to provided properties.

Show results menu item: Displays the calculated interaction surface for the cross section.

**Reinforcement Check**

Load cases menu item: Opens a form where the user can define/modify the load case(s) and corresponding properties regarding the capacity check of the provided reinforcement as per specified Reinforced Concrete code.

Analyze menu item: Calculates the capacity ratio of the reinforcement as per specified Reinforced Concrete code, under the assigned load case(s) and according to provided properties.
Show results menu item: Displays the corresponding results for the check of reinforcement bars.

Reinforcement Design

Load cases menu item: Opens a form where the user can define/modify the load case(s) and corresponding properties regarding the reinforcement design as per specified Reinforced Concrete code.

Analyze menu item: Calculates the required reinforcement amount as per specified Reinforced Concrete code, under the assigned load case(s) and according to provided properties.

Show results menu item: Displays the corresponding results for the design of reinforcement bars.
Settings Menu

Set Units
This command shows the “Units definition” form, where the user can choose between a metric, US or fully customized set of units for current project.

View Options
This opens the “View options” form, where colors, fonts/sizes and miscellaneous (some view options and the convention of axes) can be viewed or modified.

Reset to factory default settings
This option restores all user-defined preferences (colors, fonts, axis convention, toolbars etc.) to their default values.
Help Menu

User Manual
This command displays the Help file of Cross Section Analysis & Design.

Worked examples
This command displays a document with same basic, step-by-step, worked examples for Cross Section Analysis & Design.

Check for updates
Connects to the internet and searches for an updated version of Cross Section Analysis & Design.

1 min Tour
Show a short tour of the application.

Go to website
Opens your internet browser and displays the webpage of Cross Section Analysis & Design.

Find on facebook
Opens your internet browser and displays the page of Cross Section Analysis & Design on Facebook.

Follow on twitter
Opens your internet browser and displays the page of Cross Section Analysis & Design on Twitter.

YouTube channel
Opens your internet browser and displays the YouTube channel of Cross Section Analysis & Design, where demonstrative videos, samples and other useful information can be viewed.

About
Displays the “About” screen of the application, where installed version and your machine ID can be found.
SOME BASIC ACTIONS

Unlocking model

This command unlocks the file in order to enable editing but deletes all calculation results. When the user runs an analysis, the model is locked automatically. This is done to keep the user from changing it such that calculation results are invalidated.

As soon as an analysis has finished, the file is locked automatically. This is done to keep the user from changing it such that the calculation results are invalidated.

After the completion of an analysis, the model must first be unlocked (Edit -> Unlock Model or icon), so that it can be further modified. Unlocking the model deletes all results.
**Single selection of objects by picking**

Each object that has been inserted can be selected by just clicking on it. Selected objects are illustrated with a crossing hatch pattern. An object can be deselected by clicking on it again. The selection of multiple objects can be cleared by clicking on the Esc button on the keyboard, or using the corresponding toolbar button.

Reinforcement lines, reinforcement rectangles and reinforcement circles can be selected by clicking on a belonging rebar or just on their corresponding base line (straight line, rectangle, circle). When reinforcement lines, rectangles or circles are selected, some basic dimensions appear additionally. For example, in the above picture, the radius of the selected reinforcement circle is shown when it is selected.

Moreover, on the lower left corner of the main window, the number of selected objects is shown, so that the user can be easily informed about the current object selection.
All objects can be massively selected by using the keyboard keystroke Ctrl+A, choosing this option from the right-click drop down menu, or clicking on Edit -> Select -> All menu item.
Relative positions of objects

The user can draw geometric entities without any restriction on their relative position, excluding only the edge overlap which is not allowed, as showed below.

*Overlapping edges are not allowed*

On the other hand, an object can be entirely placed within another one, as shown in the following picture.

*Object inside another object*
The program automatically detects the relative positions of the provided objects. For the case above, the yellow circle lies entirely inside the cyan polygon. So, the program assumes that the cyan polygon has a hole where the whole yellow circle is inserted. In this way, the user can very easily describe the geometry of the section correctly, while the program does not consider the common areas twice.

*Provided geometry by the user*

*How program handles above case*
DESCRIPTION OF FORMS

Units

How to open

1. By selecting Settings -> Set Units options from the main window menu bar.

2. By clicking on the “Units” status bar button in the lower right corner of the main screen and then selecting “Details”

Description

The system of units for all input and output data can be defined using this form. The user can choose between the predefined Metric and US (Imperial) systems or even provide his own units for each item, such as force, length, area etc.

View options

How to open

By selecting Settings -> View options from the main window menu bar.

Description

Colors tab

In this tab, the user can modify the colors of the drawing area (background, grid, ruler, axes etc.), the colors of the geometric objects (polygons, points, reinforcement bars etc.), color preferences for dimensions/labels as well as for the information pane on the left of the main screen. Moreover, the user is able to see/modify the colors of the displayed resulting screens.

Fonts and sizes

In this tab, the user can define the displayed font families and corresponding font sizes.

Misc. tab

Among other data, the user can specify whether the reinforcement bars will be drawn with scale (as per their diameter) or with constant size circles of a pre-defined diameter in pixels.

Moreover, the user can specify the labels of the axes. This convention is valued at every reference to the coordinate system. Specified axes labels will be considered in the geometric definition of the cross section, the specified load cases as well as the calculation results. Cross Section Analysis & Design uses the coordinate system y-z by default, assuming that the longitudinal x axis is coming out vertical from the computer screen. However, this can be changed as shown above.

“Reset to default values” button applies all default settings for the data listed in the “View options” form.
Project information

How to open

1. By selecting Project -> Project information from the main window menu bar

2. By clicking on the corresponding toolbar button 📊 of the main window

Description

Project, company as well as model information can be provided using this form. All relative data will be included in the calculation report.
Reinforced Concrete Code

How to open

1. By selecting Project -> Reinforced Concrete Code from the main window menu bar
2. By clicking on the corresponding toolbar button of the main window

Description

The Reinforced Concrete Regulation is specified in this form. This is applicable only for the following analysis types:

1. Interaction as per Reinforced Concrete Code
2. Reinforcement Design
3. Reinforcement Check

In case concrete and reinforcement materials have not been assigned to a section part, the corresponding code can be set to None. Consequently, aforementioned analysis types will be disabled. In this case, all remaining data relative to reinforced concrete check/design, such as concrete/reinforcement material and rebar definitions, will also be disabled.

The user can choose between the following Reinforced Concrete Codes:

- AASHTO LRFD 2012
- UBC 97
- AS 3600 01
- IS 456 2000
- ACI 318 11
- BS 8110 97
- CSA A233 04
- EUROCODE 2 2004
- NZS 3101 95
- CP 65 1999

Depending on the specified code, the user may specify some additional options which will affect design parameters, such as safety factors, reduction factors, allowable minimum/maximum reinforcement ratios etc.
Moreover, the user can override the minimum and maximum reinforcement ratio limits by choosing the related option as below:

![Reinforcement ratio limits](image)

By using the option “Default by code for columns”, the program assumes that the cross section belongs to a column and calculates the maximum and minimum ratios according to the selected code. In other cases (for example beam and wall sections etc.), the user shall override these values.
Available Rebars

How to open

1. By selecting Project -> Available Rebars from the main window menu bar

2. By clicking on the corresponding toolbar button of the main window

Description

The list of available Rebar Diameters is defined using this form. These rebar sizes are available when drawing reinforcement bars in the main window of the application. Besides, during Reinforcement Design, only rebars defined herein will be selected.

Adding new rebar

Enter its name and the corresponding diameter in the relative fields on the top of the form and click on the Add new button.

Deleting a rebar

Select the rebar(s) to be deleted from the list (multiple selection with Ctrl or Shift button) and then click on the Delete current button.

Modifying a rebar

Select the rebar to be modified from the list, enter the new values in the corresponding fields “Name”, “Diameter” and finally click on “Modify current” button.

Inserting rebar(s) from library

Click on “From library...” button in order to insert predefined rebars from library.
Rebars library

How to open

By clicking on the “From library...” button on the Available Rebars form.

Description

A list of the most common standards for rebar diameters (SI, US Customary, Canadian, US Soft Metric) can be found in this form.

Inserting rebar(s)

Select the rebar(s) to be inserted from the list (multiple selection with Ctrl or Shift button) and then click the “Insert selected rebars” button.

Inserting all rebars from current list

Just click the “Insert whole rebar set” button.
Replicate

How to open

1. By selecting one or more geometric objects and then selecting Edit -> Replicate from the main window menu bar

2. By selecting one or more geometric objects and then clicking on the corresponding toolbar button on the right of main window

3. By right-clicking on a geometric object and choosing the Replicate item

Description

This command creates one or more copies of one or more specified initial geometric objects. The available options are: Linear replicate, Radial replicate and Mirror.

**Linear replicate**

The user can specify the count and of the increments as well as the increment distances in order to create new geometric objects.

**Radial replicate**

In the same manner, the user can specify the base point, angular increments and increment count in order to create radial replicates from the initial object(s). Moreover, the arc direction (e.g. clockwise) is specified.

**Mirror**

Initial object(s) are mirrored about an axis specified by two points.

*When “Delete original objects” option is selected, the geometric entities that have been selected will be removed after replicating.*
Concrete

How to open

1. By selecting Materials -> Concrete from the main window menu bar

2. By clicking on the corresponding toolbar button of the main window

Description

Available concrete materials list
This list contains all concrete materials that have been defined in the project. In order to show, modify or delete one, you should first highlight it.

All available materials list
This list contains all available materials defined in the project, regardless of their type. For example, a reinforcement material will be included here as well.

Concrete panel
In this panel, all data regarding the selected concrete material are shown. It should be noted that concrete strength refers to the stress of strength specified by the selected Reinforced Concrete Code. IS 456, BS 8110, and CP 65 standards require the cubic strength in this field, whereas remaining codes (AASHTO, UBC, AS 3600, ACI 318, CSA A233, EC2 and NZS 3101) require the corresponding cylinder strength.

By selecting the option “Confined”, current concrete material will be assumed to be confined and the relative amplification factors (defined in Analysis Parameters) will apply, so that modified values for concrete strength and corresponding strains are taken into account due to confinement.

The option “User defined elasticity modulus” allows the user to enter a specific value of the concrete elasticity modulus. If unchecked, the program calculates the corresponding elasticity modulus based on the provided stress of strength and according to the specified Reinforced Concrete Code.

Add new button
A new concrete material can be added by clicking this button.

From library
A predefined concrete material from a list can be inserted by clicking this button.

Delete
Current concrete material can be deleted by clicking this button.
Reinforcement

How to open

1. By selecting Materials -> Reinforcement from the main window menu bar

2. By clicking on the corresponding toolbar button of the main window

Description

Available reinforcement materials list
This list contains all reinforcement materials that have been defined in the project. In order to show, modify or delete one, you should first highlight it.

All available materials list
This list contains all available materials defined in the project, regardless of their type. For example, a concrete material will be included here as well.

Reinforcement panel
In this panel, all data regarding the selected reinforcement material are shown, including the related yield strength.

Add new button
A new reinforcement material can be added by clicking this button.

From library
A predefined reinforcement material from a list can be inserted by clicking this button.

Delete
Current reinforcement material can be deleted by clicking this button.
Linear Materials

How to open

1. By selecting Materials -> Linear Materials from the main window menu bar

2. By clicking on the corresponding toolbar button of the main window

Description

Available linear materials list
This list contains all linear materials that have been defined in the project. In order to show, modify or delete one, you should first highlight it.

All available materials list
This list contains all available materials defined in the project, regardless of their type. For example, a bilinear material will be included here as well.

Material data panel
In this panel, all data regarding the selected linear material are shown.

Among the obvious fields (Name, Notes, Color), the following values can be specified:

- **E pos**: Represents the elasticity modulus of the positive branch
- **e max**: Represents the maximum positive strain
- **E neg**: Represents the elasticity modulus of the negative branch
- **e min**: Represents the minimum negative strain
- **Is symmetric**: If selected, the stress strain curve will be assumed symmetric around the origin
- **Can take tension**: If selected, the stress strain curve will resist tensile stresses
- **Can take compression**: If selected, the stress strain curve will resist compressive stresses

Stress vs. Strain curve for linear materials (only tensile part is shown)
- **Allow strain values outside the defined curve**: If selected, the material will be assumed to accept unlimited strain values, outside the above stress/strain diagram, without provoking failure. Apparently, the stress values outside the graph will be zero. For instance this option should be used if modeling materials where cracks are allowed, so that the program can allow the development of unlimited strains without a corresponding stress resistance.

![Stress-Strain curve](image)

*Allow strain values outside the defined curve option*

**Stress-Strain curve**
The created stress/strain curve based on the provided data is shown here. The user can take a picture of this curve by clicking this button at the upper right corner of this window.

**Add new button**
A new linear material can be added by clicking this button.

**Delete**
Current linear material can be deleted by clicking this button.

**Convert to editable custom defined material**
By clicking this button, current material will be converted to custom defined material. It can then be found by choosing Materials -> Custom Defined Materials (stress/strain curve), or by clicking the toolbar icon on the top of the main window.
Bilinear Materials

How to open

1. By selecting Materials -> Bilinear Materials from the main window menu bar
2. By clicking on the corresponding toolbar button of the main window

Description

*Available bilinear materials list*
This list contains all bilinear materials that have been defined in the project. In order to show, modify or delete one, you should first highlight it.

*All available materials list*
This list contains all available materials defined in the project, regardless of their type. For example, a linear material will be included here as well.

*Material data panel*
In this panel, all data regarding the selected bilinear material are shown.

Among the obvious fields (Name, Notes, Color), the following values can be specified:

*Stress vs. Strain curve for bilinear materials (only tensile part is shown)*

- **E1 pos**: Represents the elasticity modulus of the first positive branch
- **ey pos**: Represents the ending strain of the first positive branch
- **E2 pos**: Represents the elasticity modulus of the second positive branch (hardening)
- **e max**: Represents the maximum positive strain
- **E1 neg**: Represents the elasticity modulus of the first negative branch
- **ey neg**: Represents the ending strain of the first negative branch
- **E2 neg**: Represents the elasticity modulus of the second negative branch (hardening)
- **e min**: Represents the minimum negative strain
• **Is symmetric**: If selected, the stress strain curve will be assumed symmetric around the origin

• **Can take tension**: If selected, the stress strain curve will resist tensile stresses

• **Can take compression**: If selected, the stress strain curve will resist compressive stresses

• **Allow strain values outside the defined curve**: If selected, the material will be assumed to accept unlimited strain values, outside the above stress/strain diagram, without provoking failure. Apparently, the stress values outside the graph will be zero. For instance this option should be used if modeling materials where cracks are allowed, so that the program can allow the development of unlimited strains without a corresponding stress resistance

![Stress-Strain curve](image)

*Allow strain values outside the defined curve option*

**Stress-Strain curve**
The created stress/strain curve based on the provided data is shown here. The user can take a picture of this curve by clicking this button at the upper right corner of this window.

**Add new button**
A new bilinear material can be added by clicking this button.

**Delete**
Current bilinear material can be deleted by clicking this button.

**Convert to editable custom defined material**
By clicking this button, current material will be converted to custom defined material. It can then be found by choosing Materials -> Custom Defined Materials (stress/strain curve), or by clicking the toolbar icon on the top of the main window.
Trilinear Materials

How to open

1. By selecting Materials -> Trilinear Materials from the main window menu bar
2. By clicking on the corresponding toolbar button of the main window

Description

Available trilinear materials list
This list contains all trilinear materials that have been defined in the project. In order to show, modify or delete one, you should first highlight it.

All available materials list
This list contains all available materials defined in the project, regardless of their type. For example, a linear material will be included here as well.

Material data panel
In this panel, all data regarding the selected trilinear material are shown.

Among the obvious fields (Name, Notes, Color), the following values can be specified:

Stress vs. Strain curve for trilinear materials (only tensile part is shown)

- **E1 pos**: Represents the elasticity modulus of the first positive branch
- **ey1 pos**: Represents the ending strain of the first positive branch
- **E2 pos**: Represents the elasticity modulus of the second positive branch
- **ey2 pos**: Represents the ending strain of the second positive branch
- **E3 pos**: Represents the elasticity modulus of the third positive branch
- **emax**: Represents the maximum positive strain
- **E1 neg**: Represents the elasticity modulus of the first negative branch
- **ey1 neg**: Represents the ending strain of the first negative branch
- **E2 neg**: Represents the elasticity modulus of the second negative branch
- **ey2 neg**: Represents the ending strain of the second negative branch
- **E3 neg**: Represents the elasticity modulus of the third negative branch
- **e min**: Represents the minimum negative strain
- **Is symmetric**: If selected, the stress strain curve will be assumed symmetric around the origin
- **Can take tension**: If selected, the stress strain curve will resist tensile stresses
- **Can take compression**: If selected, the stress strain curve will resist compressive stresses
- **Allow strain values outside the defined curve**: If selected, the material will be assumed to accept unlimited strain values, outside the above stress/strain diagram, without provoking failure. Apparently, the stress values outside the graph will be zero. For instance this option should be used if modeling materials where cracks are allowed, so that the program can allow the development of unlimited strains without a corresponding stress resistance.

![Stress-Strain curve](image)

*Allow strain values outside the defined curve option*

**Stress-Strain curve**
The created stress/strain curve based on the provided data is shown here. The user can take a picture of this curve by clicking this button at the upper right corner of this window.

**Add new button**
A new trilinear material can be added by clicking this button.

**Delete**
Current trilinear material can be deleted by clicking this button.
Convert to editable custom defined material
By clicking this button, current material will be converted to custom defined material. It can then be found by choosing Materials -> Custom Defined Materials (stress/strain curve), or by clicking the toolbar icon on the top of the main window.
Parabolic Materials

How to open

1. By selecting Materials -> Parabolic Materials from the main window menu bar

2. By clicking on the corresponding toolbar button of the main window

Description

Available parabolic materials list
This list contains all parabolic materials that have been defined in the project. In order to show, modify or delete one, you should first highlight it.

All available materials list
This list contains all available materials defined in the project, regardless of their type. For example, a linear material will be included here as well.

Material data panel
In this panel, all data regarding the selected parabolic material are shown.

Among the obvious fields (Name, Notes, Color), the following values can be specified:

- **Einit pos**: Represents the initial elasticity modulus (tangent at origin) of the positive branch
- **e max**: Represents the maximum positive strain
- **Stress at e max**: Represents the stress that corresponds to the strain e max
- **Einit neg**: Represents the initial elasticity modulus (tangent at origin) of the negative branch
- **e min**: Represents the minimum negative strain
- **Stress at e min**: Represents the stress that corresponds to the strain e min

*Stress vs. Strain curve for parabolic materials (only tensile part is shown)*
- **Is symmetric**: If selected, the stress strain curve will be assumed symmetric around the origin.

- **Can take tension**: If selected, the stress strain curve will resist tensile stresses.

- **Can take compression**: If selected, the stress strain curve will resist compressive stresses.

- **Allow strain values outside the defined curve**: If selected, the material will be assumed to accept unlimited strain values, outside the above stress/strain diagram, without provoking failure. Apparently, the stress values outside the graph will be zero. For instance this option should be used if modeling materials where cracks are allowed, so that the program can allow the development of unlimited strains without a corresponding stress resistance.

![Stress-Strain curve](image)

*Allow strain values outside the defined curve option*

**Stress-Strain curve**
The created stress/strain curve based on the provided data is shown here. The user can take a picture of this curve by clicking this button ![Camera](image) at the upper right corner of this window.

**Add new button**
A new parabolic material can be added by clicking this button.

**Delete**
Current parabolic material can be deleted by clicking this button.

**Convert to editable custom defined material**
By clicking this button, current material will be converted to custom defined material. It can then be found by choosing Materials -> Custom Defined Materials (stress/strain curve), or by clicking the ![Custom](image) toolbar icon on the top of the main window.
Custom Defined Materials (stress/strain curve)

How to open

1. By selecting Materials -> Custom Defined Materials (stress/strain curve) from the main window menu bar

2. By clicking on the corresponding toolbar button of the main window

Description

From this form, the user can specify a totally generic material without any limitation in its stress/strain curve, as the user can provide a number of constant, linear, quadratic or cubic segments that will form the whole material curve.

Available custom defined materials list

This list contains all custom defined materials that have been defined in the project. In order to show, modify or delete one, you should first highlight it.

All available materials list

This list contains all available materials defined in the project, regardless of their type. For example, a linear material will be included here as well.

Material data panel

In this panel, all data regarding the selected custom defined material are shown.

Among the obvious fields (Name, Notes, Color), the following values can be specified:

- **Stress-Strain curve segments**: Contains a list of the stress/strain curve segments.
  - By clicking this icon, a new segment can be added

A segment has one of the following types:

1. **Constant**: A segment of constant stress (for instance rectangular stress block). Only Starting/Ending strain and starting stress values need to be provided.

2. **Linear**: A segment of a linearly varying strain vs. stress curve. Starting/Ending strain and Starting/Ending stress values need to be provided.

3. **Quadratic**: A segment of a quadratically varying strain vs. stress curve. Starting/Ending strain, Starting/Ending stress values as well as the strain/stress values of another point need to be provided.

4. **Cubic**: A segment of a cubically varying strain vs. stress curve. Starting/Ending strain, Starting/Ending stress values as well as the strain/stress values of two other points need to be provided.
- By clicking this icon ✗, current segment is deleted
- Using the icons ▲ and ▼, the selected segment can be moved up or down among the remaining ones

- **Allow strain values outside the defined curve:** If selected, the material will be assumed to accept unlimited strain values, outside the above stress/strain diagram, without provoking failure. Apparently, the stress values outside the graph will be zero. For instance this option should be used if modeling materials where cracks are allowed, so that the program can allow the development of unlimited strains without a corresponding stress resistance.

**Stress-Strain curve**
The created stress/strain curve based on the provided data is shown here. The user can take a picture of this curve by clicking this button at the upper right corner of this window.

**Add new button**
A new custom defined material can be added by clicking this button.

**Delete**
Current custom defined material can be deleted by clicking this button.
Materials library

How to open

1. By selecting Materials -> From Library from the main window menu bar

2. By clicking on the corresponding toolbar button of the main window

Description

A list of predefined materials can be found in this form. It should be noted that the user cannot import concrete or reinforcement materials using this form. Instead, such materials can be used by opening the “Concrete” or “Reinforcement” form and then clicking on the “From library...” button.

Material type

The selected material category is specified here.

Inserting material(s)

Select the material(s) to be inserted from the list (multiple selection with Ctrl or Shift button) and then click the “Insert selected only” button.

Inserting all materials from current list

Just click the “Insert whole material set” button.
Concrete grade library

How to open
By clicking on the “From library...” on the Concrete form.

Description
A list of predefined concrete grades can be found in this form.

Standard
The concrete specification is specified here.

Inserting concrete material(s)
Select the material(s) to be inserted from the list (multiple selection with Ctrl or Shift button) and then click the “Insert selected only” button.

Inserting all concrete materials from current list
Just click the “Insert whole concrete material set” button.
Reinforcement grade library

How to open
By clicking on the “From library…” on the Reinforcement form.

Description
A list of predefined reinforcement grades can be found in this form.

Standard
The reinforcement specification is specified here.

Inserting reinforcement material(s)
Select the material(s) to be inserted from the list (multiple selection with Ctrl or Shift button) and then click the “Insert selected only” button.

Inserting all reinforcement materials from current list
Just click the “Insert whole reinforcement material set” button.
Rectangle (opposite points)

How to open

1. By selecting Draw -> Rectangle (Opposite points) from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing rectangle and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one rectangle object.

Description

A rectangle object by providing two opposite points can be inserted using this form.

First point

The first point for the rectangle definition can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button

2. Or by left mouse clicking on the drawing area

Second point

The second point for the rectangle definition can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button

2. Or by left mouse clicking on the drawing area

After defining the second point, the form is closed and the rectangle appears on the drawing area.

Note: This form is also shown when asking for the properties of an existing rectangle object. In this case, the buttons are not visible and the user can directly modify the coordinates of the points using the keyboard.

Material

The user can here define the material to be assigned to current geometric object.

Hole

If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Rectangle (using dimensions)

How to open

1. By selecting Draw -> Rectangle using dimensions from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing rectangle and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one rectangle object.

Description

A rectangle object by providing its dimensions can be inserted using this form. The form closes as soon as the center point is defined and the “OK” button of the form is clicked. Then, the rectangle appears on the drawing area.

Center point

The center point for the rectangle definition can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button

2. Or by left mouse clicking on the drawing area

Note: This form is also shown when asking for the properties of an existing rectangle object. In this case, the button is not visible and the user can directly modify the coordinates of the center point using the keyboard.

Dimensions

The dimensions of the rectangle shall be inserted in the corresponding fields.

Material

The user can here define the material to be assigned to current geometric object.

Hole

If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Polygon

How to open

1. By selecting Draw -> Polygon from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing polygon and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one polygon object.

Description

A polygon object by providing a sequence of edge points can be inserted using this form.

The form closes as soon as at least 3 points have been defined and the user clicks the “OK” button.

Polygon points

The edge polygon points can be given in two ways:

1. By clicking the button to add a new point and entering its coordinates in the corresponding list

2. Or by left mouse clicking on the drawing area

Note: The user can remove a specific point by selecting it from the list and clicking the button.

Material

The user can here define the material to be assigned to current geometric object.

Hole

If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Polygon from line offset

How to open

1. By selecting Draw -> Polygon from line offset from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing polygon defined similarly and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one polygon (defined from line offset) object.

Description

From this form, the user can indirectly draw a polygon by providing an axis line and an offset distance. The program will then create the corresponding polygon object.

The form closes as soon as at least 2 points have been defined and the user clicks the “OK” button.

Line points

The guide line points for the polygon definitions can be given in two ways:

1. By clicking the button to add a new point and entering its coordinates in the corresponding list

2. Or by left mouse clicking on the drawing area

Note: The user can remove a specific point by selecting it from the list and clicking the button.

Thickness

The thickness (total offset) from the guide line is to be entered here.

Method

The user can specify one out of three methods for the polygon definition, as illustrated below.
Different methods for polygon definition

**Material**
The user can here define the material to be assigned to current geometric object.

**Hole**
If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Inscribed polygon

How to open

1. By selecting Draw -> Inscribed Polygon from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.
3. By right clicking on an existing inscribed polygon and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one inscribed polygon object.

Description

From this form, the user can draw a polygon object by providing a center point and a point on its circumscribed circle.

Center point
The center point for the inscribed polygon definition can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

Point on circumscribed circle

A point on the circumscribed circle shall be provided in the corresponding fields, which be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

After defining the second point, the form is closed and the inscribed polygon appears on the drawing area.

Note: This form is also shown when asking for the properties of an existing inscribed polygon object. In this case, the button is not visible and the user can directly modify the coordinates of the center point using the keyboard.

Number of sides

The number of sides of the inscribed polygon is to be entered here.

Material
The user can here define the material to be assigned to current geometric object.

Hole
If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Circle (2 points)

How to open
1. By selecting Draw -> Circle (2 Points) from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.
3. By right clicking on an existing circle and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one circle object.

Description
A circle object by providing its center point and one point on it can be inserted using this form.

Center point
The center point for the circle definition can be given in two ways:
1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

Point on circle
The point on the circle can be given in two ways:
1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

After defining the second point, the form is closed and the circle appears on the drawing area.

Note: This form is also shown when asking for the properties of an existing circle object. In this case, the buttons are not visible and the user can directly modify the coordinates of the points using the keyboard.

Material
The user can here define the material to be assigned to current geometric object.

Hole
If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Circle (Center and Diameter)

How to open

1. By selecting Draw -> Circle using Center and Diameter from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing circle and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one circle object.

Description

A circle object by providing the center point and its diameter can be inserted using this form. The form closes as soon as the center point is defined and the “OK” button of the form is clicked. Then, the circle appears on the drawing area.

Center point

The center point for the rectangle definition can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button

2. Or by left mouse clicking on the drawing area

Note: This form is also shown when asking for the properties of an existing rectangle object. In this case, the button is not visible and the user can directly modify the coordinates of the center point using the keyboard.

Offset distances

The relative coordinates between the specified center point and the actual center location of the circle can be specified here.

Diameter

The circle diameter shall be inserted in the corresponding field.

Material

The user can here define the material to be assigned to current geometric object.

Hole

If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Arc

How to open

1. By selecting Draw -> Circular Arc from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.
3. By right clicking on an existing arc and then clicking on “Properties” from the dropdown menu or choosing Edit -> Properties after having selected one circular arc object.

Description

A circular arc object by providing its center and the starting/ending points can be inserted using this form.

Direction

The arc direction (Clockwise or Counter clockwise).

Type

The arc object type (Segment or Sector).

Center point

The center point for the arc definition can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

First point

The starting arc point can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

Second point

The ending arc point can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

After defining the second point, the form is closed and the circular arc appears on the drawing area.

Note: This form is also shown when asking for the properties of an existing donut segment object. In this case, the buttons are not visible and the user can directly modify the coordinates of the points using the keyboard. In this case the options “Fixed” may instead appear. When the “Fixed” option is selected, the coordinates of the corresponding point
remain constant no matter what the other points are modified. In case the “Fixed” option is disabled the coordinates of the corresponding points will be automatically calculated so that they lie on a circle circumference.

**Material**
The user can here define the material to be assigned to current geometric object.

**Hole**
If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Donut

How to open

1. By selecting Draw -> Donut from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.
3. By right clicking on an existing donut and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one donut object.

Description

A donut object by providing its center point and two points, on internal and external circle can be inserted using this form.

Center point

The center point for the donut definition can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

First point

A point on internal or external circle can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

Second point

A corresponding point on internal or external circle can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

After defining the second point, the form is closed and the donut appears on the drawing area.

Note: This form is also shown when asking for the properties of an existing donut object. In this case, the buttons are not visible and the user can directly modify the coordinates of the points using the keyboard.

Material

The user can here define the material to be assigned to current geometric object.

Hole

If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Donut segment

How to open

1. By selecting Draw -> Donut Segment from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing donut segment and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one donut segment object.

Description

A donut segment object by providing its center and starting/ending arc points can be inserted using this form.

Direction

The arc direction (Clockwise or Counter clockwise).

Center point

The center point for the donut segment definition can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button

2. Or by left mouse clicking on the drawing area

First point

The starting point on internal or external circle can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button

2. Or by left mouse clicking on the drawing area

Second point

The ending point on internal or external circle can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button

2. Or by left mouse clicking on the drawing area

Third point

A third point for the definition of the thickness can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button

2. Or by left mouse clicking on the drawing area

After defining the third point, the form is closed and the donut segment appears on the drawing area.
Note: This form is also shown when asking for the properties of an existing donut segment object. In this case, the buttons are not visible and the user can directly modify the coordinates of the points using the keyboard. In this case the options “Fixed” may instead appear. When the “Fixed” option is selected, the coordinates of the corresponding point remain constant no matter what the other points are modified. In case the “Fixed” option is disabled the coordinates of the corresponding points will be automatically calculated so that they lie on a circle circumference.

**Material**

The user can here define the material to be assigned to current geometric object.

**Hole**

If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Fillet

How to open

1. By selecting Draw -> Fillet from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.
3. By right clicking on an existing fillet and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one fillet object.

Description

A fillet object by providing its center and another auxiliary point can be inserted using this form.

Direction

The direction along which the fillet is developed (Clockwise or Counter clockwise).

Center point

The center point for the fillet definition can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

Auxiliary point

The auxiliary fillet point can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

After defining the auxiliary point, the form is closed and the fillet appears on the drawing area.

Note: This form is also shown when asking for the properties of an existing fillet object. In this case, the buttons are not visible and the user can directly modify the coordinates of the points using the keyboard.

Material

The user can here define the material to be assigned to current geometric object.

Hole

If checked, the object will be assumed to be a hole. The “Material” list is then disabled.
Standard section

How to open

1. By selecting Draw -> Standard Section from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing standard section and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one standard section object.

Description
Existing predefined standard sections can be inserted using this form.

Sections from library
A predefined section group shall be selected from this list.

Use custom section dimensions
Sections defined by the user will be displayed if this option is selected.

Section type
The type of the section is selected here (I wide flange, Channel, Tee, Angle, Box, Pipe).

Select list
A section from the list can be selected using this control.

Section dimensions
The corresponding dimensions of the selected section are displayed in the related field.

Preview
The chosen section is displayed in this area. The user can click on a characteristic point (for instance Center of Gravity, edge and middle points etc.) of the section that will represent its insertion point.

Place at points
Refers to the point where the aforementioned insertion point will be placed in the main drawing screen.

Material
The user can here define the material to be assigned to current geometric object.
Rebar

How to open

1. By selecting Draw -> Rebar from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing rebar and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one rebar object.

Description

A single rebar by providing its center point can be inserted using this form.

When inserting a reinforcement object, the program automatically asks for a specified cover and corresponding snap points are shown in the drawing area so that the input of reinforcement bars can take place directly, as shown in the following picture.

Additional points to snap as per specified cover value

The form closes as soon as the center point is defined and the “OK” button of the form is clicked. Then, the rebar appears on the drawing area.
Point
The rebar center point can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

Note: This form is also shown when asking for the properties of an existing rebar object. In this case, the button is not visible and the user can directly modify the coordinates of the points using the keyboard.

Offset distances
The relative coordinates between the specified center point and the actual center location of the rebar can be specified here.

Reinforcement
A rebar reinforcement is to be selected here. All defined rebars in project are included in the related list.

Note about Reinforcement Design: Unless the Constant size for design option has been selected, the assigned Rebar sizes (for example Φ16, or #7 etc.) are ignored during Reinforcement Design, since the program calculates in that case the required rebar sizes from the beginning.

Material
The user can here define the reinforcement material to be assigned to current rebar.

Constant size for design
This option affects the Reinforcement Design. If checked, the rebar will remain constant after designing the reinforcement and will not be re-dimensioned.

If unchecked, the rebar is designed and replaced by the optimum rebar size defined in project.

Grow factor
This parameter is usually left to be equal to 1.0. It defines a relative ratio between the areas of all the rebars in project, so that during the design, the rebars will be resized (grow or shrink) as per this ratio. This parameter is used when performing Reinforcement Design.
Rebar line

How to open

1. By selecting Draw -> Rebar Line from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing rebar line and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one rebar line object.

Description

A sequence of collinear rebars can be inserted using this form.

When inserting a reinforcement object, the program automatically asks for a specified cover and corresponding snap points are shown in the drawing area so that the input of reinforcement bars can take place directly, as shown in the following picture.

The form closes as soon as the center point is defined and the “OK” button of the form is clicked. Then, the rebar line appears on the drawing area.
Cross Section Analysis & Design

Start point
The rebar line starting point can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

End point
The rebar line ending point can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

Note: This form is also shown when asking for the properties of an existing rebar line object. In this case, the button is not visible and the user can directly modify the coordinates of the points using the keyboard.

Offset direction
Using the option, the user specifies whether the rebars will be placed above or below the provided axis line.

Offset
An offset distance can be given here. It can be equal to zero.

Method
The user can here specify the total rebar count or a specified intermediate distance between the rebar centers on the line.

s1,s2 distances
Edge distances as per related image.

Reinforcement
A rebar reinforcement is to be selected here. It will be assigned to each rebar belonging to current rebar line. All defined rebars in project are included in the related list.

Note about Reinforcement Design: Unless the Constant size for design option has been selected, the assigned Rebar sizes (for example $16$, or $\#7$ etc.) are ignored during Reinforcement Design, since the program calculates in that case the required rebar sizes from the beginning.

Material
The user can here define the reinforcement material to be assigned to current rebar line.

Constant size for design
This option affects the Reinforcement Design. If checked, the rebars will remain constant after designing the reinforcement and will not be re-dimensioned.

If unchecked, the rebars are designed and replaced by the optimum rebar sizes defined in project.
Grow factor
This parameter is usually left to be equal to 1.0. It defines a relative ratio between the areas of all the rebars in project, so that during the design, the rebars will be resized (grow or shrink) as per this ratio. This parameter is used when performing Reinforcement Design.

Split to single rebars
This option splits the rebars belonging to current rebar line into single rebars that can be modified individually.
Rebar circle

How to open

1. By selecting Draw -> Rebar Circle from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

3. By right clicking on an existing rebar circle and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one rebar circle object.

Description

A sequence of rebars that lie on a provided circle can be inserted using this form.

When inserting a reinforcement object, the program automatically asks for a specified cover and corresponding snap points are shown in the drawing area so that the input of reinforcement bars can take place directly, as shown in the following picture.

Additional points to snap as per specified cover value

The form closes as soon as the center point is defined and the “OK” button of the form is clicked. Then, the rebar circle appears on the drawing area.
Center point
The rebar circle center point can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

Other point
A point on the rebar circle circumference can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

Note: This form is also shown when asking for the properties of an existing rebar circle object. In this case, the button is not visible and the user can directly modify the coordinates of the points using the keyboard.

Offset direction
Using the option, the user specifies whether the rebars will be placed on a circle inside or outside the provided one.

Offset
An offset distance can be given here. It can be equal to zero.

Rebar count
The user can here specify the total rebar count on the rebar circle.

Reinforcement
A rebar reinforcement is to be selected here. It will be assigned to each rebar belonging to current rebar circle. All defined rebars in project are included in the related list.

Note about Reinforcement Design: Unless the Constant size for design option has been selected, the assigned Rebar sizes (for example 16, or #7 etc.) are ignored during Reinforcement Design, since the program calculates in that case the required rebar sizes from the beginning.

Material
The user can here define the reinforcement material to be assigned to current rebar circle.

Constant size for design
This option affects the Reinforcement Design. If checked, the rebars will remain constant after designing the reinforcement and will not be re-dimensioned.

If unchecked, the rebars are designed and replaced by the optimum rebar sizes defined in project.

Grow factor
This parameter is usually left to be equal to 1.0. It defines a relative ratio between the areas of all the rebars in project, so that during the design, the rebars will be resized (grow or shrink) as per this ratio. This parameter is used when performing Reinforcement Design.
**Split to single rebars**

This option splits the rebars belonging to current rebar circle into single rebars that can be modified individually.
Rebar rectangle

How to open

1. By selecting Draw -> Rebar Rectangle from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.
3. By right clicking on an existing rebar rectangle and then clicking on “Properties” from the drop down menu or choosing Edit -> Properties after having selected one rebar rectangle object.

Description

A sequence of rebars that lie on a provided rectangle can be inserted using this form.

*When inserting a reinforcement object, the program automatically asks for a specified cover and corresponding snap points are shown in the drawing area so that the input of reinforcement bars can take place directly, as shown in the following picture.*

Additional points to snap as per specified cover value

The form closes as soon as the center point is defined and the “OK” button of the form is clicked. Then, the rebar rectangle appears on the drawing area.
**First corner**
The first corner of the rebar rectangle can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

**Opposite corner**
The opposite corner of the rebar rectangle can be given in two ways:

1. By entering its coordinates in the corresponding fields and clicking on the button
2. Or by left mouse clicking on the drawing area

*Note: This form is also shown when asking for the properties of an existing rebar rectangle object. In this case, the button is not visible and the user can directly modify the coordinates of the points using the keyboard.*

**Offset direction**
Using the option, the user specifies whether the rebars will be placed on a rectangle inside or outside the provided one.

**Offset**
An offset distance can be given here. It can be equal to zero.

**Rebar count horizontally/vertically**
The user can here specify the rebar count per horizontal/vertical side.

**Corner rebars/Other rebars reinforcement**
A rebar reinforcement is to be selected here for the corner and the remaining rebars. All defined rebars in project are included in the related lists.

*Note about Reinforcement Design: Unless the Constant size for design option has been selected, the assigned Rebar sizes (for example Φ 16, or #7 etc.) are ignored during Reinforcement Design, since the program calculates in that case the required rebar sizes from the beginning.*

**Material**
The user can here define the reinforcement material to be assigned to current rebar rectangle.

**Constant size for design**
This option affects the Reinforcement Design. If checked, the rebars will remain constant after designing the reinforcement and will not be re-dimensionalized.

If unchecked, the rebars are designed and replaced by the optimum rebar sizes defined in project.
Grow factor for corner/other rebars
This parameter is usually left to be equal to 1.0. It defines a relative ratio between the areas of all the rebars in project, so that during the design, the rebars will be resized (grow or shrink) as per this ratio. This parameter is used when performing Reinforcement Design.

Split to single rebars
This option splits the rebars belonging to current rebar rectangle into single rebars that can be modified individually.
Analysis parameters

How to open

1. By selecting Analysis -> Analysis Parameters from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.

Description

Using these form, the user can define or modify the Analysis Parameters set of current project. An Analysis Parameters set contains information regarding partial safety factors, resistance factors, material resistance limitations, as well as the stress/strain curve type for compressive/tensile concrete parts (rectangular, linear, parabolic etc.) and the corresponding parameters regarding the reinforcement steel behavior. Each defined load case (for instance Interaction, Moment/Curvature load case etc.) is assigned with an Analysis Parameters set. In this way, the user can use the same defined geometry and materials, by overriding some of their properties depending on the analysis he is performing. For example, the safety factors for calculations in Serviceability Limit State (SLS) will be equal to 1.0, whereas this will not happen in case of Ultimate Limit State analyses (ULS). Both SLS and ULS Analysis Parameters sets are predefined, but can be modified by the user. Furthermore, additional sets can easily be added.

Reinforced concrete data

This tab contains data related to concrete and reinforcement, as well as confinement options and code specific values, e.g. safety factors etc.

Apply R/C code defaults

Using this button, the default values as per the selected Reinforced Concrete Regulation are applied for the following data only:

- Compressive part curve values (strains, lamda factor etc.)
- Elasticity modulus of reinforcement
- Ultimate reinforcement strain
- Safety factors/Resistance factors

Concrete Data

Stress/strain curve data of concrete

- Compression Part

Represents the stress/strain distribution that will apply to all concrete zones under compression. The option “Default rectangular by code for ULS” uses a rectangular stress block according to the specified regulation and is valid only for Ultimate Limit State Analyses. Therefore, this stress/strain curve type for compression will not be valid for other analysis types, for instance Moment Curvature, Deformed
configuration, Strain plane configuration. On the other hand, in order to comply absolutely with the Reinforced Concrete Regulation that has been chosen, the user can use this option for Advanced Interaction, Reinforced Concrete code based interaction and Reinforcement Design Analyses. The program uses the “Default rectangular by code for ULS” option as default for the predefined ULS Analysis Parameters set.

*Note: If Linear or Bilinear type is selected, the maximum compressive concrete strain is to be given in the corresponding field.*

- **Tension Part**

  The user can choose whether the tensile concrete resistance will be taken in account. This applies to all concrete zones under tension. It is apparent that the tensile resistance will be ignored, especially for Ultimate Limit State analyses, as cracks on the tensile concrete zone appear before reaching the resistance of the section. Thus, tensile resistance should be taken in account only for Serviceability Limit State analyses. Therefore, the program uses this options for the predefined SLS Analysis Parameters set. Of course, the user can modify these options.

  In any case, concrete will be able to accept unlimited tensile strains, regardless the related properties defined by the user.

**Amplification factors due to confinement**

The corresponding values represent factors which apply to the characteristic strain and stress values of the selected stress/strain curve for concrete. These values apply only to concrete materials that have been assigned with the property “Confined”. In case of absence of confined concrete materials, these factors are ignores.

Hence concrete strength for confined concrete materials, will be assumed as follows:

\[
(\text{Final concrete strength}) = (\text{Concrete strength factor}) \times (\text{Specified concrete strength})
\]

These factors apply to strain values accordingly, for instance in case of “Parabolic-Linear” stress/strain curve type for compression, following strain are taken in account:

\[
(\text{final ec2}) = (\text{ec2 factor}) \times (\text{ec2})
\]

\[
(\text{final ecu}) = (\text{ecu factor}) \times (\text{ecu})
\]

The use of these factors, in combination with the great range of the available stress/strain curve types for the compressive concrete zones, guarantees the flexibility of the program regarding the control of confined stress/strain curves, since the user can adjust a concrete curve using amplification factors in order to simulate almost all common confinement models, such as Mander, Hoshikuma, Saatcioglu etc.
**Warning:** Amplification factors are not taken in account if the option “Default rectangular by code for ULS” for the compressive concrete stress/strain relation is chosen.

**Code specific values**

In this panel, the required values related to the specified regulation can be provided, such as safety factors, frame type, design situation etc.

**Warning:** Strength reduction $\varphi$ factors (applicable only for AASHTO, UBC, AS 3600, ACI 318, NZS 3101) are only applied when performing an analysis where the section strength is calculated. Such analysis types are only Interaction, Reinforcement check and Reinforcement design. In all other analysis types, $\varphi$ factors do not apply!

On the other hand, partial resistance factors for materials ($\gamma$ factors) are always applied, regardless the type of analysis!

**Reinforcement Data**

**Stress-strain Curve**

A linear-constant or bilinear with hardening stress strain curve can be specified for the reinforcement bars. The elasticity modulus (E) and the ultimate strain (esu) can be entered in the corresponding fields. Moreover, if bilinear curve type is selected, the factors of the second branch elasticity modulus as well as the ultimate stress are required.

**Ignore compression part**

If this option is selected, the reinforcement bars will only take tensile loads.

**Stress-Strain Limits**

Using these fields, the user can specify compressive or tensile stress/strain limits which will apply for the current Analysis Parameters set.

**Other Materials Data**

This tab contains data related to non-concrete or reinforcement materials (linear, bilinear, trilinear, parabolic or user defined), for example aluminum, timber etc. The user can define a safety factor to be applied to all values of the corresponding stress/strain diagram and provide some advanced parameters for the effective stress/strain curve of each material.

**Material list**

A material from the list on the left should be selected in order to assign the related parameters.

**Safety factor list**

This value represents a partial safety factor that is applied to every stress value of the provided stress/strain curve.

**Use whole stress-strain curve as defined**

If selected, the entire stress/strain curve of the selected material will be used. The safety factor is applied in this case as well. If unselected, the user can specify further advanced parameters regarding current material, as follows.
Advanced parameters

Stop when reaching maximum or minimum material stress

Assuming an arbitrary stress vs. strain material curve, the analysis will stop, when the maximum tensile or compressive stress is reached, at the indicated points in the above picture.

Stop when reaching a tensile stress value

Specified tensile stress value to stop
Stop when reaching a compressive stress value

Stop when reaching a tensile strain value
Stop when reaching a compressive strain value

Specified compressive strain value to stop

Stop when reaching a tensile strain value on a predefined fiber from the maximum tensile strain

Distance from maximum tensile strain

Fiber to check

Strain to check
Stop when reaching a compressive strain value on a predefined fiber from the maximum compressive strain.

Note: All above values are used only in current Analysis Parameters set. So, material definitions are not modified by this form.
Calculation parameters

How to open

1. By selecting Analysis -> Calculation Parameters from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description

From this form, the user can view or modify the Calculation Parameters, which represent characteristic values that are considered in the calculations.

Parameters

Relative target error for neutral axis estimation

 Represents the accuracy regarding force equilibrium between the applied external loads and the calculated internal ones, when estimating the neutral axis. This value is relative to the applied forces magnitude. In brief, the program proceeds to the following assumption:

\[ \Sigma F_{ex} = \sqrt{N_{ex}^2 + M_{y,ex}^2 + M_{z,ex}^2} \]

where \( N_{ex} \), \( M_{y,ex} \), and \( M_{z,ex} \) represent the external applied axial force and bending moments respectively. Correspondingly, the resultant vector of the internally calculated loads is defined as:

\[ \Sigma F_{in} = \sqrt{N_{in}^2 + M_{y,in}^2 + M_{z,in}^2} \]

Equilibrium is achieved when:

\[ \frac{\Sigma F_{ex} - \Sigma F_{in}}{\Sigma F_{ex}} \leq \text{Relative target error} \]

Maximum iterations count for moment curvature analysis

Represents the maximum count of iterations when performing a moment/curvature analysis. Each iteration results to a point on the moment/curvature diagram.

Curvature step

Represents the step of curvature that is applied for the moment/curvature curve calculation. The program automatically modifies this step internally further if needed, in order to achieve convergence.

Axial strain step

Represents the step of axial strain that is applied for the axial force/strain curve calculation and is used similarly to the above mentioned Curvature step.

Loads application/reporting point

Specifies the point of the cross section on which the loads (axial force bending moments) will act. This represents the location where loads are applied as input (e.g. Deformed configuration, reinforcement check/design etc), or reported as output (e.g. Moment curvature analysis, Interaction diagrams etc).
Inertia calculation options

**Use geometric properties**

By selecting this option, the program calculates the inertia data and additional section properties, based only on the geometry and neglecting the possible existence of more than one used materials.

**Base material**

If the “Use geometric properties” option is not selected, the equivalent area method is applied. A single material assigned to a part of the section is selected to be the base material. The base material is usually the most dominant material present within the cross section. The properties of the remaining materials are then adjusted laterally to emulate the base material’s elastic characteristics.

**Analysis parameters to use**

An Analysis Parameters set shall be selected, as this is used for the estimation of the elasticity modulus of the material and the effective yield stress. Both values are needed for the plastic parameters estimation (plastic neutral axis, plastic moduli etc.).

By default, in order to handle all material type including the materials with custom defined stress/strain curves, the program makes following assumptions:

- The elasticity modulus is calculated as the tangent of the stress/strain curve at origin
- The yield stress is assumed to be equal to the ending stress of the first stress/strain curve segment for positive strains

After the selection of an Analysis Parameters set, a stress/strain curve, including all data of safety factors, advanced parameters (defined in Analysis Parameters) etc., is calculated and the estimation of the above values is then possible.

**Interaction (as per R/C code) and Reinforcement check/design parameters**

**Handle reinforcement as points**

If this option is selected, the rebars will be substituted by equal point forces. Handling rebars as single points may slightly reduce calculation time, but may result in instabilities, numerical divergence and wrong results, so it is recommended that this is not changed.

**Utilization limit for design (for Reinforcement check/design only)**

Represents the maximum capacity ratio for designing rebars. If set equal to 1.0, the reinforcement bars will be chosen so that their resistance is used up completely.

**Neutral axis steps for regions 1 to 5 (for Code Based Interaction and Reinforcement design only)**

A value defining the number of different neutral axis locations in the regions shown below:
Possible strain distribution for a specific neutral axis angle

In the above picture, \( esu \) represents the maximum (ultimate) reinforcement strain \((\approx 20\%)\), \( ecu,b \) the ultimate concrete strain for bending, \( ecu,c \) the corresponding concrete strain for pure axial compression and \( ey \) the reinforcement yield strain. These parameters are taken equal to the values proposed by the selected Reinforced Concrete code, but the user can modify them using the Analysis parameters form. If a “Default rectangular by code for ULS” concrete stress/strain part for compression is not specified, the above \( ecu,c \) value is taken equal to the maximum compressive stress that can develop as per the selected stress/strain diagram. Value \( ecu,b \) is apparently taken equal to the maximum compressive strain of the aforementioned curve. In case of Linear or Bilinear concrete compression curve, the \( ecu,c \) value can be provided by assigning a value to the “max axial strain” field (strain for pure axial compression).

Iteration count of neutral axis orientation (for Code Based Interaction and Reinforcement design only)

Represents the number of neutral axis location around the section (Neutral axis angle in the picture above).
Advanced interaction parameters (for Advanced Interaction only)

**Iteration count of neutral axis orientation**

Represents the number of neutral axis location around the section.

**Tensile axial forces count to consider**

Represents the number of tensile axial forces to consider when constructing the interaction diagram for Moment vs. Axial force curves. This is the count of the intermediate points to take in account between the horizontal axis (zero axial force) and the maximum tensile axial force.

**Compressive axial forces count to consider**

Represents the number of compressive axial forces to consider when constructing the interaction diagram for Moment vs. Axial force curves. This is the count of the intermediate points to take in account between the horizontal axis (zero axial force) and the maximum compressive axial force.
Load cases for Moment Curvature

How to open
1. By selecting Analysis -> Moment Curvature -> Load cases from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.

Description
From this form, the user can define the load cases to be considered for the Moment Curvature analysis.

Adding a load case
A new load case can be added by clicking the Add New button.

Deleting a load case
An existing load case can be deleted by clicking the Delete button.

Description of load cases list
Name
A unique name for the selected load case is defined in this cell.

Moment curvature type
A type for the moment curvature analysis is defined, as follows:
- **Axial force**: By selecting this option, a Strain vs. Axial force diagram is requested
- **Moment about y**: A Curvature vs. Moment about Y axis is requested
- **Moment about z**: A Curvature vs. Moment about Z axis is requested

Custom angle
Specifies the angle (in degrees) between the coordinate system where the results are reported and the initial one. This angle is measured counter-clockwise. This value is not taken into account if the Moment curvature type is set to “Axial force”.

Analysis parameters
Using this field, the user can assign the Analysis Parameters set for the current load case.

Warning: In case there are concrete materials in section, the used Analysis Parameters set for the strain plane analysis shall not have a rectangular concrete stress block assigned, since this can only be used for resistance calculations (Interaction diagrams and Reinforcement Check/Design).

Options
Some additional options can be set using the form opened by this button.
Clipboard operations
Selected values from the corresponding load cases list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.

Copied values can be pasted using the button.
Load cases for deformed configuration

How to open

1. By selecting Analysis -> Deformed configuration -> Load cases from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description

From this form, the user can define the load cases to be considered for the Deformed configuration analysis.

Adding a load case

A new load case can be added by clicking the Add New button.

Deleting a load case

An existing load case can be deleted by clicking the Delete button.

Description of load cases list

Name

A unique name for the selected load case is defined in this cell.

Axial force

The acting axial force is specified in the corresponding cell. Positive value means tension.

Moment about y

The bending moment about y axis is specified in the corresponding cell.

Moment about z

The bending moment about z axis is specified in the corresponding cell.

Analysis parameters

Using this field, the user can assign the Analysis Parameters set for the current load case.

Warning: In case there are concrete materials in section, the used Analysis Parameters set for the strain plane analysis shall not have a rectangular concrete stress block assigned, since this can only be used for resistance calculations (Interaction diagrams and Reinforcement Check/Design).

Clipboard operations

Selected values from the corresponding load cases list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.

Copied values can be pasted using the button.
Load cases for strain plane analysis

How to open

1. By selecting Analysis -> Stress state under given strain plane -> Load cases from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description

From this form, the user can define the load cases to be considered for the Strain plane configuration analysis.

Adding a load case

A new load case can be added by clicking the Add New button.

Deleting a load case

An existing load case can be deleted by clicking the Delete button.

Description of load cases list

Name
A unique name for the selected load case is defined in this cell.

e0
The strain at origin is defined in this cell. Positive value means tension.

Curvature
The curvature is defined in this cell.

NA angle
The angle between the neutral axis and the default horizontal axis (y) is specified in the corresponding cell. It is measured in rad counterclockwise.

Analysis parameters
Using this field, the user can assign the Analysis Parameters set for the current load case.

Warning: In case there are concrete materials in section, the used Analysis Parameters set for the strain plane analysis shall not have a rectangular concrete stress block assigned, since this can only be used for resistance calculations (Interaction diagrams and Reinforcement Check/Design).

Clipboard operations
Selected values from the corresponding load cases list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.

Copied values can be pasted using the button.
Load cases for Advanced Interaction or R/C code based Interaction

How to open

For Reinforced Concrete based Interaction interaction

1. By selecting Analysis -> Interaction (as per selected R/C code) -> Load cases from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

For advanced interaction

1. By selecting Analysis -> Interaction (advanced) -> Load cases from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description

From this form, the user can define the load cases to be considered for the Interaction analysis.

Adding a load case

A new load case can be added by clicking the Add New button.

Deleting a load case

An existing load case can be deleted by clicking the Delete button.

Description of load cases list

Name

A unique name for the selected load case is defined in this cell.

Interaction type

A type for the interaction analysis is defined, as follows:

- Moment about y - Moment about z: By selecting this option, an interaction diagram in terms Moment about Y axis vs. Moment about Z axis is requested

- Axial force - Moment about y: An interaction diagram in terms Moment about Y axis vs. Axial force is requested

- Axial force - Moment about z: An interaction diagram in terms Moment about Z axis vs. Axial force is requested

Analysis parameters

Using this field, the user can assign the Analysis Parameters set for the current load case.

Options

Some additional options can be set using the form opened by this button.
Clipboard operations
Selected values from the corresponding load cases list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.

Copied values can be pasted using the button.
Load cases for reinforcement check

How to open

1. By selecting Analysis -> Reinforcement check -> Load cases from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description

From this form, the user can define the load cases to be considered for the Reinforcement Check.

Adding a load case

A new load case can be added by clicking the Add New button.

Deleting a load case

An existing load case can be deleted by clicking the Delete button.

Description of load cases list

Name

A unique name for the selected load case is defined in this cell.

Axial force

The acting axial force is specified in the corresponding cell. Positive value means tension.

Moment about y

The bending moment about y axis is specified in the corresponding cell.

Moment about z

The bending moment about z axis is specified in the corresponding cell.

Analysis parameters

Using this field, the user can assign the Analysis Parameters set for the current load case.

Clipboard operations

Selected values from the corresponding load cases list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.

Copied values can be pasted using the button.
Load cases for reinforcement design

How to open

1. By selecting Analysis -> Reinforcement design -> Load cases from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description
From this form, the user can define the load cases to be considered for the Reinforcement Design.

Adding a load case
A new load case can be added by clicking the Add New button.

Deleting a load case
An existing load case can be deleted by clicking the Delete button.

Description of load cases list
The required reinforcement amount will be estimated considering all defined load cases in the list, so that all requirements according to the specified Reinforced Concrete Regulation are satisfied.

Name
A unique name for the selected load case is defined in this cell.

Axial force
The acting axial force is specified in the corresponding cell. Positive value means tension.

Moment about y
The bending moment about y axis is specified in the corresponding cell.

Moment about z
The bending moment about z axis is specified in the corresponding cell.

Analysis parameters
Using this field, the user can assign the Analysis Parameters set for the current load case.

Clipboard operations
Selected values from the corresponding load cases list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.

Copied values can be pasted using the button.
Options for Moment Curvature

How to open
By clicking on the “Options” button of the corresponding load case in the “Load case for Moment Curvature” form.

Description
From this form, the user can define some optional parameters for the generation of the Moment/Curvature curve.

Variations
The user can here define whether more than one Moment/Curvature diagrams will be produced by varying a parameter, such as Axial force or Reinforcement ratio.

No alteration
Only one Moment/Curvature curve is generated.

Alternate Axial Force
The user can provide a set of axial force values. Each value will correspond to a calculated Moment/Curvature curve.

Alternate Reinforcement Ratio
The user can create a set of reinforcement ratios. Each value will correspond to a calculated Moment/Curvature curve.

Bilinearization of Moment-Curvature curve

Second branch slope
An equivalent bilinear curve for the calculated Moment/Curvature curve(s) is automatically estimated by the program. The user can specify the slope of the second branch. A zero value means that the bilinearized model will be of type elastic-fully plastic without hardening.
Options for Interaction

How to open
By clicking on the “Options” button of the corresponding load case in the “Load cases for Advanced Interaction” or “Load cases for Interaction as per R/C code” form.

Description
From this form, the user can define some optional parameters for the generation of the interaction diagram.

Variations
The user can here define whether more than one Interaction diagrams will be produced by varying a parameter, such as Axial force or Reinforcement ratio.

No alteration
Only one Interaction curve is generated.

Alternate Axial Force
The user can provide a set of axial force values. Each value will correspond to a calculated Interaction diagram.

Alternate Reinforcement Ratio
The user can create a set of reinforcement ratios. Each value will correspond to a calculated Interaction diagram.
Inertia data

How to open

1. By selecting Analysis -> Inertia data -> Show results from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description

In this form, the calculated inertia data are represented.

Graph pane
Apart from the geometry of the section, following data is also illustrated.

Centroid coordinate system
It is indicated with a "C" character.

Principal coordinate system
It results from a counter-clockwise rotation of the centroid system, so that the inertia product values are zero. Its axes are indicated by a ' character, for example y', z' etc.

Inertia ellipse
An ellipse on the principal coordinate system is illustrated, with an axes ratio equal to the ratio of the inertia moments about them.

List of section properties
In this list, all calculated section properties are shown.

Clipboard operations
Selected values from the corresponding list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.
Moment curvature results

How to open
1. By selecting Analysis -> Moment Curvature -> Show results from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.

Description
In this form, the results of Moment/Curvature analysis are represented.

Load case
The load case about which the results are reported.

Current point
The coordinates of current mouse position on the corresponding diagram.

Selected curve data
If axial force or reinforcement ratios alternations are specified in the “Options for Moment Curvature” form, the user can here define the color for each sub-curve.

Export current graph data
The points of current curve can be exported to a text file by clicking this button.

Show strain/stress distribution for current point
If clicked, the strain distribution and the corresponding stress contour for current point on diagram appears.

Show equivalent bilinearized curve
If selected, an equivalent bilinear model for current curve is shown for the tensile and compressive part of it. Moreover, the yield/ultimate curvature/strain values are reported in the corresponding controls.
Deformed configuration results

How to open
1. By selecting Analysis -> Deformed configuration -> Show results from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.

Description
In this form, the deformed configuration analysis results are represented.

Load case
The load case about which the results are reported.

Neutral axis location and deformed configuration
In this graph pane, the neutral axis and the strain distribution are shown. Furthermore, the equivalent force couple and the related lever arm distances are represented.

Stress distribution
The stresses on the section are represented using color contours. By moving the mouse cursor, detailed information about the strain and stress values of current point are reported.

Neutral axis information
In this list, the neutral axis data (strain at origin, curvature and neutral axis angle in degrees) are shown. Moreover, the values of the equivalent force couple and the corresponding lever arm distances are reported.

Material stress information
Maximum/minimum stress values and the respective locations are reported in the corresponding list for the specified material.

Analysis info
Reports whether the cross section is adequate for the applied loads of the selected load case.

Warning: Since this analysis does not calculate section resistances, some code limitations may not be checked, such as neutral axis depth limitations etc. Likewise, strength reduction factors are apparently not applied. So, if the user checks the capacity of the section, an interaction analysis (Moment vs. Moment) for the axial force value is recommended.

Clipboard operations
Selected values from the corresponding list can be copied to clipboard using the button. The button copies all values of the load cases list to clipboard.
Strain plane analysis results

How to open

1. By selecting Analysis -> Stress state under given strain plane -> Show results from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description

In this form, the results of the strain plane configuration analysis are represented.

Load case
The load case about which the results are reported.

Neutral axis location and deformed configuration
In this graph pane, the neutral axis and the strain distribution are shown. Furthermore, the equivalent force couple and the related lever arm distances are represented.

Stress distribution
The stresses on the section are represented using color contours. By moving the mouse cursor, detailed information about the strain and stress values of current point are reported.

Neutral axis information
In this list, the neutral axis data (strain at origin, curvature and neutral axis angle in degrees) are shown. Moreover, the values of the equivalent force couple and the corresponding lever arm distances are reported.

Material stress information
Maximum/minimum stress values and the respective locations are reported in the corresponding list for the specified material.

Analysis info
Reports whether the cross section is adequate for the applied loads of the selected load case.

Warning: Since this analysis does not calculate section resistances, some code limitations may not be checked, such as neutral axis depth limitations etc. Likewise, strength reduction factors are apparently not applied. So, if the user checks the capacity of the section, an interaction analysis (Moment vs. Moment) for the axial force value is recommended.

Clipboard operations

Selected values from the corresponding list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.
Interaction results (advanced)

How to open

1. By selecting Analysis -> Interaction (advanced) -> Show results from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description

In this form, the results of the advanced interaction analysis are represented.

Case of Interaction types Moment vs. Axial force:

In the program itself an interaction diagram is produced from the section forces for a series of limit states. For each point of the diagram the cross section has to be integrated once. For non-symmetric sections, if a diagram Moment about Y vs. Axial Force is requested, there may result a moment about Z axis which is not zero. This is not shown in the diagram. The presented My - N interaction curve, however, represents a correct plot in the three-dimensional My - Mz - N diagram. It is strongly recommended that the user performs a Moment vs. Moment Interaction analysis for each axial force values in order to be able to check properly the cross section, without the aforementioned problems regarding non-symmetric sections.

Load case

The load case about which the results are reported.

Current point

The coordinates of current mouse position on the corresponding diagram.

Selected curve data

If axial force or reinforcement ratios alternations are specified in the “Options for Moment Curvature” form, the user can here define the color for each sub-curve.

Export current graph data

The points of current curve can be exported to a text file by clicking this button.
Interaction results (as per selected R/C code)

How to open
1. By selecting Analysis -> Interaction (as per selected R/C code) -> Show results from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.

Description
In this form, the results of the interaction analysis as per specified Reinforced Concrete code are represented.

Case of Interaction types Moment vs. Axial force:
In the program itself an interaction diagram is produced from the section forces for a series of limit states. For each point of the diagram the cross section has to be integrated once. For non-symmetric sections, if a diagram Moment about Y vs. Axial Force is requested, there may result a moment about Z axis which is not zero. This is not shown in the diagram. The presented N-My interaction curve, however, represents a correct plot in the three-dimensional N-My-Mz diagram. It is strongly recommended that the user performs a Moment vs. Moment Interaction analysis for each axial force values in order to be able to check properly the cross section, without the aforementioned problems regarding non-symmetric sections.

Load case
The load case about which the results are reported.

Current point
The coordinates of current mouse position on the corresponding diagram.

Selected curve data
If axial force or reinforcement ratios alternations are specified in the “Options for Moment Curvature” form, the user can here define the color for each sub-curve.

Export current graph data
The points of current curve can be exported to a text file by clicking this button.
Reinforcement check results

How to open

1. By selecting Analysis -> Reinforcement check -> Show results from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description
In this form, the reinforcement check results as per the specified Reinforced Concrete code are represented.

Reinforcement ratio placed
The calculated reinforcement ratio which is already placed in the section.

Minimum ratio
The minimum reinforcement ratio values, specified as per the selected Reinforced Concrete code.

Note: The user can override this value in the “Reinforced Concrete Regulation” form.

Maximum ratio
The maximum reinforcement ratio values, specified as per the selected Reinforced Concrete code.

Note: The user can override this value in the “Reinforced Concrete Regulation” form.

Summary
In the corresponding list, the calculated x/d ratio (compression zone to section depth) and the capacity ratio of each defined load case are reported. A ratio less or equal than the value “Utilization limit for design” specified in the “Calculation parameters” form is assumed acceptable.

Clipboard operations
Selected values from the corresponding list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.
Reinforcement design results

How to open

1. By selecting Analysis -> Reinforcement design -> Show results from the main window menu bar.

2. By clicking on the corresponding toolbar button of the main window.

Description
In this form, the reinforcement design results as per the specified Reinforced Concrete code are represented.

Design info
Informs whether the cross section is adequate as per the specified Reinforced Concrete code.

Minimum ratio
The minimum reinforcement ratio values, specified as per the selected Reinforced Concrete code.

Note: The user can override this value in the “Reinforced Concrete Regulation” form.

Maximum ratio
The maximum reinforcement ratio values, specified as per the selected Reinforced Concrete code.

Note: The user can override this value in the “Reinforced Concrete Regulation” form.

Summary
In the corresponding list, the calculated x/d ratio (compression zone to section depth) and the reinforcement ratio of each defined load case are reported. Likewise, the placed reinforcement ratio is shown. Both values are close but not same, since the program chooses the best rebar sizes from the available ones in order to resist the specified load cases and satisfy all relevant code checks.

Results for load case
Comprehensive results regarding the selected load case are reported in this panel.

Needed ratio
Reinforcement ratio demand to resist applied loads.

Needed ratio considering minimum reinforcement
Reinforcement ratio demand considering the minimum reinforcement ratio value.

Provided ratio
Reinforcement ratio placed by the program after choosing the best rebars.
Reinforcement details
A list which contains the reinforcement area demand for each rebar location, the placed rebar property and the placed corresponding area.

*Note:* Placed reinforcement bars are chosen from the rebar list defined in project, under the Project -> Available Rebars menu.

**Clipboard operations**
Selected values from the corresponding list can be copied to clipboard using the button.

The button copies all values of the load cases list to clipboard.
Report settings

How to open

1. By selecting Analysis -> Calculation report from the main window menu bar.
2. By clicking on the corresponding toolbar button of the main window.

Description

In this form, the user can define the data which will be represented in the calculation report.

*Items to include in calculation report*

All relative project items can be selected to be included in the report.

The report will only contain items that have already been used in the project. Thus, materials that have not been assigned to geometric objects will not be included.

*Note: When Reinforced Concrete code is set to None, the items “Reinforced Concrete code” and “Available rebars” will be disabled.*

Results

The user can select which of the available results will be included in the calculation report. It is evident that the corresponding analysis should have been carried out first, so that the associated results are available.

Moreover, if multiple load cases have been defined, the user can choose whether all or some of them will be included in the report by clicking on the “Select” button.
CALCULATION REFERENCE

General

Cross Section Analysis & Design uses optimized numerical and analytical mathematical models to simulate the behavior of an arbitrary, general cross section under biaxial bending and concurrently acting normal (axial) force. It is worth mentioning that no limitations regarding the number of materials and the form of their stress/strain curve apply. Cross Section Analysis & Design utilizes a combination of state-of-the-art scientific knowledge in the field of structural analysis, numerical methods, parallel processing etc. Due to the aforementioned, the user can enjoy a robust, fast, general and productive all-in-one software application which can be used in a great range of engineering practice, from the simplest to the most complex task regarding the analysis and design of a cross section.

The geometry of the cross section is described by multi-nested polygons with straight or curved edges, which can be convex or concave or may contain openings. The analytical integration of the stress field together with the non-linear optimization methods implemented in its algorithm, make Cross Section Analysis & Design fast and reliable. Among other remaining advantages, the user can note the following in comparison to the existing tools on the market.

Almost all algorithms use a strict form of stress-strain law for materials. Cross Section Analysis & Design utilizes all ordinary stress/strain curve patterns of materials (linear, bilinear, trilinear, parabolic etc.). Furthermore, all common curves for concrete and reinforcement materials are used (Rectangular stress distribution, parabolic etc.).

Almost all similar applications are applicable to polygonal cross sections with straight edges. Cross Section Analysis & Design has extended functionality validated by relative research work, so that it can handle circles and circular arcs without adopting simplified assumptions. Consequently, the geometry, regardless of its shape (straight or circular) is modeled in exact correspondence with the real geometry. For example rebars are not substituted by point forces, but are handled as circular polygons. In this case, the moment/curvature diagrams are reliable and the reinforcement design converges for any complex shaped cross section geometry without the necessity of manipulations.

Last but not least, Cross Section Analysis & Design uses a semi-numerical and analytical method in order to get the advantages of both techniques and dramatically improve the convergence and speed of all implemented methods, without the need of any external adjustment by the user.
Calculation of elasticity modulus of concrete

By default, the program calculates the elasticity modulus of concrete according to the specified Reinforced Concrete Regulation, as follows:

**Eurocode 2 2004**

\[ E_{cm} = 22 \left( \frac{f_{cm}}{10} \right)^{0.3}, \text{where } f_{cm} \text{ in MPa, } E_{cm} \text{ in GPa} \]

where

\[ f_{cm} = f_{ck} + 8, \text{ where } f_{ck} \text{ and } f_{ca} \text{ in MPa} \]

Note: If current concrete material is not selected to be confined, value \( f_{ck} \) is equal to the strength stress value provided in the “Concrete” form.

In case of confined concrete, the concrete strength factor defined in the corresponding Analysis Parameters set is taken in account for the calculation of the elasticity modulus, e.g.:

\[ f_{ck} = \left( \text{concrete strength factor} \right) \times \left( \text{Strength stress defined in Concrete form} \right) \]

In all cases, if elasticity modulus is directly provided by the user, the program respects this value regardless of the confinement option.

**AASHTO LRFD 2012, UBC 97, ACI 318 11**

\[ E_c = 57000 \sqrt{f_c'} \text{, where } f_c', \text{ and } E_c \text{ in psi} \]

Note: If current concrete material is not selected to be confined, value \( f_c' \) is equal to the strength stress value provided in the “Concrete” form.

In case of confined concrete, the concrete strength factor defined in the corresponding Analysis Parameters set is taken in account for the calculation of the elasticity modulus, e.g.:

\[ f_c' = \left( \text{concrete strength factor} \right) \times \left( \text{Strength stress defined in Concrete form} \right) \]

In all cases, if elasticity modulus is directly provided by the user, the program respects this value regardless of the confinement option.

**CSA A233 04**

\[ E_c = \left( 3300 \sqrt{f_c'} + 6900 \right) \left( \frac{\gamma_c}{2300} \right)^{1.5}, \text{ where } \gamma_c = 2400 \text{ kg/m}^3 \text{ and } f_c', E_c \text{ in MPa} \]

Note: If current concrete material is not selected to be confined, value \( f_c' \) is equal to the strength stress value provided in the “Concrete” form.

In case of confined concrete, the concrete strength factor defined in the corresponding Analysis Parameters set is taken in account for the calculation of the elasticity modulus, e.g.:
\[ f'_c = (\text{concrete strength factor}) \times (\text{Strength stress defined in Concrete form}) \]

In all cases, if elasticity modulus is directly provided by the user, the program respects this value regardless of the confinement option.

**AS 3600 01**

\[ E_c = \rho^{1.5} \times \left(0.043\sqrt{f_{cm}}\right), \text{ where } \rho = 2400 \text{ kg/m}^3 \text{ and } f_{cm}, E_c \text{ in MPa} \]

The stress \( f_{cm} \) is calculated as follows:

\[ f_{cm} = 1.085 f_c + 2.5, \text{ fcm and f} \text{c in Mpa} \]

Note: If current concrete material is not selected to be confined, value \( f_c \) is equal to the strength stress value provided in the “Concrete” form.

In case of confined concrete, the concrete strength factor defined in the corresponding Analysis Parameters set is taken in account for the calculation of the elasticity modulus, e.g.:  

\[ f_c = (\text{concrete strength factor}) \times (\text{Strength stress defined in Concrete form}) \]

In all cases, if elasticity modulus is directly provided by the user, the program respects this value regardless of the confinement option.

**NZS 3101 95**

\[ E_c = \left(3320 + 6900 \left( \frac{f_c}{2300} \right)^{1.5} \right), \text{ where } \gamma_c = 2400 \text{ kg/m}^3 \text{ and } f'_c, E_c \text{ in MPa} \]

Note: If current concrete material is not selected to be confined, value \( f'_c \) is equal to the strength stress value provided in the “Concrete” form.

In case of confined concrete, the concrete strength factor defined in the corresponding Analysis Parameters set is taken in account for the calculation of the elasticity modulus, e.g.:

\[ f'_c = (\text{concrete strength factor}) \times (\text{Strength stress defined in Concrete form}) \]

In all cases, if elasticity modulus is directly provided by the user, the program respects this value regardless of the confinement option.

**BS 8110 97 and CP 65 1999**

\[ E_c = 5.5 \frac{f_{cm}}{\gamma_m}, f_{cm} \text{ in MPa, } E_c \text{ in Gpa} \]

The safety factor \( \gamma_m \) is taken equal to the “gama c” value defined in the corresponding Analysis Parameters set.
Note: If current concrete material is not selected to be confined, value $f_{cu}$ is equal to the strength stress value provided in the “Concrete” form.

In case of confined concrete, the concrete strength factor defined in the corresponding Analysis Parameters set is taken in account for the calculation of the elasticity modulus, e.g.:

$$f_{cu} = \left(\text{concrete strength factor}\right) \times \left(\text{Strength stress defined in Concrete form}\right)$$

In all cases, if elasticity modulus is directly provided by the user, the program respects this value regardless of the confinement option.

**IS 456 2000**

$$E_c = 5000 \sqrt{f_{ck}} \text{, } f_{ck}, E_c \text{ in MPa}$$

Note: If current concrete material is not selected to be confined, value $f_{ck}$ is equal to the strength stress value provided in the “Concrete” form.

In case of confined concrete, the concrete strength factor defined in the corresponding Analysis Parameters set is taken in account for the calculation of the elasticity modulus, e.g.:

$$f_{ck} = \left(\text{concrete strength factor}\right) \times \left(\text{Strength stress defined in Concrete form}\right)$$

In all cases, if elasticity modulus is directly provided by the user, the program respects this value regardless of the confinement option.
Rectangular stress distribution for concrete under compression in Ultimate Limit State

If the user selects the option “Default rectangular by code for ULS” in the Analysis Parameters form, regarding the concrete compression part, the program automatically calculates and uses the equivalent rectangular stress distribution as per the specified Reinforced Concrete Code in a way that is demonstrated in the following pages.

Consequently, the concrete stress/strain curve will have the following form:

Values $\varepsilon_1$, $\varepsilon_u$, and $\sigma_c$ are defined according to the specified regulation.

Eurocode 2 2004

Value $f_{ck}$ represents the characteristic compressive strength of concrete, as defined in the corresponding Concrete form. In the following, $f_{ck}$ will be assumed to have MPa units.
First of all, factor \( n \) is defined:

\[
n = 1.0, \text{ for } f_{\text{ck}} \leq 50 \text{ MPa}
\]

and

\[
n = 1.0 - \frac{f_{\text{ck}} - 50}{200}, \text{ for } 50 \leq f_{\text{ck}} \leq 90 \text{ MPa}
\]

Then, factor \( \lambda \) is defined as follows:

\[
\lambda = 0.8, \text{ for } f_{\text{ck}} \leq 50 \text{ MPa}
\]

and

\[
\lambda = 0.8 - \frac{f_{\text{ck}} - 50}{400}, \text{ for } 50 \leq f_{\text{ck}} \leq 90 \text{ MPa}
\]

The compressive design strength of concrete is:

\[
f_{\text{cd}} = \alpha_{cc} \frac{f_{\text{ck}}}{\gamma_c},
\]

where \( \alpha_{cc} \) is the coefficient taking account of long term effects on the compressive strength and of unfavorable effects resulting from the way the load is applied and \( \gamma_c \) is the partial safety factor for concrete. Both values can be modified from the corresponding Analysis parameters set.

Finally, the stress value for the rectangular distribution, \( \sigma_c \) is defined as:

\[
\sigma_c = nf_{\text{cd}}
\]

The strain values of the rectangular distribution are:

\[
\epsilon_i = (1 - \lambda) \epsilon_{cu}
\]

\[
\epsilon_u = \epsilon_{cu} = 3.5\%
\]

**AASHTO LRFD 2012, UBC 97, ACI 318 11**

Value \( f_{\text{c}'} \) represents the characteristic compressive strength of concrete, as defined in the corresponding Concrete form. In the following, \( f_{\text{c}'} \) will be assumed to have ksi units.

First of all, factor \( \beta_i \) is defined:

\[
\beta_i = 0.85 - 0.05 \left( f_{\text{c}'} - 4 \right), \text{ if } 0.65 \leq \beta_i \leq 0.85
\]

The stress value for the rectangular distribution, \( \sigma_c \) is defined as:

\[
\sigma_c = 0.85 f_{\text{c}'}
\]
The strain values of the rectangular distribution are:

\[ e_1 = (1 - \beta_1) e_{cu} \]
\[ e_u = e_{cu} = 3\%_0 \]

**CSA A233 04**

Value \( f'_c \) represents the characteristic compressive strength of concrete, as defined in the corresponding Concrete form. In the following, \( f'_c \) will be assumed to have MPa units.

First of all, factor \( \alpha_1 \) is defined:

\[ \alpha_1 = 0.85 - 0.0015 f'_c, \quad \alpha_1 \geq 0.67 \]

Likewise, factor \( \beta_1 \) is defined:

\[ \beta_1 = 0.97 - 0.0025 f'_c, \quad \beta_1 \geq 0.67 \]

The stress value for the rectangular distribution, \( \sigma_c \) is defined as:

\[ \sigma_c = \alpha_1 f'_c \]

The strain values of the rectangular distribution are:

\[ e_1 = (1 - \beta_1) e_{cu} \]
\[ e_u = e_{cu} = 3\%_0 \]

**AS 3600 01**

Value \( f'_c \) represents the characteristic compressive strength of concrete, as defined in the corresponding Concrete form. In the following, \( f'_c \) will be assumed to have MPa units.

First of all, factor \( \gamma \) is defined:

\[ \gamma = 0.85 - 0.007 (f'_c - 28), \quad 0.65 \leq \gamma \leq 0.85 \]

The stress value for the rectangular distribution, \( \sigma_c \) is defined as:

\[ \sigma_c = 0.85 f'_c \]

The strain values of the rectangular distribution are:

\[ e_1 = (1 - \gamma) e_{cu} \]
\[ e_u = e_{cu} = 3\%_0 \]
NZS 3101 95

Value $f'_c$ represents the characteristic compressive strength of concrete, as defined in the corresponding Concrete form. In the following, $f'_c$ will be assumed to have MPa units.

First of all, factor $\alpha_1$ is defined:

$$\alpha_1 = 0.85 - 0.004 \left( f'_c - 55 \right), \quad 0.75 \leq \alpha_1 \leq 0.85$$

Likewise, factor $\beta_1$ is defined:

$$\beta_1 = 0.85 - 0.008 \left( f'_c - 30 \right), \quad 0.65 \leq \beta_1 \leq 0.85$$

The stress value for the rectangular distribution, $\sigma_c$, is defined as:

$$\sigma_c = \alpha_1 f'_c$$

The strain values of the rectangular distribution are:

$$\varepsilon_1 = (1 - \beta_1) \varepsilon_{cu}$$

$$\varepsilon_u = \varepsilon_{cu} = 3\%$$

BS 8110 97 and CP 65 1999

Value $f_{cu}$ represents the characteristic cubic compressive strength of concrete, as defined in the corresponding Concrete form. In the following, $f'_c$ will be assumed to have MPa units.

By default, the height of the rectangular stress block is taken as:

$$\alpha = 0.90x, \quad \text{where } x \text{ the neutral axis depth}$$

The stress value for the rectangular distribution, $\sigma_c$, is defined as:

$$\sigma_c = 0.67\frac{f_{cu}}{\gamma_c}$$

where $\gamma_c$ is the partial safety factor for concrete. It can be modified from the corresponding Analysis parameters set.

The strain values of the rectangular distribution are:

$$\varepsilon_1 = 0.1\varepsilon_{cu}$$

$$\varepsilon_u = \varepsilon_{cu} = 3.5\%$$

IS 456 2000

Value $f_{cu}$ represents the characteristic cubic compressive strength of concrete, as defined in the corresponding Concrete form. In the following, $f'_c$ will be assumed to have MPa units.
First of all, factor $\beta_1$ is defined:

$$\beta_1 = 0.84$$

By default, the height of the rectangular stress block is taken as:

$$\alpha = \beta_1 x_u$$

where $x_u$ the neutral axis depth

The stress value for the rectangular distribution, $\sigma_c$ is defined as:

$$\sigma_c = 0.67 \frac{f_{ck}}{\gamma_c}$$

where $\gamma_c$ is a partial safety factor for concrete. It can be modified from the corresponding Analysis parameters set.

The strain values of the rectangular distribution are:

$$\varepsilon_1 = (1 - \beta_1) \varepsilon_{cu}$$

$$\varepsilon_u = \varepsilon_{cu} = 3.5\%$$
Calculation of strength reduction factors $\phi$ (only applicable for AASHTO, UBC, AS 3600, ACI 318, NZS 3101 codes)

Strength reduction $\phi$ factors (applicable only for AASHTO, UBC, AS 3600, ACI 318, NZS 3101) are applied only when performing an analysis where the section strength is calculated. Such analysis types are only Interaction, Reinforcement check and Reinforcement design. In all other analysis types, $\phi$ factors do not apply!

*On the other hand, partial resistance factors for materials ($\gamma$ factors) are always applied, regardless the type of analysis!*

The calculation of the $\phi$ factors is represented for each code below.

**AASHTO LRFD 2012**

The value of $\phi$ used in the interaction diagram varies from compression controlled $\phi$ to tension controlled $\phi$ based on the maximum tensile strain in the reinforcing at the extreme edge $\varepsilon_t$.

Sections are considered compression controlled when the tensile strain in the extreme tension steel is equal to or less than the compression controlled strain limit at the time the concrete in compression reaches its assumed strain limit of $\varepsilon_{c,max}$, which is 3\\%o. The compression controlled strain limit is the tensile strain in the reinforcement at balanced strain conditions, which is taken as the yield strain of the steel reinforcing, $f_y/E$.

Sections are tension controlled when the tensile strain in the extreme tension steel is equal to or greater than 5\\%o, just as the concrete in compression reaches its assumed strain limit of 3\\%o.

Sections with $\varepsilon_t$ between the two limits are considered to be in a transient region between compression controlled and tension controlled sections.

When the section is tension controlled, a $\phi$ factor for tension control is used. When the section is compression controlled, a $\phi$ factor for compression control is used. When the section is within the transition region, $\phi$ is linearly interpolated between the two values, as follows:

\[
\phi = \begin{cases} 
\phi_t, & \varepsilon_t \leq \varepsilon_y \\
\phi_t - (\phi_t - \phi_c) \left( \frac{5\%o - \varepsilon_t}{5\%o - \varepsilon_y} \right), & \varepsilon_y \leq \varepsilon_t \leq 5\%o, \\
\phi_c, & \varepsilon_t \geq 5\%o 
\end{cases}
\]

where $\phi_t = 0.90$ (tension controlled sections)

$\phi_c = 0.75$, spirals or ties in Seismic Zone 1 or in any Zone for non-seismic load combinations

$0.70$, spiral or ties in Seismic Zones 2, 3, or 4 for seismic load combinations
ACI 318 11

The value of $\phi$ used in the interaction diagram varies from compression controlled $\phi$ to tension controlled $\phi$ based on the maximum tensile strain in the reinforcing at the extreme edge $\varepsilon_t$.

Sections are considered compression controlled when the tensile strain in the extreme tension steel is equal to or less than the compression controlled strain limit at the time the concrete in compression reaches its assumed strain limit of $\varepsilon_{c,\text{max}}$, which is 3%. The compression controlled strain limit is the tensile strain in the reinforcement at balanced strain conditions, which is taken as the yield strain of the steel reinforcing, $f_y/E$.

Sections are tension controlled when the tensile strain in the extreme tension steel is equal to or greater than 5%, just as the concrete in compression reaches its assumed strain limit of 3%.

Sections with $\varepsilon_t$ between the two limits are considered to be in a transient region between compression controlled and tension controlled sections.

When the section is tension controlled, a $\phi$ factor for tension control is used. When the section is compression controlled, a $\phi$ factor for compression control is used. When the section is within the transition region, $\phi$ is linearly interpolated between the two values, as follows:

$$
\phi = \begin{cases} 
\phi_c, & \varepsilon_t \leq \varepsilon_y, \\
\phi_t - (\phi_t - \phi_c) \left( \frac{5\%_0 - \varepsilon_t}{5\%_0 - \varepsilon_y} \right), & \varepsilon_y \leq \varepsilon_t \leq 5\%_0, \\
\phi_t, & \varepsilon_t \geq 5\%_0
\end{cases}
$$

where $\phi_t = 0.90$ (tension controlled sections)

$\phi_c = 0.75$, spirals or ties in Seismic Zone 1 or in any Zone for non-seismic load combinations

0.65, spiral or ties in Seismic Zones 2, 3, or 4 for seismic load combinations

UBC 97

The strength reduction factors $\phi$ are as follows:

$$
\phi = \begin{cases} 
0.90, & \text{for flexure} \\
0.90, & \text{for axial tension} \\
0.90, & \text{for axial tension and flexure} \\
0.75, & \text{for axial compression and axial compression and flexure (spirals)} \\
0.70, & \text{for axial compression and axial compression and flexure (ties)}
\end{cases}
$$
CSA A233 04

There are two types of strength resistance factors:

- Material dependent factors:
  \[ \phi_c = 0.65, \quad \text{for concrete} \]
  \[ \phi_s = 0.85, \quad \text{for steel} \]

- Member resistance factor \( \phi_m \), which is taken equal to 0.75

Note: Factors \( \phi_c \) and \( \phi_s \) are handled as partial safety factors for the material resistances. Therefore, they are applied when performing all types of analysis, such as moment/curvature, deformed state, interaction, reinforcement design etc.

On the other hand, \( \phi_m \) is handled as a resistance factor and it is applied additionally to the above, only when section strength is calculated. Such analysis types are only Interaction, Reinforcement check and Reinforcement design.

AS 3600 01

The strength reduction factor \( \phi \) is defined as follows:

<table>
<thead>
<tr>
<th>Type of action effect</th>
<th>( \phi ) factor</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Axial force without bending</td>
<td></td>
</tr>
<tr>
<td>Tension</td>
<td>0.8</td>
</tr>
<tr>
<td>Compression</td>
<td>0.6</td>
</tr>
<tr>
<td>2. Bending without axial tension or compression</td>
<td></td>
</tr>
<tr>
<td>( k_u \leq 0.4 )</td>
<td>0.8</td>
</tr>
<tr>
<td>( k_u &gt; 0.4 )</td>
<td>0.8 ( M_{ud}/M_{uo} \geq 0.6 )</td>
</tr>
<tr>
<td>3. Bending with axial tension</td>
<td></td>
</tr>
<tr>
<td>( N_u \geq N_{ub} )</td>
<td>( \phi' + (0.8 - \phi)(N_u/N_{uot}) ), ( \phi ) from case 2</td>
</tr>
<tr>
<td>( N_u &lt; N_{ub} )</td>
<td>0.6</td>
</tr>
<tr>
<td>4. Bending with axial compression</td>
<td></td>
</tr>
<tr>
<td>( N_u \geq N_{ub} )</td>
<td>0.6</td>
</tr>
<tr>
<td>( N_u &lt; N_{ub} )</td>
<td>0.6 + (( \phi - 0.6 )) (1 - ( N_u/N_{ub} )), ( \phi ) from case 2</td>
</tr>
</tbody>
</table>

NZS 3101 95

The strength reduction factor \( \phi \) is defined as follows:

\[ \phi = 0.85, \quad \text{for bending} \]
\[ \phi = 0.85, \quad \text{for compression} \]
Maximum allowable compressive axial load for reinforced concrete cross sections

The compressive axial load carried by a reinforced concrete section is limited according to the specified Reinforced Concrete code, as described in the following pages.

Note: The following analysis types are affected by this limitation:

- Interaction analysis as per selected Reinforced Concrete code
- Reinforcement check
- Reinforcement design

Such limitations apply only to AASHTO, UBC, ACI 318, CSA A233, AS 3600, NZS 3101 and IS 456 standards.

AASHTO LRFD 2012, UBC 97, ACI 318 11

The maximum compressive axial load is limited to $\phi P_{n(\text{max})}$, where:

$$\phi P_{n(\text{max})} = \begin{cases} 0.85 \phi \left[ 0.85 f_r \left( A_g - A_{st} \right) + f_y A_{st} \right], & \text{spiral} \\ 0.80 \phi \left[ 0.85 f_r \left( A_g - A_{st} \right) + f_y A_{st} \right], & \text{tied} \end{cases}$$

In calculating $\phi P_{n(\text{max})}$, the $\phi$ factor for compression control case is used.

CSA A233 04

The maximum compressive axial load is limited to $P_{r,\text{max}}$, where:

$$P_{r,\text{max}} = \begin{cases} 0.85 \phi \left[ \alpha f_r \left( A_g - A_{st} \right) + f_y A_{st} \right], & \text{spiral} \\ 0.80 \phi \left[ \alpha f_r \left( A_g - A_{st} \right) + f_y A_{st} \right], & \text{tied} \end{cases}$$

AS 3600 01

The maximum compressive axial load is limited to $N_{u0}$, where:

$$N_{u0} = \phi \left[ 0.85 f_r \left( A_g - A_{st} \right) + f_y A_{st} \right]$$

In calculating $N_{u0}$, the $\phi$ factor for axial compression without bending case is used.

NZS 3101 95

The maximum compressive axial load is limited to $N_{\text{max}}$, where:

$$N_{\text{max}} = \begin{cases} 0.85 \phi \left[ \alpha f_r \left( A_g - A_{st} \right) + f_y A_{st} \right], & \text{Ordinary, Elastic} \\ 0.70 \phi \left[ \alpha f_r \left( A_g - A_{st} \right) + f_y A_{st} \right], & \text{Ductile, Limited} \end{cases}$$
The maximum compressive axial load is limited to $P_u$, where:

$$P_u = \begin{cases} 0.4 f_{ck} A_c + 0.67 f_s A_{sc}, & \text{tied} \\ 1.05 \left[ 0.4 f_{ck} A_c + 0.67 f_s A_{sc} \right], & \text{spiral} \end{cases}$$
Reinforcement ratio limits ($\rho_{\text{min}}, \rho_{\text{max}}$)

When performing a Reinforcement Design analysis, the program selects the best reinforcement ratio so that the external loads can be carried and concurrently the code provisions are satisfied. The selected ratio can only be between the predefined by the code limits. The user can modify these limits from the “Reinforced Concrete Regulation” form though.

Minimum and maximum reinforcement ratio limits are defined for each regulation below:

**Eurocode 2 2004**
- Minimum reinforcement ratio: 0.2 %
- Maximum reinforcement ratio: 4.0 %

**AASHTO LRFD 2012**
- **Seismic Zone 1 or in any Zone for non-seismic load combinations**
  - Minimum reinforcement ratio: $0.135 \frac{f_c'}{f_y}$
  - Maximum reinforcement ratio: 8.0 %
- **Seismic Zones 2, 3, or 4 for seismic load combinations**
  - Minimum reinforcement ratio: 1.0 %
  - Maximum reinforcement ratio: 6.0 %

**UBC 97, ACI 318 11, AS 3600 01**
- **Ordinary or Intermediate frame type**
  - Minimum reinforcement ratio: 1.0 %
  - Maximum reinforcement ratio: 8.0 %
- **Special frame type**
  - Minimum reinforcement ratio: 1.0 %
  - Maximum reinforcement ratio: 6.0 %

**CSA A233 04**
- **Conventional or Moderately Ductile frame type**
  - Minimum reinforcement ratio: 1.0 %
Maximum reinforcement ratio: 8.0 %

**Ductile frame type**

Minimum reinforcement ratio: 1.0 %
Maximum reinforcement ratio: 6.0 %

**NZS 3101 95**

Ordinary, Elastic frame type

Minimum reinforcement ratio: 0.8%
Maximum reinforcement ratio: 8.0 %

Ductile limited frame type

Minimum reinforcement ratio: 0.8 %
Maximum reinforcement ratio: $18 / f_y$ (MPa)

*In case of more than one defined steel grades, the ratio $18 / f_y$ is taken as the smallest possible value.*

**BS 8110 97 and CP 65 1999**

Minimum reinforcement ratio: 0.4%
Maximum reinforcement ratio: 6.0 %

**IS 456 2000**

Minimum reinforcement ratio: 0.8%
Maximum reinforcement ratio: 6.0 %
Material resistance limits

Material resistance limitations are checked as per the specified Reinforced Concrete code, when performing one of the following analysis types:

- Interaction as per specified Reinforced Concrete code
- Reinforcement check
- Reinforcement design

The program performs the following checks before the analysis and notifies the user if needed. The material resistance limits are summarized below.

**Eurocode 2 2004**

\[ f_c \leq 90 \text{ MPa} \]

\[ 400 \text{ MPa} \leq f_y \leq 600 \text{ MPa} \]

**AASHTO LRFD 2012**

\[ f_c \leq 10 \text{ ksi} \]

\[ f_y \leq 75 \text{ ksi} \]

**UBC 97**

\[ f_y \leq 80 \text{ ksi} \]

**ACI 318 11**

\[ f_c \geq 2.5 \text{ ksi} \]

\[ f_y \leq 80 \text{ ksi} \]

**AS 3600 01**

\[ 20 \text{ MPa} \leq f_c \leq 65 \text{ MPa} \]

**CSA A233 04**

\[ f_c \geq 20 \text{ MPa} \]

\[ 80 \text{ MPa} \leq f_y \leq 500 \text{ MPa} \]

**NZS 3101 95**

\[ f_y \leq 500 \text{ MPa} \]

**BS 8110 97**

\[ 25 \text{ MPa} \leq f_c \leq 60 \text{ MPa}, \text{ where } f_c \text{ the cubic concrete strength} \]
CP 65 1999

30 MPa ≤ f_c ≤ 60 MPa, where $f_c$ the cubic concrete strength

IS 456 2000

$f_c$ ≤ 55 MPa, where $f_c$ the cubic concrete strength
Interaction as per specified Reinforced Concrete Regulation

The interaction surface calculation procedure which is described below, considers all checks related to the selected Reinforced Concrete code. Furthermore, the corresponding strength reduction factors (applicable only for AASHTO, UBC, AS 3600, ACI 318, NZS 3101) or the material partial safety factors are applied in these calculations, according to the Analysis Parameters. Lastly, the maximum compressive load of the section is limited to its maximum value defined by the code (applicable only for AASHTO, UBC, ACI 318, CSA A233, AS 3600, NZS 3101 and IS 456). The following steps are performed when an “Interaction as per selected Reinforced Concrete code” analysis is executed.

Case of Moment vs. Axial force

In such cases, a full 3D interaction diagram is first calculated and then projected on the plane Moment vs. Axial force.
Warning: In the program itself an interaction diagram is produced from the ultimate section forces for a series of limit states. For each point of the diagram, the cross section has to be integrated once. For non-symmetric sections, if a diagram Moment about Y vs. Axial Force is requested, a moment about Z axis which is not zero may result. This is not shown in the diagram. The presented My - N interaction curve, however, represents a correct plot in the three-dimensional My - Mz - N diagram. It is strongly recommended that the user performs a Moment vs. Moment Interaction analysis for each axial force values in order to be able to check properly the cross section, without the aforementioned problems regarding non-symmetric sections.

Creation of 3D Interaction diagram
The interaction surface is created as the neutral axis angle is rotated around the section. The total number of rotations is specified by the “Iteration count of neutral axis orientation” (Interaction as per R/C code and Reinforcement check/design parameters) field in the “Calculation parameters” form.

For a specific neutral axis angle, the strain distribution is changed in order to cover all regions 1 to 5, as showed below. Each single strain distribution will result in a point on the 3D interaction surface.
In the picture above, esu represents the maximum (ultimate) reinforcement strain (≈20%), ecu,b the ultimate concrete strain for bending and ecu,c the corresponding concrete strain for pure axial compression. These parameters are taken equal to the values proposed by the selected Reinforced Concrete code, but the user can modify them from the Analysis parameters form. If not a “Default rectangular by code for ULS” concrete stress/strain part for compression is specified, above ecu,c value is taken equal to the maximum compressive stress that can develop as per the selected stress/strain diagram. Value ecu,b is apparently taken equal to the maximum compressive strain of the aforementioned curve. In case of Linear or Bilinear concrete compression curve, the value ecu,c can be provided by assigning a value to the “max axial strain” field (strain for pure axial compression).

After the completion of the rotation of the neutral axis around the section for a total of 360°, the full 3D interaction diagram will be available.

**Case of Moment vs. Moment (Axial force is constant)**

![Moment vs. Moment interaction diagram](image)

In such cases there is no need to calculate the full 3D Interaction diagram. Instead, the program executes the following steps.

1. The program rotates the neutral axis around the cross section. The total number of rotations is specified by the “Iteration count of neutral axis orientation” (Interaction as per R/C code and Reinforcement check/design parameters) field in the “Calculation parameters” form.

2. For a specific neutral axis angle, the program estimates the strain distribution, so that the equilibrium condition for the axial force (external axial force is given) is satisfied.
Specific neutral axis angle and calculated strain distribution so that axial force equilibrium is satisfied

For this configuration, a couple of Moments (about Y and Z axis) can easily be found. This represents a point on the Moment vs. Moment interaction diagram.

3. After the completion of the rotation of the neutral axis around the section for a total of 360°, the full Moment vs. Moment interaction surface will be available.
The program creates a full 3D interaction surface according to the specified Reinforced Concrete code and the remaining data defined in the corresponding Analysis Parameters set.

The interaction surface is created as the neutral axis angle is rotated around the section. The total number of rotations is specified by the “Iteration count of neutral axis orientation” (Interaction as per R/C code and Reinforcement check/design parameters) field in the “Calculation parameters” form.

For a specific neutral axis angle, the strain distribution is changed in order to cover all regions 1 to 5, as following picture shows. Each single strain distribution will result in a point on the 3D interaction surface.

![Strain distribution for a specific neutral axis angle](image)

In the picture above, esu represents the maximum (ultimate) reinforcement strain (=20‰), ecu,b the ultimate concrete strain for bending, ecu,c the corresponding concrete strain for pure axial compression and ey the reinforcement yield strain. These parameters are taken equal to the values proposed by the selected Reinforced Concrete code, but the user can modify them from the Analysis parameters form. If a “Default rectangular by code for ULS” concrete stress/strain part for compression is not specified, the before mentioned ecu,c value is taken equal to the maximum compressive stress that can develop as per the...
selected stress/strain diagram. Value $\varepsilon_{cu,b}$ is apparently taken equal to the maximum compressive strain of the aforementioned curve. In case of Linear or Bilinear concrete compression curve, the value $\varepsilon_{cu,c}$ can be provided by assigning a value to the “max axial strain” field (strain for pure axial compression).

After the completion of the rotation of the neutral axis around the section for a total of $360^\circ$, the full 3D interaction diagram will be available.

**Advanced Note:** The related strain distribution is applied between the extreme locations of concrete materials. This means that $\varepsilon_{cu,b}$ strain of region 4, will be assumed at the most top concrete element. If other, non-concrete materials are located above this location, they will be assigned by the equivalent strain distribution, as a linear strain distribution is adopted. If these materials fail (according to the criteria specified in the Analysis Parameters set), their contribution to the global section resistance is ignored. In any other cases, they are considered normally, as per their stress/strain curves.
Reinforcement Design

When a Reinforcement Design procedure takes place, the program carries out the following steps.

1. The minimum and maximum reinforcement ratios are calculated according to the selected Reinforced Concrete code.

2. The 3D interaction surface is calculated for different values of the reinforcement ratio.

3. The procedure stops when all load vectors $N$, $M_y$, $M_z$ are located inside the interaction surface and the maximum corresponding capacity ratio does not exceed the Utilization Limit value specified in the Calculation Parameters form. Depending on the estimated reinforcement ratio, the following cases can be distinguished:
   
   a. Reinforcement ratio is less than the minimum required by the code: In this case, the design is adequate and the minimum reinforcement is placed, no matter what a smaller value is required.

   b. Reinforcement ratio is larger than the maximum defined by code: In this case, the design is inadequate. The user shall either change the rebar locations, or the section dimensions etc.

   c. If the required reinforcement ratio is between the minimum and maximum required by code, the design is adequate.

Transformation of reinforcement ratio to rebar areas

It is clear from the above that the program internally calculates the rebar areas for each reinforcement ratio that is chosen during the design procedure, until the best ratio has been estimated.

For a given reinforcement ratio value (Reinforcement Steel Area/Concrete Area), the corresponding rebars are calculated as follows:

The parameters that are taken in account to transform a reinforcement ratio to rebar areas are the following:

- **Grow factor**: Represents the relative ratios between the rebars, so that they are resized accordingly.

- **Constant size for design**: If selected, the corresponding rebars will remain constant and will not be affected by the design.
Example of “Grow factor” assignment

In the example above, the rebar areas $A_{s1}$, $A_{s2}$, $A_{s3}$ will not change, as they will keep their initial rebar assignment. On the other hand, rebars $A_{s4}$, $A_{s5}$, $A_{s6}$, $A_{s7}$ will grow with a factor 1.0 and the remaining $A_{s8}$, $A_{s9}$, $A_{s10}$ with a factor 2.0.

This means that:

- Rebars $A_{s1}$, $A_{s2}$, $A_{s3}$ will keep their assignments, for example, they will have the rebar that has been set when they were defined (for example $\Phi 16$, or #7 etc.)

- Rebars $A_{s4}$, $A_{s5}$, $A_{s6}$, $A_{s7}$ will always have the same area: $A_{s4} = A_{s5} = A_{s6} = A_{s7}$. The same applies for rebars $A_{s8}$, $A_{s9}$, $A_{s10}$ ($A_{s8} = A_{s9} = A_{s10}$)

- The ratio between the rebar areas 8, 9, 10 to 4, 5, 6, 7 will always be equal to the ratio of their grow factors. This means that: $A_{s8} / A_{s4} = 2.0/1.0 = 2 -\rightarrow A_{s8} = 2A_{s4}$ etc.

Note: Unless the Constant size for design option has been selected, the Rebar sizes (for example $\Phi 16$, or #7 etc.) that have been assigned when rebars were defined, are now ignored, since the program calculates the required rebar sizes from the beginning.
Advanced Interaction

The following steps are performed when an “Advanced Interaction” analysis is executed.

*This analysis type is regardless of the specified Reinforced Concrete regulation. Apart from partial safety factors for materials, strength reduction factors $\phi$ are not applied! The materials used in the section can be of any type, as the maximum response of the cross section against biaxial loads is computed. This type of analysis is suitable for generic cross sections that consist of arbitrary materials, such as composite sections with encased steel members, masonry sections etc.*

Case of Moment vs. Axial force

In such cases, a full 3D interaction diagram is first calculated and then projected on a plane Moment vs. Axial force.
Warning: In the program itself an interaction diagram is produced from the ultimate section forces for a series of limit states. For each point of the diagram, the cross section has to be integrated once. For non-symmetric sections, if a diagram Moment about $Y$ vs. Axial Force is requested, a moment about $Z$ axis which is not zero may result. This is not shown in the diagram. The presented $M_y - N$ interaction curve, however, represents a correct plot in the three-dimensional $M_y - M_z - N$ diagram. It is strongly recommended that the user performs a Moment vs. Moment Interaction analysis for each axial force values in order to be able to check properly the cross section, without the aforementioned problems regarding non-symmetric sections.
**Creation of 3D Interaction diagram**

*Full interaction surface (only one quadrant is shown)*

First of all the maximum tensile and compressive loads, $N_t$ and $N_c$ respectively, are calculated.

Afterwards, the neutral axis is rotated around so that the interaction diagram can be formed. The total number of rotations is specified by the “Iteration count of neutral axis orientation” (Advanced interaction parameters) field in the “Calculation parameters” form.

**For a specific neutral axis angle:**

The program iterates through the possible axial forces. For tensile forces, it iterates through the range between 0 and $N_t$. Likewise, the program iterates through the range between 0 and $N_c$ in order to consider compressive axial forces.

The number of iterations is controlled by the fields “Tensile axial forces count to consider” and “Compressive axial forces count to consider” in the Calculation parameters form.

**For a specific axial force:**

Since neutral axis angle and axial forces are known values, the program can estimate a strain distribution, so that the resulting bending moment gets a maximum value.
The problem can be summarized as follows:

Considering axial force equilibrium and given a neutral axis angle, find a strain distribution that result in the maximum Moment value.

The task above can be carried out efficiently by non-linear optimization methods which are implemented by the program.

After iterating through all possible axial forces and for each neutral axis angle, a full 3D interaction diagram is formed.
Case of Moment vs. Moment (Axial force is constant)

The aforementioned procedure is followed accordingly. The 3D full interaction method is simplified as the axial force is now fixed. Thus, after the rotation of the neutral axis around the section and the estimation of the respective strain distributions, a 2D interaction diagram in Moment vs. Moment terms is formed.