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User manual 

GENERAL 

 

2D Frame Analysis 

Structural analysis of beams, trusses and frames under static, 

dynamic, linear and non-linear loads 

 

 

 

Thank you for using ENGISSOL® products. We can assure you that you will be provided with 

a robust, powerful and reliable application of high standards and guaranteed accurate 

results, regarding the analysis of any kind of 2D structures (generic trusses, frames, beams 

etc.). Engissol’s know-how with respect to engineering application development is 

incomparable, a fact that is proven by thousands of satisfied end-users around the world. 
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2D Frame Analysis™ performs structural analysis on beams, trusses, frames under static, 

dynamic, linear and non-linear loads. It uses the powerful and well-known analysis core 

“ENGISSOL – FEM Library” which has received many awards because of its flexibility in 

handling large-scale linear and non-linear arithmetic problems. Among the program’s 

capabilities are the calculation and illustration of internal forces diagrams, the deformed 

shape, the dynamic modes and the comprehensive representation of the results on an 

automatically created report. 

2D Frame Analysis™ covers efficiently the design engineer's everyday needs due to its 

simplicity and the wide range of supported cases. Besides, it has been tested thoroughly to 

meet specific standards and is considered to be the best tool for the analysis of beam, frame 

and trusses on the market. 

At ENGISSOL we are always looking for feedback on how to improve our products. You can 

contact us at engissol@engissol.com. 

mailto:engissol@engissol.com
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DISCLAIMER 
IMPORTANT- READ CAREFULLY: This ENGINEERING SOFTWARE SOLUTIONS ("ENGISSOL") 

End-User License Agreement ("EULA") is a legal agreement between you, user of software 

applications, ("End User") and ENGISSOL for all ENGISSOL products, source code (where 

provided), demos, printed materials, and "online" or electronic documentation ("SOFTWARE 

PRODUCT(S) "). 

ENGISSOL grants to you a nonexclusive license to use the SOFTWARE PRODUCT(S) for the 

sole purposes of engineering and design calculations. By using the SOFTWARE PRODUCT(S), 

you agree to be bound by the terms of this EULA. If you do not agree to any part of the 

terms of this EULA, DO NOT USE, EVALUATE, OR REPLICATE IN ANY MANNER, ANY PART, FILE 

OR PORTION OF THE SOFTWARE PRODUCT(S).  

All SOFTWARE PRODUCT(S) is licensed, not sold. By purchasing any of the SOFTWARE 

PRODUCT(S), you instantly acquire a license for the SOFTWARE PRODUCT(S) from ENGISSOL. 

The licenses do not expire unless explicitly stated otherwise. Each license of any SOFTWARE 

PRODUCT(S) can only be used on a single computer. 

If the SOFTWARE PRODUCT(S) you have obtained is marked as a "DEMO" you may use one 

copy of the SOFTWARE PRODUCT(S) for testing purposes ("Evaluation Period"). DURING THE 

EVALUATION PERIOD YOU ARE NOT ENTITLED TO USE THE DEMO FOR COMMERCIAL 

PURPOSES. 

ENFORCEMENT OF INTELLECTUAL PROPERTY RIGHTS. If the licensed right of use for this 

SOFTWARE PRODUCT(S) is purchased by you with any intent to reverse engineer, decompile, 

create derivative works, and the exploitation or unauthorized transfer of, any ENGISSOL 

intellectual property and trade secrets, to include any exposed methods or source code 

where provided, no licensed right of use shall exist, and any PRODUCT(s) created as a result 

shall be judged illegal by definition of all applicable law. Any sale or resale of intellectual 

property or created derivatives so obtained will be prosecuted to the fullest extent of all 

local, European and international law. 

All ENGISSOL files remain ENGISSOL's exclusive property and YOU MAY NOT DISTRIBUTE ANY 

OF THEM. 

1. GRANT OF LICENSE 

This EULA, if legally executed as defined herein, licenses and so grants the single End User 

the following rights: 

2. LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY 

You may not reverse engineer, decompile, create derivative works, translate, or disassemble 

the SOFTWARE PRODUCT(S), and only to the extent that such activity is expressly permitted 

by applicable law notwithstanding this limitation. You agree to take all reasonable, legal and 

appropriate measures to prohibit the illegal dissemination of the SOFTWARE PRODUCT(S) or 

any of its constituent parts. 
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3. RENTAL 

You may not rent, lease, or lend the SOFTWARE PRODUCT(S). 

6. UPDATES 

You must be properly licensed to use the SOFTWARE PRODUCT(S) identified by ENGISSOL as 

being eligible for the update in order to use the SOFTWARE PRODUCT(S). An update of 

SOFTWARE PRODUCT(S) replaces the SOFTWARE PRODUCT(S) that formed the basis for your 

eligibility for the update, and together constitutes a single PRODUCT(S). You may use the 

resulting updated PRODUCT(S) only in accordance with all the terms of this EULA. 

If the SOFTWARE PRODUCT(S) contains new critical features and therefore constitutes a 

major update, additional costs may apply in relevance and in proportion to the new 

features. 

Any supplemental SOFTWARE PRODUCT(S) provided to you as part of the Support Services 

shall be considered part of the SOFTWARE PRODUCT(S) and subject to the terms and 

conditions of this EULA. 

8. COPYRIGHT 

All title and copyrights in and to the SOFTWARE PRODUCT(S) (including but not limited to 

any copy written documentation, demos, incorporated into any copies of the SOFTWARE 

PRODUCT(S)) are owned by ENGISSOL. The SOFTWARE PRODUCT(S) is protected by 

copyright laws and international treaty provisions and therefore, you must treat the 

SOFTWARE PRODUCT(S) like any other copyrighted material except that you may install the 

SOFTWARE PRODUCT(S) as described in this EULA. 

9. DISCLAIMER OF WARRANTY 

ENGISSOL expressly disclaims any warranty for the SOFTWARE PRODUCT(S). THE SOFTWARE 

PRODUCT(S) AND ANY RELATED DOCUMENTATION IS PROVIDED "AS IS" WITHOUT 

WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, 

THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR 

NONINFRINGEMENT. 

10. LIMITATIONS ON LIABILITY 

To the maximum extent permitted by applicable law, in no event shall ENGISSOL be liable for 

any special, incidental, indirect, or consequential damages whatsoever (including, without 

limitation, damages for loss of business profits, business interruption, loss of business 

information, or any other pecuniary loss) arising out of the use of or inability to use the 

SOFTWARE PRODUCT(S) or the provision of or failure to provide Support Services, even if 

ENGISSOL has been advised of the possibility of such damages. 

End User understands that the SOFTWARE PRODUCT(S) may produce inaccurate results 

because of a failure or fault by End User to properly use and or deploy the SOFTWARE 

PRODUCT(S). End User assumes full and sole responsibility for any use of the SOFTWARE 
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PRODUCT(S), and bears the entire risk for failures or faults within the SOFTWARE 

PRODUCT(S). You agree that regardless the cause of failure or fault or the form of any claim, 

YOUR REMEDY AND ENGISSOL'S OBLIGATION SHALL BE GOVERNED BY THIS AGREEMENT 

AND THAT IS THE FAULT’S RESOLUTION. IN CASE OF INEFFECTIVENESS OF THE ABOVE 

ACTION ENGISSOL'S LIABILITY SHALL IN NO EVENT EXCEED THE PRICE PAID TO ENGISSOL FOR 

THE SOFTWARE PRODUCT(S). This Limited Warranty is void if failure of the SOFTWARE 

PRODUCT(S) has resulted from accident, abuse, alteration, unauthorized use or 

misapplication of the SOFTWARE PRODUCT(S). 

11. TERMINATION 

Without prejudice to any other rights or remedies, ENGISSOL will terminate this EULA upon 

your failure to comply with all the terms and conditions of this EULA. In such events, you 

must destroy all copies of the SOFTWARE PRODUCT(S) and all of its parts including any 

related documentation, and must remove ANY and ALL use of such technology immediately 

from any applications using technology contained in the SOFTWARE PRODUCT(S) developed 

by you, whether in native, altered or compiled state. 

12. MISCELLANEOUS 

This EULA may only be modified in writing signed by an authorized officer of ENGISSOL. If 

any provision of this EULA is found void or unenforceable, the remainder will remain valid 

and enforceable according to its terms. 

ENGISSOL reserves all rights not specifically granted in this EULA. 

End User acknowledges that he or she has read this Agreement, understands it, and agrees 

to be bound by its terms and conditions. 

Should you have any questions concerning this EULA, or if you desire to contact ENGISSOL 

for any reason, please contact us at engissol@engissol.com. 

 

http://www.engissol.com/contact-us.html
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SYSTEM REQUIREMENTS 
2D Frame Analysis ® is a 32- and 64-bit compatible application. 

Your computer shall meet these minimum requirements so that 2D Frame Analysis can run 

properly. 

 

Processor 

Minimum 400 MHz 

RAM 

Minimum 96 MB 

Disk space (minimum) 

32-bit 280 MB 

64-bit 610 MB 

Operating system 

Windows 10 (all versions) x86 and x64 

Windows 7 (all versions) x86 and x64 

Windows Vista (all versions) x86 and x64 

Windows XP (all versions) x86 and x64 

Windows Millennium Edition 

Microsoft Windows 98 Second Edition 

Microsoft Windows 98 
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PROGRAM FEATURES 
2D Frame Analysis is a powerful application that can perform a wide range of calculations on 

2D structures (beams, trusses, frames etc.). The structure can be drawn directly using the 

versatile featured user interface. The user can also import standard steel sections from a 

complete shape library according to all major codes (AISC, Australian-New Zealand, BS, 

Chinese, European, Indian, Aluminum etc.) There are no limitations regarding the geometry 

of the structure, materials or loads, since the program can handle any arbitrary 2D structure 

under static, dynamic, linear and non-linear loads. Among its capabilities, 2D Frame Analysis 

can calculate and graphically illustrate deformations, internal forces, dynamic modes and 

other analysis results. A large material library is also available according to almost all 

concrete, steel, timber, aluminum etc. material specifications. Apart from these, the user 

can define custom material and cross section data for use in the structure that is modelled. 

The program features can be found below comprehensively: 

Analysis 

 Use of highly flexible, general, finite element method 

 Parallel processing algorithms for optimal analysis performance 

 All boundary supports (roller, hinge, fixed etc.) 

 Spring supports (translational and rotational) 

 All types of member end-releases, including internal partial spring stiffness for semi-

rigid end releases 

 Timoshenko elements for the consideration of shear deformations 

 End length offsets for the simulation of member connections 

 Linear static analysis of all types of structures (trusses, beams, frames, etc.) 

 Incremental non-linear static analysis (second order effects) of all types of structures 

(trusses, beams, frames, etc.) with many stiffness matrix update options 

 Modal analysis for the estimation of dynamic modes, periods, frequencies, etc. 

considering the mass source (loads, self-mass etc.) specified by the user 

 Both lumped and consistent mass matrix 

 Time History analysis of all types of structures (trusses, beams, frames, etc.) 

 Response Spectrum analysis of all types of structures (trusses, beams, frames, etc.) 

 Unlimited count of load cases 

 Unlimited count of load combinations using many combination options (Add, 

Envelope, Absolute, SRSS) 

Pre-processing 

 All major systems of units are supported (Metric, US, User defined) 

 Top quality graphics rendering 

 Full GUI including zoom, pan, grid, snap options 

 Every user action can be done graphically at real time 

 Library with all major steel section shapes 
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 Library with all major concrete and reinforcement grades, as well as other materials 

such as cold formed/hot rolled steel etc. 

 Definition of custom materials and cross sections 

 Application of nodal loads 

 Application of element loads 

 Unlimited span loads 

 Uniform and trapezoidal loads 

 Thermal loads 

 Local, Global and Projected global coordinate systems for the application of loads 

Post-processing 

 Comprehensive and versatile reporting of the results 

 Automatic creation of high-quality, editable calculation report that can be exported 

to Word (doc), Excel (xls) and Adobe PDF (pdf) formats. 

 Graphical representation of the support reactions 

 Graphical representation of the deformed shape of the structure 

 Creation of fully customizable graphs of internal forces (Axial force, Shear force, 

Bending moment) for each load case and load combination 

 Graphical representation of the dynamic modes of the structure 

 Representation of the results in tabular form that is exportable to Excel 
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EDITIONS COMPARISON 
2D Frame Analysis ships in 3 different editions, the Truss Edition, the Static Edition and the 

Dynamic Edition. The features of the editions are represented below. 

Feature 
Truss 

Edition 
Static 

Edition 
Dynamic 
Edition 

Use of optimized frame finite elements ✔ ✔ ✔ 

Parallel processing algorithms for optimal analysis performance ✔ ✔ ✔ 

All boundary supports available (roller, hinge, fixed, etc.) ✔ ✔ ✔ 

Spring supports ✔ ✔ ✔ 

End releases including partial spring stiffness ✔ ✔ ✔ 

Both Timoshenko elements (for shear deformation effects) and 
classical Euler-Bernoulli elements 

✔ ✔ ✔ 

End length offsets for the simulation of member connections ✔ ✔ ✔ 

Linear static analysis ✔ ✔ ✔ 

Incremental non-linear static analysis (second order effects) of all 
types of structures (trusses, beams, frames, etc.) with many 
stiffness matrix update options 

✔ ✔ ✔ 

Modal analysis for the estimation of dynamic modes, periods, 
frequencies, etc. considering the mass source (loads, self-mass 
etc.) specified by the user 

  ✔ 

Both lumped and consistent mass matrix   ✔ 

Time History analysis   ✔ 

Response Spectrum analysis   ✔ 

Unlimited count of load cases ✔ ✔ ✔ 

Unlimited count of load combinations using many combination 
options (Add, Envelope, Absolute, SRSS) 

✔ ✔ ✔ 

All major systems of units are supported (Metric, US, User 
defined) 

✔ ✔ ✔ 

Top quality graphics rendering ✔ ✔ ✔ 

Full GUI including zoom, pan, grid, snap options ✔ ✔ ✔ 

Library with all major steel section shapes ✔ ✔ ✔ 

Library with all major concrete and reinforcement grades, as well 
as other materials such as cold formed/hot rolled steel etc. 

✔ ✔ ✔ 
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Definition of custom materials and cross sections ✔ ✔ ✔ 

Application of nodal loads ✔ ✔ ✔ 

Application of element loads ✔ ✔ ✔ 

Unlimited span loads ✔ ✔ ✔ 

Uniform and trapezoidal loads ✔ ✔ ✔ 

Thermal loads ✔ ✔ ✔ 

Local, Global and Projected global coordinate systems for the 
application of loads 

✔ ✔ ✔ 

Automatic creation of high-quality, editable calculation report 
that can be exported to Word (doc), Excel (xls) and Adobe PDF 
(pdf) formats. 

✔ ✔ ✔ 

Graphical representation of support reactions, deformed shape, 
axial force, shear force and bending moment diagrams 

✔ ✔ ✔ 

Graphical representation of the dynamic modes of the structure ✔ ✔ ✔ 

Representation of the results in tabular form that is exportable to 
Excel 

✔ ✔ ✔ 

Only pinned connection supported ✔   
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MAIN SCREEN LAYOUT 
The main screen layout 2D Frame Analysis is illustrated below. 
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MAIN MENU DESCRIPTION 

File Menu 

New  

Creates a new empty file. 

New from template 

Creates a new file from the available templates 

New from existing 

Creates a new file adopting all properties, except geometry, of another specified file. 

Open  

Opens a file from disk. 

Open sample project 

Shows a dialog with all sample projects that can be opened. 

Import Text file 

Imports a text file. 

Save  

“Save” will save the current file under the same name in the same location. It saves the 

changes over the original file that has been opened. 

Save As 

“Save As” will always bring up a window allowing the user to change the file name and its 

location in disk. Assuming you make a change to name or location, the original file will still 

be intact in its original location after the “Save As”. 

Export to Text file 

Exports the model to a text file. Results are not exported. 

Capture picture  

The user can take a picture of what is on the drawing screen by selecting this command 

under the File. A dialog will open where the user can specify the location and format (jpg, 

bmp, gif) of the image. 

Recent projects 



2D FRAME ANALYSIS 
Structural analysis of beams, trusses and frames under static, dynamic, linear and non-linear loads 

R         17 | P a g e  

All recent projects that have been opened or saved lately will appear here. They can be 

directly opened by clicking on them without using the “Open” command. 

Exit 

Closes the application and asks for saving in case of unsaved data in current file. 
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Edit Menu 

Edit -> Select submenu 

All 

Selects all elements and nodes. 

By Material 

Selects the elements that have been assigned with the specified material. 

By Cross Section 

Selects the elements that have been assigned with the specified cross section. 

All Dimension Lines 

Selects all existing dimension lines. 

All Labels 

Selects all existing dimension labels. 

Boxed selection  

The user can draw a rectangular window using two points. If the window is defined 

rightwards (from left to right), all objects which lie entirely within it, will be selected. If a 

window is defined leftwards (from right to left), only objects which lie entirely within the 

window or cross the window border, are selected. 

Clear selection  

Deselects all objects. This action can be invoked with the Esc button as well. 

Delete  

Deletes all selected objects. 

Change Dimension Line Location  

Changes the offset of a dimension line (straight or radial). The user shall first click on this 

command and afterwards click on a dimension line in order to modify its offset. 

Modify label Text  

Changes the text of a label. The user shall first click on this command and afterwards click on 

a label in order to modify its text. 
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Modify Location of text label  

Changes the location of the text of a label. The user shall first click on this command and 

afterwards click on a label in order to modify its text location. 

Modify Arrow location of label  

Changes the location of the arrow of a label. The user shall first click on this command and 

afterwards click on a label in order to modify its arrow location. 

Undo  

This command allows the user to undo a number of recent actions in a file. 

Redo  

This command allows the user to redo a number of recent actions in a file, which have been 

undone previously. 
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View Menu 

Pan  

Panning allows you to quickly move around the drawing area at the same magnification you 

currently have set. 

Zoom In/Out   

The Zoom In/Out commands allow the user to change the display size of a drawing on the 

computer screen. 

Zoom Window  

The Zoom Window command zooms to the rectangle defined by the user in the drawing 

screen. 

Zoom Extends  

The Zoom Extends command zooms to the edges of the drawing. 
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Project Data Menu 

Project information  

This command displays a form where the project information (Project Name, Engineer 

Name, Date etc.) is available. 

Add new Material  

By clicking this item, a form opens where a new material can be specified or imported from 

the library. 

Add new Cross section  

By clicking this item, a form opens where a new cross section can be specified or imported 

from the library. 

Add new Response Spectrum function  

By clicking this item, a new response spectrum function can be defined. (Available in the 

Dynamic Edition only) 

Add new Time History function  

By clicking this item, a new time history function can be defined. (Available in the Dynamic 

Edition only) 

Add new Load Case 

By clicking this item, a new load case can be defined. 

Add new Load Case 

By clicking this item, a new load combination can be defined. 

 

  

about:blankprojectinformation.htm
about:blankrccform.htm
about:blankrccform.htm
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Elements Menu 

Elements-> Add new Frame Element submenu  

Fixed-Fixed  

Adds a new frame element with rigid ends (no releases). The element is inserted graphically 

by the user. 

Fixed-Pinned  

Adds a new frame element with rigid starting end and pinned ending end. The element is 

inserted graphically by the user. 

Pinned-Fixed  

Adds a new frame element with pinned starting end and rigid ending end. The element is 

inserted graphically by the user. 

Pinned-Fixed  

Adds a new frame element with pinned both starting and ending ends. The element is 

inserted graphically by the user. This option is automatically applied to all new elements in 

the Truss Edition of the program. 

Add new Frame Element manually  

Adds a new frame element by providing its coordinates. The user can specify all related 

properties of the element. 

Assign Material to Selected Frames 

This command is only available when at least one element has been selected. Using these 

options, the user can massively assign a new material to all selected elements. 

Assign Section to Selected Frames 

This command is only available when at least one element has been selected. Using these 

options, the user can massively assign a new cross section to all selected elements. 

Copy/paste node assignments  

Using this option, the user can transfer the chosen properties of a source node including 

material, section, section placement, end length offsets, releases (only available in Truss 

Edition) and loads to another destination frame. 

Copy/paste frame assignments  
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Using this option, the user can transfer the chosen properties of a source frame including 

supports, Masses (only in Dynamic Edition) to another destination node. 

Properties of selected frame or node  

This command is only available when only one element or node has been selected. 

“Properties” command displays the geometric data, material properties etc. of the selected 

entity. 
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Draw Menu 

Linear Horizontal Linear Dimension Line  

Using this command, the user can draw a straight horizontal dimension line. 

Linear Vertical Linear Dimension Line  

Using this command, the user can draw a straight vertical dimension line. 

Linear Dimension Line  

Using this command, the user can draw a straight dimension line. 

Radial Dimension Line  

Using this command, the user can draw a radial dimension line. 

Label  

Using this command, the user can insert a description label. 
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Analysis Menu 

Calculation Parameters  

This command opens a form where the Calculation Parameters can be viewed or modified. 

Run Analysis  

Performs the structural analysis considering the specified load cases 

Specify Results Location  

Opens a form where the user can specify the location of each frame element to be included 

in the calculation report. The user can override the default locations and add additional 

ones. 

Result tables  

Opens a form where all analysis results are represented in tabular form and are exportable 

to Excel for further processing. 

Calculation report  

Creates the calculation report according to the properties specified by the user. 



2D FRAME ANALYSIS 
Structural analysis of beams, trusses and frames under static, dynamic, linear and non-linear loads 

R         26 | P a g e  

Settings Menu 

Set Units  

This command shows the “Units definition” form, where the user can choose between a 

metric, US or fully customized set of units for current project. 

Preferences  

This opens the “Preferences” form, where the view options including colors and fonts/sizes 

can be viewed or modified. 

Reset to factory default settings  

This option restores all user-defined preferences (colors, fonts, view options etc.) to their 

default values. 
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Help Menu 

User Manual  

This command displays the Help file of 2D Frame Analysis. 

Online worked examples  

This command displays a document with same basic, step-by-step, worked examples for 2D 

Frame Analysis. 

Check for updates  

Connects to the internet and searches for an updated version of 2D Frame Analysis. 

Go to website  

Opens your internet browser and displays the webpage of 2D Frame Analysis. 

Find on facebook  

Opens your internet browser and displays the page of 2D Frame Analysis on Facebook. 

Follow on twitter  

Opens your internet browser and displays the page of 2D Frame Analysis on Twitter. 

YouTube channel  

Opens your internet browser and displays the YouTube channel of 2D Frame Analysis, where 

demonstrative videos, samples and other useful information can be viewed. 

License type 

Specifies the license type (standalone or network). 

Remove License 

Removes all licensing information and reverts the program back to demo. 

About 

Displays the “About” screen of the application, where installed version and your machine ID 

can be found. 
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TOOLBAR ITEMS DESCRIPTION 

Bottom toolbar 

Axes  

Toggle button that specifies if axes are visible. 

Grid  

Toggle button that specifies if grid is visible. 

Ruler  

Toggle button that specifies if ruler is visible. 

View wire frame  

Toggle button that specifies if the elements of the structure are displayed wired. 

Dim lines  

Toggle button that specifies if dimension lines are visible. 

Labels  

Toggle button that specifies if labels are visible. 
Element info 

Specifies the element information to be displayed (Materials, Sections, Supports Frame 
number, Loads, Local axes, End releases, Rigid offsets). 
Snap to grid 

Toggle button that specifies if snap to grid function is enabled. 
Snap to Mid points 

Toggle button that specifies if snap to element middle points is enabled. 
Grid distance 

Specifies the grid distance. 
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Vertical toolbar 

Boxed Selection  

The Zoom Window command zooms to the rectangle defined by the user in the drawing 

screen. 

Clear Selection  

Clear current selection. 

Pan  

Panning allows you to quickly move around the drawing area at the same magnification you 

currently have set. 

Zoom In/Out   

The Zoom In/Out commands allow the user to change the display size of a drawing on the 

computer screen. 

Zoom Window  

The Zoom Window command zooms to the rectangle defined by the user in the drawing 

screen. 

Zoom Extends  

The Zoom Extends command zooms to the edges of the drawing. 

Copy/paste node assignments  

Using this option, the user can transfer the chosen properties of a source node including 

material, section, section placement, end length offsets, releases (only available in Truss 

Edition) and loads to another destination frame. 

Copy/paste frame assignments  

Using this option, the user can transfer the chosen properties of a source frame including 

supports, Masses (only in Dynamic Edition) to another destination node. 
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Model page horizontal toolbar 

Add frame element  

Adds a new frame element with rigid ends (no releases). The element is inserted graphically 

by the user. 

Add new Frame Element manually (provide coordinates)  

Adds a new frame element by providing its coordinates. The user can specify all related 

properties of the element. 

Fixed-Pinned  

Adds a new frame element with rigid starting end and pinned ending end. The element is 

inserted graphically by the user. 

Pinned-Fixed  

Adds a new frame element with pinned starting end and rigid ending end. The element is 

inserted graphically by the user. 

Pinned-Fixed  

Adds a new frame element with pinned both starting and ending ends. The element is 

inserted graphically by the user. This option is automatically applied to all new elements in 

the Truss Edition of the program. 

Delete frame element  

Deletes a frame element by clicking on it. 

Add horizontal roller  

Assigns a horizontal roller to the specified node. 

Add vertical roller  

Assigns a vertical roller to the specified node. 

Add hinge  

Assigns a hinge to the specified node. 

Add fixed support  

Assigns a fixed support to the specified node. 
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Add horizontal fixed roller support  

Assigns a horizontal fixed roller to the specified node. 

Add vertical fixed roller support  

Assigns a vertical fixed roller to the specified node. 

x spring  

Assigns a horizontal spring to the specified node. The spring stiffness is provided in the 

corresponding form. 

y spring  

Assigns a vertical spring to the specified node. The spring stiffness is provided in the 

corresponding form. 

Rot. spring  

Assigns a rotational spring to the specified node. The spring stiffness is provided in the 

corresponding form. 

Clear supports  

Clear the assigned supports of the specified node. 

Apply vertical nodal load  

Assigns a vertical load to the specified node for the selected load case. 

Apply horizontal nodal load  

Assigns a horizontal load to the specified node for the selected load case. 

Apply nodal moment  

Assigns a moment to the specified node for the selected load case. 

Apply vertical uniform frame load  

Assigns a vertical uniform load to the specified frame element for the selected load case. 

Apply horizontal uniform frame load  

Assigns a horizontal uniform load to the specified frame element for the selected load case. 
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Apply custom load on frame  

Assigns a user-specified frame load for the selected load case. 

Clear nodal or frame loads  

Clears the loads of the specified node or frame element. 

Active material 

Specifies the material that will be assigned to new frame elements. 

Active section 

Specifies the cross section that will be assigned to new frame elements. 

Active load case 

Specifies the active load case. 
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Model page vertical toolbar 

Delete  

Deletes all selected objects. 

Linear Horizontal Linear Dimension Line  

Using this command, the user can draw a straight horizontal dimension line. 

Linear Vertical Linear Dimension Line  

Using this command, the user can draw a straight vertical dimension line. 

Linear Dimension Line  

Using this command, the user can draw a straight dimension line. 

Radial Dimension Line  

Using this command, the user can draw a radial dimension line. 

Change Dimension Line Location  

Changes the offset of a dimension line (straight or radial). The user shall first click on this 

command and afterwards click on a dimension line in order to modify its offset. 

Label  

Using this command, the user can insert a description label. 

Modify label Text  

Changes the text of a label. The user shall first click on this command and afterwards click on 

a label in order to modify its text. 

Modify Location of text label  

Changes the location of the text of a label. The user shall first click on this command and 

afterwards click on a label in order to modify its text location. 

Modify Arrow location of label  

Changes the location of the arrow of a label. The user shall first click on this command and 

afterwards click on a label in order to modify its arrow location. 
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Results page toolbar 

Reactions  

Displays the reactions for the specified load case or load combination. 

Deformed Shape  

Displays the deformed shape for the specified load case or load combination. 

Axial Force Diagram   

Displays the axial force diagram for the specified load case or load combination. 

Shear Force Diagram   

Displays the shear force diagram for the specified load case or load combination. 

Bending Moment Diagram  

Displays the axial bending moment diagram for the specified load case or load combination. 

Dynamic Modes  

Displays the dynamic modes of the structure. This option is active when at least one 

response spectrum or time history load case is available. This function is available in the 

Dynamic Edition only. 

Load case/combo 

Specifies the current load case or load combination for results reporting. 

Show values 

Specifies if force/moment values are displayed for the axial, shear force and bending 

moment diagrams. 

Show min/max values 

Specifies if Minimum, Maximum or Minimum and Maximum values are displayed. This 

option is available when displaying results for a load combination of type “Envelope”. 

Moreover, this option is available if displaying results of a load combination that includes a 

response spectrum case. 

Scale 

The diagrams scaling can be controlled by this control. 

Step 
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Specifies the current step to display results for. It is only available if reading results from a 

non-linear static load case. 

Mode 

Specifies the dynamic mode to display. This option is active when at least one response 

spectrum or time history load case is available. This function is available in the Dynamic 

Edition only. 
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DESCRIPTION OF THE FORMS 

Units 

How to open 

1. By selecting Settings -> Set Units options from the main window menu bar. 

2. By clicking on the “Units” status bar button in the lower right corner of the main 

screen and then selecting “Details” 

Description 

The system of units for all input and output data can be defined using this form. The user 

can choose between the predefined Metric and US (Imperial) systems or even provide his 

own units for each item, such as force, length, area etc. 

Preferences 

How to open 

By selecting Settings -> Preferences from the main window menu bar. 

Description 

Misc. tab 

The user can specify the positive diagram location (above or below frame element). It 

defines how internal force diagrams appear. 

Moreover, the user can specify if the program automatically checks for updates when it 

starts. 

“Reset to default values” button applies all default settings for the data listed in the “View 

options” form. 

Fonts and sizes 

In this tab, the user can define the displayed font families and corresponding font sizes. 

Colors tab 

In this tab, the user can modify the colors of the drawing area (background, grid, ruler, axes 

etc.), the colors of the geometric objects (polygons, points, reinforcement bars etc.), color 

preferences for dimensions/labels as well as for the information pane on the left of the main 

screen. Moreover, the user is able to see/modify the colors of the displayed resulting 

screens. 
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Reset to factory default settings  

This option restores all user-defined preferences (colors, fonts, view options etc.) to their 

default values. 

Project information 

How to open 

1. By selecting Project Data -> Project information from the main window menu bar 

2. By clicking on the corresponding toolbar button  of the main window 

Description 

Project, company as well as model information can be provided using this form. All relative 

data will be included in the calculation report. 
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Material definition 

How to open 

1. By selecting Project Data -> Add new Material from the main window menu bar 

2. By clicking on the corresponding toolbar button  of the main window 

Description 

The available materials are defined in this form. 

Name 

The name for the material. 

Elasticity modulus 

Specifies the elasticity modulus of the material. 

Shear modulus 

Specifies the shear modulus of the material. 

Specific weight 

Specifies the specific weight of the material. It is used to calculate the self-weight load as 

well as the self-mass in case of dynamic analysis. 

Temperature coefficient of resistance 

Specifies the temperature coefficient of resistance of the material. 

Import from library 

Open the library form of materials in order to import a predefined material. 
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Material from library 

How to open 

By clicking the “Import from library” button from the Material definition form. 

Description 

The user can import a predefined material from a wide variety of predefined material 

libraries. 

Material type 

The library to choose a material from. Available lists: Australian NZ, ASTM, CSA, BS, 

European04, European, UNI, GOST, JIS, JIS (Civil), GB, GB (Civil), JTG04, TB05, KS01, KS, IS, 

CNS560, CNS. 

Available material 

The available materials list. A material can be selected and imported to the project by 

clicking the “Insert material” button. 
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Cross section definition 

How to open 

1. By selecting Project Data -> Add new Cross section from the main window menu bar 

2. By clicking on the corresponding toolbar button  of the main window 

Description 

The available cross sections are defined in this form. 

Section name 

The name for the cross section. 

Section type 

Using this control, the user can specify the type of the cross section (Rectangular, Circular, I 

wide flange, Channel, Tee, Angle, Box and Pipe). 

Import from library 

A predefined cross section can be inserted using this button. 

Shear coefficient 

The Timoshenko shear coefficient can be specified using this control. The shear coefficient is 

considered if the option “Consider shear deformation effect” on the Calculation parameters 

form is enabled. Shear coefficient depends on the section shape and is normally assumed 

equal to 5/6 for rectangular sections. 

Section dimensions 

The sectional dimensions are specified in the corresponding fields. 

Section properties 

The automatically calculated sectional properties (Area, inertia moments and section 

moduli) are represented in these fields. 

Preview 

The chosen section is displayed in this area. 
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Section from library 

How to open 

By clicking the “Import from library” button from the Cross section definition form. 

Description 

The user can import a predefined cross section from a wide variety of predefined section 

libraries. 

Section type 

The name for the cross section. 

Section type 

Using this control, the user can specify the type of the imported cross section (I wide flange, 

Channel, Tee, Angle, Box and Pipe). 

Library list 

The library to choose a section from. Available lists: Aluminum shapes, Aluminum shapes 

6061-T6, AISC shapes v3, AISC shapes v13, AISC13, AISCLRFD1, AISCLRFD2, AISCLRFD3, 

Australian and New Zealand steel shapes v8, British Standards steel shapes, British Standards 

steel shapes 2006, Chinese steel shapes, European steel shapes, Indian steel shapes. 

Section 

The cross section to import. 
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Frame element 

How to open 

1. By selecting Elements -> Add new Frame Element manually from the main window 

menu bar. A new frame element is created using this option. 

2. By selecting Elements -> Properties of selected frame or node from the main 

window menu bar. An existing frame element can be viewed/modified using these 

buttons. 

3. By clicking one of the corresponding toolbar buttons , ,  or  of the 

Model page horizontal toolbar. An existing frame element can be viewed/modified 

using these buttons. 

4. By right-clicking on a frame element when on Model page. 

Description 

The user can create or view/edit a frame element using this form. 

Geometry tab 

The starting and ending nodes coordinates are displayed. 

Properties tab 

Material 

Specifies the material assigned to the frame element 

Cross section 

Specifies the cross section assigned to the frame element 

Section placement 

Specifies how the cross section of the frame element is inserted. If choosing the “Strong 

axis” option, the cross section is inserted so that the inertia data about the major axis of the 

section are considered. The strong axis of the cross section is perpendicular to screen. 

Similarly, if choosing the “Weak axis” option, the cross section is inserted so that the inertia 

data about the minor axis of the section are considered. The weak axis of the cross section is 

perpendicular to screen. 

End length offset 

Specifies the length of starting and ending offset lengths for the frame element. The stiffness 

of end length offsets is controlled by the “Rigid end length offset stiffness multiplier” option 

in the Calculation parameters form. 
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Consider connection with joints and other frame elements along element length 

Specifies if joints within the frame span or intersection with other frame elements are 

considered as connections. When this option is enabled, an internal node during the analysis 

is added at these points so that a rigid connection takes place. 

Releases tab 

Specifies the end releases of the degrees of freedom at the starting and ending node of the 

frame element. Both full and partial spring releases are supported. In case of partial springs, 

the corresponding translational/rotational stiffness values can be entered. 

Loads tab 

Load case 

Specifies the load case to display loads for. 

Span point loads 

Using this control, concentrated span loads (horizontal, vertical forces and/or moments) can 

be applied. 

Coordinate system 

The coordinate system of current span loads is specified. Span loads can be provided in local 

or global coordinate system. 

Horizontal load 

Horizontal load value 

Vertical load 

Vertical load value 

Moment 

Moment value 

Distance from starting node 

Specifies the location of the span loads. If option “Absolute” for location definition is 

selected, the distance is provided in absolute units, for example m, ft, etc. If option 

“Relative” for location definition is selected, the distance is provided relatively to the frame 

length, for example 0.50 means at the middle of the frame element. 

Temperature load 

Thermal difference 
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Specifies the temperature difference between environment and central frame line, in 

absolute temperature units. This load mainly causes axial tension/compression. 

Thermal gradient 

Thermal gradient is defined as the ratio of the temperature difference between two points, 

each located above and below the frame element. Thermal gradient has the units of 

temperature divided by length. This load mainly causes bending. 

Uniform load 

Coordinate system 

The coordinate system of uniform loads is specified. Uniform loads can be provided in local, 

global or projected global coordinate system. If choosing global projected coordinate 

system, loads are applied at global coordinate system and they are afterwards projected to 

the frame element. Snow loads on slopped roofs are usually entered at projected global 

system. 

Load 

The uniform load value in units force per length. 

Direction 

Specifies the load direction (horizontal or vertical). 

Trapezoidal load 

Coordinate system 

The coordinate system of uniform loads is specified. Uniform loads can be provided in local, 

global or projected global coordinate system. If choosing global projected coordinate 

system, loads are applied at global coordinate system and they are afterwards projected to 

the frame element. Snow loads on slopped roofs are usually entered at projected global 

system. 

Distance 1 from starting node 

Specifies the starting location of the trapezoidal load. If option “Absolute” for location 

definition is selected, the distance is provided in absolute units, for example m, ft, etc. If 

option “Relative” for location definition is selected, the distance is provided relatively to the 

frame length, for example 0.50 means at the middle of the frame element. 

Load 1 

The uniform load value at the starting location of the trapezoidal load in units force per 

length. 

Distance 2 from starting node 
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Specifies the ending location of the trapezoidal load. If option “Absolute” for location 

definition is selected, the distance is provided in absolute units, for example m, ft, etc. If 

option “Relative” for location definition is selected, the distance is provided relatively to the 

frame length, for example 0.50 means at the middle of the frame element. 

Load 2 

The uniform load value at the ending location of the trapezoidal load in units force per 

length. 

Direction 

Specifies the load direction (horizontal or vertical). 

  



2D FRAME ANALYSIS 
Structural analysis of beams, trusses and frames under static, dynamic, linear and non-linear loads 

R         46 | P a g e  

Node 

How to open 

1. By selecting Elements -> Properties of selected frame or node from the main 

window menu bar. An existing frame element can be viewed/modified using these 

buttons. 

2. By right-clicking on a node when on Model page. 

Description 

The user can view/edit a node using this form. 

Geometry tab 

Coordinates 

The nodal coordinates are displayed. 

Additional Masses 

The additional nodal masses can be specified using this control. This option is available in the 

Dynamic Edition only. 

Supports tab 

Specifies the support types of the node. All combination of degrees of freedom restraints are 

supported. In case of spring supports, the corresponding translational/rotational spring 

stiffness values can be provided. 

Loads tab 

Load case 

Specifies the load case to display loads for. 

Nodal load 

Using this control, nodal loads (Horizontal, Vertical forces and Bending moments at global 

coordinate system can be applied. 
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Static load case 

How to open 

1. By clicking the “Add new” button from the Load cases field of the Load 

cases/combos tab page on the left of the main page. Using this option, a static load 

case can be added. 

2. By clicking the “Details” button from the Load cases field of the Load cases/combos 

tab page on the left of the main page. Using this option, a static load case can be 

viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Load Case 

menu item. 

4. By clicking on the corresponding toolbar button  of the main window 

Description 

A linear static analysis case is represented in this form. 

Name 

The name of the load case. 

Include self weight 

Specifies if self weight is considered for this load case. If this option is enabled, self weight is 

automatically added to the remaining loads specified by the user. 

Self weight multiplier 

Specifies the self weight factor to be considered. This option is available if “Include self 

weight” option is selected. 
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Non linear static load case 

How to open 

1. By clicking the “Add new” button from the Load cases field of the Load 

cases/combos tab page on the left of the main page. Using this option, a non linear 

static load case can be added. 

2. By clicking the “Details” button from the Load cases field of the Load cases/combos 

tab page on the left of the main page. Using this option, a non linear static load case 

can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Load Case 

menu item. 

4. By clicking on the corresponding toolbar button  of the main window 

Description 

A non linear static analysis case is represented in this form. 

Data 

The analysis cases, that are considered in the non linear load case, are specified here. A 

factor can also be specified for each participating load. Only linear static load cases can take 

part in a non-linear static case. 
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Response spectrum case 

How to open 

1. By clicking the “Add new” button from the Load cases field of the Load 

cases/combos tab page on the left of the main page. Using this option, a response 

spectrum load case can be added. 

2. By clicking the “Details” button from the Load cases field of the Load cases/combos 

tab page on the left of the main page. Using this option, a response spectrum load 

case can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Load Case 

menu item. 

4. By clicking on the corresponding toolbar button  of the main window 

Description 

A response spectrum analysis case is represented in this form. 

Direction 

Specifies if the response spectrum case will be applied at the X (horizontal) or Y (vertical) 

global coordinate. 

Modal combination method 

Specifies how the calculated modes will be combined in order to get the dynamic response 

of the structure. Available methods: CQC (Complete-Quadratic-Combination) and SRSS 

(Square Root of the Sum of the Squares). 

Response Spectrum Function 

Specifies the response spectrum function to use for this load case. 
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Standard response spectrum function 

How to open 

1. By clicking the “Add new” button from the Response Spectra field of the Dynamic 

Data tab page on the left of the main page. Using this option, a response spectrum 

can be added. 

2. By clicking the “Details” button from the Load cases/combos tab page on the left of 

the main page. Using this option, a response spectrum can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Response 

Spectrum function menu item. 

Name 

The name of the response spectrum function. 

Starting acceleration 

Specifies the acceleration at the start of the function. 

Period at point 2 

Specifies the period at the second function point. 

Acceleration at plateau 

Specifies the acceleration at the top of the function 

Period at point 3 

Specifies the period at the third function point. 

Ending period 

Specifies the period at the end of the function. 

Ending acceleration 

Specifies the acceleration at the end of the function. 

Response spectrum function 

Displays the response spectrum data. 

Response spectrum graph 

Displays the response spectrum function plot. 
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User defined response spectrum function 

How to open 

1. By clicking the “Add new” button from the Response Spectra field of the Dynamic 

Data tab page on the left of the main page. Using this option, a response spectrum 

can be added. 

2. By clicking the “Details” button from the Load cases/combos tab page on the left of 

the main page. Using this option, a response spectrum can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Response 

Spectrum function menu item. 

Name 

The name of the response spectrum function. 

Period 

The period of a point of the response spectrum function to add. 

Acceleration 

The acceleration of a point of the response spectrum function to add. 

Add/Edit/Delete 

The points of the diagram can be added, modified or deleted using these buttons. 
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Response spectrum function from file 

How to open 

1. By clicking the “Add new” button from the Response Spectra field of the Dynamic 

Data tab page on the left of the main page. Using this option, a response spectrum 

can be added. 

2. By clicking the “Details” button from the Load cases/combos tab page on the left of 

the main page. Using this option, a response spectrum can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Response 

Spectrum function menu item. 

Name 

The name of the response spectrum function. 

Select file 

Select the file that includes the response spectrum function. 

Response spectrum function 

Displays the response spectrum data. 

Response spectrum graph 

Displays the response spectrum function plot. 
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Time history case 

How to open 

1. By clicking the “Add new” button from the Load cases field of the Load 

cases/combos tab page on the left of the main page. Using this option, a time 

history load case can be added. 

2. By clicking the “Details” button from the Load cases field of the Load cases/combos 

tab page on the left of the main page. Using this option, a time history load case can 

be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Load Case 

menu item. 

4. By clicking on the corresponding toolbar button  of the main window 

Description 

A time history analysis case is represented in this form. 

Direction 

Specifies if the time history case will be applied at the X (horizontal) or Y (vertical) global 

coordinate. 

Modal combination method 

Specifies how the calculated modes will be combined in order to get the dynamic response 

of the structure. Available methods: CQC (Complete-Quadratic-Combination) and SRSS 

(Square Root of the Sum of the Squares). 

Time History Function 

Specifies the time history function to use for this load case. 

Steps 

Specifies the number of steps to consider. 

dt 

Specifies the time interval for each step. 
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Sine time history function 

How to open 

1. By clicking the “Add new” button from the Time History functions of the Dynamic 

Data tab page on the left of the main page. Using this option, a time history function 

can be added. 

2. By clicking the “Details” button from the Time History functions of the Dynamic Data 

tab page. Using this option, a time history function can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Time History 

function menu item. 

Name 

The name of the time history function. 

Amplitude 

Specifies the amplitude of the time history function. 

Period 

Specifies the period of the time history function. 

Number of cycles 

Specifies the number of cycles of the time history function. 

Steps per cycle 

Specifies the steps per cycle of the time history function. 

Time history function 

Displays the time history data. 

Time history graph 

Displays the time history function plot. 
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Cosine time history function 

How to open 

1. By clicking the “Add new” button from the Time History functions of the Dynamic 

Data tab page on the left of the main page. Using this option, a time history function 

can be added. 

2. By clicking the “Details” button from the Time History functions of the Dynamic Data 

tab page. Using this option, a time history function can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Time History 

function menu item. 

Name 

The name of the time history function. 

Amplitude 

Specifies the amplitude of the time history function. 

Period 

Specifies the period of the time history function. 

Number of cycles 

Specifies the number of cycles of the time history function. 

Steps per cycle 

Specifies the steps per cycle of the time history function. 

Time history function 

Displays the time history data. 

Time history graph 

Displays the time history function plot. 
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Ramp time history function 

How to open 

1. By clicking the “Add new” button from the Time History functions of the Dynamic 

Data tab page on the left of the main page. Using this option, a time history function 

can be added. 

2. By clicking the “Details” button from the Time History functions of the Dynamic Data 

tab page. Using this option, a time history function can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Time History 

function menu item. 

Name 

The name of the time history function. 

Ramp time 

Specifies the time at the ramp. 

Amplitude 

Specifies the amplitude of the time history function. 

Maximum time 

Specifies the maximum time of the time history function. 

Time history function 

Displays the time history data. 

Time history graph 

Displays the time history function plot. 
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Saw tooth time history function 

How to open 

1. By clicking the “Add new” button from the Time History functions of the Dynamic 

Data tab page on the left of the main page. Using this option, a time history function 

can be added. 

2. By clicking the “Details” button from the Time History functions of the Dynamic Data 

tab page. Using this option, a time history function can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Time History 

function menu item. 

Name 

The name of the time history function. 

Ramp time 

Specifies the time at the ramp. 

Period 

Specifies the period of the time history function. 

Number of cycles 

Specifies the number of cycles of the time history function. 

Time history function 

Displays the time history data. 

Time history graph 

Displays the time history function plot. 
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Triangular time history function 

How to open 

1. By clicking the “Add new” button from the Time History functions of the Dynamic 

Data tab page on the left of the main page. Using this option, a time history function 

can be added. 

2. By clicking the “Details” button from the Time History functions of the Dynamic Data 

tab page. Using this option, a time history function can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Time History 

function menu item. 

Name 

The name of the time history function. 

Amplitude 

Specifies the amplitude of the time history function. 

Period 

Specifies the period of the time history function. 

Number of cycles 

Specifies the number of cycles of the time history function. 

Time history function 

Displays the time history data. 

Time history graph 

Displays the time history function plot. 
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User defined time history function 

How to open 

1. By clicking the “Add new” button from the Time History functions of the Dynamic 

Data tab page on the left of the main page. Using this option, a time history function 

can be added. 

2. By clicking the “Details” button from the Time History functions of the Dynamic Data 

tab page. Using this option, a time history function can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Time History 

function menu item. 

Name 

The name of the time history function. 

Time 

The time of a point of the time history function to add. 

Acceleration 

The acceleration of a point of the time history function to add. 

Add/Edit/Delete 

The points of the diagram can be added, modified or deleted using these buttons. 

Time history function 

Displays the time history data. 

Time history graph 

Displays the time history function plot. 
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Time history function from file 

How to open 

1. By clicking the “Add new” button from the Time History functions of the Dynamic 

Data tab page on the left of the main page. Using this option, a time history function 

can be added. 

2. By clicking the “Details” button from the Time History functions of the Dynamic Data 

tab page. Using this option, a time history function can be viewed/modified. 

3. By choosing the corresponding item from the Project Data->Add new Time History 

function menu item. 

Name 

The name of the time history function. 

Select file 

Select the file that includes the time history function. 

Time history function 

Displays the time history data. 

Time history graph 

Displays the time history function plot. 
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Load combination 

How to open 

1. By clicking the “Add new” button from the Load combinations field of the Load 

cases/combos tab page on the left of the main page. Using this option, a load 

combination can be added. 

2. By clicking the “Details” button from the Load combinations field of the Load 

cases/combos tab page on the left of the main page. Using this option, a load 

combination can be viewed/modified. 

3. By clicking the Project Data->Add new Load Combination function menu item. 

4. By clicking on the corresponding toolbar button  of the main window 

Name 

The name of the load combination. 

Type 

The type of combination between load cases and load combinations that participate in this 

load combination. Supported types are:  

Add: The program performs a linear addition of the response of each participating load case 

or load combination in this load combination. 

Absolute: Performs a linear addition of the absolute values of the response of each 

participating load case or load combination in this load combination, in order to get the 

maximum values of the response. Minimum values are obtained by multiplying maximum 

values by -1. 

Envelope: A max/min Envelope of the included load cases or load combinations is evaluated 

for each frame output segment and node. The participating load cases or load combinations 

that give the maximum and minimum components are used for this combo. Therefore, the 

load Combo holds two values (minimum and maximum) for each output segment and node. 

SRSS: To get the maximum values, the program considers the square root of the sum of the 

squares of the larger absolute values for each of the included load cases or load 

combinations. Minimum values are obtained by multiplying maximum values by -1. 

Analysis cases 

The participating load cases or load combinations and their factors are reported on the 

corresponding control. 
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Calculation parameters 

How to open 

1. By selecting Analysis -> Calculation Parameters from the main window menu bar. 

2. By clicking on the corresponding toolbar button  of the main window. 

Description 

Using this form, the user can define the parameters that are considered during the structural 

analysis of the model. 

General tab 

Consider shear deformation effect 

Using this control, the user can specify if shear deformation effects are to be considered in 

the analysis. When this option is enabled, Timoshenko beam theory is used. Timoshenko 

beam theory is recommended for structures with small ratios of length per beam height. 

Rigid end length offset stiffness multiplier 

Specifies that stiffness multiplier of the end length offset length (if any) at starting and 

ending frame element locations. This value is unitless and is applied to the initial frame 

element stiffness. 

Non Linear Analysis tab 

The Modified Newton-Raphson algorithm is used in order to carry out the static non-linear 

analysis. The related parameters are represented below. 

Load steps 

Specifies the number of load steps for the non-linear loads. 

Iterations per load step 

Specifies the number of iterations within a load step for the non-linear loads. 

Convergence tolerance 

Specifies the stiffness tolerance that is considered for convergence. 

Update method 

Specifies how the stiffness matrix is updated during the non-linear analysis. Available 
options are: After each iteration inside a load step, After each load step and Keep constant. 
Dynamic Analysis tab 

The parameters of dynamic response spectrum, time history and modal analysis are 

specified in this control. This option is only available in the Dynamic Edition. 
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Mass source 

Specifies the mass source for the dynamic analysis. 

From self weight only: Dynamic mass is assumed to come from Self weight only. 

From self weight plus specified loads: Dynamic mass is assumed to come from Self weight 

plus specified load cases. The corresponding load cases control is enabled if this option is 

selected. 

From specified loads only: Dynamic mass is assumed to come from specified load cases only. 

The corresponding load cases control is enabled if this option is selected. 

Number of modes to find 

Specifies the number of dynamic modes to calculate. This number cannot be greater than 

the total degrees of freedom of the structure. 

Acceleration of gravity 

Specifies the gravity acceleration to consider in order to convert loads to masses. 

Lumped mass matrix 

If selected, the specified mass matrix is lumped (only diagonal terms). Otherwise, a 

consistent mass matrix is produced. It is strongly recommended to use a lumped mass  
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Frame results 

How to open 

By right clicking on a frame element when in Results page 

Description 

The results of a single frame element are reported in this form. 

Frame element 

The label of the frame element is displayed. 

Length 

The length of the frame element is displayed. 

Location 

The location to get results at. Location is provided in length units. Internal forces and 

displacements are reported for the specified location. The given location cannot lie within 

any end offset lengths, if defined. 

Load case/combo 

The load case or load combination to get results for. 

Results type 

Specifies if Minimum, Maximum or Minimum and Maximum values are displayed. This 

option is available when displaying results for a load combination of type “Envelope”. 

Moreover, this option is available if displaying results of a load combination that includes a 

response spectrum case. 

Step 

Specifies the current step to display results for. It is only available if reading results from a 

non-linear static load case. 

Displacements/Rotations 

The translational displacements and rotations at the local coordinate system of the frame 

element are represented. 

Internal forces 

The internal forces at the local coordinate system of the frame element are represented. 

Internal forces representation 

The minimum and maximum values and corresponding locations are reported. These 

locations are also represented graphically by clicking on each of them.  
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Node results 

How to open 

By right clicking on a node when in Results page 

Description 

The results of a single node are reported in this form. 

Node 

The label of the node is displayed. 

x, y 

The nodal coordinates are displayed. 

Load case/combo 

The load case or load combination to get results for. 

Results type 

Specifies if Minimum, Maximum or Minimum and Maximum values are displayed. This 

option is available when displaying results for a load combination of type “Envelope”. 

Moreover, this option is available if displaying results of a load combination that includes a 

response spectrum case. 

Step 

Specifies the current step to display results for. It is only available if reading results from a 

non-linear static load case. 

Displacements/Rotations 

The translational displacements and rotations at the global coordinate system are 

represented. 

Reactions 

The reactions of the constrained degrees of freedom (if any), at the global coordinate 

system are represented. 
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Results locations 

How to open 

1. By selecting Analysis -> Specify Results Locations from the main window menu bar. 

2. By clicking on the corresponding toolbar button  of the main window 

Description 

The locations of the frame elements that will be included in the calculation report are 

defined using this form. Warning: Results locations are cleared and replaced by default 

values each time the structural analysis is carried out. They shall be set by the user just 

before the creation of the calculation report. 

Element 

The element to view or modify its results locations. 

New location to add 

Using this control, a new location for results reporting can be added. 

Delete selected location 

Using this button, the selected results location is deleted. 

Reset for element 

Using this button, the selected results location for the selected frame element are cleared 

and reverted to their defaults. 

Reset for all elements 

Using this button, the selected results location for all frame elements are cleared and 

reverted to their defaults. 
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Results tables 

How to open 

1. By selecting Analysis -> Results tables from the main window menu bar. 

2. By clicking on the corresponding toolbar button  of the main window 

Description 

The analysis results of the whole structure are represented in this form in tabular format. 

The values can be exported to Excel for further processing. 

Results 

Specifies the results to be displayed. Available options are: 

Support reactions: Displays the nodal reactions 

Total reactions: Displays the total reaction of the whole structure 

Node displacements/rotations: Displays the nodal displacements/rotations 

Frame forces: Displays the frame elements internal forces 

Frame deformation: Displays the frame elements deformations 

Modal analysis results: Displays the calculated dynamic modes and the related modal 

analysis data. This option is available in the Dynamic Edition only and is active if at least one 

response spectrum or time history analysis has been included in the structure. 

Load case/combination 

Specifies the load case or load combination to display results for. 

Output type 

Specifies if Minimum, Maximum or Minimum and Maximum values are displayed. This 

option is available when displaying results for a load combination of type “Envelope”. 

Moreover, this option is available if displaying results of a load combination that includes a 

response spectrum case. 

Step 

Specifies the current step to display results for. It is only available if reading results from a 

non-linear static load case. 
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Report settings 

How to open 

1. By selecting Analysis -> Calculation report from the main window menu bar. 

2. By clicking on the corresponding toolbar button  of the main window. 

Description 

In this form, the user can define the data which will be represented in the calculation report. 

Data to include in calculation report 

All relative project items can be selected to be included in the report. 

The report will only contain items that have already be used in the project. Thus, materials 

and sections that have not been assigned to frame elements will not be included. 

Select load cases/combos 

The user can select which of the load cases/combinations will be represented on the 

calculation report. 


