EC3Design Namespace

[image]

ENGISSOL - EC3/8 Design Library
EC3Design Namespace
Send Feedback
EC3/8 Design Library

Classes

Class | Description
Beam |
BeamDuctilityDesignParameters |
BeamDuctilityDesignResults | Ducility design results regarding a beam
BeamSLSResults | Contains the SLS results for a frame element defined as beam
Brace |
BraceDuctilityDesignParameters |
BucklingCheckResults |
Column |
ColumnDuctilityDesignParameters |
ColumnDuctilityDesignResults | Ducility design results regarding a column
DuctileMomentResistingJoint | A joint object containing joints to be designed with ductility demands regarding moment resisting frames
DuctilityDesignResults | Ducility design results regarding a brace
FrameElement |
FrameResultsSet | Contains a set loads (internal forces) at all element stations as well as results per stations or per element
FrameResultsSetDuctilityDesignResults | Ducility design results regarding a frame results set
JointDuctilityDesignResults | Ducility design results regarding a joint
Material |
Model |
Node |
Parameters |
RailSection | Class that represents a rail section, that can be assgined to runway beams
RunwayBeamExtraResults | Contains the extra results of a frame element defined as runway beam
RunwayBeamInputData | Input data for runway beams
SectionCheckResults |
Station | Contains loads and results regarding a specific location of a frame element
StationDuctilityDesignResults | Ducility design results regarding a station
Story |
StoryDuctilityDesignResults | Ducility design results regarding a story

Enumerations

Enumeration | Description
BeamType |
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


Beam Class

[image]

ENGISSOL - EC3/8 Design Library
Beam Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Beam : FrameElement
Visual Basic (Declaration)
Public Class Beam _
    Inherits FrameElement
Visual C++
public ref class Beam : public FrameElement

Inheritance Hierarchy

System..::.Object
EC3Design..::.FrameElement
EC3Design..::.Beam

See Also

Beam Members
EC3Design Namespace


Beam Members

[image] [image]

ENGISSOL - EC3/8 Design Library
Beam Members
Beam Class Constructors Methods Fields Properties See Also Send Feedback
EC3/8 Design Library

The Beam type exposes the following members.

Constructors

Name | Description
Beam | Construction of a beam object

Methods

Name | Description
Check | Performs the checks of the frame element for resistance and buckling and fills the corresponding Results objects (Inherited from FrameElement.)
Equals | (Inherited from FrameElement.)

Fields

Name | Description
Camper | The Camper that is given to the beam's middle point
DuctilityDesignParameters |
DuctilityDesignResults |
EndingNode | (Inherited from FrameElement.)
EndingReleaseRX | (Inherited from FrameElement.)
EndingReleaseRY | (Inherited from FrameElement.)
EndingReleaseRZ | (Inherited from FrameElement.)
EndingReleaseTX | (Inherited from FrameElement.)
EndingReleaseTY | (Inherited from FrameElement.)
EndingReleaseTZ | (Inherited from FrameElement.)
ExtraResultsRunway | Additional check results of runway beams
FrameResultsSets_DEAD_SLS | Dead load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_LIVE_SLS | Live load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_SLS | SLS combinations (Inherited from FrameElement.)
FrameResultsSets_ULS | ULS combinations (Inherited from FrameElement.)
ID | ID of Frame Element (Inherited from FrameElement.)
IsRunwayBeam | Specifies whether this beam should be designed as runway beam
Length | Length of Frame Element (Inherited from FrameElement.)
Material | Material of Frame Element (Inherited from FrameElement.)
PointInPlaneXY | (Inherited from FrameElement.)
RunwayData | Runway data, in case of runway beam
Section | Section of Frame Element (Inherited from FrameElement.)
SeismicOnlyLoads | Combinations with seismic-only loads included in seismic combination (Inherited from FrameElement.)
SeismicVericalLoads | Combination with vertical loads included in seismic combination (Inherited from FrameElement.)
SLSResultsBeam |
StartingNode | (Inherited from FrameElement.)
StartingReleaseRX | (Inherited from FrameElement.)
StartingReleaseRY | (Inherited from FrameElement.)
StartingReleaseRZ | (Inherited from FrameElement.)
StartingReleaseTX | (Inherited from FrameElement.)
StartingReleaseTY | (Inherited from FrameElement.)
StartingReleaseTZ | (Inherited from FrameElement.)
Story | (Inherited from FrameElement.)
Type | (Inherited from FrameElement.)
TypeForDeflectionCheck | The Beam type, it can be NonAccessibleRoofs or AccesibleRoofsOrFloors
za | Z coordinate of load application point on section (input) (Inherited from FrameElement.)

Properties

Name | Description
_Section | (Inherited from FrameElement.)

See Also

Beam Class


Beam Constructor

[image]

ENGISSOL - EC3/8 Design Library
Beam Constructor
Beam Class See Also Send Feedback
EC3/8 Design Library
Construction of a beam object

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Beam(
    string _ID,
    double _Length,
    Object _Section,
    Material _Material,
    Node _StartingNode,
    Node _EndingNode
)
Visual Basic (Declaration)
Public Sub New ( _
    _ID As String, _
    _Length As Double, _
    _Section As Object, _
    _Material As Material, _
    _StartingNode As Node, _
    _EndingNode As Node _
)
Visual C++
public:
Beam(
    String^ _ID,
    double _Length,
    Object^ _Section,
    Material^ _Material,
    Node^ _StartingNode,
    Node^ _EndingNode
)

Parameters

_ID
Type: System..::.String
Beam ID
_Length
Type: System..::.Double
Length
_Section
Type: System..::.Object
Section object
_Material
Type: EC3Design..::.Material
Material object
_StartingNode
Type: EC3Design..::.Node
Starting node object
_EndingNode
Type: EC3Design..::.Node
Starting node object

See Also

Beam Class


Beam Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
Beam Fields
Beam Class See Also Send Feedback
EC3/8 Design Library

The Beam type exposes the following members.

Fields

Name | Description
Camper | The Camper that is given to the beam's middle point
DuctilityDesignParameters |
DuctilityDesignResults |
EndingNode | (Inherited from FrameElement.)
EndingReleaseRX | (Inherited from FrameElement.)
EndingReleaseRY | (Inherited from FrameElement.)
EndingReleaseRZ | (Inherited from FrameElement.)
EndingReleaseTX | (Inherited from FrameElement.)
EndingReleaseTY | (Inherited from FrameElement.)
EndingReleaseTZ | (Inherited from FrameElement.)
ExtraResultsRunway | Additional check results of runway beams
FrameResultsSets_DEAD_SLS | Dead load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_LIVE_SLS | Live load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_SLS | SLS combinations (Inherited from FrameElement.)
FrameResultsSets_ULS | ULS combinations (Inherited from FrameElement.)
ID | ID of Frame Element (Inherited from FrameElement.)
IsRunwayBeam | Specifies whether this beam should be designed as runway beam
Length | Length of Frame Element (Inherited from FrameElement.)
Material | Material of Frame Element (Inherited from FrameElement.)
PointInPlaneXY | (Inherited from FrameElement.)
RunwayData | Runway data, in case of runway beam
Section | Section of Frame Element (Inherited from FrameElement.)
SeismicOnlyLoads | Combinations with seismic-only loads included in seismic combination (Inherited from FrameElement.)
SeismicVericalLoads | Combination with vertical loads included in seismic combination (Inherited from FrameElement.)
SLSResultsBeam |
StartingNode | (Inherited from FrameElement.)
StartingReleaseRX | (Inherited from FrameElement.)
StartingReleaseRY | (Inherited from FrameElement.)
StartingReleaseRZ | (Inherited from FrameElement.)
StartingReleaseTX | (Inherited from FrameElement.)
StartingReleaseTY | (Inherited from FrameElement.)
StartingReleaseTZ | (Inherited from FrameElement.)
Story | (Inherited from FrameElement.)
Type | (Inherited from FrameElement.)
TypeForDeflectionCheck | The Beam type, it can be NonAccessibleRoofs or AccesibleRoofsOrFloors
za | Z coordinate of load application point on section (input) (Inherited from FrameElement.)

See Also

Beam Class


Camper Field

[image]

ENGISSOL - EC3/8 Design Library
Beam..::.Camper Field
Beam Class See Also Send Feedback
EC3/8 Design Library
The Camper that is given to the beam's middle point

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Camper
Visual Basic (Declaration)
Public Camper As Double
Visual C++
public:
double Camper

See Also

Beam Class


DuctilityDesignParameters Field

[image]

ENGISSOL - EC3/8 Design Library
Beam..::.DuctilityDesignParameters Field
Beam Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamDuctilityDesignParameters DuctilityDesignParameters
Visual Basic (Declaration)
Public DuctilityDesignParameters As BeamDuctilityDesignParameters
Visual C++
public:
BeamDuctilityDesignParameters^ DuctilityDesignParameters

See Also

Beam Class


DuctilityDesignResults Field

[image]

ENGISSOL - EC3/8 Design Library
Beam..::.DuctilityDesignResults Field
Beam Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamDuctilityDesignResults DuctilityDesignResults
Visual Basic (Declaration)
Public DuctilityDesignResults As BeamDuctilityDesignResults
Visual C++
public:
BeamDuctilityDesignResults^ DuctilityDesignResults

See Also

Beam Class


ExtraResultsRunway Field

[image]

ENGISSOL - EC3/8 Design Library
Beam..::.ExtraResultsRunway Field
Beam Class See Also Send Feedback
EC3/8 Design Library
Additional check results of runway beams

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RunwayBeamExtraResults ExtraResultsRunway
Visual Basic (Declaration)
Public ExtraResultsRunway As RunwayBeamExtraResults
Visual C++
public:
RunwayBeamExtraResults^ ExtraResultsRunway

Remarks

See Also

Beam Class


IsRunwayBeam Field

[image]

ENGISSOL - EC3/8 Design Library
Beam..::.IsRunwayBeam Field
Beam Class See Also Send Feedback
EC3/8 Design Library
Specifies whether this beam should be designed as runway beam

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsRunwayBeam
Visual Basic (Declaration)
Public IsRunwayBeam As Boolean
Visual C++
public:
bool IsRunwayBeam

See Also

Beam Class


RunwayData Field

[image]

ENGISSOL - EC3/8 Design Library
Beam..::.RunwayData Field
Beam Class See Also Send Feedback
EC3/8 Design Library
Runway data, in case of runway beam

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RunwayBeamInputData RunwayData
Visual Basic (Declaration)
Public RunwayData As RunwayBeamInputData
Visual C++
public:
RunwayBeamInputData^ RunwayData

See Also

Beam Class


SLSResultsBeam Field

[image]

ENGISSOL - EC3/8 Design Library
Beam..::.SLSResultsBeam Field
Beam Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSLSResults SLSResultsBeam
Visual Basic (Declaration)
Public SLSResultsBeam As BeamSLSResults
Visual C++
public:
BeamSLSResults^ SLSResultsBeam

See Also

Beam Class


TypeForDeflectionCheck Field

[image]

ENGISSOL - EC3/8 Design Library
Beam..::.TypeForDeflectionCheck Field
Beam Class See Also Send Feedback
EC3/8 Design Library
The Beam type, it can be NonAccessibleRoofs or AccesibleRoofsOrFloors

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamType TypeForDeflectionCheck
Visual Basic (Declaration)
Public TypeForDeflectionCheck As BeamType
Visual C++
public:
BeamType TypeForDeflectionCheck

See Also

Beam Class


Beam Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
Beam Methods
Beam Class See Also Send Feedback
EC3/8 Design Library

The Beam type exposes the following members.

Methods

Name | Description
Check | Performs the checks of the frame element for resistance and buckling and fills the corresponding Results objects (Inherited from FrameElement.)
Equals | (Inherited from FrameElement.)

See Also

Beam Class


Beam Properties

[image] [image]

ENGISSOL - EC3/8 Design Library
Beam Properties
Beam Class See Also Send Feedback
EC3/8 Design Library

The Beam type exposes the following members.

Properties

Name | Description
_Section | (Inherited from FrameElement.)

See Also

Beam Class


BeamDuctilityDesignParameters Class

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignParameters Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamDuctilityDesignParameters
Visual Basic (Declaration)
Public Class BeamDuctilityDesignParameters
Visual C++
public ref class BeamDuctilityDesignParameters

Inheritance Hierarchy

System..::.Object
EC3Design..::.BeamDuctilityDesignParameters

See Also

BeamDuctilityDesignParameters Members


BeamDuctilityDesignParameters Members

[image] [image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignParameters Members
BeamDuctilityDesignParameters Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The BeamDuctilityDesignParameters type exposes the following members.

Constructors

Name | Description
BeamDuctilityDesignParameters | Initializes a new instance of the BeamDuctilityDesignParameters class

Fields

Name | Description
InDissipativeZone_EdgeI |
InDissipativeZone_EdgeJ |
IsLinkELement |

See Also

BeamDuctilityDesignParameters Class


BeamDuctilityDesignParameters Constructor

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignParameters Constructor
BeamDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the BeamDuctilityDesignParameters class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamDuctilityDesignParameters()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamDuctilityDesignParameters()

See Also

BeamDuctilityDesignParameters Class


BeamDuctilityDesignParameters Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignParameters Fields
BeamDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

The BeamDuctilityDesignParameters type exposes the following members.

Fields

Name | Description
InDissipativeZone_EdgeI |
InDissipativeZone_EdgeJ |
IsLinkELement |

See Also

BeamDuctilityDesignParameters Class


InDissipativeZone_EdgeI Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignParameters..::.InDissipativeZone_EdgeI Field
BeamDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool InDissipativeZone_EdgeI
Visual Basic (Declaration)
Public InDissipativeZone_EdgeI As Boolean
Visual C++
public:
bool InDissipativeZone_EdgeI

See Also

BeamDuctilityDesignParameters Class


InDissipativeZone_EdgeJ Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignParameters..::.InDissipativeZone_EdgeJ Field
BeamDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool InDissipativeZone_EdgeJ
Visual Basic (Declaration)
Public InDissipativeZone_EdgeJ As Boolean
Visual C++
public:
bool InDissipativeZone_EdgeJ

See Also

BeamDuctilityDesignParameters Class


IsLinkELement Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignParameters..::.IsLinkELement Field
BeamDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLinkELement
Visual Basic (Declaration)
Public IsLinkELement As Boolean
Visual C++
public:
bool IsLinkELement

See Also

BeamDuctilityDesignParameters Class


BeamDuctilityDesignResults Class

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults Class
Members See Also Send Feedback
EC3/8 Design Library
Ducility design results regarding a beam

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamDuctilityDesignResults
Visual Basic (Declaration)
Public Class BeamDuctilityDesignResults
Visual C++
public ref class BeamDuctilityDesignResults

Inheritance Hierarchy

System..::.Object
EC3Design..::.BeamDuctilityDesignResults

See Also

BeamDuctilityDesignResults Members


BeamDuctilityDesignResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults Members
BeamDuctilityDesignResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The BeamDuctilityDesignResults type exposes the following members.

Constructors

Name | Description
BeamDuctilityDesignResults | Initializes a new instance of the BeamDuctilityDesignResults class

Fields

Name | Description
INode_AxialCheck_Satisfied | True, if check (6.3), paragraph 6.6.2(2) for starting node is satisfied, otherwise false
INode_Med | Design bending moment of starting node for use in check (6.2), paragraph 6.6.2(2)
INode_MomentCheck_Satisfied | True, if check (6.2), paragraph 6.6.2(2) for starting node is satisfied, otherwise false
INode_MRd | Bending moment design resistance of starting node for use in check (6.2), paragraph 6.6.2(2)
INode_Ned | Design axial force of starting node for use in check (6.3), paragraph 6.6.2(2)
INode_NRd | Shear force design resistance of starting node for use in check (6.4), paragraph 6.6.2(2)
INode_ShearCheck_Satisfied | True, if check (6.4), paragraph 6.6.2(2) for starting node is satisfied, otherwise false
INode_Ved | Design shear force of starting node for use in check (6.4), paragraph 6.6.2(2)
INode_VRd | Shear force design resistance of starting node for use in check (6.4), paragraph 6.6.2(2), according to formula (6.5)
JNode_AxialCheck_Satisfied | True, if check (6.3), paragraph 6.6.2(2) for ending node is satisfied, otherwise false
JNode_Med | Design bending moment of ending node for use in check (6.2), paragraph 6.6.2(2)
JNode_MomentCheck_Satisfied | True, if check (6.2), paragraph 6.6.2(2) for ending node is satisfied, otherwise false
JNode_MRd | Bending moment design resistance of ending node for use in check (6.2), paragraph 6.6.2(2)
JNode_Ned | Design axial force of ending node for use in check (6.3), paragraph 6.6.2(2)
JNode_NRd | Shear force design resistance of ending node for use in check (6.4), paragraph 6.6.2(2)
JNode_ShearCheck_Satisfied | True, if check (6.4), paragraph 6.6.2(2) for ending node is satisfied, otherwise false
JNode_Ved | Design shear force of ending node for use in check (6.4), paragraph 6.6.2(2)
JNode_VRd | Shear force design resistance of ending node for use in check (6.4), paragraph 6.6.2(2), according to formula (6.5)
MinOmega | Minimum omega value according to 6.7.4(1) for use in check 6.7.3(8)
OmegaCheckSatisfied | True, if check 6.7.3(8) is satisfied, otherwise false

See Also

BeamDuctilityDesignResults Class


BeamDuctilityDesignResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults Constructor
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the BeamDuctilityDesignResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamDuctilityDesignResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamDuctilityDesignResults()

See Also

BeamDuctilityDesignResults Class


BeamDuctilityDesignResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults Fields
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library

The BeamDuctilityDesignResults type exposes the following members.

Fields

Name | Description
INode_AxialCheck_Satisfied | True, if check (6.3), paragraph 6.6.2(2) for starting node is satisfied, otherwise false
INode_Med | Design bending moment of starting node for use in check (6.2), paragraph 6.6.2(2)
INode_MomentCheck_Satisfied | True, if check (6.2), paragraph 6.6.2(2) for starting node is satisfied, otherwise false
INode_MRd | Bending moment design resistance of starting node for use in check (6.2), paragraph 6.6.2(2)
INode_Ned | Design axial force of starting node for use in check (6.3), paragraph 6.6.2(2)
INode_NRd | Shear force design resistance of starting node for use in check (6.4), paragraph 6.6.2(2)
INode_ShearCheck_Satisfied | True, if check (6.4), paragraph 6.6.2(2) for starting node is satisfied, otherwise false
INode_Ved | Design shear force of starting node for use in check (6.4), paragraph 6.6.2(2)
INode_VRd | Shear force design resistance of starting node for use in check (6.4), paragraph 6.6.2(2), according to formula (6.5)
JNode_AxialCheck_Satisfied | True, if check (6.3), paragraph 6.6.2(2) for ending node is satisfied, otherwise false
JNode_Med | Design bending moment of ending node for use in check (6.2), paragraph 6.6.2(2)
JNode_MomentCheck_Satisfied | True, if check (6.2), paragraph 6.6.2(2) for ending node is satisfied, otherwise false
JNode_MRd | Bending moment design resistance of ending node for use in check (6.2), paragraph 6.6.2(2)
JNode_Ned | Design axial force of ending node for use in check (6.3), paragraph 6.6.2(2)
JNode_NRd | Shear force design resistance of ending node for use in check (6.4), paragraph 6.6.2(2)
JNode_ShearCheck_Satisfied | True, if check (6.4), paragraph 6.6.2(2) for ending node is satisfied, otherwise false
JNode_Ved | Design shear force of ending node for use in check (6.4), paragraph 6.6.2(2)
JNode_VRd | Shear force design resistance of ending node for use in check (6.4), paragraph 6.6.2(2), according to formula (6.5)
MinOmega | Minimum omega value according to 6.7.4(1) for use in check 6.7.3(8)
OmegaCheckSatisfied | True, if check 6.7.3(8) is satisfied, otherwise false

See Also

BeamDuctilityDesignResults Class


INode_AxialCheck_Satisfied Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.INode_AxialCheck_Satisfied Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check (6.3), paragraph 6.6.2(2) for starting node is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool INode_AxialCheck_Satisfied
Visual Basic (Declaration)
Public INode_AxialCheck_Satisfied As Boolean
Visual C++
public:
bool INode_AxialCheck_Satisfied

See Also

BeamDuctilityDesignResults Class


INode_Med Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.INode_Med Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Design bending moment of starting node for use in check (6.2), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double INode_Med
Visual Basic (Declaration)
Public INode_Med As Double
Visual C++
public:
double INode_Med

See Also

BeamDuctilityDesignResults Class


INode_MomentCheck_Satisfied Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.INode_MomentCheck_Satisfied Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check (6.2), paragraph 6.6.2(2) for starting node is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool INode_MomentCheck_Satisfied
Visual Basic (Declaration)
Public INode_MomentCheck_Satisfied As Boolean
Visual C++
public:
bool INode_MomentCheck_Satisfied

See Also

BeamDuctilityDesignResults Class


INode_MRd Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.INode_MRd Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Bending moment design resistance of starting node for use in check (6.2), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double INode_MRd
Visual Basic (Declaration)
Public INode_MRd As Double
Visual C++
public:
double INode_MRd

See Also

BeamDuctilityDesignResults Class


INode_Ned Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.INode_Ned Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Design axial force of starting node for use in check (6.3), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double INode_Ned
Visual Basic (Declaration)
Public INode_Ned As Double
Visual C++
public:
double INode_Ned

See Also

BeamDuctilityDesignResults Class


INode_NRd Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.INode_NRd Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Shear force design resistance of starting node for use in check (6.4), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double INode_NRd
Visual Basic (Declaration)
Public INode_NRd As Double
Visual C++
public:
double INode_NRd

See Also

BeamDuctilityDesignResults Class


INode_ShearCheck_Satisfied Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.INode_ShearCheck_Satisfied Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check (6.4), paragraph 6.6.2(2) for starting node is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool INode_ShearCheck_Satisfied
Visual Basic (Declaration)
Public INode_ShearCheck_Satisfied As Boolean
Visual C++
public:
bool INode_ShearCheck_Satisfied

See Also

BeamDuctilityDesignResults Class


INode_Ved Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.INode_Ved Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Design shear force of starting node for use in check (6.4), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double INode_Ved
Visual Basic (Declaration)
Public INode_Ved As Double
Visual C++
public:
double INode_Ved

See Also

BeamDuctilityDesignResults Class


INode_VRd Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.INode_VRd Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Shear force design resistance of starting node for use in check (6.4), paragraph 6.6.2(2), according to formula (6.5)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double INode_VRd
Visual Basic (Declaration)
Public INode_VRd As Double
Visual C++
public:
double INode_VRd

See Also

BeamDuctilityDesignResults Class


JNode_AxialCheck_Satisfied Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.JNode_AxialCheck_Satisfied Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check (6.3), paragraph 6.6.2(2) for ending node is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool JNode_AxialCheck_Satisfied
Visual Basic (Declaration)
Public JNode_AxialCheck_Satisfied As Boolean
Visual C++
public:
bool JNode_AxialCheck_Satisfied

See Also

BeamDuctilityDesignResults Class


JNode_Med Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.JNode_Med Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Design bending moment of ending node for use in check (6.2), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double JNode_Med
Visual Basic (Declaration)
Public JNode_Med As Double
Visual C++
public:
double JNode_Med

See Also

BeamDuctilityDesignResults Class


JNode_MomentCheck_Satisfied Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.JNode_MomentCheck_Satisfied Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check (6.2), paragraph 6.6.2(2) for ending node is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool JNode_MomentCheck_Satisfied
Visual Basic (Declaration)
Public JNode_MomentCheck_Satisfied As Boolean
Visual C++
public:
bool JNode_MomentCheck_Satisfied

See Also

BeamDuctilityDesignResults Class


JNode_MRd Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.JNode_MRd Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Bending moment design resistance of ending node for use in check (6.2), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double JNode_MRd
Visual Basic (Declaration)
Public JNode_MRd As Double
Visual C++
public:
double JNode_MRd

See Also

BeamDuctilityDesignResults Class


JNode_Ned Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.JNode_Ned Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Design axial force of ending node for use in check (6.3), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double JNode_Ned
Visual Basic (Declaration)
Public JNode_Ned As Double
Visual C++
public:
double JNode_Ned

See Also

BeamDuctilityDesignResults Class


JNode_NRd Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.JNode_NRd Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Shear force design resistance of ending node for use in check (6.4), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double JNode_NRd
Visual Basic (Declaration)
Public JNode_NRd As Double
Visual C++
public:
double JNode_NRd

See Also

BeamDuctilityDesignResults Class


JNode_ShearCheck_Satisfied Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.JNode_ShearCheck_Satisfied Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check (6.4), paragraph 6.6.2(2) for ending node is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool JNode_ShearCheck_Satisfied
Visual Basic (Declaration)
Public JNode_ShearCheck_Satisfied As Boolean
Visual C++
public:
bool JNode_ShearCheck_Satisfied

See Also

BeamDuctilityDesignResults Class


JNode_Ved Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.JNode_Ved Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Design shear force of ending node for use in check (6.4), paragraph 6.6.2(2)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double JNode_Ved
Visual Basic (Declaration)
Public JNode_Ved As Double
Visual C++
public:
double JNode_Ved

See Also

BeamDuctilityDesignResults Class


JNode_VRd Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.JNode_VRd Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Shear force design resistance of ending node for use in check (6.4), paragraph 6.6.2(2), according to formula (6.5)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double JNode_VRd
Visual Basic (Declaration)
Public JNode_VRd As Double
Visual C++
public:
double JNode_VRd

See Also

BeamDuctilityDesignResults Class


MinOmega Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.MinOmega Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Minimum omega value according to 6.7.4(1) for use in check 6.7.3(8)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MinOmega
Visual Basic (Declaration)
Public MinOmega As Double
Visual C++
public:
double MinOmega

See Also

BeamDuctilityDesignResults Class


OmegaCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
BeamDuctilityDesignResults..::.OmegaCheckSatisfied Field
BeamDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check 6.7.3(8) is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool OmegaCheckSatisfied
Visual Basic (Declaration)
Public OmegaCheckSatisfied As Boolean
Visual C++
public:
bool OmegaCheckSatisfied

See Also

BeamDuctilityDesignResults Class


BeamSLSResults Class

[image]

ENGISSOL - EC3/8 Design Library
BeamSLSResults Class
Members See Also Send Feedback
EC3/8 Design Library
Contains the SLS results for a frame element defined as beam

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSLSResults
Visual Basic (Declaration)
Public Class BeamSLSResults
Visual C++
public ref class BeamSLSResults

Remarks

Inheritance Hierarchy

System..::.Object
EC3Design..::.BeamSLSResults

See Also

BeamSLSResults Members


BeamSLSResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
BeamSLSResults Members
BeamSLSResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The BeamSLSResults type exposes the following members.

Constructors

Name | Description
BeamSLSResults | Initializes a new instance of the BeamSLSResults class

Fields

Name | Description
d2_limit |
dmax | d1+d2-Camper value
dmax_limit |

See Also

BeamSLSResults Class


BeamSLSResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
BeamSLSResults Constructor
BeamSLSResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the BeamSLSResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSLSResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSLSResults()

See Also

BeamSLSResults Class


BeamSLSResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
BeamSLSResults Fields
BeamSLSResults Class See Also Send Feedback
EC3/8 Design Library

The BeamSLSResults type exposes the following members.

Fields

Name | Description
d2_limit |
dmax | d1+d2-Camper value
dmax_limit |

See Also

BeamSLSResults Class


d2_limit Field

[image]

ENGISSOL - EC3/8 Design Library
BeamSLSResults..::.d2_limit Field
BeamSLSResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double d2_limit
Visual Basic (Declaration)
Public d2_limit As Double
Visual C++
public:
double d2_limit

See Also

BeamSLSResults Class


dmax Field

[image]

ENGISSOL - EC3/8 Design Library
BeamSLSResults..::.dmax Field
BeamSLSResults Class See Also Send Feedback
EC3/8 Design Library
d1+d2-Camper value

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double dmax
Visual Basic (Declaration)
Public dmax As Double
Visual C++
public:
double dmax

See Also

BeamSLSResults Class


dmax_limit Field

[image]

ENGISSOL - EC3/8 Design Library
BeamSLSResults..::.dmax_limit Field
BeamSLSResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double dmax_limit
Visual Basic (Declaration)
Public dmax_limit As Double
Visual C++
public:
double dmax_limit

See Also

BeamSLSResults Class


BeamType Enumeration

[image]

ENGISSOL - EC3/8 Design Library
BeamType Enumeration
See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum BeamType
Visual Basic (Declaration)
Public Enumeration BeamType
Visual C++
public enum class BeamType

Members

Member name | Description
NonAccessibleRoofs |
AccesibleRoofsOrFloors |

See Also

EC3Design Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


Brace Class

[image]

ENGISSOL - EC3/8 Design Library
Brace Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Brace : FrameElement
Visual Basic (Declaration)
Public Class Brace _
    Inherits FrameElement
Visual C++
public ref class Brace : public FrameElement

Inheritance Hierarchy

System..::.Object
EC3Design..::.FrameElement
EC3Design..::.Brace

See Also

Brace Members


Brace Members

[image] [image]

ENGISSOL - EC3/8 Design Library
Brace Members
Brace Class Constructors Methods Fields Properties See Also Send Feedback
EC3/8 Design Library

The Brace type exposes the following members.

Constructors

Name | Description
Brace | Construction of a brace object

Methods

Name | Description
Check | Performs the checks of the frame element for resistance and buckling and fills the corresponding Results objects (Inherited from FrameElement.)
Equals | (Inherited from FrameElement.)

Fields

Name | Description
DuctilityDesignParameters |
DuctilityDesignResults |
EndingNode | (Inherited from FrameElement.)
EndingReleaseRX | (Inherited from FrameElement.)
EndingReleaseRY | (Inherited from FrameElement.)
EndingReleaseRZ | (Inherited from FrameElement.)
EndingReleaseTX | (Inherited from FrameElement.)
EndingReleaseTY | (Inherited from FrameElement.)
EndingReleaseTZ | (Inherited from FrameElement.)
FrameResultsSets_DEAD_SLS | Dead load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_LIVE_SLS | Live load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_SLS | SLS combinations (Inherited from FrameElement.)
FrameResultsSets_ULS | ULS combinations (Inherited from FrameElement.)
ID | ID of Frame Element (Inherited from FrameElement.)
Length | Length of Frame Element (Inherited from FrameElement.)
Material | Material of Frame Element (Inherited from FrameElement.)
PointInPlaneXY | (Inherited from FrameElement.)
Section | Section of Frame Element (Inherited from FrameElement.)
SeismicOnlyLoads | Combinations with seismic-only loads included in seismic combination (Inherited from FrameElement.)
SeismicVericalLoads | Combination with vertical loads included in seismic combination (Inherited from FrameElement.)
StartingNode | (Inherited from FrameElement.)
StartingReleaseRX | (Inherited from FrameElement.)
StartingReleaseRY | (Inherited from FrameElement.)
StartingReleaseRZ | (Inherited from FrameElement.)
StartingReleaseTX | (Inherited from FrameElement.)
StartingReleaseTY | (Inherited from FrameElement.)
StartingReleaseTZ | (Inherited from FrameElement.)
Story | (Inherited from FrameElement.)
Type | (Inherited from FrameElement.)
za | Z coordinate of load application point on section (input) (Inherited from FrameElement.)

Properties

Name | Description
_Section | (Inherited from FrameElement.)

See Also

Brace Class


Brace Constructor

[image]

ENGISSOL - EC3/8 Design Library
Brace Constructor
Brace Class See Also Send Feedback
EC3/8 Design Library
Construction of a brace object

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brace(
    string _ID,
    double _Length,
    Object _Section,
    Material _Material,
    Node _StartingNode,
    Node _EndingNode
)
Visual Basic (Declaration)
Public Sub New ( _
    _ID As String, _
    _Length As Double, _
    _Section As Object, _
    _Material As Material, _
    _StartingNode As Node, _
    _EndingNode As Node _
)
Visual C++
public:
Brace(
    String^ _ID,
    double _Length,
    Object^ _Section,
    Material^ _Material,
    Node^ _StartingNode,
    Node^ _EndingNode
)

Parameters

_ID
Type: System..::.String
Brace ID
_Length
Type: System..::.Double
Length
_Section
Type: System..::.Object
Section object
_Material
Type: EC3Design..::.Material
Material object
_StartingNode
Type: EC3Design..::.Node
Starting node object
_EndingNode
Type: EC3Design..::.Node
Starting node object

See Also

Brace Class


Brace Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
Brace Fields
Brace Class See Also Send Feedback
EC3/8 Design Library

The Brace type exposes the following members.

Fields

Name | Description
DuctilityDesignParameters |
DuctilityDesignResults |
EndingNode | (Inherited from FrameElement.)
EndingReleaseRX | (Inherited from FrameElement.)
EndingReleaseRY | (Inherited from FrameElement.)
EndingReleaseRZ | (Inherited from FrameElement.)
EndingReleaseTX | (Inherited from FrameElement.)
EndingReleaseTY | (Inherited from FrameElement.)
EndingReleaseTZ | (Inherited from FrameElement.)
FrameResultsSets_DEAD_SLS | Dead load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_LIVE_SLS | Live load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_SLS | SLS combinations (Inherited from FrameElement.)
FrameResultsSets_ULS | ULS combinations (Inherited from FrameElement.)
ID | ID of Frame Element (Inherited from FrameElement.)
Length | Length of Frame Element (Inherited from FrameElement.)
Material | Material of Frame Element (Inherited from FrameElement.)
PointInPlaneXY | (Inherited from FrameElement.)
Section | Section of Frame Element (Inherited from FrameElement.)
SeismicOnlyLoads | Combinations with seismic-only loads included in seismic combination (Inherited from FrameElement.)
SeismicVericalLoads | Combination with vertical loads included in seismic combination (Inherited from FrameElement.)
StartingNode | (Inherited from FrameElement.)
StartingReleaseRX | (Inherited from FrameElement.)
StartingReleaseRY | (Inherited from FrameElement.)
StartingReleaseRZ | (Inherited from FrameElement.)
StartingReleaseTX | (Inherited from FrameElement.)
StartingReleaseTY | (Inherited from FrameElement.)
StartingReleaseTZ | (Inherited from FrameElement.)
Story | (Inherited from FrameElement.)
Type | (Inherited from FrameElement.)
za | Z coordinate of load application point on section (input) (Inherited from FrameElement.)

See Also

Brace Class


DuctilityDesignParameters Field

[image]

ENGISSOL - EC3/8 Design Library
Brace..::.DuctilityDesignParameters Field
Brace Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BraceDuctilityDesignParameters DuctilityDesignParameters
Visual Basic (Declaration)
Public DuctilityDesignParameters As BraceDuctilityDesignParameters
Visual C++
public:
BraceDuctilityDesignParameters^ DuctilityDesignParameters

See Also

Brace Class


DuctilityDesignResults Field

[image]

ENGISSOL - EC3/8 Design Library
Brace..::.DuctilityDesignResults Field
Brace Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DuctilityDesignResults DuctilityDesignResults
Visual Basic (Declaration)
Public DuctilityDesignResults As DuctilityDesignResults
Visual C++
public:
DuctilityDesignResults^ DuctilityDesignResults

See Also

Brace Class


Brace Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
Brace Methods
Brace Class See Also Send Feedback
EC3/8 Design Library

The Brace type exposes the following members.

Methods

Name | Description
Check | Performs the checks of the frame element for resistance and buckling and fills the corresponding Results objects (Inherited from FrameElement.)
Equals | (Inherited from FrameElement.)

See Also

Brace Class


Brace Properties

[image] [image]

ENGISSOL - EC3/8 Design Library
Brace Properties
Brace Class See Also Send Feedback
EC3/8 Design Library

The Brace type exposes the following members.

Properties

Name | Description
_Section | (Inherited from FrameElement.)

See Also

Brace Class


BraceDuctilityDesignParameters Class

[image]

ENGISSOL - EC3/8 Design Library
BraceDuctilityDesignParameters Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BraceDuctilityDesignParameters
Visual Basic (Declaration)
Public Class BraceDuctilityDesignParameters
Visual C++
public ref class BraceDuctilityDesignParameters

Inheritance Hierarchy

System..::.Object
EC3Design..::.BraceDuctilityDesignParameters

See Also

BraceDuctilityDesignParameters Members


BraceDuctilityDesignParameters Members

[image] [image]

ENGISSOL - EC3/8 Design Library
BraceDuctilityDesignParameters Members
BraceDuctilityDesignParameters Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The BraceDuctilityDesignParameters type exposes the following members.

Constructors

Name | Description
BraceDuctilityDesignParameters | Initializes a new instance of the BraceDuctilityDesignParameters class

Fields

Name | Description
ConcentricBrace |
EccentricBrace |
InDissipativeZone |
XBrace |

See Also

BraceDuctilityDesignParameters Class


BraceDuctilityDesignParameters Constructor

[image]

ENGISSOL - EC3/8 Design Library
BraceDuctilityDesignParameters Constructor
BraceDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the BraceDuctilityDesignParameters class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BraceDuctilityDesignParameters()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BraceDuctilityDesignParameters()

See Also

BraceDuctilityDesignParameters Class


BraceDuctilityDesignParameters Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
BraceDuctilityDesignParameters Fields
BraceDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

The BraceDuctilityDesignParameters type exposes the following members.

Fields

Name | Description
ConcentricBrace |
EccentricBrace |
InDissipativeZone |
XBrace |

See Also

BraceDuctilityDesignParameters Class


ConcentricBrace Field

[image]

ENGISSOL - EC3/8 Design Library
BraceDuctilityDesignParameters..::.ConcentricBrace Field
BraceDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ConcentricBrace
Visual Basic (Declaration)
Public ConcentricBrace As Boolean
Visual C++
public:
bool ConcentricBrace

See Also

BraceDuctilityDesignParameters Class


EccentricBrace Field

[image]

ENGISSOL - EC3/8 Design Library
BraceDuctilityDesignParameters..::.EccentricBrace Field
BraceDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool EccentricBrace
Visual Basic (Declaration)
Public EccentricBrace As Boolean
Visual C++
public:
bool EccentricBrace

See Also

BraceDuctilityDesignParameters Class


InDissipativeZone Field

[image]

ENGISSOL - EC3/8 Design Library
BraceDuctilityDesignParameters..::.InDissipativeZone Field
BraceDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool InDissipativeZone
Visual Basic (Declaration)
Public InDissipativeZone As Boolean
Visual C++
public:
bool InDissipativeZone

See Also

BraceDuctilityDesignParameters Class


XBrace Field

[image]

ENGISSOL - EC3/8 Design Library
BraceDuctilityDesignParameters..::.XBrace Field
BraceDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool XBrace
Visual Basic (Declaration)
Public XBrace As Boolean
Visual C++
public:
bool XBrace

See Also

BraceDuctilityDesignParameters Class


BucklingCheckResults Class

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BucklingCheckResults
Visual Basic (Declaration)
Public Class BucklingCheckResults
Visual C++
public ref class BucklingCheckResults

Inheritance Hierarchy

System..::.Object
EC3Design..::.BucklingCheckResults

See Also

BucklingCheckResults Members


BucklingCheckResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults Members
BucklingCheckResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The BucklingCheckResults type exposes the following members.

Constructors

Name | Description
BucklingCheckResults | Initializes a new instance of the BucklingCheckResults class

Fields

Name | Description
C1 | Coefficients for current moment diagram
C2 |
C3 |
DMy | Resulting additional moment about yy axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)
DMz | Resulting additional moment about zz axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)
EulerCriticalLoady | Critical axial load for flexural (Euler) buckling about yy axis
EulerCriticalLoadz | Critical axial load for flexural (Euler) buckling about zz axis
kyy | Interaction factors according to Table A1, Annex A - Method 1 (EC3, Part 1-1)
kyz |
kzy |
kzz |
M2 |
M3 | Internal forces that are used during the buckling resistance calculation
Ncompression |
NcrT | Critical axial load for torsional buckling
NcrTF | Critical axial load for torsional flexural buckling
Ratio1 | Capacity ratio of equation 6.61 for member subjected to compression and biaxial bending
Ratio2 | Capacity ratio of equation 6.62 for member subjected to compression and biaxial bending
RatioLateralTorsionalBucklingForCraneGirder | Interaction ratio of members subjected to combined bending and torsion
SectionClassY | Section class at the maximum moment point
SectionClassZ |
T_FT_Ratio | Capacity ratio against torsional and torsional flexural buckling under compression force Ncompression.
x_T_FT | Reduction factor for Torsional and flexural torsional buckling, only for open sections
xLT | Reduction factor for lateral torsional buckling under moment about yy axis
xy | Reduction factor x for flexural (Euler) buckling about yy axis
xz | Reduction factor x for flexural (Euler) buckling about zz axis

See Also

BucklingCheckResults Class


BucklingCheckResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults Constructor
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the BucklingCheckResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BucklingCheckResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BucklingCheckResults()

See Also

BucklingCheckResults Class


BucklingCheckResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults Fields
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library

The BucklingCheckResults type exposes the following members.

Fields

Name | Description
C1 | Coefficients for current moment diagram
C2 |
C3 |
DMy | Resulting additional moment about yy axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)
DMz | Resulting additional moment about zz axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)
EulerCriticalLoady | Critical axial load for flexural (Euler) buckling about yy axis
EulerCriticalLoadz | Critical axial load for flexural (Euler) buckling about zz axis
kyy | Interaction factors according to Table A1, Annex A - Method 1 (EC3, Part 1-1)
kyz |
kzy |
kzz |
M2 |
M3 | Internal forces that are used during the buckling resistance calculation
Ncompression |
NcrT | Critical axial load for torsional buckling
NcrTF | Critical axial load for torsional flexural buckling
Ratio1 | Capacity ratio of equation 6.61 for member subjected to compression and biaxial bending
Ratio2 | Capacity ratio of equation 6.62 for member subjected to compression and biaxial bending
RatioLateralTorsionalBucklingForCraneGirder | Interaction ratio of members subjected to combined bending and torsion
SectionClassY | Section class at the maximum moment point
SectionClassZ |
T_FT_Ratio | Capacity ratio against torsional and torsional flexural buckling under compression force Ncompression.
x_T_FT | Reduction factor for Torsional and flexural torsional buckling, only for open sections
xLT | Reduction factor for lateral torsional buckling under moment about yy axis
xy | Reduction factor x for flexural (Euler) buckling about yy axis
xz | Reduction factor x for flexural (Euler) buckling about zz axis

See Also

BucklingCheckResults Class


C1 Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.C1 Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Coefficients for current moment diagram

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double C1
Visual Basic (Declaration)
Public C1 As Double
Visual C++
public:
double C1

See Also

BucklingCheckResults Class


C2 Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.C2 Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double C2
Visual Basic (Declaration)
Public C2 As Double
Visual C++
public:
double C2

See Also

BucklingCheckResults Class


C3 Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.C3 Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double C3
Visual Basic (Declaration)
Public C3 As Double
Visual C++
public:
double C3

See Also

BucklingCheckResults Class


DMy Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.DMy Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Resulting additional moment about yy axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DMy
Visual Basic (Declaration)
Public DMy As Double
Visual C++
public:
double DMy

See Also

BucklingCheckResults Class


DMz Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.DMz Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Resulting additional moment about zz axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DMz
Visual Basic (Declaration)
Public DMz As Double
Visual C++
public:
double DMz

See Also

BucklingCheckResults Class


EulerCriticalLoady Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.EulerCriticalLoady Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Critical axial load for flexural (Euler) buckling about yy axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double EulerCriticalLoady
Visual Basic (Declaration)
Public EulerCriticalLoady As Double
Visual C++
public:
double EulerCriticalLoady

See Also

BucklingCheckResults Class


EulerCriticalLoadz Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.EulerCriticalLoadz Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Critical axial load for flexural (Euler) buckling about zz axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double EulerCriticalLoadz
Visual Basic (Declaration)
Public EulerCriticalLoadz As Double
Visual C++
public:
double EulerCriticalLoadz

See Also

BucklingCheckResults Class


kyy Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.kyy Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Interaction factors according to Table A1, Annex A - Method 1 (EC3, Part 1-1)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double kyy
Visual Basic (Declaration)
Public kyy As Double
Visual C++
public:
double kyy

See Also

BucklingCheckResults Class


kyz Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.kyz Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double kyz
Visual Basic (Declaration)
Public kyz As Double
Visual C++
public:
double kyz

See Also

BucklingCheckResults Class


kzy Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.kzy Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double kzy
Visual Basic (Declaration)
Public kzy As Double
Visual C++
public:
double kzy

See Also

BucklingCheckResults Class


kzz Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.kzz Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double kzz
Visual Basic (Declaration)
Public kzz As Double
Visual C++
public:
double kzz

See Also

BucklingCheckResults Class


M2 Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.M2 Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double M2
Visual Basic (Declaration)
Public M2 As Double
Visual C++
public:
double M2

See Also

BucklingCheckResults Class


M3 Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.M3 Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Internal forces that are used during the buckling resistance calculation

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double M3
Visual Basic (Declaration)
Public M3 As Double
Visual C++
public:
double M3

See Also

BucklingCheckResults Class


Ncompression Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.Ncompression Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ncompression
Visual Basic (Declaration)
Public Ncompression As Double
Visual C++
public:
double Ncompression

See Also

BucklingCheckResults Class


NcrT Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.NcrT Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Critical axial load for torsional buckling

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double NcrT
Visual Basic (Declaration)
Public NcrT As Double
Visual C++
public:
double NcrT

See Also

BucklingCheckResults Class


NcrTF Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.NcrTF Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Critical axial load for torsional flexural buckling

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double NcrTF
Visual Basic (Declaration)
Public NcrTF As Double
Visual C++
public:
double NcrTF

See Also

BucklingCheckResults Class


Ratio1 Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.Ratio1 Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Capacity ratio of equation 6.61 for member subjected to compression and biaxial bending

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ratio1
Visual Basic (Declaration)
Public Ratio1 As Double
Visual C++
public:
double Ratio1

See Also

BucklingCheckResults Class


Ratio2 Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.Ratio2 Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Capacity ratio of equation 6.62 for member subjected to compression and biaxial bending

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ratio2
Visual Basic (Declaration)
Public Ratio2 As Double
Visual C++
public:
double Ratio2

See Also

BucklingCheckResults Class


RatioLateralTorsionalBucklingForCraneGirder Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.RatioLateralTorsionalBucklingForCraneGirder Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Interaction ratio of members subjected to combined bending and torsion

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RatioLateralTorsionalBucklingForCraneGirder
Visual Basic (Declaration)
Public RatioLateralTorsionalBucklingForCraneGirder As Double
Visual C++
public:
double RatioLateralTorsionalBucklingForCraneGirder

Remarks

For use in runway beams only [Annex A, EN 1993-6]

See Also

BucklingCheckResults Class


SectionClassY Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.SectionClassY Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Section class at the maximum moment point

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int SectionClassY
Visual Basic (Declaration)
Public SectionClassY As Integer
Visual C++
public:
int SectionClassY

See Also

BucklingCheckResults Class


SectionClassZ Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.SectionClassZ Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int SectionClassZ
Visual Basic (Declaration)
Public SectionClassZ As Integer
Visual C++
public:
int SectionClassZ

See Also

BucklingCheckResults Class


T_FT_Ratio Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.T_FT_Ratio Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Capacity ratio against torsional and torsional flexural buckling under compression force Ncompression.

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double T_FT_Ratio
Visual Basic (Declaration)
Public T_FT_Ratio As Double
Visual C++
public:
double T_FT_Ratio

See Also

BucklingCheckResults Class


x_T_FT Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.x_T_FT Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Reduction factor for Torsional and flexural torsional buckling, only for open sections

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double x_T_FT
Visual Basic (Declaration)
Public x_T_FT As Double
Visual C++
public:
double x_T_FT

See Also

BucklingCheckResults Class


xLT Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.xLT Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Reduction factor for lateral torsional buckling under moment about yy axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double xLT
Visual Basic (Declaration)
Public xLT As Double
Visual C++
public:
double xLT

See Also

BucklingCheckResults Class


xy Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.xy Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Reduction factor x for flexural (Euler) buckling about yy axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double xy
Visual Basic (Declaration)
Public xy As Double
Visual C++
public:
double xy

See Also

BucklingCheckResults Class


xz Field

[image]

ENGISSOL - EC3/8 Design Library
BucklingCheckResults..::.xz Field
BucklingCheckResults Class See Also Send Feedback
EC3/8 Design Library
Reduction factor x for flexural (Euler) buckling about zz axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double xz
Visual Basic (Declaration)
Public xz As Double
Visual C++
public:
double xz

See Also

BucklingCheckResults Class


Column Class

[image]

ENGISSOL - EC3/8 Design Library
Column Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Column : FrameElement
Visual Basic (Declaration)
Public Class Column _
    Inherits FrameElement
Visual C++
public ref class Column : public FrameElement

Inheritance Hierarchy

System..::.Object
EC3Design..::.FrameElement
EC3Design..::.Column

See Also

Column Members


Column Members

[image] [image]

ENGISSOL - EC3/8 Design Library
Column Members
Column Class Constructors Methods Fields Properties See Also Send Feedback
EC3/8 Design Library

The Column type exposes the following members.

Constructors

Name | Description
Column | Construction of a column object

Methods

Name | Description
Check | Performs the checks of the frame element for resistance and buckling and fills the corresponding Results objects (Inherited from FrameElement.)
Equals | (Inherited from FrameElement.)

Fields

Name | Description
BracedAboutMajorAxis | Has to be set true, if the column is braced about its major axis (in xz local system)
BracedAboutMinorAxis | Has to be set true, if the column is braced about its minor axis (in xy local system)
DuctilityDesignParameters |
DuctilityDesignResults |
EndingNode | (Inherited from FrameElement.)
EndingReleaseRX | (Inherited from FrameElement.)
EndingReleaseRY | (Inherited from FrameElement.)
EndingReleaseRZ | (Inherited from FrameElement.)
EndingReleaseTX | (Inherited from FrameElement.)
EndingReleaseTY | (Inherited from FrameElement.)
EndingReleaseTZ | (Inherited from FrameElement.)
FrameResultsSets_DEAD_SLS | Dead load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_LIVE_SLS | Live load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_SLS | SLS combinations (Inherited from FrameElement.)
FrameResultsSets_ULS | ULS combinations (Inherited from FrameElement.)
ID | ID of Frame Element (Inherited from FrameElement.)
Length | Length of Frame Element (Inherited from FrameElement.)
Material | Material of Frame Element (Inherited from FrameElement.)
PointInPlaneXY | (Inherited from FrameElement.)
Section | Section of Frame Element (Inherited from FrameElement.)
SeismicOnlyLoads | Combinations with seismic-only loads included in seismic combination (Inherited from FrameElement.)
SeismicVericalLoads | Combination with vertical loads included in seismic combination (Inherited from FrameElement.)
StartingNode | (Inherited from FrameElement.)
StartingReleaseRX | (Inherited from FrameElement.)
StartingReleaseRY | (Inherited from FrameElement.)
StartingReleaseRZ | (Inherited from FrameElement.)
StartingReleaseTX | (Inherited from FrameElement.)
StartingReleaseTY | (Inherited from FrameElement.)
StartingReleaseTZ | (Inherited from FrameElement.)
Story | (Inherited from FrameElement.)
Type | (Inherited from FrameElement.)
za | Z coordinate of load application point on section (input) (Inherited from FrameElement.)

Properties

Name | Description
_Section | (Inherited from FrameElement.)

See Also

Column Class


Column Constructor

[image]

ENGISSOL - EC3/8 Design Library
Column Constructor
Column Class See Also Send Feedback
EC3/8 Design Library
Construction of a column object

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Column(
    string _ID,
    double _Length,
    Object _Section,
    Material _Material,
    Node _StartingNode,
    Node _EndingNode,
    bool _BracedAboutMajorAxis,
    bool _BracedAboutMinorAxis
)
Visual Basic (Declaration)
Public Sub New ( _
    _ID As String, _
    _Length As Double, _
    _Section As Object, _
    _Material As Material, _
    _StartingNode As Node, _
    _EndingNode As Node, _
    _BracedAboutMajorAxis As Boolean, _
    _BracedAboutMinorAxis As Boolean _
)
Visual C++
public:
Column(
    String^ _ID,
    double _Length,
    Object^ _Section,
    Material^ _Material,
    Node^ _StartingNode,
    Node^ _EndingNode,
    bool _BracedAboutMajorAxis,
    bool _BracedAboutMinorAxis
)

Parameters

_ID
Type: System..::.String
Column ID
_Length
Type: System..::.Double
Length
_Section
Type: System..::.Object
Section object
_Material
Type: EC3Design..::.Material
Material object
_StartingNode
Type: EC3Design..::.Node
Starting node object
_EndingNode
Type: EC3Design..::.Node
Starting node object
_BracedAboutMajorAxis
Type: System..::.Boolean
Has to be set true, if the column is braced about its major axis (in xz local system)
_BracedAboutMinorAxis
Type: System..::.Boolean
Has to be set true, if the column is braced about its minor axis (in xy local system)

See Also

Column Class


Column Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
Column Fields
Column Class See Also Send Feedback
EC3/8 Design Library

The Column type exposes the following members.

Fields

Name | Description
BracedAboutMajorAxis | Has to be set true, if the column is braced about its major axis (in xz local system)
BracedAboutMinorAxis | Has to be set true, if the column is braced about its minor axis (in xy local system)
DuctilityDesignParameters |
DuctilityDesignResults |
EndingNode | (Inherited from FrameElement.)
EndingReleaseRX | (Inherited from FrameElement.)
EndingReleaseRY | (Inherited from FrameElement.)
EndingReleaseRZ | (Inherited from FrameElement.)
EndingReleaseTX | (Inherited from FrameElement.)
EndingReleaseTY | (Inherited from FrameElement.)
EndingReleaseTZ | (Inherited from FrameElement.)
FrameResultsSets_DEAD_SLS | Dead load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_LIVE_SLS | Live load combinations included in each SLS combination (Inherited from FrameElement.)
FrameResultsSets_SLS | SLS combinations (Inherited from FrameElement.)
FrameResultsSets_ULS | ULS combinations (Inherited from FrameElement.)
ID | ID of Frame Element (Inherited from FrameElement.)
Length | Length of Frame Element (Inherited from FrameElement.)
Material | Material of Frame Element (Inherited from FrameElement.)
PointInPlaneXY | (Inherited from FrameElement.)
Section | Section of Frame Element (Inherited from FrameElement.)
SeismicOnlyLoads | Combinations with seismic-only loads included in seismic combination (Inherited from FrameElement.)
SeismicVericalLoads | Combination with vertical loads included in seismic combination (Inherited from FrameElement.)
StartingNode | (Inherited from FrameElement.)
StartingReleaseRX | (Inherited from FrameElement.)
StartingReleaseRY | (Inherited from FrameElement.)
StartingReleaseRZ | (Inherited from FrameElement.)
StartingReleaseTX | (Inherited from FrameElement.)
StartingReleaseTY | (Inherited from FrameElement.)
StartingReleaseTZ | (Inherited from FrameElement.)
Story | (Inherited from FrameElement.)
Type | (Inherited from FrameElement.)
za | Z coordinate of load application point on section (input) (Inherited from FrameElement.)

See Also

Column Class


BracedAboutMajorAxis Field

[image]

ENGISSOL - EC3/8 Design Library
Column..::.BracedAboutMajorAxis Field
Column Class See Also Send Feedback
EC3/8 Design Library
Has to be set true, if the column is braced about its major axis (in xz local system)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool BracedAboutMajorAxis
Visual Basic (Declaration)
Public BracedAboutMajorAxis As Boolean
Visual C++
public:
bool BracedAboutMajorAxis

Remarks

See Also

Column Class


BracedAboutMinorAxis Field

[image]

ENGISSOL - EC3/8 Design Library
Column..::.BracedAboutMinorAxis Field
Column Class See Also Send Feedback
EC3/8 Design Library
Has to be set true, if the column is braced about its minor axis (in xy local system)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool BracedAboutMinorAxis
Visual Basic (Declaration)
Public BracedAboutMinorAxis As Boolean
Visual C++
public:
bool BracedAboutMinorAxis

Remarks

See Also

Column Class


DuctilityDesignParameters Field

[image]

ENGISSOL - EC3/8 Design Library
Column..::.DuctilityDesignParameters Field
Column Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColumnDuctilityDesignParameters DuctilityDesignParameters
Visual Basic (Declaration)
Public DuctilityDesignParameters As ColumnDuctilityDesignParameters
Visual C++
public:
ColumnDuctilityDesignParameters^ DuctilityDesignParameters

See Also

Column Class


DuctilityDesignResults Field

[image]

ENGISSOL - EC3/8 Design Library
Column..::.DuctilityDesignResults Field
Column Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColumnDuctilityDesignResults DuctilityDesignResults
Visual Basic (Declaration)
Public DuctilityDesignResults As ColumnDuctilityDesignResults
Visual C++
public:
ColumnDuctilityDesignResults^ DuctilityDesignResults

See Also

Column Class


Column Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
Column Methods
Column Class See Also Send Feedback
EC3/8 Design Library

The Column type exposes the following members.

Methods

Name | Description
Check | Performs the checks of the frame element for resistance and buckling and fills the corresponding Results objects (Inherited from FrameElement.)
Equals | (Inherited from FrameElement.)

See Also

Column Class


Column Properties

[image] [image]

ENGISSOL - EC3/8 Design Library
Column Properties
Column Class See Also Send Feedback
EC3/8 Design Library

The Column type exposes the following members.

Properties

Name | Description
_Section | (Inherited from FrameElement.)

See Also

Column Class


ColumnDuctilityDesignParameters Class

[image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignParameters Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColumnDuctilityDesignParameters
Visual Basic (Declaration)
Public Class ColumnDuctilityDesignParameters
Visual C++
public ref class ColumnDuctilityDesignParameters

Inheritance Hierarchy

System..::.Object
EC3Design..::.ColumnDuctilityDesignParameters

See Also

ColumnDuctilityDesignParameters Members


ColumnDuctilityDesignParameters Members

[image] [image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignParameters Members
ColumnDuctilityDesignParameters Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The ColumnDuctilityDesignParameters type exposes the following members.

Constructors

Name | Description
ColumnDuctilityDesignParameters | Initializes a new instance of the ColumnDuctilityDesignParameters class

Fields

Name | Description
InDissipativeZone |
IsLinkElement |

See Also

ColumnDuctilityDesignParameters Class


ColumnDuctilityDesignParameters Constructor

[image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignParameters Constructor
ColumnDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the ColumnDuctilityDesignParameters class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColumnDuctilityDesignParameters()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColumnDuctilityDesignParameters()

See Also

ColumnDuctilityDesignParameters Class


ColumnDuctilityDesignParameters Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignParameters Fields
ColumnDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

The ColumnDuctilityDesignParameters type exposes the following members.

Fields

Name | Description
InDissipativeZone |
IsLinkElement |

See Also

ColumnDuctilityDesignParameters Class


InDissipativeZone Field

[image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignParameters..::.InDissipativeZone Field
ColumnDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool InDissipativeZone
Visual Basic (Declaration)
Public InDissipativeZone As Boolean
Visual C++
public:
bool InDissipativeZone

See Also

ColumnDuctilityDesignParameters Class


IsLinkElement Field

[image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignParameters..::.IsLinkElement Field
ColumnDuctilityDesignParameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLinkElement
Visual Basic (Declaration)
Public IsLinkElement As Boolean
Visual C++
public:
bool IsLinkElement

See Also

ColumnDuctilityDesignParameters Class


ColumnDuctilityDesignResults Class

[image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignResults Class
Members See Also Send Feedback
EC3/8 Design Library
Ducility design results regarding a column

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColumnDuctilityDesignResults
Visual Basic (Declaration)
Public Class ColumnDuctilityDesignResults
Visual C++
public ref class ColumnDuctilityDesignResults

Inheritance Hierarchy

System..::.Object
EC3Design..::.ColumnDuctilityDesignResults

See Also

ColumnDuctilityDesignResults Members


ColumnDuctilityDesignResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignResults Members
ColumnDuctilityDesignResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The ColumnDuctilityDesignResults type exposes the following members.

Constructors

Name | Description
ColumnDuctilityDesignResults | Initializes a new instance of the ColumnDuctilityDesignResults class

Fields

Name | Description
MinOmega | Minimum omega value according to 6.7.4(1) for use in check 6.7.3(8)
OmegaCheckSatisfied | True, if check 6.7.3(8) is satisfied, otherwise false

See Also

ColumnDuctilityDesignResults Class


ColumnDuctilityDesignResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignResults Constructor
ColumnDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the ColumnDuctilityDesignResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColumnDuctilityDesignResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColumnDuctilityDesignResults()

See Also

ColumnDuctilityDesignResults Class


ColumnDuctilityDesignResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignResults Fields
ColumnDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library

The ColumnDuctilityDesignResults type exposes the following members.

Fields

Name | Description
MinOmega | Minimum omega value according to 6.7.4(1) for use in check 6.7.3(8)
OmegaCheckSatisfied | True, if check 6.7.3(8) is satisfied, otherwise false

See Also

ColumnDuctilityDesignResults Class


MinOmega Field

[image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignResults..::.MinOmega Field
ColumnDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Minimum omega value according to 6.7.4(1) for use in check 6.7.3(8)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MinOmega
Visual Basic (Declaration)
Public MinOmega As Double
Visual C++
public:
double MinOmega

See Also

ColumnDuctilityDesignResults Class


OmegaCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
ColumnDuctilityDesignResults..::.OmegaCheckSatisfied Field
ColumnDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check 6.7.3(8) is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool OmegaCheckSatisfied
Visual Basic (Declaration)
Public OmegaCheckSatisfied As Boolean
Visual C++
public:
bool OmegaCheckSatisfied

See Also

ColumnDuctilityDesignResults Class


DuctileMomentResistingJoint Class

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint Class
Members See Also Send Feedback
EC3/8 Design Library
A joint object containing joints to be designed with ductility demands regarding moment resisting frames

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DuctileMomentResistingJoint
Visual Basic (Declaration)
Public Class DuctileMomentResistingJoint
Visual C++
public ref class DuctileMomentResistingJoint

Remarks

Inheritance Hierarchy

System..::.Object
EC3Design..::.DuctileMomentResistingJoint

See Also

DuctileMomentResistingJoint Members


DuctileMomentResistingJoint Members

[image] [image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint Members
DuctileMomentResistingJoint Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The DuctileMomentResistingJoint type exposes the following members.

Constructors

Name | Description
DuctileMomentResistingJoint | Initializes a new instance of the DuctileMomentResistingJoint class

Fields

Name | Description
BaseJoint |
BeamResistancesAboutGlobalXAxis |
BeamResistancesAboutGlobalYAxis |
Beams |
ColumnBelow |
ColumnUp |
DuctilityDesignResults |
Node |
TopJoint |

See Also

DuctileMomentResistingJoint Class


DuctileMomentResistingJoint Constructor

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint Constructor
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the DuctileMomentResistingJoint class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DuctileMomentResistingJoint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DuctileMomentResistingJoint()

See Also

DuctileMomentResistingJoint Class


DuctileMomentResistingJoint Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint Fields
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

The DuctileMomentResistingJoint type exposes the following members.

Fields

Name | Description
BaseJoint |
BeamResistancesAboutGlobalXAxis |
BeamResistancesAboutGlobalYAxis |
Beams |
ColumnBelow |
ColumnUp |
DuctilityDesignResults |
Node |
TopJoint |

See Also

DuctileMomentResistingJoint Class


BaseJoint Field

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint..::.BaseJoint Field
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool BaseJoint
Visual Basic (Declaration)
Public BaseJoint As Boolean
Visual C++
public:
bool BaseJoint

See Also

DuctileMomentResistingJoint Class


BeamResistancesAboutGlobalXAxis Field

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint..::.BeamResistancesAboutGlobalXAxis Field
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamResistancesAboutGlobalXAxis
Visual Basic (Declaration)
Public BeamResistancesAboutGlobalXAxis As Double
Visual C++
public:
double BeamResistancesAboutGlobalXAxis

See Also

DuctileMomentResistingJoint Class


BeamResistancesAboutGlobalYAxis Field

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint..::.BeamResistancesAboutGlobalYAxis Field
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamResistancesAboutGlobalYAxis
Visual Basic (Declaration)
Public BeamResistancesAboutGlobalYAxis As Double
Visual C++
public:
double BeamResistancesAboutGlobalYAxis

See Also

DuctileMomentResistingJoint Class


Beams Field

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint..::.Beams Field
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<Beam> Beams
Visual Basic (Declaration)
Public Beams As List(Of Beam)
Visual C++
public:
List<Beam^>^ Beams

See Also

DuctileMomentResistingJoint Class


ColumnBelow Field

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint..::.ColumnBelow Field
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Column ColumnBelow
Visual Basic (Declaration)
Public ColumnBelow As Column
Visual C++
public:
Column^ ColumnBelow

See Also

DuctileMomentResistingJoint Class


ColumnUp Field

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint..::.ColumnUp Field
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Column ColumnUp
Visual Basic (Declaration)
Public ColumnUp As Column
Visual C++
public:
Column^ ColumnUp

See Also

DuctileMomentResistingJoint Class


DuctilityDesignResults Field

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint..::.DuctilityDesignResults Field
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public JointDuctilityDesignResults DuctilityDesignResults
Visual Basic (Declaration)
Public DuctilityDesignResults As JointDuctilityDesignResults
Visual C++
public:
JointDuctilityDesignResults^ DuctilityDesignResults

See Also

DuctileMomentResistingJoint Class


Node Field

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint..::.Node Field
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Node Node
Visual Basic (Declaration)
Public Node As Node
Visual C++
public:
Node^ Node

See Also

DuctileMomentResistingJoint Class


TopJoint Field

[image]

ENGISSOL - EC3/8 Design Library
DuctileMomentResistingJoint..::.TopJoint Field
DuctileMomentResistingJoint Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool TopJoint
Visual Basic (Declaration)
Public TopJoint As Boolean
Visual C++
public:
bool TopJoint

See Also

DuctileMomentResistingJoint Class


DuctilityDesignResults Class

[image]

ENGISSOL - EC3/8 Design Library
DuctilityDesignResults Class
Members See Also Send Feedback
EC3/8 Design Library
Ducility design results regarding a brace

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DuctilityDesignResults
Visual Basic (Declaration)
Public Class DuctilityDesignResults
Visual C++
public ref class DuctilityDesignResults

Inheritance Hierarchy

System..::.Object
EC3Design..::.DuctilityDesignResults

See Also

DuctilityDesignResults Members


DuctilityDesignResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
DuctilityDesignResults Members
DuctilityDesignResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The DuctilityDesignResults type exposes the following members.

Constructors

Name | Description
DuctilityDesignResults | Initializes a new instance of the DuctilityDesignResults class

Fields

Name | Description
MaxOmega | Maximum omega value according to 6.7.4(1) for use in check 6.7.3(8)
MinOmega | Minimum omega value according to 6.7.4(1) for use in check 6.7.3(8)
NonDimLamda | Non dimensional slenderness for use in check 6.7.3(1) for X diagonal bracings
NonDimLamdaCheckSatisfied | True, if check 6.7.3(1),(2) for diagonal bracings is satisfied, otherwise false
OmegaCheckSatisfied | True, if check 6.7.3(8) is satisfied, otherwise false

See Also

DuctilityDesignResults Class


DuctilityDesignResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
DuctilityDesignResults Constructor
DuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the DuctilityDesignResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DuctilityDesignResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DuctilityDesignResults()

See Also

DuctilityDesignResults Class


DuctilityDesignResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
DuctilityDesignResults Fields
DuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library

The DuctilityDesignResults type exposes the following members.

Fields

Name | Description
MaxOmega | Maximum omega value according to 6.7.4(1) for use in check 6.7.3(8)
MinOmega | Minimum omega value according to 6.7.4(1) for use in check 6.7.3(8)
NonDimLamda | Non dimensional slenderness for use in check 6.7.3(1) for X diagonal bracings
NonDimLamdaCheckSatisfied | True, if check 6.7.3(1),(2) for diagonal bracings is satisfied, otherwise false
OmegaCheckSatisfied | True, if check 6.7.3(8) is satisfied, otherwise false

See Also

DuctilityDesignResults Class


MaxOmega Field

[image]

ENGISSOL - EC3/8 Design Library
DuctilityDesignResults..::.MaxOmega Field
DuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Maximum omega value according to 6.7.4(1) for use in check 6.7.3(8)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MaxOmega
Visual Basic (Declaration)
Public MaxOmega As Double
Visual C++
public:
double MaxOmega

See Also

DuctilityDesignResults Class


MinOmega Field

[image]

ENGISSOL - EC3/8 Design Library
DuctilityDesignResults..::.MinOmega Field
DuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Minimum omega value according to 6.7.4(1) for use in check 6.7.3(8)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MinOmega
Visual Basic (Declaration)
Public MinOmega As Double
Visual C++
public:
double MinOmega

See Also

DuctilityDesignResults Class


NonDimLamda Field

[image]

ENGISSOL - EC3/8 Design Library
DuctilityDesignResults..::.NonDimLamda Field
DuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Non dimensional slenderness for use in check 6.7.3(1) for X diagonal bracings

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double NonDimLamda
Visual Basic (Declaration)
Public NonDimLamda As Double
Visual C++
public:
double NonDimLamda

See Also

DuctilityDesignResults Class


NonDimLamdaCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
DuctilityDesignResults..::.NonDimLamdaCheckSatisfied Field
DuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check 6.7.3(1),(2) for diagonal bracings is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool NonDimLamdaCheckSatisfied
Visual Basic (Declaration)
Public NonDimLamdaCheckSatisfied As Boolean
Visual C++
public:
bool NonDimLamdaCheckSatisfied

See Also

DuctilityDesignResults Class


OmegaCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
DuctilityDesignResults..::.OmegaCheckSatisfied Field
DuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check 6.7.3(8) is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool OmegaCheckSatisfied
Visual Basic (Declaration)
Public OmegaCheckSatisfied As Boolean
Visual C++
public:
bool OmegaCheckSatisfied

See Also

DuctilityDesignResults Class


FrameElement Class

[image]

ENGISSOL - EC3/8 Design Library
FrameElement Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class FrameElement
Visual Basic (Declaration)
Public MustInherit Class FrameElement
Visual C++
public ref class FrameElement abstract

Inheritance Hierarchy

System..::.Object
EC3Design..::.FrameElement
EC3Design..::.Beam
EC3Design..::.Brace
EC3Design..::.Column

See Also

FrameElement Members


FrameElement Members

[image] [image]

ENGISSOL - EC3/8 Design Library
FrameElement Members
FrameElement Class Constructors Methods Fields Properties See Also Send Feedback
EC3/8 Design Library

The FrameElement type exposes the following members.

Constructors

Name | Description
FrameElement | Initialization of a frame element

Methods

Name | Description
Check | Performs the checks of the frame element for resistance and buckling and fills the corresponding Results objects
Equals | (Overrides Object..::.Equals(Object).)

Fields

Name | Description
EndingNode |
EndingReleaseRX |
EndingReleaseRY |
EndingReleaseRZ |
EndingReleaseTX |
EndingReleaseTY |
EndingReleaseTZ |
FrameResultsSets_DEAD_SLS | Dead load combinations included in each SLS combination
FrameResultsSets_LIVE_SLS | Live load combinations included in each SLS combination
FrameResultsSets_SLS | SLS combinations
FrameResultsSets_ULS | ULS combinations
ID | ID of Frame Element
Length | Length of Frame Element
Material | Material of Frame Element
PointInPlaneXY |
Section | Section of Frame Element
SeismicOnlyLoads | Combinations with seismic-only loads included in seismic combination
SeismicVericalLoads | Combination with vertical loads included in seismic combination
StartingNode |
StartingReleaseRX |
StartingReleaseRY |
StartingReleaseRZ |
StartingReleaseTX |
StartingReleaseTY |
StartingReleaseTZ |
Story |
Type |
za | Z coordinate of load application point on section (input)

Properties

Name | Description
_Section |

See Also

FrameElement Class


FrameElement Constructor

[image]

ENGISSOL - EC3/8 Design Library
FrameElement Constructor
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Initialization of a frame element

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FrameElement(
    string _ID,
    double _Length,
    Object __Section,
    Material _Material,
    Node _StartingNode,
    Node _EndingNode
)
Visual Basic (Declaration)
Public Sub New ( _
    _ID As String, _
    _Length As Double, _
    __Section As Object, _
    _Material As Material, _
    _StartingNode As Node, _
    _EndingNode As Node _
)
Visual C++
public:
FrameElement(
    String^ _ID,
    double _Length,
    Object^ __Section,
    Material^ _Material,
    Node^ _StartingNode,
    Node^ _EndingNode
)

Parameters

_ID
Type: System..::.String
ID of the frame element
_Length
Type: System..::.Double
Length
__Section
Type: System..::.Object
The Section object to assign to the frame element, eg a HSection object
_Material
Type: EC3Design..::.Material
The Material object to assign to the frame element
_StartingNode
Type: EC3Design..::.Node
Starting node
_EndingNode
Type: EC3Design..::.Node
Ending node

See Also

FrameElement Class


FrameElement Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
FrameElement Fields
FrameElement Class See Also Send Feedback
EC3/8 Design Library

The FrameElement type exposes the following members.

Fields

Name | Description
EndingNode |
EndingReleaseRX |
EndingReleaseRY |
EndingReleaseRZ |
EndingReleaseTX |
EndingReleaseTY |
EndingReleaseTZ |
FrameResultsSets_DEAD_SLS | Dead load combinations included in each SLS combination
FrameResultsSets_LIVE_SLS | Live load combinations included in each SLS combination
FrameResultsSets_SLS | SLS combinations
FrameResultsSets_ULS | ULS combinations
ID | ID of Frame Element
Length | Length of Frame Element
Material | Material of Frame Element
PointInPlaneXY |
Section | Section of Frame Element
SeismicOnlyLoads | Combinations with seismic-only loads included in seismic combination
SeismicVericalLoads | Combination with vertical loads included in seismic combination
StartingNode |
StartingReleaseRX |
StartingReleaseRY |
StartingReleaseRZ |
StartingReleaseTX |
StartingReleaseTY |
StartingReleaseTZ |
Story |
Type |
za | Z coordinate of load application point on section (input)

See Also

FrameElement Class


EndingNode Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.EndingNode Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Node EndingNode
Visual Basic (Declaration)
Public EndingNode As Node
Visual C++
public:
Node^ EndingNode

See Also

FrameElement Class


EndingReleaseRX Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.EndingReleaseRX Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool EndingReleaseRX
Visual Basic (Declaration)
Public EndingReleaseRX As Boolean
Visual C++
public:
bool EndingReleaseRX

See Also

FrameElement Class


EndingReleaseRY Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.EndingReleaseRY Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool EndingReleaseRY
Visual Basic (Declaration)
Public EndingReleaseRY As Boolean
Visual C++
public:
bool EndingReleaseRY

See Also

FrameElement Class


EndingReleaseRZ Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.EndingReleaseRZ Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool EndingReleaseRZ
Visual Basic (Declaration)
Public EndingReleaseRZ As Boolean
Visual C++
public:
bool EndingReleaseRZ

See Also

FrameElement Class


EndingReleaseTX Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.EndingReleaseTX Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool EndingReleaseTX
Visual Basic (Declaration)
Public EndingReleaseTX As Boolean
Visual C++
public:
bool EndingReleaseTX

See Also

FrameElement Class


EndingReleaseTY Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.EndingReleaseTY Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool EndingReleaseTY
Visual Basic (Declaration)
Public EndingReleaseTY As Boolean
Visual C++
public:
bool EndingReleaseTY

See Also

FrameElement Class


EndingReleaseTZ Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.EndingReleaseTZ Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool EndingReleaseTZ
Visual Basic (Declaration)
Public EndingReleaseTZ As Boolean
Visual C++
public:
bool EndingReleaseTZ

See Also

FrameElement Class


FrameResultsSets_DEAD_SLS Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.FrameResultsSets_DEAD_SLS Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Dead load combinations included in each SLS combination

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<FrameResultsSet> FrameResultsSets_DEAD_SLS
Visual Basic (Declaration)
Public FrameResultsSets_DEAD_SLS As List(Of FrameResultsSet)
Visual C++
public:
List<FrameResultsSet^>^ FrameResultsSets_DEAD_SLS

See Also

FrameElement Class


FrameResultsSets_LIVE_SLS Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.FrameResultsSets_LIVE_SLS Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Live load combinations included in each SLS combination

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<FrameResultsSet> FrameResultsSets_LIVE_SLS
Visual Basic (Declaration)
Public FrameResultsSets_LIVE_SLS As List(Of FrameResultsSet)
Visual C++
public:
List<FrameResultsSet^>^ FrameResultsSets_LIVE_SLS

See Also

FrameElement Class


FrameResultsSets_SLS Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.FrameResultsSets_SLS Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
SLS combinations

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<FrameResultsSet> FrameResultsSets_SLS
Visual Basic (Declaration)
Public FrameResultsSets_SLS As List(Of FrameResultsSet)
Visual C++
public:
List<FrameResultsSet^>^ FrameResultsSets_SLS

See Also

FrameElement Class


FrameResultsSets_ULS Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.FrameResultsSets_ULS Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
ULS combinations

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<FrameResultsSet> FrameResultsSets_ULS
Visual Basic (Declaration)
Public FrameResultsSets_ULS As List(Of FrameResultsSet)
Visual C++
public:
List<FrameResultsSet^>^ FrameResultsSets_ULS

See Also

FrameElement Class


ID Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.ID Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
ID of Frame Element

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ID
Visual Basic (Declaration)
Public ID As String
Visual C++
public:
String^ ID

See Also

FrameElement Class


Length Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.Length Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Length of Frame Element

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Length
Visual Basic (Declaration)
Public Length As Double
Visual C++
public:
double Length

See Also

FrameElement Class


Material Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.Material Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Material of Frame Element

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Material Material
Visual Basic (Declaration)
Public Material As Material
Visual C++
public:
Material^ Material

See Also

FrameElement Class


PointInPlaneXY Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.PointInPlaneXY Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XYZ PointInPlaneXY
Visual Basic (Declaration)
Public PointInPlaneXY As XYZ
Visual C++
public:
XYZ PointInPlaneXY

See Also

FrameElement Class


Section Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.Section Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Section of Frame Element

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Section
Visual Basic (Declaration)
Public Section As Object
Visual C++
public:
Object^ Section

See Also

FrameElement Class


SeismicOnlyLoads Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.SeismicOnlyLoads Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Combinations with seismic-only loads included in seismic combination

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<FrameResultsSet> SeismicOnlyLoads
Visual Basic (Declaration)
Public SeismicOnlyLoads As List(Of FrameResultsSet)
Visual C++
public:
List<FrameResultsSet^>^ SeismicOnlyLoads

See Also

FrameElement Class


SeismicVericalLoads Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.SeismicVericalLoads Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Combination with vertical loads included in seismic combination

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FrameResultsSet SeismicVericalLoads
Visual Basic (Declaration)
Public SeismicVericalLoads As FrameResultsSet
Visual C++
public:
FrameResultsSet^ SeismicVericalLoads

See Also

FrameElement Class


StartingNode Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.StartingNode Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Node StartingNode
Visual Basic (Declaration)
Public StartingNode As Node
Visual C++
public:
Node^ StartingNode

See Also

FrameElement Class


StartingReleaseRX Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.StartingReleaseRX Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool StartingReleaseRX
Visual Basic (Declaration)
Public StartingReleaseRX As Boolean
Visual C++
public:
bool StartingReleaseRX

See Also

FrameElement Class


StartingReleaseRY Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.StartingReleaseRY Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool StartingReleaseRY
Visual Basic (Declaration)
Public StartingReleaseRY As Boolean
Visual C++
public:
bool StartingReleaseRY

See Also

FrameElement Class


StartingReleaseRZ Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.StartingReleaseRZ Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool StartingReleaseRZ
Visual Basic (Declaration)
Public StartingReleaseRZ As Boolean
Visual C++
public:
bool StartingReleaseRZ

See Also

FrameElement Class


StartingReleaseTX Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.StartingReleaseTX Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool StartingReleaseTX
Visual Basic (Declaration)
Public StartingReleaseTX As Boolean
Visual C++
public:
bool StartingReleaseTX

See Also

FrameElement Class


StartingReleaseTY Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.StartingReleaseTY Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool StartingReleaseTY
Visual Basic (Declaration)
Public StartingReleaseTY As Boolean
Visual C++
public:
bool StartingReleaseTY

See Also

FrameElement Class


StartingReleaseTZ Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.StartingReleaseTZ Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool StartingReleaseTZ
Visual Basic (Declaration)
Public StartingReleaseTZ As Boolean
Visual C++
public:
bool StartingReleaseTZ

See Also

FrameElement Class


Story Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.Story Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Story Story
Visual Basic (Declaration)
Public Story As Story
Visual C++
public:
Story^ Story

See Also

FrameElement Class


Type Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.Type Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Type
Visual Basic (Declaration)
Public Type As String
Visual C++
public:
String^ Type

See Also

FrameElement Class


za Field

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.za Field
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Z coordinate of load application point on section (input)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double za
Visual Basic (Declaration)
Public za As Double
Visual C++
public:
double za

See Also

FrameElement Class


FrameElement Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
FrameElement Methods
FrameElement Class See Also Send Feedback
EC3/8 Design Library

The FrameElement type exposes the following members.

Methods

Name | Description
Check | Performs the checks of the frame element for resistance and buckling and fills the corresponding Results objects
Equals | (Overrides Object..::.Equals(Object).)

See Also

FrameElement Class


Check Method

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.Check Method
FrameElement Class See Also Send Feedback
EC3/8 Design Library
Performs the checks of the frame element for resistance and buckling and fills the corresponding Results objects

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Check()
Visual Basic (Declaration)
Public Sub Check
Visual C++
public:
void Check()

See Also

FrameElement Class


Equals Method

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::.Equals Method
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

FrameElement Class


FrameElement Properties

[image] [image]

ENGISSOL - EC3/8 Design Library
FrameElement Properties
FrameElement Class See Also Send Feedback
EC3/8 Design Library

The FrameElement type exposes the following members.

Properties

Name | Description
_Section |

See Also

FrameElement Class


_Section Property

[image]

ENGISSOL - EC3/8 Design Library
FrameElement..::._Section Property
FrameElement Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object _Section { get; set; }
Visual Basic (Declaration)
Public Property _Section As Object
Visual C++
public:
property Object^ _Section {
    Object^ get ();
    void set (Object^ value);
}

See Also

FrameElement Class


FrameResultsSet Class

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet Class
Members See Also Send Feedback
EC3/8 Design Library
Contains a set loads (internal forces) at all element stations as well as results per stations or per element

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FrameResultsSet
Visual Basic (Declaration)
Public Class FrameResultsSet
Visual C++
public ref class FrameResultsSet

Remarks

Inheritance Hierarchy

System..::.Object
EC3Design..::.FrameResultsSet

See Also

FrameResultsSet Members


FrameResultsSet Members

[image] [image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet Members
FrameResultsSet Class Constructors Methods Fields See Also Send Feedback
EC3/8 Design Library

The FrameResultsSet type exposes the following members.

Constructors

Name | Description
FrameResultsSet | Initialization of a load case object

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)

Fields

Name | Description
BucklingResults | Design results according to Eurocode 3
Deltax | Absolute longitudinal deformation of the member
DuctilityDesignResults | Ductility design results for this frame element
Name | The name of the load case, eg "Load combo 1"
SeismicCombo | True if this load set is seimsic
Stations | Stations list for this results set
UniformLoady | true is there is a uniform load acting in y axis
UniformLoadz | true is there is a uniform load acting in z axis
WheelPosition | Wheel poisition case, needed only in case of Runway Beams, EN 1993-6
xe | Distance xe according to Figure 6.2, EN 1993-6

See Also

FrameResultsSet Class


FrameResultsSet Constructor

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet Constructor
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
Initialization of a load case object

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FrameResultsSet(
    string _name
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String _
)
Visual C++
public:
FrameResultsSet(
    String^ _name
)

Parameters

_name
Type: System..::.String
Load case name

See Also

FrameResultsSet Class


FrameResultsSet Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet Fields
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library

The FrameResultsSet type exposes the following members.

Fields

Name | Description
BucklingResults | Design results according to Eurocode 3
Deltax | Absolute longitudinal deformation of the member
DuctilityDesignResults | Ductility design results for this frame element
Name | The name of the load case, eg "Load combo 1"
SeismicCombo | True if this load set is seimsic
Stations | Stations list for this results set
UniformLoady | true is there is a uniform load acting in y axis
UniformLoadz | true is there is a uniform load acting in z axis
WheelPosition | Wheel poisition case, needed only in case of Runway Beams, EN 1993-6
xe | Distance xe according to Figure 6.2, EN 1993-6

See Also

FrameResultsSet Class


BucklingResults Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.BucklingResults Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
Design results according to Eurocode 3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BucklingCheckResults BucklingResults
Visual Basic (Declaration)
Public BucklingResults As BucklingCheckResults
Visual C++
public:
BucklingCheckResults^ BucklingResults

See Also

FrameResultsSet Class


Deltax Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.Deltax Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
Absolute longitudinal deformation of the member

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Deltax
Visual Basic (Declaration)
Public Deltax As Double
Visual C++
public:
double Deltax

See Also

FrameResultsSet Class


DuctilityDesignResults Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.DuctilityDesignResults Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
Ductility design results for this frame element

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FrameResultsSetDuctilityDesignResults DuctilityDesignResults
Visual Basic (Declaration)
Public DuctilityDesignResults As FrameResultsSetDuctilityDesignResults
Visual C++
public:
FrameResultsSetDuctilityDesignResults^ DuctilityDesignResults

Remarks

See Also

FrameResultsSet Class


Name Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.Name Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
The name of the load case, eg "Load combo 1"

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name
Visual Basic (Declaration)
Public Name As String
Visual C++
public:
String^ Name

See Also

FrameResultsSet Class


SeismicCombo Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.SeismicCombo Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
True if this load set is seimsic

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SeismicCombo
Visual Basic (Declaration)
Public SeismicCombo As Boolean
Visual C++
public:
bool SeismicCombo

Remarks

See Also

FrameResultsSet Class


Stations Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.Stations Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
Stations list for this results set

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<Station> Stations
Visual Basic (Declaration)
Public Stations As List(Of Station)
Visual C++
public:
List<Station^>^ Stations

See Also

FrameResultsSet Class


UniformLoady Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.UniformLoady Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
true is there is a uniform load acting in y axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UniformLoady
Visual Basic (Declaration)
Public UniformLoady As Boolean
Visual C++
public:
bool UniformLoady

See Also

FrameResultsSet Class


UniformLoadz Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.UniformLoadz Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
true is there is a uniform load acting in z axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UniformLoadz
Visual Basic (Declaration)
Public UniformLoadz As Boolean
Visual C++
public:
bool UniformLoadz

See Also

FrameResultsSet Class


WheelPosition Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.WheelPosition Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
Wheel poisition case, needed only in case of Runway Beams, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int WheelPosition
Visual Basic (Declaration)
Public WheelPosition As Integer
Visual C++
public:
int WheelPosition

Remarks

According to Table 6.2, EN 1993-6, case (a)=1......case (d)=4 (Needed only in case of runway beams)

See Also

FrameResultsSet Class


xe Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.xe Field
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library
Distance xe according to Figure 6.2, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double xe
Visual Basic (Declaration)
Public xe As Double
Visual C++
public:
double xe

Remarks

(Needed only in case of runway beams)

See Also

FrameResultsSet Class


FrameResultsSet Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet Methods
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library

The FrameResultsSet type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)

See Also

FrameResultsSet Class


Equals Method

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSet..::.Equals Method
FrameResultsSet Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

FrameResultsSet Class


FrameResultsSetDuctilityDesignResults Class

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults Class
Members See Also Send Feedback
EC3/8 Design Library
Ducility design results regarding a frame results set

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FrameResultsSetDuctilityDesignResults
Visual Basic (Declaration)
Public Class FrameResultsSetDuctilityDesignResults
Visual C++
public ref class FrameResultsSetDuctilityDesignResults

Inheritance Hierarchy

System..::.Object
EC3Design..::.FrameResultsSetDuctilityDesignResults

See Also

FrameResultsSetDuctilityDesignResults Members


FrameResultsSetDuctilityDesignResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults Members
FrameResultsSetDuctilityDesignResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The FrameResultsSetDuctilityDesignResults type exposes the following members.

Constructors

Name | Description
FrameResultsSetDuctilityDesignResults | Initializes a new instance of the FrameResultsSetDuctilityDesignResults class

Fields

Name | Description
LinkLengthCheckSatisfied | True, if moment check according to 6.8.2(6)is satisfied, otherwise false
McheckSatisfied_End | True, if moment check according to 6.8.2(4) or (5) is satisfied, otherwise false
McheckSatisfied_Start | True, if moment check according to 6.8.2(4) or (5) is satisfied, otherwise false
MEdlink_End | Acting moment at the ending edge of the link
MEdlink_Start | Acting moment at the starting edge of the link
Mplink_End | Moment design resistance of link at its ending edge according to 6.8.2(3) or (5)
Mplink_Start | Moment design resistance of link at its starting edge according to 6.8.2(3) or (5)
NearSeismicLink_AxialCheckSatisfied | True, if check according to (6.30), paragraph 6.8.3 is satisfied, otherwise false
NearSeismicLink_Ned | Compression force due to non seismic actions included in the combination of actions for the seismic design situation, according to paragraph 6.8.3, for use in formula (6.30)
NearSeismicLink_NRd | Axial design resistance according to paragraph 6.8.3, for use in formula (6.30)
Ned | Axial force in the beam or column due to non-seismic actions included in the combination for the seismic design situation, as defined in paragraph 6.7.4(1)
NedCheckSatisfied | True, if check according to paragraph 6.7.4(1) is satisfied, otherwise false
NplRd | Design buckling resistance of the beam or column, as defined in paragraph 6.7.4(1)
VcheckSatisfied_End | True, if shear check according to 6.8.2(4) or (5) is satisfied, otherwise false
VcheckSatisfied_Start | True, if shear check according to 6.8.2(4) or (5) is satisfied, otherwise false
VEdlink_End | Acting shear force at the ending edge of the link
VEdlink_Start | Acting shear force at the starting edge of the link
Vplink_End | Shear design resistance of link at its ending edge according to 6.8.2(3) or (5)
Vplink_Start | Shear design resistance of link at its starting edge according to 6.8.2(3) or (5)

See Also

FrameResultsSetDuctilityDesignResults Class


FrameResultsSetDuctilityDesignResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults Constructor
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the FrameResultsSetDuctilityDesignResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FrameResultsSetDuctilityDesignResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FrameResultsSetDuctilityDesignResults()

See Also

FrameResultsSetDuctilityDesignResults Class


FrameResultsSetDuctilityDesignResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults Fields
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library

The FrameResultsSetDuctilityDesignResults type exposes the following members.

Fields

Name | Description
LinkLengthCheckSatisfied | True, if moment check according to 6.8.2(6)is satisfied, otherwise false
McheckSatisfied_End | True, if moment check according to 6.8.2(4) or (5) is satisfied, otherwise false
McheckSatisfied_Start | True, if moment check according to 6.8.2(4) or (5) is satisfied, otherwise false
MEdlink_End | Acting moment at the ending edge of the link
MEdlink_Start | Acting moment at the starting edge of the link
Mplink_End | Moment design resistance of link at its ending edge according to 6.8.2(3) or (5)
Mplink_Start | Moment design resistance of link at its starting edge according to 6.8.2(3) or (5)
NearSeismicLink_AxialCheckSatisfied | True, if check according to (6.30), paragraph 6.8.3 is satisfied, otherwise false
NearSeismicLink_Ned | Compression force due to non seismic actions included in the combination of actions for the seismic design situation, according to paragraph 6.8.3, for use in formula (6.30)
NearSeismicLink_NRd | Axial design resistance according to paragraph 6.8.3, for use in formula (6.30)
Ned | Axial force in the beam or column due to non-seismic actions included in the combination for the seismic design situation, as defined in paragraph 6.7.4(1)
NedCheckSatisfied | True, if check according to paragraph 6.7.4(1) is satisfied, otherwise false
NplRd | Design buckling resistance of the beam or column, as defined in paragraph 6.7.4(1)
VcheckSatisfied_End | True, if shear check according to 6.8.2(4) or (5) is satisfied, otherwise false
VcheckSatisfied_Start | True, if shear check according to 6.8.2(4) or (5) is satisfied, otherwise false
VEdlink_End | Acting shear force at the ending edge of the link
VEdlink_Start | Acting shear force at the starting edge of the link
Vplink_End | Shear design resistance of link at its ending edge according to 6.8.2(3) or (5)
Vplink_Start | Shear design resistance of link at its starting edge according to 6.8.2(3) or (5)

See Also

FrameResultsSetDuctilityDesignResults Class


LinkLengthCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.LinkLengthCheckSatisfied Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if moment check according to 6.8.2(6)is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LinkLengthCheckSatisfied
Visual Basic (Declaration)
Public LinkLengthCheckSatisfied As Boolean
Visual C++
public:
bool LinkLengthCheckSatisfied

See Also

FrameResultsSetDuctilityDesignResults Class


McheckSatisfied_End Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.McheckSatisfied_End Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if moment check according to 6.8.2(4) or (5) is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool McheckSatisfied_End
Visual Basic (Declaration)
Public McheckSatisfied_End As Boolean
Visual C++
public:
bool McheckSatisfied_End

See Also

FrameResultsSetDuctilityDesignResults Class


McheckSatisfied_Start Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.McheckSatisfied_Start Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if moment check according to 6.8.2(4) or (5) is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool McheckSatisfied_Start
Visual Basic (Declaration)
Public McheckSatisfied_Start As Boolean
Visual C++
public:
bool McheckSatisfied_Start

See Also

FrameResultsSetDuctilityDesignResults Class


MEdlink_End Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.MEdlink_End Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Acting moment at the ending edge of the link

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MEdlink_End
Visual Basic (Declaration)
Public MEdlink_End As Double
Visual C++
public:
double MEdlink_End

See Also

FrameResultsSetDuctilityDesignResults Class


MEdlink_Start Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.MEdlink_Start Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Acting moment at the starting edge of the link

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MEdlink_Start
Visual Basic (Declaration)
Public MEdlink_Start As Double
Visual C++
public:
double MEdlink_Start

See Also

FrameResultsSetDuctilityDesignResults Class


Mplink_End Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.Mplink_End Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Moment design resistance of link at its ending edge according to 6.8.2(3) or (5)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Mplink_End
Visual Basic (Declaration)
Public Mplink_End As Double
Visual C++
public:
double Mplink_End

See Also

FrameResultsSetDuctilityDesignResults Class


Mplink_Start Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.Mplink_Start Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Moment design resistance of link at its starting edge according to 6.8.2(3) or (5)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Mplink_Start
Visual Basic (Declaration)
Public Mplink_Start As Double
Visual C++
public:
double Mplink_Start

See Also

FrameResultsSetDuctilityDesignResults Class


NearSeismicLink_AxialCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.NearSeismicLink_AxialCheckSatisfied Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check according to (6.30), paragraph 6.8.3 is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool NearSeismicLink_AxialCheckSatisfied
Visual Basic (Declaration)
Public NearSeismicLink_AxialCheckSatisfied As Boolean
Visual C++
public:
bool NearSeismicLink_AxialCheckSatisfied

See Also

FrameResultsSetDuctilityDesignResults Class


NearSeismicLink_Ned Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.NearSeismicLink_Ned Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Compression force due to non seismic actions included in the combination of actions for the seismic design situation, according to paragraph 6.8.3, for use in formula (6.30)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double NearSeismicLink_Ned
Visual Basic (Declaration)
Public NearSeismicLink_Ned As Double
Visual C++
public:
double NearSeismicLink_Ned

See Also

FrameResultsSetDuctilityDesignResults Class


NearSeismicLink_NRd Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.NearSeismicLink_NRd Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Axial design resistance according to paragraph 6.8.3, for use in formula (6.30)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double NearSeismicLink_NRd
Visual Basic (Declaration)
Public NearSeismicLink_NRd As Double
Visual C++
public:
double NearSeismicLink_NRd

See Also

FrameResultsSetDuctilityDesignResults Class


Ned Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.Ned Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Axial force in the beam or column due to non-seismic actions included in the combination for the seismic design situation, as defined in paragraph 6.7.4(1)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ned
Visual Basic (Declaration)
Public Ned As Double
Visual C++
public:
double Ned

Remarks

See Also

FrameResultsSetDuctilityDesignResults Class


NedCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.NedCheckSatisfied Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check according to paragraph 6.7.4(1) is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool NedCheckSatisfied
Visual Basic (Declaration)
Public NedCheckSatisfied As Boolean
Visual C++
public:
bool NedCheckSatisfied

See Also

FrameResultsSetDuctilityDesignResults Class


NplRd Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.NplRd Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Design buckling resistance of the beam or column, as defined in paragraph 6.7.4(1)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double NplRd
Visual Basic (Declaration)
Public NplRd As Double
Visual C++
public:
double NplRd

See Also

FrameResultsSetDuctilityDesignResults Class


VcheckSatisfied_End Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.VcheckSatisfied_End Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if shear check according to 6.8.2(4) or (5) is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool VcheckSatisfied_End
Visual Basic (Declaration)
Public VcheckSatisfied_End As Boolean
Visual C++
public:
bool VcheckSatisfied_End

See Also

FrameResultsSetDuctilityDesignResults Class


VcheckSatisfied_Start Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.VcheckSatisfied_Start Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if shear check according to 6.8.2(4) or (5) is satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool VcheckSatisfied_Start
Visual Basic (Declaration)
Public VcheckSatisfied_Start As Boolean
Visual C++
public:
bool VcheckSatisfied_Start

See Also

FrameResultsSetDuctilityDesignResults Class


VEdlink_End Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.VEdlink_End Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Acting shear force at the ending edge of the link

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VEdlink_End
Visual Basic (Declaration)
Public VEdlink_End As Double
Visual C++
public:
double VEdlink_End

See Also

FrameResultsSetDuctilityDesignResults Class


VEdlink_Start Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.VEdlink_Start Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Acting shear force at the starting edge of the link

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VEdlink_Start
Visual Basic (Declaration)
Public VEdlink_Start As Double
Visual C++
public:
double VEdlink_Start

See Also

FrameResultsSetDuctilityDesignResults Class


Vplink_End Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.Vplink_End Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Shear design resistance of link at its ending edge according to 6.8.2(3) or (5)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Vplink_End
Visual Basic (Declaration)
Public Vplink_End As Double
Visual C++
public:
double Vplink_End

See Also

FrameResultsSetDuctilityDesignResults Class


Vplink_Start Field

[image]

ENGISSOL - EC3/8 Design Library
FrameResultsSetDuctilityDesignResults..::.Vplink_Start Field
FrameResultsSetDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Shear design resistance of link at its starting edge according to 6.8.2(3) or (5)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Vplink_Start
Visual Basic (Declaration)
Public Vplink_Start As Double
Visual C++
public:
double Vplink_Start

See Also

FrameResultsSetDuctilityDesignResults Class


JointDuctilityDesignResults Class

[image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults Class
Members See Also Send Feedback
EC3/8 Design Library
Ducility design results regarding a joint

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class JointDuctilityDesignResults
Visual Basic (Declaration)
Public Class JointDuctilityDesignResults
Visual C++
public ref class JointDuctilityDesignResults

Inheritance Hierarchy

System..::.Object
EC3Design..::.JointDuctilityDesignResults

See Also

JointDuctilityDesignResults Members


JointDuctilityDesignResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults Members
JointDuctilityDesignResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The JointDuctilityDesignResults type exposes the following members.

Constructors

Name | Description
JointDuctilityDesignResults | Initializes a new instance of the JointDuctilityDesignResults class

Fields

Name | Description
BeamResistancesAboutGlobalXAxis | The sum of design values of the moments of resitance of beams about Global X axis framing the joint, according to 4.4.2.3
BeamResistancesAboutGlobalYAxis | The sum of design values of the moments of resitance of beams about Global Y axis framing the joint, according to 4.4.2.3
CheckAboutGLobalXSatisfied | True, if equation (4.29) of paragraph 4.4.2.3, regarding Global X direction, is satisfied
CheckAboutGLobalYSatisfied | True, if equation (4.29) of paragraph 4.4.2.3, regarding Global Y direction, is satisfied
Sigma_Mx_Rd | The sum of design values of the moments of resitance of columns about Global X axis framing the joint, according to 4.4.2.3
Sigma_My_Rd | The sum of design values of the moments of resitance of columns about Global Y axis framing the joint, according to 4.4.2.3

See Also

JointDuctilityDesignResults Class


JointDuctilityDesignResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults Constructor
JointDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the JointDuctilityDesignResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public JointDuctilityDesignResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
JointDuctilityDesignResults()

See Also

JointDuctilityDesignResults Class


JointDuctilityDesignResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults Fields
JointDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library

The JointDuctilityDesignResults type exposes the following members.

Fields

Name | Description
BeamResistancesAboutGlobalXAxis | The sum of design values of the moments of resitance of beams about Global X axis framing the joint, according to 4.4.2.3
BeamResistancesAboutGlobalYAxis | The sum of design values of the moments of resitance of beams about Global Y axis framing the joint, according to 4.4.2.3
CheckAboutGLobalXSatisfied | True, if equation (4.29) of paragraph 4.4.2.3, regarding Global X direction, is satisfied
CheckAboutGLobalYSatisfied | True, if equation (4.29) of paragraph 4.4.2.3, regarding Global Y direction, is satisfied
Sigma_Mx_Rd | The sum of design values of the moments of resitance of columns about Global X axis framing the joint, according to 4.4.2.3
Sigma_My_Rd | The sum of design values of the moments of resitance of columns about Global Y axis framing the joint, according to 4.4.2.3

See Also

JointDuctilityDesignResults Class


BeamResistancesAboutGlobalXAxis Field

[image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults..::.BeamResistancesAboutGlobalXAxis Field
JointDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
The sum of design values of the moments of resitance of beams about Global X axis framing the joint, according to 4.4.2.3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamResistancesAboutGlobalXAxis
Visual Basic (Declaration)
Public BeamResistancesAboutGlobalXAxis As Double
Visual C++
public:
double BeamResistancesAboutGlobalXAxis

See Also

JointDuctilityDesignResults Class


BeamResistancesAboutGlobalYAxis Field

[image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults..::.BeamResistancesAboutGlobalYAxis Field
JointDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
The sum of design values of the moments of resitance of beams about Global Y axis framing the joint, according to 4.4.2.3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamResistancesAboutGlobalYAxis
Visual Basic (Declaration)
Public BeamResistancesAboutGlobalYAxis As Double
Visual C++
public:
double BeamResistancesAboutGlobalYAxis

See Also

JointDuctilityDesignResults Class


CheckAboutGLobalXSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults..::.CheckAboutGLobalXSatisfied Field
JointDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if equation (4.29) of paragraph 4.4.2.3, regarding Global X direction, is satisfied

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckAboutGLobalXSatisfied
Visual Basic (Declaration)
Public CheckAboutGLobalXSatisfied As Boolean
Visual C++
public:
bool CheckAboutGLobalXSatisfied

See Also

JointDuctilityDesignResults Class


CheckAboutGLobalYSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults..::.CheckAboutGLobalYSatisfied Field
JointDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if equation (4.29) of paragraph 4.4.2.3, regarding Global Y direction, is satisfied

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckAboutGLobalYSatisfied
Visual Basic (Declaration)
Public CheckAboutGLobalYSatisfied As Boolean
Visual C++
public:
bool CheckAboutGLobalYSatisfied

See Also

JointDuctilityDesignResults Class


Sigma_Mx_Rd Field

[image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults..::.Sigma_Mx_Rd Field
JointDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
The sum of design values of the moments of resitance of columns about Global X axis framing the joint, according to 4.4.2.3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Sigma_Mx_Rd
Visual Basic (Declaration)
Public Sigma_Mx_Rd As Double
Visual C++
public:
double Sigma_Mx_Rd

See Also

JointDuctilityDesignResults Class


Sigma_My_Rd Field

[image]

ENGISSOL - EC3/8 Design Library
JointDuctilityDesignResults..::.Sigma_My_Rd Field
JointDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
The sum of design values of the moments of resitance of columns about Global Y axis framing the joint, according to 4.4.2.3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Sigma_My_Rd
Visual Basic (Declaration)
Public Sigma_My_Rd As Double
Visual C++
public:
double Sigma_My_Rd

See Also

JointDuctilityDesignResults Class


Material Class

[image]

ENGISSOL - EC3/8 Design Library
Material Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Material
Visual Basic (Declaration)
Public Class Material
Visual C++
public ref class Material

Inheritance Hierarchy

System..::.Object
EC3Design..::.Material

See Also

Material Members


Material Members

[image] [image]

ENGISSOL - EC3/8 Design Library
Material Members
Material Class Constructors Methods Fields See Also Send Feedback
EC3/8 Design Library

The Material type exposes the following members.

Constructors

Name | Description
Material | Initializes a new instance of the Material class

Methods

Name | Description
epsilon |

Fields

Name | Description
E |
fu |
fy |
G |
gama |
n |
Name |

See Also

Material Class


Material Constructor

[image]

ENGISSOL - EC3/8 Design Library
Material Constructor
Material Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the Material class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Material()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Material()

See Also

Material Class


Material Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
Material Fields
Material Class See Also Send Feedback
EC3/8 Design Library

The Material type exposes the following members.

Fields

Name | Description
E |
fu |
fy |
G |
gama |
n |
Name |

See Also

Material Class


E Field

[image]

ENGISSOL - EC3/8 Design Library
Material..::.E Field
Material Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double E
Visual Basic (Declaration)
Public E As Double
Visual C++
public:
double E

See Also

Material Class


fu Field

[image]

ENGISSOL - EC3/8 Design Library
Material..::.fu Field
Material Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double fu
Visual Basic (Declaration)
Public fu As Double
Visual C++
public:
double fu

See Also

Material Class


fy Field

[image]

ENGISSOL - EC3/8 Design Library
Material..::.fy Field
Material Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double fy
Visual Basic (Declaration)
Public fy As Double
Visual C++
public:
double fy

See Also

Material Class


G Field

[image]

ENGISSOL - EC3/8 Design Library
Material..::.G Field
Material Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double G
Visual Basic (Declaration)
Public G As Double
Visual C++
public:
double G

See Also

Material Class


gama Field

[image]

ENGISSOL - EC3/8 Design Library
Material..::.gama Field
Material Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double gama
Visual Basic (Declaration)
Public gama As Double
Visual C++
public:
double gama

See Also

Material Class


n Field

[image]

ENGISSOL - EC3/8 Design Library
Material..::.n Field
Material Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double n
Visual Basic (Declaration)
Public n As Double
Visual C++
public:
double n

See Also

Material Class


Name Field

[image]

ENGISSOL - EC3/8 Design Library
Material..::.Name Field
Material Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name
Visual Basic (Declaration)
Public Name As String
Visual C++
public:
String^ Name

See Also

Material Class


Material Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
Material Methods
Material Class See Also Send Feedback
EC3/8 Design Library

The Material type exposes the following members.

Methods

Name | Description
epsilon |

See Also

Material Class


epsilon Method

[image]

ENGISSOL - EC3/8 Design Library
Material..::.epsilon Method
Material Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double epsilon()
Visual Basic (Declaration)
Public Function epsilon As Double
Visual C++
public:
double epsilon()

See Also

Material Class


Model Class

[image]

ENGISSOL - EC3/8 Design Library
Model Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Model
Visual Basic (Declaration)
Public Class Model
Visual C++
public ref class Model

Inheritance Hierarchy

System..::.Object
EC3Design..::.Model

See Also

Model Members


Model Members

[image] [image]

ENGISSOL - EC3/8 Design Library
Model Members
Model Class Constructors Methods Fields See Also Send Feedback
EC3/8 Design Library

The Model type exposes the following members.

Constructors

Name | Description
Model | Initializes a new instance of the Model class

Methods

Name | Description
Check |

Fields

Name | Description
Beams |
Braces |
Columns |
DuctileMomentResistingJoints | Joints to be designed according to ductility design provisions
Stories |

See Also

Model Class


Model Constructor

[image]

ENGISSOL - EC3/8 Design Library
Model Constructor
Model Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the Model class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Model()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Model()

See Also

Model Class


Model Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
Model Fields
Model Class See Also Send Feedback
EC3/8 Design Library

The Model type exposes the following members.

Fields

Name | Description
Beams |
Braces |
Columns |
DuctileMomentResistingJoints | Joints to be designed according to ductility design provisions
Stories |

See Also

Model Class


Beams Field

[image]

ENGISSOL - EC3/8 Design Library
Model..::.Beams Field
Model Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<Beam> Beams
Visual Basic (Declaration)
Public Shared Beams As List(Of Beam)
Visual C++
public:
static List<Beam^>^ Beams

See Also

Model Class


Braces Field

[image]

ENGISSOL - EC3/8 Design Library
Model..::.Braces Field
Model Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<Brace> Braces
Visual Basic (Declaration)
Public Shared Braces As List(Of Brace)
Visual C++
public:
static List<Brace^>^ Braces

See Also

Model Class


Columns Field

[image]

ENGISSOL - EC3/8 Design Library
Model..::.Columns Field
Model Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<Column> Columns
Visual Basic (Declaration)
Public Shared Columns As List(Of Column)
Visual C++
public:
static List<Column^>^ Columns

See Also

Model Class


DuctileMomentResistingJoints Field

[image]

ENGISSOL - EC3/8 Design Library
Model..::.DuctileMomentResistingJoints Field
Model Class See Also Send Feedback
EC3/8 Design Library
Joints to be designed according to ductility design provisions

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<DuctileMomentResistingJoint> DuctileMomentResistingJoints
Visual Basic (Declaration)
Public Shared DuctileMomentResistingJoints As List(Of DuctileMomentResistingJoint)
Visual C++
public:
static List<DuctileMomentResistingJoint^>^ DuctileMomentResistingJoints

See Also

Model Class


Stories Field

[image]

ENGISSOL - EC3/8 Design Library
Model..::.Stories Field
Model Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ArrayList Stories
Visual Basic (Declaration)
Public Shared Stories As ArrayList
Visual C++
public:
static ArrayList^ Stories

See Also

Model Class


Model Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
Model Methods
Model Class See Also Send Feedback
EC3/8 Design Library

The Model type exposes the following members.

Methods

Name | Description
Check |

See Also

Model Class


Check Method

[image]

ENGISSOL - EC3/8 Design Library
Model..::.Check Method
Model Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Check()
Visual Basic (Declaration)
Public Shared Sub Check
Visual C++
public:
static void Check()

See Also

Model Class


Node Class

[image]

ENGISSOL - EC3/8 Design Library
Node Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Node
Visual Basic (Declaration)
Public Class Node
Visual C++
public ref class Node

Inheritance Hierarchy

System..::.Object
EC3Design..::.Node

See Also

Node Members


Node Members

[image] [image]

ENGISSOL - EC3/8 Design Library
Node Members
Node Class Constructors Methods Fields See Also Send Feedback
EC3/8 Design Library

The Node type exposes the following members.

Constructors

Name | Description
Node | Initializes a new instance of the Node class

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)

Fields

Name | Description
ID |
SupportRX |
SupportRY |
SupportRZ |
SupportTX |
SupportTY |
SupportTZ |
x |
y |
z |

See Also

Node Class


Node Constructor

[image]

ENGISSOL - EC3/8 Design Library
Node Constructor
Node Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the Node class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Node(
    double _x,
    double _y,
    double _z
)
Visual Basic (Declaration)
Public Sub New ( _
    _x As Double, _
    _y As Double, _
    _z As Double _
)
Visual C++
public:
Node(
    double _x,
    double _y,
    double _z
)

Parameters

_x
Type: System..::.Double
_y
Type: System..::.Double
_z
Type: System..::.Double

See Also

Node Class


Node Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
Node Fields
Node Class See Also Send Feedback
EC3/8 Design Library

The Node type exposes the following members.

Fields

Name | Description
ID |
SupportRX |
SupportRY |
SupportRZ |
SupportTX |
SupportTY |
SupportTZ |
x |
y |
z |

See Also

Node Class


ID Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.ID Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ID
Visual Basic (Declaration)
Public ID As String
Visual C++
public:
String^ ID

See Also

Node Class


SupportRX Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.SupportRX Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SupportRX
Visual Basic (Declaration)
Public SupportRX As Boolean
Visual C++
public:
bool SupportRX

See Also

Node Class


SupportRY Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.SupportRY Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SupportRY
Visual Basic (Declaration)
Public SupportRY As Boolean
Visual C++
public:
bool SupportRY

See Also

Node Class


SupportRZ Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.SupportRZ Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SupportRZ
Visual Basic (Declaration)
Public SupportRZ As Boolean
Visual C++
public:
bool SupportRZ

See Also

Node Class


SupportTX Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.SupportTX Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SupportTX
Visual Basic (Declaration)
Public SupportTX As Boolean
Visual C++
public:
bool SupportTX

See Also

Node Class


SupportTY Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.SupportTY Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SupportTY
Visual Basic (Declaration)
Public SupportTY As Boolean
Visual C++
public:
bool SupportTY

See Also

Node Class


SupportTZ Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.SupportTZ Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SupportTZ
Visual Basic (Declaration)
Public SupportTZ As Boolean
Visual C++
public:
bool SupportTZ

See Also

Node Class


x Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.x Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double x
Visual Basic (Declaration)
Public x As Double
Visual C++
public:
double x

See Also

Node Class


y Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.y Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double y
Visual Basic (Declaration)
Public y As Double
Visual C++
public:
double y

See Also

Node Class


z Field

[image]

ENGISSOL - EC3/8 Design Library
Node..::.z Field
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double z
Visual Basic (Declaration)
Public z As Double
Visual C++
public:
double z

See Also

Node Class


Node Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
Node Methods
Node Class See Also Send Feedback
EC3/8 Design Library

The Node type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)

See Also

Node Class


Equals Method

[image]

ENGISSOL - EC3/8 Design Library
Node..::.Equals Method
Node Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Node Class


Parameters Class

[image]

ENGISSOL - EC3/8 Design Library
Parameters Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Parameters
Visual Basic (Declaration)
Public Class Parameters
Visual C++
public ref class Parameters

Inheritance Hierarchy

System..::.Object
EC3Design..::.Parameters

See Also

Parameters Members


Parameters Members

[image] [image]

ENGISSOL - EC3/8 Design Library
Parameters Members
Parameters Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The Parameters type exposes the following members.

Constructors

Name | Description
Parameters | Initializes a new instance of the Parameters class

Fields

Name | Description
gamaFf | Safety factor gamaFf for check against fatigue
gamaM0 | Safety factor gama M0
gamaM1 | Safety factor gama M1
gamaM2 | Safety factor gama M2
gamaMf | Safety factor gamaMf for check against fatigue
gamaMser |
gov |
lamda_direct | Values according to the classification of crane for the fatigue assesement regarding direct stresses
lamda_shear | Values according to the classification of crane for the fatigue assesement regarding shear stresses
MaxValue | Maximum double value assumed
MinValue | Minimum double value assumed
phi1 | Dynamic factor v1 according to table 2.1, EN 1991-3
phi2 | Dynamic factor v2 according to table 2.1, EN 1991-3
ZeroValue | Maximum force value that will be assumed equal to zero, eg 0.1

See Also

Parameters Class


Parameters Constructor

[image]

ENGISSOL - EC3/8 Design Library
Parameters Constructor
Parameters Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the Parameters class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Parameters()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Parameters()

See Also

Parameters Class


Parameters Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
Parameters Fields
Parameters Class See Also Send Feedback
EC3/8 Design Library

The Parameters type exposes the following members.

Fields

Name | Description
gamaFf | Safety factor gamaFf for check against fatigue
gamaM0 | Safety factor gama M0
gamaM1 | Safety factor gama M1
gamaM2 | Safety factor gama M2
gamaMf | Safety factor gamaMf for check against fatigue
gamaMser |
gov |
lamda_direct | Values according to the classification of crane for the fatigue assesement regarding direct stresses
lamda_shear | Values according to the classification of crane for the fatigue assesement regarding shear stresses
MaxValue | Maximum double value assumed
MinValue | Minimum double value assumed
phi1 | Dynamic factor v1 according to table 2.1, EN 1991-3
phi2 | Dynamic factor v2 according to table 2.1, EN 1991-3
ZeroValue | Maximum force value that will be assumed equal to zero, eg 0.1

See Also

Parameters Class


gamaFf Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.gamaFf Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Safety factor gamaFf for check against fatigue

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double gamaFf
Visual Basic (Declaration)
Public Shared gamaFf As Double
Visual C++
public:
static double gamaFf

See Also

Parameters Class


gamaM0 Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.gamaM0 Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Safety factor gama M0

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double gamaM0
Visual Basic (Declaration)
Public Shared gamaM0 As Double
Visual C++
public:
static double gamaM0

See Also

Parameters Class


gamaM1 Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.gamaM1 Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Safety factor gama M1

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double gamaM1
Visual Basic (Declaration)
Public Shared gamaM1 As Double
Visual C++
public:
static double gamaM1

See Also

Parameters Class


gamaM2 Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.gamaM2 Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Safety factor gama M2

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double gamaM2
Visual Basic (Declaration)
Public Shared gamaM2 As Double
Visual C++
public:
static double gamaM2

See Also

Parameters Class


gamaMf Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.gamaMf Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Safety factor gamaMf for check against fatigue

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double gamaMf
Visual Basic (Declaration)
Public Shared gamaMf As Double
Visual C++
public:
static double gamaMf

See Also

Parameters Class


gamaMser Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.gamaMser Field
Parameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Object gamaMser
Visual Basic (Declaration)
Public Shared gamaMser As Object
Visual C++
public:
static Object^ gamaMser

See Also

Parameters Class


gov Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.gov Field
Parameters Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double gov
Visual Basic (Declaration)
Public Shared gov As Double
Visual C++
public:
static double gov

See Also

Parameters Class


lamda_direct Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.lamda_direct Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Values according to the classification of crane for the fatigue assesement regarding direct stresses

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double lamda_direct
Visual Basic (Declaration)
Public Shared lamda_direct As Double
Visual C++
public:
static double lamda_direct

Remarks

See Also

Parameters Class


lamda_shear Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.lamda_shear Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Values according to the classification of crane for the fatigue assesement regarding shear stresses

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double lamda_shear
Visual Basic (Declaration)
Public Shared lamda_shear As Double
Visual C++
public:
static double lamda_shear

Remarks

See Also

Parameters Class


MaxValue Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.MaxValue Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Maximum double value assumed

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double MaxValue
Visual Basic (Declaration)
Public Shared MaxValue As Double
Visual C++
public:
static double MaxValue

See Also

Parameters Class


MinValue Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.MinValue Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Minimum double value assumed

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double MinValue
Visual Basic (Declaration)
Public Shared MinValue As Double
Visual C++
public:
static double MinValue

See Also

Parameters Class


phi1 Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.phi1 Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Dynamic factor v1 according to table 2.1, EN 1991-3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double phi1
Visual Basic (Declaration)
Public Shared phi1 As Double
Visual C++
public:
static double phi1

Remarks

See Also

Parameters Class


phi2 Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.phi2 Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Dynamic factor v2 according to table 2.1, EN 1991-3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double phi2
Visual Basic (Declaration)
Public Shared phi2 As Double
Visual C++
public:
static double phi2

Remarks

See Also

Parameters Class


ZeroValue Field

[image]

ENGISSOL - EC3/8 Design Library
Parameters..::.ZeroValue Field
Parameters Class See Also Send Feedback
EC3/8 Design Library
Maximum force value that will be assumed equal to zero, eg 0.1

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double ZeroValue
Visual Basic (Declaration)
Public Shared ZeroValue As Double
Visual C++
public:
static double ZeroValue

See Also

Parameters Class


RailSection Class

[image]

ENGISSOL - EC3/8 Design Library
RailSection Class
Members See Also Send Feedback
EC3/8 Design Library
Class that represents a rail section, that can be assgined to runway beams

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class RailSection
Visual Basic (Declaration)
Public Class RailSection
Visual C++
public ref class RailSection

Inheritance Hierarchy

System..::.Object
EC3Design..::.RailSection

See Also

RailSection Members


RailSection Members

[image] [image]

ENGISSOL - EC3/8 Design Library
RailSection Members
RailSection Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The RailSection type exposes the following members.

Constructors

Name | Description
RailSection | Initializes a new instance of the RailSection class

Fields

Name | Description
Area_0125_wear |
Area_025_wear |
br |
br2 |
hr | Geometric values hr, tr of rail section
tr |
tr2 |
tr3 |
Type | Rail section type Types definition:

See Also

RailSection Class


RailSection Constructor

[image]

ENGISSOL - EC3/8 Design Library
RailSection Constructor
RailSection Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the RailSection class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RailSection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RailSection()

See Also

RailSection Class


RailSection Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
RailSection Fields
RailSection Class See Also Send Feedback
EC3/8 Design Library

The RailSection type exposes the following members.

Fields

Name | Description
Area_0125_wear |
Area_025_wear |
br |
br2 |
hr | Geometric values hr, tr of rail section
tr |
tr2 |
tr3 |
Type | Rail section type Types definition:

See Also

RailSection Class


Area_0125_wear Field

[image]

ENGISSOL - EC3/8 Design Library
RailSection..::.Area_0125_wear Field
RailSection Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Area_0125_wear
Visual Basic (Declaration)
Public Area_0125_wear As Double
Visual C++
public:
double Area_0125_wear

See Also

RailSection Class


Area_025_wear Field

[image]

ENGISSOL - EC3/8 Design Library
RailSection..::.Area_025_wear Field
RailSection Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Area_025_wear
Visual Basic (Declaration)
Public Area_025_wear As Double
Visual C++
public:
double Area_025_wear

See Also

RailSection Class


br Field

[image]

ENGISSOL - EC3/8 Design Library
RailSection..::.br Field
RailSection Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double br
Visual Basic (Declaration)
Public br As Double
Visual C++
public:
double br

See Also

RailSection Class


br2 Field

[image]

ENGISSOL - EC3/8 Design Library
RailSection..::.br2 Field
RailSection Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double br2
Visual Basic (Declaration)
Public br2 As Double
Visual C++
public:
double br2

See Also

RailSection Class


hr Field

[image]

ENGISSOL - EC3/8 Design Library
RailSection..::.hr Field
RailSection Class See Also Send Feedback
EC3/8 Design Library
Geometric values hr, tr of rail section

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hr
Visual Basic (Declaration)
Public hr As Double
Visual C++
public:
double hr

See Also

RailSection Class


tr Field

[image]

ENGISSOL - EC3/8 Design Library
RailSection..::.tr Field
RailSection Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tr
Visual Basic (Declaration)
Public tr As Double
Visual C++
public:
double tr

See Also

RailSection Class


tr2 Field

[image]

ENGISSOL - EC3/8 Design Library
RailSection..::.tr2 Field
RailSection Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tr2
Visual Basic (Declaration)
Public tr2 As Double
Visual C++
public:
double tr2

See Also

RailSection Class


tr3 Field

[image]

ENGISSOL - EC3/8 Design Library
RailSection..::.tr3 Field
RailSection Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tr3
Visual Basic (Declaration)
Public tr3 As Double
Visual C++
public:
double tr3

See Also

RailSection Class


Type Field

[image]

ENGISSOL - EC3/8 Design Library
RailSection..::.Type Field
RailSection Class See Also Send Feedback
EC3/8 Design Library
Rail section type

Types definition:

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Type
Visual Basic (Declaration)
Public Type As Integer
Visual C++
public:
int Type

Remarks

If equal to 0, custom type assumed. Then values Area, z_cg, bfr, Ir_025_wear and Ir_0125_wear should be given manually

See Also

RailSection Class


RunwayBeamExtraResults Class

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults Class
Members See Also Send Feedback
EC3/8 Design Library
Contains the extra results of a frame element defined as runway beam

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class RunwayBeamExtraResults
Visual Basic (Declaration)
Public Class RunwayBeamExtraResults
Visual C++
public ref class RunwayBeamExtraResults

Remarks

Inheritance Hierarchy

System..::.Object
EC3Design..::.RunwayBeamExtraResults

See Also

RunwayBeamExtraResults Members


RunwayBeamExtraResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults Members
RunwayBeamExtraResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The RunwayBeamExtraResults type exposes the following members.

Constructors

Name | Description
RunwayBeamExtraResults | Initializes a new instance of the RunwayBeamExtraResults class

Fields

Name | Description
BottomFlangeLoadsSatisfied | True, if bottom flange loads check is satisfied, according to 6.7, EN 1993-6
BottomFlangeVibrationCheckSatisfied | True, if bottom flange vibration check is satisfied according to 7.6 EN 1993-6
DesignResistanceOfBottomFlangeToWheelLoads | Design resistance of bottom flange to wheel loads, according to 6.7, EN 1993-6
FatigueCheckBetweenTopFlangeAndWebSatisfied | True if fatigue check between top flange and web is satisfied, according to formula 9.4, EN 1993-6
FatigueRatioBetweenTopFlangeAndWeb | Interaction ratio regarding direct and shear stresses for fatigue check between top flange and web, according to formula 9.4, EN 1993-6
HorizontalDeflectionSatisfied | True, if maximum horizontal deflection check is satisfied, according to table 7.1 (a), EN 1993-6
InteractionRatioWebLoads | Interactio ratio between transverse force, bending moments and axial force for loads the web, according to 6.5, EN 1993-6
MaxHorizontalDeflection | Maximum horizontal deflection for check according to table 7.1 (a), EN 1993-6
MaxVerticalDeflection | Maximum vertical deflection for check according to table 7.2 (a), EN 1993-6
ReversibleBehaviourChecksSatisfied | True, if reversible behaviour check is satisfied according to 7.5 EN 1993-6
VerticalDeflectionSatisfied | True, if maximum vertical deflection check is satisfied, according to table 7.2 (a), EN 1993-6
WebBreathingCheckSatisfied | True, if web breathing check is satisfied, according to 7.4, EN 1993-6
WebLoadsCheckSatisfied | True if check for loads on the web is satisfied, according to 6.5, EN 1993-6

See Also

RunwayBeamExtraResults Class


RunwayBeamExtraResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults Constructor
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the RunwayBeamExtraResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RunwayBeamExtraResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RunwayBeamExtraResults()

See Also

RunwayBeamExtraResults Class


RunwayBeamExtraResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults Fields
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library

The RunwayBeamExtraResults type exposes the following members.

Fields

Name | Description
BottomFlangeLoadsSatisfied | True, if bottom flange loads check is satisfied, according to 6.7, EN 1993-6
BottomFlangeVibrationCheckSatisfied | True, if bottom flange vibration check is satisfied according to 7.6 EN 1993-6
DesignResistanceOfBottomFlangeToWheelLoads | Design resistance of bottom flange to wheel loads, according to 6.7, EN 1993-6
FatigueCheckBetweenTopFlangeAndWebSatisfied | True if fatigue check between top flange and web is satisfied, according to formula 9.4, EN 1993-6
FatigueRatioBetweenTopFlangeAndWeb | Interaction ratio regarding direct and shear stresses for fatigue check between top flange and web, according to formula 9.4, EN 1993-6
HorizontalDeflectionSatisfied | True, if maximum horizontal deflection check is satisfied, according to table 7.1 (a), EN 1993-6
InteractionRatioWebLoads | Interactio ratio between transverse force, bending moments and axial force for loads the web, according to 6.5, EN 1993-6
MaxHorizontalDeflection | Maximum horizontal deflection for check according to table 7.1 (a), EN 1993-6
MaxVerticalDeflection | Maximum vertical deflection for check according to table 7.2 (a), EN 1993-6
ReversibleBehaviourChecksSatisfied | True, if reversible behaviour check is satisfied according to 7.5 EN 1993-6
VerticalDeflectionSatisfied | True, if maximum vertical deflection check is satisfied, according to table 7.2 (a), EN 1993-6
WebBreathingCheckSatisfied | True, if web breathing check is satisfied, according to 7.4, EN 1993-6
WebLoadsCheckSatisfied | True if check for loads on the web is satisfied, according to 6.5, EN 1993-6

See Also

RunwayBeamExtraResults Class


BottomFlangeLoadsSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.BottomFlangeLoadsSatisfied Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
True, if bottom flange loads check is satisfied, according to 6.7, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool BottomFlangeLoadsSatisfied
Visual Basic (Declaration)
Public BottomFlangeLoadsSatisfied As Boolean
Visual C++
public:
bool BottomFlangeLoadsSatisfied

Remarks

See Also

RunwayBeamExtraResults Class


BottomFlangeVibrationCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.BottomFlangeVibrationCheckSatisfied Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
True, if bottom flange vibration check is satisfied according to 7.6 EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool BottomFlangeVibrationCheckSatisfied
Visual Basic (Declaration)
Public BottomFlangeVibrationCheckSatisfied As Boolean
Visual C++
public:
bool BottomFlangeVibrationCheckSatisfied

See Also

RunwayBeamExtraResults Class


DesignResistanceOfBottomFlangeToWheelLoads Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.DesignResistanceOfBottomFlangeToWheelLoads Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
Design resistance of bottom flange to wheel loads, according to 6.7, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DesignResistanceOfBottomFlangeToWheelLoads
Visual Basic (Declaration)
Public DesignResistanceOfBottomFlangeToWheelLoads As Double
Visual C++
public:
double DesignResistanceOfBottomFlangeToWheelLoads

See Also

RunwayBeamExtraResults Class


FatigueCheckBetweenTopFlangeAndWebSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.FatigueCheckBetweenTopFlangeAndWebSatisfied Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
True if fatigue check between top flange and web is satisfied, according to formula 9.4, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool FatigueCheckBetweenTopFlangeAndWebSatisfied
Visual Basic (Declaration)
Public FatigueCheckBetweenTopFlangeAndWebSatisfied As Boolean
Visual C++
public:
bool FatigueCheckBetweenTopFlangeAndWebSatisfied

See Also

RunwayBeamExtraResults Class


FatigueRatioBetweenTopFlangeAndWeb Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.FatigueRatioBetweenTopFlangeAndWeb Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
Interaction ratio regarding direct and shear stresses for fatigue check between top flange and web, according to formula 9.4, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FatigueRatioBetweenTopFlangeAndWeb
Visual Basic (Declaration)
Public FatigueRatioBetweenTopFlangeAndWeb As Double
Visual C++
public:
double FatigueRatioBetweenTopFlangeAndWeb

See Also

RunwayBeamExtraResults Class


HorizontalDeflectionSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.HorizontalDeflectionSatisfied Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
True, if maximum horizontal deflection check is satisfied, according to table 7.1 (a), EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool HorizontalDeflectionSatisfied
Visual Basic (Declaration)
Public HorizontalDeflectionSatisfied As Boolean
Visual C++
public:
bool HorizontalDeflectionSatisfied

See Also

RunwayBeamExtraResults Class


InteractionRatioWebLoads Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.InteractionRatioWebLoads Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
Interactio ratio between transverse force, bending moments and axial force for loads the web, according to 6.5, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double InteractionRatioWebLoads
Visual Basic (Declaration)
Public InteractionRatioWebLoads As Double
Visual C++
public:
double InteractionRatioWebLoads

See Also

RunwayBeamExtraResults Class


MaxHorizontalDeflection Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.MaxHorizontalDeflection Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
Maximum horizontal deflection for check according to table 7.1 (a), EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MaxHorizontalDeflection
Visual Basic (Declaration)
Public MaxHorizontalDeflection As Double
Visual C++
public:
double MaxHorizontalDeflection

See Also

RunwayBeamExtraResults Class


MaxVerticalDeflection Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.MaxVerticalDeflection Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
Maximum vertical deflection for check according to table 7.2 (a), EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MaxVerticalDeflection
Visual Basic (Declaration)
Public MaxVerticalDeflection As Double
Visual C++
public:
double MaxVerticalDeflection

See Also

RunwayBeamExtraResults Class


ReversibleBehaviourChecksSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.ReversibleBehaviourChecksSatisfied Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
True, if reversible behaviour check is satisfied according to 7.5 EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReversibleBehaviourChecksSatisfied
Visual Basic (Declaration)
Public ReversibleBehaviourChecksSatisfied As Boolean
Visual C++
public:
bool ReversibleBehaviourChecksSatisfied

See Also

RunwayBeamExtraResults Class


VerticalDeflectionSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.VerticalDeflectionSatisfied Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
True, if maximum vertical deflection check is satisfied, according to table 7.2 (a), EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool VerticalDeflectionSatisfied
Visual Basic (Declaration)
Public VerticalDeflectionSatisfied As Boolean
Visual C++
public:
bool VerticalDeflectionSatisfied

See Also

RunwayBeamExtraResults Class


WebBreathingCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.WebBreathingCheckSatisfied Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
True, if web breathing check is satisfied, according to 7.4, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WebBreathingCheckSatisfied
Visual Basic (Declaration)
Public WebBreathingCheckSatisfied As Boolean
Visual C++
public:
bool WebBreathingCheckSatisfied

See Also

RunwayBeamExtraResults Class


WebLoadsCheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamExtraResults..::.WebLoadsCheckSatisfied Field
RunwayBeamExtraResults Class See Also Send Feedback
EC3/8 Design Library
True if check for loads on the web is satisfied, according to 6.5, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WebLoadsCheckSatisfied
Visual Basic (Declaration)
Public WebLoadsCheckSatisfied As Boolean
Visual C++
public:
bool WebLoadsCheckSatisfied

See Also

RunwayBeamExtraResults Class


RunwayBeamInputData Class

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData Class
Members See Also Send Feedback
EC3/8 Design Library
Input data for runway beams

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class RunwayBeamInputData
Visual Basic (Declaration)
Public Class RunwayBeamInputData
Visual C++
public ref class RunwayBeamInputData

Inheritance Hierarchy

System..::.Object
EC3Design..::.RunwayBeamInputData

See Also

RunwayBeamInputData Members


RunwayBeamInputData Members

[image] [image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData Members
RunwayBeamInputData Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The RunwayBeamInputData type exposes the following members.

Constructors

Name | Description
RunwayBeamInputData | Initializes a new instance of the RunwayBeamInputData class

Fields

Name | Description
CraneFlangeConnectionCase | Describes how crane is connected to the runway beam flange, according to Table 5.1, EN1993-6
DesignValueOfWheelLoad | Design value of wheel load for checking against web/bottom flange failure, or reversible behaviour
DetailCategoryOfTopFlangeToWebJunction | Top flange to web junction detail category, according to table 8.10 EN 1993-1-9
Distance_n | Distance from the centerline of the wheel load to the free edge of the flange
DistanceBetweenLateralRestraints | Distance between lateral restraints for vibration check of bottom flange
DistanceBetweenTransverseStiffeners | Distance between transverse stiffeners (if any)
DistanceBetweenWheels | Wheel spacing, defined as xw in figure 6.2, EN 1993-6
ey | Wheel eccentricity given in 2.5.2.1(2) of prEN 1991-3
Qmaxi | Wheel load to consider in check against fatigue
RailSection | The rail section of the runway beam
UseOfTransverseStiffeners | True, if transverse stiffeners are used, otherwise false
WheelLoadsOnTopFlange | True, if wheel loads are applied on top flange, otherwise false

See Also

RunwayBeamInputData Class


RunwayBeamInputData Constructor

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData Constructor
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the RunwayBeamInputData class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RunwayBeamInputData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RunwayBeamInputData()

See Also

RunwayBeamInputData Class


RunwayBeamInputData Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData Fields
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library

The RunwayBeamInputData type exposes the following members.

Fields

Name | Description
CraneFlangeConnectionCase | Describes how crane is connected to the runway beam flange, according to Table 5.1, EN1993-6
DesignValueOfWheelLoad | Design value of wheel load for checking against web/bottom flange failure, or reversible behaviour
DetailCategoryOfTopFlangeToWebJunction | Top flange to web junction detail category, according to table 8.10 EN 1993-1-9
Distance_n | Distance from the centerline of the wheel load to the free edge of the flange
DistanceBetweenLateralRestraints | Distance between lateral restraints for vibration check of bottom flange
DistanceBetweenTransverseStiffeners | Distance between transverse stiffeners (if any)
DistanceBetweenWheels | Wheel spacing, defined as xw in figure 6.2, EN 1993-6
ey | Wheel eccentricity given in 2.5.2.1(2) of prEN 1991-3
Qmaxi | Wheel load to consider in check against fatigue
RailSection | The rail section of the runway beam
UseOfTransverseStiffeners | True, if transverse stiffeners are used, otherwise false
WheelLoadsOnTopFlange | True, if wheel loads are applied on top flange, otherwise false

See Also

RunwayBeamInputData Class


CraneFlangeConnectionCase Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.CraneFlangeConnectionCase Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Describes how crane is connected to the runway beam flange, according to Table 5.1, EN1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CraneFlangeConnectionCase
Visual Basic (Declaration)
Public CraneFlangeConnectionCase As Integer
Visual C++
public:
int CraneFlangeConnectionCase

Remarks

1=case (a), 2=case (b), 3=case (c)

See Also

RunwayBeamInputData Class


DesignValueOfWheelLoad Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.DesignValueOfWheelLoad Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Design value of wheel load for checking against web/bottom flange failure, or reversible behaviour

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DesignValueOfWheelLoad
Visual Basic (Declaration)
Public DesignValueOfWheelLoad As Double
Visual C++
public:
double DesignValueOfWheelLoad

Remarks

See Also

RunwayBeamInputData Class


DetailCategoryOfTopFlangeToWebJunction Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.DetailCategoryOfTopFlangeToWebJunction Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Top flange to web junction detail category, according to table 8.10 EN 1993-1-9

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DetailCategoryOfTopFlangeToWebJunction
Visual Basic (Declaration)
Public DetailCategoryOfTopFlangeToWebJunction As Double
Visual C++
public:
double DetailCategoryOfTopFlangeToWebJunction

Remarks

Given in MPa

See Also

RunwayBeamInputData Class


Distance_n Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.Distance_n Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Distance from the centerline of the wheel load to the free edge of the flange

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Distance_n
Visual Basic (Declaration)
Public Distance_n As Double
Visual C++
public:
double Distance_n

Remarks

Needed for underslung rails only

See Also

RunwayBeamInputData Class


DistanceBetweenLateralRestraints Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.DistanceBetweenLateralRestraints Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Distance between lateral restraints for vibration check of bottom flange

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DistanceBetweenLateralRestraints
Visual Basic (Declaration)
Public DistanceBetweenLateralRestraints As Double
Visual C++
public:
double DistanceBetweenLateralRestraints

Remarks

See Also

RunwayBeamInputData Class


DistanceBetweenTransverseStiffeners Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.DistanceBetweenTransverseStiffeners Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Distance between transverse stiffeners (if any)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DistanceBetweenTransverseStiffeners
Visual Basic (Declaration)
Public DistanceBetweenTransverseStiffeners As Double
Visual C++
public:
double DistanceBetweenTransverseStiffeners

See Also

RunwayBeamInputData Class


DistanceBetweenWheels Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.DistanceBetweenWheels Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Wheel spacing, defined as xw in figure 6.2, EN 1993-6

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DistanceBetweenWheels
Visual Basic (Declaration)
Public DistanceBetweenWheels As Double
Visual C++
public:
double DistanceBetweenWheels

Remarks

See Also

RunwayBeamInputData Class


ey Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.ey Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Wheel eccentricity given in 2.5.2.1(2) of prEN 1991-3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ey
Visual Basic (Declaration)
Public ey As Double
Visual C++
public:
double ey

See Also

RunwayBeamInputData Class


Qmaxi Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.Qmaxi Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
Wheel load to consider in check against fatigue

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Qmaxi
Visual Basic (Declaration)
Public Qmaxi As Double
Visual C++
public:
double Qmaxi

See Also

RunwayBeamInputData Class


RailSection Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.RailSection Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
The rail section of the runway beam

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RailSection RailSection
Visual Basic (Declaration)
Public RailSection As RailSection
Visual C++
public:
RailSection^ RailSection

See Also

RunwayBeamInputData Class


UseOfTransverseStiffeners Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.UseOfTransverseStiffeners Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
True, if transverse stiffeners are used, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfTransverseStiffeners
Visual Basic (Declaration)
Public UseOfTransverseStiffeners As Boolean
Visual C++
public:
bool UseOfTransverseStiffeners

See Also

RunwayBeamInputData Class


WheelLoadsOnTopFlange Field

[image]

ENGISSOL - EC3/8 Design Library
RunwayBeamInputData..::.WheelLoadsOnTopFlange Field
RunwayBeamInputData Class See Also Send Feedback
EC3/8 Design Library
True, if wheel loads are applied on top flange, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WheelLoadsOnTopFlange
Visual Basic (Declaration)
Public WheelLoadsOnTopFlange As Boolean
Visual C++
public:
bool WheelLoadsOnTopFlange

See Also

RunwayBeamInputData Class


SectionCheckResults Class

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SectionCheckResults
Visual Basic (Declaration)
Public Class SectionCheckResults
Visual C++
public ref class SectionCheckResults

Inheritance Hierarchy

System..::.Object
EC3Design..::.SectionCheckResults

See Also

SectionCheckResults Members


SectionCheckResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults Members
SectionCheckResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The SectionCheckResults type exposes the following members.

Constructors

Name | Description
SectionCheckResults | Initializes a new instance of the SectionCheckResults class

Fields

Name | Description
AxialForceResistance | Resistance to axial loads
Class22 | Section class about zz axis
Class33 | Section class about yy axis
DMy | Resulting additional moment about yy axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)
DMz | Resulting additional moment about zz axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)
My_T_V_Rd | Moment resistance about yy axis. It is reduced because of shear and torsion, if needed
Mz_T_V_Rd | Moment resistance about zz axis. It is reduced because of shear and torsion, if needed
Ratio | Capacity ratio of this station
ShearYBucklingCheckNeeded | True, if shear buckling should be checked for shear parallel to Y axis, as 6.2.6(6) of EN1993-1-1 states
ShearYBucklingRatio | Shear buckling capacity ratio for shear to Y axis
ShearYBucklingResistance | Calculated shear buckling resistance for one web parallel to Y axis, according to 5.2(1), EN1993-1-5
ShearZBucklingCheckNeeded | True, if shear buckling should be checked for shear parallel to Z axis, as 6.2.6(6) of EN1993-1-1 states
ShearZBucklingRatio | Shear buckling capacity ratio for shear to Z axis
ShearZBucklingResistance | Calculated shear buckling resistance for one web parallel to Z axis, according to 5.2(1), EN1993-1-5
V_web_ShearYBuckling | Acting shear force on one web of the section parallel to Y axis
V_web_ShearZBuckling | Acting shear force on one web of the section parallel to Z axis

See Also

SectionCheckResults Class


SectionCheckResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults Constructor
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the SectionCheckResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SectionCheckResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SectionCheckResults()

See Also

SectionCheckResults Class


SectionCheckResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults Fields
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library

The SectionCheckResults type exposes the following members.

Fields

Name | Description
AxialForceResistance | Resistance to axial loads
Class22 | Section class about zz axis
Class33 | Section class about yy axis
DMy | Resulting additional moment about yy axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)
DMz | Resulting additional moment about zz axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)
My_T_V_Rd | Moment resistance about yy axis. It is reduced because of shear and torsion, if needed
Mz_T_V_Rd | Moment resistance about zz axis. It is reduced because of shear and torsion, if needed
Ratio | Capacity ratio of this station
ShearYBucklingCheckNeeded | True, if shear buckling should be checked for shear parallel to Y axis, as 6.2.6(6) of EN1993-1-1 states
ShearYBucklingRatio | Shear buckling capacity ratio for shear to Y axis
ShearYBucklingResistance | Calculated shear buckling resistance for one web parallel to Y axis, according to 5.2(1), EN1993-1-5
ShearZBucklingCheckNeeded | True, if shear buckling should be checked for shear parallel to Z axis, as 6.2.6(6) of EN1993-1-1 states
ShearZBucklingRatio | Shear buckling capacity ratio for shear to Z axis
ShearZBucklingResistance | Calculated shear buckling resistance for one web parallel to Z axis, according to 5.2(1), EN1993-1-5
V_web_ShearYBuckling | Acting shear force on one web of the section parallel to Y axis
V_web_ShearZBuckling | Acting shear force on one web of the section parallel to Z axis

See Also

SectionCheckResults Class


AxialForceResistance Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.AxialForceResistance Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Resistance to axial loads

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double AxialForceResistance
Visual Basic (Declaration)
Public AxialForceResistance As Double
Visual C++
public:
double AxialForceResistance

See Also

SectionCheckResults Class


Class22 Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.Class22 Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Section class about zz axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Class22
Visual Basic (Declaration)
Public Class22 As Integer
Visual C++
public:
int Class22

See Also

SectionCheckResults Class


Class33 Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.Class33 Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Section class about yy axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Class33
Visual Basic (Declaration)
Public Class33 As Integer
Visual C++
public:
int Class33

See Also

SectionCheckResults Class


DMy Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.DMy Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Resulting additional moment about yy axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DMy
Visual Basic (Declaration)
Public DMy As Double
Visual C++
public:
double DMy

See Also

SectionCheckResults Class


DMz Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.DMz Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Resulting additional moment about zz axis because of the centroid shift of the effective area relative to the center of gravity of the gross cross section according to 6.2.2.5(4)

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DMz
Visual Basic (Declaration)
Public DMz As Double
Visual C++
public:
double DMz

See Also

SectionCheckResults Class


My_T_V_Rd Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.My_T_V_Rd Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Moment resistance about yy axis. It is reduced because of shear and torsion, if needed

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double My_T_V_Rd
Visual Basic (Declaration)
Public My_T_V_Rd As Double
Visual C++
public:
double My_T_V_Rd

See Also

SectionCheckResults Class


Mz_T_V_Rd Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.Mz_T_V_Rd Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Moment resistance about zz axis. It is reduced because of shear and torsion, if needed

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Mz_T_V_Rd
Visual Basic (Declaration)
Public Mz_T_V_Rd As Double
Visual C++
public:
double Mz_T_V_Rd

See Also

SectionCheckResults Class


Ratio Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.Ratio Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Capacity ratio of this station

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ratio
Visual Basic (Declaration)
Public Ratio As Double
Visual C++
public:
double Ratio

See Also

SectionCheckResults Class


ShearYBucklingCheckNeeded Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.ShearYBucklingCheckNeeded Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
True, if shear buckling should be checked for shear parallel to Y axis, as 6.2.6(6) of EN1993-1-1 states

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShearYBucklingCheckNeeded
Visual Basic (Declaration)
Public ShearYBucklingCheckNeeded As Boolean
Visual C++
public:
bool ShearYBucklingCheckNeeded

See Also

SectionCheckResults Class


ShearYBucklingRatio Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.ShearYBucklingRatio Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Shear buckling capacity ratio for shear to Y axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearYBucklingRatio
Visual Basic (Declaration)
Public ShearYBucklingRatio As Double
Visual C++
public:
double ShearYBucklingRatio

See Also

SectionCheckResults Class


ShearYBucklingResistance Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.ShearYBucklingResistance Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Calculated shear buckling resistance for one web parallel to Y axis, according to 5.2(1), EN1993-1-5

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearYBucklingResistance
Visual Basic (Declaration)
Public ShearYBucklingResistance As Double
Visual C++
public:
double ShearYBucklingResistance

See Also

SectionCheckResults Class


ShearZBucklingCheckNeeded Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.ShearZBucklingCheckNeeded Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
True, if shear buckling should be checked for shear parallel to Z axis, as 6.2.6(6) of EN1993-1-1 states

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShearZBucklingCheckNeeded
Visual Basic (Declaration)
Public ShearZBucklingCheckNeeded As Boolean
Visual C++
public:
bool ShearZBucklingCheckNeeded

See Also

SectionCheckResults Class


ShearZBucklingRatio Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.ShearZBucklingRatio Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Shear buckling capacity ratio for shear to Z axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearZBucklingRatio
Visual Basic (Declaration)
Public ShearZBucklingRatio As Double
Visual C++
public:
double ShearZBucklingRatio

See Also

SectionCheckResults Class


ShearZBucklingResistance Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.ShearZBucklingResistance Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Calculated shear buckling resistance for one web parallel to Z axis, according to 5.2(1), EN1993-1-5

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearZBucklingResistance
Visual Basic (Declaration)
Public ShearZBucklingResistance As Double
Visual C++
public:
double ShearZBucklingResistance

See Also

SectionCheckResults Class


V_web_ShearYBuckling Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.V_web_ShearYBuckling Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Acting shear force on one web of the section parallel to Y axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double V_web_ShearYBuckling
Visual Basic (Declaration)
Public V_web_ShearYBuckling As Double
Visual C++
public:
double V_web_ShearYBuckling

See Also

SectionCheckResults Class


V_web_ShearZBuckling Field

[image]

ENGISSOL - EC3/8 Design Library
SectionCheckResults..::.V_web_ShearZBuckling Field
SectionCheckResults Class See Also Send Feedback
EC3/8 Design Library
Acting shear force on one web of the section parallel to Z axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double V_web_ShearZBuckling
Visual Basic (Declaration)
Public V_web_ShearZBuckling As Double
Visual C++
public:
double V_web_ShearZBuckling

See Also

SectionCheckResults Class


Station Class

[image]

ENGISSOL - EC3/8 Design Library
Station Class
Members See Also Send Feedback
EC3/8 Design Library
Contains loads and results regarding a specific location of a frame element

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Station : IComparable
Visual Basic (Declaration)
Public Class Station _
    Implements IComparable
Visual C++
public ref class Station : IComparable

Inheritance Hierarchy

System..::.Object
EC3Design..::.Station

See Also

Station Members


Station Members

[image] [image]

ENGISSOL - EC3/8 Design Library
Station Members
Station Class Constructors Methods Fields See Also Send Feedback
EC3/8 Design Library

The Station type exposes the following members.

Constructors

Name | Description
Station | Initializes a new instance of the Station class

Methods

Name | Description
CompareTo |

Fields

Name | Description
DuctilityDesignResults | Ducility design results for this location
Loc | Location of frame element
M2 |
M3 |
N | Internal forces
Rx |
Ry |
Rz |
SectionResults | Design results for this location
T |
Tx |
Ty |
Tz |
V2 |
V3 |

See Also

Station Class


Station Constructor

[image]

ENGISSOL - EC3/8 Design Library
Station Constructor
Station Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the Station class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Station()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Station()

See Also

Station Class


Station Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
Station Fields
Station Class See Also Send Feedback
EC3/8 Design Library

The Station type exposes the following members.

Fields

Name | Description
DuctilityDesignResults | Ducility design results for this location
Loc | Location of frame element
M2 |
M3 |
N | Internal forces
Rx |
Ry |
Rz |
SectionResults | Design results for this location
T |
Tx |
Ty |
Tz |
V2 |
V3 |

See Also

Station Class


DuctilityDesignResults Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.DuctilityDesignResults Field
Station Class See Also Send Feedback
EC3/8 Design Library
Ducility design results for this location

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StationDuctilityDesignResults DuctilityDesignResults
Visual Basic (Declaration)
Public DuctilityDesignResults As StationDuctilityDesignResults
Visual C++
public:
StationDuctilityDesignResults^ DuctilityDesignResults

Remarks

See Also

Station Class


Loc Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.Loc Field
Station Class See Also Send Feedback
EC3/8 Design Library
Location of frame element

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Loc
Visual Basic (Declaration)
Public Loc As Double
Visual C++
public:
double Loc

See Also

Station Class


M2 Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.M2 Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double M2
Visual Basic (Declaration)
Public M2 As Double
Visual C++
public:
double M2

See Also

Station Class


M3 Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.M3 Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double M3
Visual Basic (Declaration)
Public M3 As Double
Visual C++
public:
double M3

See Also

Station Class


N Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.N Field
Station Class See Also Send Feedback
EC3/8 Design Library
Internal forces

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double N
Visual Basic (Declaration)
Public N As Double
Visual C++
public:
double N

Remarks

Resulting forcves from analysis

See Also

Station Class


Rx Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.Rx Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Rx
Visual Basic (Declaration)
Public Rx As Double
Visual C++
public:
double Rx

See Also

Station Class


Ry Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.Ry Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ry
Visual Basic (Declaration)
Public Ry As Double
Visual C++
public:
double Ry

See Also

Station Class


Rz Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.Rz Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Rz
Visual Basic (Declaration)
Public Rz As Double
Visual C++
public:
double Rz

See Also

Station Class


SectionResults Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.SectionResults Field
Station Class See Also Send Feedback
EC3/8 Design Library
Design results for this location

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SectionCheckResults SectionResults
Visual Basic (Declaration)
Public SectionResults As SectionCheckResults
Visual C++
public:
SectionCheckResults^ SectionResults

See Also

Station Class


T Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.T Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double T
Visual Basic (Declaration)
Public T As Double
Visual C++
public:
double T

See Also

Station Class


Tx Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.Tx Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Tx
Visual Basic (Declaration)
Public Tx As Double
Visual C++
public:
double Tx

See Also

Station Class


Ty Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.Ty Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ty
Visual Basic (Declaration)
Public Ty As Double
Visual C++
public:
double Ty

See Also

Station Class


Tz Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.Tz Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Tz
Visual Basic (Declaration)
Public Tz As Double
Visual C++
public:
double Tz

See Also

Station Class


V2 Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.V2 Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double V2
Visual Basic (Declaration)
Public V2 As Double
Visual C++
public:
double V2

See Also

Station Class


V3 Field

[image]

ENGISSOL - EC3/8 Design Library
Station..::.V3 Field
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double V3
Visual Basic (Declaration)
Public V3 As Double
Visual C++
public:
double V3

See Also

Station Class


Station Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
Station Methods
Station Class See Also Send Feedback
EC3/8 Design Library

The Station type exposes the following members.

Methods

Name | Description
CompareTo |

See Also

Station Class


CompareTo Method

[image]

ENGISSOL - EC3/8 Design Library
Station..::.CompareTo Method
Station Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CompareTo(
    Object x
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    x As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ x
) sealed

Parameters

x
Type: System..::.Object

Implements

IComparable..::.CompareTo(Object)

See Also

Station Class


StationDuctilityDesignResults Class

[image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults Class
Members See Also Send Feedback
EC3/8 Design Library
Ducility design results regarding a station

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StationDuctilityDesignResults
Visual Basic (Declaration)
Public Class StationDuctilityDesignResults
Visual C++
public ref class StationDuctilityDesignResults

Inheritance Hierarchy

System..::.Object
EC3Design..::.StationDuctilityDesignResults

See Also

StationDuctilityDesignResults Members


StationDuctilityDesignResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults Members
StationDuctilityDesignResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The StationDuctilityDesignResults type exposes the following members.

Constructors

Name | Description
StationDuctilityDesignResults | Initializes a new instance of the StationDuctilityDesignResults class

Fields

Name | Description
CheckSatisfied_Y | True, if check of (6.7), paragrapph 6.6.3 is satisfied for direction y, otherwise false
CheckSatisfied_Z | True, if check of (6.7), paragrapph 6.6.3 is satisfied for direction z, otherwise false
VedEy | Design shear force parallel to local y axis according to (6.6), paragraph 6.6.3
VedEz | Design shear force parallel to local z axis according to (6.6), paragraph 6.6.3
VRdy | Shear force design resistance parallel to local y axis
VRdz | Shear force design resistance parallel to local z axis

See Also

StationDuctilityDesignResults Class


StationDuctilityDesignResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults Constructor
StationDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the StationDuctilityDesignResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StationDuctilityDesignResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StationDuctilityDesignResults()

See Also

StationDuctilityDesignResults Class


StationDuctilityDesignResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults Fields
StationDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library

The StationDuctilityDesignResults type exposes the following members.

Fields

Name | Description
CheckSatisfied_Y | True, if check of (6.7), paragrapph 6.6.3 is satisfied for direction y, otherwise false
CheckSatisfied_Z | True, if check of (6.7), paragrapph 6.6.3 is satisfied for direction z, otherwise false
VedEy | Design shear force parallel to local y axis according to (6.6), paragraph 6.6.3
VedEz | Design shear force parallel to local z axis according to (6.6), paragraph 6.6.3
VRdy | Shear force design resistance parallel to local y axis
VRdz | Shear force design resistance parallel to local z axis

See Also

StationDuctilityDesignResults Class


CheckSatisfied_Y Field

[image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults..::.CheckSatisfied_Y Field
StationDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check of (6.7), paragrapph 6.6.3 is satisfied for direction y, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckSatisfied_Y
Visual Basic (Declaration)
Public CheckSatisfied_Y As Boolean
Visual C++
public:
bool CheckSatisfied_Y

See Also

StationDuctilityDesignResults Class


CheckSatisfied_Z Field

[image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults..::.CheckSatisfied_Z Field
StationDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check of (6.7), paragrapph 6.6.3 is satisfied for direction z, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckSatisfied_Z
Visual Basic (Declaration)
Public CheckSatisfied_Z As Boolean
Visual C++
public:
bool CheckSatisfied_Z

See Also

StationDuctilityDesignResults Class


VedEy Field

[image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults..::.VedEy Field
StationDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Design shear force parallel to local y axis according to (6.6), paragraph 6.6.3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VedEy
Visual Basic (Declaration)
Public VedEy As Double
Visual C++
public:
double VedEy

See Also

StationDuctilityDesignResults Class


VedEz Field

[image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults..::.VedEz Field
StationDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Design shear force parallel to local z axis according to (6.6), paragraph 6.6.3

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VedEz
Visual Basic (Declaration)
Public VedEz As Double
Visual C++
public:
double VedEz

See Also

StationDuctilityDesignResults Class


VRdy Field

[image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults..::.VRdy Field
StationDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Shear force design resistance parallel to local y axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VRdy
Visual Basic (Declaration)
Public VRdy As Double
Visual C++
public:
double VRdy

See Also

StationDuctilityDesignResults Class


VRdz Field

[image]

ENGISSOL - EC3/8 Design Library
StationDuctilityDesignResults..::.VRdz Field
StationDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Shear force design resistance parallel to local z axis

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VRdz
Visual Basic (Declaration)
Public VRdz As Double
Visual C++
public:
double VRdz

See Also

StationDuctilityDesignResults Class


Story Class

[image]

ENGISSOL - EC3/8 Design Library
Story Class
Members See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Story
Visual Basic (Declaration)
Public Class Story
Visual C++
public ref class Story

Inheritance Hierarchy

System..::.Object
EC3Design..::.Story

See Also

Story Members


Story Members

[image] [image]

ENGISSOL - EC3/8 Design Library
Story Members
Story Class Constructors Methods Fields See Also Send Feedback
EC3/8 Design Library

The Story type exposes the following members.

Constructors

Name | Description
Story | Initializes a new instance of the Story class

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)

Fields

Name | Description
DuctilityDesignResults |
FirstStory |
LastStory |
Name |
z |

See Also

Story Class


Story Constructor

[image]

ENGISSOL - EC3/8 Design Library
Story Constructor
Story Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the Story class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Story()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Story()

See Also

Story Class


Story Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
Story Fields
Story Class See Also Send Feedback
EC3/8 Design Library

The Story type exposes the following members.

Fields

Name | Description
DuctilityDesignResults |
FirstStory |
LastStory |
Name |
z |

See Also

Story Class


DuctilityDesignResults Field

[image]

ENGISSOL - EC3/8 Design Library
Story..::.DuctilityDesignResults Field
Story Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StoryDuctilityDesignResults DuctilityDesignResults
Visual Basic (Declaration)
Public DuctilityDesignResults As StoryDuctilityDesignResults
Visual C++
public:
StoryDuctilityDesignResults^ DuctilityDesignResults

See Also

Story Class


FirstStory Field

[image]

ENGISSOL - EC3/8 Design Library
Story..::.FirstStory Field
Story Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool FirstStory
Visual Basic (Declaration)
Public FirstStory As Boolean
Visual C++
public:
bool FirstStory

See Also

Story Class


LastStory Field

[image]

ENGISSOL - EC3/8 Design Library
Story..::.LastStory Field
Story Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LastStory
Visual Basic (Declaration)
Public LastStory As Boolean
Visual C++
public:
bool LastStory

See Also

Story Class


Name Field

[image]

ENGISSOL - EC3/8 Design Library
Story..::.Name Field
Story Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name
Visual Basic (Declaration)
Public Name As String
Visual C++
public:
String^ Name

See Also

Story Class


z Field

[image]

ENGISSOL - EC3/8 Design Library
Story..::.z Field
Story Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double z
Visual Basic (Declaration)
Public z As Double
Visual C++
public:
double z

See Also

Story Class


Story Methods

[image] [image]

ENGISSOL - EC3/8 Design Library
Story Methods
Story Class See Also Send Feedback
EC3/8 Design Library

The Story type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)

See Also

Story Class


Equals Method

[image]

ENGISSOL - EC3/8 Design Library
Story..::.Equals Method
Story Class See Also Send Feedback
EC3/8 Design Library

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Story Class


StoryDuctilityDesignResults Class

[image]

ENGISSOL - EC3/8 Design Library
StoryDuctilityDesignResults Class
Members See Also Send Feedback
EC3/8 Design Library
Ducility design results regarding a story

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StoryDuctilityDesignResults
Visual Basic (Declaration)
Public Class StoryDuctilityDesignResults
Visual C++
public ref class StoryDuctilityDesignResults

Inheritance Hierarchy

System..::.Object
EC3Design..::.StoryDuctilityDesignResults

See Also

StoryDuctilityDesignResults Members


StoryDuctilityDesignResults Members

[image] [image]

ENGISSOL - EC3/8 Design Library
StoryDuctilityDesignResults Members
StoryDuctilityDesignResults Class Constructors Fields See Also Send Feedback
EC3/8 Design Library

The StoryDuctilityDesignResults type exposes the following members.

Constructors

Name | Description
StoryDuctilityDesignResults | Initializes a new instance of the StoryDuctilityDesignResults class

Fields

Name | Description
Aminus | Area of horizontal projections of the cross sections of the tension diagonals, when the horizontal seismic actions have a negative direction
Aplus | Area of horizontal projections of the cross sections of the tension diagonals, when the horizontal seismic actions have a positive direction
CheckSatisfied | True, if check according to (6.11), paragraph 6.7.1 ios satisfied, otherwise false

See Also

StoryDuctilityDesignResults Class


StoryDuctilityDesignResults Constructor

[image]

ENGISSOL - EC3/8 Design Library
StoryDuctilityDesignResults Constructor
StoryDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Initializes a new instance of the StoryDuctilityDesignResults class

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StoryDuctilityDesignResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StoryDuctilityDesignResults()

See Also

StoryDuctilityDesignResults Class


StoryDuctilityDesignResults Fields

[image] [image]

ENGISSOL - EC3/8 Design Library
StoryDuctilityDesignResults Fields
StoryDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library

The StoryDuctilityDesignResults type exposes the following members.

Fields

Name | Description
Aminus | Area of horizontal projections of the cross sections of the tension diagonals, when the horizontal seismic actions have a negative direction
Aplus | Area of horizontal projections of the cross sections of the tension diagonals, when the horizontal seismic actions have a positive direction
CheckSatisfied | True, if check according to (6.11), paragraph 6.7.1 ios satisfied, otherwise false

See Also

StoryDuctilityDesignResults Class


Aminus Field

[image]

ENGISSOL - EC3/8 Design Library
StoryDuctilityDesignResults..::.Aminus Field
StoryDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Area of horizontal projections of the cross sections of the tension diagonals, when the horizontal seismic actions have a negative direction

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Aminus
Visual Basic (Declaration)
Public Aminus As Double
Visual C++
public:
double Aminus

See Also

StoryDuctilityDesignResults Class


Aplus Field

[image]

ENGISSOL - EC3/8 Design Library
StoryDuctilityDesignResults..::.Aplus Field
StoryDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
Area of horizontal projections of the cross sections of the tension diagonals, when the horizontal seismic actions have a positive direction

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Aplus
Visual Basic (Declaration)
Public Aplus As Double
Visual C++
public:
double Aplus

See Also

StoryDuctilityDesignResults Class


CheckSatisfied Field

[image]

ENGISSOL - EC3/8 Design Library
StoryDuctilityDesignResults..::.CheckSatisfied Field
StoryDuctilityDesignResults Class See Also Send Feedback
EC3/8 Design Library
True, if check according to (6.11), paragraph 6.7.1 ios satisfied, otherwise false

Namespace: EC3Design
Assembly: EC3Design (in EC3Design.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckSatisfied
Visual Basic (Declaration)
Public CheckSatisfied As Boolean
Visual C++
public:
bool CheckSatisfied

See Also

StoryDuctilityDesignResults Class