SteelConnectionsEC3 Namespace

[image]

ENGISSOL - EC3 Steel Connection Design Library
SteelConnectionsEC3 Namespace
Send Feedback
EC3 Steel Connection Design Library

Classes

Class | Description
BeamColumnAngleConnection | Represents a beam to column connection by means of a single or double cleat Variables definition:
BeamColumnAngleConnectionInputWarnings | Input warnings class for the connection
BeamColumnAngleConnectionResults | Connection results class
BeamColumnEndplateConnection | Represents a singe or double side beam to column connection by means of an endplate Variables definition:
BeamColumnEndplateConnectionInputWarnings | Input warnings class for the connection
BeamColumnEndplateConnectionResults | Connection results class
BeamColumnPlate1Connection | Represents a beam to column(H) connection by means of a single bolted plate Variables definition:
BeamColumnPlate1ConnectionInputWarnings | Input warnings class for the connection
BeamColumnPlate1ConnectionResults | Connection results class
BeamColumnPlate2Connection | Represents a beam to column(RHS) connection by means of a single bolted plate Variables definition:
BeamColumnPlate2ConnectionInputWarnings | Input warnings class for the connection
BeamColumnPlate2ConnectionResults | Connection results class
BeamColumnPlate3Connection | Represents a beam to column(CHS) connection by means of a single bolted plate Variables definition:
BeamColumnPlate3ConnectionInputWarnings | Input warnings class for the connection
BeamColumnPlate3ConnectionResults | Connection results class
BeamColumnRowResults | Represents results regarding to one bolt row
BeamColumnTeeConnection | Represents a beam to column connection by means of a Tee plate welded to the column and an endplate bolted to it Variables definition:
BeamColumnTeeConnectionInputWarnings | Input warnings class for the connection
BeamColumnTeeConnectionResults | Connection results class
BeamColumnWeldedConnection | Represents a singe or double side beam to column welded connection Variables definition:
BeamColumnWeldedConnectionInputWarnings | Input warnings class for the connection
BeamColumnWeldedConnectionResults | Connection results class
BeamOnBeamConnection | Represents a beam to beam connection by means of a single or double cleat Variables definition:
BeamOnBeamConnectionInputWarnings | Input warnings class for the connection
BeamOnBeamConnectionResults | Connection results class
BeamOnBeamTeeConnection | Represents a beam to beam connection by means of a Tee member and an endplate Variables definition:
BeamOnBeamTeeConnectionInputWarnings | Input warnings class for the connection
BeamOnBeamTeeConnectionResults | Connection results class
BeamSplices1Connection | Represents a beam splice connection between 2 H section members by means of web and flange plates Variables definition:
BeamSplices1ConnectionInputWarnings | Input warnings class for the connection
BeamSplices1ConnectionResults | Connection results class
BeamSplices2Connection | Represents a beam splice connection between 2 H section members by means of welded web plates and in-fill welds between the flanges Variables definition:
BeamSplices2ConnectionInputWarnings | Input warnings class for the connection
BeamSplices2ConnectionResults | Connection results class
BeamSplicesEndplateConnection | Represents a beam splice connection between 2 H section members by means of endplates Variables definition:
BeamSplicesEndplateConnectionInputWarnings | Input warnings class for the connection
BeamSplicesEndplateConnectionResults | Connection results class
BeamSplicesRowResults | Represents results regarding to one bolt row
BoltedBasePlate | Represents a bolted baseplate connected to a column Variables definition:
BoltedEndPlate | Represents a bolted endplate connected to a column Variables definition:
Bolts | Represents a bolt Variables definition:
CHSChordConnection | Hollow section joints between CHS members according to 7.4 [prEN 1993-1-8 : 2003]
ColumnBaseplateConnection | Represents a column base connection by means of a baseplate Variables definition:
ColumnBaseplateConnectionInputWarnings | Input warnings class for the connection
ColumnBaseplateConnectionResults | Connection results class
LoadCase | Represents a loadcase
MemberOnJoint1Connection | Represents a bolted connection between a member (single or double) and a plate Variables definition:
MemberOnJoint1ConnectionInputWarnings | Input warnings class for the connection
MemberOnJoint1ConnectionResults | Connection results class
MemberOnJoint2Connection | Represents a welded connection between a member (single or double) and a plate Variables definition:
MemberOnJoint2ConnectionInputWarnings | Input warnings class for the connection
MemberOnJoint2ConnectionResults | Connection results class
MemberOnJoint3Connection | Represents a bolted connection between 3 member (single or double) and a plate Variables definition:
MemberOnJoint3ConnectionInputWarnings | Input warnings class for the connection
MemberOnJoint3ConnectionResults | Connection results class
MemberOnJoint4Connection | Represents a welded connection between 3 member (single or double) and a plate Variables definition:
MemberOnJoint4ConnectionInputWarnings | Input warnings class for the connection
MemberOnJoint4ConnectionResults | Connection results class
OneSideBeamColumnEndplateInputWarnings | Input warnings class for the connection
OneSideBeamColumnEndplateResults |
OneSideBeamColumnWeldedInputWarnings | Input warnings class for the connection
OneSideBeamColumnWeldedResults |
RHSChordConnection | Hollow section joints between RHS chord members and CHS/RHS brace members according to 7.5 [prEN 1993-1-8 : 2003]
SingleBoltedPlate | Represents a general bolted plate Variables definition:
SteelGrade | Represents a steel grade according to prEN1993

Enumerations

Enumeration | Description
BoltedBasePlate..::.LoadTransferBasePlate | Represents the load direction transferred from the column to the baseplate
BoltedEndPlate..::.LoadTransferEndPlate | Represents the load direction transferred from the beam to the endplate
Bolts..::.Grade | Bolt grade
Bolts..::.Type | Bolt type
SingleBoltedPlate..::.LoadTransferSingleBoltedPlate | Represents the load direction transferred to the plate
SteelGrade..::.Grade | Enumeration of the steel grades supported by prEN1993
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


BeamColumnAngleConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam to column connection by means of a single or double cleat

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnAngleConnection
Visual Basic (Declaration)
Public Class BeamColumnAngleConnection
Visual C++
public ref class BeamColumnAngleConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnAngleConnection

See Also

BeamColumnAngleConnection Members
SteelConnectionsEC3 Namespace


BeamColumnAngleConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection Members
BeamColumnAngleConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnAngleConnection type exposes the following members.

Constructors

Name | Description
BeamColumnAngleConnection | Initializes a new instance of the BeamColumnAngleConnection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AboutCoumnMajorAxis | True, if the connection is implemented about the major axis of the column, otherwise false
aLeft | Weld thickness in case of welded connection between Left beam and cleat(s)
aRight | Weld thickness in case of welded connection between right beam and cleat(s)
BeamLeft | Left beam object
BeamRight | Right beam object
BeamSteel | Beam steel grade
Column | Column steel grade
LeftConnectionAlso | True, if a left connection exists
LoadCasesLeft | Load cases of left beam
LoadCasesRight | Loadcases of right beam
OnlyOneAnglePerConnection | True, if a single cleat is used, otherwise (in case of double cleat), false
PlateOnBeamLeft | Bolted plate on Left beam
PlateOnBeamRight | Bolted plate on right beam
PlateOnColumnLeft | Bolted plate on the left of the column
PlateOnColumnRight | Bolted plate on the right of the column
Results | List of results
WeldedOnBeamLeft | True, if the connection between Left beam and cleat(s) is welded, otherwise false
WeldedOnBeamRight | True, if the connection between right beam and cleat(s) is welded, otherwise false

See Also

BeamColumnAngleConnection Class


BeamColumnAngleConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection Constructor
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnAngleConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnAngleConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnAngleConnection()

See Also

BeamColumnAngleConnection Class


BeamColumnAngleConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection Fields
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnAngleConnection type exposes the following members.

Fields

Name | Description
AboutCoumnMajorAxis | True, if the connection is implemented about the major axis of the column, otherwise false
aLeft | Weld thickness in case of welded connection between Left beam and cleat(s)
aRight | Weld thickness in case of welded connection between right beam and cleat(s)
BeamLeft | Left beam object
BeamRight | Right beam object
BeamSteel | Beam steel grade
Column | Column steel grade
LeftConnectionAlso | True, if a left connection exists
LoadCasesLeft | Load cases of left beam
LoadCasesRight | Loadcases of right beam
OnlyOneAnglePerConnection | True, if a single cleat is used, otherwise (in case of double cleat), false
PlateOnBeamLeft | Bolted plate on Left beam
PlateOnBeamRight | Bolted plate on right beam
PlateOnColumnLeft | Bolted plate on the left of the column
PlateOnColumnRight | Bolted plate on the right of the column
Results | List of results
WeldedOnBeamLeft | True, if the connection between Left beam and cleat(s) is welded, otherwise false
WeldedOnBeamRight | True, if the connection between right beam and cleat(s) is welded, otherwise false

See Also

BeamColumnAngleConnection Class


AboutCoumnMajorAxis Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.AboutCoumnMajorAxis Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the connection is implemented about the major axis of the column, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AboutCoumnMajorAxis
Visual Basic (Declaration)
Public AboutCoumnMajorAxis As Boolean
Visual C++
public:
bool AboutCoumnMajorAxis

Remarks

See Also

BeamColumnAngleConnection Class


aLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.aLeft Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness in case of welded connection between Left beam and cleat(s)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aLeft
Visual Basic (Declaration)
Public aLeft As Double
Visual C++
public:
double aLeft

Remarks

See Also

BeamColumnAngleConnection Class


aRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.aRight Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness in case of welded connection between right beam and cleat(s)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aRight
Visual Basic (Declaration)
Public aRight As Double
Visual C++
public:
double aRight

Remarks

See Also

BeamColumnAngleConnection Class


BeamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.BeamLeft Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Left beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection BeamLeft
Visual Basic (Declaration)
Public BeamLeft As HSection
Visual C++
public:
HSection^ BeamLeft

Remarks

See Also

BeamColumnAngleConnection Class


BeamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.BeamRight Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Right beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection BeamRight
Visual Basic (Declaration)
Public BeamRight As HSection
Visual C++
public:
HSection^ BeamRight

Remarks

See Also

BeamColumnAngleConnection Class


BeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.BeamSteel Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade BeamSteel
Visual Basic (Declaration)
Public BeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ BeamSteel

Remarks

See Also

BeamColumnAngleConnection Class


Column Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.Column Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Column
Visual Basic (Declaration)
Public Column As HSection
Visual C++
public:
HSection^ Column

Remarks

See Also

BeamColumnAngleConnection Class


LeftConnectionAlso Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.LeftConnectionAlso Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a left connection exists

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LeftConnectionAlso
Visual Basic (Declaration)
Public LeftConnectionAlso As Boolean
Visual C++
public:
bool LeftConnectionAlso

Remarks

See Also

BeamColumnAngleConnection Class


LoadCasesLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.LoadCasesLeft Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of left beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesLeft
Visual Basic (Declaration)
Public LoadCasesLeft As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesLeft

Remarks

Following forces are considered:

Ved (positive=downwards)

See Also

BeamColumnAngleConnection Class


LoadCasesRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.LoadCasesRight Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Loadcases of right beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesRight
Visual Basic (Declaration)
Public LoadCasesRight As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesRight

Remarks

Following forces are considered:

Ved (positive=downwards)

See Also

BeamColumnAngleConnection Class


OnlyOneAnglePerConnection Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.OnlyOneAnglePerConnection Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a single cleat is used, otherwise (in case of double cleat), false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool OnlyOneAnglePerConnection
Visual Basic (Declaration)
Public OnlyOneAnglePerConnection As Boolean
Visual C++
public:
bool OnlyOneAnglePerConnection

Remarks

See Also

BeamColumnAngleConnection Class


PlateOnBeamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.PlateOnBeamLeft Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate on Left beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate PlateOnBeamLeft
Visual Basic (Declaration)
Public PlateOnBeamLeft As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ PlateOnBeamLeft

Remarks

See Also

BeamColumnAngleConnection Class


PlateOnBeamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.PlateOnBeamRight Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate on right beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate PlateOnBeamRight
Visual Basic (Declaration)
Public PlateOnBeamRight As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ PlateOnBeamRight

Remarks

See Also

BeamColumnAngleConnection Class


PlateOnColumnLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.PlateOnColumnLeft Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate on the left of the column

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate PlateOnColumnLeft
Visual Basic (Declaration)
Public PlateOnColumnLeft As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ PlateOnColumnLeft

Remarks

See Also

BeamColumnAngleConnection Class


PlateOnColumnRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.PlateOnColumnRight Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate on the right of the column

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate PlateOnColumnRight
Visual Basic (Declaration)
Public PlateOnColumnRight As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ PlateOnColumnRight

Remarks

See Also

BeamColumnAngleConnection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.Results Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamColumnAngleConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamColumnAngleConnectionResults)
Visual C++
public:
List<BeamColumnAngleConnectionResults^>^ Results

Remarks

See Also

BeamColumnAngleConnection Class


WeldedOnBeamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.WeldedOnBeamLeft Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the connection between Left beam and cleat(s) is welded, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WeldedOnBeamLeft
Visual Basic (Declaration)
Public WeldedOnBeamLeft As Boolean
Visual C++
public:
bool WeldedOnBeamLeft

Remarks

See Also

BeamColumnAngleConnection Class


WeldedOnBeamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.WeldedOnBeamRight Field
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the connection between right beam and cleat(s) is welded, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WeldedOnBeamRight
Visual Basic (Declaration)
Public WeldedOnBeamRight As Boolean
Visual C++
public:
bool WeldedOnBeamRight

Remarks

See Also

BeamColumnAngleConnection Class


BeamColumnAngleConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection Methods
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnAngleConnection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnAngleConnection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.Calculate Method
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamColumnAngleConnection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnection..::.GetInputWarnings Method
BeamColumnAngleConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnAngleConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamColumnAngleConnectionInputWarnings
Visual C++
public:
BeamColumnAngleConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamColumnAngleConnection Class


BeamColumnAngleConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnAngleConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamColumnAngleConnectionInputWarnings
Visual C++
public ref class BeamColumnAngleConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnAngleConnectionInputWarnings

See Also

BeamColumnAngleConnectionInputWarnings Members


BeamColumnAngleConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings Members
BeamColumnAngleConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnAngleConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamColumnAngleConnectionInputWarnings | Initializes a new instance of the BeamColumnAngleConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
LeftPlateOnBeam | Input warnings regarding the left plate on beam
LeftPlateOnColumn | Input warnings regarding the left plate on column
Other | Input warnings regarding other connection parts
RightPlateOnBeam | Input warnings regarding the right plate on beam
RightPlateOnColumn | Input warnings regarding the right plate on column
Welds | Input warnings regarding welds

See Also

BeamColumnAngleConnectionInputWarnings Class


BeamColumnAngleConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings Constructor
BeamColumnAngleConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnAngleConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnAngleConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnAngleConnectionInputWarnings()

See Also

BeamColumnAngleConnectionInputWarnings Class


BeamColumnAngleConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings Fields
BeamColumnAngleConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnAngleConnectionInputWarnings type exposes the following members.

Fields

Name | Description
LeftPlateOnBeam | Input warnings regarding the left plate on beam
LeftPlateOnColumn | Input warnings regarding the left plate on column
Other | Input warnings regarding other connection parts
RightPlateOnBeam | Input warnings regarding the right plate on beam
RightPlateOnColumn | Input warnings regarding the right plate on column
Welds | Input warnings regarding welds

See Also

BeamColumnAngleConnectionInputWarnings Class


LeftPlateOnBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings..::.LeftPlateOnBeam Field
BeamColumnAngleConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the left plate on beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> LeftPlateOnBeam
Visual Basic (Declaration)
Public LeftPlateOnBeam As List(Of String)
Visual C++
public:
List<String^>^ LeftPlateOnBeam

Remarks

See Also

BeamColumnAngleConnectionInputWarnings Class


LeftPlateOnColumn Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings..::.LeftPlateOnColumn Field
BeamColumnAngleConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the left plate on column

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> LeftPlateOnColumn
Visual Basic (Declaration)
Public LeftPlateOnColumn As List(Of String)
Visual C++
public:
List<String^>^ LeftPlateOnColumn

Remarks

See Also

BeamColumnAngleConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings..::.Other Field
BeamColumnAngleConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamColumnAngleConnectionInputWarnings Class


RightPlateOnBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings..::.RightPlateOnBeam Field
BeamColumnAngleConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the right plate on beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> RightPlateOnBeam
Visual Basic (Declaration)
Public RightPlateOnBeam As List(Of String)
Visual C++
public:
List<String^>^ RightPlateOnBeam

Remarks

See Also

BeamColumnAngleConnectionInputWarnings Class


RightPlateOnColumn Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings..::.RightPlateOnColumn Field
BeamColumnAngleConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the right plate on column

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> RightPlateOnColumn
Visual Basic (Declaration)
Public RightPlateOnColumn As List(Of String)
Visual C++
public:
List<String^>^ RightPlateOnColumn

Remarks

See Also

BeamColumnAngleConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings..::.Welds Field
BeamColumnAngleConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamColumnAngleConnectionInputWarnings Class


BeamColumnAngleConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionInputWarnings Methods
BeamColumnAngleConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnAngleConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnAngleConnectionInputWarnings Class


BeamColumnAngleConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnAngleConnectionResults
Visual Basic (Declaration)
Public Class BeamColumnAngleConnectionResults
Visual C++
public ref class BeamColumnAngleConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnAngleConnectionResults

See Also

BeamColumnAngleConnectionResults Members


BeamColumnAngleConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults Members
BeamColumnAngleConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnAngleConnectionResults type exposes the following members.

Constructors

Name | Description
BeamColumnAngleConnectionResults | Initializes a new instance of the BeamColumnAngleConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BeamLeftBoltsBearingCapacity | Left connection beam bolts bearing capacity, if not Left welded connection
BeamLeftBoltsBearingResistance | Left connection beam bolts bearing resistance, if not Left welded connection
BeamLeftMostStressesBoltShearCapacity | Shear capacity of the most stressed bolt on the Left beam, if not Left welded connection
BeamLeftMostStressesBoltShearResistance | Shear resistance of the most stressed bolt on the Left beam, if not Left welded connection
BeamLeftPlateTearBlockingCapacity | Left connection beam pleta tear blocking capacity, if not Left welded connection
BeamLeftPlateTearBlockingResistance | Left connection beam plate tear blocking resistance, if not Left welded connection
BeamLeftTearBlockingCapacity | Left connection beam web tear blocking capacity, if not Left welded connection
BeamLeftTearBlockingResistance | Left connection beam web tear blocking resistance, if not Left welded connection
BeamRightBoltsBearingCapacity | Right connection beam bolts bearing capacity, if not right welded connection
BeamRightBoltsBearingResistance | Right connection beam bolts bearing resistance, if not right welded connection
BeamRightMostStressesBoltShearCapacity | Shear capacity of the most stressed bolt on the right beam, if not right welded connection
BeamRightMostStressesBoltShearResistance | Shear resistance of the most stressed bolt on the right beam, if not right welded connection
BeamRightPlateTearBlockingCapacity | Right connection beam pleta tear blocking capacity, if not right welded connection
BeamRightPlateTearBlockingResistance | Right connection beam plate tear blocking resistance, if not right welded connection
BeamRightTearBlockingCapacity | Right connection beam web tear blocking capacity, if not right welded connection
BeamRightTearBlockingResistance | Right connection beam web tear blocking resistance, if not right welded connection
ColumnBoltsLeftBearingCapacity | Left connection column bolts bearing capacity
ColumnBoltsLeftBearingResistance | Left connection column bolts bearing resistance
ColumnBoltsLeftShearCapacity | Left connection column bolts shear capacity
ColumnBoltsLeftShearResistance | Left connection column bolts shear resistance
ColumnBoltsRightBearingCapacity | Right connection column bolts bearing capacity
ColumnBoltsRightBearingResistance | Right connection column bolts bearing resistance
ColumnBoltsRightShearCapacity | Right connection column bolts shear capacity
ColumnBoltsRightShearResistance | Right connection column bolts shear resistance
LeftPlateOnColumnTearBlockingCapacity | Left connection column plate tear blocking capacity
LeftPlateOnColumnTearBlockingResistance | Left connection column plate tear blocking resistance
MomentAngleLeftCapacity | Left cleat moment capacity
MomentAngleLeftResistance | Left cleat moment resistance
MomentAngleRightCapacity | Right cleat moment capacity
MomentAngleRightResistance | Right cleat moment resistance
RightPlateOnColumnTearBlockingCapacity | Right connection column plate tear blocking capacity
RightPlateOnColumnTearBlockingResistance | Right connection column plate tear blocking resistance
ShearAngleLeftCapacity | Left cleat shear capacity
ShearAngleLeftResistance | Left cleat shear resistance
ShearAngleRightCapacity | Right cleat shear capacity
ShearAngleRightResistance | Right cleat shear resistance
WeldLeftCapacity | Left connection between beam web and clear weld capacity, if welded Left connection
WeldLeftResistance | Left connection between beam web and clear weld resistance, if welded Left connection
WeldRightCapacity | Right connection between beam web and clear weld capacity, if welded right connection
WeldRightResistance | Right connection between beam web and clear weld resistance, if welded right connection

See Also

BeamColumnAngleConnectionResults Class


BeamColumnAngleConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults Constructor
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnAngleConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnAngleConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnAngleConnectionResults()

See Also

BeamColumnAngleConnectionResults Class


BeamColumnAngleConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults Fields
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnAngleConnectionResults type exposes the following members.

Fields

Name | Description
BeamLeftBoltsBearingCapacity | Left connection beam bolts bearing capacity, if not Left welded connection
BeamLeftBoltsBearingResistance | Left connection beam bolts bearing resistance, if not Left welded connection
BeamLeftMostStressesBoltShearCapacity | Shear capacity of the most stressed bolt on the Left beam, if not Left welded connection
BeamLeftMostStressesBoltShearResistance | Shear resistance of the most stressed bolt on the Left beam, if not Left welded connection
BeamLeftPlateTearBlockingCapacity | Left connection beam pleta tear blocking capacity, if not Left welded connection
BeamLeftPlateTearBlockingResistance | Left connection beam plate tear blocking resistance, if not Left welded connection
BeamLeftTearBlockingCapacity | Left connection beam web tear blocking capacity, if not Left welded connection
BeamLeftTearBlockingResistance | Left connection beam web tear blocking resistance, if not Left welded connection
BeamRightBoltsBearingCapacity | Right connection beam bolts bearing capacity, if not right welded connection
BeamRightBoltsBearingResistance | Right connection beam bolts bearing resistance, if not right welded connection
BeamRightMostStressesBoltShearCapacity | Shear capacity of the most stressed bolt on the right beam, if not right welded connection
BeamRightMostStressesBoltShearResistance | Shear resistance of the most stressed bolt on the right beam, if not right welded connection
BeamRightPlateTearBlockingCapacity | Right connection beam pleta tear blocking capacity, if not right welded connection
BeamRightPlateTearBlockingResistance | Right connection beam plate tear blocking resistance, if not right welded connection
BeamRightTearBlockingCapacity | Right connection beam web tear blocking capacity, if not right welded connection
BeamRightTearBlockingResistance | Right connection beam web tear blocking resistance, if not right welded connection
ColumnBoltsLeftBearingCapacity | Left connection column bolts bearing capacity
ColumnBoltsLeftBearingResistance | Left connection column bolts bearing resistance
ColumnBoltsLeftShearCapacity | Left connection column bolts shear capacity
ColumnBoltsLeftShearResistance | Left connection column bolts shear resistance
ColumnBoltsRightBearingCapacity | Right connection column bolts bearing capacity
ColumnBoltsRightBearingResistance | Right connection column bolts bearing resistance
ColumnBoltsRightShearCapacity | Right connection column bolts shear capacity
ColumnBoltsRightShearResistance | Right connection column bolts shear resistance
LeftPlateOnColumnTearBlockingCapacity | Left connection column plate tear blocking capacity
LeftPlateOnColumnTearBlockingResistance | Left connection column plate tear blocking resistance
MomentAngleLeftCapacity | Left cleat moment capacity
MomentAngleLeftResistance | Left cleat moment resistance
MomentAngleRightCapacity | Right cleat moment capacity
MomentAngleRightResistance | Right cleat moment resistance
RightPlateOnColumnTearBlockingCapacity | Right connection column plate tear blocking capacity
RightPlateOnColumnTearBlockingResistance | Right connection column plate tear blocking resistance
ShearAngleLeftCapacity | Left cleat shear capacity
ShearAngleLeftResistance | Left cleat shear resistance
ShearAngleRightCapacity | Right cleat shear capacity
ShearAngleRightResistance | Right cleat shear resistance
WeldLeftCapacity | Left connection between beam web and clear weld capacity, if welded Left connection
WeldLeftResistance | Left connection between beam web and clear weld resistance, if welded Left connection
WeldRightCapacity | Right connection between beam web and clear weld capacity, if welded right connection
WeldRightResistance | Right connection between beam web and clear weld resistance, if welded right connection

See Also

BeamColumnAngleConnectionResults Class


BeamLeftBoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamLeftBoltsBearingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam bolts bearing capacity, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftBoltsBearingCapacity
Visual Basic (Declaration)
Public BeamLeftBoltsBearingCapacity As Double
Visual C++
public:
double BeamLeftBoltsBearingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamLeftBoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamLeftBoltsBearingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam bolts bearing resistance, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftBoltsBearingResistance
Visual Basic (Declaration)
Public BeamLeftBoltsBearingResistance As Double
Visual C++
public:
double BeamLeftBoltsBearingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamLeftMostStressesBoltShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamLeftMostStressesBoltShearCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear capacity of the most stressed bolt on the Left beam, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftMostStressesBoltShearCapacity
Visual Basic (Declaration)
Public BeamLeftMostStressesBoltShearCapacity As Double
Visual C++
public:
double BeamLeftMostStressesBoltShearCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamLeftMostStressesBoltShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamLeftMostStressesBoltShearResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the most stressed bolt on the Left beam, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftMostStressesBoltShearResistance
Visual Basic (Declaration)
Public BeamLeftMostStressesBoltShearResistance As Double
Visual C++
public:
double BeamLeftMostStressesBoltShearResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamLeftPlateTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamLeftPlateTearBlockingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam pleta tear blocking capacity, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftPlateTearBlockingCapacity
Visual Basic (Declaration)
Public BeamLeftPlateTearBlockingCapacity As Double
Visual C++
public:
double BeamLeftPlateTearBlockingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamLeftPlateTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamLeftPlateTearBlockingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam plate tear blocking resistance, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftPlateTearBlockingResistance
Visual Basic (Declaration)
Public BeamLeftPlateTearBlockingResistance As Double
Visual C++
public:
double BeamLeftPlateTearBlockingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamLeftTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamLeftTearBlockingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam web tear blocking capacity, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftTearBlockingCapacity
Visual Basic (Declaration)
Public BeamLeftTearBlockingCapacity As Double
Visual C++
public:
double BeamLeftTearBlockingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamLeftTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamLeftTearBlockingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam web tear blocking resistance, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftTearBlockingResistance
Visual Basic (Declaration)
Public BeamLeftTearBlockingResistance As Double
Visual C++
public:
double BeamLeftTearBlockingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamRightBoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamRightBoltsBearingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam bolts bearing capacity, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightBoltsBearingCapacity
Visual Basic (Declaration)
Public BeamRightBoltsBearingCapacity As Double
Visual C++
public:
double BeamRightBoltsBearingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamRightBoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamRightBoltsBearingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam bolts bearing resistance, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightBoltsBearingResistance
Visual Basic (Declaration)
Public BeamRightBoltsBearingResistance As Double
Visual C++
public:
double BeamRightBoltsBearingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamRightMostStressesBoltShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamRightMostStressesBoltShearCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear capacity of the most stressed bolt on the right beam, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightMostStressesBoltShearCapacity
Visual Basic (Declaration)
Public BeamRightMostStressesBoltShearCapacity As Double
Visual C++
public:
double BeamRightMostStressesBoltShearCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamRightMostStressesBoltShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamRightMostStressesBoltShearResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the most stressed bolt on the right beam, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightMostStressesBoltShearResistance
Visual Basic (Declaration)
Public BeamRightMostStressesBoltShearResistance As Double
Visual C++
public:
double BeamRightMostStressesBoltShearResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamRightPlateTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamRightPlateTearBlockingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam pleta tear blocking capacity, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightPlateTearBlockingCapacity
Visual Basic (Declaration)
Public BeamRightPlateTearBlockingCapacity As Double
Visual C++
public:
double BeamRightPlateTearBlockingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamRightPlateTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamRightPlateTearBlockingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam plate tear blocking resistance, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightPlateTearBlockingResistance
Visual Basic (Declaration)
Public BeamRightPlateTearBlockingResistance As Double
Visual C++
public:
double BeamRightPlateTearBlockingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamRightTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamRightTearBlockingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam web tear blocking capacity, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightTearBlockingCapacity
Visual Basic (Declaration)
Public BeamRightTearBlockingCapacity As Double
Visual C++
public:
double BeamRightTearBlockingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamRightTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.BeamRightTearBlockingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam web tear blocking resistance, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightTearBlockingResistance
Visual Basic (Declaration)
Public BeamRightTearBlockingResistance As Double
Visual C++
public:
double BeamRightTearBlockingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


ColumnBoltsLeftBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ColumnBoltsLeftBearingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection column bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnBoltsLeftBearingCapacity
Visual Basic (Declaration)
Public ColumnBoltsLeftBearingCapacity As Double
Visual C++
public:
double ColumnBoltsLeftBearingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


ColumnBoltsLeftBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ColumnBoltsLeftBearingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection column bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnBoltsLeftBearingResistance
Visual Basic (Declaration)
Public ColumnBoltsLeftBearingResistance As Double
Visual C++
public:
double ColumnBoltsLeftBearingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


ColumnBoltsLeftShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ColumnBoltsLeftShearCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection column bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnBoltsLeftShearCapacity
Visual Basic (Declaration)
Public ColumnBoltsLeftShearCapacity As Double
Visual C++
public:
double ColumnBoltsLeftShearCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


ColumnBoltsLeftShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ColumnBoltsLeftShearResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection column bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnBoltsLeftShearResistance
Visual Basic (Declaration)
Public ColumnBoltsLeftShearResistance As Double
Visual C++
public:
double ColumnBoltsLeftShearResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


ColumnBoltsRightBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ColumnBoltsRightBearingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection column bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnBoltsRightBearingCapacity
Visual Basic (Declaration)
Public ColumnBoltsRightBearingCapacity As Double
Visual C++
public:
double ColumnBoltsRightBearingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


ColumnBoltsRightBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ColumnBoltsRightBearingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection column bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnBoltsRightBearingResistance
Visual Basic (Declaration)
Public ColumnBoltsRightBearingResistance As Double
Visual C++
public:
double ColumnBoltsRightBearingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


ColumnBoltsRightShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ColumnBoltsRightShearCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection column bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnBoltsRightShearCapacity
Visual Basic (Declaration)
Public ColumnBoltsRightShearCapacity As Double
Visual C++
public:
double ColumnBoltsRightShearCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


ColumnBoltsRightShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ColumnBoltsRightShearResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection column bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnBoltsRightShearResistance
Visual Basic (Declaration)
Public ColumnBoltsRightShearResistance As Double
Visual C++
public:
double ColumnBoltsRightShearResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


LeftPlateOnColumnTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.LeftPlateOnColumnTearBlockingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection column plate tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double LeftPlateOnColumnTearBlockingCapacity
Visual Basic (Declaration)
Public LeftPlateOnColumnTearBlockingCapacity As Double
Visual C++
public:
double LeftPlateOnColumnTearBlockingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


LeftPlateOnColumnTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.LeftPlateOnColumnTearBlockingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection column plate tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double LeftPlateOnColumnTearBlockingResistance
Visual Basic (Declaration)
Public LeftPlateOnColumnTearBlockingResistance As Double
Visual C++
public:
double LeftPlateOnColumnTearBlockingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


MomentAngleLeftCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.MomentAngleLeftCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left cleat moment capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentAngleLeftCapacity
Visual Basic (Declaration)
Public MomentAngleLeftCapacity As Double
Visual C++
public:
double MomentAngleLeftCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


MomentAngleLeftResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.MomentAngleLeftResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left cleat moment resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentAngleLeftResistance
Visual Basic (Declaration)
Public MomentAngleLeftResistance As Double
Visual C++
public:
double MomentAngleLeftResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


MomentAngleRightCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.MomentAngleRightCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right cleat moment capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentAngleRightCapacity
Visual Basic (Declaration)
Public MomentAngleRightCapacity As Double
Visual C++
public:
double MomentAngleRightCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


MomentAngleRightResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.MomentAngleRightResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right cleat moment resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentAngleRightResistance
Visual Basic (Declaration)
Public MomentAngleRightResistance As Double
Visual C++
public:
double MomentAngleRightResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


RightPlateOnColumnTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.RightPlateOnColumnTearBlockingCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection column plate tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RightPlateOnColumnTearBlockingCapacity
Visual Basic (Declaration)
Public RightPlateOnColumnTearBlockingCapacity As Double
Visual C++
public:
double RightPlateOnColumnTearBlockingCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


RightPlateOnColumnTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.RightPlateOnColumnTearBlockingResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection column plate tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RightPlateOnColumnTearBlockingResistance
Visual Basic (Declaration)
Public RightPlateOnColumnTearBlockingResistance As Double
Visual C++
public:
double RightPlateOnColumnTearBlockingResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


ShearAngleLeftCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ShearAngleLeftCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left cleat shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearAngleLeftCapacity
Visual Basic (Declaration)
Public ShearAngleLeftCapacity As Double
Visual C++
public:
double ShearAngleLeftCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


ShearAngleLeftResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ShearAngleLeftResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left cleat shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearAngleLeftResistance
Visual Basic (Declaration)
Public ShearAngleLeftResistance As Double
Visual C++
public:
double ShearAngleLeftResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


ShearAngleRightCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ShearAngleRightCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right cleat shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearAngleRightCapacity
Visual Basic (Declaration)
Public ShearAngleRightCapacity As Double
Visual C++
public:
double ShearAngleRightCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


ShearAngleRightResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.ShearAngleRightResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right cleat shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearAngleRightResistance
Visual Basic (Declaration)
Public ShearAngleRightResistance As Double
Visual C++
public:
double ShearAngleRightResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


WeldLeftCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.WeldLeftCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection between beam web and clear weld capacity, if welded Left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldLeftCapacity
Visual Basic (Declaration)
Public WeldLeftCapacity As Double
Visual C++
public:
double WeldLeftCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


WeldLeftResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.WeldLeftResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection between beam web and clear weld resistance, if welded Left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldLeftResistance
Visual Basic (Declaration)
Public WeldLeftResistance As Double
Visual C++
public:
double WeldLeftResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


WeldRightCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.WeldRightCapacity Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection between beam web and clear weld capacity, if welded right connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldRightCapacity
Visual Basic (Declaration)
Public WeldRightCapacity As Double
Visual C++
public:
double WeldRightCapacity

Remarks

See Also

BeamColumnAngleConnectionResults Class


WeldRightResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults..::.WeldRightResistance Field
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection between beam web and clear weld resistance, if welded right connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldRightResistance
Visual Basic (Declaration)
Public WeldRightResistance As Double
Visual C++
public:
double WeldRightResistance

Remarks

See Also

BeamColumnAngleConnectionResults Class


BeamColumnAngleConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnAngleConnectionResults Methods
BeamColumnAngleConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnAngleConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnAngleConnectionResults Class


BeamColumnEndplateConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a singe or double side beam to column connection by means of an endplate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnEndplateConnection
Visual Basic (Declaration)
Public Class BeamColumnEndplateConnection
Visual C++
public ref class BeamColumnEndplateConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnEndplateConnection

See Also

BeamColumnEndplateConnection Members


BeamColumnEndplateConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection Members
BeamColumnEndplateConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnEndplateConnection type exposes the following members.

Constructors

Name | Description
BeamColumnEndplateConnection | Initializes a new instance of the BeamColumnEndplateConnection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
af_beamLeft | Weld thickness between left beam flange and endplate
af_beamRight | Weld thickness between right beam flange and endplate
aHaunchLeftBeamFlange | Weld thickness between left haunch flange and beam flange
aHaunchLeftEndPlateFlange | Weld thickness between left haunch flange and endplate
aHaunchLeftEndPlateWeb | Weld thickness between left haunch web and endplate
aHaunchRightBeamFlange | Weld thickness between right haunch flange and beam flange
aHaunchRightEndPlateFlange | Weld thickness between right haunch flange and endplate
aHaunchRightEndPlateWeb | Weld thickness between right haunch web and endplate
ast_col | Weld thickness between column web and transverse stiffners
aSupplementaryWebPlate | Weld thickness between supplementary column web plates and column web
aw_beamLeft | Weld thickness between left beam web and endplate
aw_beamRight | Weld thickness between right beam web and endplate
BeamLeft | Left beam object
BeamRight | Right beam object
bs | Supplementary column web plates width
bst_col | Column transverse stiffeners total width
Column | Column object
ColumnExtensionOverRightBeam | Net distance between column end and upper beam flange
ColumnSteel | Column steel grade
ds | Center distance between stiffeners
ds_over_rightBeamFlange | center distance between right upper beam flange and upper column web stiffener
HaunchLeft | Left haunch object
HaunchRight | Right haunch object
LeftBeamSteel | Left beam steel grade
LeftConnectionAlso | True, if left connection exist (double side connection), otherwise false
LoadCasesLeftBeam | Load cases of left beam, in case of double side connection
LoadCasesResultantColumn | Resultant loads on column from upper and lower stories
LoadCasesRightBeam | Load cases of right beam
NrOfSupplementaryWebPlates | Number of supplementary column web plates used (1, 2 or 3)
PlateLeft | Left endplate object
PlateRight | Right endplate object
Results | List of results
RightBeamSteel | Right beam steel grade
tbp_Left | Thickness of backing plates for the left connection, if used
tbp_Right | Thickness of backing plates for the right connection, if used
Theta_HaunchLeft | Angle between left beam and haunch flanges
Theta_HaunchRight | Angle between right beam and haunch flanges
ts | Supplementary column web plates thickness
tst_bLeft | True, if a haunch is used for the left connection, otherwise false
tst_bRight | True, if a haunch is used for the right connection, otherwise false
tst_col | Column transverse stiffeners thickness
UseOfBackingPlatesLeft | True, if backing plates are used for the left connection, otherwise false
UseOfBackingPlatesRight | True, if backing plates are used for the right connection, otherwise false
UseOfBeamLeftWebStiffener | True, if a beam web stiffener is used for the left connection, otherwise false
UseOfBeamRightWebStiffener | True, if a beam web stiffener is used for the right connection, otherwise false
UseOfColumnWebStiffeners | True is transverse column web stiffeners are used, otherwise false
UseOfDiagonalColumnWebStiffener | True is diagonal stiffeners are used, otherwise false
UseOfHaunchLeft | True, if a haunch is used for the left connection, otherwise false
UseOfHaunchRight | True, if a haunch is used for the right connection, otherwise false

See Also

BeamColumnEndplateConnection Class


BeamColumnEndplateConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection Constructor
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnEndplateConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnEndplateConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnEndplateConnection()

See Also

BeamColumnEndplateConnection Class


BeamColumnEndplateConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection Fields
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnEndplateConnection type exposes the following members.

Fields

Name | Description
af_beamLeft | Weld thickness between left beam flange and endplate
af_beamRight | Weld thickness between right beam flange and endplate
aHaunchLeftBeamFlange | Weld thickness between left haunch flange and beam flange
aHaunchLeftEndPlateFlange | Weld thickness between left haunch flange and endplate
aHaunchLeftEndPlateWeb | Weld thickness between left haunch web and endplate
aHaunchRightBeamFlange | Weld thickness between right haunch flange and beam flange
aHaunchRightEndPlateFlange | Weld thickness between right haunch flange and endplate
aHaunchRightEndPlateWeb | Weld thickness between right haunch web and endplate
ast_col | Weld thickness between column web and transverse stiffners
aSupplementaryWebPlate | Weld thickness between supplementary column web plates and column web
aw_beamLeft | Weld thickness between left beam web and endplate
aw_beamRight | Weld thickness between right beam web and endplate
BeamLeft | Left beam object
BeamRight | Right beam object
bs | Supplementary column web plates width
bst_col | Column transverse stiffeners total width
Column | Column object
ColumnExtensionOverRightBeam | Net distance between column end and upper beam flange
ColumnSteel | Column steel grade
ds | Center distance between stiffeners
ds_over_rightBeamFlange | center distance between right upper beam flange and upper column web stiffener
HaunchLeft | Left haunch object
HaunchRight | Right haunch object
LeftBeamSteel | Left beam steel grade
LeftConnectionAlso | True, if left connection exist (double side connection), otherwise false
LoadCasesLeftBeam | Load cases of left beam, in case of double side connection
LoadCasesResultantColumn | Resultant loads on column from upper and lower stories
LoadCasesRightBeam | Load cases of right beam
NrOfSupplementaryWebPlates | Number of supplementary column web plates used (1, 2 or 3)
PlateLeft | Left endplate object
PlateRight | Right endplate object
Results | List of results
RightBeamSteel | Right beam steel grade
tbp_Left | Thickness of backing plates for the left connection, if used
tbp_Right | Thickness of backing plates for the right connection, if used
Theta_HaunchLeft | Angle between left beam and haunch flanges
Theta_HaunchRight | Angle between right beam and haunch flanges
ts | Supplementary column web plates thickness
tst_bLeft | True, if a haunch is used for the left connection, otherwise false
tst_bRight | True, if a haunch is used for the right connection, otherwise false
tst_col | Column transverse stiffeners thickness
UseOfBackingPlatesLeft | True, if backing plates are used for the left connection, otherwise false
UseOfBackingPlatesRight | True, if backing plates are used for the right connection, otherwise false
UseOfBeamLeftWebStiffener | True, if a beam web stiffener is used for the left connection, otherwise false
UseOfBeamRightWebStiffener | True, if a beam web stiffener is used for the right connection, otherwise false
UseOfColumnWebStiffeners | True is transverse column web stiffeners are used, otherwise false
UseOfDiagonalColumnWebStiffener | True is diagonal stiffeners are used, otherwise false
UseOfHaunchLeft | True, if a haunch is used for the left connection, otherwise false
UseOfHaunchRight | True, if a haunch is used for the right connection, otherwise false

See Also

BeamColumnEndplateConnection Class


af_beamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.af_beamLeft Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left beam flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double af_beamLeft
Visual Basic (Declaration)
Public af_beamLeft As Double
Visual C++
public:
double af_beamLeft

Remarks

Beam flange is welded at its both sides

See Also

BeamColumnEndplateConnection Class


af_beamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.af_beamRight Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right beam flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double af_beamRight
Visual Basic (Declaration)
Public af_beamRight As Double
Visual C++
public:
double af_beamRight

Remarks

Beam flange is welded at its both sides

See Also

BeamColumnEndplateConnection Class


aHaunchLeftBeamFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.aHaunchLeftBeamFlange Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left haunch flange and beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchLeftBeamFlange
Visual Basic (Declaration)
Public aHaunchLeftBeamFlange As Double
Visual C++
public:
double aHaunchLeftBeamFlange

Remarks

See Also

BeamColumnEndplateConnection Class


aHaunchLeftEndPlateFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.aHaunchLeftEndPlateFlange Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left haunch flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchLeftEndPlateFlange
Visual Basic (Declaration)
Public aHaunchLeftEndPlateFlange As Double
Visual C++
public:
double aHaunchLeftEndPlateFlange

Remarks

See Also

BeamColumnEndplateConnection Class


aHaunchLeftEndPlateWeb Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.aHaunchLeftEndPlateWeb Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left haunch web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchLeftEndPlateWeb
Visual Basic (Declaration)
Public aHaunchLeftEndPlateWeb As Double
Visual C++
public:
double aHaunchLeftEndPlateWeb

Remarks

See Also

BeamColumnEndplateConnection Class


aHaunchRightBeamFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.aHaunchRightBeamFlange Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right haunch flange and beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchRightBeamFlange
Visual Basic (Declaration)
Public aHaunchRightBeamFlange As Double
Visual C++
public:
double aHaunchRightBeamFlange

Remarks

See Also

BeamColumnEndplateConnection Class


aHaunchRightEndPlateFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.aHaunchRightEndPlateFlange Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right haunch flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchRightEndPlateFlange
Visual Basic (Declaration)
Public aHaunchRightEndPlateFlange As Double
Visual C++
public:
double aHaunchRightEndPlateFlange

Remarks

See Also

BeamColumnEndplateConnection Class


aHaunchRightEndPlateWeb Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.aHaunchRightEndPlateWeb Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right haunch web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchRightEndPlateWeb
Visual Basic (Declaration)
Public aHaunchRightEndPlateWeb As Double
Visual C++
public:
double aHaunchRightEndPlateWeb

Remarks

See Also

BeamColumnEndplateConnection Class


ast_col Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.ast_col Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between column web and transverse stiffners

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ast_col
Visual Basic (Declaration)
Public ast_col As Double
Visual C++
public:
double ast_col

Remarks

See Also

BeamColumnEndplateConnection Class


aSupplementaryWebPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.aSupplementaryWebPlate Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between supplementary column web plates and column web

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aSupplementaryWebPlate
Visual Basic (Declaration)
Public aSupplementaryWebPlate As Double
Visual C++
public:
double aSupplementaryWebPlate

Remarks

See Also

BeamColumnEndplateConnection Class


aw_beamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.aw_beamLeft Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left beam web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aw_beamLeft
Visual Basic (Declaration)
Public aw_beamLeft As Double
Visual C++
public:
double aw_beamLeft

Remarks

See Also

BeamColumnEndplateConnection Class


aw_beamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.aw_beamRight Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right beam web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aw_beamRight
Visual Basic (Declaration)
Public aw_beamRight As Double
Visual C++
public:
double aw_beamRight

Remarks

See Also

BeamColumnEndplateConnection Class


BeamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.BeamLeft Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Left beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection BeamLeft
Visual Basic (Declaration)
Public BeamLeft As HSection
Visual C++
public:
HSection^ BeamLeft

Remarks

See Also

BeamColumnEndplateConnection Class


BeamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.BeamRight Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Right beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection BeamRight
Visual Basic (Declaration)
Public BeamRight As HSection
Visual C++
public:
HSection^ BeamRight

Remarks

See Also

BeamColumnEndplateConnection Class


bs Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.bs Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Supplementary column web plates width

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double bs
Visual Basic (Declaration)
Public bs As Double
Visual C++
public:
double bs

Remarks

See Also

BeamColumnEndplateConnection Class


bst_col Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.bst_col Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column transverse stiffeners total width

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double bst_col
Visual Basic (Declaration)
Public bst_col As Double
Visual C++
public:
double bst_col

Remarks

See Also

BeamColumnEndplateConnection Class


Column Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.Column Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Column
Visual Basic (Declaration)
Public Column As HSection
Visual C++
public:
HSection^ Column

Remarks

See Also

BeamColumnEndplateConnection Class


ColumnExtensionOverRightBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.ColumnExtensionOverRightBeam Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Net distance between column end and upper beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ColumnExtensionOverRightBeam
Visual Basic (Declaration)
Public ColumnExtensionOverRightBeam As Object
Visual C++
public:
Object^ ColumnExtensionOverRightBeam

Remarks

See Also

BeamColumnEndplateConnection Class


ColumnSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.ColumnSteel Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade ColumnSteel
Visual Basic (Declaration)
Public ColumnSteel As SteelGrade
Visual C++
public:
SteelGrade^ ColumnSteel

Remarks

See Also

BeamColumnEndplateConnection Class


ds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.ds Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Center distance between stiffeners

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ds
Visual Basic (Declaration)
Public ds As Double
Visual C++
public:
double ds

Remarks

See Also

BeamColumnEndplateConnection Class


ds_over_rightBeamFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.ds_over_rightBeamFlange Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
center distance between right upper beam flange and upper column web stiffener

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ds_over_rightBeamFlange
Visual Basic (Declaration)
Public ds_over_rightBeamFlange As Object
Visual C++
public:
Object^ ds_over_rightBeamFlange

Remarks

See Also

BeamColumnEndplateConnection Class


HaunchLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.HaunchLeft Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Left haunch object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TSection HaunchLeft
Visual Basic (Declaration)
Public HaunchLeft As TSection
Visual C++
public:
TSection^ HaunchLeft

Remarks

See Also

BeamColumnEndplateConnection Class


HaunchRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.HaunchRight Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Right haunch object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TSection HaunchRight
Visual Basic (Declaration)
Public HaunchRight As TSection
Visual C++
public:
TSection^ HaunchRight

Remarks

See Also

BeamColumnEndplateConnection Class


LeftBeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.LeftBeamSteel Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Left beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade LeftBeamSteel
Visual Basic (Declaration)
Public LeftBeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ LeftBeamSteel

Remarks

See Also

BeamColumnEndplateConnection Class


LeftConnectionAlso Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.LeftConnectionAlso Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if left connection exist (double side connection), otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LeftConnectionAlso
Visual Basic (Declaration)
Public LeftConnectionAlso As Boolean
Visual C++
public:
bool LeftConnectionAlso

Remarks

See Also

BeamColumnEndplateConnection Class


LoadCasesLeftBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.LoadCasesLeftBeam Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of left beam, in case of double side connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesLeftBeam
Visual Basic (Declaration)
Public LoadCasesLeftBeam As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesLeftBeam

Remarks

Following forces are considered:

Ned (positive=compressive), WARNING: Ned should not exceed 5% of the beam plastic axial resistance, according to 6.2.3(2) [prEN 1993-1-8 : 2003]!!

Ved (positive=downwards)

Med (positive=lower beam flange is compressed), WARNING: Med has to be positive!!

See Also

BeamColumnEndplateConnection Class


LoadCasesResultantColumn Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.LoadCasesResultantColumn Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Resultant loads on column from upper and lower stories

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesResultantColumn
Visual Basic (Declaration)
Public LoadCasesResultantColumn As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesResultantColumn

Remarks

Following forces are considered:

Ned (positive=compressive)

Ved (sign does not matter)

Med (sign does not matter)

See Also

BeamColumnEndplateConnection Class


LoadCasesRightBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.LoadCasesRightBeam Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of right beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesRightBeam
Visual Basic (Declaration)
Public LoadCasesRightBeam As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesRightBeam

Remarks

Following forces are considered:

Ned (positive=compressive), WARNING: Ned should not exceed 5% of the beam plastic axial resistance, according to 6.2.3(2) [prEN 1993-1-8 : 2003]!!

Ved (positive=downwards)

Med (positive=lower beam flange is compressed), WARNING: Med has to be positive!!

See Also

BeamColumnEndplateConnection Class


NrOfSupplementaryWebPlates Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.NrOfSupplementaryWebPlates Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Number of supplementary column web plates used (1, 2 or 3)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int NrOfSupplementaryWebPlates
Visual Basic (Declaration)
Public NrOfSupplementaryWebPlates As Integer
Visual C++
public:
int NrOfSupplementaryWebPlates

Remarks

See Also

BeamColumnEndplateConnection Class


PlateLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.PlateLeft Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Left endplate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BoltedEndPlate PlateLeft
Visual Basic (Declaration)
Public PlateLeft As BoltedEndPlate
Visual C++
public:
BoltedEndPlate^ PlateLeft

Remarks

See Also

BeamColumnEndplateConnection Class


PlateRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.PlateRight Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Right endplate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BoltedEndPlate PlateRight
Visual Basic (Declaration)
Public PlateRight As BoltedEndPlate
Visual C++
public:
BoltedEndPlate^ PlateRight

Remarks

See Also

BeamColumnEndplateConnection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.Results Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamColumnEndplateConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamColumnEndplateConnectionResults)
Visual C++
public:
List<BeamColumnEndplateConnectionResults^>^ Results

Remarks

See Also

BeamColumnEndplateConnection Class


RightBeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.RightBeamSteel Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Right beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade RightBeamSteel
Visual Basic (Declaration)
Public RightBeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ RightBeamSteel

Remarks

See Also

BeamColumnEndplateConnection Class


tbp_Left Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.tbp_Left Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness of backing plates for the left connection, if used

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tbp_Left
Visual Basic (Declaration)
Public tbp_Left As Double
Visual C++
public:
double tbp_Left

Remarks

See Also

BeamColumnEndplateConnection Class


tbp_Right Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.tbp_Right Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness of backing plates for the right connection, if used

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tbp_Right
Visual Basic (Declaration)
Public tbp_Right As Double
Visual C++
public:
double tbp_Right

Remarks

See Also

BeamColumnEndplateConnection Class


Theta_HaunchLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.Theta_HaunchLeft Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Angle between left beam and haunch flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Theta_HaunchLeft
Visual Basic (Declaration)
Public Theta_HaunchLeft As Double
Visual C++
public:
double Theta_HaunchLeft

Remarks

See Also

BeamColumnEndplateConnection Class


Theta_HaunchRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.Theta_HaunchRight Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Angle between right beam and haunch flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Theta_HaunchRight
Visual Basic (Declaration)
Public Theta_HaunchRight As Double
Visual C++
public:
double Theta_HaunchRight

Remarks

See Also

BeamColumnEndplateConnection Class


ts Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.ts Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Supplementary column web plates thickness

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ts
Visual Basic (Declaration)
Public ts As Double
Visual C++
public:
double ts

Remarks

See Also

BeamColumnEndplateConnection Class


tst_bLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.tst_bLeft Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a haunch is used for the left connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tst_bLeft
Visual Basic (Declaration)
Public tst_bLeft As Double
Visual C++
public:
double tst_bLeft

Remarks

See Also

BeamColumnEndplateConnection Class


tst_bRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.tst_bRight Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a haunch is used for the right connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tst_bRight
Visual Basic (Declaration)
Public tst_bRight As Double
Visual C++
public:
double tst_bRight

Remarks

See Also

BeamColumnEndplateConnection Class


tst_col Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.tst_col Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column transverse stiffeners thickness

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tst_col
Visual Basic (Declaration)
Public tst_col As Double
Visual C++
public:
double tst_col

Remarks

See Also

BeamColumnEndplateConnection Class


UseOfBackingPlatesLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.UseOfBackingPlatesLeft Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if backing plates are used for the left connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfBackingPlatesLeft
Visual Basic (Declaration)
Public UseOfBackingPlatesLeft As Boolean
Visual C++
public:
bool UseOfBackingPlatesLeft

Remarks

See Also

BeamColumnEndplateConnection Class


UseOfBackingPlatesRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.UseOfBackingPlatesRight Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if backing plates are used for the right connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfBackingPlatesRight
Visual Basic (Declaration)
Public UseOfBackingPlatesRight As Boolean
Visual C++
public:
bool UseOfBackingPlatesRight

Remarks

See Also

BeamColumnEndplateConnection Class


UseOfBeamLeftWebStiffener Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.UseOfBeamLeftWebStiffener Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a beam web stiffener is used for the left connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfBeamLeftWebStiffener
Visual Basic (Declaration)
Public UseOfBeamLeftWebStiffener As Boolean
Visual C++
public:
bool UseOfBeamLeftWebStiffener

Remarks

See Also

BeamColumnEndplateConnection Class


UseOfBeamRightWebStiffener Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.UseOfBeamRightWebStiffener Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a beam web stiffener is used for the right connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfBeamRightWebStiffener
Visual Basic (Declaration)
Public UseOfBeamRightWebStiffener As Boolean
Visual C++
public:
bool UseOfBeamRightWebStiffener

Remarks

See Also

BeamColumnEndplateConnection Class


UseOfColumnWebStiffeners Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.UseOfColumnWebStiffeners Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True is transverse column web stiffeners are used, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfColumnWebStiffeners
Visual Basic (Declaration)
Public UseOfColumnWebStiffeners As Boolean
Visual C++
public:
bool UseOfColumnWebStiffeners

Remarks

See Also

BeamColumnEndplateConnection Class


UseOfDiagonalColumnWebStiffener Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.UseOfDiagonalColumnWebStiffener Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True is diagonal stiffeners are used, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfDiagonalColumnWebStiffener
Visual Basic (Declaration)
Public UseOfDiagonalColumnWebStiffener As Boolean
Visual C++
public:
bool UseOfDiagonalColumnWebStiffener

Remarks

See Also

BeamColumnEndplateConnection Class


UseOfHaunchLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.UseOfHaunchLeft Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a haunch is used for the left connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfHaunchLeft
Visual Basic (Declaration)
Public UseOfHaunchLeft As Boolean
Visual C++
public:
bool UseOfHaunchLeft

Remarks

See Also

BeamColumnEndplateConnection Class


UseOfHaunchRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.UseOfHaunchRight Field
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a haunch is used for the right connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfHaunchRight
Visual Basic (Declaration)
Public UseOfHaunchRight As Boolean
Visual C++
public:
bool UseOfHaunchRight

Remarks

See Also

BeamColumnEndplateConnection Class


BeamColumnEndplateConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection Methods
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnEndplateConnection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnEndplateConnection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.Calculate Method
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamColumnEndplateConnection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnection..::.GetInputWarnings Method
BeamColumnEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnEndplateConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamColumnEndplateConnectionInputWarnings
Visual C++
public:
BeamColumnEndplateConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamColumnEndplateConnection Class


BeamColumnEndplateConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnEndplateConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamColumnEndplateConnectionInputWarnings
Visual C++
public ref class BeamColumnEndplateConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnEndplateConnectionInputWarnings

See Also

BeamColumnEndplateConnectionInputWarnings Members


BeamColumnEndplateConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionInputWarnings Members
BeamColumnEndplateConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnEndplateConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamColumnEndplateConnectionInputWarnings | Initializes a new instance of the BeamColumnEndplateConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
LeftConnectionWarnings | Input warnings regarding the left connection
RightConnectionWarnings | Input warnings regarding the right connection

See Also

BeamColumnEndplateConnectionInputWarnings Class


BeamColumnEndplateConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionInputWarnings Constructor
BeamColumnEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnEndplateConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnEndplateConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnEndplateConnectionInputWarnings()

See Also

BeamColumnEndplateConnectionInputWarnings Class


BeamColumnEndplateConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionInputWarnings Fields
BeamColumnEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnEndplateConnectionInputWarnings type exposes the following members.

Fields

Name | Description
LeftConnectionWarnings | Input warnings regarding the left connection
RightConnectionWarnings | Input warnings regarding the right connection

See Also

BeamColumnEndplateConnectionInputWarnings Class


LeftConnectionWarnings Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionInputWarnings..::.LeftConnectionWarnings Field
BeamColumnEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OneSideBeamColumnEndplateInputWarnings LeftConnectionWarnings
Visual Basic (Declaration)
Public LeftConnectionWarnings As OneSideBeamColumnEndplateInputWarnings
Visual C++
public:
OneSideBeamColumnEndplateInputWarnings^ LeftConnectionWarnings

Remarks

See Also

BeamColumnEndplateConnectionInputWarnings Class


RightConnectionWarnings Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionInputWarnings..::.RightConnectionWarnings Field
BeamColumnEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the right connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OneSideBeamColumnEndplateInputWarnings RightConnectionWarnings
Visual Basic (Declaration)
Public RightConnectionWarnings As OneSideBeamColumnEndplateInputWarnings
Visual C++
public:
OneSideBeamColumnEndplateInputWarnings^ RightConnectionWarnings

Remarks

See Also

BeamColumnEndplateConnectionInputWarnings Class


BeamColumnEndplateConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionInputWarnings Methods
BeamColumnEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnEndplateConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnEndplateConnectionInputWarnings Class


BeamColumnEndplateConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnEndplateConnectionResults
Visual Basic (Declaration)
Public Class BeamColumnEndplateConnectionResults
Visual C++
public ref class BeamColumnEndplateConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnEndplateConnectionResults

See Also

BeamColumnEndplateConnectionResults Members


BeamColumnEndplateConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionResults Members
BeamColumnEndplateConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnEndplateConnectionResults type exposes the following members.

Constructors

Name | Description
BeamColumnEndplateConnectionResults | Initializes a new instance of the BeamColumnEndplateConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
LeftConnectionResults | List of left connection results
RightConnectionResults | List of right connection results

See Also

BeamColumnEndplateConnectionResults Class


BeamColumnEndplateConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionResults Constructor
BeamColumnEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnEndplateConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnEndplateConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnEndplateConnectionResults()

See Also

BeamColumnEndplateConnectionResults Class


BeamColumnEndplateConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionResults Fields
BeamColumnEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnEndplateConnectionResults type exposes the following members.

Fields

Name | Description
LeftConnectionResults | List of left connection results
RightConnectionResults | List of right connection results

See Also

BeamColumnEndplateConnectionResults Class


LeftConnectionResults Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionResults..::.LeftConnectionResults Field
BeamColumnEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
List of left connection results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<OneSideBeamColumnEndplateResults> LeftConnectionResults
Visual Basic (Declaration)
Public LeftConnectionResults As List(Of OneSideBeamColumnEndplateResults)
Visual C++
public:
List<OneSideBeamColumnEndplateResults^>^ LeftConnectionResults

Remarks

See Also

BeamColumnEndplateConnectionResults Class


RightConnectionResults Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionResults..::.RightConnectionResults Field
BeamColumnEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
List of right connection results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<OneSideBeamColumnEndplateResults> RightConnectionResults
Visual Basic (Declaration)
Public RightConnectionResults As List(Of OneSideBeamColumnEndplateResults)
Visual C++
public:
List<OneSideBeamColumnEndplateResults^>^ RightConnectionResults

Remarks

See Also

BeamColumnEndplateConnectionResults Class


BeamColumnEndplateConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnEndplateConnectionResults Methods
BeamColumnEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnEndplateConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnEndplateConnectionResults Class


BeamColumnPlate1Connection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam to column(H) connection by means of a single bolted plate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnPlate1Connection
Visual Basic (Declaration)
Public Class BeamColumnPlate1Connection
Visual C++
public ref class BeamColumnPlate1Connection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnPlate1Connection

See Also

BeamColumnPlate1Connection Members


BeamColumnPlate1Connection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection Members
BeamColumnPlate1Connection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate1Connection type exposes the following members.

Constructors

Name | Description
BeamColumnPlate1Connection | Initializes a new instance of the BeamColumnPlate1Connection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
a | Weld thickness between plate and column
AboutColumnMajorAxis | True, if the connection is implemented about the major axis of the column, otherwise false
Beam | Beam object
BeamSteel | Beam steel grade
Column | Column steel grade
LoadCases | Load cases of the beam
Plate | Bolted plate object
Results | List of results
TwoSideWeld | True, if the plate is welded at its both side to the column, otherwise false

See Also

BeamColumnPlate1Connection Class


BeamColumnPlate1Connection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection Constructor
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnPlate1Connection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate1Connection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnPlate1Connection()

See Also

BeamColumnPlate1Connection Class


BeamColumnPlate1Connection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection Fields
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate1Connection type exposes the following members.

Fields

Name | Description
a | Weld thickness between plate and column
AboutColumnMajorAxis | True, if the connection is implemented about the major axis of the column, otherwise false
Beam | Beam object
BeamSteel | Beam steel grade
Column | Column steel grade
LoadCases | Load cases of the beam
Plate | Bolted plate object
Results | List of results
TwoSideWeld | True, if the plate is welded at its both side to the column, otherwise false

See Also

BeamColumnPlate1Connection Class


a Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.a Field
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between plate and column

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a
Visual Basic (Declaration)
Public a As Double
Visual C++
public:
double a

Remarks

See Also

BeamColumnPlate1Connection Class


AboutColumnMajorAxis Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.AboutColumnMajorAxis Field
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the connection is implemented about the major axis of the column, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AboutColumnMajorAxis
Visual Basic (Declaration)
Public AboutColumnMajorAxis As Boolean
Visual C++
public:
bool AboutColumnMajorAxis

Remarks

See Also

BeamColumnPlate1Connection Class


Beam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.Beam Field
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Beam
Visual Basic (Declaration)
Public Beam As HSection
Visual C++
public:
HSection^ Beam

Remarks

See Also

BeamColumnPlate1Connection Class


BeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.BeamSteel Field
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade BeamSteel
Visual Basic (Declaration)
Public BeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ BeamSteel

Remarks

See Also

BeamColumnPlate1Connection Class


Column Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.Column Field
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Column
Visual Basic (Declaration)
Public Column As HSection
Visual C++
public:
HSection^ Column

Remarks

See Also

BeamColumnPlate1Connection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.LoadCases Field
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ved (positive=downwards)

See Also

BeamColumnPlate1Connection Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.Plate Field
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate Plate
Visual Basic (Declaration)
Public Plate As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ Plate

Remarks

See Also

BeamColumnPlate1Connection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.Results Field
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamColumnPlate1ConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamColumnPlate1ConnectionResults)
Visual C++
public:
List<BeamColumnPlate1ConnectionResults^>^ Results

Remarks

See Also

BeamColumnPlate1Connection Class


TwoSideWeld Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.TwoSideWeld Field
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the plate is welded at its both side to the column, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool TwoSideWeld
Visual Basic (Declaration)
Public TwoSideWeld As Boolean
Visual C++
public:
bool TwoSideWeld

Remarks

See Also

BeamColumnPlate1Connection Class


BeamColumnPlate1Connection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection Methods
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate1Connection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnPlate1Connection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.Calculate Method
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamColumnPlate1Connection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1Connection..::.GetInputWarnings Method
BeamColumnPlate1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate1ConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamColumnPlate1ConnectionInputWarnings
Visual C++
public:
BeamColumnPlate1ConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamColumnPlate1Connection Class


BeamColumnPlate1ConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnPlate1ConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamColumnPlate1ConnectionInputWarnings
Visual C++
public ref class BeamColumnPlate1ConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnPlate1ConnectionInputWarnings

See Also

BeamColumnPlate1ConnectionInputWarnings Members


BeamColumnPlate1ConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionInputWarnings Members
BeamColumnPlate1ConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate1ConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamColumnPlate1ConnectionInputWarnings | Initializes a new instance of the BeamColumnPlate1ConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamColumnPlate1ConnectionInputWarnings Class


BeamColumnPlate1ConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionInputWarnings Constructor
BeamColumnPlate1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnPlate1ConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate1ConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnPlate1ConnectionInputWarnings()

See Also

BeamColumnPlate1ConnectionInputWarnings Class


BeamColumnPlate1ConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionInputWarnings Fields
BeamColumnPlate1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate1ConnectionInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamColumnPlate1ConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionInputWarnings..::.Other Field
BeamColumnPlate1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamColumnPlate1ConnectionInputWarnings Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionInputWarnings..::.Plate Field
BeamColumnPlate1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Plate
Visual Basic (Declaration)
Public Plate As List(Of String)
Visual C++
public:
List<String^>^ Plate

Remarks

See Also

BeamColumnPlate1ConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionInputWarnings..::.Welds Field
BeamColumnPlate1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamColumnPlate1ConnectionInputWarnings Class


BeamColumnPlate1ConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionInputWarnings Methods
BeamColumnPlate1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate1ConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnPlate1ConnectionInputWarnings Class


BeamColumnPlate1ConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnPlate1ConnectionResults
Visual Basic (Declaration)
Public Class BeamColumnPlate1ConnectionResults
Visual C++
public ref class BeamColumnPlate1ConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnPlate1ConnectionResults

See Also

BeamColumnPlate1ConnectionResults Members


BeamColumnPlate1ConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults Members
BeamColumnPlate1ConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate1ConnectionResults type exposes the following members.

Constructors

Name | Description
BeamColumnPlate1ConnectionResults | Initializes a new instance of the BeamColumnPlate1ConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BeamTearBlockingCapacity | Beam web tear blocking capacity
BeamTearBlockingResistance | Beam web tear blocking resistance
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
PlateTearBlockingCapacity | Plate tear blocking capacity
PlateTearBlockingResistance | Plate tear blocking resistance
WeldCapacity | Weld capacity
WeldResistance | Weld resistance

See Also

BeamColumnPlate1ConnectionResults Class


BeamColumnPlate1ConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults Constructor
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnPlate1ConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate1ConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnPlate1ConnectionResults()

See Also

BeamColumnPlate1ConnectionResults Class


BeamColumnPlate1ConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults Fields
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate1ConnectionResults type exposes the following members.

Fields

Name | Description
BeamTearBlockingCapacity | Beam web tear blocking capacity
BeamTearBlockingResistance | Beam web tear blocking resistance
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
PlateTearBlockingCapacity | Plate tear blocking capacity
PlateTearBlockingResistance | Plate tear blocking resistance
WeldCapacity | Weld capacity
WeldResistance | Weld resistance

See Also

BeamColumnPlate1ConnectionResults Class


BeamTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.BeamTearBlockingCapacity Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamTearBlockingCapacity
Visual Basic (Declaration)
Public BeamTearBlockingCapacity As Double
Visual C++
public:
double BeamTearBlockingCapacity

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


BeamTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.BeamTearBlockingResistance Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamTearBlockingResistance
Visual Basic (Declaration)
Public BeamTearBlockingResistance As Double
Visual C++
public:
double BeamTearBlockingResistance

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


BoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.BoltsBearingCapacity Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingCapacity
Visual Basic (Declaration)
Public BoltsBearingCapacity As Double
Visual C++
public:
double BoltsBearingCapacity

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


BoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.BoltsBearingResistance Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingResistance
Visual Basic (Declaration)
Public BoltsBearingResistance As Double
Visual C++
public:
double BoltsBearingResistance

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


BoltsShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.BoltsShearCapacity Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearCapacity
Visual Basic (Declaration)
Public BoltsShearCapacity As Double
Visual C++
public:
double BoltsShearCapacity

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


BoltsShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.BoltsShearResistance Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearResistance
Visual Basic (Declaration)
Public BoltsShearResistance As Double
Visual C++
public:
double BoltsShearResistance

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


PlateTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.PlateTearBlockingCapacity Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTearBlockingCapacity
Visual Basic (Declaration)
Public PlateTearBlockingCapacity As Double
Visual C++
public:
double PlateTearBlockingCapacity

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


PlateTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.PlateTearBlockingResistance Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTearBlockingResistance
Visual Basic (Declaration)
Public PlateTearBlockingResistance As Double
Visual C++
public:
double PlateTearBlockingResistance

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


WeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.WeldCapacity Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldCapacity
Visual Basic (Declaration)
Public WeldCapacity As Double
Visual C++
public:
double WeldCapacity

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


WeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults..::.WeldResistance Field
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldResistance
Visual Basic (Declaration)
Public WeldResistance As Double
Visual C++
public:
double WeldResistance

Remarks

See Also

BeamColumnPlate1ConnectionResults Class


BeamColumnPlate1ConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate1ConnectionResults Methods
BeamColumnPlate1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate1ConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnPlate1ConnectionResults Class


BeamColumnPlate2Connection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam to column(RHS) connection by means of a single bolted plate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnPlate2Connection
Visual Basic (Declaration)
Public Class BeamColumnPlate2Connection
Visual C++
public ref class BeamColumnPlate2Connection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnPlate2Connection

See Also

BeamColumnPlate2Connection Members


BeamColumnPlate2Connection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection Members
BeamColumnPlate2Connection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate2Connection type exposes the following members.

Constructors

Name | Description
BeamColumnPlate2Connection | Initializes a new instance of the BeamColumnPlate2Connection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
a | Weld thickness between plate and column
AboutColumnMajorAxis | True, if the connection is implemented about the major axis of the column, otherwise false
Beam | Beam object
BeamSteel | Beam steel grade
Column | Column steel grade
ColumnSteel | Beam steel grade
LoadCases | Load cases of the beam
Plate | Bolted plate object
Results | List of results
TwoSideWeld | True, if the plate is welded at its both side to the column, otherwise false

See Also

BeamColumnPlate2Connection Class


BeamColumnPlate2Connection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection Constructor
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnPlate2Connection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate2Connection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnPlate2Connection()

See Also

BeamColumnPlate2Connection Class


BeamColumnPlate2Connection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection Fields
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate2Connection type exposes the following members.

Fields

Name | Description
a | Weld thickness between plate and column
AboutColumnMajorAxis | True, if the connection is implemented about the major axis of the column, otherwise false
Beam | Beam object
BeamSteel | Beam steel grade
Column | Column steel grade
ColumnSteel | Beam steel grade
LoadCases | Load cases of the beam
Plate | Bolted plate object
Results | List of results
TwoSideWeld | True, if the plate is welded at its both side to the column, otherwise false

See Also

BeamColumnPlate2Connection Class


a Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.a Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between plate and column

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a
Visual Basic (Declaration)
Public a As Double
Visual C++
public:
double a

Remarks

See Also

BeamColumnPlate2Connection Class


AboutColumnMajorAxis Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.AboutColumnMajorAxis Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the connection is implemented about the major axis of the column, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AboutColumnMajorAxis
Visual Basic (Declaration)
Public AboutColumnMajorAxis As Boolean
Visual C++
public:
bool AboutColumnMajorAxis

Remarks

See Also

BeamColumnPlate2Connection Class


Beam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.Beam Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Beam
Visual Basic (Declaration)
Public Beam As HSection
Visual C++
public:
HSection^ Beam

Remarks

See Also

BeamColumnPlate2Connection Class


BeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.BeamSteel Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade BeamSteel
Visual Basic (Declaration)
Public BeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ BeamSteel

Remarks

See Also

BeamColumnPlate2Connection Class


Column Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.Column Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RHS Column
Visual Basic (Declaration)
Public Column As RHS
Visual C++
public:
RHS^ Column

Remarks

See Also

BeamColumnPlate2Connection Class


ColumnSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.ColumnSteel Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade ColumnSteel
Visual Basic (Declaration)
Public ColumnSteel As SteelGrade
Visual C++
public:
SteelGrade^ ColumnSteel

Remarks

See Also

BeamColumnPlate2Connection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.LoadCases Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ved (positive=downwards)

See Also

BeamColumnPlate2Connection Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.Plate Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate Plate
Visual Basic (Declaration)
Public Plate As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ Plate

Remarks

See Also

BeamColumnPlate2Connection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.Results Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamColumnPlate2ConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamColumnPlate2ConnectionResults)
Visual C++
public:
List<BeamColumnPlate2ConnectionResults^>^ Results

Remarks

See Also

BeamColumnPlate2Connection Class


TwoSideWeld Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.TwoSideWeld Field
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the plate is welded at its both side to the column, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool TwoSideWeld
Visual Basic (Declaration)
Public TwoSideWeld As Boolean
Visual C++
public:
bool TwoSideWeld

Remarks

See Also

BeamColumnPlate2Connection Class


BeamColumnPlate2Connection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection Methods
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate2Connection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnPlate2Connection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.Calculate Method
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamColumnPlate2Connection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2Connection..::.GetInputWarnings Method
BeamColumnPlate2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate2ConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamColumnPlate2ConnectionInputWarnings
Visual C++
public:
BeamColumnPlate2ConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamColumnPlate2Connection Class


BeamColumnPlate2ConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnPlate2ConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamColumnPlate2ConnectionInputWarnings
Visual C++
public ref class BeamColumnPlate2ConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnPlate2ConnectionInputWarnings

See Also

BeamColumnPlate2ConnectionInputWarnings Members


BeamColumnPlate2ConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionInputWarnings Members
BeamColumnPlate2ConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate2ConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamColumnPlate2ConnectionInputWarnings | Initializes a new instance of the BeamColumnPlate2ConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamColumnPlate2ConnectionInputWarnings Class


BeamColumnPlate2ConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionInputWarnings Constructor
BeamColumnPlate2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnPlate2ConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate2ConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnPlate2ConnectionInputWarnings()

See Also

BeamColumnPlate2ConnectionInputWarnings Class


BeamColumnPlate2ConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionInputWarnings Fields
BeamColumnPlate2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate2ConnectionInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamColumnPlate2ConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionInputWarnings..::.Other Field
BeamColumnPlate2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamColumnPlate2ConnectionInputWarnings Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionInputWarnings..::.Plate Field
BeamColumnPlate2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Plate
Visual Basic (Declaration)
Public Plate As List(Of String)
Visual C++
public:
List<String^>^ Plate

Remarks

See Also

BeamColumnPlate2ConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionInputWarnings..::.Welds Field
BeamColumnPlate2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamColumnPlate2ConnectionInputWarnings Class


BeamColumnPlate2ConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionInputWarnings Methods
BeamColumnPlate2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate2ConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnPlate2ConnectionInputWarnings Class


BeamColumnPlate2ConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnPlate2ConnectionResults
Visual Basic (Declaration)
Public Class BeamColumnPlate2ConnectionResults
Visual C++
public ref class BeamColumnPlate2ConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnPlate2ConnectionResults

See Also

BeamColumnPlate2ConnectionResults Members


BeamColumnPlate2ConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults Members
BeamColumnPlate2ConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate2ConnectionResults type exposes the following members.

Constructors

Name | Description
BeamColumnPlate2ConnectionResults | Initializes a new instance of the BeamColumnPlate2ConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BeamTearBlockingCapacity | Beam web tear blocking capacity
BeamTearBlockingResistance | Beam web tear blocking resistance
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
ColumnFaceFailureCapacity | RHS column flange face failure capacity
ColumnFaceFailureResistance | RHS column flange face failure resistance
PlateTearBlockingCapacity | Plate tear blocking capacity
PlateTearBlockingResistance | Plate tear blocking resistance
WeldCapacity | Weld capacity
WeldResistance | Weld resistance

See Also

BeamColumnPlate2ConnectionResults Class


BeamColumnPlate2ConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults Constructor
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnPlate2ConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate2ConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnPlate2ConnectionResults()

See Also

BeamColumnPlate2ConnectionResults Class


BeamColumnPlate2ConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults Fields
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate2ConnectionResults type exposes the following members.

Fields

Name | Description
BeamTearBlockingCapacity | Beam web tear blocking capacity
BeamTearBlockingResistance | Beam web tear blocking resistance
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
ColumnFaceFailureCapacity | RHS column flange face failure capacity
ColumnFaceFailureResistance | RHS column flange face failure resistance
PlateTearBlockingCapacity | Plate tear blocking capacity
PlateTearBlockingResistance | Plate tear blocking resistance
WeldCapacity | Weld capacity
WeldResistance | Weld resistance

See Also

BeamColumnPlate2ConnectionResults Class


BeamTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.BeamTearBlockingCapacity Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamTearBlockingCapacity
Visual Basic (Declaration)
Public BeamTearBlockingCapacity As Double
Visual C++
public:
double BeamTearBlockingCapacity

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


BeamTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.BeamTearBlockingResistance Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamTearBlockingResistance
Visual Basic (Declaration)
Public BeamTearBlockingResistance As Double
Visual C++
public:
double BeamTearBlockingResistance

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


BoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.BoltsBearingCapacity Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingCapacity
Visual Basic (Declaration)
Public BoltsBearingCapacity As Double
Visual C++
public:
double BoltsBearingCapacity

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


BoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.BoltsBearingResistance Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingResistance
Visual Basic (Declaration)
Public BoltsBearingResistance As Double
Visual C++
public:
double BoltsBearingResistance

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


BoltsShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.BoltsShearCapacity Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearCapacity
Visual Basic (Declaration)
Public BoltsShearCapacity As Double
Visual C++
public:
double BoltsShearCapacity

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


BoltsShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.BoltsShearResistance Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearResistance
Visual Basic (Declaration)
Public BoltsShearResistance As Double
Visual C++
public:
double BoltsShearResistance

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


ColumnFaceFailureCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.ColumnFaceFailureCapacity Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
RHS column flange face failure capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnFaceFailureCapacity
Visual Basic (Declaration)
Public ColumnFaceFailureCapacity As Double
Visual C++
public:
double ColumnFaceFailureCapacity

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


ColumnFaceFailureResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.ColumnFaceFailureResistance Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
RHS column flange face failure resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnFaceFailureResistance
Visual Basic (Declaration)
Public ColumnFaceFailureResistance As Double
Visual C++
public:
double ColumnFaceFailureResistance

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


PlateTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.PlateTearBlockingCapacity Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTearBlockingCapacity
Visual Basic (Declaration)
Public PlateTearBlockingCapacity As Double
Visual C++
public:
double PlateTearBlockingCapacity

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


PlateTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.PlateTearBlockingResistance Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTearBlockingResistance
Visual Basic (Declaration)
Public PlateTearBlockingResistance As Double
Visual C++
public:
double PlateTearBlockingResistance

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


WeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.WeldCapacity Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldCapacity
Visual Basic (Declaration)
Public WeldCapacity As Double
Visual C++
public:
double WeldCapacity

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


WeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults..::.WeldResistance Field
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldResistance
Visual Basic (Declaration)
Public WeldResistance As Double
Visual C++
public:
double WeldResistance

Remarks

See Also

BeamColumnPlate2ConnectionResults Class


BeamColumnPlate2ConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate2ConnectionResults Methods
BeamColumnPlate2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate2ConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnPlate2ConnectionResults Class


BeamColumnPlate3Connection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam to column(CHS) connection by means of a single bolted plate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnPlate3Connection
Visual Basic (Declaration)
Public Class BeamColumnPlate3Connection
Visual C++
public ref class BeamColumnPlate3Connection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnPlate3Connection

See Also

BeamColumnPlate3Connection Members


BeamColumnPlate3Connection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection Members
BeamColumnPlate3Connection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate3Connection type exposes the following members.

Constructors

Name | Description
BeamColumnPlate3Connection | Initializes a new instance of the BeamColumnPlate3Connection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
a | Weld thickness between plate and column
Beam | Beam object
BeamSteel | Beam steel grade
Column | Column steel grade
ColumnSteel | Beam steel grade
LoadCases | Load cases of the beam
Plate | Bolted plate object
Results | List of results
TwoSideWeld | True, if the plate is welded at its both side to the column, otherwise false

See Also

BeamColumnPlate3Connection Class


BeamColumnPlate3Connection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection Constructor
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnPlate3Connection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate3Connection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnPlate3Connection()

See Also

BeamColumnPlate3Connection Class


BeamColumnPlate3Connection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection Fields
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate3Connection type exposes the following members.

Fields

Name | Description
a | Weld thickness between plate and column
Beam | Beam object
BeamSteel | Beam steel grade
Column | Column steel grade
ColumnSteel | Beam steel grade
LoadCases | Load cases of the beam
Plate | Bolted plate object
Results | List of results
TwoSideWeld | True, if the plate is welded at its both side to the column, otherwise false

See Also

BeamColumnPlate3Connection Class


a Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.a Field
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between plate and column

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a
Visual Basic (Declaration)
Public a As Double
Visual C++
public:
double a

Remarks

See Also

BeamColumnPlate3Connection Class


Beam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.Beam Field
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Beam
Visual Basic (Declaration)
Public Beam As HSection
Visual C++
public:
HSection^ Beam

Remarks

See Also

BeamColumnPlate3Connection Class


BeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.BeamSteel Field
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade BeamSteel
Visual Basic (Declaration)
Public BeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ BeamSteel

Remarks

See Also

BeamColumnPlate3Connection Class


Column Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.Column Field
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CHS Column
Visual Basic (Declaration)
Public Column As CHS
Visual C++
public:
CHS^ Column

Remarks

See Also

BeamColumnPlate3Connection Class


ColumnSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.ColumnSteel Field
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade ColumnSteel
Visual Basic (Declaration)
Public ColumnSteel As SteelGrade
Visual C++
public:
SteelGrade^ ColumnSteel

Remarks

See Also

BeamColumnPlate3Connection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.LoadCases Field
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ved (positive=downwards)

See Also

BeamColumnPlate3Connection Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.Plate Field
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate Plate
Visual Basic (Declaration)
Public Plate As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ Plate

Remarks

See Also

BeamColumnPlate3Connection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.Results Field
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamColumnPlate3ConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamColumnPlate3ConnectionResults)
Visual C++
public:
List<BeamColumnPlate3ConnectionResults^>^ Results

Remarks

See Also

BeamColumnPlate3Connection Class


TwoSideWeld Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.TwoSideWeld Field
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the plate is welded at its both side to the column, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool TwoSideWeld
Visual Basic (Declaration)
Public TwoSideWeld As Boolean
Visual C++
public:
bool TwoSideWeld

Remarks

See Also

BeamColumnPlate3Connection Class


BeamColumnPlate3Connection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection Methods
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate3Connection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnPlate3Connection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.Calculate Method
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamColumnPlate3Connection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3Connection..::.GetInputWarnings Method
BeamColumnPlate3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate3ConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamColumnPlate3ConnectionInputWarnings
Visual C++
public:
BeamColumnPlate3ConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamColumnPlate3Connection Class


BeamColumnPlate3ConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnPlate3ConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamColumnPlate3ConnectionInputWarnings
Visual C++
public ref class BeamColumnPlate3ConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnPlate3ConnectionInputWarnings

See Also

BeamColumnPlate3ConnectionInputWarnings Members


BeamColumnPlate3ConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionInputWarnings Members
BeamColumnPlate3ConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate3ConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamColumnPlate3ConnectionInputWarnings | Initializes a new instance of the BeamColumnPlate3ConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamColumnPlate3ConnectionInputWarnings Class


BeamColumnPlate3ConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionInputWarnings Constructor
BeamColumnPlate3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnPlate3ConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate3ConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnPlate3ConnectionInputWarnings()

See Also

BeamColumnPlate3ConnectionInputWarnings Class


BeamColumnPlate3ConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionInputWarnings Fields
BeamColumnPlate3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate3ConnectionInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamColumnPlate3ConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionInputWarnings..::.Other Field
BeamColumnPlate3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamColumnPlate3ConnectionInputWarnings Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionInputWarnings..::.Plate Field
BeamColumnPlate3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Plate
Visual Basic (Declaration)
Public Plate As List(Of String)
Visual C++
public:
List<String^>^ Plate

Remarks

See Also

BeamColumnPlate3ConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionInputWarnings..::.Welds Field
BeamColumnPlate3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamColumnPlate3ConnectionInputWarnings Class


BeamColumnPlate3ConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionInputWarnings Methods
BeamColumnPlate3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate3ConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnPlate3ConnectionInputWarnings Class


BeamColumnPlate3ConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnPlate3ConnectionResults
Visual Basic (Declaration)
Public Class BeamColumnPlate3ConnectionResults
Visual C++
public ref class BeamColumnPlate3ConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnPlate3ConnectionResults

See Also

BeamColumnPlate3ConnectionResults Members


BeamColumnPlate3ConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults Members
BeamColumnPlate3ConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate3ConnectionResults type exposes the following members.

Constructors

Name | Description
BeamColumnPlate3ConnectionResults | Initializes a new instance of the BeamColumnPlate3ConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BeamTearBlockingCapacity | Beam web tear blocking capacity
BeamTearBlockingResistance | Beam web tear blocking resistance
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
ColumnFaceFailureCapacity | RHS column flange face failure capacity
ColumnFaceFailureResistance | RHS column flange face failure resistance
PlateTearBlockingCapacity | Plate tear blocking capacity
PlateTearBlockingResistance | Plate tear blocking resistance
WeldCapacity | Weld capacity
WeldResistance | Weld resistance

See Also

BeamColumnPlate3ConnectionResults Class


BeamColumnPlate3ConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults Constructor
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnPlate3ConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnPlate3ConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnPlate3ConnectionResults()

See Also

BeamColumnPlate3ConnectionResults Class


BeamColumnPlate3ConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults Fields
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate3ConnectionResults type exposes the following members.

Fields

Name | Description
BeamTearBlockingCapacity | Beam web tear blocking capacity
BeamTearBlockingResistance | Beam web tear blocking resistance
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
ColumnFaceFailureCapacity | RHS column flange face failure capacity
ColumnFaceFailureResistance | RHS column flange face failure resistance
PlateTearBlockingCapacity | Plate tear blocking capacity
PlateTearBlockingResistance | Plate tear blocking resistance
WeldCapacity | Weld capacity
WeldResistance | Weld resistance

See Also

BeamColumnPlate3ConnectionResults Class


BeamTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.BeamTearBlockingCapacity Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamTearBlockingCapacity
Visual Basic (Declaration)
Public BeamTearBlockingCapacity As Double
Visual C++
public:
double BeamTearBlockingCapacity

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


BeamTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.BeamTearBlockingResistance Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamTearBlockingResistance
Visual Basic (Declaration)
Public BeamTearBlockingResistance As Double
Visual C++
public:
double BeamTearBlockingResistance

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


BoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.BoltsBearingCapacity Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingCapacity
Visual Basic (Declaration)
Public BoltsBearingCapacity As Double
Visual C++
public:
double BoltsBearingCapacity

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


BoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.BoltsBearingResistance Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingResistance
Visual Basic (Declaration)
Public BoltsBearingResistance As Double
Visual C++
public:
double BoltsBearingResistance

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


BoltsShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.BoltsShearCapacity Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearCapacity
Visual Basic (Declaration)
Public BoltsShearCapacity As Double
Visual C++
public:
double BoltsShearCapacity

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


BoltsShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.BoltsShearResistance Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearResistance
Visual Basic (Declaration)
Public BoltsShearResistance As Double
Visual C++
public:
double BoltsShearResistance

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


ColumnFaceFailureCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.ColumnFaceFailureCapacity Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
RHS column flange face failure capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnFaceFailureCapacity
Visual Basic (Declaration)
Public ColumnFaceFailureCapacity As Double
Visual C++
public:
double ColumnFaceFailureCapacity

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


ColumnFaceFailureResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.ColumnFaceFailureResistance Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
RHS column flange face failure resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnFaceFailureResistance
Visual Basic (Declaration)
Public ColumnFaceFailureResistance As Double
Visual C++
public:
double ColumnFaceFailureResistance

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


PlateTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.PlateTearBlockingCapacity Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTearBlockingCapacity
Visual Basic (Declaration)
Public PlateTearBlockingCapacity As Double
Visual C++
public:
double PlateTearBlockingCapacity

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


PlateTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.PlateTearBlockingResistance Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTearBlockingResistance
Visual Basic (Declaration)
Public PlateTearBlockingResistance As Double
Visual C++
public:
double PlateTearBlockingResistance

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


WeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.WeldCapacity Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldCapacity
Visual Basic (Declaration)
Public WeldCapacity As Double
Visual C++
public:
double WeldCapacity

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


WeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults..::.WeldResistance Field
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldResistance
Visual Basic (Declaration)
Public WeldResistance As Double
Visual C++
public:
double WeldResistance

Remarks

See Also

BeamColumnPlate3ConnectionResults Class


BeamColumnPlate3ConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnPlate3ConnectionResults Methods
BeamColumnPlate3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnPlate3ConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnPlate3ConnectionResults Class


BeamColumnRowResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents results regarding to one bolt row

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnRowResults
Visual Basic (Declaration)
Public Class BeamColumnRowResults
Visual C++
public ref class BeamColumnRowResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnRowResults

See Also

BeamColumnRowResults Members


BeamColumnRowResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults Members
BeamColumnRowResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnRowResults type exposes the following members.

Constructors

Name | Description
BeamColumnRowResults | Initializes a new instance of the BeamColumnRowResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
beff_bcf_group | Effective width for the column flange in bending resistance for the bolt row as part of a bolt group
beff_bcf_group_onlyThisRow | Effective length for the column flage in bending for this row only as a part of a group
beff_bcf_individual | Effective width for the column flange in bending for the bolt row as single
beff_bep_group | Effective width for the endplate in bending for the bolt row as part of a bolt group
beff_bep_group_onlyThisRow | Effective length for the endplate in bending for this row only as a part of a group
beff_bep_individual | Effective width for the endplate in bending resistance for the bolt row as single
Fbcf_final | Final bolt row resistance for the column flange in bending
Fbcf_group | Column flange in bending resistance for the bolt row as part of a bolt group
Fbcf_individual | Column flange in bending resistance for the bolt row as single
Fbep_final | Final bolt row resistance for the endplate in bending
Fbep_group | Endplate in bending resistance for the bolt row as part of a bolt group
Fbep_individual | Endplate in bending resistance for the bolt row as single
Ft_final | Final bolt row resistance
Ftwb_final | Final bolt row resistance for the beam web in tension
FtwbRd_group | Beam web in tension resistance for the bolt row as part of a bolt group
FtwbRd_individual | Beam web in tension resistance for the bolt row as single
Ftwc_final | Final bolt row resistance for the column web in tension
FtwcRd_group | Column web in tension for the bolt row as part of a bolt group
FtwcRd_individual | Column web in tension for the bolt row as single
keff_r | Effective stiffness coefficient for this bolt row

See Also

BeamColumnRowResults Class


BeamColumnRowResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults Constructor
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnRowResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnRowResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnRowResults()

See Also

BeamColumnRowResults Class


BeamColumnRowResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults Fields
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnRowResults type exposes the following members.

Fields

Name | Description
beff_bcf_group | Effective width for the column flange in bending resistance for the bolt row as part of a bolt group
beff_bcf_group_onlyThisRow | Effective length for the column flage in bending for this row only as a part of a group
beff_bcf_individual | Effective width for the column flange in bending for the bolt row as single
beff_bep_group | Effective width for the endplate in bending for the bolt row as part of a bolt group
beff_bep_group_onlyThisRow | Effective length for the endplate in bending for this row only as a part of a group
beff_bep_individual | Effective width for the endplate in bending resistance for the bolt row as single
Fbcf_final | Final bolt row resistance for the column flange in bending
Fbcf_group | Column flange in bending resistance for the bolt row as part of a bolt group
Fbcf_individual | Column flange in bending resistance for the bolt row as single
Fbep_final | Final bolt row resistance for the endplate in bending
Fbep_group | Endplate in bending resistance for the bolt row as part of a bolt group
Fbep_individual | Endplate in bending resistance for the bolt row as single
Ft_final | Final bolt row resistance
Ftwb_final | Final bolt row resistance for the beam web in tension
FtwbRd_group | Beam web in tension resistance for the bolt row as part of a bolt group
FtwbRd_individual | Beam web in tension resistance for the bolt row as single
Ftwc_final | Final bolt row resistance for the column web in tension
FtwcRd_group | Column web in tension for the bolt row as part of a bolt group
FtwcRd_individual | Column web in tension for the bolt row as single
keff_r | Effective stiffness coefficient for this bolt row

See Also

BeamColumnRowResults Class


beff_bcf_group Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.beff_bcf_group Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective width for the column flange in bending resistance for the bolt row as part of a bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double beff_bcf_group
Visual Basic (Declaration)
Public beff_bcf_group As Double
Visual C++
public:
double beff_bcf_group

Remarks

See Also

BeamColumnRowResults Class


beff_bcf_group_onlyThisRow Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.beff_bcf_group_onlyThisRow Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective length for the column flage in bending for this row only as a part of a group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double beff_bcf_group_onlyThisRow
Visual Basic (Declaration)
Public beff_bcf_group_onlyThisRow As Double
Visual C++
public:
double beff_bcf_group_onlyThisRow

Remarks

See Also

BeamColumnRowResults Class


beff_bcf_individual Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.beff_bcf_individual Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective width for the column flange in bending for the bolt row as single

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double beff_bcf_individual
Visual Basic (Declaration)
Public beff_bcf_individual As Double
Visual C++
public:
double beff_bcf_individual

Remarks

See Also

BeamColumnRowResults Class


beff_bep_group Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.beff_bep_group Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective width for the endplate in bending for the bolt row as part of a bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double beff_bep_group
Visual Basic (Declaration)
Public beff_bep_group As Double
Visual C++
public:
double beff_bep_group

Remarks

See Also

BeamColumnRowResults Class


beff_bep_group_onlyThisRow Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.beff_bep_group_onlyThisRow Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective length for the endplate in bending for this row only as a part of a group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double beff_bep_group_onlyThisRow
Visual Basic (Declaration)
Public beff_bep_group_onlyThisRow As Double
Visual C++
public:
double beff_bep_group_onlyThisRow

Remarks

See Also

BeamColumnRowResults Class


beff_bep_individual Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.beff_bep_individual Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective width for the endplate in bending resistance for the bolt row as single

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double beff_bep_individual
Visual Basic (Declaration)
Public beff_bep_individual As Double
Visual C++
public:
double beff_bep_individual

Remarks

See Also

BeamColumnRowResults Class


Fbcf_final Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.Fbcf_final Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt row resistance for the column flange in bending

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Fbcf_final
Visual Basic (Declaration)
Public Fbcf_final As Double
Visual C++
public:
double Fbcf_final

Remarks

See Also

BeamColumnRowResults Class


Fbcf_group Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.Fbcf_group Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column flange in bending resistance for the bolt row as part of a bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Fbcf_group
Visual Basic (Declaration)
Public Fbcf_group As Double
Visual C++
public:
double Fbcf_group

Remarks

See Also

BeamColumnRowResults Class


Fbcf_individual Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.Fbcf_individual Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column flange in bending resistance for the bolt row as single

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Fbcf_individual
Visual Basic (Declaration)
Public Fbcf_individual As Double
Visual C++
public:
double Fbcf_individual

Remarks

See Also

BeamColumnRowResults Class


Fbep_final Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.Fbep_final Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt row resistance for the endplate in bending

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Fbep_final
Visual Basic (Declaration)
Public Fbep_final As Double
Visual C++
public:
double Fbep_final

Remarks

See Also

BeamColumnRowResults Class


Fbep_group Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.Fbep_group Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Endplate in bending resistance for the bolt row as part of a bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Fbep_group
Visual Basic (Declaration)
Public Fbep_group As Double
Visual C++
public:
double Fbep_group

Remarks

See Also

BeamColumnRowResults Class


Fbep_individual Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.Fbep_individual Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Endplate in bending resistance for the bolt row as single

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Fbep_individual
Visual Basic (Declaration)
Public Fbep_individual As Double
Visual C++
public:
double Fbep_individual

Remarks

See Also

BeamColumnRowResults Class


Ft_final Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.Ft_final Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt row resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ft_final
Visual Basic (Declaration)
Public Ft_final As Double
Visual C++
public:
double Ft_final

Remarks

See Also

BeamColumnRowResults Class


Ftwb_final Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.Ftwb_final Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt row resistance for the beam web in tension

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ftwb_final
Visual Basic (Declaration)
Public Ftwb_final As Double
Visual C++
public:
double Ftwb_final

Remarks

See Also

BeamColumnRowResults Class


FtwbRd_group Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.FtwbRd_group Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web in tension resistance for the bolt row as part of a bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FtwbRd_group
Visual Basic (Declaration)
Public FtwbRd_group As Double
Visual C++
public:
double FtwbRd_group

Remarks

See Also

BeamColumnRowResults Class


FtwbRd_individual Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.FtwbRd_individual Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web in tension resistance for the bolt row as single

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FtwbRd_individual
Visual Basic (Declaration)
Public FtwbRd_individual As Double
Visual C++
public:
double FtwbRd_individual

Remarks

See Also

BeamColumnRowResults Class


Ftwc_final Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.Ftwc_final Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt row resistance for the column web in tension

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ftwc_final
Visual Basic (Declaration)
Public Ftwc_final As Double
Visual C++
public:
double Ftwc_final

Remarks

See Also

BeamColumnRowResults Class


FtwcRd_group Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.FtwcRd_group Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column web in tension for the bolt row as part of a bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FtwcRd_group
Visual Basic (Declaration)
Public FtwcRd_group As Double
Visual C++
public:
double FtwcRd_group

Remarks

See Also

BeamColumnRowResults Class


FtwcRd_individual Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.FtwcRd_individual Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column web in tension for the bolt row as single

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FtwcRd_individual
Visual Basic (Declaration)
Public FtwcRd_individual As Double
Visual C++
public:
double FtwcRd_individual

Remarks

See Also

BeamColumnRowResults Class


keff_r Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults..::.keff_r Field
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective stiffness coefficient for this bolt row

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double keff_r
Visual Basic (Declaration)
Public keff_r As Double
Visual C++
public:
double keff_r

Remarks

See Also

BeamColumnRowResults Class


BeamColumnRowResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnRowResults Methods
BeamColumnRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnRowResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnRowResults Class


BeamColumnTeeConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam to column connection by means of a Tee plate welded to the column and an endplate bolted to it

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnTeeConnection
Visual Basic (Declaration)
Public Class BeamColumnTeeConnection
Visual C++
public ref class BeamColumnTeeConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnTeeConnection

See Also

BeamColumnTeeConnection Members


BeamColumnTeeConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection Members
BeamColumnTeeConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnTeeConnection type exposes the following members.

Constructors

Name | Description
BeamColumnTeeConnection | Initializes a new instance of the BeamColumnTeeConnection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
aFlangeBeam | Weld thickness between flange and endplate
aFlangesColumn | Weld thickness between column flanges and Tee flange
aWebBeam | Weld thickness between beam web and endplate
aWebColumn | Weld thickness between column web and Tee web
Beam | Beam object
Column | Column object
LoadCases | Load cases of the beam
Plate | Endplate object
Results | List of results
Tee | Tee object
TeeLength | Tee length
TeeSteel | Tee steel

See Also

BeamColumnTeeConnection Class


BeamColumnTeeConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection Constructor
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnTeeConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnTeeConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnTeeConnection()

See Also

BeamColumnTeeConnection Class


BeamColumnTeeConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection Fields
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnTeeConnection type exposes the following members.

Fields

Name | Description
aFlangeBeam | Weld thickness between flange and endplate
aFlangesColumn | Weld thickness between column flanges and Tee flange
aWebBeam | Weld thickness between beam web and endplate
aWebColumn | Weld thickness between column web and Tee web
Beam | Beam object
Column | Column object
LoadCases | Load cases of the beam
Plate | Endplate object
Results | List of results
Tee | Tee object
TeeLength | Tee length
TeeSteel | Tee steel

See Also

BeamColumnTeeConnection Class


aFlangeBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.aFlangeBeam Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aFlangeBeam
Visual Basic (Declaration)
Public aFlangeBeam As Double
Visual C++
public:
double aFlangeBeam

Remarks

See Also

BeamColumnTeeConnection Class


aFlangesColumn Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.aFlangesColumn Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between column flanges and Tee flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aFlangesColumn
Visual Basic (Declaration)
Public aFlangesColumn As Double
Visual C++
public:
double aFlangesColumn

Remarks

See Also

BeamColumnTeeConnection Class


aWebBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.aWebBeam Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between beam web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aWebBeam
Visual Basic (Declaration)
Public aWebBeam As Double
Visual C++
public:
double aWebBeam

Remarks

See Also

BeamColumnTeeConnection Class


aWebColumn Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.aWebColumn Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between column web and Tee web

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aWebColumn
Visual Basic (Declaration)
Public aWebColumn As Double
Visual C++
public:
double aWebColumn

Remarks

See Also

BeamColumnTeeConnection Class


Beam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.Beam Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Beam
Visual Basic (Declaration)
Public Beam As HSection
Visual C++
public:
HSection^ Beam

Remarks

See Also

BeamColumnTeeConnection Class


Column Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.Column Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Column
Visual Basic (Declaration)
Public Column As HSection
Visual C++
public:
HSection^ Column

Remarks

See Also

BeamColumnTeeConnection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.LoadCases Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ved (positive=downwards)

See Also

BeamColumnTeeConnection Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.Plate Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Endplate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BoltedEndPlate Plate
Visual Basic (Declaration)
Public Plate As BoltedEndPlate
Visual C++
public:
BoltedEndPlate^ Plate

Remarks

See Also

BeamColumnTeeConnection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.Results Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamColumnTeeConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamColumnTeeConnectionResults)
Visual C++
public:
List<BeamColumnTeeConnectionResults^>^ Results

Remarks

See Also

BeamColumnTeeConnection Class


Tee Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.Tee Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Tee object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TSection Tee
Visual Basic (Declaration)
Public Tee As TSection
Visual C++
public:
TSection^ Tee

Remarks

See Also

BeamColumnTeeConnection Class


TeeLength Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.TeeLength Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Tee length

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double TeeLength
Visual Basic (Declaration)
Public TeeLength As Double
Visual C++
public:
double TeeLength

Remarks

See Also

BeamColumnTeeConnection Class


TeeSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.TeeSteel Field
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Tee steel

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade TeeSteel
Visual Basic (Declaration)
Public TeeSteel As SteelGrade
Visual C++
public:
SteelGrade^ TeeSteel

Remarks

See Also

BeamColumnTeeConnection Class


BeamColumnTeeConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection Methods
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnTeeConnection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnTeeConnection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.Calculate Method
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamColumnTeeConnection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnection..::.GetInputWarnings Method
BeamColumnTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnTeeConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamColumnTeeConnectionInputWarnings
Visual C++
public:
BeamColumnTeeConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamColumnTeeConnection Class


BeamColumnTeeConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnTeeConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamColumnTeeConnectionInputWarnings
Visual C++
public ref class BeamColumnTeeConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnTeeConnectionInputWarnings

See Also

BeamColumnTeeConnectionInputWarnings Members


BeamColumnTeeConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionInputWarnings Members
BeamColumnTeeConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnTeeConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamColumnTeeConnectionInputWarnings | Initializes a new instance of the BeamColumnTeeConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamColumnTeeConnectionInputWarnings Class


BeamColumnTeeConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionInputWarnings Constructor
BeamColumnTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnTeeConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnTeeConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnTeeConnectionInputWarnings()

See Also

BeamColumnTeeConnectionInputWarnings Class


BeamColumnTeeConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionInputWarnings Fields
BeamColumnTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnTeeConnectionInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamColumnTeeConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionInputWarnings..::.Other Field
BeamColumnTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamColumnTeeConnectionInputWarnings Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionInputWarnings..::.Plate Field
BeamColumnTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Plate
Visual Basic (Declaration)
Public Plate As List(Of String)
Visual C++
public:
List<String^>^ Plate

Remarks

See Also

BeamColumnTeeConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionInputWarnings..::.Welds Field
BeamColumnTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamColumnTeeConnectionInputWarnings Class


BeamColumnTeeConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionInputWarnings Methods
BeamColumnTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnTeeConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnTeeConnectionInputWarnings Class


BeamColumnTeeConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnTeeConnectionResults
Visual Basic (Declaration)
Public Class BeamColumnTeeConnectionResults
Visual C++
public ref class BeamColumnTeeConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnTeeConnectionResults

See Also

BeamColumnTeeConnectionResults Members


BeamColumnTeeConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults Members
BeamColumnTeeConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnTeeConnectionResults type exposes the following members.

Constructors

Name | Description
BeamColumnTeeConnectionResults | Initializes a new instance of the BeamColumnTeeConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BeamWeldCapacity | Beam weld capacity
BeamWeldResistance | Beam weld resistance
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
ColumnWeldCapacity | Column weld capacity
ColumnWeldResistance | Column weld resistance

See Also

BeamColumnTeeConnectionResults Class


BeamColumnTeeConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults Constructor
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnTeeConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnTeeConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnTeeConnectionResults()

See Also

BeamColumnTeeConnectionResults Class


BeamColumnTeeConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults Fields
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnTeeConnectionResults type exposes the following members.

Fields

Name | Description
BeamWeldCapacity | Beam weld capacity
BeamWeldResistance | Beam weld resistance
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
ColumnWeldCapacity | Column weld capacity
ColumnWeldResistance | Column weld resistance

See Also

BeamColumnTeeConnectionResults Class


BeamWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults..::.BeamWeldCapacity Field
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamWeldCapacity
Visual Basic (Declaration)
Public BeamWeldCapacity As Double
Visual C++
public:
double BeamWeldCapacity

Remarks

See Also

BeamColumnTeeConnectionResults Class


BeamWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults..::.BeamWeldResistance Field
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamWeldResistance
Visual Basic (Declaration)
Public BeamWeldResistance As Double
Visual C++
public:
double BeamWeldResistance

Remarks

See Also

BeamColumnTeeConnectionResults Class


BoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults..::.BoltsBearingCapacity Field
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingCapacity
Visual Basic (Declaration)
Public BoltsBearingCapacity As Double
Visual C++
public:
double BoltsBearingCapacity

Remarks

See Also

BeamColumnTeeConnectionResults Class


BoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults..::.BoltsBearingResistance Field
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingResistance
Visual Basic (Declaration)
Public BoltsBearingResistance As Double
Visual C++
public:
double BoltsBearingResistance

Remarks

See Also

BeamColumnTeeConnectionResults Class


BoltsShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults..::.BoltsShearCapacity Field
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearCapacity
Visual Basic (Declaration)
Public BoltsShearCapacity As Double
Visual C++
public:
double BoltsShearCapacity

Remarks

See Also

BeamColumnTeeConnectionResults Class


BoltsShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults..::.BoltsShearResistance Field
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearResistance
Visual Basic (Declaration)
Public BoltsShearResistance As Double
Visual C++
public:
double BoltsShearResistance

Remarks

See Also

BeamColumnTeeConnectionResults Class


ColumnWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults..::.ColumnWeldCapacity Field
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnWeldCapacity
Visual Basic (Declaration)
Public ColumnWeldCapacity As Double
Visual C++
public:
double ColumnWeldCapacity

Remarks

See Also

BeamColumnTeeConnectionResults Class


ColumnWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults..::.ColumnWeldResistance Field
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnWeldResistance
Visual Basic (Declaration)
Public ColumnWeldResistance As Double
Visual C++
public:
double ColumnWeldResistance

Remarks

See Also

BeamColumnTeeConnectionResults Class


BeamColumnTeeConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnTeeConnectionResults Methods
BeamColumnTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnTeeConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnTeeConnectionResults Class


BeamColumnWeldedConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a singe or double side beam to column welded connection

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnWeldedConnection
Visual Basic (Declaration)
Public Class BeamColumnWeldedConnection
Visual C++
public ref class BeamColumnWeldedConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnWeldedConnection

See Also

BeamColumnWeldedConnection Members


BeamColumnWeldedConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection Members
BeamColumnWeldedConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnWeldedConnection type exposes the following members.

Constructors

Name | Description
BeamColumnWeldedConnection | Initializes a new instance of the BeamColumnWeldedConnection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
af_beamLeft | Weld thickness between left beam flange and endplate
af_beamRight | Weld thickness between right beam flange and endplate
aHaunchLeftBeamFlange | Weld thickness between left haunch flange and beam flange
aHaunchLeftEndPlateFlange | Weld thickness between left haunch flange and endplate
aHaunchLeftEndPlateWeb | Weld thickness between left haunch web and endplate
aHaunchRightBeamFlange | Weld thickness between right haunch flange and beam flange
aHaunchRightEndPlateFlange | Weld thickness between right haunch flange and endplate
aHaunchRightEndPlateWeb | Weld thickness between right haunch web and endplate
ast_col | Weld thickness between column web and transverse stiffners
aSupplementaryWebPlate | Weld thickness between supplementary column web plates and column web
aw_beamLeft | Weld thickness between left beam web and endplate
aw_beamRight | Weld thickness between right beam web and endplate
BeamLeft | Left beam object
BeamRight | Right beam object
bs | Supplementary column web plates width
bst_col | Column transverse stiffeners total width
Column | Column object
ColumnExtensionOverRightBeam | Net distance between column end and upper beam flange
ColumnSteel | Column steel grade
ds | Center distance between stiffeners
ds_over_rightBeamFlange | center distance between right upper beam flange and upper column web stiffener
HaunchLeft | Left haunch object
HaunchRight | Right haunch object
LeftBeamSteel | Left beam steel grade
LeftConnectionAlso | True, if left connection exist (double side connection), otherwise false
LoadCasesLeftBeam | Load cases of left beam, in case of double side connection
LoadCasesResultantColumn | Resultant loads on column from upper and lower stories
LoadCasesRightBeam | Load cases of right beam
NrOfSupplementaryWebPlates | Number of supplementary column web plates used (1, 2 or 3)
Results | List of results
RightBeamSteel | Right beam steel grade
Theta_HaunchLeft | Angle between left beam and haunch flanges
Theta_HaunchRight | Angle between right beam and haunch flanges
ts | Supplementary column web plates thickness
tst_bLeft | True, if a haunch is used for the left connection, otherwise false
tst_bRight | True, if a haunch is used for the right connection, otherwise false
tst_col | Column transverse stiffeners thickness
UseOfBeamLeftWebStiffener | True, if a beam web stiffener is used for the left connection, otherwise false
UseOfBeamRightWebStiffener | True, if a beam web stiffener is used for the right connection, otherwise false
UseOfColumnWebStiffeners | True is transverse column web stiffeners are used, otherwise false
UseOfDiagonalColumnWebStiffener | True is diagonal stiffeners are used, otherwise false
UseOfHaunchLeft | True, if a haunch is used for the left connection, otherwise false
UseOfHaunchRight | True, if a haunch is used for the right connection, otherwise false

See Also

BeamColumnWeldedConnection Class


BeamColumnWeldedConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection Constructor
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnWeldedConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnWeldedConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnWeldedConnection()

See Also

BeamColumnWeldedConnection Class


BeamColumnWeldedConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection Fields
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnWeldedConnection type exposes the following members.

Fields

Name | Description
af_beamLeft | Weld thickness between left beam flange and endplate
af_beamRight | Weld thickness between right beam flange and endplate
aHaunchLeftBeamFlange | Weld thickness between left haunch flange and beam flange
aHaunchLeftEndPlateFlange | Weld thickness between left haunch flange and endplate
aHaunchLeftEndPlateWeb | Weld thickness between left haunch web and endplate
aHaunchRightBeamFlange | Weld thickness between right haunch flange and beam flange
aHaunchRightEndPlateFlange | Weld thickness between right haunch flange and endplate
aHaunchRightEndPlateWeb | Weld thickness between right haunch web and endplate
ast_col | Weld thickness between column web and transverse stiffners
aSupplementaryWebPlate | Weld thickness between supplementary column web plates and column web
aw_beamLeft | Weld thickness between left beam web and endplate
aw_beamRight | Weld thickness between right beam web and endplate
BeamLeft | Left beam object
BeamRight | Right beam object
bs | Supplementary column web plates width
bst_col | Column transverse stiffeners total width
Column | Column object
ColumnExtensionOverRightBeam | Net distance between column end and upper beam flange
ColumnSteel | Column steel grade
ds | Center distance between stiffeners
ds_over_rightBeamFlange | center distance between right upper beam flange and upper column web stiffener
HaunchLeft | Left haunch object
HaunchRight | Right haunch object
LeftBeamSteel | Left beam steel grade
LeftConnectionAlso | True, if left connection exist (double side connection), otherwise false
LoadCasesLeftBeam | Load cases of left beam, in case of double side connection
LoadCasesResultantColumn | Resultant loads on column from upper and lower stories
LoadCasesRightBeam | Load cases of right beam
NrOfSupplementaryWebPlates | Number of supplementary column web plates used (1, 2 or 3)
Results | List of results
RightBeamSteel | Right beam steel grade
Theta_HaunchLeft | Angle between left beam and haunch flanges
Theta_HaunchRight | Angle between right beam and haunch flanges
ts | Supplementary column web plates thickness
tst_bLeft | True, if a haunch is used for the left connection, otherwise false
tst_bRight | True, if a haunch is used for the right connection, otherwise false
tst_col | Column transverse stiffeners thickness
UseOfBeamLeftWebStiffener | True, if a beam web stiffener is used for the left connection, otherwise false
UseOfBeamRightWebStiffener | True, if a beam web stiffener is used for the right connection, otherwise false
UseOfColumnWebStiffeners | True is transverse column web stiffeners are used, otherwise false
UseOfDiagonalColumnWebStiffener | True is diagonal stiffeners are used, otherwise false
UseOfHaunchLeft | True, if a haunch is used for the left connection, otherwise false
UseOfHaunchRight | True, if a haunch is used for the right connection, otherwise false

See Also

BeamColumnWeldedConnection Class


af_beamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.af_beamLeft Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left beam flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double af_beamLeft
Visual Basic (Declaration)
Public af_beamLeft As Double
Visual C++
public:
double af_beamLeft

Remarks

Beam flange is welded at its both sides

See Also

BeamColumnWeldedConnection Class


af_beamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.af_beamRight Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right beam flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double af_beamRight
Visual Basic (Declaration)
Public af_beamRight As Double
Visual C++
public:
double af_beamRight

Remarks

Beam flange is welded at its both sides

See Also

BeamColumnWeldedConnection Class


aHaunchLeftBeamFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.aHaunchLeftBeamFlange Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left haunch flange and beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchLeftBeamFlange
Visual Basic (Declaration)
Public aHaunchLeftBeamFlange As Double
Visual C++
public:
double aHaunchLeftBeamFlange

Remarks

See Also

BeamColumnWeldedConnection Class


aHaunchLeftEndPlateFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.aHaunchLeftEndPlateFlange Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left haunch flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchLeftEndPlateFlange
Visual Basic (Declaration)
Public aHaunchLeftEndPlateFlange As Double
Visual C++
public:
double aHaunchLeftEndPlateFlange

Remarks

See Also

BeamColumnWeldedConnection Class


aHaunchLeftEndPlateWeb Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.aHaunchLeftEndPlateWeb Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left haunch web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchLeftEndPlateWeb
Visual Basic (Declaration)
Public aHaunchLeftEndPlateWeb As Double
Visual C++
public:
double aHaunchLeftEndPlateWeb

Remarks

See Also

BeamColumnWeldedConnection Class


aHaunchRightBeamFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.aHaunchRightBeamFlange Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right haunch flange and beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchRightBeamFlange
Visual Basic (Declaration)
Public aHaunchRightBeamFlange As Double
Visual C++
public:
double aHaunchRightBeamFlange

Remarks

See Also

BeamColumnWeldedConnection Class


aHaunchRightEndPlateFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.aHaunchRightEndPlateFlange Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right haunch flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchRightEndPlateFlange
Visual Basic (Declaration)
Public aHaunchRightEndPlateFlange As Double
Visual C++
public:
double aHaunchRightEndPlateFlange

Remarks

See Also

BeamColumnWeldedConnection Class


aHaunchRightEndPlateWeb Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.aHaunchRightEndPlateWeb Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right haunch web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchRightEndPlateWeb
Visual Basic (Declaration)
Public aHaunchRightEndPlateWeb As Double
Visual C++
public:
double aHaunchRightEndPlateWeb

Remarks

See Also

BeamColumnWeldedConnection Class


ast_col Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.ast_col Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between column web and transverse stiffners

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ast_col
Visual Basic (Declaration)
Public ast_col As Double
Visual C++
public:
double ast_col

Remarks

See Also

BeamColumnWeldedConnection Class


aSupplementaryWebPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.aSupplementaryWebPlate Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between supplementary column web plates and column web

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aSupplementaryWebPlate
Visual Basic (Declaration)
Public aSupplementaryWebPlate As Double
Visual C++
public:
double aSupplementaryWebPlate

Remarks

See Also

BeamColumnWeldedConnection Class


aw_beamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.aw_beamLeft Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between left beam web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aw_beamLeft
Visual Basic (Declaration)
Public aw_beamLeft As Double
Visual C++
public:
double aw_beamLeft

Remarks

See Also

BeamColumnWeldedConnection Class


aw_beamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.aw_beamRight Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between right beam web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aw_beamRight
Visual Basic (Declaration)
Public aw_beamRight As Double
Visual C++
public:
double aw_beamRight

Remarks

See Also

BeamColumnWeldedConnection Class


BeamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.BeamLeft Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Left beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection BeamLeft
Visual Basic (Declaration)
Public BeamLeft As HSection
Visual C++
public:
HSection^ BeamLeft

Remarks

See Also

BeamColumnWeldedConnection Class


BeamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.BeamRight Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Right beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection BeamRight
Visual Basic (Declaration)
Public BeamRight As HSection
Visual C++
public:
HSection^ BeamRight

Remarks

See Also

BeamColumnWeldedConnection Class


bs Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.bs Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Supplementary column web plates width

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double bs
Visual Basic (Declaration)
Public bs As Double
Visual C++
public:
double bs

Remarks

See Also

BeamColumnWeldedConnection Class


bst_col Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.bst_col Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column transverse stiffeners total width

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double bst_col
Visual Basic (Declaration)
Public bst_col As Double
Visual C++
public:
double bst_col

Remarks

See Also

BeamColumnWeldedConnection Class


Column Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.Column Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Column
Visual Basic (Declaration)
Public Column As HSection
Visual C++
public:
HSection^ Column

Remarks

See Also

BeamColumnWeldedConnection Class


ColumnExtensionOverRightBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.ColumnExtensionOverRightBeam Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Net distance between column end and upper beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ColumnExtensionOverRightBeam
Visual Basic (Declaration)
Public ColumnExtensionOverRightBeam As Object
Visual C++
public:
Object^ ColumnExtensionOverRightBeam

Remarks

See Also

BeamColumnWeldedConnection Class


ColumnSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.ColumnSteel Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade ColumnSteel
Visual Basic (Declaration)
Public ColumnSteel As SteelGrade
Visual C++
public:
SteelGrade^ ColumnSteel

Remarks

See Also

BeamColumnWeldedConnection Class


ds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.ds Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Center distance between stiffeners

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ds
Visual Basic (Declaration)
Public ds As Double
Visual C++
public:
double ds

Remarks

See Also

BeamColumnWeldedConnection Class


ds_over_rightBeamFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.ds_over_rightBeamFlange Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
center distance between right upper beam flange and upper column web stiffener

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ds_over_rightBeamFlange
Visual Basic (Declaration)
Public ds_over_rightBeamFlange As Object
Visual C++
public:
Object^ ds_over_rightBeamFlange

Remarks

See Also

BeamColumnWeldedConnection Class


HaunchLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.HaunchLeft Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Left haunch object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TSection HaunchLeft
Visual Basic (Declaration)
Public HaunchLeft As TSection
Visual C++
public:
TSection^ HaunchLeft

Remarks

See Also

BeamColumnWeldedConnection Class


HaunchRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.HaunchRight Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Right haunch object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TSection HaunchRight
Visual Basic (Declaration)
Public HaunchRight As TSection
Visual C++
public:
TSection^ HaunchRight

Remarks

See Also

BeamColumnWeldedConnection Class


LeftBeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.LeftBeamSteel Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Left beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade LeftBeamSteel
Visual Basic (Declaration)
Public LeftBeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ LeftBeamSteel

Remarks

See Also

BeamColumnWeldedConnection Class


LeftConnectionAlso Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.LeftConnectionAlso Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if left connection exist (double side connection), otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LeftConnectionAlso
Visual Basic (Declaration)
Public LeftConnectionAlso As Boolean
Visual C++
public:
bool LeftConnectionAlso

Remarks

See Also

BeamColumnWeldedConnection Class


LoadCasesLeftBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.LoadCasesLeftBeam Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of left beam, in case of double side connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesLeftBeam
Visual Basic (Declaration)
Public LoadCasesLeftBeam As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesLeftBeam

Remarks

Following forces are considered:

Ned (positive=compressive), WARNING: Ned should not exceed 5% of the beam plastic axial resistance, according to 6.2.3(2) [prEN 1993-1-8 : 2003]!!

Ved (positive=downwards)

Med (positive=lower beam flange is compressed), WARNING: Med has to be positive!!

See Also

BeamColumnWeldedConnection Class


LoadCasesResultantColumn Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.LoadCasesResultantColumn Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Resultant loads on column from upper and lower stories

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesResultantColumn
Visual Basic (Declaration)
Public LoadCasesResultantColumn As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesResultantColumn

Remarks

Following forces are considered:

Ned (positive=compressive)

Ved (sign does not matter)

Med (sign does not matter)

See Also

BeamColumnWeldedConnection Class


LoadCasesRightBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.LoadCasesRightBeam Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of right beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesRightBeam
Visual Basic (Declaration)
Public LoadCasesRightBeam As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesRightBeam

Remarks

Following forces are considered:

Ned (positive=compressive), WARNING: Ned should not exceed 5% of the beam plastic axial resistance, according to 6.2.3(2) [prEN 1993-1-8 : 2003]!!

Ved (positive=downwards)

Med (positive=lower beam flange is compressed), WARNING: Med has to be positive!!

See Also

BeamColumnWeldedConnection Class


NrOfSupplementaryWebPlates Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.NrOfSupplementaryWebPlates Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Number of supplementary column web plates used (1, 2 or 3)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int NrOfSupplementaryWebPlates
Visual Basic (Declaration)
Public NrOfSupplementaryWebPlates As Integer
Visual C++
public:
int NrOfSupplementaryWebPlates

Remarks

See Also

BeamColumnWeldedConnection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.Results Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamColumnWeldedConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamColumnWeldedConnectionResults)
Visual C++
public:
List<BeamColumnWeldedConnectionResults^>^ Results

Remarks

See Also

BeamColumnWeldedConnection Class


RightBeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.RightBeamSteel Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Right beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade RightBeamSteel
Visual Basic (Declaration)
Public RightBeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ RightBeamSteel

Remarks

See Also

BeamColumnWeldedConnection Class


Theta_HaunchLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.Theta_HaunchLeft Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Angle between left beam and haunch flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Theta_HaunchLeft
Visual Basic (Declaration)
Public Theta_HaunchLeft As Double
Visual C++
public:
double Theta_HaunchLeft

Remarks

See Also

BeamColumnWeldedConnection Class


Theta_HaunchRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.Theta_HaunchRight Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Angle between right beam and haunch flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Theta_HaunchRight
Visual Basic (Declaration)
Public Theta_HaunchRight As Double
Visual C++
public:
double Theta_HaunchRight

Remarks

See Also

BeamColumnWeldedConnection Class


ts Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.ts Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Supplementary column web plates thickness

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ts
Visual Basic (Declaration)
Public ts As Double
Visual C++
public:
double ts

Remarks

See Also

BeamColumnWeldedConnection Class


tst_bLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.tst_bLeft Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a haunch is used for the left connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tst_bLeft
Visual Basic (Declaration)
Public tst_bLeft As Double
Visual C++
public:
double tst_bLeft

Remarks

See Also

BeamColumnWeldedConnection Class


tst_bRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.tst_bRight Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a haunch is used for the right connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tst_bRight
Visual Basic (Declaration)
Public tst_bRight As Double
Visual C++
public:
double tst_bRight

Remarks

See Also

BeamColumnWeldedConnection Class


tst_col Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.tst_col Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column transverse stiffeners thickness

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tst_col
Visual Basic (Declaration)
Public tst_col As Double
Visual C++
public:
double tst_col

Remarks

See Also

BeamColumnWeldedConnection Class


UseOfBeamLeftWebStiffener Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.UseOfBeamLeftWebStiffener Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a beam web stiffener is used for the left connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfBeamLeftWebStiffener
Visual Basic (Declaration)
Public UseOfBeamLeftWebStiffener As Boolean
Visual C++
public:
bool UseOfBeamLeftWebStiffener

Remarks

See Also

BeamColumnWeldedConnection Class


UseOfBeamRightWebStiffener Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.UseOfBeamRightWebStiffener Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a beam web stiffener is used for the right connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfBeamRightWebStiffener
Visual Basic (Declaration)
Public UseOfBeamRightWebStiffener As Boolean
Visual C++
public:
bool UseOfBeamRightWebStiffener

Remarks

See Also

BeamColumnWeldedConnection Class


UseOfColumnWebStiffeners Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.UseOfColumnWebStiffeners Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True is transverse column web stiffeners are used, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfColumnWebStiffeners
Visual Basic (Declaration)
Public UseOfColumnWebStiffeners As Boolean
Visual C++
public:
bool UseOfColumnWebStiffeners

Remarks

See Also

BeamColumnWeldedConnection Class


UseOfDiagonalColumnWebStiffener Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.UseOfDiagonalColumnWebStiffener Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True is diagonal stiffeners are used, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfDiagonalColumnWebStiffener
Visual Basic (Declaration)
Public UseOfDiagonalColumnWebStiffener As Boolean
Visual C++
public:
bool UseOfDiagonalColumnWebStiffener

Remarks

See Also

BeamColumnWeldedConnection Class


UseOfHaunchLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.UseOfHaunchLeft Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a haunch is used for the left connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfHaunchLeft
Visual Basic (Declaration)
Public UseOfHaunchLeft As Boolean
Visual C++
public:
bool UseOfHaunchLeft

Remarks

See Also

BeamColumnWeldedConnection Class


UseOfHaunchRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.UseOfHaunchRight Field
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a haunch is used for the right connection, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfHaunchRight
Visual Basic (Declaration)
Public UseOfHaunchRight As Boolean
Visual C++
public:
bool UseOfHaunchRight

Remarks

See Also

BeamColumnWeldedConnection Class


BeamColumnWeldedConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection Methods
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnWeldedConnection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnWeldedConnection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.Calculate Method
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamColumnWeldedConnection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnection..::.GetInputWarnings Method
BeamColumnWeldedConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnEndplateConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamColumnEndplateConnectionInputWarnings
Visual C++
public:
BeamColumnEndplateConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamColumnWeldedConnection Class


BeamColumnWeldedConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnWeldedConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamColumnWeldedConnectionInputWarnings
Visual C++
public ref class BeamColumnWeldedConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnWeldedConnectionInputWarnings

See Also

BeamColumnWeldedConnectionInputWarnings Members


BeamColumnWeldedConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionInputWarnings Members
BeamColumnWeldedConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnWeldedConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamColumnWeldedConnectionInputWarnings | Initializes a new instance of the BeamColumnWeldedConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
LeftConnectionWarnings | Input warnings regarding the left connection
RightConnectionWarnings | Input warnings regarding the right connection

See Also

BeamColumnWeldedConnectionInputWarnings Class


BeamColumnWeldedConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionInputWarnings Constructor
BeamColumnWeldedConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnWeldedConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnWeldedConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnWeldedConnectionInputWarnings()

See Also

BeamColumnWeldedConnectionInputWarnings Class


BeamColumnWeldedConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionInputWarnings Fields
BeamColumnWeldedConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnWeldedConnectionInputWarnings type exposes the following members.

Fields

Name | Description
LeftConnectionWarnings | Input warnings regarding the left connection
RightConnectionWarnings | Input warnings regarding the right connection

See Also

BeamColumnWeldedConnectionInputWarnings Class


LeftConnectionWarnings Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionInputWarnings..::.LeftConnectionWarnings Field
BeamColumnWeldedConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OneSideBeamColumnEndplateInputWarnings LeftConnectionWarnings
Visual Basic (Declaration)
Public LeftConnectionWarnings As OneSideBeamColumnEndplateInputWarnings
Visual C++
public:
OneSideBeamColumnEndplateInputWarnings^ LeftConnectionWarnings

Remarks

See Also

BeamColumnWeldedConnectionInputWarnings Class


RightConnectionWarnings Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionInputWarnings..::.RightConnectionWarnings Field
BeamColumnWeldedConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the right connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OneSideBeamColumnEndplateInputWarnings RightConnectionWarnings
Visual Basic (Declaration)
Public RightConnectionWarnings As OneSideBeamColumnEndplateInputWarnings
Visual C++
public:
OneSideBeamColumnEndplateInputWarnings^ RightConnectionWarnings

Remarks

See Also

BeamColumnWeldedConnectionInputWarnings Class


BeamColumnWeldedConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionInputWarnings Methods
BeamColumnWeldedConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnWeldedConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnWeldedConnectionInputWarnings Class


BeamColumnWeldedConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamColumnWeldedConnectionResults
Visual Basic (Declaration)
Public Class BeamColumnWeldedConnectionResults
Visual C++
public ref class BeamColumnWeldedConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamColumnWeldedConnectionResults

See Also

BeamColumnWeldedConnectionResults Members


BeamColumnWeldedConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionResults Members
BeamColumnWeldedConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnWeldedConnectionResults type exposes the following members.

Constructors

Name | Description
BeamColumnWeldedConnectionResults | Initializes a new instance of the BeamColumnWeldedConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
LeftConnectionResults | List of left connection results
RightConnectionResults | List of right connection results

See Also

BeamColumnWeldedConnectionResults Class


BeamColumnWeldedConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionResults Constructor
BeamColumnWeldedConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamColumnWeldedConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamColumnWeldedConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamColumnWeldedConnectionResults()

See Also

BeamColumnWeldedConnectionResults Class


BeamColumnWeldedConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionResults Fields
BeamColumnWeldedConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnWeldedConnectionResults type exposes the following members.

Fields

Name | Description
LeftConnectionResults | List of left connection results
RightConnectionResults | List of right connection results

See Also

BeamColumnWeldedConnectionResults Class


LeftConnectionResults Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionResults..::.LeftConnectionResults Field
BeamColumnWeldedConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
List of left connection results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<OneSideBeamColumnWeldedResults> LeftConnectionResults
Visual Basic (Declaration)
Public LeftConnectionResults As List(Of OneSideBeamColumnWeldedResults)
Visual C++
public:
List<OneSideBeamColumnWeldedResults^>^ LeftConnectionResults

Remarks

See Also

BeamColumnWeldedConnectionResults Class


RightConnectionResults Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionResults..::.RightConnectionResults Field
BeamColumnWeldedConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
List of right connection results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<OneSideBeamColumnWeldedResults> RightConnectionResults
Visual Basic (Declaration)
Public RightConnectionResults As List(Of OneSideBeamColumnWeldedResults)
Visual C++
public:
List<OneSideBeamColumnWeldedResults^>^ RightConnectionResults

Remarks

See Also

BeamColumnWeldedConnectionResults Class


BeamColumnWeldedConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamColumnWeldedConnectionResults Methods
BeamColumnWeldedConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamColumnWeldedConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamColumnWeldedConnectionResults Class


BeamOnBeamConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam to beam connection by means of a single or double cleat

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamOnBeamConnection
Visual Basic (Declaration)
Public Class BeamOnBeamConnection
Visual C++
public ref class BeamOnBeamConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamOnBeamConnection

See Also

BeamOnBeamConnection Members


BeamOnBeamConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection Members
BeamOnBeamConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamConnection type exposes the following members.

Constructors

Name | Description
BeamOnBeamConnection | Initializes a new instance of the BeamOnBeamConnection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
aLeft | Weld thickness in case of welded connection between Left beam and cleat(s)
aRight | Weld thickness in case of welded connection between right beam and cleat(s)
BeamLeft | Left beam object
BeamRight | Right beam object
BeamSteel | Beam steel grade
LeftBeamTotalSectionCut | Total section cut (above+below) of left beam
LeftConnectionAlso | True, if a left connection exists
LoadCasesLeft | Load cases of left beam
LoadCasesRight | Loadcases of right beam
MainBeam | Main beam steel grade
OnlyOneAnglePerConnection | True, if a single cleat is used, otherwise (in case of double cleat), false
PlateOnBeamLeft | Bolted plate on Left beam
PlateOnBeamRight | Bolted plate on right beam
PlateOnMainBeamLeft | Bolted plate on the left of the main beam
PlateOnMainBeamRight | Bolted plate on the right of the main beam
Results | List of results
RightBeamTotalSectionCut | Total section cut (above+below) of right beam
WeldedOnBeamLeft | True, if the connection between Left beam and cleat(s) is welded, otherwise false
WeldedOnBeamRight | True, if the connection between right beam and cleat(s) is welded, otherwise false

See Also

BeamOnBeamConnection Class


BeamOnBeamConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection Constructor
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamOnBeamConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamOnBeamConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamOnBeamConnection()

See Also

BeamOnBeamConnection Class


BeamOnBeamConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection Fields
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamConnection type exposes the following members.

Fields

Name | Description
aLeft | Weld thickness in case of welded connection between Left beam and cleat(s)
aRight | Weld thickness in case of welded connection between right beam and cleat(s)
BeamLeft | Left beam object
BeamRight | Right beam object
BeamSteel | Beam steel grade
LeftBeamTotalSectionCut | Total section cut (above+below) of left beam
LeftConnectionAlso | True, if a left connection exists
LoadCasesLeft | Load cases of left beam
LoadCasesRight | Loadcases of right beam
MainBeam | Main beam steel grade
OnlyOneAnglePerConnection | True, if a single cleat is used, otherwise (in case of double cleat), false
PlateOnBeamLeft | Bolted plate on Left beam
PlateOnBeamRight | Bolted plate on right beam
PlateOnMainBeamLeft | Bolted plate on the left of the main beam
PlateOnMainBeamRight | Bolted plate on the right of the main beam
Results | List of results
RightBeamTotalSectionCut | Total section cut (above+below) of right beam
WeldedOnBeamLeft | True, if the connection between Left beam and cleat(s) is welded, otherwise false
WeldedOnBeamRight | True, if the connection between right beam and cleat(s) is welded, otherwise false

See Also

BeamOnBeamConnection Class


aLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.aLeft Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness in case of welded connection between Left beam and cleat(s)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aLeft
Visual Basic (Declaration)
Public aLeft As Double
Visual C++
public:
double aLeft

Remarks

See Also

BeamOnBeamConnection Class


aRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.aRight Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness in case of welded connection between right beam and cleat(s)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aRight
Visual Basic (Declaration)
Public aRight As Double
Visual C++
public:
double aRight

Remarks

See Also

BeamOnBeamConnection Class


BeamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.BeamLeft Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Left beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection BeamLeft
Visual Basic (Declaration)
Public BeamLeft As HSection
Visual C++
public:
HSection^ BeamLeft

Remarks

See Also

BeamOnBeamConnection Class


BeamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.BeamRight Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Right beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection BeamRight
Visual Basic (Declaration)
Public BeamRight As HSection
Visual C++
public:
HSection^ BeamRight

Remarks

See Also

BeamOnBeamConnection Class


BeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.BeamSteel Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade BeamSteel
Visual Basic (Declaration)
Public BeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ BeamSteel

Remarks

See Also

BeamOnBeamConnection Class


LeftBeamTotalSectionCut Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.LeftBeamTotalSectionCut Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Total section cut (above+below) of left beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double LeftBeamTotalSectionCut
Visual Basic (Declaration)
Public LeftBeamTotalSectionCut As Double
Visual C++
public:
double LeftBeamTotalSectionCut

Remarks

See Also

BeamOnBeamConnection Class


LeftConnectionAlso Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.LeftConnectionAlso Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a left connection exists

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LeftConnectionAlso
Visual Basic (Declaration)
Public LeftConnectionAlso As Boolean
Visual C++
public:
bool LeftConnectionAlso

Remarks

See Also

BeamOnBeamConnection Class


LoadCasesLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.LoadCasesLeft Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of left beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesLeft
Visual Basic (Declaration)
Public LoadCasesLeft As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesLeft

Remarks

Following forces are considered:

Ved (positive=downwards)

See Also

BeamOnBeamConnection Class


LoadCasesRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.LoadCasesRight Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Loadcases of right beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCasesRight
Visual Basic (Declaration)
Public LoadCasesRight As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCasesRight

Remarks

Following forces are considered:

Ved (positive=downwards)

See Also

BeamOnBeamConnection Class


MainBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.MainBeam Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Main beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection MainBeam
Visual Basic (Declaration)
Public MainBeam As HSection
Visual C++
public:
HSection^ MainBeam

Remarks

See Also

BeamOnBeamConnection Class


OnlyOneAnglePerConnection Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.OnlyOneAnglePerConnection Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if a single cleat is used, otherwise (in case of double cleat), false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool OnlyOneAnglePerConnection
Visual Basic (Declaration)
Public OnlyOneAnglePerConnection As Boolean
Visual C++
public:
bool OnlyOneAnglePerConnection

Remarks

See Also

BeamOnBeamConnection Class


PlateOnBeamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.PlateOnBeamLeft Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate on Left beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate PlateOnBeamLeft
Visual Basic (Declaration)
Public PlateOnBeamLeft As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ PlateOnBeamLeft

Remarks

See Also

BeamOnBeamConnection Class


PlateOnBeamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.PlateOnBeamRight Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate on right beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate PlateOnBeamRight
Visual Basic (Declaration)
Public PlateOnBeamRight As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ PlateOnBeamRight

Remarks

See Also

BeamOnBeamConnection Class


PlateOnMainBeamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.PlateOnMainBeamLeft Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate on the left of the main beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate PlateOnMainBeamLeft
Visual Basic (Declaration)
Public PlateOnMainBeamLeft As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ PlateOnMainBeamLeft

Remarks

See Also

BeamOnBeamConnection Class


PlateOnMainBeamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.PlateOnMainBeamRight Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolted plate on the right of the main beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate PlateOnMainBeamRight
Visual Basic (Declaration)
Public PlateOnMainBeamRight As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ PlateOnMainBeamRight

Remarks

See Also

BeamOnBeamConnection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.Results Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamOnBeamConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamOnBeamConnectionResults)
Visual C++
public:
List<BeamOnBeamConnectionResults^>^ Results

Remarks

See Also

BeamOnBeamConnection Class


RightBeamTotalSectionCut Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.RightBeamTotalSectionCut Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Total section cut (above+below) of right beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RightBeamTotalSectionCut
Visual Basic (Declaration)
Public RightBeamTotalSectionCut As Double
Visual C++
public:
double RightBeamTotalSectionCut

Remarks

See Also

BeamOnBeamConnection Class


WeldedOnBeamLeft Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.WeldedOnBeamLeft Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the connection between Left beam and cleat(s) is welded, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WeldedOnBeamLeft
Visual Basic (Declaration)
Public WeldedOnBeamLeft As Boolean
Visual C++
public:
bool WeldedOnBeamLeft

Remarks

See Also

BeamOnBeamConnection Class


WeldedOnBeamRight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.WeldedOnBeamRight Field
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the connection between right beam and cleat(s) is welded, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WeldedOnBeamRight
Visual Basic (Declaration)
Public WeldedOnBeamRight As Boolean
Visual C++
public:
bool WeldedOnBeamRight

Remarks

See Also

BeamOnBeamConnection Class


BeamOnBeamConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection Methods
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamConnection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamOnBeamConnection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.Calculate Method
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamOnBeamConnection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnection..::.GetInputWarnings Method
BeamOnBeamConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamOnBeamConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamOnBeamConnectionInputWarnings
Visual C++
public:
BeamOnBeamConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamOnBeamConnection Class


BeamOnBeamConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamOnBeamConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamOnBeamConnectionInputWarnings
Visual C++
public ref class BeamOnBeamConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamOnBeamConnectionInputWarnings

See Also

BeamOnBeamConnectionInputWarnings Members


BeamOnBeamConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings Members
BeamOnBeamConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamOnBeamConnectionInputWarnings | Initializes a new instance of the BeamOnBeamConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
LeftPlateOnBeam | Input warnings regarding the left plate on beam
LeftPlateOnMainBeam | Input warnings regarding the left plate on main beam
Other | Input warnings regarding other connection parts
RightPlateOnBeam | Input warnings regarding the right plate on beam
RightPlateOnMainBeam | Input warnings regarding the right plate on main beam
Welds | Input warnings regarding welds

See Also

BeamOnBeamConnectionInputWarnings Class


BeamOnBeamConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings Constructor
BeamOnBeamConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamOnBeamConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamOnBeamConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamOnBeamConnectionInputWarnings()

See Also

BeamOnBeamConnectionInputWarnings Class


BeamOnBeamConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings Fields
BeamOnBeamConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamConnectionInputWarnings type exposes the following members.

Fields

Name | Description
LeftPlateOnBeam | Input warnings regarding the left plate on beam
LeftPlateOnMainBeam | Input warnings regarding the left plate on main beam
Other | Input warnings regarding other connection parts
RightPlateOnBeam | Input warnings regarding the right plate on beam
RightPlateOnMainBeam | Input warnings regarding the right plate on main beam
Welds | Input warnings regarding welds

See Also

BeamOnBeamConnectionInputWarnings Class


LeftPlateOnBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings..::.LeftPlateOnBeam Field
BeamOnBeamConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the left plate on beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> LeftPlateOnBeam
Visual Basic (Declaration)
Public LeftPlateOnBeam As List(Of String)
Visual C++
public:
List<String^>^ LeftPlateOnBeam

Remarks

See Also

BeamOnBeamConnectionInputWarnings Class


LeftPlateOnMainBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings..::.LeftPlateOnMainBeam Field
BeamOnBeamConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the left plate on main beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> LeftPlateOnMainBeam
Visual Basic (Declaration)
Public LeftPlateOnMainBeam As List(Of String)
Visual C++
public:
List<String^>^ LeftPlateOnMainBeam

Remarks

See Also

BeamOnBeamConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings..::.Other Field
BeamOnBeamConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamOnBeamConnectionInputWarnings Class


RightPlateOnBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings..::.RightPlateOnBeam Field
BeamOnBeamConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the right plate on beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> RightPlateOnBeam
Visual Basic (Declaration)
Public RightPlateOnBeam As List(Of String)
Visual C++
public:
List<String^>^ RightPlateOnBeam

Remarks

See Also

BeamOnBeamConnectionInputWarnings Class


RightPlateOnMainBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings..::.RightPlateOnMainBeam Field
BeamOnBeamConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the right plate on main beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> RightPlateOnMainBeam
Visual Basic (Declaration)
Public RightPlateOnMainBeam As List(Of String)
Visual C++
public:
List<String^>^ RightPlateOnMainBeam

Remarks

See Also

BeamOnBeamConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings..::.Welds Field
BeamOnBeamConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamOnBeamConnectionInputWarnings Class


BeamOnBeamConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionInputWarnings Methods
BeamOnBeamConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamOnBeamConnectionInputWarnings Class


BeamOnBeamConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamOnBeamConnectionResults
Visual Basic (Declaration)
Public Class BeamOnBeamConnectionResults
Visual C++
public ref class BeamOnBeamConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamOnBeamConnectionResults

See Also

BeamOnBeamConnectionResults Members


BeamOnBeamConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults Members
BeamOnBeamConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamConnectionResults type exposes the following members.

Constructors

Name | Description
BeamOnBeamConnectionResults | Initializes a new instance of the BeamOnBeamConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BeamLeftBoltsBearingCapacity | Left connection beam bolts bearing capacity, if not Left welded connection
BeamLeftBoltsBearingResistance | Left connection beam bolts bearing resistance, if not Left welded connection
BeamLeftMostStressesBoltShearCapacity | Shear capacity of the most stressed bolt on the Left beam, if not Left welded connection
BeamLeftMostStressesBoltShearResistance | Shear resistance of the most stressed bolt on the Left beam, if not Left welded connection
BeamLeftPlateTearBlockingCapacity | Left connection beam pleta tear blocking capacity, if not Left welded connection
BeamLeftPlateTearBlockingResistance | Left connection beam plate tear blocking resistance, if not Left welded connection
BeamLeftTearBlockingCapacity | Left connection beam web tear blocking capacity, if not Left welded connection
BeamLeftTearBlockingResistance | Left connection beam web tear blocking resistance, if not Left welded connection
BeamRightBoltsBearingCapacity | Right connection beam bolts bearing capacity, if not right welded connection
BeamRightBoltsBearingResistance | Right connection beam bolts bearing resistance, if not right welded connection
BeamRightMostStressesBoltShearCapacity | Shear capacity of the most stressed bolt on the right beam, if not right welded connection
BeamRightMostStressesBoltShearResistance | Shear resistance of the most stressed bolt on the right beam, if not right welded connection
BeamRightPlateTearBlockingCapacity | Right connection beam pleta tear blocking capacity, if not right welded connection
BeamRightPlateTearBlockingResistance | Right connection beam plate tear blocking resistance, if not right welded connection
BeamRightTearBlockingCapacity | Right connection beam web tear blocking capacity, if not right welded connection
BeamRightTearBlockingResistance | Right connection beam web tear blocking resistance, if not right welded connection
LeftPlateOnMainBeamTearBlockingCapacity | Left connection MainBeam plate tear blocking capacity
LeftPlateOnMainBeamTearBlockingResistance | Left connection MainBeam plate tear blocking resistance
MainBeamBoltsBearingCapacity | Bolts bearing capacity of main beam
MainBeamBoltsBearingResistance | Bolts bearing resistance of main beam
MainBeamBoltsLeftShearCapacity | Left connection MainBeam bolts shear capacity
MainBeamBoltsLeftShearResistance | Left connection MainBeam bolts shear resistance
MainBeamBoltsRightShearCapacity | Right connection MainBeam bolts shear capacity
MainBeamBoltsRightShearResistance | Right connection MainBeam bolts shear resistance
MomentAngleLeftCapacity | Left cleat moment capacity
MomentAngleLeftResistance | Left cleat moment resistance
MomentAngleRightCapacity | Right cleat moment capacity
MomentAngleRightResistance | Right cleat moment resistance
RightPlateOnMainBeamTearBlockingCapacity | Right connection MainBeam plate tear blocking capacity
RightPlateOnMainBeamTearBlockingResistance | Right connection MainBeam plate tear blocking resistance
ShearAngleLeftCapacity | Left cleat shear capacity
ShearAngleLeftResistance | Left cleat shear resistance
ShearAngleRightCapacity | Right cleat shear capacity
ShearAngleRightResistance | Right cleat shear resistance
WeldLeftCapacity | Left connection between beam web and clear weld capacity, if welded Left connection
WeldLeftResistance | Left connection between beam web and clear weld resistance, if welded Left connection
WeldRightCapacity | Right connection between beam web and clear weld capacity, if welded right connection
WeldRightResistance | Right connection between beam web and clear weld resistance, if welded right connection

See Also

BeamOnBeamConnectionResults Class


BeamOnBeamConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults Constructor
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamOnBeamConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamOnBeamConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamOnBeamConnectionResults()

See Also

BeamOnBeamConnectionResults Class


BeamOnBeamConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults Fields
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamConnectionResults type exposes the following members.

Fields

Name | Description
BeamLeftBoltsBearingCapacity | Left connection beam bolts bearing capacity, if not Left welded connection
BeamLeftBoltsBearingResistance | Left connection beam bolts bearing resistance, if not Left welded connection
BeamLeftMostStressesBoltShearCapacity | Shear capacity of the most stressed bolt on the Left beam, if not Left welded connection
BeamLeftMostStressesBoltShearResistance | Shear resistance of the most stressed bolt on the Left beam, if not Left welded connection
BeamLeftPlateTearBlockingCapacity | Left connection beam pleta tear blocking capacity, if not Left welded connection
BeamLeftPlateTearBlockingResistance | Left connection beam plate tear blocking resistance, if not Left welded connection
BeamLeftTearBlockingCapacity | Left connection beam web tear blocking capacity, if not Left welded connection
BeamLeftTearBlockingResistance | Left connection beam web tear blocking resistance, if not Left welded connection
BeamRightBoltsBearingCapacity | Right connection beam bolts bearing capacity, if not right welded connection
BeamRightBoltsBearingResistance | Right connection beam bolts bearing resistance, if not right welded connection
BeamRightMostStressesBoltShearCapacity | Shear capacity of the most stressed bolt on the right beam, if not right welded connection
BeamRightMostStressesBoltShearResistance | Shear resistance of the most stressed bolt on the right beam, if not right welded connection
BeamRightPlateTearBlockingCapacity | Right connection beam pleta tear blocking capacity, if not right welded connection
BeamRightPlateTearBlockingResistance | Right connection beam plate tear blocking resistance, if not right welded connection
BeamRightTearBlockingCapacity | Right connection beam web tear blocking capacity, if not right welded connection
BeamRightTearBlockingResistance | Right connection beam web tear blocking resistance, if not right welded connection
LeftPlateOnMainBeamTearBlockingCapacity | Left connection MainBeam plate tear blocking capacity
LeftPlateOnMainBeamTearBlockingResistance | Left connection MainBeam plate tear blocking resistance
MainBeamBoltsBearingCapacity | Bolts bearing capacity of main beam
MainBeamBoltsBearingResistance | Bolts bearing resistance of main beam
MainBeamBoltsLeftShearCapacity | Left connection MainBeam bolts shear capacity
MainBeamBoltsLeftShearResistance | Left connection MainBeam bolts shear resistance
MainBeamBoltsRightShearCapacity | Right connection MainBeam bolts shear capacity
MainBeamBoltsRightShearResistance | Right connection MainBeam bolts shear resistance
MomentAngleLeftCapacity | Left cleat moment capacity
MomentAngleLeftResistance | Left cleat moment resistance
MomentAngleRightCapacity | Right cleat moment capacity
MomentAngleRightResistance | Right cleat moment resistance
RightPlateOnMainBeamTearBlockingCapacity | Right connection MainBeam plate tear blocking capacity
RightPlateOnMainBeamTearBlockingResistance | Right connection MainBeam plate tear blocking resistance
ShearAngleLeftCapacity | Left cleat shear capacity
ShearAngleLeftResistance | Left cleat shear resistance
ShearAngleRightCapacity | Right cleat shear capacity
ShearAngleRightResistance | Right cleat shear resistance
WeldLeftCapacity | Left connection between beam web and clear weld capacity, if welded Left connection
WeldLeftResistance | Left connection between beam web and clear weld resistance, if welded Left connection
WeldRightCapacity | Right connection between beam web and clear weld capacity, if welded right connection
WeldRightResistance | Right connection between beam web and clear weld resistance, if welded right connection

See Also

BeamOnBeamConnectionResults Class


BeamLeftBoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamLeftBoltsBearingCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam bolts bearing capacity, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftBoltsBearingCapacity
Visual Basic (Declaration)
Public BeamLeftBoltsBearingCapacity As Double
Visual C++
public:
double BeamLeftBoltsBearingCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamLeftBoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamLeftBoltsBearingResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam bolts bearing resistance, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftBoltsBearingResistance
Visual Basic (Declaration)
Public BeamLeftBoltsBearingResistance As Double
Visual C++
public:
double BeamLeftBoltsBearingResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamLeftMostStressesBoltShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamLeftMostStressesBoltShearCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear capacity of the most stressed bolt on the Left beam, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftMostStressesBoltShearCapacity
Visual Basic (Declaration)
Public BeamLeftMostStressesBoltShearCapacity As Double
Visual C++
public:
double BeamLeftMostStressesBoltShearCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamLeftMostStressesBoltShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamLeftMostStressesBoltShearResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the most stressed bolt on the Left beam, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftMostStressesBoltShearResistance
Visual Basic (Declaration)
Public BeamLeftMostStressesBoltShearResistance As Double
Visual C++
public:
double BeamLeftMostStressesBoltShearResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamLeftPlateTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamLeftPlateTearBlockingCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam pleta tear blocking capacity, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftPlateTearBlockingCapacity
Visual Basic (Declaration)
Public BeamLeftPlateTearBlockingCapacity As Double
Visual C++
public:
double BeamLeftPlateTearBlockingCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamLeftPlateTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamLeftPlateTearBlockingResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam plate tear blocking resistance, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftPlateTearBlockingResistance
Visual Basic (Declaration)
Public BeamLeftPlateTearBlockingResistance As Double
Visual C++
public:
double BeamLeftPlateTearBlockingResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamLeftTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamLeftTearBlockingCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam web tear blocking capacity, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftTearBlockingCapacity
Visual Basic (Declaration)
Public BeamLeftTearBlockingCapacity As Double
Visual C++
public:
double BeamLeftTearBlockingCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamLeftTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamLeftTearBlockingResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection beam web tear blocking resistance, if not Left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamLeftTearBlockingResistance
Visual Basic (Declaration)
Public BeamLeftTearBlockingResistance As Double
Visual C++
public:
double BeamLeftTearBlockingResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamRightBoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamRightBoltsBearingCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam bolts bearing capacity, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightBoltsBearingCapacity
Visual Basic (Declaration)
Public BeamRightBoltsBearingCapacity As Double
Visual C++
public:
double BeamRightBoltsBearingCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamRightBoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamRightBoltsBearingResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam bolts bearing resistance, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightBoltsBearingResistance
Visual Basic (Declaration)
Public BeamRightBoltsBearingResistance As Double
Visual C++
public:
double BeamRightBoltsBearingResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamRightMostStressesBoltShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamRightMostStressesBoltShearCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear capacity of the most stressed bolt on the right beam, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightMostStressesBoltShearCapacity
Visual Basic (Declaration)
Public BeamRightMostStressesBoltShearCapacity As Double
Visual C++
public:
double BeamRightMostStressesBoltShearCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamRightMostStressesBoltShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamRightMostStressesBoltShearResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the most stressed bolt on the right beam, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightMostStressesBoltShearResistance
Visual Basic (Declaration)
Public BeamRightMostStressesBoltShearResistance As Double
Visual C++
public:
double BeamRightMostStressesBoltShearResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamRightPlateTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamRightPlateTearBlockingCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam pleta tear blocking capacity, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightPlateTearBlockingCapacity
Visual Basic (Declaration)
Public BeamRightPlateTearBlockingCapacity As Double
Visual C++
public:
double BeamRightPlateTearBlockingCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamRightPlateTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamRightPlateTearBlockingResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam plate tear blocking resistance, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightPlateTearBlockingResistance
Visual Basic (Declaration)
Public BeamRightPlateTearBlockingResistance As Double
Visual C++
public:
double BeamRightPlateTearBlockingResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamRightTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamRightTearBlockingCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam web tear blocking capacity, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightTearBlockingCapacity
Visual Basic (Declaration)
Public BeamRightTearBlockingCapacity As Double
Visual C++
public:
double BeamRightTearBlockingCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamRightTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.BeamRightTearBlockingResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection beam web tear blocking resistance, if not right welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamRightTearBlockingResistance
Visual Basic (Declaration)
Public BeamRightTearBlockingResistance As Double
Visual C++
public:
double BeamRightTearBlockingResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


LeftPlateOnMainBeamTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.LeftPlateOnMainBeamTearBlockingCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection MainBeam plate tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double LeftPlateOnMainBeamTearBlockingCapacity
Visual Basic (Declaration)
Public LeftPlateOnMainBeamTearBlockingCapacity As Double
Visual C++
public:
double LeftPlateOnMainBeamTearBlockingCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


LeftPlateOnMainBeamTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.LeftPlateOnMainBeamTearBlockingResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection MainBeam plate tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double LeftPlateOnMainBeamTearBlockingResistance
Visual Basic (Declaration)
Public LeftPlateOnMainBeamTearBlockingResistance As Double
Visual C++
public:
double LeftPlateOnMainBeamTearBlockingResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


MainBeamBoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MainBeamBoltsBearingCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity of main beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MainBeamBoltsBearingCapacity
Visual Basic (Declaration)
Public MainBeamBoltsBearingCapacity As Double
Visual C++
public:
double MainBeamBoltsBearingCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


MainBeamBoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MainBeamBoltsBearingResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance of main beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MainBeamBoltsBearingResistance
Visual Basic (Declaration)
Public MainBeamBoltsBearingResistance As Double
Visual C++
public:
double MainBeamBoltsBearingResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


MainBeamBoltsLeftShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MainBeamBoltsLeftShearCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection MainBeam bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MainBeamBoltsLeftShearCapacity
Visual Basic (Declaration)
Public MainBeamBoltsLeftShearCapacity As Double
Visual C++
public:
double MainBeamBoltsLeftShearCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


MainBeamBoltsLeftShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MainBeamBoltsLeftShearResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection MainBeam bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MainBeamBoltsLeftShearResistance
Visual Basic (Declaration)
Public MainBeamBoltsLeftShearResistance As Double
Visual C++
public:
double MainBeamBoltsLeftShearResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


MainBeamBoltsRightShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MainBeamBoltsRightShearCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection MainBeam bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MainBeamBoltsRightShearCapacity
Visual Basic (Declaration)
Public MainBeamBoltsRightShearCapacity As Double
Visual C++
public:
double MainBeamBoltsRightShearCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


MainBeamBoltsRightShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MainBeamBoltsRightShearResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection MainBeam bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MainBeamBoltsRightShearResistance
Visual Basic (Declaration)
Public MainBeamBoltsRightShearResistance As Double
Visual C++
public:
double MainBeamBoltsRightShearResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


MomentAngleLeftCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MomentAngleLeftCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left cleat moment capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentAngleLeftCapacity
Visual Basic (Declaration)
Public MomentAngleLeftCapacity As Double
Visual C++
public:
double MomentAngleLeftCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


MomentAngleLeftResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MomentAngleLeftResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left cleat moment resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentAngleLeftResistance
Visual Basic (Declaration)
Public MomentAngleLeftResistance As Double
Visual C++
public:
double MomentAngleLeftResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


MomentAngleRightCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MomentAngleRightCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right cleat moment capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentAngleRightCapacity
Visual Basic (Declaration)
Public MomentAngleRightCapacity As Double
Visual C++
public:
double MomentAngleRightCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


MomentAngleRightResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.MomentAngleRightResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right cleat moment resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentAngleRightResistance
Visual Basic (Declaration)
Public MomentAngleRightResistance As Double
Visual C++
public:
double MomentAngleRightResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


RightPlateOnMainBeamTearBlockingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.RightPlateOnMainBeamTearBlockingCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection MainBeam plate tear blocking capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RightPlateOnMainBeamTearBlockingCapacity
Visual Basic (Declaration)
Public RightPlateOnMainBeamTearBlockingCapacity As Double
Visual C++
public:
double RightPlateOnMainBeamTearBlockingCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


RightPlateOnMainBeamTearBlockingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.RightPlateOnMainBeamTearBlockingResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection MainBeam plate tear blocking resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RightPlateOnMainBeamTearBlockingResistance
Visual Basic (Declaration)
Public RightPlateOnMainBeamTearBlockingResistance As Double
Visual C++
public:
double RightPlateOnMainBeamTearBlockingResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


ShearAngleLeftCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.ShearAngleLeftCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left cleat shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearAngleLeftCapacity
Visual Basic (Declaration)
Public ShearAngleLeftCapacity As Double
Visual C++
public:
double ShearAngleLeftCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


ShearAngleLeftResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.ShearAngleLeftResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left cleat shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearAngleLeftResistance
Visual Basic (Declaration)
Public ShearAngleLeftResistance As Double
Visual C++
public:
double ShearAngleLeftResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


ShearAngleRightCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.ShearAngleRightCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right cleat shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearAngleRightCapacity
Visual Basic (Declaration)
Public ShearAngleRightCapacity As Double
Visual C++
public:
double ShearAngleRightCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


ShearAngleRightResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.ShearAngleRightResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right cleat shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearAngleRightResistance
Visual Basic (Declaration)
Public ShearAngleRightResistance As Double
Visual C++
public:
double ShearAngleRightResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


WeldLeftCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.WeldLeftCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection between beam web and clear weld capacity, if welded Left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldLeftCapacity
Visual Basic (Declaration)
Public WeldLeftCapacity As Double
Visual C++
public:
double WeldLeftCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


WeldLeftResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.WeldLeftResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Left connection between beam web and clear weld resistance, if welded Left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldLeftResistance
Visual Basic (Declaration)
Public WeldLeftResistance As Double
Visual C++
public:
double WeldLeftResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


WeldRightCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.WeldRightCapacity Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection between beam web and clear weld capacity, if welded right connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldRightCapacity
Visual Basic (Declaration)
Public WeldRightCapacity As Double
Visual C++
public:
double WeldRightCapacity

Remarks

See Also

BeamOnBeamConnectionResults Class


WeldRightResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults..::.WeldRightResistance Field
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Right connection between beam web and clear weld resistance, if welded right connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldRightResistance
Visual Basic (Declaration)
Public WeldRightResistance As Double
Visual C++
public:
double WeldRightResistance

Remarks

See Also

BeamOnBeamConnectionResults Class


BeamOnBeamConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamConnectionResults Methods
BeamOnBeamConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamOnBeamConnectionResults Class


BeamOnBeamTeeConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam to beam connection by means of a Tee member and an endplate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamOnBeamTeeConnection
Visual Basic (Declaration)
Public Class BeamOnBeamTeeConnection
Visual C++
public ref class BeamOnBeamTeeConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamOnBeamTeeConnection

See Also

BeamOnBeamTeeConnection Members


BeamOnBeamTeeConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection Members
BeamOnBeamTeeConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamTeeConnection type exposes the following members.

Constructors

Name | Description
BeamOnBeamTeeConnection | Initializes a new instance of the BeamOnBeamTeeConnection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
aFlangeSecBeam | Weld thickness between secondary beam flange and endplate
aFlangesMainBeam | Weld thickness between main beam flanges and Tee flange
aWebMainBeam | Weld thickness between main beam web and Tee web
aWebSecBeam | Weld thickness between secondary beam web and endplate
LoadCases | Load cases of secondary beam
MainBeam | Main beam object
Plate | Endplate object
Results | List of results
SecBeam | Secondary beam object
Tee | Tee object
TeeSteel | Tee steel grade

See Also

BeamOnBeamTeeConnection Class


BeamOnBeamTeeConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection Constructor
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamOnBeamTeeConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamOnBeamTeeConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamOnBeamTeeConnection()

See Also

BeamOnBeamTeeConnection Class


BeamOnBeamTeeConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection Fields
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamTeeConnection type exposes the following members.

Fields

Name | Description
aFlangeSecBeam | Weld thickness between secondary beam flange and endplate
aFlangesMainBeam | Weld thickness between main beam flanges and Tee flange
aWebMainBeam | Weld thickness between main beam web and Tee web
aWebSecBeam | Weld thickness between secondary beam web and endplate
LoadCases | Load cases of secondary beam
MainBeam | Main beam object
Plate | Endplate object
Results | List of results
SecBeam | Secondary beam object
Tee | Tee object
TeeSteel | Tee steel grade

See Also

BeamOnBeamTeeConnection Class


aFlangeSecBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.aFlangeSecBeam Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between secondary beam flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aFlangeSecBeam
Visual Basic (Declaration)
Public aFlangeSecBeam As Double
Visual C++
public:
double aFlangeSecBeam

Remarks

See Also

BeamOnBeamTeeConnection Class


aFlangesMainBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.aFlangesMainBeam Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between main beam flanges and Tee flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aFlangesMainBeam
Visual Basic (Declaration)
Public aFlangesMainBeam As Double
Visual C++
public:
double aFlangesMainBeam

Remarks

See Also

BeamOnBeamTeeConnection Class


aWebMainBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.aWebMainBeam Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between main beam web and Tee web

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aWebMainBeam
Visual Basic (Declaration)
Public aWebMainBeam As Double
Visual C++
public:
double aWebMainBeam

Remarks

See Also

BeamOnBeamTeeConnection Class


aWebSecBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.aWebSecBeam Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between secondary beam web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aWebSecBeam
Visual Basic (Declaration)
Public aWebSecBeam As Double
Visual C++
public:
double aWebSecBeam

Remarks

See Also

BeamOnBeamTeeConnection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.LoadCases Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of secondary beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ved (positive=downwards)

See Also

BeamOnBeamTeeConnection Class


MainBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.MainBeam Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Main beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection MainBeam
Visual Basic (Declaration)
Public MainBeam As HSection
Visual C++
public:
HSection^ MainBeam

Remarks

See Also

BeamOnBeamTeeConnection Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.Plate Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Endplate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BoltedEndPlate Plate
Visual Basic (Declaration)
Public Plate As BoltedEndPlate
Visual C++
public:
BoltedEndPlate^ Plate

Remarks

See Also

BeamOnBeamTeeConnection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.Results Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamOnBeamTeeConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamOnBeamTeeConnectionResults)
Visual C++
public:
List<BeamOnBeamTeeConnectionResults^>^ Results

Remarks

See Also

BeamOnBeamTeeConnection Class


SecBeam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.SecBeam Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Secondary beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection SecBeam
Visual Basic (Declaration)
Public SecBeam As HSection
Visual C++
public:
HSection^ SecBeam

Remarks

See Also

BeamOnBeamTeeConnection Class


Tee Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.Tee Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Tee object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TSection Tee
Visual Basic (Declaration)
Public Tee As TSection
Visual C++
public:
TSection^ Tee

Remarks

See Also

BeamOnBeamTeeConnection Class


TeeSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.TeeSteel Field
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Tee steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade TeeSteel
Visual Basic (Declaration)
Public TeeSteel As SteelGrade
Visual C++
public:
SteelGrade^ TeeSteel

Remarks

See Also

BeamOnBeamTeeConnection Class


BeamOnBeamTeeConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection Methods
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamTeeConnection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamOnBeamTeeConnection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.Calculate Method
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamOnBeamTeeConnection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnection..::.GetInputWarnings Method
BeamOnBeamTeeConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamOnBeamTeeConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamOnBeamTeeConnectionInputWarnings
Visual C++
public:
BeamOnBeamTeeConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamOnBeamTeeConnection Class


BeamOnBeamTeeConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamOnBeamTeeConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamOnBeamTeeConnectionInputWarnings
Visual C++
public ref class BeamOnBeamTeeConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamOnBeamTeeConnectionInputWarnings

See Also

BeamOnBeamTeeConnectionInputWarnings Members


BeamOnBeamTeeConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionInputWarnings Members
BeamOnBeamTeeConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamTeeConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamOnBeamTeeConnectionInputWarnings | Initializes a new instance of the BeamOnBeamTeeConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamOnBeamTeeConnectionInputWarnings Class


BeamOnBeamTeeConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionInputWarnings Constructor
BeamOnBeamTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamOnBeamTeeConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamOnBeamTeeConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamOnBeamTeeConnectionInputWarnings()

See Also

BeamOnBeamTeeConnectionInputWarnings Class


BeamOnBeamTeeConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionInputWarnings Fields
BeamOnBeamTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamTeeConnectionInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

BeamOnBeamTeeConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionInputWarnings..::.Other Field
BeamOnBeamTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamOnBeamTeeConnectionInputWarnings Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionInputWarnings..::.Plate Field
BeamOnBeamTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Plate
Visual Basic (Declaration)
Public Plate As List(Of String)
Visual C++
public:
List<String^>^ Plate

Remarks

See Also

BeamOnBeamTeeConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionInputWarnings..::.Welds Field
BeamOnBeamTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamOnBeamTeeConnectionInputWarnings Class


BeamOnBeamTeeConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionInputWarnings Methods
BeamOnBeamTeeConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamTeeConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamOnBeamTeeConnectionInputWarnings Class


BeamOnBeamTeeConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamOnBeamTeeConnectionResults
Visual Basic (Declaration)
Public Class BeamOnBeamTeeConnectionResults
Visual C++
public ref class BeamOnBeamTeeConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamOnBeamTeeConnectionResults

See Also

BeamOnBeamTeeConnectionResults Members


BeamOnBeamTeeConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults Members
BeamOnBeamTeeConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamTeeConnectionResults type exposes the following members.

Constructors

Name | Description
BeamOnBeamTeeConnectionResults | Initializes a new instance of the BeamOnBeamTeeConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts bearing capacity
BoltsShearResistance | Bolts shear resistance
MainBeamWeldCapacity | Weld capacity between main beam and Tee
MainBeamWeldResistance | Weld resistance between main beam and Tee
SecBeamWeldCapacity | Weld capacity between secondary beam and endplate
SecBeamWeldResistance | Weld resistance between secondary beam and endplate

See Also

BeamOnBeamTeeConnectionResults Class


BeamOnBeamTeeConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults Constructor
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamOnBeamTeeConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamOnBeamTeeConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamOnBeamTeeConnectionResults()

See Also

BeamOnBeamTeeConnectionResults Class


BeamOnBeamTeeConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults Fields
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamTeeConnectionResults type exposes the following members.

Fields

Name | Description
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts bearing capacity
BoltsShearResistance | Bolts shear resistance
MainBeamWeldCapacity | Weld capacity between main beam and Tee
MainBeamWeldResistance | Weld resistance between main beam and Tee
SecBeamWeldCapacity | Weld capacity between secondary beam and endplate
SecBeamWeldResistance | Weld resistance between secondary beam and endplate

See Also

BeamOnBeamTeeConnectionResults Class


BoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults..::.BoltsBearingCapacity Field
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingCapacity
Visual Basic (Declaration)
Public BoltsBearingCapacity As Double
Visual C++
public:
double BoltsBearingCapacity

Remarks

See Also

BeamOnBeamTeeConnectionResults Class


BoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults..::.BoltsBearingResistance Field
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingResistance
Visual Basic (Declaration)
Public BoltsBearingResistance As Double
Visual C++
public:
double BoltsBearingResistance

Remarks

See Also

BeamOnBeamTeeConnectionResults Class


BoltsShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults..::.BoltsShearCapacity Field
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearCapacity
Visual Basic (Declaration)
Public BoltsShearCapacity As Double
Visual C++
public:
double BoltsShearCapacity

Remarks

See Also

BeamOnBeamTeeConnectionResults Class


BoltsShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults..::.BoltsShearResistance Field
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearResistance
Visual Basic (Declaration)
Public BoltsShearResistance As Double
Visual C++
public:
double BoltsShearResistance

Remarks

See Also

BeamOnBeamTeeConnectionResults Class


MainBeamWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults..::.MainBeamWeldCapacity Field
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity between main beam and Tee

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MainBeamWeldCapacity
Visual Basic (Declaration)
Public MainBeamWeldCapacity As Double
Visual C++
public:
double MainBeamWeldCapacity

Remarks

See Also

BeamOnBeamTeeConnectionResults Class


MainBeamWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults..::.MainBeamWeldResistance Field
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance between main beam and Tee

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MainBeamWeldResistance
Visual Basic (Declaration)
Public MainBeamWeldResistance As Double
Visual C++
public:
double MainBeamWeldResistance

Remarks

See Also

BeamOnBeamTeeConnectionResults Class


SecBeamWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults..::.SecBeamWeldCapacity Field
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity between secondary beam and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double SecBeamWeldCapacity
Visual Basic (Declaration)
Public SecBeamWeldCapacity As Double
Visual C++
public:
double SecBeamWeldCapacity

Remarks

See Also

BeamOnBeamTeeConnectionResults Class


SecBeamWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults..::.SecBeamWeldResistance Field
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance between secondary beam and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double SecBeamWeldResistance
Visual Basic (Declaration)
Public SecBeamWeldResistance As Double
Visual C++
public:
double SecBeamWeldResistance

Remarks

See Also

BeamOnBeamTeeConnectionResults Class


BeamOnBeamTeeConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamOnBeamTeeConnectionResults Methods
BeamOnBeamTeeConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamOnBeamTeeConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamOnBeamTeeConnectionResults Class


BeamSplices1Connection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam splice connection between 2 H section members by means of web and flange plates

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplices1Connection
Visual Basic (Declaration)
Public Class BeamSplices1Connection
Visual C++
public ref class BeamSplices1Connection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplices1Connection

See Also

BeamSplices1Connection Members


BeamSplices1Connection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection Members
BeamSplices1Connection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices1Connection type exposes the following members.

Constructors

Name | Description
BeamSplices1Connection | Initializes a new instance of the BeamSplices1Connection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
afl | Weld thickness between flange plate and beam flange, in case of left welded connection
aw | Weld thickness between web plate and beam web, in case of left welded connection
Beam | Beam object
BeamSteel | Beam steel grade
FlangeHalfPlate | Flange half plate object
gap | Gap between connected members
LoadCases | Load cases of the beam
Results | List of results
WebHalfPlate | Web half plate object
WeldedLeftConnection | True, if left connection is welded, otherwise false

See Also

BeamSplices1Connection Class


BeamSplices1Connection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection Constructor
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplices1Connection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplices1Connection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplices1Connection()

See Also

BeamSplices1Connection Class


BeamSplices1Connection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection Fields
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices1Connection type exposes the following members.

Fields

Name | Description
afl | Weld thickness between flange plate and beam flange, in case of left welded connection
aw | Weld thickness between web plate and beam web, in case of left welded connection
Beam | Beam object
BeamSteel | Beam steel grade
FlangeHalfPlate | Flange half plate object
gap | Gap between connected members
LoadCases | Load cases of the beam
Results | List of results
WebHalfPlate | Web half plate object
WeldedLeftConnection | True, if left connection is welded, otherwise false

See Also

BeamSplices1Connection Class


afl Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.afl Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between flange plate and beam flange, in case of left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double afl
Visual Basic (Declaration)
Public afl As Double
Visual C++
public:
double afl

Remarks

See Also

BeamSplices1Connection Class


aw Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.aw Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between web plate and beam web, in case of left welded connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aw
Visual Basic (Declaration)
Public aw As Double
Visual C++
public:
double aw

Remarks

See Also

BeamSplices1Connection Class


Beam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.Beam Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Beam
Visual Basic (Declaration)
Public Beam As HSection
Visual C++
public:
HSection^ Beam

Remarks

See Also

BeamSplices1Connection Class


BeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.BeamSteel Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade BeamSteel
Visual Basic (Declaration)
Public BeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ BeamSteel

Remarks

See Also

BeamSplices1Connection Class


FlangeHalfPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.FlangeHalfPlate Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange half plate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate FlangeHalfPlate
Visual Basic (Declaration)
Public FlangeHalfPlate As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ FlangeHalfPlate

Remarks

See Also

BeamSplices1Connection Class


gap Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.gap Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Gap between connected members

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double gap
Visual Basic (Declaration)
Public gap As Double
Visual C++
public:
double gap

Remarks

See Also

BeamSplices1Connection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.LoadCases Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ned (positive=tensile)

Ved (positive=rotates the joint counterclockwise)

Med (positive=lower beam flange is under tension)

See Also

BeamSplices1Connection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.Results Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamSplices1ConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamSplices1ConnectionResults)
Visual C++
public:
List<BeamSplices1ConnectionResults^>^ Results

Remarks

See Also

BeamSplices1Connection Class


WebHalfPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.WebHalfPlate Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Web half plate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate WebHalfPlate
Visual Basic (Declaration)
Public WebHalfPlate As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ WebHalfPlate

Remarks

See Also

BeamSplices1Connection Class


WeldedLeftConnection Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.WeldedLeftConnection Field
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if left connection is welded, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WeldedLeftConnection
Visual Basic (Declaration)
Public WeldedLeftConnection As Boolean
Visual C++
public:
bool WeldedLeftConnection

Remarks

See Also

BeamSplices1Connection Class


BeamSplices1Connection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection Methods
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices1Connection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplices1Connection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.Calculate Method
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamSplices1Connection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1Connection..::.GetInputWarnings Method
BeamSplices1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplices1ConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamSplices1ConnectionInputWarnings
Visual C++
public:
BeamSplices1ConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamSplices1Connection Class


BeamSplices1ConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplices1ConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamSplices1ConnectionInputWarnings
Visual C++
public ref class BeamSplices1ConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplices1ConnectionInputWarnings

See Also

BeamSplices1ConnectionInputWarnings Members


BeamSplices1ConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionInputWarnings Members
BeamSplices1ConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices1ConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamSplices1ConnectionInputWarnings | Initializes a new instance of the BeamSplices1ConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FlangePlate | Input warnings regarding the bolted flange plate
Other | Input warnings regarding other connection parts
WebPlate | Input warnings regarding the bolted web plate
Welds | Input warnings regarding welds

See Also

BeamSplices1ConnectionInputWarnings Class


BeamSplices1ConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionInputWarnings Constructor
BeamSplices1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplices1ConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplices1ConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplices1ConnectionInputWarnings()

See Also

BeamSplices1ConnectionInputWarnings Class


BeamSplices1ConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionInputWarnings Fields
BeamSplices1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices1ConnectionInputWarnings type exposes the following members.

Fields

Name | Description
FlangePlate | Input warnings regarding the bolted flange plate
Other | Input warnings regarding other connection parts
WebPlate | Input warnings regarding the bolted web plate
Welds | Input warnings regarding welds

See Also

BeamSplices1ConnectionInputWarnings Class


FlangePlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionInputWarnings..::.FlangePlate Field
BeamSplices1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted flange plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> FlangePlate
Visual Basic (Declaration)
Public FlangePlate As List(Of String)
Visual C++
public:
List<String^>^ FlangePlate

Remarks

See Also

BeamSplices1ConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionInputWarnings..::.Other Field
BeamSplices1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamSplices1ConnectionInputWarnings Class


WebPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionInputWarnings..::.WebPlate Field
BeamSplices1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted web plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> WebPlate
Visual Basic (Declaration)
Public WebPlate As List(Of String)
Visual C++
public:
List<String^>^ WebPlate

Remarks

See Also

BeamSplices1ConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionInputWarnings..::.Welds Field
BeamSplices1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamSplices1ConnectionInputWarnings Class


BeamSplices1ConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionInputWarnings Methods
BeamSplices1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices1ConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplices1ConnectionInputWarnings Class


BeamSplices1ConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplices1ConnectionResults
Visual Basic (Declaration)
Public Class BeamSplices1ConnectionResults
Visual C++
public ref class BeamSplices1ConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplices1ConnectionResults

See Also

BeamSplices1ConnectionResults Members


BeamSplices1ConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults Members
BeamSplices1ConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices1ConnectionResults type exposes the following members.

Constructors

Name | Description
BeamSplices1ConnectionResults | Initializes a new instance of the BeamSplices1ConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FlangeBearingCapacity | Flange bolts bearing capacity
FlangeBearingResistance | Flange bolts bearing resistance
FlangeBoltsShearCapacity | Flange bolts shear capacity
FlangeBoltsShearResistance | Flange bolts shear resistance
FlangePlateAxialCapacity | Flange plate capacity in axial force
FlangePlateAxialResistance | Flange plate resistance in axial force
FlangeWeldCapacity | Flange welds capacity, in case of welded left connection
FlangeWeldResistance | Flange welds resistance, in case of welded left connection
MomentDesignCapacity | Moment capacity of the beam
MomentDesignResistance | Moment resistance of the beam
ShearDesignCapacity | Shear capacity of the beam
ShearDesignResistance | Shear resistance of the beam
WebBearingCapacity | Web bolts bearing capacity
WebBearingResistance | Web bolts bearing resistance
WebBoltsShearCapacity | Web bolts bearing capacity
WebBoltsShearResistance | Web bolts bearing resistance
WebPlateAxialCapacity | Web plate capacity in axial force
WebPlateAxialResistance | Web plate resistance in axial force
WebWeldCapacity | Web welds capacity, in case of welded left connection
WebWeldResistance | Web welds resistance, in case of welded left connection

See Also

BeamSplices1ConnectionResults Class


BeamSplices1ConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults Constructor
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplices1ConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplices1ConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplices1ConnectionResults()

See Also

BeamSplices1ConnectionResults Class


BeamSplices1ConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults Fields
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices1ConnectionResults type exposes the following members.

Fields

Name | Description
FlangeBearingCapacity | Flange bolts bearing capacity
FlangeBearingResistance | Flange bolts bearing resistance
FlangeBoltsShearCapacity | Flange bolts shear capacity
FlangeBoltsShearResistance | Flange bolts shear resistance
FlangePlateAxialCapacity | Flange plate capacity in axial force
FlangePlateAxialResistance | Flange plate resistance in axial force
FlangeWeldCapacity | Flange welds capacity, in case of welded left connection
FlangeWeldResistance | Flange welds resistance, in case of welded left connection
MomentDesignCapacity | Moment capacity of the beam
MomentDesignResistance | Moment resistance of the beam
ShearDesignCapacity | Shear capacity of the beam
ShearDesignResistance | Shear resistance of the beam
WebBearingCapacity | Web bolts bearing capacity
WebBearingResistance | Web bolts bearing resistance
WebBoltsShearCapacity | Web bolts bearing capacity
WebBoltsShearResistance | Web bolts bearing resistance
WebPlateAxialCapacity | Web plate capacity in axial force
WebPlateAxialResistance | Web plate resistance in axial force
WebWeldCapacity | Web welds capacity, in case of welded left connection
WebWeldResistance | Web welds resistance, in case of welded left connection

See Also

BeamSplices1ConnectionResults Class


FlangeBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.FlangeBearingCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangeBearingCapacity
Visual Basic (Declaration)
Public FlangeBearingCapacity As Double
Visual C++
public:
double FlangeBearingCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


FlangeBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.FlangeBearingResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangeBearingResistance
Visual Basic (Declaration)
Public FlangeBearingResistance As Double
Visual C++
public:
double FlangeBearingResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


FlangeBoltsShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.FlangeBoltsShearCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangeBoltsShearCapacity
Visual Basic (Declaration)
Public FlangeBoltsShearCapacity As Double
Visual C++
public:
double FlangeBoltsShearCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


FlangeBoltsShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.FlangeBoltsShearResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangeBoltsShearResistance
Visual Basic (Declaration)
Public FlangeBoltsShearResistance As Double
Visual C++
public:
double FlangeBoltsShearResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


FlangePlateAxialCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.FlangePlateAxialCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange plate capacity in axial force

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangePlateAxialCapacity
Visual Basic (Declaration)
Public FlangePlateAxialCapacity As Double
Visual C++
public:
double FlangePlateAxialCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


FlangePlateAxialResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.FlangePlateAxialResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange plate resistance in axial force

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangePlateAxialResistance
Visual Basic (Declaration)
Public FlangePlateAxialResistance As Double
Visual C++
public:
double FlangePlateAxialResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


FlangeWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.FlangeWeldCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange welds capacity, in case of welded left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangeWeldCapacity
Visual Basic (Declaration)
Public FlangeWeldCapacity As Double
Visual C++
public:
double FlangeWeldCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


FlangeWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.FlangeWeldResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange welds resistance, in case of welded left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangeWeldResistance
Visual Basic (Declaration)
Public FlangeWeldResistance As Double
Visual C++
public:
double FlangeWeldResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


MomentDesignCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.MomentDesignCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment capacity of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentDesignCapacity
Visual Basic (Declaration)
Public MomentDesignCapacity As Double
Visual C++
public:
double MomentDesignCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


MomentDesignResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.MomentDesignResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment resistance of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentDesignResistance
Visual Basic (Declaration)
Public MomentDesignResistance As Double
Visual C++
public:
double MomentDesignResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


ShearDesignCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.ShearDesignCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear capacity of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearDesignCapacity
Visual Basic (Declaration)
Public ShearDesignCapacity As Double
Visual C++
public:
double ShearDesignCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


ShearDesignResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.ShearDesignResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearDesignResistance
Visual Basic (Declaration)
Public ShearDesignResistance As Double
Visual C++
public:
double ShearDesignResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


WebBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.WebBearingCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebBearingCapacity
Visual Basic (Declaration)
Public WebBearingCapacity As Double
Visual C++
public:
double WebBearingCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


WebBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.WebBearingResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebBearingResistance
Visual Basic (Declaration)
Public WebBearingResistance As Double
Visual C++
public:
double WebBearingResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


WebBoltsShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.WebBoltsShearCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebBoltsShearCapacity
Visual Basic (Declaration)
Public WebBoltsShearCapacity As Double
Visual C++
public:
double WebBoltsShearCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


WebBoltsShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.WebBoltsShearResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebBoltsShearResistance
Visual Basic (Declaration)
Public WebBoltsShearResistance As Double
Visual C++
public:
double WebBoltsShearResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


WebPlateAxialCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.WebPlateAxialCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web plate capacity in axial force

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebPlateAxialCapacity
Visual Basic (Declaration)
Public WebPlateAxialCapacity As Double
Visual C++
public:
double WebPlateAxialCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


WebPlateAxialResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.WebPlateAxialResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web plate resistance in axial force

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebPlateAxialResistance
Visual Basic (Declaration)
Public WebPlateAxialResistance As Double
Visual C++
public:
double WebPlateAxialResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


WebWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.WebWeldCapacity Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web welds capacity, in case of welded left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebWeldCapacity
Visual Basic (Declaration)
Public WebWeldCapacity As Double
Visual C++
public:
double WebWeldCapacity

Remarks

See Also

BeamSplices1ConnectionResults Class


WebWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults..::.WebWeldResistance Field
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web welds resistance, in case of welded left connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebWeldResistance
Visual Basic (Declaration)
Public WebWeldResistance As Double
Visual C++
public:
double WebWeldResistance

Remarks

See Also

BeamSplices1ConnectionResults Class


BeamSplices1ConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices1ConnectionResults Methods
BeamSplices1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices1ConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplices1ConnectionResults Class


BeamSplices2Connection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam splice connection between 2 H section members by means of welded web plates and in-fill welds between the flanges

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplices2Connection
Visual Basic (Declaration)
Public Class BeamSplices2Connection
Visual C++
public ref class BeamSplices2Connection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplices2Connection

See Also

BeamSplices2Connection Members


BeamSplices2Connection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection Members
BeamSplices2Connection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices2Connection type exposes the following members.

Constructors

Name | Description
BeamSplices2Connection | Initializes a new instance of the BeamSplices2Connection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
afl | Weld (in-fill) thickness between beam flanges
aw | Weld thickness between web plate and beam web
Beam | Beam object
BeamSteel | Beam steel grade
gap | Gap between connected members
LoadCases | Load cases of the beam
Results | List of results
WebPlateHeight |
WebPlateSteel | Web plate steel grade
WebPlateThickness |
WebPlateWidth | Web plate dimensions

See Also

BeamSplices2Connection Class


BeamSplices2Connection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection Constructor
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplices2Connection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplices2Connection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplices2Connection()

See Also

BeamSplices2Connection Class


BeamSplices2Connection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection Fields
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices2Connection type exposes the following members.

Fields

Name | Description
afl | Weld (in-fill) thickness between beam flanges
aw | Weld thickness between web plate and beam web
Beam | Beam object
BeamSteel | Beam steel grade
gap | Gap between connected members
LoadCases | Load cases of the beam
Results | List of results
WebPlateHeight |
WebPlateSteel | Web plate steel grade
WebPlateThickness |
WebPlateWidth | Web plate dimensions

See Also

BeamSplices2Connection Class


afl Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.afl Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld (in-fill) thickness between beam flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double afl
Visual Basic (Declaration)
Public afl As Double
Visual C++
public:
double afl

Remarks

See Also

BeamSplices2Connection Class


aw Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.aw Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between web plate and beam web

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aw
Visual Basic (Declaration)
Public aw As Double
Visual C++
public:
double aw

Remarks

See Also

BeamSplices2Connection Class


Beam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.Beam Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Beam
Visual Basic (Declaration)
Public Beam As HSection
Visual C++
public:
HSection^ Beam

Remarks

See Also

BeamSplices2Connection Class


BeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.BeamSteel Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade BeamSteel
Visual Basic (Declaration)
Public BeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ BeamSteel

Remarks

See Also

BeamSplices2Connection Class


gap Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.gap Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Gap between connected members

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double gap
Visual Basic (Declaration)
Public gap As Double
Visual C++
public:
double gap

Remarks

See Also

BeamSplices2Connection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.LoadCases Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ned (positive=tensile)

Ved (positive=rotates the joint counterclockwise)

Med (positive=lower beam flange is under tension)

See Also

BeamSplices2Connection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.Results Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamSplices2ConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamSplices2ConnectionResults)
Visual C++
public:
List<BeamSplices2ConnectionResults^>^ Results

Remarks

See Also

BeamSplices2Connection Class


WebPlateHeight Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.WebPlateHeight Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebPlateHeight
Visual Basic (Declaration)
Public WebPlateHeight As Double
Visual C++
public:
double WebPlateHeight

See Also

BeamSplices2Connection Class


WebPlateSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.WebPlateSteel Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Web plate steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade WebPlateSteel
Visual Basic (Declaration)
Public WebPlateSteel As SteelGrade
Visual C++
public:
SteelGrade^ WebPlateSteel

Remarks

See Also

BeamSplices2Connection Class


WebPlateThickness Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.WebPlateThickness Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebPlateThickness
Visual Basic (Declaration)
Public WebPlateThickness As Double
Visual C++
public:
double WebPlateThickness

See Also

BeamSplices2Connection Class


WebPlateWidth Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.WebPlateWidth Field
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Web plate dimensions

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebPlateWidth
Visual Basic (Declaration)
Public WebPlateWidth As Double
Visual C++
public:
double WebPlateWidth

Remarks

See Also

BeamSplices2Connection Class


BeamSplices2Connection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection Methods
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices2Connection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplices2Connection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.Calculate Method
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamSplices2Connection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2Connection..::.GetInputWarnings Method
BeamSplices2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplices2ConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamSplices2ConnectionInputWarnings
Visual C++
public:
BeamSplices2ConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamSplices2Connection Class


BeamSplices2ConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplices2ConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamSplices2ConnectionInputWarnings
Visual C++
public ref class BeamSplices2ConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplices2ConnectionInputWarnings

See Also

BeamSplices2ConnectionInputWarnings Members


BeamSplices2ConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionInputWarnings Members
BeamSplices2ConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices2ConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamSplices2ConnectionInputWarnings | Initializes a new instance of the BeamSplices2ConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Welds | Input warnings regarding welds

See Also

BeamSplices2ConnectionInputWarnings Class


BeamSplices2ConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionInputWarnings Constructor
BeamSplices2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplices2ConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplices2ConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplices2ConnectionInputWarnings()

See Also

BeamSplices2ConnectionInputWarnings Class


BeamSplices2ConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionInputWarnings Fields
BeamSplices2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices2ConnectionInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Welds | Input warnings regarding welds

See Also

BeamSplices2ConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionInputWarnings..::.Other Field
BeamSplices2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamSplices2ConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionInputWarnings..::.Welds Field
BeamSplices2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamSplices2ConnectionInputWarnings Class


BeamSplices2ConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionInputWarnings Methods
BeamSplices2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices2ConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplices2ConnectionInputWarnings Class


BeamSplices2ConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplices2ConnectionResults
Visual Basic (Declaration)
Public Class BeamSplices2ConnectionResults
Visual C++
public ref class BeamSplices2ConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplices2ConnectionResults

See Also

BeamSplices2ConnectionResults Members


BeamSplices2ConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults Members
BeamSplices2ConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices2ConnectionResults type exposes the following members.

Constructors

Name | Description
BeamSplices2ConnectionResults | Initializes a new instance of the BeamSplices2ConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FlangeWeldCapacity | Flange welds capacity
FlangeWeldResistance | Flange welds resistance
WebPlateAxialCapacity | Web plate capacity in axial force
WebPlateAxialResistance | Web plate resistance in axial force
WebWeldCapacity | Web welds capacity
WebWeldResistance | Web welds resistance

See Also

BeamSplices2ConnectionResults Class


BeamSplices2ConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults Constructor
BeamSplices2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplices2ConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplices2ConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplices2ConnectionResults()

See Also

BeamSplices2ConnectionResults Class


BeamSplices2ConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults Fields
BeamSplices2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices2ConnectionResults type exposes the following members.

Fields

Name | Description
FlangeWeldCapacity | Flange welds capacity
FlangeWeldResistance | Flange welds resistance
WebPlateAxialCapacity | Web plate capacity in axial force
WebPlateAxialResistance | Web plate resistance in axial force
WebWeldCapacity | Web welds capacity
WebWeldResistance | Web welds resistance

See Also

BeamSplices2ConnectionResults Class


FlangeWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults..::.FlangeWeldCapacity Field
BeamSplices2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange welds capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangeWeldCapacity
Visual Basic (Declaration)
Public FlangeWeldCapacity As Double
Visual C++
public:
double FlangeWeldCapacity

Remarks

See Also

BeamSplices2ConnectionResults Class


FlangeWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults..::.FlangeWeldResistance Field
BeamSplices2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Flange welds resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FlangeWeldResistance
Visual Basic (Declaration)
Public FlangeWeldResistance As Double
Visual C++
public:
double FlangeWeldResistance

Remarks

See Also

BeamSplices2ConnectionResults Class


WebPlateAxialCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults..::.WebPlateAxialCapacity Field
BeamSplices2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web plate capacity in axial force

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebPlateAxialCapacity
Visual Basic (Declaration)
Public WebPlateAxialCapacity As Double
Visual C++
public:
double WebPlateAxialCapacity

Remarks

See Also

BeamSplices2ConnectionResults Class


WebPlateAxialResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults..::.WebPlateAxialResistance Field
BeamSplices2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web plate resistance in axial force

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebPlateAxialResistance
Visual Basic (Declaration)
Public WebPlateAxialResistance As Double
Visual C++
public:
double WebPlateAxialResistance

Remarks

See Also

BeamSplices2ConnectionResults Class


WebWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults..::.WebWeldCapacity Field
BeamSplices2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web welds capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebWeldCapacity
Visual Basic (Declaration)
Public WebWeldCapacity As Double
Visual C++
public:
double WebWeldCapacity

Remarks

See Also

BeamSplices2ConnectionResults Class


WebWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults..::.WebWeldResistance Field
BeamSplices2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Web welds resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WebWeldResistance
Visual Basic (Declaration)
Public WebWeldResistance As Double
Visual C++
public:
double WebWeldResistance

Remarks

See Also

BeamSplices2ConnectionResults Class


BeamSplices2ConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplices2ConnectionResults Methods
BeamSplices2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplices2ConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplices2ConnectionResults Class


BeamSplicesEndplateConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a beam splice connection between 2 H section members by means of endplates

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplicesEndplateConnection
Visual Basic (Declaration)
Public Class BeamSplicesEndplateConnection
Visual C++
public ref class BeamSplicesEndplateConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplicesEndplateConnection

See Also

BeamSplicesEndplateConnection Members


BeamSplicesEndplateConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection Members
BeamSplicesEndplateConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesEndplateConnection type exposes the following members.

Constructors

Name | Description
BeamSplicesEndplateConnection | Initializes a new instance of the BeamSplicesEndplateConnection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
af_beam | Weld thickness between beam flange and endplate
aHaunchBeamFlange | Weld thickness between haunch and beam flanges
aHaunchEndPlateFlange | Weld thickness between haunch flange and endplate
aHaunchEndPlateWeb | Weld thickness between haunch web and endplate
aw_beam | Weld thickness between beam web and endplate
Beam | Beam object
BeamSteel | Beam steel grade
Haunch | Haunch section
LoadCases | Load cases of the beam
Plate | Endplate object
Results | List of results
Theta_Haunch | Angle between beam and haunch flanges
tst_b |
UseOfBeamWebStiffener | True, if beam web stiffeners are used, otherwise false
UseOfHaunch | True, if haunces are used, otherwise false

See Also

BeamSplicesEndplateConnection Class


BeamSplicesEndplateConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection Constructor
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplicesEndplateConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplicesEndplateConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplicesEndplateConnection()

See Also

BeamSplicesEndplateConnection Class


BeamSplicesEndplateConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection Fields
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesEndplateConnection type exposes the following members.

Fields

Name | Description
af_beam | Weld thickness between beam flange and endplate
aHaunchBeamFlange | Weld thickness between haunch and beam flanges
aHaunchEndPlateFlange | Weld thickness between haunch flange and endplate
aHaunchEndPlateWeb | Weld thickness between haunch web and endplate
aw_beam | Weld thickness between beam web and endplate
Beam | Beam object
BeamSteel | Beam steel grade
Haunch | Haunch section
LoadCases | Load cases of the beam
Plate | Endplate object
Results | List of results
Theta_Haunch | Angle between beam and haunch flanges
tst_b |
UseOfBeamWebStiffener | True, if beam web stiffeners are used, otherwise false
UseOfHaunch | True, if haunces are used, otherwise false

See Also

BeamSplicesEndplateConnection Class


af_beam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.af_beam Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between beam flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double af_beam
Visual Basic (Declaration)
Public af_beam As Double
Visual C++
public:
double af_beam

Remarks

See Also

BeamSplicesEndplateConnection Class


aHaunchBeamFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.aHaunchBeamFlange Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between haunch and beam flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchBeamFlange
Visual Basic (Declaration)
Public aHaunchBeamFlange As Double
Visual C++
public:
double aHaunchBeamFlange

Remarks

See Also

BeamSplicesEndplateConnection Class


aHaunchEndPlateFlange Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.aHaunchEndPlateFlange Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between haunch flange and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchEndPlateFlange
Visual Basic (Declaration)
Public aHaunchEndPlateFlange As Double
Visual C++
public:
double aHaunchEndPlateFlange

Remarks

See Also

BeamSplicesEndplateConnection Class


aHaunchEndPlateWeb Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.aHaunchEndPlateWeb Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between haunch web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aHaunchEndPlateWeb
Visual Basic (Declaration)
Public aHaunchEndPlateWeb As Double
Visual C++
public:
double aHaunchEndPlateWeb

Remarks

See Also

BeamSplicesEndplateConnection Class


aw_beam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.aw_beam Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between beam web and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aw_beam
Visual Basic (Declaration)
Public aw_beam As Double
Visual C++
public:
double aw_beam

Remarks

See Also

BeamSplicesEndplateConnection Class


Beam Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.Beam Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Beam
Visual Basic (Declaration)
Public Beam As HSection
Visual C++
public:
HSection^ Beam

Remarks

See Also

BeamSplicesEndplateConnection Class


BeamSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.BeamSteel Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade BeamSteel
Visual Basic (Declaration)
Public BeamSteel As SteelGrade
Visual C++
public:
SteelGrade^ BeamSteel

Remarks

See Also

BeamSplicesEndplateConnection Class


Haunch Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.Haunch Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Haunch section

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TSection Haunch
Visual Basic (Declaration)
Public Haunch As TSection
Visual C++
public:
TSection^ Haunch

Remarks

See Also

BeamSplicesEndplateConnection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.LoadCases Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ned (positive=compressive), WARNING: Ned should not exceed 5% of the beam plastic axial resistance, according to 6.2.3(2) [prEN 1993-1-8 : 2003]!!

Ved (positive=downwards)

Med (positive=lower beam flange is compressed), WARNING: Med has to be positive!!

See Also

BeamSplicesEndplateConnection Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.Plate Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Endplate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BoltedEndPlate Plate
Visual Basic (Declaration)
Public Plate As BoltedEndPlate
Visual C++
public:
BoltedEndPlate^ Plate

Remarks

See Also

BeamSplicesEndplateConnection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.Results Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamSplicesEndplateConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of BeamSplicesEndplateConnectionResults)
Visual C++
public:
List<BeamSplicesEndplateConnectionResults^>^ Results

Remarks

See Also

BeamSplicesEndplateConnection Class


Theta_Haunch Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.Theta_Haunch Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Angle between beam and haunch flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Theta_Haunch
Visual Basic (Declaration)
Public Theta_Haunch As Double
Visual C++
public:
double Theta_Haunch

Remarks

See Also

BeamSplicesEndplateConnection Class


tst_b Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.tst_b Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tst_b
Visual Basic (Declaration)
Public tst_b As Double
Visual C++
public:
double tst_b

Remarks

See Also

BeamSplicesEndplateConnection Class


UseOfBeamWebStiffener Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.UseOfBeamWebStiffener Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if beam web stiffeners are used, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfBeamWebStiffener
Visual Basic (Declaration)
Public UseOfBeamWebStiffener As Boolean
Visual C++
public:
bool UseOfBeamWebStiffener

Remarks

Weld is assumed on both sides of the beam flange

See Also

BeamSplicesEndplateConnection Class


UseOfHaunch Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.UseOfHaunch Field
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if haunces are used, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfHaunch
Visual Basic (Declaration)
Public UseOfHaunch As Boolean
Visual C++
public:
bool UseOfHaunch

Remarks

See Also

BeamSplicesEndplateConnection Class


BeamSplicesEndplateConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection Methods
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesEndplateConnection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplicesEndplateConnection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.Calculate Method
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

BeamSplicesEndplateConnection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnection..::.GetInputWarnings Method
BeamSplicesEndplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplicesEndplateConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As BeamSplicesEndplateConnectionInputWarnings
Visual C++
public:
BeamSplicesEndplateConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

BeamSplicesEndplateConnection Class


BeamSplicesEndplateConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplicesEndplateConnectionInputWarnings
Visual Basic (Declaration)
Public Class BeamSplicesEndplateConnectionInputWarnings
Visual C++
public ref class BeamSplicesEndplateConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplicesEndplateConnectionInputWarnings

See Also

BeamSplicesEndplateConnectionInputWarnings Members


BeamSplicesEndplateConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionInputWarnings Members
BeamSplicesEndplateConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesEndplateConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
BeamSplicesEndplateConnectionInputWarnings | Initializes a new instance of the BeamSplicesEndplateConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the endplate
Welds | Input warnings regarding welds

See Also

BeamSplicesEndplateConnectionInputWarnings Class


BeamSplicesEndplateConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionInputWarnings Constructor
BeamSplicesEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplicesEndplateConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplicesEndplateConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplicesEndplateConnectionInputWarnings()

See Also

BeamSplicesEndplateConnectionInputWarnings Class


BeamSplicesEndplateConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionInputWarnings Fields
BeamSplicesEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesEndplateConnectionInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the endplate
Welds | Input warnings regarding welds

See Also

BeamSplicesEndplateConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionInputWarnings..::.Other Field
BeamSplicesEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

BeamSplicesEndplateConnectionInputWarnings Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionInputWarnings..::.Plate Field
BeamSplicesEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Plate
Visual Basic (Declaration)
Public Plate As List(Of String)
Visual C++
public:
List<String^>^ Plate

Remarks

See Also

BeamSplicesEndplateConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionInputWarnings..::.Welds Field
BeamSplicesEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

BeamSplicesEndplateConnectionInputWarnings Class


BeamSplicesEndplateConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionInputWarnings Methods
BeamSplicesEndplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesEndplateConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplicesEndplateConnectionInputWarnings Class


BeamSplicesEndplateConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplicesEndplateConnectionResults
Visual Basic (Declaration)
Public Class BeamSplicesEndplateConnectionResults
Visual C++
public ref class BeamSplicesEndplateConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplicesEndplateConnectionResults

See Also

BeamSplicesEndplateConnectionResults Members


BeamSplicesEndplateConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults Members
BeamSplicesEndplateConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesEndplateConnectionResults type exposes the following members.

Constructors

Name | Description
BeamSplicesEndplateConnectionResults | Initializes a new instance of the BeamSplicesEndplateConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BearingCapacity | Bearing capacity of the connection
BearingResistance | Bearing resistance of the connection
BoltInteractionCapacity | Bolt ineraction capacity
MomentCapacity | Moment capacity of the connection
MomentResistance | Moment resistance of the connection
RowResults | List of results for each row
RowsUnderTension | Final bolt rows count under tension
ShearCapacity | Shear capacity of the connection
ShearResistance | Shear resistance of the connection
Sj | Rotational stiffness of the joint
WeldCapacity | Weld capacity between beam and endplate
WeldResistance | Weld resistance between beam and endplate
zeq | Equal lever arm

See Also

BeamSplicesEndplateConnectionResults Class


BeamSplicesEndplateConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults Constructor
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplicesEndplateConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplicesEndplateConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplicesEndplateConnectionResults()

See Also

BeamSplicesEndplateConnectionResults Class


BeamSplicesEndplateConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults Fields
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesEndplateConnectionResults type exposes the following members.

Fields

Name | Description
BearingCapacity | Bearing capacity of the connection
BearingResistance | Bearing resistance of the connection
BoltInteractionCapacity | Bolt ineraction capacity
MomentCapacity | Moment capacity of the connection
MomentResistance | Moment resistance of the connection
RowResults | List of results for each row
RowsUnderTension | Final bolt rows count under tension
ShearCapacity | Shear capacity of the connection
ShearResistance | Shear resistance of the connection
Sj | Rotational stiffness of the joint
WeldCapacity | Weld capacity between beam and endplate
WeldResistance | Weld resistance between beam and endplate
zeq | Equal lever arm

See Also

BeamSplicesEndplateConnectionResults Class


BearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.BearingCapacity Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bearing capacity of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BearingCapacity
Visual Basic (Declaration)
Public BearingCapacity As Double
Visual C++
public:
double BearingCapacity

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


BearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.BearingResistance Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bearing resistance of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BearingResistance
Visual Basic (Declaration)
Public BearingResistance As Double
Visual C++
public:
double BearingResistance

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


BoltInteractionCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.BoltInteractionCapacity Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolt ineraction capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltInteractionCapacity
Visual Basic (Declaration)
Public BoltInteractionCapacity As Double
Visual C++
public:
double BoltInteractionCapacity

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


MomentCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.MomentCapacity Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment capacity of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentCapacity
Visual Basic (Declaration)
Public MomentCapacity As Double
Visual C++
public:
double MomentCapacity

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


MomentResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.MomentResistance Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment resistance of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentResistance
Visual Basic (Declaration)
Public MomentResistance As Double
Visual C++
public:
double MomentResistance

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


RowResults Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.RowResults Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results for each row

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamSplicesRowResults> RowResults
Visual Basic (Declaration)
Public RowResults As List(Of BeamSplicesRowResults)
Visual C++
public:
List<BeamSplicesRowResults^>^ RowResults

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


RowsUnderTension Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.RowsUnderTension Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt rows count under tension

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int RowsUnderTension
Visual Basic (Declaration)
Public RowsUnderTension As Integer
Visual C++
public:
int RowsUnderTension

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


ShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.ShearCapacity Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear capacity of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearCapacity
Visual Basic (Declaration)
Public ShearCapacity As Double
Visual C++
public:
double ShearCapacity

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


ShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.ShearResistance Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearResistance
Visual Basic (Declaration)
Public ShearResistance As Double
Visual C++
public:
double ShearResistance

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


Sj Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.Sj Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Rotational stiffness of the joint

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Sj
Visual Basic (Declaration)
Public Sj As Double
Visual C++
public:
double Sj

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


WeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.WeldCapacity Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity between beam and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldCapacity
Visual Basic (Declaration)
Public WeldCapacity As Double
Visual C++
public:
double WeldCapacity

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


WeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.WeldResistance Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance between beam and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldResistance
Visual Basic (Declaration)
Public WeldResistance As Double
Visual C++
public:
double WeldResistance

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


zeq Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults..::.zeq Field
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Equal lever arm

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double zeq
Visual Basic (Declaration)
Public zeq As Double
Visual C++
public:
double zeq

Remarks

See Also

BeamSplicesEndplateConnectionResults Class


BeamSplicesEndplateConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesEndplateConnectionResults Methods
BeamSplicesEndplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesEndplateConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplicesEndplateConnectionResults Class


BeamSplicesRowResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents results regarding to one bolt row

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BeamSplicesRowResults
Visual Basic (Declaration)
Public Class BeamSplicesRowResults
Visual C++
public ref class BeamSplicesRowResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BeamSplicesRowResults

See Also

BeamSplicesRowResults Members


BeamSplicesRowResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults Members
BeamSplicesRowResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesRowResults type exposes the following members.

Constructors

Name | Description
BeamSplicesRowResults | Initializes a new instance of the BeamSplicesRowResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
beff_bep_group | Effective width for the endplate in bending for the bolt row as part of a bolt group
beff_bep_group_onlyThisRow | Effective length for the endplate in bending this row only as a part of a group
beff_bep_individual | Effective width for the endplate in bending resistance for the bolt row as single
Fbep_final | Final bolt row resistance for the endplate in bending
Fbep_group | Endplate in bending resistance for the bolt row as part of a bolt group
Fbep_individual | Endplate in bending resistance for the bolt row as single
Ft_final | Final bolt row resistance
Ftwb_final | Final bolt row resistance for the beam web in tension
FtwbRd_group | Beam web in tension resistance for the bolt row as part of a bolt group
FtwbRd_individual | Beam web in tension resistance for the bolt row as single
keff_r | Effective stiffness coefficient for this bolt row

See Also

BeamSplicesRowResults Class


BeamSplicesRowResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults Constructor
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BeamSplicesRowResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BeamSplicesRowResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSplicesRowResults()

See Also

BeamSplicesRowResults Class


BeamSplicesRowResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults Fields
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesRowResults type exposes the following members.

Fields

Name | Description
beff_bep_group | Effective width for the endplate in bending for the bolt row as part of a bolt group
beff_bep_group_onlyThisRow | Effective length for the endplate in bending this row only as a part of a group
beff_bep_individual | Effective width for the endplate in bending resistance for the bolt row as single
Fbep_final | Final bolt row resistance for the endplate in bending
Fbep_group | Endplate in bending resistance for the bolt row as part of a bolt group
Fbep_individual | Endplate in bending resistance for the bolt row as single
Ft_final | Final bolt row resistance
Ftwb_final | Final bolt row resistance for the beam web in tension
FtwbRd_group | Beam web in tension resistance for the bolt row as part of a bolt group
FtwbRd_individual | Beam web in tension resistance for the bolt row as single
keff_r | Effective stiffness coefficient for this bolt row

See Also

BeamSplicesRowResults Class


beff_bep_group Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.beff_bep_group Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective width for the endplate in bending for the bolt row as part of a bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double beff_bep_group
Visual Basic (Declaration)
Public beff_bep_group As Double
Visual C++
public:
double beff_bep_group

Remarks

See Also

BeamSplicesRowResults Class


beff_bep_group_onlyThisRow Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.beff_bep_group_onlyThisRow Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective length for the endplate in bending this row only as a part of a group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double beff_bep_group_onlyThisRow
Visual Basic (Declaration)
Public beff_bep_group_onlyThisRow As Double
Visual C++
public:
double beff_bep_group_onlyThisRow

Remarks

See Also

BeamSplicesRowResults Class


beff_bep_individual Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.beff_bep_individual Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective width for the endplate in bending resistance for the bolt row as single

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double beff_bep_individual
Visual Basic (Declaration)
Public beff_bep_individual As Double
Visual C++
public:
double beff_bep_individual

Remarks

See Also

BeamSplicesRowResults Class


Fbep_final Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.Fbep_final Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt row resistance for the endplate in bending

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Fbep_final
Visual Basic (Declaration)
Public Fbep_final As Double
Visual C++
public:
double Fbep_final

Remarks

See Also

BeamSplicesRowResults Class


Fbep_group Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.Fbep_group Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Endplate in bending resistance for the bolt row as part of a bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Fbep_group
Visual Basic (Declaration)
Public Fbep_group As Double
Visual C++
public:
double Fbep_group

Remarks

See Also

BeamSplicesRowResults Class


Fbep_individual Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.Fbep_individual Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Endplate in bending resistance for the bolt row as single

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Fbep_individual
Visual Basic (Declaration)
Public Fbep_individual As Double
Visual C++
public:
double Fbep_individual

Remarks

See Also

BeamSplicesRowResults Class


Ft_final Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.Ft_final Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt row resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ft_final
Visual Basic (Declaration)
Public Ft_final As Double
Visual C++
public:
double Ft_final

Remarks

See Also

BeamSplicesRowResults Class


Ftwb_final Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.Ftwb_final Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt row resistance for the beam web in tension

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ftwb_final
Visual Basic (Declaration)
Public Ftwb_final As Double
Visual C++
public:
double Ftwb_final

Remarks

See Also

BeamSplicesRowResults Class


FtwbRd_group Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.FtwbRd_group Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web in tension resistance for the bolt row as part of a bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FtwbRd_group
Visual Basic (Declaration)
Public FtwbRd_group As Double
Visual C++
public:
double FtwbRd_group

Remarks

See Also

BeamSplicesRowResults Class


FtwbRd_individual Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.FtwbRd_individual Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Beam web in tension resistance for the bolt row as single

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FtwbRd_individual
Visual Basic (Declaration)
Public FtwbRd_individual As Double
Visual C++
public:
double FtwbRd_individual

Remarks

See Also

BeamSplicesRowResults Class


keff_r Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults..::.keff_r Field
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Effective stiffness coefficient for this bolt row

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double keff_r
Visual Basic (Declaration)
Public keff_r As Double
Visual C++
public:
double keff_r

Remarks

See Also

BeamSplicesRowResults Class


BeamSplicesRowResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BeamSplicesRowResults Methods
BeamSplicesRowResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The BeamSplicesRowResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSplicesRowResults Class


BoltedBasePlate Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a bolted baseplate connected to a column

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BoltedBasePlate
Visual Basic (Declaration)
Public Class BoltedBasePlate
Visual C++
public ref class BoltedBasePlate

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BoltedBasePlate

See Also

BoltedBasePlate Members


BoltedBasePlate Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate Members
BoltedBasePlate Class Constructors Methods Fields Properties See Also Send Feedback
EC3 Steel Connection Design Library

The BoltedBasePlate type exposes the following members.

Constructors

Name | Description
BoltedBasePlate | Initializes a new instance of the BoltedBasePlate class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FbRd | Bearing resistance of the bolt group
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FvRd | Shear resistance of the bolt group
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns a list of strings that describe the input warnings regarding the bolt placement on the plate
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
px | Horizontal inner distance between bolts
py | Vertical inner distance for a bolt row
RowInsideColumnFlanges | Checks if a bolt row is located along the column height
RowOutsideColumnFlanges | Checks if a bolt row is located outside the column height
Rows | Total bolt rows count
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalRowDistances | Calculation of the distance of each row from the upper edge of the baseplate

Fields

Name | Description
b | Width
Bolts | Bolts object
ex | Horizontal edge distance
ey2 | Vertical distance between first bolt row inside column flanges and outer bolt row
h | Height
RowsInside | Number of bolt rows inside column flanges
Steel | Steel grade object
t | Thickness
ThereAreRowsOutside | True, if there are bolt rows outside the column flanges

Properties

Name | Description
BoltsNr | Total bolts count
ey1 | Vertical distance between first bolt row and baseplate edge

See Also

BoltedBasePlate Class


BoltedBasePlate Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate Constructor
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BoltedBasePlate class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BoltedBasePlate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoltedBasePlate()

See Also

BoltedBasePlate Class


BoltedBasePlate Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate Fields
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library

The BoltedBasePlate type exposes the following members.

Fields

Name | Description
b | Width
Bolts | Bolts object
ex | Horizontal edge distance
ey2 | Vertical distance between first bolt row inside column flanges and outer bolt row
h | Height
RowsInside | Number of bolt rows inside column flanges
Steel | Steel grade object
t | Thickness
ThereAreRowsOutside | True, if there are bolt rows outside the column flanges

See Also

BoltedBasePlate Class


b Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.b Field
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Width

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double b
Visual Basic (Declaration)
Public b As Double
Visual C++
public:
double b

Remarks

See Also

BoltedBasePlate Class


Bolts Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.Bolts Field
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Bolts Bolts
Visual Basic (Declaration)
Public Bolts As Bolts
Visual C++
public:
Bolts^ Bolts

Remarks

See Also

BoltedBasePlate Class


ex Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.ex Field
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Horizontal edge distance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ex
Visual Basic (Declaration)
Public ex As Double
Visual C++
public:
double ex

Remarks

See Also

BoltedBasePlate Class


ey2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.ey2 Field
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Vertical distance between first bolt row inside column flanges and outer bolt row

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ey2
Visual Basic (Declaration)
Public ey2 As Double
Visual C++
public:
double ey2

Remarks

See Also

BoltedBasePlate Class


h Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.h Field
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double h
Visual Basic (Declaration)
Public h As Double
Visual C++
public:
double h

Remarks

See Also

BoltedBasePlate Class


RowsInside Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.RowsInside Field
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Number of bolt rows inside column flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int RowsInside
Visual Basic (Declaration)
Public RowsInside As Integer
Visual C++
public:
int RowsInside

Remarks

See Also

BoltedBasePlate Class


Steel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.Steel Field
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Steel grade object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade Steel
Visual Basic (Declaration)
Public Steel As SteelGrade
Visual C++
public:
SteelGrade^ Steel

Remarks

See Also

BoltedBasePlate Class


t Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.t Field
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double t
Visual Basic (Declaration)
Public t As Double
Visual C++
public:
double t

Remarks

See Also

BoltedBasePlate Class


ThereAreRowsOutside Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.ThereAreRowsOutside Field
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if there are bolt rows outside the column flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ThereAreRowsOutside
Visual Basic (Declaration)
Public ThereAreRowsOutside As Boolean
Visual C++
public:
bool ThereAreRowsOutside

Remarks

See Also

BoltedBasePlate Class


BoltedBasePlate Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate Methods
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library

The BoltedBasePlate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FbRd | Bearing resistance of the bolt group
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FvRd | Shear resistance of the bolt group
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns a list of strings that describe the input warnings regarding the bolt placement on the plate
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
px | Horizontal inner distance between bolts
py | Vertical inner distance for a bolt row
RowInsideColumnFlanges | Checks if a bolt row is located along the column height
RowOutsideColumnFlanges | Checks if a bolt row is located outside the column height
Rows | Total bolt rows count
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalRowDistances | Calculation of the distance of each row from the upper edge of the baseplate

See Also

BoltedBasePlate Class


FbRd Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.FbRd Method
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Bearing resistance of the bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FbRd(
    BoltedBasePlate..::.LoadTransferBasePlate _LoadTransefr,
    double t_other_plate
)
Visual Basic (Declaration)
Public Function FbRd ( _
    _LoadTransefr As BoltedBasePlate..::.LoadTransferBasePlate, _
    t_other_plate As Double _
) As Double
Visual C++
public:
double FbRd(
    BoltedBasePlate..::.LoadTransferBasePlate _LoadTransefr,
    double t_other_plate
)

Parameters

_LoadTransefr
Type: SteelConnectionsEC3..::.BoltedBasePlate..::.LoadTransferBasePlate
Load transfer direction
t_other_plate
Type: System..::.Double
The thickness of another plate to consider (if any)

Return Value

Bearing resistance

Remarks

See Also

BoltedBasePlate Class


FvRd Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.FvRd Method
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FvRd()
Visual Basic (Declaration)
Public Function FvRd As Double
Visual C++
public:
double FvRd()

Return Value

Shear resistance

Remarks

See Also

BoltedBasePlate Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.GetInputWarnings Method
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns a list of strings that describe the input warnings regarding the bolt placement on the plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> GetInputWarnings(
    BoltedBasePlate..::.LoadTransferBasePlate LoadTransfer
)
Visual Basic (Declaration)
Public Function GetInputWarnings ( _
    LoadTransfer As BoltedBasePlate..::.LoadTransferBasePlate _
) As List(Of String)
Visual C++
public:
List<String^>^ GetInputWarnings(
    BoltedBasePlate..::.LoadTransferBasePlate LoadTransfer
)

Parameters

LoadTransfer
Type: SteelConnectionsEC3..::.BoltedBasePlate..::.LoadTransferBasePlate
LoadTransferBasePlate object

Return Value

List of warnings

Remarks

See Also

BoltedBasePlate Class


px Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.px Method
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Horizontal inner distance between bolts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double px()
Visual Basic (Declaration)
Public Function px As Double
Visual C++
public:
double px()

Return Value

The horizontal distance between the bolts

Remarks

See Also

BoltedBasePlate Class


py Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.py Method
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Vertical inner distance for a bolt row

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double py(
    int row
)
Visual Basic (Declaration)
Public Function py ( _
    row As Integer _
) As Double
Visual C++
public:
double py(
    int row
)

Parameters

row
Type: System..::.Int32
The bolt row, starting from the top row(=1)

Return Value

The vertical distance between the bolts

Remarks

Calculates the sum of the distances between the given row, its previous and its next rows

See Also

BoltedBasePlate Class


RowInsideColumnFlanges Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.RowInsideColumnFlanges Method
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Checks if a bolt row is located along the column height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RowInsideColumnFlanges(
    int row
)
Visual Basic (Declaration)
Public Function RowInsideColumnFlanges ( _
    row As Integer _
) As Boolean
Visual C++
public:
bool RowInsideColumnFlanges(
    int row
)

Parameters

row
Type: System..::.Int32
The bolt row, starting from the top row(=1)

Return Value

True, if the bolt row is located along the column height

Remarks

See Also

BoltedBasePlate Class


RowOutsideColumnFlanges Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.RowOutsideColumnFlanges Method
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Checks if a bolt row is located outside the column height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RowOutsideColumnFlanges(
    int row
)
Visual Basic (Declaration)
Public Function RowOutsideColumnFlanges ( _
    row As Integer _
) As Boolean
Visual C++
public:
bool RowOutsideColumnFlanges(
    int row
)

Parameters

row
Type: System..::.Int32
The bolt row, starting from the top row(=1)

Return Value

True, if the bolt row is located outside the column height

Remarks

See Also

BoltedBasePlate Class


Rows Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.Rows Method
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Total bolt rows count

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Rows()
Visual Basic (Declaration)
Public Function Rows As Object
Visual C++
public:
Object^ Rows()

Return Value

Remarks

Count of total bolt rows

See Also

BoltedBasePlate Class


VerticalRowDistances Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.VerticalRowDistances Method
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Calculation of the distance of each row from the upper edge of the baseplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<double> VerticalRowDistances()
Visual Basic (Declaration)
Public Function VerticalRowDistances As List(Of Double)
Visual C++
public:
List<double>^ VerticalRowDistances()

Return Value

A list of doubles that contains the distance of each row from the upper edge of the baseplate

Remarks

See Also

BoltedBasePlate Class


BoltedBasePlate Properties

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate Properties
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library

The BoltedBasePlate type exposes the following members.

Properties

Name | Description
BoltsNr | Total bolts count
ey1 | Vertical distance between first bolt row and baseplate edge

See Also

BoltedBasePlate Class


BoltsNr Property

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.BoltsNr Property
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Total bolts count

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int BoltsNr { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoltsNr As Integer
Visual C++
public:
property int BoltsNr {
    int get ();
}

Field Value

Return Value

Count of total bolts

Remarks

See Also

BoltedBasePlate Class


ey1 Property

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.ey1 Property
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Vertical distance between first bolt row and baseplate edge

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ey1 { get; set; }
Visual Basic (Declaration)
Public Property ey1 As Double
Visual C++
public:
property double ey1 {
    double get ();
    void set (double value);
}

Field Value

Return Value

Remarks

If there are no bolt rows outside the column, zero value is returned

See Also

BoltedBasePlate Class


BoltedBasePlate.LoadTransferBasePlate Enumeration

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedBasePlate..::.LoadTransferBasePlate Enumeration
BoltedBasePlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Represents the load direction transferred from the column to the baseplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum LoadTransferBasePlate
Visual Basic (Declaration)
Public Enumeration LoadTransferBasePlate
Visual C++
public enum class LoadTransferBasePlate

Members

Member name | Description
Up | Load transfer upwards
Down | Load transfer downwards
Right | Load transfer rightwards
Left | Load transfer leftwards

Remarks

See Also

SteelConnectionsEC3 Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


BoltedEndPlate Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a bolted endplate connected to a column

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BoltedEndPlate
Visual Basic (Declaration)
Public Class BoltedEndPlate
Visual C++
public ref class BoltedEndPlate

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.BoltedEndPlate

See Also

BoltedEndPlate Members


BoltedEndPlate Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate Members
BoltedEndPlate Class Constructors Methods Fields Properties See Also Send Feedback
EC3 Steel Connection Design Library

The BoltedEndPlate type exposes the following members.

Constructors

Name | Description
BoltedEndPlate | Initializes a new instance of the BoltedEndPlate class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FbRd | Bearing resistance of the bolt group
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FirstRowBelowUpperFlange | Checks if the given row is the first below the upper column flange
FvRd | Shear resistance of the bolt group
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns a list of strings that describe the input warnings regarding the bolt placement on the plate
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
px | Horizontal inner distance between bolts
py | Vertical inner distance for a bolt row
RowInsideFlanges | Checks if a bolt row is located along the beam height
RowOnBeamHeight | Checks if the bolt row is located along the beam height
RowOnHaunchHeight | Checks if the bolt row is located along the haunch height
RowOutsideUpperFlange | Checks if a bolt row is located outside the upper beam flange
Rows | Total bolt rows count
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalRowDistances | Calculation of the distance of each row from the upper edge of the endplate

Fields

Name | Description
b | Width
Bolts | Bolts object
ex | Horizontal edge distance
ey2 | Vertical distance between first bolt row above lower beam flange and outer bolt row below the beam flange
ey3 | Vertical distance between first bolt row below upper beam flange and outer bolt row above the beam flange
h | Height
h_over | Distance between the upper beam flange and the upper endplate edge
RowAbove | True, if there is a bolt row above the upper beam flange
RowBelow | True, if there is a bolt row below the lower beam flange
RowsInside | Number of bolt rows inside column flanges
Steel | Steel grade object
t | Thickness

Properties

Name | Description
BoltsNr | Total bolts count
ey1 | Vertical distance between bolt row below lower beam flange and endplate edge
ey4 | Vertical distance between bolt row above upper beam flange and endplate edge

See Also

BoltedEndPlate Class


BoltedEndPlate Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate Constructor
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the BoltedEndPlate class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BoltedEndPlate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoltedEndPlate()

See Also

BoltedEndPlate Class


BoltedEndPlate Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate Fields
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library

The BoltedEndPlate type exposes the following members.

Fields

Name | Description
b | Width
Bolts | Bolts object
ex | Horizontal edge distance
ey2 | Vertical distance between first bolt row above lower beam flange and outer bolt row below the beam flange
ey3 | Vertical distance between first bolt row below upper beam flange and outer bolt row above the beam flange
h | Height
h_over | Distance between the upper beam flange and the upper endplate edge
RowAbove | True, if there is a bolt row above the upper beam flange
RowBelow | True, if there is a bolt row below the lower beam flange
RowsInside | Number of bolt rows inside column flanges
Steel | Steel grade object
t | Thickness

See Also

BoltedEndPlate Class


b Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.b Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Width

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double b
Visual Basic (Declaration)
Public b As Double
Visual C++
public:
double b

Remarks

See Also

BoltedEndPlate Class


Bolts Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.Bolts Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Bolts Bolts
Visual Basic (Declaration)
Public Bolts As Bolts
Visual C++
public:
Bolts^ Bolts

Remarks

See Also

BoltedEndPlate Class


ex Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.ex Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Horizontal edge distance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ex
Visual Basic (Declaration)
Public ex As Double
Visual C++
public:
double ex

Remarks

See Also

BoltedEndPlate Class


ey2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.ey2 Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Vertical distance between first bolt row above lower beam flange and outer bolt row below the beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ey2
Visual Basic (Declaration)
Public ey2 As Double
Visual C++
public:
double ey2

Remarks

See Also

BoltedEndPlate Class


ey3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.ey3 Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Vertical distance between first bolt row below upper beam flange and outer bolt row above the beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ey3
Visual Basic (Declaration)
Public ey3 As Double
Visual C++
public:
double ey3

Remarks

See Also

BoltedEndPlate Class


h Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.h Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double h
Visual Basic (Declaration)
Public h As Double
Visual C++
public:
double h

Remarks

See Also

BoltedEndPlate Class


h_over Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.h_over Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Distance between the upper beam flange and the upper endplate edge

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double h_over
Visual Basic (Declaration)
Public h_over As Double
Visual C++
public:
double h_over

Remarks

See Also

BoltedEndPlate Class


RowAbove Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.RowAbove Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if there is a bolt row above the upper beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RowAbove
Visual Basic (Declaration)
Public RowAbove As Boolean
Visual C++
public:
bool RowAbove

Remarks

See Also

BoltedEndPlate Class


RowBelow Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.RowBelow Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if there is a bolt row below the lower beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RowBelow
Visual Basic (Declaration)
Public RowBelow As Boolean
Visual C++
public:
bool RowBelow

Remarks

See Also

BoltedEndPlate Class


RowsInside Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.RowsInside Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Number of bolt rows inside column flanges

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int RowsInside
Visual Basic (Declaration)
Public RowsInside As Integer
Visual C++
public:
int RowsInside

Remarks

See Also

BoltedEndPlate Class


Steel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.Steel Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Steel grade object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade Steel
Visual Basic (Declaration)
Public Steel As SteelGrade
Visual C++
public:
SteelGrade^ Steel

Remarks

See Also

BoltedEndPlate Class


t Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.t Field
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double t
Visual Basic (Declaration)
Public t As Double
Visual C++
public:
double t

Remarks

See Also

BoltedEndPlate Class


BoltedEndPlate Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate Methods
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library

The BoltedEndPlate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FbRd | Bearing resistance of the bolt group
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FirstRowBelowUpperFlange | Checks if the given row is the first below the upper column flange
FvRd | Shear resistance of the bolt group
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns a list of strings that describe the input warnings regarding the bolt placement on the plate
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
px | Horizontal inner distance between bolts
py | Vertical inner distance for a bolt row
RowInsideFlanges | Checks if a bolt row is located along the beam height
RowOnBeamHeight | Checks if the bolt row is located along the beam height
RowOnHaunchHeight | Checks if the bolt row is located along the haunch height
RowOutsideUpperFlange | Checks if a bolt row is located outside the upper beam flange
Rows | Total bolt rows count
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalRowDistances | Calculation of the distance of each row from the upper edge of the endplate

See Also

BoltedEndPlate Class


FbRd Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.FbRd Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Bearing resistance of the bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FbRd(
    BoltedEndPlate..::.LoadTransferEndPlate _LoadTransefr,
    double t_other_plate
)
Visual Basic (Declaration)
Public Function FbRd ( _
    _LoadTransefr As BoltedEndPlate..::.LoadTransferEndPlate, _
    t_other_plate As Double _
) As Double
Visual C++
public:
double FbRd(
    BoltedEndPlate..::.LoadTransferEndPlate _LoadTransefr,
    double t_other_plate
)

Parameters

_LoadTransefr
Type: SteelConnectionsEC3..::.BoltedEndPlate..::.LoadTransferEndPlate
Load transfer direction
t_other_plate
Type: System..::.Double
The thickness of another plate to consider (if any)

Return Value

Bearing resistance

Remarks

See Also

BoltedEndPlate Class


FirstRowBelowUpperFlange Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.FirstRowBelowUpperFlange Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Checks if the given row is the first below the upper column flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool FirstRowBelowUpperFlange(
    int row
)
Visual Basic (Declaration)
Public Function FirstRowBelowUpperFlange ( _
    row As Integer _
) As Boolean
Visual C++
public:
bool FirstRowBelowUpperFlange(
    int row
)

Parameters

row
Type: System..::.Int32
The bolt row, starting from the top row(=1)

Return Value

True, if the bolt row is located outside the column height

Remarks

See Also

BoltedEndPlate Class


FvRd Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.FvRd Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FvRd()
Visual Basic (Declaration)
Public Function FvRd As Double
Visual C++
public:
double FvRd()

Return Value

Shear resistance

Remarks

See Also

BoltedEndPlate Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.GetInputWarnings Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns a list of strings that describe the input warnings regarding the bolt placement on the plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> GetInputWarnings(
    BoltedEndPlate..::.LoadTransferEndPlate LoadTransfer
)
Visual Basic (Declaration)
Public Function GetInputWarnings ( _
    LoadTransfer As BoltedEndPlate..::.LoadTransferEndPlate _
) As List(Of String)
Visual C++
public:
List<String^>^ GetInputWarnings(
    BoltedEndPlate..::.LoadTransferEndPlate LoadTransfer
)

Parameters

LoadTransfer
Type: SteelConnectionsEC3..::.BoltedEndPlate..::.LoadTransferEndPlate
LoadTransferEndPlate object

Return Value

List of warnings

Remarks

See Also

BoltedEndPlate Class


px Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.px Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Horizontal inner distance between bolts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double px()
Visual Basic (Declaration)
Public Function px As Double
Visual C++
public:
double px()

Return Value

The horizontal distance between the bolts

Remarks

See Also

BoltedEndPlate Class


py Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.py Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Vertical inner distance for a bolt row

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double py(
    int row
)
Visual Basic (Declaration)
Public Function py ( _
    row As Integer _
) As Double
Visual C++
public:
double py(
    int row
)

Parameters

row
Type: System..::.Int32
The bolt row, starting from the top row(=1)

Return Value

The vertical distance between the bolts

Remarks

Calculates the half of the sum of the distances between the given row, its previous and its next rows

See Also

BoltedEndPlate Class


RowInsideFlanges Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.RowInsideFlanges Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Checks if a bolt row is located along the beam height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RowInsideFlanges(
    int row
)
Visual Basic (Declaration)
Public Function RowInsideFlanges ( _
    row As Integer _
) As Boolean
Visual C++
public:
bool RowInsideFlanges(
    int row
)

Parameters

row
Type: System..::.Int32
The bolt row, starting from the top row(=1)

Return Value

True, if the bolt row is located along the beam height

Remarks

See Also

BoltedEndPlate Class


RowOnBeamHeight Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.RowOnBeamHeight Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Checks if the bolt row is located along the beam height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RowOnBeamHeight(
    int Row,
    double hBeam,
    double hHaunch
)
Visual Basic (Declaration)
Public Function RowOnBeamHeight ( _
    Row As Integer, _
    hBeam As Double, _
    hHaunch As Double _
) As Boolean
Visual C++
public:
bool RowOnBeamHeight(
    int Row,
    double hBeam,
    double hHaunch
)

Parameters

Row
Type: System..::.Int32
Row to check
hBeam
Type: System..::.Double
Beam height
hHaunch
Type: System..::.Double
Haunch height, if any

Return Value

True, if the bolt row is located along the beam height

Remarks

See Also

BoltedEndPlate Class


RowOnHaunchHeight Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.RowOnHaunchHeight Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Checks if the bolt row is located along the haunch height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RowOnHaunchHeight(
    int Row,
    double hBeam,
    double hHaunch
)
Visual Basic (Declaration)
Public Function RowOnHaunchHeight ( _
    Row As Integer, _
    hBeam As Double, _
    hHaunch As Double _
) As Boolean
Visual C++
public:
bool RowOnHaunchHeight(
    int Row,
    double hBeam,
    double hHaunch
)

Parameters

Row
Type: System..::.Int32
Row to check
hBeam
Type: System..::.Double
Beam height
hHaunch
Type: System..::.Double
Haunch height, if any

Return Value

True, if the bolt row is located along the haunch height

Remarks

See Also

BoltedEndPlate Class


RowOutsideUpperFlange Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.RowOutsideUpperFlange Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Checks if a bolt row is located outside the upper beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RowOutsideUpperFlange(
    int row
)
Visual Basic (Declaration)
Public Function RowOutsideUpperFlange ( _
    row As Integer _
) As Boolean
Visual C++
public:
bool RowOutsideUpperFlange(
    int row
)

Parameters

row
Type: System..::.Int32
The bolt row, starting from the top row(=1)

Return Value

True, if the bolt row is located outside the upper beam flange

Remarks

See Also

BoltedEndPlate Class


Rows Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.Rows Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Total bolt rows count

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Rows()
Visual Basic (Declaration)
Public Function Rows As Object
Visual C++
public:
Object^ Rows()

Return Value

Remarks

Count of total bolt rows

See Also

BoltedEndPlate Class


VerticalRowDistances Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.VerticalRowDistances Method
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Calculation of the distance of each row from the upper edge of the endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<double> VerticalRowDistances()
Visual Basic (Declaration)
Public Function VerticalRowDistances As List(Of Double)
Visual C++
public:
List<double>^ VerticalRowDistances()

Return Value

A list of doubles that contains the distance of each row from the upper edge of the endplate

Remarks

See Also

BoltedEndPlate Class


BoltedEndPlate Properties

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate Properties
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library

The BoltedEndPlate type exposes the following members.

Properties

Name | Description
BoltsNr | Total bolts count
ey1 | Vertical distance between bolt row below lower beam flange and endplate edge
ey4 | Vertical distance between bolt row above upper beam flange and endplate edge

See Also

BoltedEndPlate Class


BoltsNr Property

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.BoltsNr Property
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Total bolts count

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int BoltsNr { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoltsNr As Integer
Visual C++
public:
property int BoltsNr {
    int get ();
}

Field Value

Return Value

Count of total bolts

Remarks

See Also

BoltedEndPlate Class


ey1 Property

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.ey1 Property
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Vertical distance between bolt row below lower beam flange and endplate edge

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ey1 { get; set; }
Visual Basic (Declaration)
Public Property ey1 As Double
Visual C++
public:
property double ey1 {
    double get ();
    void set (double value);
}

Field Value

Return Value

Remarks

If there is no bolt row below the column, zero value is returned

See Also

BoltedEndPlate Class


ey4 Property

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.ey4 Property
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Vertical distance between bolt row above upper beam flange and endplate edge

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ey4 { get; set; }
Visual Basic (Declaration)
Public Property ey4 As Double
Visual C++
public:
property double ey4 {
    double get ();
    void set (double value);
}

Field Value

Return Value

Remarks

If there is no bolt row below the column, zero value is returned

See Also

BoltedEndPlate Class


BoltedEndPlate.LoadTransferEndPlate Enumeration

[image]

ENGISSOL - EC3 Steel Connection Design Library
BoltedEndPlate..::.LoadTransferEndPlate Enumeration
BoltedEndPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Represents the load direction transferred from the beam to the endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum LoadTransferEndPlate
Visual Basic (Declaration)
Public Enumeration LoadTransferEndPlate
Visual C++
public enum class LoadTransferEndPlate

Members

Member name | Description
Up | Load transfer upwards
Down | Load transfer downwards
Right | Load transfer rightwards
Left | Load transfer leftwards

Remarks

See Also

SteelConnectionsEC3 Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


Bolts Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a bolt

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Bolts
Visual Basic (Declaration)
Public Class Bolts
Visual C++
public ref class Bolts

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.Bolts

See Also

Bolts Members


Bolts Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts Members
Bolts Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The Bolts type exposes the following members.

Constructors

Name | Description
Bolts | Bolt object construction

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BoltGrade | Bolt grade
BoltType | Bolt type
OverSizeHoles | True if oversized holes will be used for this bolt

See Also

Bolts Class


Bolts Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts Constructor
Bolts Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolt object construction

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Bolts(
    Bolts..::.Type _type,
    Bolts..::.Grade _grade,
    bool _OverSizeHoles
)
Visual Basic (Declaration)
Public Sub New ( _
    _type As Bolts..::.Type, _
    _grade As Bolts..::.Grade, _
    _OverSizeHoles As Boolean _
)
Visual C++
public:
Bolts(
    Bolts..::.Type _type,
    Bolts..::.Grade _grade,
    bool _OverSizeHoles
)

Parameters

_type
Type: SteelConnectionsEC3..::.Bolts..::.Type
Bolt type
_grade
Type: SteelConnectionsEC3..::.Bolts..::.Grade
Bolt grade
_OverSizeHoles
Type: System..::.Boolean
True if oversized holes will be used

Remarks

See Also

Bolts Class


Bolts Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts Fields
Bolts Class See Also Send Feedback
EC3 Steel Connection Design Library

The Bolts type exposes the following members.

Fields

Name | Description
BoltGrade | Bolt grade
BoltType | Bolt type
OverSizeHoles | True if oversized holes will be used for this bolt

See Also

Bolts Class


BoltGrade Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts..::.BoltGrade Field
Bolts Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolt grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Bolts..::.Grade BoltGrade
Visual Basic (Declaration)
Public BoltGrade As Bolts..::.Grade
Visual C++
public:
Bolts..::.Grade BoltGrade

See Also

Bolts Class


BoltType Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts..::.BoltType Field
Bolts Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolt type

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Bolts..::.Type BoltType
Visual Basic (Declaration)
Public BoltType As Bolts..::.Type
Visual C++
public:
Bolts..::.Type BoltType

See Also

Bolts Class


OverSizeHoles Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts..::.OverSizeHoles Field
Bolts Class See Also Send Feedback
EC3 Steel Connection Design Library
True if oversized holes will be used for this bolt

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool OverSizeHoles
Visual Basic (Declaration)
Public OverSizeHoles As Boolean
Visual C++
public:
bool OverSizeHoles

See Also

Bolts Class


Bolts Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts Methods
Bolts Class See Also Send Feedback
EC3 Steel Connection Design Library

The Bolts type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Bolts Class


Bolts.Grade Enumeration

[image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts..::.Grade Enumeration
Bolts Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolt grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Grade
Visual Basic (Declaration)
Public Enumeration Grade
Visual C++
public enum class Grade

Members

Member name | Description
g4_6 | Bolt grade 4.6
g4_8 | Bolt grade 4.8
g5_6 | Bolt grade 5.6
g5_8 | Bolt grade 5.8
g6_8 | Bolt grade 6.8
g8_8 | Bolt grade 8.8
g10_9 | Bolt grade 10.9

Remarks

See Also

SteelConnectionsEC3 Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


Bolts.Type Enumeration

[image]

ENGISSOL - EC3 Steel Connection Design Library
Bolts..::.Type Enumeration
Bolts Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolt type

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Type
Visual Basic (Declaration)
Public Enumeration Type
Visual C++
public enum class Type

Members

Member name | Description
M12 | Bolt type M12
M16 | Bolt type M16
M20 | Bolt type M20
M22 | Bolt type M22
M24 | Bolt type M24
M27 | Bolt type M27
M30 | Bolt type M30
M36 | Bolt type M36

Remarks

See Also

SteelConnectionsEC3 Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


CHSChordConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Hollow section joints between CHS members according to 7.4 [prEN 1993-1-8 : 2003]

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CHSChordConnection
Visual Basic (Declaration)
Public Class CHSChordConnection
Visual C++
public ref class CHSChordConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.CHSChordConnection

See Also

CHSChordConnection Members


CHSChordConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection Members
CHSChordConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The CHSChordConnection type exposes the following members.

Constructors

Name | Description
CHSChordConnection | Initializes a new instance of the CHSChordConnection class

Methods

Name | Description
AxialResistance_Type1 | Type 1 joint calculation Variables definition:
AxialResistance_Type2 | Type 2 joint calculation Variables definition:
AxialResistance_Type3 | Type 3 joint calculation Variables definition:
AxialResistance_Type4 | Type 4 joint calculation Variables definition:
AxialResistance_Type5 | Type 5 joint calculation Variables definition:
AxialResistance_Type6 | Type 6 joint calculation Variables definition:
AxialResistance_Type7 | Type 7 joint calculation Variables definition:
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Chord | Chord object
ChordSteel | Chord steel grade
GeometryRangeOfValidity_OK | True, if the geometry is within the range of validity of table 7.1, otherwise false Variables definition:
MEd0 | Chord bending moment
NEd0 | Chord axial force (compressive)
VEd0 | Chord shear force

See Also

CHSChordConnection Class


CHSChordConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection Constructor
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the CHSChordConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CHSChordConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CHSChordConnection()

See Also

CHSChordConnection Class


CHSChordConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection Fields
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The CHSChordConnection type exposes the following members.

Fields

Name | Description
Chord | Chord object
ChordSteel | Chord steel grade
GeometryRangeOfValidity_OK | True, if the geometry is within the range of validity of table 7.1, otherwise false Variables definition:
MEd0 | Chord bending moment
NEd0 | Chord axial force (compressive)
VEd0 | Chord shear force

See Also

CHSChordConnection Class


Chord Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.Chord Field
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CHS Chord
Visual Basic (Declaration)
Public Chord As CHS
Visual C++
public:
CHS^ Chord

Remarks

See Also

CHSChordConnection Class


ChordSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.ChordSteel Field
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade ChordSteel
Visual Basic (Declaration)
Public ChordSteel As SteelGrade
Visual C++
public:
SteelGrade^ ChordSteel

Remarks

See Also

CHSChordConnection Class


GeometryRangeOfValidity_OK Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.GeometryRangeOfValidity_OK Field
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the geometry is within the range of validity of table 7.1, otherwise false

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GeometryRangeOfValidity_OK
Visual Basic (Declaration)
Public GeometryRangeOfValidity_OK As Boolean
Visual C++
public:
bool GeometryRangeOfValidity_OK

Remarks

This is an output variable

See Also

CHSChordConnection Class


MEd0 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.MEd0 Field
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord bending moment

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MEd0
Visual Basic (Declaration)
Public MEd0 As Double
Visual C++
public:
double MEd0

Remarks

See Also

CHSChordConnection Class


NEd0 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.NEd0 Field
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord axial force (compressive)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double NEd0
Visual Basic (Declaration)
Public NEd0 As Double
Visual C++
public:
double NEd0

Remarks

See Also

CHSChordConnection Class


VEd0 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.VEd0 Field
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord shear force

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VEd0
Visual Basic (Declaration)
Public VEd0 As Double
Visual C++
public:
double VEd0

Remarks

See Also

CHSChordConnection Class


CHSChordConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection Methods
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The CHSChordConnection type exposes the following members.

Methods

Name | Description
AxialResistance_Type1 | Type 1 joint calculation Variables definition:
AxialResistance_Type2 | Type 2 joint calculation Variables definition:
AxialResistance_Type3 | Type 3 joint calculation Variables definition:
AxialResistance_Type4 | Type 4 joint calculation Variables definition:
AxialResistance_Type5 | Type 5 joint calculation Variables definition:
AxialResistance_Type6 | Type 6 joint calculation Variables definition:
AxialResistance_Type7 | Type 7 joint calculation Variables definition:
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CHSChordConnection Class


AxialResistance_Type1 Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.AxialResistance_Type1 Method
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 1 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type1(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel
)
Visual Basic (Declaration)
Public Function AxialResistance_Type1 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade _
) As Boolean
Visual C++
public:
bool AxialResistance_Type1(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1 (compressive)
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel

Return Value

True, if all resistance criteria are met

Remarks

N1 positive signing accoring to table 7.2

See Also

CHSChordConnection Class


AxialResistance_Type2 Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.AxialResistance_Type2 Method
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 2 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type2(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel
)
Visual Basic (Declaration)
Public Function AxialResistance_Type2 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade _
) As Boolean
Visual C++
public:
bool AxialResistance_Type2(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1 (compressive)
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel

Return Value

True, if all resistance criteria are met

Remarks

N1 positive signing accoring to table 7.2

See Also

CHSChordConnection Class


AxialResistance_Type3 Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.AxialResistance_Type3 Method
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 3 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type3(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel,
    CHS Brace2,
    double theta2,
    double N2,
    SteelGrade Brace2Steel,
    double g,
    double p,
    double q,
    bool GapJoint
)
Visual Basic (Declaration)
Public Function AxialResistance_Type3 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade, _
    Brace2 As CHS, _
    theta2 As Double, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    g As Double, _
    p As Double, _
    q As Double, _
    GapJoint As Boolean _
) As Boolean
Visual C++
public:
bool AxialResistance_Type3(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel,
    CHS^ Brace2,
    double theta2,
    double N2,
    SteelGrade^ Brace2Steel,
    double g,
    double p,
    double q,
    bool GapJoint
)

Parameters

Brace1
Type: CHS
Brace 1 object (overlapping member in case of overlap connection)
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
Brace2
Type: CHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
g
Type: System..::.Double
gap length

Variables definition:

>
p
Type: System..::.Double
overlapped distance p

q
Type: System..::.Double
overlapping length q

GapJoint
Type: System..::.Boolean
True, in case of gap joint, otherwise overlapped joint

Return Value

True, if all resistance criteria are met

Remarks

N1,N2 positive signing accoring to table 7.2

See Also

CHSChordConnection Class


AxialResistance_Type4 Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.AxialResistance_Type4 Method
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 4 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type4(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel
)
Visual Basic (Declaration)
Public Function AxialResistance_Type4 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade _
) As Boolean
Visual C++
public:
bool AxialResistance_Type4(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel

Return Value

True, if all resistance criteria are met

Remarks

N1 positive signing accoring to table 7.6

See Also

CHSChordConnection Class


AxialResistance_Type5 Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.AxialResistance_Type5 Method
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 5 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type5(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel,
    CHS Brace2,
    double theta2,
    double N2,
    SteelGrade Brace2Steel,
    CHS Brace3,
    double theta3,
    double N3,
    SteelGrade Brace3Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type5 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade, _
    Brace2 As CHS, _
    theta2 As Double, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    Brace3 As CHS, _
    theta3 As Double, _
    N3 As Double, _
    Brace3Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type5(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel,
    CHS^ Brace2,
    double theta2,
    double N2,
    SteelGrade^ Brace2Steel,
    CHS^ Brace3,
    double theta3,
    double N3,
    SteelGrade^ Brace3Steel,
    double g
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
Brace2
Type: CHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
Brace3
Type: CHS
Brace 3 object
theta3
Type: System..::.Double
Angle of brace 3
N3
Type: System..::.Double
Axial force of brace 3 (compressive)
Brace3Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 3 steel
g
Type: System..::.Double
gap length

Variables definition:

Return Value

True, if all resistance criteria are met

Remarks

N1, N2, N3 positive signing accoring to table 7.6

See Also

CHSChordConnection Class


AxialResistance_Type6 Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.AxialResistance_Type6 Method
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 6 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type6(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel,
    CHS Brace2,
    double theta2,
    double N2,
    SteelGrade Brace2Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type6 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade, _
    Brace2 As CHS, _
    theta2 As Double, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type6(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel,
    CHS^ Brace2,
    double theta2,
    double N2,
    SteelGrade^ Brace2Steel,
    double g
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
Brace2
Type: CHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
g
Type: System..::.Double
Not important for this function, it is used to have simmilar signature to AxialResistance_Type7

Variables definition:

Return Value

True, if all resistance criteria are met

Remarks

N1, N2 positive signing accoring to table 7.6, this joint is a gap joint

See Also

CHSChordConnection Class


AxialResistance_Type7 Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
CHSChordConnection..::.AxialResistance_Type7 Method
CHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 7 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type7(
    CHS Brace1,
    double theta1,
    double N1,
    CHS Brace2,
    double theta2,
    SteelGrade Brace1Steel,
    double N2,
    SteelGrade Brace2Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type7 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace2 As CHS, _
    theta2 As Double, _
    Brace1Steel As SteelGrade, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type7(
    CHS^ Brace1,
    double theta1,
    double N1,
    CHS^ Brace2,
    double theta2,
    SteelGrade^ Brace1Steel,
    double N2,
    SteelGrade^ Brace2Steel,
    double g
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace2
Type: CHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
g
Type: System..::.Double
gap

Return Value

True, if all resistance criteria are met

Remarks

N1, N2 positive signing accoring to table 7.6, this joint is a gap joint

See Also

CHSChordConnection Class


ColumnBaseplateConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a column base connection by means of a baseplate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColumnBaseplateConnection
Visual Basic (Declaration)
Public Class ColumnBaseplateConnection
Visual C++
public ref class ColumnBaseplateConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.ColumnBaseplateConnection

See Also

ColumnBaseplateConnection Members


ColumnBaseplateConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection Members
ColumnBaseplateConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The ColumnBaseplateConnection type exposes the following members.

Constructors

Name | Description
ColumnBaseplateConnection | Initializes a new instance of the ColumnBaseplateConnection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
af | Concrete footing length
afl | Weld thickness between column flange and baseplate
ast_col | Weld thickness between stiffeners and column, if stiffeners used
ast_pl | Weld thickness between stiffeners and baseplate, if stiffeners used
aw | Weld thickness between column web and baseplate
bf | Concrete footing width
c1 | Distances for the placement of baseplate on footing
c2 |
Column | Column object
ColumnSteel | Column steel grade
Ec | Concrete elasticity modulus in kN/mm^2
fck | Characteristic concrete strength in kN/mm^2
fgk | Characteristic grout strength
grout_t | Grout thickness
hf | Concrete footing height
hst | Stiffeners height
LoadCases | Load cases of the beam
Plate | Baseplate object
Results | List of results
tst | Stiffeners thickness
UseOfStiffeners | Trus, if stiffeners are used, otherwise false

See Also

ColumnBaseplateConnection Class


ColumnBaseplateConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection Constructor
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the ColumnBaseplateConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColumnBaseplateConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColumnBaseplateConnection()

See Also

ColumnBaseplateConnection Class


ColumnBaseplateConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection Fields
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The ColumnBaseplateConnection type exposes the following members.

Fields

Name | Description
af | Concrete footing length
afl | Weld thickness between column flange and baseplate
ast_col | Weld thickness between stiffeners and column, if stiffeners used
ast_pl | Weld thickness between stiffeners and baseplate, if stiffeners used
aw | Weld thickness between column web and baseplate
bf | Concrete footing width
c1 | Distances for the placement of baseplate on footing
c2 |
Column | Column object
ColumnSteel | Column steel grade
Ec | Concrete elasticity modulus in kN/mm^2
fck | Characteristic concrete strength in kN/mm^2
fgk | Characteristic grout strength
grout_t | Grout thickness
hf | Concrete footing height
hst | Stiffeners height
LoadCases | Load cases of the beam
Plate | Baseplate object
Results | List of results
tst | Stiffeners thickness
UseOfStiffeners | Trus, if stiffeners are used, otherwise false

See Also

ColumnBaseplateConnection Class


af Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.af Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Concrete footing length

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double af
Visual Basic (Declaration)
Public af As Double
Visual C++
public:
double af

Remarks

See Also

ColumnBaseplateConnection Class


afl Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.afl Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between column flange and baseplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double afl
Visual Basic (Declaration)
Public afl As Double
Visual C++
public:
double afl

Remarks

See Also

ColumnBaseplateConnection Class


ast_col Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.ast_col Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between stiffeners and column, if stiffeners used

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ast_col
Visual Basic (Declaration)
Public ast_col As Double
Visual C++
public:
double ast_col

Remarks

See Also

ColumnBaseplateConnection Class


ast_pl Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.ast_pl Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between stiffeners and baseplate, if stiffeners used

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ast_pl
Visual Basic (Declaration)
Public ast_pl As Double
Visual C++
public:
double ast_pl

Remarks

See Also

ColumnBaseplateConnection Class


aw Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.aw Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between column web and baseplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double aw
Visual Basic (Declaration)
Public aw As Double
Visual C++
public:
double aw

Remarks

See Also

ColumnBaseplateConnection Class


bf Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.bf Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Concrete footing width

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double bf
Visual Basic (Declaration)
Public bf As Double
Visual C++
public:
double bf

Remarks

See Also

ColumnBaseplateConnection Class


c1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.c1 Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Distances for the placement of baseplate on footing

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double c1
Visual Basic (Declaration)
Public c1 As Double
Visual C++
public:
double c1

Remarks

See Also

ColumnBaseplateConnection Class


c2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.c2 Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double c2
Visual Basic (Declaration)
Public c2 As Double
Visual C++
public:
double c2

See Also

ColumnBaseplateConnection Class


Column Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.Column Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HSection Column
Visual Basic (Declaration)
Public Column As HSection
Visual C++
public:
HSection^ Column

Remarks

See Also

ColumnBaseplateConnection Class


ColumnSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.ColumnSteel Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Column steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade ColumnSteel
Visual Basic (Declaration)
Public ColumnSteel As SteelGrade
Visual C++
public:
SteelGrade^ ColumnSteel

Remarks

See Also

ColumnBaseplateConnection Class


Ec Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.Ec Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Concrete elasticity modulus in kN/mm^2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ec
Visual Basic (Declaration)
Public Ec As Double
Visual C++
public:
double Ec

Remarks

See Also

ColumnBaseplateConnection Class


fck Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.fck Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Characteristic concrete strength in kN/mm^2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double fck
Visual Basic (Declaration)
Public fck As Double
Visual C++
public:
double fck

Remarks

See Also

ColumnBaseplateConnection Class


fgk Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.fgk Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Characteristic grout strength

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double fgk
Visual Basic (Declaration)
Public fgk As Double
Visual C++
public:
double fgk

Remarks

See Also

ColumnBaseplateConnection Class


grout_t Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.grout_t Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Grout thickness

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double grout_t
Visual Basic (Declaration)
Public grout_t As Double
Visual C++
public:
double grout_t

Remarks

See Also

ColumnBaseplateConnection Class


hf Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.hf Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Concrete footing height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hf
Visual Basic (Declaration)
Public hf As Double
Visual C++
public:
double hf

Remarks

See Also

ColumnBaseplateConnection Class


hst Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.hst Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Stiffeners height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hst
Visual Basic (Declaration)
Public hst As Double
Visual C++
public:
double hst

Remarks

See Also

ColumnBaseplateConnection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.LoadCases Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the beam

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ned (positive=compressive), WARNING: Ned has to be positive!!

Ved (positive=downwards)

Med (sign does nor matter)

See Also

ColumnBaseplateConnection Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.Plate Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Baseplate object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BoltedBasePlate Plate
Visual Basic (Declaration)
Public Plate As BoltedBasePlate
Visual C++
public:
BoltedBasePlate^ Plate

Remarks

See Also

ColumnBaseplateConnection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.Results Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<ColumnBaseplateConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of ColumnBaseplateConnectionResults)
Visual C++
public:
List<ColumnBaseplateConnectionResults^>^ Results

Remarks

See Also

ColumnBaseplateConnection Class


tst Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.tst Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Stiffeners thickness

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tst
Visual Basic (Declaration)
Public tst As Double
Visual C++
public:
double tst

Remarks

See Also

ColumnBaseplateConnection Class


UseOfStiffeners Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.UseOfStiffeners Field
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Trus, if stiffeners are used, otherwise false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseOfStiffeners
Visual Basic (Declaration)
Public UseOfStiffeners As Boolean
Visual C++
public:
bool UseOfStiffeners

Remarks

See Also

ColumnBaseplateConnection Class


ColumnBaseplateConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection Methods
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The ColumnBaseplateConnection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnBaseplateConnection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.Calculate Method
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

ColumnBaseplateConnection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnection..::.GetInputWarnings Method
ColumnBaseplateConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColumnBaseplateConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As ColumnBaseplateConnectionInputWarnings
Visual C++
public:
ColumnBaseplateConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

ColumnBaseplateConnection Class


ColumnBaseplateConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColumnBaseplateConnectionInputWarnings
Visual Basic (Declaration)
Public Class ColumnBaseplateConnectionInputWarnings
Visual C++
public ref class ColumnBaseplateConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.ColumnBaseplateConnectionInputWarnings

See Also

ColumnBaseplateConnectionInputWarnings Members


ColumnBaseplateConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionInputWarnings Members
ColumnBaseplateConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The ColumnBaseplateConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
ColumnBaseplateConnectionInputWarnings | Initializes a new instance of the ColumnBaseplateConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the baseplate
Welds | Input warnings regarding welds

See Also

ColumnBaseplateConnectionInputWarnings Class


ColumnBaseplateConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionInputWarnings Constructor
ColumnBaseplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the ColumnBaseplateConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColumnBaseplateConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColumnBaseplateConnectionInputWarnings()

See Also

ColumnBaseplateConnectionInputWarnings Class


ColumnBaseplateConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionInputWarnings Fields
ColumnBaseplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The ColumnBaseplateConnectionInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the baseplate
Welds | Input warnings regarding welds

See Also

ColumnBaseplateConnectionInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionInputWarnings..::.Other Field
ColumnBaseplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

ColumnBaseplateConnectionInputWarnings Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionInputWarnings..::.Plate Field
ColumnBaseplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the baseplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Plate
Visual Basic (Declaration)
Public Plate As List(Of String)
Visual C++
public:
List<String^>^ Plate

Remarks

See Also

ColumnBaseplateConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionInputWarnings..::.Welds Field
ColumnBaseplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

ColumnBaseplateConnectionInputWarnings Class


ColumnBaseplateConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionInputWarnings Methods
ColumnBaseplateConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The ColumnBaseplateConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnBaseplateConnectionInputWarnings Class


ColumnBaseplateConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColumnBaseplateConnectionResults
Visual Basic (Declaration)
Public Class ColumnBaseplateConnectionResults
Visual C++
public ref class ColumnBaseplateConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.ColumnBaseplateConnectionResults

See Also

ColumnBaseplateConnectionResults Members


ColumnBaseplateConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults Members
ColumnBaseplateConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The ColumnBaseplateConnectionResults type exposes the following members.

Constructors

Name | Description
ColumnBaseplateConnectionResults | Initializes a new instance of the ColumnBaseplateConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AnchorInteractionCapacity | Anchor shear and tension interaction capacity
BearingCapacity | Bearing capacity of connection
BearingResistance | Bearing resistance of connection
MaxForceOfTensionAnchor | Maximum anchor tension force
MomentCapacity | Moment capacity of connection
MomentResistance | Moment resistance of connection
PlateWeldCapacity | Weld capacity between baseplate and column-stiffeners (if used)
PlateWeldResistance | Weld resistance between baseplate, column and stiffeners (if used)
ShearCapacity | Shear capacity of connection
ShearResistance | Shear resistance of connection
Sj | Rotational stiffness of the joint
StiffenerColumnWeldCapacity | Weld capacity between stiffeners and column, if stiffeners used
StiffenerColumnWeldResistance | Weld resistance between stiffeners and column, if stiffeners used

See Also

ColumnBaseplateConnectionResults Class


ColumnBaseplateConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults Constructor
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the ColumnBaseplateConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColumnBaseplateConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColumnBaseplateConnectionResults()

See Also

ColumnBaseplateConnectionResults Class


ColumnBaseplateConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults Fields
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The ColumnBaseplateConnectionResults type exposes the following members.

Fields

Name | Description
AnchorInteractionCapacity | Anchor shear and tension interaction capacity
BearingCapacity | Bearing capacity of connection
BearingResistance | Bearing resistance of connection
MaxForceOfTensionAnchor | Maximum anchor tension force
MomentCapacity | Moment capacity of connection
MomentResistance | Moment resistance of connection
PlateWeldCapacity | Weld capacity between baseplate and column-stiffeners (if used)
PlateWeldResistance | Weld resistance between baseplate, column and stiffeners (if used)
ShearCapacity | Shear capacity of connection
ShearResistance | Shear resistance of connection
Sj | Rotational stiffness of the joint
StiffenerColumnWeldCapacity | Weld capacity between stiffeners and column, if stiffeners used
StiffenerColumnWeldResistance | Weld resistance between stiffeners and column, if stiffeners used

See Also

ColumnBaseplateConnectionResults Class


AnchorInteractionCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.AnchorInteractionCapacity Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Anchor shear and tension interaction capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double AnchorInteractionCapacity
Visual Basic (Declaration)
Public AnchorInteractionCapacity As Double
Visual C++
public:
double AnchorInteractionCapacity

Remarks

See Also

ColumnBaseplateConnectionResults Class


BearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.BearingCapacity Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bearing capacity of connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BearingCapacity
Visual Basic (Declaration)
Public BearingCapacity As Double
Visual C++
public:
double BearingCapacity

Remarks

See Also

ColumnBaseplateConnectionResults Class


BearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.BearingResistance Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bearing resistance of connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BearingResistance
Visual Basic (Declaration)
Public BearingResistance As Double
Visual C++
public:
double BearingResistance

Remarks

See Also

ColumnBaseplateConnectionResults Class


MaxForceOfTensionAnchor Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.MaxForceOfTensionAnchor Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Maximum anchor tension force

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MaxForceOfTensionAnchor
Visual Basic (Declaration)
Public MaxForceOfTensionAnchor As Double
Visual C++
public:
double MaxForceOfTensionAnchor

Remarks

See Also

ColumnBaseplateConnectionResults Class


MomentCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.MomentCapacity Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment capacity of connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentCapacity
Visual Basic (Declaration)
Public MomentCapacity As Double
Visual C++
public:
double MomentCapacity

Remarks

See Also

ColumnBaseplateConnectionResults Class


MomentResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.MomentResistance Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment resistance of connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentResistance
Visual Basic (Declaration)
Public MomentResistance As Double
Visual C++
public:
double MomentResistance

Remarks

See Also

ColumnBaseplateConnectionResults Class


PlateWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.PlateWeldCapacity Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity between baseplate and column-stiffeners (if used)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldCapacity
Visual Basic (Declaration)
Public PlateWeldCapacity As Double
Visual C++
public:
double PlateWeldCapacity

Remarks

See Also

ColumnBaseplateConnectionResults Class


PlateWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.PlateWeldResistance Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance between baseplate, column and stiffeners (if used)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldResistance
Visual Basic (Declaration)
Public PlateWeldResistance As Double
Visual C++
public:
double PlateWeldResistance

Remarks

See Also

ColumnBaseplateConnectionResults Class


ShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.ShearCapacity Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear capacity of connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearCapacity
Visual Basic (Declaration)
Public ShearCapacity As Double
Visual C++
public:
double ShearCapacity

Remarks

See Also

ColumnBaseplateConnectionResults Class


ShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.ShearResistance Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearResistance
Visual Basic (Declaration)
Public ShearResistance As Double
Visual C++
public:
double ShearResistance

Remarks

See Also

ColumnBaseplateConnectionResults Class


Sj Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.Sj Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Rotational stiffness of the joint

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Sj
Visual Basic (Declaration)
Public Sj As Double
Visual C++
public:
double Sj

Remarks

See Also

ColumnBaseplateConnectionResults Class


StiffenerColumnWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.StiffenerColumnWeldCapacity Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity between stiffeners and column, if stiffeners used

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double StiffenerColumnWeldCapacity
Visual Basic (Declaration)
Public StiffenerColumnWeldCapacity As Double
Visual C++
public:
double StiffenerColumnWeldCapacity

Remarks

See Also

ColumnBaseplateConnectionResults Class


StiffenerColumnWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults..::.StiffenerColumnWeldResistance Field
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance between stiffeners and column, if stiffeners used

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double StiffenerColumnWeldResistance
Visual Basic (Declaration)
Public StiffenerColumnWeldResistance As Double
Visual C++
public:
double StiffenerColumnWeldResistance

Remarks

See Also

ColumnBaseplateConnectionResults Class


ColumnBaseplateConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
ColumnBaseplateConnectionResults Methods
ColumnBaseplateConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The ColumnBaseplateConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnBaseplateConnectionResults Class


LoadCase Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
LoadCase Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a loadcase

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoadCase
Visual Basic (Declaration)
Public Class LoadCase
Visual C++
public ref class LoadCase

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.LoadCase

See Also

LoadCase Members


LoadCase Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
LoadCase Members
LoadCase Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The LoadCase type exposes the following members.

Constructors

Name | Description
LoadCase | Construction of the load case

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Med | Moment in kNmm
Name | Load case name
Ned | Axial force in kN
Ved | Shear force in kN

See Also

LoadCase Class


LoadCase Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
LoadCase Constructor
LoadCase Class See Also Send Feedback
EC3 Steel Connection Design Library
Construction of the load case

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoadCase(
    string _Name,
    double _N,
    double _V,
    double _M
)
Visual Basic (Declaration)
Public Sub New ( _
    _Name As String, _
    _N As Double, _
    _V As Double, _
    _M As Double _
)
Visual C++
public:
LoadCase(
    String^ _Name,
    double _N,
    double _V,
    double _M
)

Parameters

_Name
Type: System..::.String
Load case Name
_N
Type: System..::.Double
Axial force
_V
Type: System..::.Double
Sheae force
_M
Type: System..::.Double
Moment

Remarks

The positive convention depends on each connection

See Also

LoadCase Class


LoadCase Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
LoadCase Fields
LoadCase Class See Also Send Feedback
EC3 Steel Connection Design Library

The LoadCase type exposes the following members.

Fields

Name | Description
Med | Moment in kNmm
Name | Load case name
Ned | Axial force in kN
Ved | Shear force in kN

See Also

LoadCase Class


Med Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
LoadCase..::.Med Field
LoadCase Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment in kNmm

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Med
Visual Basic (Declaration)
Public Med As Double
Visual C++
public:
double Med

Remarks

See Also

LoadCase Class


Name Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
LoadCase..::.Name Field
LoadCase Class See Also Send Feedback
EC3 Steel Connection Design Library
Load case name

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name
Visual Basic (Declaration)
Public Name As String
Visual C++
public:
String^ Name

Remarks

See Also

LoadCase Class


Ned Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
LoadCase..::.Ned Field
LoadCase Class See Also Send Feedback
EC3 Steel Connection Design Library
Axial force in kN

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ned
Visual Basic (Declaration)
Public Ned As Double
Visual C++
public:
double Ned

Remarks

See Also

LoadCase Class


Ved Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
LoadCase..::.Ved Field
LoadCase Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear force in kN

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Ved
Visual Basic (Declaration)
Public Ved As Double
Visual C++
public:
double Ved

Remarks

See Also

LoadCase Class


LoadCase Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
LoadCase Methods
LoadCase Class See Also Send Feedback
EC3 Steel Connection Design Library

The LoadCase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCase Class


MemberOnJoint1Connection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a bolted connection between a member (single or double) and a plate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint1Connection
Visual Basic (Declaration)
Public Class MemberOnJoint1Connection
Visual C++
public ref class MemberOnJoint1Connection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint1Connection

See Also

MemberOnJoint1Connection Members


MemberOnJoint1Connection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection Members
MemberOnJoint1Connection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint1Connection type exposes the following members.

Constructors

Name | Description
MemberOnJoint1Connection | Initializes a new instance of the MemberOnJoint1Connection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
a1 | Thickness of horizontal plate welds
a2 | Thickness of vertical plate welds
angle | Member angle in degrees
BoltedMember | Corresponding bolted plate
bPlate |
DoubleSideMember | True, if double side member is used (for instance 2U), else false
hPlate | Plate dimansions
LoadCases | Load cases of the member
PlateSteel | Plate steel grade
Results | List of results
tPlate |

See Also

MemberOnJoint1Connection Class


MemberOnJoint1Connection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection Constructor
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint1Connection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint1Connection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint1Connection()

See Also

MemberOnJoint1Connection Class


MemberOnJoint1Connection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection Fields
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint1Connection type exposes the following members.

Fields

Name | Description
a1 | Thickness of horizontal plate welds
a2 | Thickness of vertical plate welds
angle | Member angle in degrees
BoltedMember | Corresponding bolted plate
bPlate |
DoubleSideMember | True, if double side member is used (for instance 2U), else false
hPlate | Plate dimansions
LoadCases | Load cases of the member
PlateSteel | Plate steel grade
Results | List of results
tPlate |

See Also

MemberOnJoint1Connection Class


a1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.a1 Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness of horizontal plate welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a1
Visual Basic (Declaration)
Public a1 As Double
Visual C++
public:
double a1

Remarks

See Also

MemberOnJoint1Connection Class


a2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.a2 Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness of vertical plate welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a2
Visual Basic (Declaration)
Public a2 As Double
Visual C++
public:
double a2

Remarks

See Also

MemberOnJoint1Connection Class


angle Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.angle Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member angle in degrees

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double angle
Visual Basic (Declaration)
Public angle As Double
Visual C++
public:
double angle

Remarks

See Also

MemberOnJoint1Connection Class


BoltedMember Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.BoltedMember Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Corresponding bolted plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate BoltedMember
Visual Basic (Declaration)
Public BoltedMember As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ BoltedMember

Remarks

See Also

MemberOnJoint1Connection Class


bPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.bPlate Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double bPlate
Visual Basic (Declaration)
Public bPlate As Double
Visual C++
public:
double bPlate

See Also

MemberOnJoint1Connection Class


DoubleSideMember Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.DoubleSideMember Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if double side member is used (for instance 2U), else false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DoubleSideMember
Visual Basic (Declaration)
Public DoubleSideMember As Boolean
Visual C++
public:
bool DoubleSideMember

Remarks

See Also

MemberOnJoint1Connection Class


hPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.hPlate Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate dimansions

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hPlate
Visual Basic (Declaration)
Public hPlate As Double
Visual C++
public:
double hPlate

Remarks

See Also

MemberOnJoint1Connection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.LoadCases Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the member

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ned (positive=tensile)

See Also

MemberOnJoint1Connection Class


PlateSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.PlateSteel Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade PlateSteel
Visual Basic (Declaration)
Public PlateSteel As SteelGrade
Visual C++
public:
SteelGrade^ PlateSteel

Remarks

See Also

MemberOnJoint1Connection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.Results Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<MemberOnJoint1ConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of MemberOnJoint1ConnectionResults)
Visual C++
public:
List<MemberOnJoint1ConnectionResults^>^ Results

Remarks

See Also

MemberOnJoint1Connection Class


tPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.tPlate Field
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tPlate
Visual Basic (Declaration)
Public tPlate As Double
Visual C++
public:
double tPlate

See Also

MemberOnJoint1Connection Class


MemberOnJoint1Connection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection Methods
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint1Connection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint1Connection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.Calculate Method
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

MemberOnJoint1Connection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1Connection..::.GetInputWarnings Method
MemberOnJoint1Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint1ConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As MemberOnJoint1ConnectionInputWarnings
Visual C++
public:
MemberOnJoint1ConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

MemberOnJoint1Connection Class


MemberOnJoint1ConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint1ConnectionInputWarnings
Visual Basic (Declaration)
Public Class MemberOnJoint1ConnectionInputWarnings
Visual C++
public ref class MemberOnJoint1ConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint1ConnectionInputWarnings

See Also

MemberOnJoint1ConnectionInputWarnings Members


MemberOnJoint1ConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionInputWarnings Members
MemberOnJoint1ConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint1ConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
MemberOnJoint1ConnectionInputWarnings | Initializes a new instance of the MemberOnJoint1ConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BoltedPlate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

MemberOnJoint1ConnectionInputWarnings Class


MemberOnJoint1ConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionInputWarnings Constructor
MemberOnJoint1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint1ConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint1ConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint1ConnectionInputWarnings()

See Also

MemberOnJoint1ConnectionInputWarnings Class


MemberOnJoint1ConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionInputWarnings Fields
MemberOnJoint1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint1ConnectionInputWarnings type exposes the following members.

Fields

Name | Description
BoltedPlate | Input warnings regarding the bolted plate
Welds | Input warnings regarding welds

See Also

MemberOnJoint1ConnectionInputWarnings Class


BoltedPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionInputWarnings..::.BoltedPlate Field
MemberOnJoint1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> BoltedPlate
Visual Basic (Declaration)
Public BoltedPlate As List(Of String)
Visual C++
public:
List<String^>^ BoltedPlate

Remarks

See Also

MemberOnJoint1ConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionInputWarnings..::.Welds Field
MemberOnJoint1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

MemberOnJoint1ConnectionInputWarnings Class


MemberOnJoint1ConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionInputWarnings Methods
MemberOnJoint1ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint1ConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint1ConnectionInputWarnings Class


MemberOnJoint1ConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint1ConnectionResults
Visual Basic (Declaration)
Public Class MemberOnJoint1ConnectionResults
Visual C++
public ref class MemberOnJoint1ConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint1ConnectionResults

See Also

MemberOnJoint1ConnectionResults Members


MemberOnJoint1ConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults Members
MemberOnJoint1ConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint1ConnectionResults type exposes the following members.

Constructors

Name | Description
MemberOnJoint1ConnectionResults | Initializes a new instance of the MemberOnJoint1ConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
MemberTensionCapacity | Member tension capacity
MemberTensionResistance | Member tension resistance
PlateTensionCapacity | Plate tension capacity
PlateTensionResistance | Plate tension resistance
PlateWeldCapacity | Plate weld capacity
PlateWeldResistance | Plate weld resistance

See Also

MemberOnJoint1ConnectionResults Class


MemberOnJoint1ConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults Constructor
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint1ConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint1ConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint1ConnectionResults()

See Also

MemberOnJoint1ConnectionResults Class


MemberOnJoint1ConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults Fields
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint1ConnectionResults type exposes the following members.

Fields

Name | Description
BoltsBearingCapacity | Bolts bearing capacity
BoltsBearingResistance | Bolts bearing resistance
BoltsShearCapacity | Bolts shear capacity
BoltsShearResistance | Bolts shear resistance
MemberTensionCapacity | Member tension capacity
MemberTensionResistance | Member tension resistance
PlateTensionCapacity | Plate tension capacity
PlateTensionResistance | Plate tension resistance
PlateWeldCapacity | Plate weld capacity
PlateWeldResistance | Plate weld resistance

See Also

MemberOnJoint1ConnectionResults Class


BoltsBearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.BoltsBearingCapacity Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingCapacity
Visual Basic (Declaration)
Public BoltsBearingCapacity As Double
Visual C++
public:
double BoltsBearingCapacity

Remarks

See Also

MemberOnJoint1ConnectionResults Class


BoltsBearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.BoltsBearingResistance Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingResistance
Visual Basic (Declaration)
Public BoltsBearingResistance As Double
Visual C++
public:
double BoltsBearingResistance

Remarks

See Also

MemberOnJoint1ConnectionResults Class


BoltsShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.BoltsShearCapacity Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearCapacity
Visual Basic (Declaration)
Public BoltsShearCapacity As Double
Visual C++
public:
double BoltsShearCapacity

Remarks

See Also

MemberOnJoint1ConnectionResults Class


BoltsShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.BoltsShearResistance Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearResistance
Visual Basic (Declaration)
Public BoltsShearResistance As Double
Visual C++
public:
double BoltsShearResistance

Remarks

See Also

MemberOnJoint1ConnectionResults Class


MemberTensionCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.MemberTensionCapacity Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionCapacity
Visual Basic (Declaration)
Public MemberTensionCapacity As Double
Visual C++
public:
double MemberTensionCapacity

Remarks

See Also

MemberOnJoint1ConnectionResults Class


MemberTensionResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.MemberTensionResistance Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionResistance
Visual Basic (Declaration)
Public MemberTensionResistance As Double
Visual C++
public:
double MemberTensionResistance

Remarks

See Also

MemberOnJoint1ConnectionResults Class


PlateTensionCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.PlateTensionCapacity Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionCapacity
Visual Basic (Declaration)
Public PlateTensionCapacity As Double
Visual C++
public:
double PlateTensionCapacity

Remarks

See Also

MemberOnJoint1ConnectionResults Class


PlateTensionResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.PlateTensionResistance Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionResistance
Visual Basic (Declaration)
Public PlateTensionResistance As Double
Visual C++
public:
double PlateTensionResistance

Remarks

See Also

MemberOnJoint1ConnectionResults Class


PlateWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.PlateWeldCapacity Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldCapacity
Visual Basic (Declaration)
Public PlateWeldCapacity As Double
Visual C++
public:
double PlateWeldCapacity

Remarks

See Also

MemberOnJoint1ConnectionResults Class


PlateWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults..::.PlateWeldResistance Field
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldResistance
Visual Basic (Declaration)
Public PlateWeldResistance As Double
Visual C++
public:
double PlateWeldResistance

Remarks

See Also

MemberOnJoint1ConnectionResults Class


MemberOnJoint1ConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint1ConnectionResults Methods
MemberOnJoint1ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint1ConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint1ConnectionResults Class


MemberOnJoint2Connection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a welded connection between a member (single or double) and a plate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint2Connection
Visual Basic (Declaration)
Public Class MemberOnJoint2Connection
Visual C++
public ref class MemberOnJoint2Connection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint2Connection

See Also

MemberOnJoint2Connection Members


MemberOnJoint2Connection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection Members
MemberOnJoint2Connection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint2Connection type exposes the following members.

Constructors

Name | Description
MemberOnJoint2Connection | Initializes a new instance of the MemberOnJoint2Connection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
a1 | Thickness of horizontal plate welds
a2 | Thickness of vertical plate welds
a3 | Weld thickness between member and plate
angle | Member angle in degrees
bPlate |
DoubleSideMember | True, if double side member 1 is used (for instance 2U), else false
hMember | Section height of member 1
hPlate | Plate dimansions
l3 | Weld lengths between member and plate
l4 |
LoadCases | Load cases of the member
MemberSteel | Member steel grade
PlateSteel | Plate steel grade
Results | List of results
tMember | Section thickness of member 1
tPlate |

See Also

MemberOnJoint2Connection Class


MemberOnJoint2Connection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection Constructor
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint2Connection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint2Connection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint2Connection()

See Also

MemberOnJoint2Connection Class


MemberOnJoint2Connection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection Fields
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint2Connection type exposes the following members.

Fields

Name | Description
a1 | Thickness of horizontal plate welds
a2 | Thickness of vertical plate welds
a3 | Weld thickness between member and plate
angle | Member angle in degrees
bPlate |
DoubleSideMember | True, if double side member 1 is used (for instance 2U), else false
hMember | Section height of member 1
hPlate | Plate dimansions
l3 | Weld lengths between member and plate
l4 |
LoadCases | Load cases of the member
MemberSteel | Member steel grade
PlateSteel | Plate steel grade
Results | List of results
tMember | Section thickness of member 1
tPlate |

See Also

MemberOnJoint2Connection Class


a1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.a1 Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness of horizontal plate welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a1
Visual Basic (Declaration)
Public a1 As Double
Visual C++
public:
double a1

Remarks

See Also

MemberOnJoint2Connection Class


a2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.a2 Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness of vertical plate welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a2
Visual Basic (Declaration)
Public a2 As Double
Visual C++
public:
double a2

Remarks

See Also

MemberOnJoint2Connection Class


a3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.a3 Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between member and plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a3
Visual Basic (Declaration)
Public a3 As Double
Visual C++
public:
double a3

Remarks

See Also

MemberOnJoint2Connection Class


angle Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.angle Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member angle in degrees

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double angle
Visual Basic (Declaration)
Public angle As Double
Visual C++
public:
double angle

Remarks

See Also

MemberOnJoint2Connection Class


bPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.bPlate Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double bPlate
Visual Basic (Declaration)
Public bPlate As Double
Visual C++
public:
double bPlate

See Also

MemberOnJoint2Connection Class


DoubleSideMember Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.DoubleSideMember Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if double side member 1 is used (for instance 2U), else false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DoubleSideMember
Visual Basic (Declaration)
Public DoubleSideMember As Boolean
Visual C++
public:
bool DoubleSideMember

Remarks

See Also

MemberOnJoint2Connection Class


hMember Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.hMember Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Section height of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hMember
Visual Basic (Declaration)
Public hMember As Double
Visual C++
public:
double hMember

Remarks

See Also

MemberOnJoint2Connection Class


hPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.hPlate Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate dimansions

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hPlate
Visual Basic (Declaration)
Public hPlate As Double
Visual C++
public:
double hPlate

Remarks

See Also

MemberOnJoint2Connection Class


l3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.l3 Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld lengths between member and plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double l3
Visual Basic (Declaration)
Public l3 As Double
Visual C++
public:
double l3

Remarks

See Also

MemberOnJoint2Connection Class


l4 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.l4 Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double l4
Visual Basic (Declaration)
Public l4 As Double
Visual C++
public:
double l4

See Also

MemberOnJoint2Connection Class


LoadCases Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.LoadCases Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of the member

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases
Visual Basic (Declaration)
Public LoadCases As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases

Remarks

Following forces are considered:

Ned (positive=tensile)

See Also

MemberOnJoint2Connection Class


MemberSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.MemberSteel Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade MemberSteel
Visual Basic (Declaration)
Public MemberSteel As SteelGrade
Visual C++
public:
SteelGrade^ MemberSteel

Remarks

See Also

MemberOnJoint2Connection Class


PlateSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.PlateSteel Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade PlateSteel
Visual Basic (Declaration)
Public PlateSteel As SteelGrade
Visual C++
public:
SteelGrade^ PlateSteel

Remarks

See Also

MemberOnJoint2Connection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.Results Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<MemberOnJoint2ConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of MemberOnJoint2ConnectionResults)
Visual C++
public:
List<MemberOnJoint2ConnectionResults^>^ Results

Remarks

See Also

MemberOnJoint2Connection Class


tMember Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.tMember Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Section thickness of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tMember
Visual Basic (Declaration)
Public tMember As Double
Visual C++
public:
double tMember

Remarks

See Also

MemberOnJoint2Connection Class


tPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.tPlate Field
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tPlate
Visual Basic (Declaration)
Public tPlate As Double
Visual C++
public:
double tPlate

See Also

MemberOnJoint2Connection Class


MemberOnJoint2Connection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection Methods
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint2Connection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint2Connection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.Calculate Method
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

MemberOnJoint2Connection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2Connection..::.GetInputWarnings Method
MemberOnJoint2Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint2ConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As MemberOnJoint2ConnectionInputWarnings
Visual C++
public:
MemberOnJoint2ConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

MemberOnJoint2Connection Class


MemberOnJoint2ConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint2ConnectionInputWarnings
Visual Basic (Declaration)
Public Class MemberOnJoint2ConnectionInputWarnings
Visual C++
public ref class MemberOnJoint2ConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint2ConnectionInputWarnings

See Also

MemberOnJoint2ConnectionInputWarnings Members


MemberOnJoint2ConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionInputWarnings Members
MemberOnJoint2ConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint2ConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
MemberOnJoint2ConnectionInputWarnings | Initializes a new instance of the MemberOnJoint2ConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
PlateWelds | Input warnings regarding plate welds
WeldsMember | Input warnings regarding member welds

See Also

MemberOnJoint2ConnectionInputWarnings Class


MemberOnJoint2ConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionInputWarnings Constructor
MemberOnJoint2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint2ConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint2ConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint2ConnectionInputWarnings()

See Also

MemberOnJoint2ConnectionInputWarnings Class


MemberOnJoint2ConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionInputWarnings Fields
MemberOnJoint2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint2ConnectionInputWarnings type exposes the following members.

Fields

Name | Description
PlateWelds | Input warnings regarding plate welds
WeldsMember | Input warnings regarding member welds

See Also

MemberOnJoint2ConnectionInputWarnings Class


PlateWelds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionInputWarnings..::.PlateWelds Field
MemberOnJoint2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding plate welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> PlateWelds
Visual Basic (Declaration)
Public PlateWelds As List(Of String)
Visual C++
public:
List<String^>^ PlateWelds

Remarks

See Also

MemberOnJoint2ConnectionInputWarnings Class


WeldsMember Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionInputWarnings..::.WeldsMember Field
MemberOnJoint2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding member welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> WeldsMember
Visual Basic (Declaration)
Public WeldsMember As List(Of String)
Visual C++
public:
List<String^>^ WeldsMember

Remarks

See Also

MemberOnJoint2ConnectionInputWarnings Class


MemberOnJoint2ConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionInputWarnings Methods
MemberOnJoint2ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint2ConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint2ConnectionInputWarnings Class


MemberOnJoint2ConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint2ConnectionResults
Visual Basic (Declaration)
Public Class MemberOnJoint2ConnectionResults
Visual C++
public ref class MemberOnJoint2ConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint2ConnectionResults

See Also

MemberOnJoint2ConnectionResults Members


MemberOnJoint2ConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults Members
MemberOnJoint2ConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint2ConnectionResults type exposes the following members.

Constructors

Name | Description
MemberOnJoint2ConnectionResults | Initializes a new instance of the MemberOnJoint2ConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MemberTensionCapacity | Member tension capacity
MemberTensionResistance | Member tension resistance
MemberWeldCapacity | Member weld capacity
MemberWeldResistance | Member weld resistance
PlateTensionCapacity | Plate at member tension capacity
PlateTensionResistance | Plate at member tension resistance
PlateWeldCapacity | Plate weld capacity
PlateWeldResistance | Plate weld resistance

See Also

MemberOnJoint2ConnectionResults Class


MemberOnJoint2ConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults Constructor
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint2ConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint2ConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint2ConnectionResults()

See Also

MemberOnJoint2ConnectionResults Class


MemberOnJoint2ConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults Fields
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint2ConnectionResults type exposes the following members.

Fields

Name | Description
MemberTensionCapacity | Member tension capacity
MemberTensionResistance | Member tension resistance
MemberWeldCapacity | Member weld capacity
MemberWeldResistance | Member weld resistance
PlateTensionCapacity | Plate at member tension capacity
PlateTensionResistance | Plate at member tension resistance
PlateWeldCapacity | Plate weld capacity
PlateWeldResistance | Plate weld resistance

See Also

MemberOnJoint2ConnectionResults Class


MemberTensionCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults..::.MemberTensionCapacity Field
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionCapacity
Visual Basic (Declaration)
Public MemberTensionCapacity As Double
Visual C++
public:
double MemberTensionCapacity

Remarks

See Also

MemberOnJoint2ConnectionResults Class


MemberTensionResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults..::.MemberTensionResistance Field
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionResistance
Visual Basic (Declaration)
Public MemberTensionResistance As Double
Visual C++
public:
double MemberTensionResistance

Remarks

See Also

MemberOnJoint2ConnectionResults Class


MemberWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults..::.MemberWeldCapacity Field
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberWeldCapacity
Visual Basic (Declaration)
Public MemberWeldCapacity As Double
Visual C++
public:
double MemberWeldCapacity

Remarks

See Also

MemberOnJoint2ConnectionResults Class


MemberWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults..::.MemberWeldResistance Field
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberWeldResistance
Visual Basic (Declaration)
Public MemberWeldResistance As Double
Visual C++
public:
double MemberWeldResistance

Remarks

See Also

MemberOnJoint2ConnectionResults Class


PlateTensionCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults..::.PlateTensionCapacity Field
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate at member tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionCapacity
Visual Basic (Declaration)
Public PlateTensionCapacity As Double
Visual C++
public:
double PlateTensionCapacity

Remarks

See Also

MemberOnJoint2ConnectionResults Class


PlateTensionResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults..::.PlateTensionResistance Field
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate at member tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionResistance
Visual Basic (Declaration)
Public PlateTensionResistance As Double
Visual C++
public:
double PlateTensionResistance

Remarks

See Also

MemberOnJoint2ConnectionResults Class


PlateWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults..::.PlateWeldCapacity Field
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldCapacity
Visual Basic (Declaration)
Public PlateWeldCapacity As Double
Visual C++
public:
double PlateWeldCapacity

Remarks

See Also

MemberOnJoint2ConnectionResults Class


PlateWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults..::.PlateWeldResistance Field
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldResistance
Visual Basic (Declaration)
Public PlateWeldResistance As Double
Visual C++
public:
double PlateWeldResistance

Remarks

See Also

MemberOnJoint2ConnectionResults Class


MemberOnJoint2ConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint2ConnectionResults Methods
MemberOnJoint2ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint2ConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint2ConnectionResults Class


MemberOnJoint3Connection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a bolted connection between 3 member (single or double) and a plate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint3Connection
Visual Basic (Declaration)
Public Class MemberOnJoint3Connection
Visual C++
public ref class MemberOnJoint3Connection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint3Connection

See Also

MemberOnJoint3Connection Members


MemberOnJoint3Connection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection Members
MemberOnJoint3Connection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint3Connection type exposes the following members.

Constructors

Name | Description
MemberOnJoint3Connection | Initializes a new instance of the MemberOnJoint3Connection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
a | Thickness of plate welds
angle1 | Member1 angle in degrees
angle2 | Member2 angle in degrees
angle3 | Member3 angle in degrees
BoltedMember1 | Corresponding bolted plate 1
BoltedMember2 | Corresponding bolted plate 2
BoltedMember3 | Corresponding bolted plate 3
bPlate |
DoubleSideMember1 | True, if double side member is used (for instance 2U), else false
DoubleSideMember2 | True, if double side member is used (for instance 2U), else false
DoubleSideMember3 | True, if double side member is used (for instance 2U), else false
hPlate | Plate dimansions
LoadCases1 | Load cases of member1
LoadCases2 | Load cases of member2
LoadCases3 | Load cases of member3
PlateSteel | Plate steel grade
Results | List of results
tPlate |

See Also

MemberOnJoint3Connection Class


MemberOnJoint3Connection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection Constructor
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint3Connection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint3Connection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint3Connection()

See Also

MemberOnJoint3Connection Class


MemberOnJoint3Connection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection Fields
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint3Connection type exposes the following members.

Fields

Name | Description
a | Thickness of plate welds
angle1 | Member1 angle in degrees
angle2 | Member2 angle in degrees
angle3 | Member3 angle in degrees
BoltedMember1 | Corresponding bolted plate 1
BoltedMember2 | Corresponding bolted plate 2
BoltedMember3 | Corresponding bolted plate 3
bPlate |
DoubleSideMember1 | True, if double side member is used (for instance 2U), else false
DoubleSideMember2 | True, if double side member is used (for instance 2U), else false
DoubleSideMember3 | True, if double side member is used (for instance 2U), else false
hPlate | Plate dimansions
LoadCases1 | Load cases of member1
LoadCases2 | Load cases of member2
LoadCases3 | Load cases of member3
PlateSteel | Plate steel grade
Results | List of results
tPlate |

See Also

MemberOnJoint3Connection Class


a Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.a Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness of plate welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a
Visual Basic (Declaration)
Public a As Double
Visual C++
public:
double a

Remarks

See Also

MemberOnJoint3Connection Class


angle1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.angle1 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member1 angle in degrees

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double angle1
Visual Basic (Declaration)
Public angle1 As Double
Visual C++
public:
double angle1

Remarks

See Also

MemberOnJoint3Connection Class


angle2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.angle2 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member2 angle in degrees

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double angle2
Visual Basic (Declaration)
Public angle2 As Double
Visual C++
public:
double angle2

Remarks

See Also

MemberOnJoint3Connection Class


angle3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.angle3 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member3 angle in degrees

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double angle3
Visual Basic (Declaration)
Public angle3 As Double
Visual C++
public:
double angle3

Remarks

See Also

MemberOnJoint3Connection Class


BoltedMember1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.BoltedMember1 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Corresponding bolted plate 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate BoltedMember1
Visual Basic (Declaration)
Public BoltedMember1 As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ BoltedMember1

Remarks

See Also

MemberOnJoint3Connection Class


BoltedMember2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.BoltedMember2 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Corresponding bolted plate 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate BoltedMember2
Visual Basic (Declaration)
Public BoltedMember2 As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ BoltedMember2

Remarks

See Also

MemberOnJoint3Connection Class


BoltedMember3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.BoltedMember3 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Corresponding bolted plate 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate BoltedMember3
Visual Basic (Declaration)
Public BoltedMember3 As SingleBoltedPlate
Visual C++
public:
SingleBoltedPlate^ BoltedMember3

Remarks

See Also

MemberOnJoint3Connection Class


bPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.bPlate Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double bPlate
Visual Basic (Declaration)
Public bPlate As Double
Visual C++
public:
double bPlate

See Also

MemberOnJoint3Connection Class


DoubleSideMember1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.DoubleSideMember1 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if double side member is used (for instance 2U), else false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DoubleSideMember1
Visual Basic (Declaration)
Public DoubleSideMember1 As Boolean
Visual C++
public:
bool DoubleSideMember1

Remarks

See Also

MemberOnJoint3Connection Class


DoubleSideMember2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.DoubleSideMember2 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if double side member is used (for instance 2U), else false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DoubleSideMember2
Visual Basic (Declaration)
Public DoubleSideMember2 As Boolean
Visual C++
public:
bool DoubleSideMember2

Remarks

See Also

MemberOnJoint3Connection Class


DoubleSideMember3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.DoubleSideMember3 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if double side member is used (for instance 2U), else false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DoubleSideMember3
Visual Basic (Declaration)
Public DoubleSideMember3 As Boolean
Visual C++
public:
bool DoubleSideMember3

Remarks

See Also

MemberOnJoint3Connection Class


hPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.hPlate Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate dimansions

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hPlate
Visual Basic (Declaration)
Public hPlate As Double
Visual C++
public:
double hPlate

Remarks

See Also

MemberOnJoint3Connection Class


LoadCases1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.LoadCases1 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of member1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases1
Visual Basic (Declaration)
Public LoadCases1 As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases1

Remarks

Following forces are considered:

Ned (positive=tensile)

See Also

MemberOnJoint3Connection Class


LoadCases2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.LoadCases2 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of member2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases2
Visual Basic (Declaration)
Public LoadCases2 As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases2

Remarks

Following forces are considered:

Ned (positive=tensile)

See Also

MemberOnJoint3Connection Class


LoadCases3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.LoadCases3 Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of member3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases3
Visual Basic (Declaration)
Public LoadCases3 As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases3

Remarks

Following forces are considered:

Ned (positive=tensile)

See Also

MemberOnJoint3Connection Class


PlateSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.PlateSteel Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade PlateSteel
Visual Basic (Declaration)
Public PlateSteel As SteelGrade
Visual C++
public:
SteelGrade^ PlateSteel

Remarks

See Also

MemberOnJoint3Connection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.Results Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<MemberOnJoint3ConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of MemberOnJoint3ConnectionResults)
Visual C++
public:
List<MemberOnJoint3ConnectionResults^>^ Results

Remarks

See Also

MemberOnJoint3Connection Class


tPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.tPlate Field
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tPlate
Visual Basic (Declaration)
Public tPlate As Double
Visual C++
public:
double tPlate

See Also

MemberOnJoint3Connection Class


MemberOnJoint3Connection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection Methods
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint3Connection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint3Connection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.Calculate Method
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

MemberOnJoint3Connection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3Connection..::.GetInputWarnings Method
MemberOnJoint3Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint3ConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As MemberOnJoint3ConnectionInputWarnings
Visual C++
public:
MemberOnJoint3ConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

MemberOnJoint3Connection Class


MemberOnJoint3ConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint3ConnectionInputWarnings
Visual Basic (Declaration)
Public Class MemberOnJoint3ConnectionInputWarnings
Visual C++
public ref class MemberOnJoint3ConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint3ConnectionInputWarnings

See Also

MemberOnJoint3ConnectionInputWarnings Members


MemberOnJoint3ConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionInputWarnings Members
MemberOnJoint3ConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint3ConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
MemberOnJoint3ConnectionInputWarnings | Initializes a new instance of the MemberOnJoint3ConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BoltedPlate1 | Input warnings regarding the bolted plate 1
BoltedPlate2 | Input warnings regarding the bolted plate 2
BoltedPlate3 | Input warnings regarding the bolted plate 3
Welds | Input warnings regarding welds

See Also

MemberOnJoint3ConnectionInputWarnings Class


MemberOnJoint3ConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionInputWarnings Constructor
MemberOnJoint3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint3ConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint3ConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint3ConnectionInputWarnings()

See Also

MemberOnJoint3ConnectionInputWarnings Class


MemberOnJoint3ConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionInputWarnings Fields
MemberOnJoint3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint3ConnectionInputWarnings type exposes the following members.

Fields

Name | Description
BoltedPlate1 | Input warnings regarding the bolted plate 1
BoltedPlate2 | Input warnings regarding the bolted plate 2
BoltedPlate3 | Input warnings regarding the bolted plate 3
Welds | Input warnings regarding welds

See Also

MemberOnJoint3ConnectionInputWarnings Class


BoltedPlate1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionInputWarnings..::.BoltedPlate1 Field
MemberOnJoint3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted plate 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> BoltedPlate1
Visual Basic (Declaration)
Public BoltedPlate1 As List(Of String)
Visual C++
public:
List<String^>^ BoltedPlate1

Remarks

See Also

MemberOnJoint3ConnectionInputWarnings Class


BoltedPlate2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionInputWarnings..::.BoltedPlate2 Field
MemberOnJoint3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted plate 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> BoltedPlate2
Visual Basic (Declaration)
Public BoltedPlate2 As List(Of String)
Visual C++
public:
List<String^>^ BoltedPlate2

Remarks

See Also

MemberOnJoint3ConnectionInputWarnings Class


BoltedPlate3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionInputWarnings..::.BoltedPlate3 Field
MemberOnJoint3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the bolted plate 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> BoltedPlate3
Visual Basic (Declaration)
Public BoltedPlate3 As List(Of String)
Visual C++
public:
List<String^>^ BoltedPlate3

Remarks

See Also

MemberOnJoint3ConnectionInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionInputWarnings..::.Welds Field
MemberOnJoint3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

MemberOnJoint3ConnectionInputWarnings Class


MemberOnJoint3ConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionInputWarnings Methods
MemberOnJoint3ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint3ConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint3ConnectionInputWarnings Class


MemberOnJoint3ConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint3ConnectionResults
Visual Basic (Declaration)
Public Class MemberOnJoint3ConnectionResults
Visual C++
public ref class MemberOnJoint3ConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint3ConnectionResults

See Also

MemberOnJoint3ConnectionResults Members


MemberOnJoint3ConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults Members
MemberOnJoint3ConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint3ConnectionResults type exposes the following members.

Constructors

Name | Description
MemberOnJoint3ConnectionResults | Initializes a new instance of the MemberOnJoint3ConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BoltsBearingCapacity1 | Bolts bearing capacity of member 1
BoltsBearingCapacity2 | Bolts bearing capacity of member 2
BoltsBearingCapacity3 | Bolts bearing capacity of member 3
BoltsBearingResistance1 | Bolts bearing resistance of member 1
BoltsBearingResistance2 | Bolts bearing resistance of member 2
BoltsBearingResistance3 | Bolts bearing resistance of member 3
BoltsShearCapacity1 | Bolts shear capacity of member 1
BoltsShearCapacity2 | Bolts shear capacity of member 2
BoltsShearCapacity3 | Bolts shear capacity of member 3
BoltsShearResistance1 | Bolts shear resistance of member 1
BoltsShearResistance2 | Bolts shear resistance of member 2
BoltsShearResistance3 | Bolts shear resistance of member 3
MemberTensionCapacity1 | Member tension capacity of member 1
MemberTensionCapacity2 | Member tension capacity of member 2
MemberTensionCapacity3 | Member tension capacity of member 3
MemberTensionResistance1 | Member tension resistance of member 1
MemberTensionResistance2 | Member tension resistance of member 2
MemberTensionResistance3 | Member tension resistance of member 3
PlateTensionCapacity1 | Plate tension capacity of member 1
PlateTensionCapacity2 | Plate tension capacity of member 2
PlateTensionCapacity3 | Plate tension capacity of member 3
PlateTensionResistance1 | Plate tension resistance of member 1
PlateTensionResistance2 | Plate tension resistance of member 2
PlateTensionResistance3 | Plate tension resistance of member 3
PlateWeldCapacity | Plate weld capacity
PlateWeldResistance | Plate weld resistance

See Also

MemberOnJoint3ConnectionResults Class


MemberOnJoint3ConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults Constructor
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint3ConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint3ConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint3ConnectionResults()

See Also

MemberOnJoint3ConnectionResults Class


MemberOnJoint3ConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults Fields
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint3ConnectionResults type exposes the following members.

Fields

Name | Description
BoltsBearingCapacity1 | Bolts bearing capacity of member 1
BoltsBearingCapacity2 | Bolts bearing capacity of member 2
BoltsBearingCapacity3 | Bolts bearing capacity of member 3
BoltsBearingResistance1 | Bolts bearing resistance of member 1
BoltsBearingResistance2 | Bolts bearing resistance of member 2
BoltsBearingResistance3 | Bolts bearing resistance of member 3
BoltsShearCapacity1 | Bolts shear capacity of member 1
BoltsShearCapacity2 | Bolts shear capacity of member 2
BoltsShearCapacity3 | Bolts shear capacity of member 3
BoltsShearResistance1 | Bolts shear resistance of member 1
BoltsShearResistance2 | Bolts shear resistance of member 2
BoltsShearResistance3 | Bolts shear resistance of member 3
MemberTensionCapacity1 | Member tension capacity of member 1
MemberTensionCapacity2 | Member tension capacity of member 2
MemberTensionCapacity3 | Member tension capacity of member 3
MemberTensionResistance1 | Member tension resistance of member 1
MemberTensionResistance2 | Member tension resistance of member 2
MemberTensionResistance3 | Member tension resistance of member 3
PlateTensionCapacity1 | Plate tension capacity of member 1
PlateTensionCapacity2 | Plate tension capacity of member 2
PlateTensionCapacity3 | Plate tension capacity of member 3
PlateTensionResistance1 | Plate tension resistance of member 1
PlateTensionResistance2 | Plate tension resistance of member 2
PlateTensionResistance3 | Plate tension resistance of member 3
PlateWeldCapacity | Plate weld capacity
PlateWeldResistance | Plate weld resistance

See Also

MemberOnJoint3ConnectionResults Class


BoltsBearingCapacity1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsBearingCapacity1 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingCapacity1
Visual Basic (Declaration)
Public BoltsBearingCapacity1 As Double
Visual C++
public:
double BoltsBearingCapacity1

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsBearingCapacity2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsBearingCapacity2 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingCapacity2
Visual Basic (Declaration)
Public BoltsBearingCapacity2 As Double
Visual C++
public:
double BoltsBearingCapacity2

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsBearingCapacity3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsBearingCapacity3 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing capacity of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingCapacity3
Visual Basic (Declaration)
Public BoltsBearingCapacity3 As Double
Visual C++
public:
double BoltsBearingCapacity3

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsBearingResistance1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsBearingResistance1 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingResistance1
Visual Basic (Declaration)
Public BoltsBearingResistance1 As Double
Visual C++
public:
double BoltsBearingResistance1

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsBearingResistance2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsBearingResistance2 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingResistance2
Visual Basic (Declaration)
Public BoltsBearingResistance2 As Double
Visual C++
public:
double BoltsBearingResistance2

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsBearingResistance3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsBearingResistance3 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts bearing resistance of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsBearingResistance3
Visual Basic (Declaration)
Public BoltsBearingResistance3 As Double
Visual C++
public:
double BoltsBearingResistance3

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsShearCapacity1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsShearCapacity1 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear capacity of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearCapacity1
Visual Basic (Declaration)
Public BoltsShearCapacity1 As Double
Visual C++
public:
double BoltsShearCapacity1

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsShearCapacity2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsShearCapacity2 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear capacity of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearCapacity2
Visual Basic (Declaration)
Public BoltsShearCapacity2 As Double
Visual C++
public:
double BoltsShearCapacity2

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsShearCapacity3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsShearCapacity3 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear capacity of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearCapacity3
Visual Basic (Declaration)
Public BoltsShearCapacity3 As Double
Visual C++
public:
double BoltsShearCapacity3

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsShearResistance1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsShearResistance1 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear resistance of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearResistance1
Visual Basic (Declaration)
Public BoltsShearResistance1 As Double
Visual C++
public:
double BoltsShearResistance1

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsShearResistance2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsShearResistance2 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear resistance of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearResistance2
Visual Basic (Declaration)
Public BoltsShearResistance2 As Double
Visual C++
public:
double BoltsShearResistance2

Remarks

See Also

MemberOnJoint3ConnectionResults Class


BoltsShearResistance3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.BoltsShearResistance3 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts shear resistance of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltsShearResistance3
Visual Basic (Declaration)
Public BoltsShearResistance3 As Double
Visual C++
public:
double BoltsShearResistance3

Remarks

See Also

MemberOnJoint3ConnectionResults Class


MemberTensionCapacity1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.MemberTensionCapacity1 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension capacity of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionCapacity1
Visual Basic (Declaration)
Public MemberTensionCapacity1 As Double
Visual C++
public:
double MemberTensionCapacity1

Remarks

See Also

MemberOnJoint3ConnectionResults Class


MemberTensionCapacity2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.MemberTensionCapacity2 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension capacity of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionCapacity2
Visual Basic (Declaration)
Public MemberTensionCapacity2 As Double
Visual C++
public:
double MemberTensionCapacity2

Remarks

See Also

MemberOnJoint3ConnectionResults Class


MemberTensionCapacity3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.MemberTensionCapacity3 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension capacity of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionCapacity3
Visual Basic (Declaration)
Public MemberTensionCapacity3 As Double
Visual C++
public:
double MemberTensionCapacity3

Remarks

See Also

MemberOnJoint3ConnectionResults Class


MemberTensionResistance1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.MemberTensionResistance1 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension resistance of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionResistance1
Visual Basic (Declaration)
Public MemberTensionResistance1 As Double
Visual C++
public:
double MemberTensionResistance1

Remarks

See Also

MemberOnJoint3ConnectionResults Class


MemberTensionResistance2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.MemberTensionResistance2 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension resistance of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionResistance2
Visual Basic (Declaration)
Public MemberTensionResistance2 As Double
Visual C++
public:
double MemberTensionResistance2

Remarks

See Also

MemberOnJoint3ConnectionResults Class


MemberTensionResistance3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.MemberTensionResistance3 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member tension resistance of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionResistance3
Visual Basic (Declaration)
Public MemberTensionResistance3 As Double
Visual C++
public:
double MemberTensionResistance3

Remarks

See Also

MemberOnJoint3ConnectionResults Class


PlateTensionCapacity1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.PlateTensionCapacity1 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tension capacity of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionCapacity1
Visual Basic (Declaration)
Public PlateTensionCapacity1 As Double
Visual C++
public:
double PlateTensionCapacity1

Remarks

See Also

MemberOnJoint3ConnectionResults Class


PlateTensionCapacity2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.PlateTensionCapacity2 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tension capacity of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionCapacity2
Visual Basic (Declaration)
Public PlateTensionCapacity2 As Double
Visual C++
public:
double PlateTensionCapacity2

Remarks

See Also

MemberOnJoint3ConnectionResults Class


PlateTensionCapacity3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.PlateTensionCapacity3 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tension capacity of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionCapacity3
Visual Basic (Declaration)
Public PlateTensionCapacity3 As Double
Visual C++
public:
double PlateTensionCapacity3

Remarks

See Also

MemberOnJoint3ConnectionResults Class


PlateTensionResistance1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.PlateTensionResistance1 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tension resistance of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionResistance1
Visual Basic (Declaration)
Public PlateTensionResistance1 As Double
Visual C++
public:
double PlateTensionResistance1

Remarks

See Also

MemberOnJoint3ConnectionResults Class


PlateTensionResistance2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.PlateTensionResistance2 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tension resistance of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionResistance2
Visual Basic (Declaration)
Public PlateTensionResistance2 As Double
Visual C++
public:
double PlateTensionResistance2

Remarks

See Also

MemberOnJoint3ConnectionResults Class


PlateTensionResistance3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.PlateTensionResistance3 Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate tension resistance of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionResistance3
Visual Basic (Declaration)
Public PlateTensionResistance3 As Double
Visual C++
public:
double PlateTensionResistance3

Remarks

See Also

MemberOnJoint3ConnectionResults Class


PlateWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.PlateWeldCapacity Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldCapacity
Visual Basic (Declaration)
Public PlateWeldCapacity As Double
Visual C++
public:
double PlateWeldCapacity

Remarks

See Also

MemberOnJoint3ConnectionResults Class


PlateWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults..::.PlateWeldResistance Field
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldResistance
Visual Basic (Declaration)
Public PlateWeldResistance As Double
Visual C++
public:
double PlateWeldResistance

Remarks

See Also

MemberOnJoint3ConnectionResults Class


MemberOnJoint3ConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint3ConnectionResults Methods
MemberOnJoint3ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint3ConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint3ConnectionResults Class


MemberOnJoint4Connection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a welded connection between 3 member (single or double) and a plate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint4Connection
Visual Basic (Declaration)
Public Class MemberOnJoint4Connection
Visual C++
public ref class MemberOnJoint4Connection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint4Connection

See Also

MemberOnJoint4Connection Members


MemberOnJoint4Connection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection Members
MemberOnJoint4Connection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint4Connection type exposes the following members.

Constructors

Name | Description
MemberOnJoint4Connection | Initializes a new instance of the MemberOnJoint4Connection class

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
a | Thickness of plate horizontal weld
a3_1 | Weld thickness between member 1 and plate
a3_2 | Weld thickness between member 2 and plate
a3_3 | Weld thickness between member 3 and plate
angle1 | Member1 angle in degrees
angle2 | Member2 angle in degrees
angle3 | Member3 angle in degrees
bPlate |
DoubleSideMember1 | True, if double side member 1 is used (for instance 2U), else false
DoubleSideMember2 | True, if double side member 2 is used (for instance 2U), else false
DoubleSideMember3 | True, if double side member 3 is used (for instance 2U), else false
hMember1 | Section height of member 1
hMember2 | Section height of member 2
hMember3 | Section height of member 3
hPlate | Plate dimansions
l3_1 | Weld lengths between member 1 and plate
l3_2 | Weld lengths between member 2 and plate
l3_3 | Weld lengths between member 3 and plate
l4_1 |
l4_2 |
l4_3 |
LoadCases1 | Load cases of member1
LoadCases2 | Load cases of member2
LoadCases3 | Load cases of member3
MemberSteel | Member steel grade
PlateSteel | Plate steel grade
Results | List of results
tMember1 | Section thickness of member 1
tMember2 | Section thickness of member 2
tMember3 | Section thickness of member 3
tPlate |

See Also

MemberOnJoint4Connection Class


MemberOnJoint4Connection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection Constructor
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint4Connection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint4Connection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint4Connection()

See Also

MemberOnJoint4Connection Class


MemberOnJoint4Connection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection Fields
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint4Connection type exposes the following members.

Fields

Name | Description
a | Thickness of plate horizontal weld
a3_1 | Weld thickness between member 1 and plate
a3_2 | Weld thickness between member 2 and plate
a3_3 | Weld thickness between member 3 and plate
angle1 | Member1 angle in degrees
angle2 | Member2 angle in degrees
angle3 | Member3 angle in degrees
bPlate |
DoubleSideMember1 | True, if double side member 1 is used (for instance 2U), else false
DoubleSideMember2 | True, if double side member 2 is used (for instance 2U), else false
DoubleSideMember3 | True, if double side member 3 is used (for instance 2U), else false
hMember1 | Section height of member 1
hMember2 | Section height of member 2
hMember3 | Section height of member 3
hPlate | Plate dimansions
l3_1 | Weld lengths between member 1 and plate
l3_2 | Weld lengths between member 2 and plate
l3_3 | Weld lengths between member 3 and plate
l4_1 |
l4_2 |
l4_3 |
LoadCases1 | Load cases of member1
LoadCases2 | Load cases of member2
LoadCases3 | Load cases of member3
MemberSteel | Member steel grade
PlateSteel | Plate steel grade
Results | List of results
tMember1 | Section thickness of member 1
tMember2 | Section thickness of member 2
tMember3 | Section thickness of member 3
tPlate |

See Also

MemberOnJoint4Connection Class


a Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.a Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness of plate horizontal weld

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a
Visual Basic (Declaration)
Public a As Double
Visual C++
public:
double a

Remarks

See Also

MemberOnJoint4Connection Class


a3_1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.a3_1 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between member 1 and plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a3_1
Visual Basic (Declaration)
Public a3_1 As Double
Visual C++
public:
double a3_1

Remarks

See Also

MemberOnJoint4Connection Class


a3_2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.a3_2 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between member 2 and plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a3_2
Visual Basic (Declaration)
Public a3_2 As Double
Visual C++
public:
double a3_2

Remarks

See Also

MemberOnJoint4Connection Class


a3_3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.a3_3 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld thickness between member 3 and plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double a3_3
Visual Basic (Declaration)
Public a3_3 As Double
Visual C++
public:
double a3_3

Remarks

See Also

MemberOnJoint4Connection Class


angle1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.angle1 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member1 angle in degrees

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double angle1
Visual Basic (Declaration)
Public angle1 As Double
Visual C++
public:
double angle1

Remarks

See Also

MemberOnJoint4Connection Class


angle2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.angle2 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member2 angle in degrees

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double angle2
Visual Basic (Declaration)
Public angle2 As Double
Visual C++
public:
double angle2

Remarks

See Also

MemberOnJoint4Connection Class


angle3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.angle3 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member3 angle in degrees

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double angle3
Visual Basic (Declaration)
Public angle3 As Double
Visual C++
public:
double angle3

Remarks

See Also

MemberOnJoint4Connection Class


bPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.bPlate Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double bPlate
Visual Basic (Declaration)
Public bPlate As Double
Visual C++
public:
double bPlate

See Also

MemberOnJoint4Connection Class


DoubleSideMember1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.DoubleSideMember1 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if double side member 1 is used (for instance 2U), else false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DoubleSideMember1
Visual Basic (Declaration)
Public DoubleSideMember1 As Boolean
Visual C++
public:
bool DoubleSideMember1

Remarks

See Also

MemberOnJoint4Connection Class


DoubleSideMember2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.DoubleSideMember2 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if double side member 2 is used (for instance 2U), else false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DoubleSideMember2
Visual Basic (Declaration)
Public DoubleSideMember2 As Boolean
Visual C++
public:
bool DoubleSideMember2

Remarks

See Also

MemberOnJoint4Connection Class


DoubleSideMember3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.DoubleSideMember3 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if double side member 3 is used (for instance 2U), else false

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DoubleSideMember3
Visual Basic (Declaration)
Public DoubleSideMember3 As Boolean
Visual C++
public:
bool DoubleSideMember3

Remarks

See Also

MemberOnJoint4Connection Class


hMember1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.hMember1 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Section height of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hMember1
Visual Basic (Declaration)
Public hMember1 As Double
Visual C++
public:
double hMember1

Remarks

See Also

MemberOnJoint4Connection Class


hMember2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.hMember2 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Section height of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hMember2
Visual Basic (Declaration)
Public hMember2 As Double
Visual C++
public:
double hMember2

Remarks

See Also

MemberOnJoint4Connection Class


hMember3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.hMember3 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Section height of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hMember3
Visual Basic (Declaration)
Public hMember3 As Double
Visual C++
public:
double hMember3

Remarks

See Also

MemberOnJoint4Connection Class


hPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.hPlate Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate dimansions

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double hPlate
Visual Basic (Declaration)
Public hPlate As Double
Visual C++
public:
double hPlate

Remarks

See Also

MemberOnJoint4Connection Class


l3_1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.l3_1 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld lengths between member 1 and plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double l3_1
Visual Basic (Declaration)
Public l3_1 As Double
Visual C++
public:
double l3_1

Remarks

See Also

MemberOnJoint4Connection Class


l3_2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.l3_2 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld lengths between member 2 and plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double l3_2
Visual Basic (Declaration)
Public l3_2 As Double
Visual C++
public:
double l3_2

Remarks

See Also

MemberOnJoint4Connection Class


l3_3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.l3_3 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld lengths between member 3 and plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double l3_3
Visual Basic (Declaration)
Public l3_3 As Double
Visual C++
public:
double l3_3

Remarks

See Also

MemberOnJoint4Connection Class


l4_1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.l4_1 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double l4_1
Visual Basic (Declaration)
Public l4_1 As Double
Visual C++
public:
double l4_1

See Also

MemberOnJoint4Connection Class


l4_2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.l4_2 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double l4_2
Visual Basic (Declaration)
Public l4_2 As Double
Visual C++
public:
double l4_2

See Also

MemberOnJoint4Connection Class


l4_3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.l4_3 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double l4_3
Visual Basic (Declaration)
Public l4_3 As Double
Visual C++
public:
double l4_3

See Also

MemberOnJoint4Connection Class


LoadCases1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.LoadCases1 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of member1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases1
Visual Basic (Declaration)
Public LoadCases1 As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases1

Remarks

Following forces are considered:

Ned (positive=tensile)

See Also

MemberOnJoint4Connection Class


LoadCases2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.LoadCases2 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of member2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases2
Visual Basic (Declaration)
Public LoadCases2 As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases2

Remarks

Following forces are considered:

Ned (positive=tensile)

See Also

MemberOnJoint4Connection Class


LoadCases3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.LoadCases3 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Load cases of member3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<LoadCase> LoadCases3
Visual Basic (Declaration)
Public LoadCases3 As List(Of LoadCase)
Visual C++
public:
List<LoadCase^>^ LoadCases3

Remarks

Following forces are considered:

Ned (positive=tensile)

See Also

MemberOnJoint4Connection Class


MemberSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.MemberSteel Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Member steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade MemberSteel
Visual Basic (Declaration)
Public MemberSteel As SteelGrade
Visual C++
public:
SteelGrade^ MemberSteel

Remarks

See Also

MemberOnJoint4Connection Class


PlateSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.PlateSteel Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade PlateSteel
Visual Basic (Declaration)
Public PlateSteel As SteelGrade
Visual C++
public:
SteelGrade^ PlateSteel

Remarks

See Also

MemberOnJoint4Connection Class


Results Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.Results Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<MemberOnJoint4ConnectionResults> Results
Visual Basic (Declaration)
Public Results As List(Of MemberOnJoint4ConnectionResults)
Visual C++
public:
List<MemberOnJoint4ConnectionResults^>^ Results

Remarks

See Also

MemberOnJoint4Connection Class


tMember1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.tMember1 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Section thickness of member 1

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tMember1
Visual Basic (Declaration)
Public tMember1 As Double
Visual C++
public:
double tMember1

Remarks

See Also

MemberOnJoint4Connection Class


tMember2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.tMember2 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Section thickness of member 2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tMember2
Visual Basic (Declaration)
Public tMember2 As Double
Visual C++
public:
double tMember2

Remarks

See Also

MemberOnJoint4Connection Class


tMember3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.tMember3 Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Section thickness of member 3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tMember3
Visual Basic (Declaration)
Public tMember3 As Double
Visual C++
public:
double tMember3

Remarks

See Also

MemberOnJoint4Connection Class


tPlate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.tPlate Field
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double tPlate
Visual Basic (Declaration)
Public tPlate As Double
Visual C++
public:
double tPlate

See Also

MemberOnJoint4Connection Class


MemberOnJoint4Connection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection Methods
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint4Connection type exposes the following members.

Methods

Name | Description
Calculate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns an object that represents the input warnings of the connection
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint4Connection Class


Calculate Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.Calculate Method
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Calculate()
Visual Basic (Declaration)
Public Sub Calculate
Visual C++
public:
void Calculate()

See Also

MemberOnJoint4Connection Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4Connection..::.GetInputWarnings Method
MemberOnJoint4Connection Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns an object that represents the input warnings of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint4ConnectionInputWarnings GetInputWarnings()
Visual Basic (Declaration)
Public Function GetInputWarnings As MemberOnJoint4ConnectionInputWarnings
Visual C++
public:
MemberOnJoint4ConnectionInputWarnings^ GetInputWarnings()

Return Value

Warnings object

Remarks

See Also

MemberOnJoint4Connection Class


MemberOnJoint4ConnectionInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint4ConnectionInputWarnings
Visual Basic (Declaration)
Public Class MemberOnJoint4ConnectionInputWarnings
Visual C++
public ref class MemberOnJoint4ConnectionInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint4ConnectionInputWarnings

See Also

MemberOnJoint4ConnectionInputWarnings Members


MemberOnJoint4ConnectionInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionInputWarnings Members
MemberOnJoint4ConnectionInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint4ConnectionInputWarnings type exposes the following members.

Constructors

Name | Description
MemberOnJoint4ConnectionInputWarnings | Initializes a new instance of the MemberOnJoint4ConnectionInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
PlateWelds | Input warnings regarding plate welds
WeldsMember1 | Input warnings regarding member 1 welds
WeldsMember2 | Input warnings regarding member 2 welds
WeldsMember3 | Input warnings regarding member 3 welds

See Also

MemberOnJoint4ConnectionInputWarnings Class


MemberOnJoint4ConnectionInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionInputWarnings Constructor
MemberOnJoint4ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint4ConnectionInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint4ConnectionInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint4ConnectionInputWarnings()

See Also

MemberOnJoint4ConnectionInputWarnings Class


MemberOnJoint4ConnectionInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionInputWarnings Fields
MemberOnJoint4ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint4ConnectionInputWarnings type exposes the following members.

Fields

Name | Description
PlateWelds | Input warnings regarding plate welds
WeldsMember1 | Input warnings regarding member 1 welds
WeldsMember2 | Input warnings regarding member 2 welds
WeldsMember3 | Input warnings regarding member 3 welds

See Also

MemberOnJoint4ConnectionInputWarnings Class


PlateWelds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionInputWarnings..::.PlateWelds Field
MemberOnJoint4ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding plate welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> PlateWelds
Visual Basic (Declaration)
Public PlateWelds As List(Of String)
Visual C++
public:
List<String^>^ PlateWelds

Remarks

See Also

MemberOnJoint4ConnectionInputWarnings Class


WeldsMember1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionInputWarnings..::.WeldsMember1 Field
MemberOnJoint4ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding member 1 welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> WeldsMember1
Visual Basic (Declaration)
Public WeldsMember1 As List(Of String)
Visual C++
public:
List<String^>^ WeldsMember1

Remarks

See Also

MemberOnJoint4ConnectionInputWarnings Class


WeldsMember2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionInputWarnings..::.WeldsMember2 Field
MemberOnJoint4ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding member 2 welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> WeldsMember2
Visual Basic (Declaration)
Public WeldsMember2 As List(Of String)
Visual C++
public:
List<String^>^ WeldsMember2

Remarks

See Also

MemberOnJoint4ConnectionInputWarnings Class


WeldsMember3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionInputWarnings..::.WeldsMember3 Field
MemberOnJoint4ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding member 3 welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> WeldsMember3
Visual Basic (Declaration)
Public WeldsMember3 As List(Of String)
Visual C++
public:
List<String^>^ WeldsMember3

Remarks

See Also

MemberOnJoint4ConnectionInputWarnings Class


MemberOnJoint4ConnectionInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionInputWarnings Methods
MemberOnJoint4ConnectionInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint4ConnectionInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint4ConnectionInputWarnings Class


MemberOnJoint4ConnectionResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Connection results class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MemberOnJoint4ConnectionResults
Visual Basic (Declaration)
Public Class MemberOnJoint4ConnectionResults
Visual C++
public ref class MemberOnJoint4ConnectionResults

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.MemberOnJoint4ConnectionResults

See Also

MemberOnJoint4ConnectionResults Members


MemberOnJoint4ConnectionResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults Members
MemberOnJoint4ConnectionResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint4ConnectionResults type exposes the following members.

Constructors

Name | Description
MemberOnJoint4ConnectionResults | Initializes a new instance of the MemberOnJoint4ConnectionResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MemberTensionCapacity1 | Member 1 tension capacity
MemberTensionCapacity2 | Member 2 tension capacity
MemberTensionCapacity3 | Member 3 tension capacity
MemberTensionResistance1 | Member 1 tension resistance
MemberTensionResistance2 | Member 2 tension resistance
MemberTensionResistance3 | Member 3 tension resistance
MemberWeldCapacity1 | Member 1 weld capacity
MemberWeldCapacity2 | Member 2 weld capacity
MemberWeldCapacity3 | Member 3 weld capacity
MemberWeldResistance1 | Member 1 weld resistance
MemberWeldResistance2 | Member 2 weld resistance
MemberWeldResistance3 | Member 3 weld resistance
PlateTensionCapacity1 | Plate at member 1 tension capacity
PlateTensionCapacity2 | Plate at member 2 tension capacity
PlateTensionCapacity3 | Plate at member 3 tension capacity
PlateTensionResistance1 | Plate at member 1 tension resistance
PlateTensionResistance2 | Plate at member 2 tension resistance
PlateTensionResistance3 | Plate at member 3 tension resistance
PlateWeldCapacity | Plate weld capacity
PlateWeldResistance | Plate weld resistance

See Also

MemberOnJoint4ConnectionResults Class


MemberOnJoint4ConnectionResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults Constructor
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the MemberOnJoint4ConnectionResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemberOnJoint4ConnectionResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberOnJoint4ConnectionResults()

See Also

MemberOnJoint4ConnectionResults Class


MemberOnJoint4ConnectionResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults Fields
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint4ConnectionResults type exposes the following members.

Fields

Name | Description
MemberTensionCapacity1 | Member 1 tension capacity
MemberTensionCapacity2 | Member 2 tension capacity
MemberTensionCapacity3 | Member 3 tension capacity
MemberTensionResistance1 | Member 1 tension resistance
MemberTensionResistance2 | Member 2 tension resistance
MemberTensionResistance3 | Member 3 tension resistance
MemberWeldCapacity1 | Member 1 weld capacity
MemberWeldCapacity2 | Member 2 weld capacity
MemberWeldCapacity3 | Member 3 weld capacity
MemberWeldResistance1 | Member 1 weld resistance
MemberWeldResistance2 | Member 2 weld resistance
MemberWeldResistance3 | Member 3 weld resistance
PlateTensionCapacity1 | Plate at member 1 tension capacity
PlateTensionCapacity2 | Plate at member 2 tension capacity
PlateTensionCapacity3 | Plate at member 3 tension capacity
PlateTensionResistance1 | Plate at member 1 tension resistance
PlateTensionResistance2 | Plate at member 2 tension resistance
PlateTensionResistance3 | Plate at member 3 tension resistance
PlateWeldCapacity | Plate weld capacity
PlateWeldResistance | Plate weld resistance

See Also

MemberOnJoint4ConnectionResults Class


MemberTensionCapacity1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberTensionCapacity1 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 1 tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionCapacity1
Visual Basic (Declaration)
Public MemberTensionCapacity1 As Double
Visual C++
public:
double MemberTensionCapacity1

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberTensionCapacity2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberTensionCapacity2 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 2 tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionCapacity2
Visual Basic (Declaration)
Public MemberTensionCapacity2 As Double
Visual C++
public:
double MemberTensionCapacity2

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberTensionCapacity3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberTensionCapacity3 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 3 tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionCapacity3
Visual Basic (Declaration)
Public MemberTensionCapacity3 As Double
Visual C++
public:
double MemberTensionCapacity3

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberTensionResistance1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberTensionResistance1 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 1 tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionResistance1
Visual Basic (Declaration)
Public MemberTensionResistance1 As Double
Visual C++
public:
double MemberTensionResistance1

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberTensionResistance2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberTensionResistance2 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 2 tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionResistance2
Visual Basic (Declaration)
Public MemberTensionResistance2 As Double
Visual C++
public:
double MemberTensionResistance2

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberTensionResistance3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberTensionResistance3 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 3 tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberTensionResistance3
Visual Basic (Declaration)
Public MemberTensionResistance3 As Double
Visual C++
public:
double MemberTensionResistance3

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberWeldCapacity1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberWeldCapacity1 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 1 weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberWeldCapacity1
Visual Basic (Declaration)
Public MemberWeldCapacity1 As Double
Visual C++
public:
double MemberWeldCapacity1

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberWeldCapacity2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberWeldCapacity2 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 2 weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberWeldCapacity2
Visual Basic (Declaration)
Public MemberWeldCapacity2 As Double
Visual C++
public:
double MemberWeldCapacity2

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberWeldCapacity3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberWeldCapacity3 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 3 weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberWeldCapacity3
Visual Basic (Declaration)
Public MemberWeldCapacity3 As Double
Visual C++
public:
double MemberWeldCapacity3

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberWeldResistance1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberWeldResistance1 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 1 weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberWeldResistance1
Visual Basic (Declaration)
Public MemberWeldResistance1 As Double
Visual C++
public:
double MemberWeldResistance1

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberWeldResistance2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberWeldResistance2 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 2 weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberWeldResistance2
Visual Basic (Declaration)
Public MemberWeldResistance2 As Double
Visual C++
public:
double MemberWeldResistance2

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberWeldResistance3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.MemberWeldResistance3 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Member 3 weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MemberWeldResistance3
Visual Basic (Declaration)
Public MemberWeldResistance3 As Double
Visual C++
public:
double MemberWeldResistance3

Remarks

See Also

MemberOnJoint4ConnectionResults Class


PlateTensionCapacity1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.PlateTensionCapacity1 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate at member 1 tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionCapacity1
Visual Basic (Declaration)
Public PlateTensionCapacity1 As Double
Visual C++
public:
double PlateTensionCapacity1

Remarks

See Also

MemberOnJoint4ConnectionResults Class


PlateTensionCapacity2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.PlateTensionCapacity2 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate at member 2 tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionCapacity2
Visual Basic (Declaration)
Public PlateTensionCapacity2 As Double
Visual C++
public:
double PlateTensionCapacity2

Remarks

See Also

MemberOnJoint4ConnectionResults Class


PlateTensionCapacity3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.PlateTensionCapacity3 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate at member 3 tension capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionCapacity3
Visual Basic (Declaration)
Public PlateTensionCapacity3 As Double
Visual C++
public:
double PlateTensionCapacity3

Remarks

See Also

MemberOnJoint4ConnectionResults Class


PlateTensionResistance1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.PlateTensionResistance1 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate at member 1 tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionResistance1
Visual Basic (Declaration)
Public PlateTensionResistance1 As Double
Visual C++
public:
double PlateTensionResistance1

Remarks

See Also

MemberOnJoint4ConnectionResults Class


PlateTensionResistance2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.PlateTensionResistance2 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate at member 2 tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionResistance2
Visual Basic (Declaration)
Public PlateTensionResistance2 As Double
Visual C++
public:
double PlateTensionResistance2

Remarks

See Also

MemberOnJoint4ConnectionResults Class


PlateTensionResistance3 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.PlateTensionResistance3 Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate at member 3 tension resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateTensionResistance3
Visual Basic (Declaration)
Public PlateTensionResistance3 As Double
Visual C++
public:
double PlateTensionResistance3

Remarks

See Also

MemberOnJoint4ConnectionResults Class


PlateWeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.PlateWeldCapacity Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate weld capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldCapacity
Visual Basic (Declaration)
Public PlateWeldCapacity As Double
Visual C++
public:
double PlateWeldCapacity

Remarks

See Also

MemberOnJoint4ConnectionResults Class


PlateWeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults..::.PlateWeldResistance Field
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Plate weld resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PlateWeldResistance
Visual Basic (Declaration)
Public PlateWeldResistance As Double
Visual C++
public:
double PlateWeldResistance

Remarks

See Also

MemberOnJoint4ConnectionResults Class


MemberOnJoint4ConnectionResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
MemberOnJoint4ConnectionResults Methods
MemberOnJoint4ConnectionResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The MemberOnJoint4ConnectionResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemberOnJoint4ConnectionResults Class


OneSideBeamColumnEndplateInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class OneSideBeamColumnEndplateInputWarnings
Visual Basic (Declaration)
Public Class OneSideBeamColumnEndplateInputWarnings
Visual C++
public ref class OneSideBeamColumnEndplateInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.OneSideBeamColumnEndplateInputWarnings

See Also

OneSideBeamColumnEndplateInputWarnings Members


OneSideBeamColumnEndplateInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateInputWarnings Members
OneSideBeamColumnEndplateInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnEndplateInputWarnings type exposes the following members.

Constructors

Name | Description
OneSideBeamColumnEndplateInputWarnings | Initializes a new instance of the OneSideBeamColumnEndplateInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the endplate
Welds | Input warnings regarding welds

See Also

OneSideBeamColumnEndplateInputWarnings Class


OneSideBeamColumnEndplateInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateInputWarnings Constructor
OneSideBeamColumnEndplateInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the OneSideBeamColumnEndplateInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OneSideBeamColumnEndplateInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OneSideBeamColumnEndplateInputWarnings()

See Also

OneSideBeamColumnEndplateInputWarnings Class


OneSideBeamColumnEndplateInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateInputWarnings Fields
OneSideBeamColumnEndplateInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnEndplateInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the endplate
Welds | Input warnings regarding welds

See Also

OneSideBeamColumnEndplateInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateInputWarnings..::.Other Field
OneSideBeamColumnEndplateInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

OneSideBeamColumnEndplateInputWarnings Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateInputWarnings..::.Plate Field
OneSideBeamColumnEndplateInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Plate
Visual Basic (Declaration)
Public Plate As List(Of String)
Visual C++
public:
List<String^>^ Plate

Remarks

See Also

OneSideBeamColumnEndplateInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateInputWarnings..::.Welds Field
OneSideBeamColumnEndplateInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

OneSideBeamColumnEndplateInputWarnings Class


OneSideBeamColumnEndplateInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateInputWarnings Methods
OneSideBeamColumnEndplateInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnEndplateInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OneSideBeamColumnEndplateInputWarnings Class


OneSideBeamColumnEndplateResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class OneSideBeamColumnEndplateResults
Visual Basic (Declaration)
Public Class OneSideBeamColumnEndplateResults
Visual C++
public ref class OneSideBeamColumnEndplateResults

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.OneSideBeamColumnEndplateResults

See Also

OneSideBeamColumnEndplateResults Members


OneSideBeamColumnEndplateResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults Members
OneSideBeamColumnEndplateResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnEndplateResults type exposes the following members.

Constructors

Name | Description
OneSideBeamColumnEndplateResults | Initializes a new instance of the OneSideBeamColumnEndplateResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BearingCapacity | Bearing capacity of the connection
BearingResistance | Bearing resistance of the connection
BoltInteractionCapacity | Bolt ineraction capacity
MomentCapacity | Moment capacity of the connection
MomentResistance | Moment resistance of the connection
omega | Reduction factor calculation for interaction with shear, according to table 6.3
RowResults | List of results for each row
RowsUnderTension | Final bolt rows count under tension
ShearCapacity | Shear capacity of the connection
ShearResistance | Shear resistance of the connection
Sj | Rotational stiffness of the joint
WeldCapacity | Weld capacity between beam and endplate
WeldResistance | Weld resistance between beam and endplate
zeq | Equal lever arm

See Also

OneSideBeamColumnEndplateResults Class


OneSideBeamColumnEndplateResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults Constructor
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the OneSideBeamColumnEndplateResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OneSideBeamColumnEndplateResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OneSideBeamColumnEndplateResults()

See Also

OneSideBeamColumnEndplateResults Class


OneSideBeamColumnEndplateResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults Fields
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnEndplateResults type exposes the following members.

Fields

Name | Description
BearingCapacity | Bearing capacity of the connection
BearingResistance | Bearing resistance of the connection
BoltInteractionCapacity | Bolt ineraction capacity
MomentCapacity | Moment capacity of the connection
MomentResistance | Moment resistance of the connection
omega | Reduction factor calculation for interaction with shear, according to table 6.3
RowResults | List of results for each row
RowsUnderTension | Final bolt rows count under tension
ShearCapacity | Shear capacity of the connection
ShearResistance | Shear resistance of the connection
Sj | Rotational stiffness of the joint
WeldCapacity | Weld capacity between beam and endplate
WeldResistance | Weld resistance between beam and endplate
zeq | Equal lever arm

See Also

OneSideBeamColumnEndplateResults Class


BearingCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.BearingCapacity Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bearing capacity of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BearingCapacity
Visual Basic (Declaration)
Public BearingCapacity As Double
Visual C++
public:
double BearingCapacity

Remarks

See Also

OneSideBeamColumnEndplateResults Class


BearingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.BearingResistance Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bearing resistance of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BearingResistance
Visual Basic (Declaration)
Public BearingResistance As Double
Visual C++
public:
double BearingResistance

Remarks

See Also

OneSideBeamColumnEndplateResults Class


BoltInteractionCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.BoltInteractionCapacity Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolt ineraction capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BoltInteractionCapacity
Visual Basic (Declaration)
Public BoltInteractionCapacity As Double
Visual C++
public:
double BoltInteractionCapacity

Remarks

See Also

OneSideBeamColumnEndplateResults Class


MomentCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.MomentCapacity Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment capacity of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentCapacity
Visual Basic (Declaration)
Public MomentCapacity As Double
Visual C++
public:
double MomentCapacity

Remarks

See Also

OneSideBeamColumnEndplateResults Class


MomentResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.MomentResistance Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment resistance of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentResistance
Visual Basic (Declaration)
Public MomentResistance As Double
Visual C++
public:
double MomentResistance

Remarks

See Also

OneSideBeamColumnEndplateResults Class


omega Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.omega Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Reduction factor calculation for interaction with shear, according to table 6.3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double omega
Visual Basic (Declaration)
Public omega As Double
Visual C++
public:
double omega

Remarks

See Also

OneSideBeamColumnEndplateResults Class


RowResults Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.RowResults Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
List of results for each row

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<BeamColumnRowResults> RowResults
Visual Basic (Declaration)
Public RowResults As List(Of BeamColumnRowResults)
Visual C++
public:
List<BeamColumnRowResults^>^ RowResults

Remarks

See Also

OneSideBeamColumnEndplateResults Class


RowsUnderTension Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.RowsUnderTension Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Final bolt rows count under tension

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int RowsUnderTension
Visual Basic (Declaration)
Public RowsUnderTension As Integer
Visual C++
public:
int RowsUnderTension

Remarks

See Also

OneSideBeamColumnEndplateResults Class


ShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.ShearCapacity Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear capacity of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearCapacity
Visual Basic (Declaration)
Public ShearCapacity As Double
Visual C++
public:
double ShearCapacity

Remarks

See Also

OneSideBeamColumnEndplateResults Class


ShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.ShearResistance Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearResistance
Visual Basic (Declaration)
Public ShearResistance As Double
Visual C++
public:
double ShearResistance

Remarks

See Also

OneSideBeamColumnEndplateResults Class


Sj Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.Sj Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Rotational stiffness of the joint

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Sj
Visual Basic (Declaration)
Public Sj As Double
Visual C++
public:
double Sj

Remarks

See Also

OneSideBeamColumnEndplateResults Class


WeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.WeldCapacity Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity between beam and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldCapacity
Visual Basic (Declaration)
Public WeldCapacity As Double
Visual C++
public:
double WeldCapacity

Remarks

See Also

OneSideBeamColumnEndplateResults Class


WeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.WeldResistance Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance between beam and endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldResistance
Visual Basic (Declaration)
Public WeldResistance As Double
Visual C++
public:
double WeldResistance

Remarks

See Also

OneSideBeamColumnEndplateResults Class


zeq Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults..::.zeq Field
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Equal lever arm

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double zeq
Visual Basic (Declaration)
Public zeq As Double
Visual C++
public:
double zeq

Remarks

See Also

OneSideBeamColumnEndplateResults Class


OneSideBeamColumnEndplateResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnEndplateResults Methods
OneSideBeamColumnEndplateResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnEndplateResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OneSideBeamColumnEndplateResults Class


OneSideBeamColumnWeldedInputWarnings Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedInputWarnings Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings class for the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class OneSideBeamColumnWeldedInputWarnings
Visual Basic (Declaration)
Public Class OneSideBeamColumnWeldedInputWarnings
Visual C++
public ref class OneSideBeamColumnWeldedInputWarnings

Remarks

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.OneSideBeamColumnWeldedInputWarnings

See Also

OneSideBeamColumnWeldedInputWarnings Members


OneSideBeamColumnWeldedInputWarnings Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedInputWarnings Members
OneSideBeamColumnWeldedInputWarnings Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnWeldedInputWarnings type exposes the following members.

Constructors

Name | Description
OneSideBeamColumnWeldedInputWarnings | Initializes a new instance of the OneSideBeamColumnWeldedInputWarnings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the endplate
Welds | Input warnings regarding welds

See Also

OneSideBeamColumnWeldedInputWarnings Class


OneSideBeamColumnWeldedInputWarnings Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedInputWarnings Constructor
OneSideBeamColumnWeldedInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the OneSideBeamColumnWeldedInputWarnings class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OneSideBeamColumnWeldedInputWarnings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OneSideBeamColumnWeldedInputWarnings()

See Also

OneSideBeamColumnWeldedInputWarnings Class


OneSideBeamColumnWeldedInputWarnings Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedInputWarnings Fields
OneSideBeamColumnWeldedInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnWeldedInputWarnings type exposes the following members.

Fields

Name | Description
Other | Input warnings regarding other connection parts
Plate | Input warnings regarding the endplate
Welds | Input warnings regarding welds

See Also

OneSideBeamColumnWeldedInputWarnings Class


Other Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedInputWarnings..::.Other Field
OneSideBeamColumnWeldedInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding other connection parts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Other
Visual Basic (Declaration)
Public Other As List(Of String)
Visual C++
public:
List<String^>^ Other

Remarks

See Also

OneSideBeamColumnWeldedInputWarnings Class


Plate Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedInputWarnings..::.Plate Field
OneSideBeamColumnWeldedInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding the endplate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Plate
Visual Basic (Declaration)
Public Plate As List(Of String)
Visual C++
public:
List<String^>^ Plate

Remarks

See Also

OneSideBeamColumnWeldedInputWarnings Class


Welds Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedInputWarnings..::.Welds Field
OneSideBeamColumnWeldedInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library
Input warnings regarding welds

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> Welds
Visual Basic (Declaration)
Public Welds As List(Of String)
Visual C++
public:
List<String^>^ Welds

Remarks

See Also

OneSideBeamColumnWeldedInputWarnings Class


OneSideBeamColumnWeldedInputWarnings Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedInputWarnings Methods
OneSideBeamColumnWeldedInputWarnings Class See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnWeldedInputWarnings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OneSideBeamColumnWeldedInputWarnings Class


OneSideBeamColumnWeldedResults Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults Class
Members See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class OneSideBeamColumnWeldedResults
Visual Basic (Declaration)
Public Class OneSideBeamColumnWeldedResults
Visual C++
public ref class OneSideBeamColumnWeldedResults

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.OneSideBeamColumnWeldedResults

See Also

OneSideBeamColumnWeldedResults Members


OneSideBeamColumnWeldedResults Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults Members
OneSideBeamColumnWeldedResults Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnWeldedResults type exposes the following members.

Constructors

Name | Description
OneSideBeamColumnWeldedResults | Initializes a new instance of the OneSideBeamColumnWeldedResults class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BeamFlangeCompressionResistance | Column web compression resistance
ColumnFlangeBendingResistance | Column web compression resistance
ColumnWebCompressionResistance | Column web compression resistance
ColumnWebShearCapacity | Column web shear capacity
ColumnWebShearResistance | Column web shear resistance
ColumnWebTensionResistance | Column web compression resistance
MomentCapacity | Moment capacity of the connection
MomentResistance | Moment resistance of the connection
omega | Reduction factor calculation for interaction with shear, according to table 6.3
Sj | Rotational stiffness of the joint
WeldCapacity | Weld capacity between beam and beam flange
WeldResistance | Weld resistance between beam and beam flange

See Also

OneSideBeamColumnWeldedResults Class


OneSideBeamColumnWeldedResults Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults Constructor
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the OneSideBeamColumnWeldedResults class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OneSideBeamColumnWeldedResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OneSideBeamColumnWeldedResults()

See Also

OneSideBeamColumnWeldedResults Class


OneSideBeamColumnWeldedResults Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults Fields
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnWeldedResults type exposes the following members.

Fields

Name | Description
BeamFlangeCompressionResistance | Column web compression resistance
ColumnFlangeBendingResistance | Column web compression resistance
ColumnWebCompressionResistance | Column web compression resistance
ColumnWebShearCapacity | Column web shear capacity
ColumnWebShearResistance | Column web shear resistance
ColumnWebTensionResistance | Column web compression resistance
MomentCapacity | Moment capacity of the connection
MomentResistance | Moment resistance of the connection
omega | Reduction factor calculation for interaction with shear, according to table 6.3
Sj | Rotational stiffness of the joint
WeldCapacity | Weld capacity between beam and beam flange
WeldResistance | Weld resistance between beam and beam flange

See Also

OneSideBeamColumnWeldedResults Class


BeamFlangeCompressionResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.BeamFlangeCompressionResistance Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column web compression resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BeamFlangeCompressionResistance
Visual Basic (Declaration)
Public BeamFlangeCompressionResistance As Double
Visual C++
public:
double BeamFlangeCompressionResistance

Remarks

See Also

OneSideBeamColumnWeldedResults Class


ColumnFlangeBendingResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.ColumnFlangeBendingResistance Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column web compression resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnFlangeBendingResistance
Visual Basic (Declaration)
Public ColumnFlangeBendingResistance As Double
Visual C++
public:
double ColumnFlangeBendingResistance

Remarks

See Also

OneSideBeamColumnWeldedResults Class


ColumnWebCompressionResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.ColumnWebCompressionResistance Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column web compression resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnWebCompressionResistance
Visual Basic (Declaration)
Public ColumnWebCompressionResistance As Double
Visual C++
public:
double ColumnWebCompressionResistance

Remarks

See Also

OneSideBeamColumnWeldedResults Class


ColumnWebShearCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.ColumnWebShearCapacity Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column web shear capacity

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnWebShearCapacity
Visual Basic (Declaration)
Public ColumnWebShearCapacity As Double
Visual C++
public:
double ColumnWebShearCapacity

Remarks

See Also

OneSideBeamColumnWeldedResults Class


ColumnWebShearResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.ColumnWebShearResistance Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column web shear resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnWebShearResistance
Visual Basic (Declaration)
Public ColumnWebShearResistance As Double
Visual C++
public:
double ColumnWebShearResistance

Remarks

See Also

OneSideBeamColumnWeldedResults Class


ColumnWebTensionResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.ColumnWebTensionResistance Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Column web compression resistance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnWebTensionResistance
Visual Basic (Declaration)
Public ColumnWebTensionResistance As Double
Visual C++
public:
double ColumnWebTensionResistance

Remarks

See Also

OneSideBeamColumnWeldedResults Class


MomentCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.MomentCapacity Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment capacity of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentCapacity
Visual Basic (Declaration)
Public MomentCapacity As Double
Visual C++
public:
double MomentCapacity

Remarks

See Also

OneSideBeamColumnWeldedResults Class


MomentResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.MomentResistance Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Moment resistance of the connection

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MomentResistance
Visual Basic (Declaration)
Public MomentResistance As Double
Visual C++
public:
double MomentResistance

Remarks

See Also

OneSideBeamColumnWeldedResults Class


omega Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.omega Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Reduction factor calculation for interaction with shear, according to table 6.3

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double omega
Visual Basic (Declaration)
Public omega As Double
Visual C++
public:
double omega

Remarks

See Also

OneSideBeamColumnWeldedResults Class


Sj Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.Sj Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Rotational stiffness of the joint

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Sj
Visual Basic (Declaration)
Public Sj As Double
Visual C++
public:
double Sj

Remarks

See Also

OneSideBeamColumnWeldedResults Class


WeldCapacity Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.WeldCapacity Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld capacity between beam and beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldCapacity
Visual Basic (Declaration)
Public WeldCapacity As Double
Visual C++
public:
double WeldCapacity

Remarks

See Also

OneSideBeamColumnWeldedResults Class


WeldResistance Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults..::.WeldResistance Field
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library
Weld resistance between beam and beam flange

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double WeldResistance
Visual Basic (Declaration)
Public WeldResistance As Double
Visual C++
public:
double WeldResistance

Remarks

See Also

OneSideBeamColumnWeldedResults Class


OneSideBeamColumnWeldedResults Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
OneSideBeamColumnWeldedResults Methods
OneSideBeamColumnWeldedResults Class See Also Send Feedback
EC3 Steel Connection Design Library

The OneSideBeamColumnWeldedResults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OneSideBeamColumnWeldedResults Class


RHSChordConnection Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Hollow section joints between RHS chord members and CHS/RHS brace members according to 7.5 [prEN 1993-1-8 : 2003]

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class RHSChordConnection
Visual Basic (Declaration)
Public Class RHSChordConnection
Visual C++
public ref class RHSChordConnection

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.RHSChordConnection

See Also

RHSChordConnection Members


RHSChordConnection Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection Members
RHSChordConnection Class Constructors Methods Fields See Also Send Feedback
EC3 Steel Connection Design Library

The RHSChordConnection type exposes the following members.

Constructors

Name | Description
RHSChordConnection | Initializes a new instance of the RHSChordConnection class

Methods

Name | Description
AxialResistance_Type1 | Overloaded.
AxialResistance_Type2 | Overloaded.
AxialResistance_Type3 | Overloaded.
AxialResistance_Type4 | Overloaded.
AxialResistance_Type5 | Overloaded.
AxialResistance_Type6 | Overloaded.
AxialResistance_Type7 | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Chord | Chord object
ChordSteel | Chord steel grade
GeometryRangeOfValidity_OK | True, if the geometry is within the range of validity of table 7.8, otherwise false Variables definition:
MEd0 | Chord bending moment
NEd0 | Chord axial force (compressive)
VEd0 | Chord shear force

See Also

RHSChordConnection Class


RHSChordConnection Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection Constructor
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the RHSChordConnection class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RHSChordConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RHSChordConnection()

See Also

RHSChordConnection Class


RHSChordConnection Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection Fields
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The RHSChordConnection type exposes the following members.

Fields

Name | Description
Chord | Chord object
ChordSteel | Chord steel grade
GeometryRangeOfValidity_OK | True, if the geometry is within the range of validity of table 7.8, otherwise false Variables definition:
MEd0 | Chord bending moment
NEd0 | Chord axial force (compressive)
VEd0 | Chord shear force

See Also

RHSChordConnection Class


Chord Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.Chord Field
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RHS Chord
Visual Basic (Declaration)
Public Chord As RHS
Visual C++
public:
RHS^ Chord

Remarks

See Also

RHSChordConnection Class


ChordSteel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.ChordSteel Field
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade ChordSteel
Visual Basic (Declaration)
Public ChordSteel As SteelGrade
Visual C++
public:
SteelGrade^ ChordSteel

Remarks

See Also

RHSChordConnection Class


GeometryRangeOfValidity_OK Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.GeometryRangeOfValidity_OK Field
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
True, if the geometry is within the range of validity of table 7.8, otherwise false

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GeometryRangeOfValidity_OK
Visual Basic (Declaration)
Public GeometryRangeOfValidity_OK As Boolean
Visual C++
public:
bool GeometryRangeOfValidity_OK

Remarks

This is an output variable

See Also

RHSChordConnection Class


MEd0 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.MEd0 Field
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord bending moment

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MEd0
Visual Basic (Declaration)
Public MEd0 As Double
Visual C++
public:
double MEd0

Remarks

See Also

RHSChordConnection Class


NEd0 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.NEd0 Field
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord axial force (compressive)

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double NEd0
Visual Basic (Declaration)
Public NEd0 As Double
Visual C++
public:
double NEd0

Remarks

See Also

RHSChordConnection Class


VEd0 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.VEd0 Field
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Chord shear force

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VEd0
Visual Basic (Declaration)
Public VEd0 As Double
Visual C++
public:
double VEd0

Remarks

See Also

RHSChordConnection Class


RHSChordConnection Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection Methods
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

The RHSChordConnection type exposes the following members.

Methods

Name | Description
AxialResistance_Type1 | Overloaded.
AxialResistance_Type2 | Overloaded.
AxialResistance_Type3 | Overloaded.
AxialResistance_Type4 | Overloaded.
AxialResistance_Type5 | Overloaded.
AxialResistance_Type6 | Overloaded.
AxialResistance_Type7 | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RHSChordConnection Class


AxialResistance_Type1 Method

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type1 Method
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Overload List

Name | Description
AxialResistance_Type1(CHS, Double, SteelGrade, Double) | Type 1 joint calculation Variables definition:
AxialResistance_Type1(RHS, Double, SteelGrade, Double) | Type 1 joint calculation Variables definition:

See Also

RHSChordConnection Class
RHSChordConnection Members


AxialResistance_Type1 Method (, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type1 Method (, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 1 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type1(
    CHS Brace1,
    double theta1,
    SteelGrade Brace1Steel,
    double N1
)
Visual Basic (Declaration)
Public Function AxialResistance_Type1 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    Brace1Steel As SteelGrade, _
    N1 As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type1(
    CHS^ Brace1,
    double theta1,
    SteelGrade^ Brace1Steel,
    double N1
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
N1
Type: System..::.Double
Axial force of brace 1 (compressive)

Return Value

True, if all resistance criteria are met

Remarks

N1 positive signing accoring to tables 7.10 and 7.12

See Also

RHSChordConnection Class
AxialResistance_Type1 Overload


AxialResistance_Type1 Method (, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type1 Method (, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 1 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type1(
    RHS Brace1,
    double theta1,
    SteelGrade Brace1Steel,
    double N1
)
Visual Basic (Declaration)
Public Function AxialResistance_Type1 ( _
    Brace1 As RHS, _
    theta1 As Double, _
    Brace1Steel As SteelGrade, _
    N1 As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type1(
    RHS^ Brace1,
    double theta1,
    SteelGrade^ Brace1Steel,
    double N1
)

Parameters

Brace1
Type: RHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
N1
Type: System..::.Double
Axial force of brace 1 (compressive)

Return Value

True, if all resistance criteria are met

Remarks

N1 positive signing accoring to tables 7.10 and 7.12

See Also

RHSChordConnection Class
AxialResistance_Type1 Overload


AxialResistance_Type2 Method

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type2 Method
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Overload List

Name | Description
AxialResistance_Type2(CHS, Double, Double, SteelGrade, CHS, Double, Double, SteelGrade, Double) | Type 2 joint calculation Variables definition:
AxialResistance_Type2(RHS, Double, Double, SteelGrade, RHS, Double, Double, SteelGrade, Double) | Type 2 joint calculation Variables definition:

See Also

RHSChordConnection Class
RHSChordConnection Members


AxialResistance_Type2 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type2 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 2 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type2(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel,
    CHS Brace2,
    double theta2,
    double N2,
    SteelGrade Brace2Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type2 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade, _
    Brace2 As CHS, _
    theta2 As Double, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type2(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel,
    CHS^ Brace2,
    double theta2,
    double N2,
    SteelGrade^ Brace2Steel,
    double g
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1 (compressive)
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
Brace2
Type: CHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
g
Type: System..::.Double
Gap length

Variables definition:

Return Value

True, if all resistance criteria are met

Remarks

N1, N2 positive signing accoring to tables 7.10 and 7.12

See Also

RHSChordConnection Class
AxialResistance_Type2 Overload


AxialResistance_Type2 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type2 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 2 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type2(
    RHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel,
    RHS Brace2,
    double theta2,
    double N2,
    SteelGrade Brace2Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type2 ( _
    Brace1 As RHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade, _
    Brace2 As RHS, _
    theta2 As Double, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type2(
    RHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel,
    RHS^ Brace2,
    double theta2,
    double N2,
    SteelGrade^ Brace2Steel,
    double g
)

Parameters

Brace1
Type: RHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
Brace2
Type: RHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
g
Type: System..::.Double
Gap length

Variables definition:

Return Value

True, if all resistance criteria are met

Remarks

N1, N2 positive signing accoring to tables 7.10 and 7.12

See Also

RHSChordConnection Class
AxialResistance_Type2 Overload


AxialResistance_Type3 Method

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type3 Method
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Overload List

Name | Description
AxialResistance_Type3(CHS, Double, Double, SteelGrade, CHS, Double, SteelGrade, Double, Double) | Type 3 joint calculation Variables definition:
AxialResistance_Type3(RHS, Double, Double, SteelGrade, RHS, Double, SteelGrade, Double, Double) | Type 3 joint calculation Variables definition:

See Also

RHSChordConnection Class
RHSChordConnection Members


AxialResistance_Type3 Method (, Double, Double, SteelGrade, , Double, SteelGrade, Double, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type3 Method (, Double, Double, SteelGrade, , Double, SteelGrade, Double, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 3 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type3(
    CHS Bracei,
    double thetai,
    double Ni,
    SteelGrade BraceiSteel,
    CHS Bracej,
    double Nj,
    SteelGrade BracejSteel,
    double p,
    double q
)
Visual Basic (Declaration)
Public Function AxialResistance_Type3 ( _
    Bracei As CHS, _
    thetai As Double, _
    Ni As Double, _
    BraceiSteel As SteelGrade, _
    Bracej As CHS, _
    Nj As Double, _
    BracejSteel As SteelGrade, _
    p As Double, _
    q As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type3(
    CHS^ Bracei,
    double thetai,
    double Ni,
    SteelGrade^ BraceiSteel,
    CHS^ Bracej,
    double Nj,
    SteelGrade^ BracejSteel,
    double p,
    double q
)

Parameters

Bracei
Type: CHS
Overlapping brace
thetai
Type: System..::.Double
Angle of overlapping brace
Ni
Type: System..::.Double
Axial force of overlapping brace
BraceiSteel
Type: SteelConnectionsEC3..::.SteelGrade
Overlapping brace steel
Bracej
Type: CHS
Overlapped brace
Nj
Type: System..::.Double
Axial force of overlapped brace
BracejSteel
Type: SteelConnectionsEC3..::.SteelGrade
Overlapped brace steel
p
Type: System..::.Double
overlapped distance p

q
Type: System..::.Double
overlapping length q

Return Value

True, if all resistance criteria are met

Remarks

Ni, Nj positive signing accoring to tables 7.10 and 7.12

See Also

RHSChordConnection Class
AxialResistance_Type3 Overload


AxialResistance_Type3 Method (, Double, Double, SteelGrade, , Double, SteelGrade, Double, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type3 Method (, Double, Double, SteelGrade, , Double, SteelGrade, Double, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 3 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type3(
    RHS Bracei,
    double thetai,
    double Ni,
    SteelGrade BraceiSteel,
    RHS Bracej,
    double Nj,
    SteelGrade BracejSteel,
    double p,
    double q
)
Visual Basic (Declaration)
Public Function AxialResistance_Type3 ( _
    Bracei As RHS, _
    thetai As Double, _
    Ni As Double, _
    BraceiSteel As SteelGrade, _
    Bracej As RHS, _
    Nj As Double, _
    BracejSteel As SteelGrade, _
    p As Double, _
    q As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type3(
    RHS^ Bracei,
    double thetai,
    double Ni,
    SteelGrade^ BraceiSteel,
    RHS^ Bracej,
    double Nj,
    SteelGrade^ BracejSteel,
    double p,
    double q
)

Parameters

Bracei
Type: RHS
Overlapping brace
thetai
Type: System..::.Double
Angle of overlapping brace
Ni
Type: System..::.Double
Axial force of overlapping brace
BraceiSteel
Type: SteelConnectionsEC3..::.SteelGrade
Overlapping brace steel
Bracej
Type: RHS
Overlapped brace
Nj
Type: System..::.Double
Axial force of overlapped brace
BracejSteel
Type: SteelConnectionsEC3..::.SteelGrade
Overlapped brace steel
p
Type: System..::.Double
overlapped distance p

q
Type: System..::.Double
overlapping length q

Return Value

True, if all resistance criteria are met

Remarks

Ni, Nj positive signing accoring to tables 7.10 and 7.12

See Also

RHSChordConnection Class
AxialResistance_Type3 Overload


AxialResistance_Type4 Method

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type4 Method
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Overload List

Name | Description
AxialResistance_Type4(CHS, Double, Double, SteelGrade) | Type 4 joint calculation Variables definition:
AxialResistance_Type4(RHS, Double, Double, SteelGrade) | Type 4 joint calculation Variables definition:

See Also

RHSChordConnection Class
RHSChordConnection Members


AxialResistance_Type4 Method (, Double, Double, SteelGrade)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type4 Method (, Double, Double, SteelGrade)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 4 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type4(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel
)
Visual Basic (Declaration)
Public Function AxialResistance_Type4 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade _
) As Boolean
Visual C++
public:
bool AxialResistance_Type4(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel

Return Value

True, if all resistance criteria are met

Remarks

N1 positive signing accoring to table 7.6

See Also

RHSChordConnection Class
AxialResistance_Type4 Overload


AxialResistance_Type4 Method (, Double, Double, SteelGrade)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type4 Method (, Double, Double, SteelGrade)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 4 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type4(
    RHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel
)
Visual Basic (Declaration)
Public Function AxialResistance_Type4 ( _
    Brace1 As RHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade _
) As Boolean
Visual C++
public:
bool AxialResistance_Type4(
    RHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel
)

Parameters

Brace1
Type: RHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel

Return Value

True, if all resistance criteria are met

Remarks

N1 positive signing accoring to table 7.6

See Also

RHSChordConnection Class
AxialResistance_Type4 Overload


AxialResistance_Type5 Method

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type5 Method
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Overload List

Name | Description
AxialResistance_Type5(CHS, Double, Double, SteelGrade, CHS, Double, Double, SteelGrade, CHS, Double, Double, SteelGrade, Double) | Type 5 joint calculation Variables definition:
AxialResistance_Type5(RHS, Double, Double, SteelGrade, RHS, Double, Double, SteelGrade, RHS, Double, Double, SteelGrade, Double) | Type 5 joint calculation Variables definition:

See Also

RHSChordConnection Class
RHSChordConnection Members


AxialResistance_Type5 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type5 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 5 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type5(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel,
    CHS Brace2,
    double theta2,
    double N2,
    SteelGrade Brace2Steel,
    CHS Brace3,
    double theta3,
    double N3,
    SteelGrade Brace3Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type5 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade, _
    Brace2 As CHS, _
    theta2 As Double, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    Brace3 As CHS, _
    theta3 As Double, _
    N3 As Double, _
    Brace3Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type5(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel,
    CHS^ Brace2,
    double theta2,
    double N2,
    SteelGrade^ Brace2Steel,
    CHS^ Brace3,
    double theta3,
    double N3,
    SteelGrade^ Brace3Steel,
    double g
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
Brace2
Type: CHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
Brace3
Type: CHS
Brace 3 object
theta3
Type: System..::.Double
Angle of brace 3
N3
Type: System..::.Double
Axial force of brace 3
Brace3Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 3 steel
g
Type: System..::.Double
gap length

Variables definition:

Return Value

True, if all resistance criteria are met

Remarks

N1, N2, N3 positive signing accoring to table 7.6

See Also

RHSChordConnection Class
AxialResistance_Type5 Overload


AxialResistance_Type5 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type5 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 5 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type5(
    RHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel,
    RHS Brace2,
    double theta2,
    double N2,
    SteelGrade Brace2Steel,
    RHS Brace3,
    double theta3,
    double N3,
    SteelGrade Brace3Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type5 ( _
    Brace1 As RHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade, _
    Brace2 As RHS, _
    theta2 As Double, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    Brace3 As RHS, _
    theta3 As Double, _
    N3 As Double, _
    Brace3Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type5(
    RHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel,
    RHS^ Brace2,
    double theta2,
    double N2,
    SteelGrade^ Brace2Steel,
    RHS^ Brace3,
    double theta3,
    double N3,
    SteelGrade^ Brace3Steel,
    double g
)

Parameters

Brace1
Type: RHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
Brace2
Type: RHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
Brace3
Type: RHS
Brace 3 object
theta3
Type: System..::.Double
Angle of brace 3
N3
Type: System..::.Double
Axial force of brace 3
Brace3Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 3 steel
g
Type: System..::.Double
gap length

Variables definition:

Return Value

True, if all resistance criteria are met

Remarks

N1, N2, N3 positive signing accoring to table 7.6

See Also

RHSChordConnection Class
AxialResistance_Type5 Overload


AxialResistance_Type6 Method

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type6 Method
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Overload List

Name | Description
AxialResistance_Type6(CHS, Double, Double, SteelGrade, CHS, Double, Double, SteelGrade, Double) | Type 6 joint calculation Variables definition:
AxialResistance_Type6(RHS, Double, Double, SteelGrade, RHS, Double, Double, SteelGrade, Double) | Type 6 joint calculation Variables definition:

See Also

RHSChordConnection Class
RHSChordConnection Members


AxialResistance_Type6 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type6 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 6 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type6(
    CHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel,
    CHS Brace2,
    double theta2,
    double N2,
    SteelGrade Brace2Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type6 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade, _
    Brace2 As CHS, _
    theta2 As Double, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type6(
    CHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel,
    CHS^ Brace2,
    double theta2,
    double N2,
    SteelGrade^ Brace2Steel,
    double g
)

Parameters

Brace1
Type: CHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
Brace2
Type: CHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
g
Type: System..::.Double
Not important for this function, it is used to have simmilar signature to AxialResistance_Type7

Variables definition:

Return Value

True, if all resistance criteria are met

Remarks

N1, N2 positive signing accoring to table 7.6, this joint is a gap joint

See Also

RHSChordConnection Class
AxialResistance_Type6 Overload


AxialResistance_Type6 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type6 Method (, Double, Double, SteelGrade, , Double, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library
Type 6 joint calculation

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type6(
    RHS Brace1,
    double theta1,
    double N1,
    SteelGrade Brace1Steel,
    RHS Brace2,
    double theta2,
    double N2,
    SteelGrade Brace2Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type6 ( _
    Brace1 As RHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace1Steel As SteelGrade, _
    Brace2 As RHS, _
    theta2 As Double, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type6(
    RHS^ Brace1,
    double theta1,
    double N1,
    SteelGrade^ Brace1Steel,
    RHS^ Brace2,
    double theta2,
    double N2,
    SteelGrade^ Brace2Steel,
    double g
)

Parameters

Brace1
Type: RHS
Brace 1 object
theta1
Type: System..::.Double
Angle of brace 1
N1
Type: System..::.Double
Axial force of brace 1
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 1 steel
Brace2
Type: RHS
Brace 2 object
theta2
Type: System..::.Double
Angle of brace 2
N2
Type: System..::.Double
Axial force of brace 2
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
Brace 2 steel
g
Type: System..::.Double
Not important for this function, it is used to have simmilar signature to AxialResistance_Type7

Variables definition:

Return Value

True, if all resistance criteria are met

Remarks

N1, N2 positive signing accoring to table 7.6, this joint is a gap joint

See Also

RHSChordConnection Class
AxialResistance_Type6 Overload


AxialResistance_Type7 Method

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type7 Method
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Overload List

Name | Description
AxialResistance_Type7(CHS, Double, Double, CHS, Double, SteelGrade, Double, SteelGrade, Double) |
AxialResistance_Type7(RHS, Double, Double, RHS, Double, SteelGrade, Double, SteelGrade, Double) |

See Also

RHSChordConnection Class
RHSChordConnection Members


AxialResistance_Type7 Method (, Double, Double, , Double, SteelGrade, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type7 Method (, Double, Double, , Double, SteelGrade, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type7(
    CHS Brace1,
    double theta1,
    double N1,
    CHS Brace2,
    double theta2,
    SteelGrade Brace1Steel,
    double N2,
    SteelGrade Brace2Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type7 ( _
    Brace1 As CHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace2 As CHS, _
    theta2 As Double, _
    Brace1Steel As SteelGrade, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type7(
    CHS^ Brace1,
    double theta1,
    double N1,
    CHS^ Brace2,
    double theta2,
    SteelGrade^ Brace1Steel,
    double N2,
    SteelGrade^ Brace2Steel,
    double g
)

Parameters

Brace1
Type: CHS
theta1
Type: System..::.Double
N1
Type: System..::.Double
Brace2
Type: CHS
theta2
Type: System..::.Double
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
N2
Type: System..::.Double
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
g
Type: System..::.Double

See Also

RHSChordConnection Class
AxialResistance_Type7 Overload


AxialResistance_Type7 Method (, Double, Double, , Double, SteelGrade, Double, SteelGrade, Double)

[image]

ENGISSOL - EC3 Steel Connection Design Library
RHSChordConnection..::.AxialResistance_Type7 Method (, Double, Double, , Double, SteelGrade, Double, SteelGrade, Double)
RHSChordConnection Class See Also Send Feedback
EC3 Steel Connection Design Library

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AxialResistance_Type7(
    RHS Brace1,
    double theta1,
    double N1,
    RHS Brace2,
    double theta2,
    SteelGrade Brace1Steel,
    double N2,
    SteelGrade Brace2Steel,
    double g
)
Visual Basic (Declaration)
Public Function AxialResistance_Type7 ( _
    Brace1 As RHS, _
    theta1 As Double, _
    N1 As Double, _
    Brace2 As RHS, _
    theta2 As Double, _
    Brace1Steel As SteelGrade, _
    N2 As Double, _
    Brace2Steel As SteelGrade, _
    g As Double _
) As Boolean
Visual C++
public:
bool AxialResistance_Type7(
    RHS^ Brace1,
    double theta1,
    double N1,
    RHS^ Brace2,
    double theta2,
    SteelGrade^ Brace1Steel,
    double N2,
    SteelGrade^ Brace2Steel,
    double g
)

Parameters

Brace1
Type: RHS
theta1
Type: System..::.Double
N1
Type: System..::.Double
Brace2
Type: RHS
theta2
Type: System..::.Double
Brace1Steel
Type: SteelConnectionsEC3..::.SteelGrade
N2
Type: System..::.Double
Brace2Steel
Type: SteelConnectionsEC3..::.SteelGrade
g
Type: System..::.Double

See Also

RHSChordConnection Class
AxialResistance_Type7 Overload


SingleBoltedPlate Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a general bolted plate

Variables definition:

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SingleBoltedPlate
Visual Basic (Declaration)
Public Class SingleBoltedPlate
Visual C++
public ref class SingleBoltedPlate

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.SingleBoltedPlate

See Also

SingleBoltedPlate Members


SingleBoltedPlate Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate Members
SingleBoltedPlate Class Constructors Methods Fields Properties See Also Send Feedback
EC3 Steel Connection Design Library

The SingleBoltedPlate type exposes the following members.

Constructors

Name | Description
SingleBoltedPlate | Initializes a new instance of the SingleBoltedPlate class

Methods

Name | Description
Anet_Forcex | Calculation of the net tension area of for horizontal load
Anet_Forcey | Calculation of the net tension area of for vertical load
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FbRd | Bearing resistance of the bolt group
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FvRd | Shear resistance of the bolt group
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns a list of strings that describe the input warnings regarding the bolt placement on the plate
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
px | Horizontal inner distance between bolts
py | Vertical inner distance between bolts
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
b | Width
BoltColumns | Bolt columns number
BoltRows | Bolt rows number
Bolts | Bolts object
ex1 | Left horizontal edge distance
ex2 | Right horizontal edge distance
ey1 | Lower vertical edge distance
ey2 | Upper vertical edge distance
h | Height
Steel | Steel grade object
t | Thickness

Properties

Name | Description
BoltsNr | Total bolts count

See Also

SingleBoltedPlate Class


SingleBoltedPlate Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate Constructor
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Initializes a new instance of the SingleBoltedPlate class

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SingleBoltedPlate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SingleBoltedPlate()

See Also

SingleBoltedPlate Class


SingleBoltedPlate Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate Fields
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library

The SingleBoltedPlate type exposes the following members.

Fields

Name | Description
b | Width
BoltColumns | Bolt columns number
BoltRows | Bolt rows number
Bolts | Bolts object
ex1 | Left horizontal edge distance
ex2 | Right horizontal edge distance
ey1 | Lower vertical edge distance
ey2 | Upper vertical edge distance
h | Height
Steel | Steel grade object
t | Thickness

See Also

SingleBoltedPlate Class


b Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.b Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Width

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double b
Visual Basic (Declaration)
Public b As Double
Visual C++
public:
double b

Remarks

See Also

SingleBoltedPlate Class


BoltColumns Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.BoltColumns Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolt columns number

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int BoltColumns
Visual Basic (Declaration)
Public BoltColumns As Integer
Visual C++
public:
int BoltColumns

Remarks

See Also

SingleBoltedPlate Class


BoltRows Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.BoltRows Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolt rows number

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int BoltRows
Visual Basic (Declaration)
Public BoltRows As Integer
Visual C++
public:
int BoltRows

Remarks

See Also

SingleBoltedPlate Class


Bolts Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.Bolts Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Bolts object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Bolts Bolts
Visual Basic (Declaration)
Public Bolts As Bolts
Visual C++
public:
Bolts^ Bolts

Remarks

See Also

SingleBoltedPlate Class


ex1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.ex1 Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Left horizontal edge distance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ex1
Visual Basic (Declaration)
Public ex1 As Double
Visual C++
public:
double ex1

Remarks

See Also

SingleBoltedPlate Class


ex2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.ex2 Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Right horizontal edge distance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ex2
Visual Basic (Declaration)
Public ex2 As Double
Visual C++
public:
double ex2

Remarks

See Also

SingleBoltedPlate Class


ey1 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.ey1 Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Lower vertical edge distance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ey1
Visual Basic (Declaration)
Public ey1 As Double
Visual C++
public:
double ey1

Remarks

See Also

SingleBoltedPlate Class


ey2 Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.ey2 Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Upper vertical edge distance

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ey2
Visual Basic (Declaration)
Public ey2 As Double
Visual C++
public:
double ey2

Remarks

See Also

SingleBoltedPlate Class


h Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.h Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Height

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double h
Visual Basic (Declaration)
Public h As Double
Visual C++
public:
double h

Remarks

See Also

SingleBoltedPlate Class


Steel Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.Steel Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Steel grade object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade Steel
Visual Basic (Declaration)
Public Steel As SteelGrade
Visual C++
public:
SteelGrade^ Steel

Remarks

See Also

SingleBoltedPlate Class


t Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.t Field
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Thickness

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double t
Visual Basic (Declaration)
Public t As Double
Visual C++
public:
double t

Remarks

See Also

SingleBoltedPlate Class


SingleBoltedPlate Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate Methods
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library

The SingleBoltedPlate type exposes the following members.

Methods

Name | Description
Anet_Forcex | Calculation of the net tension area of for horizontal load
Anet_Forcey | Calculation of the net tension area of for vertical load
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FbRd | Bearing resistance of the bolt group
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FvRd | Shear resistance of the bolt group
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInputWarnings | Returns a list of strings that describe the input warnings regarding the bolt placement on the plate
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
px | Horizontal inner distance between bolts
py | Vertical inner distance between bolts
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleBoltedPlate Class


Anet_Forcex Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.Anet_Forcex Method
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Calculation of the net tension area of for horizontal load

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Anet_Forcex()
Visual Basic (Declaration)
Public Function Anet_Forcex As Double
Visual C++
public:
double Anet_Forcex()

Return Value

Net tension area for horizontal load

Remarks

See Also

SingleBoltedPlate Class


Anet_Forcey Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.Anet_Forcey Method
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Calculation of the net tension area of for vertical load

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Anet_Forcey()
Visual Basic (Declaration)
Public Function Anet_Forcey As Double
Visual C++
public:
double Anet_Forcey()

Return Value

Net tension area for vertical load

Remarks

See Also

SingleBoltedPlate Class


FbRd Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.FbRd Method
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Bearing resistance of the bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FbRd(
    SingleBoltedPlate..::.LoadTransferSingleBoltedPlate _LoadTransefr,
    double t_other_plate
)
Visual Basic (Declaration)
Public Function FbRd ( _
    _LoadTransefr As SingleBoltedPlate..::.LoadTransferSingleBoltedPlate, _
    t_other_plate As Double _
) As Double
Visual C++
public:
double FbRd(
    SingleBoltedPlate..::.LoadTransferSingleBoltedPlate _LoadTransefr,
    double t_other_plate
)

Parameters

_LoadTransefr
Type: SteelConnectionsEC3..::.SingleBoltedPlate..::.LoadTransferSingleBoltedPlate
Load transfer direction
t_other_plate
Type: System..::.Double
The thickness of another plate to consider (if any)

Return Value

Bearing resistance

Remarks

See Also

SingleBoltedPlate Class


FvRd Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.FvRd Method
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Shear resistance of the bolt group

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FvRd()
Visual Basic (Declaration)
Public Function FvRd As Double
Visual C++
public:
double FvRd()

Return Value

Shear resistance

Remarks

See Also

SingleBoltedPlate Class


GetInputWarnings Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.GetInputWarnings Method
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Returns a list of strings that describe the input warnings regarding the bolt placement on the plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<string> GetInputWarnings(
    SingleBoltedPlate..::.LoadTransferSingleBoltedPlate LoadTransfer
)
Visual Basic (Declaration)
Public Function GetInputWarnings ( _
    LoadTransfer As SingleBoltedPlate..::.LoadTransferSingleBoltedPlate _
) As List(Of String)
Visual C++
public:
List<String^>^ GetInputWarnings(
    SingleBoltedPlate..::.LoadTransferSingleBoltedPlate LoadTransfer
)

Parameters

LoadTransfer
Type: SteelConnectionsEC3..::.SingleBoltedPlate..::.LoadTransferSingleBoltedPlate
LoadTransferSingleBoltedPlate object

Return Value

List of warnings

Remarks

See Also

SingleBoltedPlate Class


px Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.px Method
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Horizontal inner distance between bolts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double px()
Visual Basic (Declaration)
Public Function px As Double
Visual C++
public:
double px()

Return Value

The horizontal distance between the bolts

Remarks

See Also

SingleBoltedPlate Class


py Method

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.py Method
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Vertical inner distance between bolts

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double py()
Visual Basic (Declaration)
Public Function py As Double
Visual C++
public:
double py()

Return Value

The vertical distance between the bolts

Remarks

See Also

SingleBoltedPlate Class


SingleBoltedPlate Properties

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate Properties
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library

The SingleBoltedPlate type exposes the following members.

Properties

Name | Description
BoltsNr | Total bolts count

See Also

SingleBoltedPlate Class


BoltsNr Property

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.BoltsNr Property
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Total bolts count

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int BoltsNr { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoltsNr As Integer
Visual C++
public:
property int BoltsNr {
    int get ();
}

Field Value

Return Value

Count of total bolts

Remarks

See Also

SingleBoltedPlate Class


SingleBoltedPlate.LoadTransferSingleBoltedPlate Enumeration

[image]

ENGISSOL - EC3 Steel Connection Design Library
SingleBoltedPlate..::.LoadTransferSingleBoltedPlate Enumeration
SingleBoltedPlate Class See Also Send Feedback
EC3 Steel Connection Design Library
Represents the load direction transferred to the plate

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum LoadTransferSingleBoltedPlate
Visual Basic (Declaration)
Public Enumeration LoadTransferSingleBoltedPlate
Visual C++
public enum class LoadTransferSingleBoltedPlate

Members

Member name | Description
Up | Load transfer upwards
Down | Load transfer downwards
Right | Load transfer rightwards
Left | Load transfer leftwards

Remarks

See Also

SteelConnectionsEC3 Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


SteelGrade Class

[image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade Class
Members See Also Send Feedback
EC3 Steel Connection Design Library
Represents a steel grade according to prEN1993

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SteelGrade
Visual Basic (Declaration)
Public Class SteelGrade
Visual C++
public ref class SteelGrade

Remarks

All units in kN, mm unless other specified

Inheritance Hierarchy

System..::.Object
SteelConnectionsEC3..::.SteelGrade

See Also

SteelGrade Members


SteelGrade Members

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade Members
SteelGrade Class Constructors Methods Fields Properties See Also Send Feedback
EC3 Steel Connection Design Library

The SteelGrade type exposes the following members.

Constructors

Name | Description
SteelGrade | Construction of a steel grade object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
E | Elasticity modulus of steel in kN/mm^2
Name | Name of the steel grade

Properties

Name | Description
fu | Ultimate stress of steel in kN/mm^2
fy | Yield stress of steel in kN/mm^2

See Also

SteelGrade Class


SteelGrade Constructor

[image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade Constructor
SteelGrade Class See Also Send Feedback
EC3 Steel Connection Design Library
Construction of a steel grade object

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade(
    SteelGrade..::.Grade _Name
)
Visual Basic (Declaration)
Public Sub New ( _
    _Name As SteelGrade..::.Grade _
)
Visual C++
public:
SteelGrade(
    SteelGrade..::.Grade _Name
)

Parameters

_Name
Type: SteelConnectionsEC3..::.SteelGrade..::.Grade
Name of the desired steel grade

Remarks

See Also

SteelGrade Class


SteelGrade Fields

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade Fields
SteelGrade Class See Also Send Feedback
EC3 Steel Connection Design Library

The SteelGrade type exposes the following members.

Fields

Name | Description
E | Elasticity modulus of steel in kN/mm^2
Name | Name of the steel grade

See Also

SteelGrade Class


E Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade..::.E Field
SteelGrade Class See Also Send Feedback
EC3 Steel Connection Design Library
Elasticity modulus of steel in kN/mm^2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double E
Visual Basic (Declaration)
Public E As Double
Visual C++
public:
double E

Remarks

See Also

SteelGrade Class


Name Field

[image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade..::.Name Field
SteelGrade Class See Also Send Feedback
EC3 Steel Connection Design Library
Name of the steel grade

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SteelGrade..::.Grade Name
Visual Basic (Declaration)
Public Name As SteelGrade..::.Grade
Visual C++
public:
SteelGrade..::.Grade Name

Remarks

See Also

SteelGrade Class


SteelGrade Methods

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade Methods
SteelGrade Class See Also Send Feedback
EC3 Steel Connection Design Library

The SteelGrade type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SteelGrade Class


SteelGrade Properties

[image] [image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade Properties
SteelGrade Class See Also Send Feedback
EC3 Steel Connection Design Library

The SteelGrade type exposes the following members.

Properties

Name | Description
fu | Ultimate stress of steel in kN/mm^2
fy | Yield stress of steel in kN/mm^2

See Also

SteelGrade Class


fu Property

[image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade..::.fu Property
SteelGrade Class See Also Send Feedback
EC3 Steel Connection Design Library
Ultimate stress of steel in kN/mm^2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object fu { get; }
Visual Basic (Declaration)
Public ReadOnly Property fu As Object
Visual C++
public:
property Object^ fu {
    Object^ get ();
}

Field Value

Return Value

Remarks

See Also

SteelGrade Class


fy Property

[image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade..::.fy Property
SteelGrade Class See Also Send Feedback
EC3 Steel Connection Design Library
Yield stress of steel in kN/mm^2

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object fy { get; }
Visual Basic (Declaration)
Public ReadOnly Property fy As Object
Visual C++
public:
property Object^ fy {
    Object^ get ();
}

Field Value

Return Value

Remarks

See Also

SteelGrade Class


SteelGrade.Grade Enumeration

[image]

ENGISSOL - EC3 Steel Connection Design Library
SteelGrade..::.Grade Enumeration
SteelGrade Class See Also Send Feedback
EC3 Steel Connection Design Library
Enumeration of the steel grades supported by prEN1993

Namespace: SteelConnectionsEC3
Assembly: SteelConnectionsEC3 (in SteelConnectionsEC3.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Grade
Visual Basic (Declaration)
Public Enumeration Grade
Visual C++
public enum class Grade

Members

Member name | Description
S235 | Steel grade S235
S275 | Steel grade S275
S355 | Steel grade S355
S450 | Steel grade S450
S275_NNL | Steel grade S275 NNL
S355_NNL | Steel grade S355 NNL
S420_NNL | Steel grade S420 NNL
S460_NNL | Steel grade S460 NNL
S275_MML | Steel grade S275 MML
S355_MML | Steel grade S355 MML
S420_MML | Steel grade S420 MML
S460_MML | Steel grade S460 MML
S235_W | Steel grade S235 W
S355_W | Steel grade S355 W
S460_QQLQL1 | Steel grade S460 QQLQL1

Remarks

See Also

SteelConnectionsEC3 Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright