Frame3D Namespace

[image]

ENGISSOL - 3D Frame Library
Frame3D Namespace
Send Feedback
3D Frame Library

Classes

Class | Description
FloorDiaphragm | Diaphragm object between nodes
FrameElementSection | Section object for Frame elements
FrameElementSectionModifiers | Class that contains the stiffness modifiers of a frame element section
FrameSuperElement | Super frame element
FrameSuperElementPointLoad | Point loads collection for super frame element
FrameSuperElementUniformLoad | Uniform loads collection for super frame element
GeometricNonLinearCase |
LinearLoadCaseForFloorDiaphragm | Load Case class (linear), for example DEAD, LIVE etc. for a floor diaphragm
LinearLoadCaseForSuperFrameElement | Load Case class (linear), for example DEAD, LIVE etc. for super frame element
LinearLoadCaseForSuperNode | Load Case class (linear), for example DEAD, LIVE etc. for a node
LoadCaseWithFactor | Represents a load case with its corresponding factor for a load combination
LoadCombination | Represents a load combination
Material | Material class
MemberReleases | Degrees of freedom releases at an element node with respect to the local coordinate system of an element
Model | Represents the entire static model
ResponseSpectrumCase | Represents a response spectrum case for a given ground acceleration direction
ResponseSpectrumFunction | Represents a response spectrum function
SuperNode | A super node represents a node in 3d space
SuperPointLoad | Point load class for super frame element
SuperUniformLoad | Uniform load class for super frame element
TimeHistoryCase | Represents a time history case for a given ground acceleration direction
TimeHistoryFunction | Represents a time history function

Enumerations

Enumeration | Description
ComboType | Defines how the different load cases that belong to a load combination will be combined
GeometricNonLinearCase..::.UpdateStiffnessMatrixMethod | Enumerator with all possible cases for the update of the global stiffness matrix
GroundMotionDirection |
LoadCaseType | Load case type
LoadCordinateSystem | Defines whether loads given with respect to the local or global coordinate system
LoadDefinitionFromStartingNode | Defines how loads are given with respect to the starting node of the super frame element
MemberType | Frame super element type
ModeComboType |
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


ComboType Enumeration

[image]

ENGISSOL - 3D Frame Library
ComboType Enumeration
See Also Send Feedback
3D Frame Library
Defines how the different load cases that belong to a load combination will be combined

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public enum ComboType
Visual Basic (Declaration)
Public Enumeration ComboType
Visual C++
public enum class ComboType

Members

Member name | Description
ADD | Additive: Results from the included load cases or combos are added
ENVE | Envelope: Results from the included load cases or combos are enveloped to find the maximum and minimum values
ABS | Absolute: The absolute values of the results from the included load cases or combos are added
SRSS | SRSS: The square root of the sum of the squares of the results from the included load cases or combos is computed.

See Also

Frame3D Namespace


FloorDiaphragm Class

[image]

ENGISSOL - 3D Frame Library
FloorDiaphragm Class
Members See Also Send Feedback
3D Frame Library
Diaphragm object between nodes

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class FloorDiaphragm
Visual Basic (Declaration)
Public Class FloorDiaphragm
Visual C++
public ref class FloorDiaphragm

Inheritance Hierarchy

System..::.Object
Frame3D..::.FloorDiaphragm

See Also

FloorDiaphragm Members


FloorDiaphragm Members

[image] [image]

ENGISSOL - 3D Frame Library
FloorDiaphragm Members
FloorDiaphragm Class Constructors Methods Fields See Also Send Feedback
3D Frame Library

The FloorDiaphragm type exposes the following members.

Constructors

Name | Description
FloorDiaphragm | Floor diaphragm object construction

Methods

Name | Description
GetDisplacementsForLoadCase | Gets nodal displacements
GetDisplacementsForLoadCombination | Performs linear superposition to calculate nodal displacements for the given load combination

Fields

Name | Description
BoundaryPoints | SuperNodes collection that define the diaphragm, anti-clockwise direction! Each diaphragm is defined in xy plane (global system)!
index | Diaphragm index, no zero based
LinearLoadCasesList | Collection of LinearLoadCaseForFloorDiaphragm objects
z | z coordinate of all diaphragm points

See Also

FloorDiaphragm Class


FloorDiaphragm Constructor

[image]

ENGISSOL - 3D Frame Library
FloorDiaphragm Constructor
FloorDiaphragm Class See Also Send Feedback
3D Frame Library
Floor diaphragm object construction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FloorDiaphragm(
    int _index,
    List<Geometry..::.XY> _BoundaryPoints,
    double _z
)
Visual Basic (Declaration)
Public Sub New ( _
    _index As Integer, _
    _BoundaryPoints As List(Of Geometry..::.XY), _
    _z As Double _
)
Visual C++
public:
FloorDiaphragm(
    int _index,
    List<Geometry..::.XY>^ _BoundaryPoints,
    double _z
)

Parameters

_index
Type: System..::.Int32
Unique floor diaphragm index
_BoundaryPoints
Type: System.Collections.Generic..::.List <(Of <( Geometry..::.XY >)>)
List of boundary points, anti-clockwise direction
_z
Type: System..::.Double
z coordinate of floor diaphragm

See Also

FloorDiaphragm Class


FloorDiaphragm Fields

[image] [image]

ENGISSOL - 3D Frame Library
FloorDiaphragm Fields
FloorDiaphragm Class See Also Send Feedback
3D Frame Library

The FloorDiaphragm type exposes the following members.

Fields

Name | Description
BoundaryPoints | SuperNodes collection that define the diaphragm, anti-clockwise direction! Each diaphragm is defined in xy plane (global system)!
index | Diaphragm index, no zero based
LinearLoadCasesList | Collection of LinearLoadCaseForFloorDiaphragm objects
z | z coordinate of all diaphragm points

See Also

FloorDiaphragm Class


BoundaryPoints Field

[image]

ENGISSOL - 3D Frame Library
FloorDiaphragm..::.BoundaryPoints Field
FloorDiaphragm Class See Also Send Feedback
3D Frame Library
SuperNodes collection that define the diaphragm, anti-clockwise direction! Each diaphragm is defined in xy plane (global system)!

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<Geometry..::.XY> BoundaryPoints
Visual Basic (Declaration)
Public BoundaryPoints As List(Of Geometry..::.XY)
Visual C++
public:
List<Geometry..::.XY>^ BoundaryPoints

See Also

FloorDiaphragm Class


index Field

[image]

ENGISSOL - 3D Frame Library
FloorDiaphragm..::.index Field
FloorDiaphragm Class See Also Send Feedback
3D Frame Library
Diaphragm index, no zero based

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public int index
Visual Basic (Declaration)
Public index As Integer
Visual C++
public:
int index

See Also

FloorDiaphragm Class


LinearLoadCasesList Field

[image]

ENGISSOL - 3D Frame Library
FloorDiaphragm..::.LinearLoadCasesList Field
FloorDiaphragm Class See Also Send Feedback
3D Frame Library
Collection of LinearLoadCaseForFloorDiaphragm objects

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<LinearLoadCaseForFloorDiaphragm> LinearLoadCasesList
Visual Basic (Declaration)
Public LinearLoadCasesList As List(Of LinearLoadCaseForFloorDiaphragm)
Visual C++
public:
List<LinearLoadCaseForFloorDiaphragm^>^ LinearLoadCasesList

See Also

FloorDiaphragm Class


z Field

[image]

ENGISSOL - 3D Frame Library
FloorDiaphragm..::.z Field
FloorDiaphragm Class See Also Send Feedback
3D Frame Library
z coordinate of all diaphragm points

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double z
Visual Basic (Declaration)
Public z As Double
Visual C++
public:
double z

See Also

FloorDiaphragm Class


FloorDiaphragm Methods

[image] [image]

ENGISSOL - 3D Frame Library
FloorDiaphragm Methods
FloorDiaphragm Class See Also Send Feedback
3D Frame Library

The FloorDiaphragm type exposes the following members.

Methods

Name | Description
GetDisplacementsForLoadCase | Gets nodal displacements
GetDisplacementsForLoadCombination | Performs linear superposition to calculate nodal displacements for the given load combination

See Also

FloorDiaphragm Class


GetDisplacementsForLoadCase Method

[image]

ENGISSOL - 3D Frame Library
FloorDiaphragm..::.GetDisplacementsForLoadCase Method
FloorDiaphragm Class See Also Send Feedback
3D Frame Library
Gets nodal displacements

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetDisplacementsForLoadCase(
    string LoadCaseName,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetDisplacementsForLoadCase ( _
    LoadCaseName As String, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetDisplacementsForLoadCase(
    String^ LoadCaseName,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

LoadCaseName
Type: System..::.String
Load case name
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values
stepNr
Type: System..::.Int32
Step number, needed for time history analysis only

See Also

FloorDiaphragm Class


GetDisplacementsForLoadCombination Method

[image]

ENGISSOL - 3D Frame Library
FloorDiaphragm..::.GetDisplacementsForLoadCombination Method
FloorDiaphragm Class See Also Send Feedback
3D Frame Library
Performs linear superposition to calculate nodal displacements for the given load combination

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetDisplacementsForLoadCombination(
    LoadCombination comb,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetDisplacementsForLoadCombination ( _
    comb As LoadCombination, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetDisplacementsForLoadCombination(
    LoadCombination^ comb,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

comb
Type: Frame3D..::.LoadCombination
Load combination object
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values for the given load combination
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values for the given load combination
stepNr
Type: System..::.Int32
Step to get results at (for Time History Analysis only)

See Also

FloorDiaphragm Class


FrameElementSection Class

[image]

ENGISSOL - 3D Frame Library
FrameElementSection Class
Members See Also Send Feedback
3D Frame Library
Section object for Frame elements

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class FrameElementSection
Visual Basic (Declaration)
Public Class FrameElementSection
Visual C++
public ref class FrameElementSection

Inheritance Hierarchy

System..::.Object
Frame3D..::.FrameElementSection

See Also

FrameElementSection Members


FrameElementSection Members

[image] [image]

ENGISSOL - 3D Frame Library
FrameElementSection Members
FrameElementSection Class Constructors Fields See Also Send Feedback
3D Frame Library

The FrameElementSection type exposes the following members.

Constructors

Name | Description
FrameElementSection | Initializes a new instance of the FrameElementSection class

Fields

Name | Description
A | Section area
h | Section height
It | Torsional constant
Iy | Moment of inertia about y local axis
Iz | Moment of inertia about z local axis
ky | Shape coefficient for shear in local element y direction (Shape coefficient=Total Area/Shear Area at examined direction)
kz | Shape coefficient for shear in local element z direction (Shape coefficient=Total Area/Shear Area at examined direction)
Name | Section name
StiffnessModifiers |

See Also

FrameElementSection Class


FrameElementSection Constructor

[image]

ENGISSOL - 3D Frame Library
FrameElementSection Constructor
FrameElementSection Class See Also Send Feedback
3D Frame Library
Initializes a new instance of the FrameElementSection class

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FrameElementSection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FrameElementSection()

See Also

FrameElementSection Class


FrameElementSection Fields

[image] [image]

ENGISSOL - 3D Frame Library
FrameElementSection Fields
FrameElementSection Class See Also Send Feedback
3D Frame Library

The FrameElementSection type exposes the following members.

Fields

Name | Description
A | Section area
h | Section height
It | Torsional constant
Iy | Moment of inertia about y local axis
Iz | Moment of inertia about z local axis
ky | Shape coefficient for shear in local element y direction (Shape coefficient=Total Area/Shear Area at examined direction)
kz | Shape coefficient for shear in local element z direction (Shape coefficient=Total Area/Shear Area at examined direction)
Name | Section name
StiffnessModifiers |

See Also

FrameElementSection Class


A Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSection..::.A Field
FrameElementSection Class See Also Send Feedback
3D Frame Library
Section area

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double A
Visual Basic (Declaration)
Public A As Double
Visual C++
public:
double A

See Also

FrameElementSection Class


h Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSection..::.h Field
FrameElementSection Class See Also Send Feedback
3D Frame Library
Section height

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double h
Visual Basic (Declaration)
Public h As Double
Visual C++
public:
double h

See Also

FrameElementSection Class


It Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSection..::.It Field
FrameElementSection Class See Also Send Feedback
3D Frame Library
Torsional constant

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double It
Visual Basic (Declaration)
Public It As Double
Visual C++
public:
double It

See Also

FrameElementSection Class


Iy Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSection..::.Iy Field
FrameElementSection Class See Also Send Feedback
3D Frame Library
Moment of inertia about y local axis

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Iy
Visual Basic (Declaration)
Public Iy As Double
Visual C++
public:
double Iy

See Also

FrameElementSection Class


Iz Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSection..::.Iz Field
FrameElementSection Class See Also Send Feedback
3D Frame Library
Moment of inertia about z local axis

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Iz
Visual Basic (Declaration)
Public Iz As Double
Visual C++
public:
double Iz

See Also

FrameElementSection Class


ky Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSection..::.ky Field
FrameElementSection Class See Also Send Feedback
3D Frame Library
Shape coefficient for shear in local element y direction (Shape coefficient=Total Area/Shear Area at examined direction)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double ky
Visual Basic (Declaration)
Public ky As Double
Visual C++
public:
double ky

See Also

FrameElementSection Class


kz Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSection..::.kz Field
FrameElementSection Class See Also Send Feedback
3D Frame Library
Shape coefficient for shear in local element z direction (Shape coefficient=Total Area/Shear Area at examined direction)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double kz
Visual Basic (Declaration)
Public kz As Double
Visual C++
public:
double kz

See Also

FrameElementSection Class


Name Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSection..::.Name Field
FrameElementSection Class See Also Send Feedback
3D Frame Library
Section name

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string Name
Visual Basic (Declaration)
Public Name As String
Visual C++
public:
String^ Name

See Also

FrameElementSection Class


StiffnessModifiers Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSection..::.StiffnessModifiers Field
FrameElementSection Class See Also Send Feedback
3D Frame Library

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FrameElementSectionModifiers StiffnessModifiers
Visual Basic (Declaration)
Public StiffnessModifiers As FrameElementSectionModifiers
Visual C++
public:
FrameElementSectionModifiers^ StiffnessModifiers

See Also

FrameElementSection Class


FrameElementSectionModifiers Class

[image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers Class
Members See Also Send Feedback
3D Frame Library
Class that contains the stiffness modifiers of a frame element section

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class FrameElementSectionModifiers
Visual Basic (Declaration)
Public Class FrameElementSectionModifiers
Visual C++
public ref class FrameElementSectionModifiers

Inheritance Hierarchy

System..::.Object
Frame3D..::.FrameElementSectionModifiers

See Also

FrameElementSectionModifiers Members


FrameElementSectionModifiers Members

[image] [image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers Members
FrameElementSectionModifiers Class Constructors Fields See Also Send Feedback
3D Frame Library

The FrameElementSectionModifiers type exposes the following members.

Constructors

Name | Description
FrameElementSectionModifiers | Initializes a new instance of the FrameElementSectionModifiers class

Fields

Name | Description
AMod | Cross section area modifier
ItMod | Torsional constant modifier
IyMod | Inertia moment about local y axis modifier
IzMod | Inertia moment about local z axis modifier
VyMod | Shear area //local y axis modifier (will be taken into account only if Timshenko element is chosen, otherwise it will not affect the analysis)
VzMod | Shear area //local z axis modifier (will be taken into account only if Timshenko element is chosen, otherwise it will not affect the analysis)

See Also

FrameElementSectionModifiers Class


FrameElementSectionModifiers Constructor

[image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers Constructor
FrameElementSectionModifiers Class See Also Send Feedback
3D Frame Library
Initializes a new instance of the FrameElementSectionModifiers class

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FrameElementSectionModifiers()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FrameElementSectionModifiers()

See Also

FrameElementSectionModifiers Class


FrameElementSectionModifiers Fields

[image] [image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers Fields
FrameElementSectionModifiers Class See Also Send Feedback
3D Frame Library

The FrameElementSectionModifiers type exposes the following members.

Fields

Name | Description
AMod | Cross section area modifier
ItMod | Torsional constant modifier
IyMod | Inertia moment about local y axis modifier
IzMod | Inertia moment about local z axis modifier
VyMod | Shear area //local y axis modifier (will be taken into account only if Timshenko element is chosen, otherwise it will not affect the analysis)
VzMod | Shear area //local z axis modifier (will be taken into account only if Timshenko element is chosen, otherwise it will not affect the analysis)

See Also

FrameElementSectionModifiers Class


AMod Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers..::.AMod Field
FrameElementSectionModifiers Class See Also Send Feedback
3D Frame Library
Cross section area modifier

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double AMod
Visual Basic (Declaration)
Public AMod As Double
Visual C++
public:
double AMod

See Also

FrameElementSectionModifiers Class


ItMod Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers..::.ItMod Field
FrameElementSectionModifiers Class See Also Send Feedback
3D Frame Library
Torsional constant modifier

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double ItMod
Visual Basic (Declaration)
Public ItMod As Double
Visual C++
public:
double ItMod

See Also

FrameElementSectionModifiers Class


IyMod Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers..::.IyMod Field
FrameElementSectionModifiers Class See Also Send Feedback
3D Frame Library
Inertia moment about local y axis modifier

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double IyMod
Visual Basic (Declaration)
Public IyMod As Double
Visual C++
public:
double IyMod

See Also

FrameElementSectionModifiers Class


IzMod Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers..::.IzMod Field
FrameElementSectionModifiers Class See Also Send Feedback
3D Frame Library
Inertia moment about local z axis modifier

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double IzMod
Visual Basic (Declaration)
Public IzMod As Double
Visual C++
public:
double IzMod

See Also

FrameElementSectionModifiers Class


VyMod Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers..::.VyMod Field
FrameElementSectionModifiers Class See Also Send Feedback
3D Frame Library
Shear area //local y axis modifier (will be taken into account only if Timshenko element is chosen, otherwise it will not affect the analysis)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double VyMod
Visual Basic (Declaration)
Public VyMod As Double
Visual C++
public:
double VyMod

See Also

FrameElementSectionModifiers Class


VzMod Field

[image]

ENGISSOL - 3D Frame Library
FrameElementSectionModifiers..::.VzMod Field
FrameElementSectionModifiers Class See Also Send Feedback
3D Frame Library
Shear area //local z axis modifier (will be taken into account only if Timshenko element is chosen, otherwise it will not affect the analysis)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double VzMod
Visual Basic (Declaration)
Public VzMod As Double
Visual C++
public:
double VzMod

See Also

FrameElementSectionModifiers Class


FrameSuperElement Class

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement Class
Members See Also Send Feedback
3D Frame Library
Super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class FrameSuperElement : FiniteElement
Visual Basic (Declaration)
Public Class FrameSuperElement _
    Inherits FiniteElement
Visual C++
public ref class FrameSuperElement : public FiniteElement

Remarks

A super frame element represents a frame element of 2 nodes in 3d space with 12 degrees of freedom.

Inheritance Hierarchy

System..::.Object
FiniteElement
Frame3D..::.FrameSuperElement

See Also

FrameSuperElement Members


FrameSuperElement Members

[image] [image]

ENGISSOL - 3D Frame Library
FrameSuperElement Members
FrameSuperElement Class Constructors Methods Fields See Also Send Feedback
3D Frame Library

The FrameSuperElement type exposes the following members.

Constructors

Name | Description
FrameSuperElement | Initialization of a frame super element

Methods

Name | Description
GetDisplacementsForLoadCase | Gets the displacements at the given location
GetDisplacementsForLoadCombination | Performs linear superposition to calculate frame element displacements for the given load combination
GetInternalForcesForLoadCase | Gets the internal forces at the given location
GetInternalForcesForLoadCombination | Performs linear superposition to calculate frame element internal forces for the given load combination
Length | Element length

Fields

Name | Description
AdditionalMass | Additional element mass, which is taken into account in dynamic analysis only
ConsiderShearEffect | True, if shear work will be considered (Timoshenko element), otherwise false
EndingNode | Ending Node
EndingNode_Releases | Member releases at starting node
ky | Shape coefficient for shear //y local axis (
kz | Shape coefficient for shear in local element z direction, equal to 6/5 for rectangular section
LinearLoadCasesList | List of the linear load cases of the element
LocalSystem | The local coordinate system that defines the placement of the element in 3d space
RigidOffsetEndDx | Rigid offset at ending node
RigidOffsetStartDx | Rigid offset at starting node
Section | Section object of the frame element
StartingNode | Starting Node
StartingNode_Releases | Member releases at starting node
StationsPoints | Points along element, where internal nodes will be created
Type | Frame element type

See Also

FrameSuperElement Class


FrameSuperElement Constructor

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement Constructor
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Initialization of a frame super element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FrameSuperElement(
    int _index,
    SuperNode _StartingNode,
    SuperNode _EndingNode,
    Geometry..::.XYZ _PointInPlaneXY,
    Material _Material,
    FrameElementSection _Section,
    MemberReleases _StartingNode_Releases,
    MemberReleases _EndingNode_Releases,
    bool _LumpedMassMatrix,
    bool _ConsiderShearEffect
)
Visual Basic (Declaration)
Public Sub New ( _
    _index As Integer, _
    _StartingNode As SuperNode, _
    _EndingNode As SuperNode, _
    _PointInPlaneXY As Geometry..::.XYZ, _
    _Material As Material, _
    _Section As FrameElementSection, _
    _StartingNode_Releases As MemberReleases, _
    _EndingNode_Releases As MemberReleases, _
    _LumpedMassMatrix As Boolean, _
    _ConsiderShearEffect As Boolean _
)
Visual C++
public:
FrameSuperElement(
    int _index,
    SuperNode^ _StartingNode,
    SuperNode^ _EndingNode,
    Geometry..::.XYZ _PointInPlaneXY,
    Material^ _Material,
    FrameElementSection^ _Section,
    MemberReleases^ _StartingNode_Releases,
    MemberReleases^ _EndingNode_Releases,
    bool _LumpedMassMatrix,
    bool _ConsiderShearEffect
)

Parameters

_index
Type: System..::.Int32
Index (must be unique)
_StartingNode
Type: Frame3D..::.SuperNode
Starting node object
_EndingNode
Type: Frame3D..::.SuperNode
Ending node object
_PointInPlaneXY
Type: MathLib..::.Geometry..::.XYZ
A 3d point in global coordinate system that lies on the plane xy of the local system of the element
_Material
Type: Frame3D..::.Material
Material object
_Section
Type: Frame3D..::.FrameElementSection
Section object
_StartingNode_Releases
Type: Frame3D..::.MemberReleases
Released dofs of starting node
_EndingNode_Releases
Type: Frame3D..::.MemberReleases
Released dofs of ending node
_LumpedMassMatrix
Type: System..::.Boolean
True to create a lumped mass matrix during dynamic analysis
_ConsiderShearEffect
Type: System..::.Boolean
True, if shear work will be considered (Timoshenko element)

Remarks

It is used for the placement of the member about its longitudinal axis (x)

See Also

FrameSuperElement Class


FrameSuperElement Fields

[image] [image]

ENGISSOL - 3D Frame Library
FrameSuperElement Fields
FrameSuperElement Class See Also Send Feedback
3D Frame Library

The FrameSuperElement type exposes the following members.

Fields

Name | Description
AdditionalMass | Additional element mass, which is taken into account in dynamic analysis only
ConsiderShearEffect | True, if shear work will be considered (Timoshenko element), otherwise false
EndingNode | Ending Node
EndingNode_Releases | Member releases at starting node
ky | Shape coefficient for shear //y local axis (
kz | Shape coefficient for shear in local element z direction, equal to 6/5 for rectangular section
LinearLoadCasesList | List of the linear load cases of the element
LocalSystem | The local coordinate system that defines the placement of the element in 3d space
RigidOffsetEndDx | Rigid offset at ending node
RigidOffsetStartDx | Rigid offset at starting node
Section | Section object of the frame element
StartingNode | Starting Node
StartingNode_Releases | Member releases at starting node
StationsPoints | Points along element, where internal nodes will be created
Type | Frame element type

See Also

FrameSuperElement Class


AdditionalMass Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.AdditionalMass Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Additional element mass, which is taken into account in dynamic analysis only

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double AdditionalMass
Visual Basic (Declaration)
Public AdditionalMass As Double
Visual C++
public:
double AdditionalMass

See Also

FrameSuperElement Class


ConsiderShearEffect Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.ConsiderShearEffect Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
True, if shear work will be considered (Timoshenko element), otherwise false

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool ConsiderShearEffect
Visual Basic (Declaration)
Public ConsiderShearEffect As Boolean
Visual C++
public:
bool ConsiderShearEffect

See Also

FrameSuperElement Class


EndingNode Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.EndingNode Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Ending Node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public SuperNode EndingNode
Visual Basic (Declaration)
Public EndingNode As SuperNode
Visual C++
public:
SuperNode^ EndingNode

See Also

FrameSuperElement Class


EndingNode_Releases Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.EndingNode_Releases Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Member releases at starting node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public MemberReleases EndingNode_Releases
Visual Basic (Declaration)
Public EndingNode_Releases As MemberReleases
Visual C++
public:
MemberReleases^ EndingNode_Releases

See Also

FrameSuperElement Class


ky Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.ky Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Shape coefficient for shear //y local axis (
Shape coefficient for shear in local element y direction, equal to 6/5 for rectangular section

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double ky
Visual Basic (Declaration)
Public ky As Double
Visual C++
public:
double ky

See Also

FrameSuperElement Class


kz Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.kz Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Shape coefficient for shear in local element z direction, equal to 6/5 for rectangular section

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double kz
Visual Basic (Declaration)
Public kz As Double
Visual C++
public:
double kz

See Also

FrameSuperElement Class


LinearLoadCasesList Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.LinearLoadCasesList Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
List of the linear load cases of the element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<LinearLoadCaseForSuperFrameElement> LinearLoadCasesList
Visual Basic (Declaration)
Public LinearLoadCasesList As List(Of LinearLoadCaseForSuperFrameElement)
Visual C++
public:
List<LinearLoadCaseForSuperFrameElement^>^ LinearLoadCasesList

See Also

FrameSuperElement Class


LocalSystem Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.LocalSystem Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
The local coordinate system that defines the placement of the element in 3d space

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LocalCoordinateSystem LocalSystem
Visual Basic (Declaration)
Public LocalSystem As LocalCoordinateSystem
Visual C++
public:
LocalCoordinateSystem^ LocalSystem

See Also

FrameSuperElement Class


RigidOffsetEndDx Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.RigidOffsetEndDx Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Rigid offset at ending node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double RigidOffsetEndDx
Visual Basic (Declaration)
Public RigidOffsetEndDx As Double
Visual C++
public:
double RigidOffsetEndDx

Remarks

only positive

See Also

FrameSuperElement Class


RigidOffsetStartDx Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.RigidOffsetStartDx Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Rigid offset at starting node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double RigidOffsetStartDx
Visual Basic (Declaration)
Public RigidOffsetStartDx As Double
Visual C++
public:
double RigidOffsetStartDx

Remarks

only positive

See Also

FrameSuperElement Class


Section Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.Section Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Section object of the frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FrameElementSection Section
Visual Basic (Declaration)
Public Section As FrameElementSection
Visual C++
public:
FrameElementSection^ Section

See Also

FrameSuperElement Class


StartingNode Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.StartingNode Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Starting Node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public SuperNode StartingNode
Visual Basic (Declaration)
Public StartingNode As SuperNode
Visual C++
public:
SuperNode^ StartingNode

See Also

FrameSuperElement Class


StartingNode_Releases Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.StartingNode_Releases Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Member releases at starting node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public MemberReleases StartingNode_Releases
Visual Basic (Declaration)
Public StartingNode_Releases As MemberReleases
Visual C++
public:
MemberReleases^ StartingNode_Releases

See Also

FrameSuperElement Class


StationsPoints Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.StationsPoints Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Points along element, where internal nodes will be created

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<double> StationsPoints
Visual Basic (Declaration)
Public StationsPoints As List(Of Double)
Visual C++
public:
List<double>^ StationsPoints

See Also

FrameSuperElement Class


Type Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.Type Field
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Frame element type

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public MemberType Type
Visual Basic (Declaration)
Public Type As MemberType
Visual C++
public:
MemberType Type

See Also

FrameSuperElement Class


FrameSuperElement Methods

[image] [image]

ENGISSOL - 3D Frame Library
FrameSuperElement Methods
FrameSuperElement Class See Also Send Feedback
3D Frame Library

The FrameSuperElement type exposes the following members.

Methods

Name | Description
GetDisplacementsForLoadCase | Gets the displacements at the given location
GetDisplacementsForLoadCombination | Performs linear superposition to calculate frame element displacements for the given load combination
GetInternalForcesForLoadCase | Gets the internal forces at the given location
GetInternalForcesForLoadCombination | Performs linear superposition to calculate frame element internal forces for the given load combination
Length | Element length

See Also

FrameSuperElement Class


GetDisplacementsForLoadCase Method

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.GetDisplacementsForLoadCase Method
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Gets the displacements at the given location

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetDisplacementsForLoadCase(
    double Loc,
    string LoadCaseName,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetDisplacementsForLoadCase ( _
    Loc As Double, _
    LoadCaseName As String, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetDisplacementsForLoadCase(
    double Loc,
    String^ LoadCaseName,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

Loc
Type: System..::.Double
LoadCaseName
Type: System..::.String
Load case name
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values
stepNr
Type: System..::.Int32
Step number, needed for time history analysis only

See Also

FrameSuperElement Class


GetDisplacementsForLoadCombination Method

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.GetDisplacementsForLoadCombination Method
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Performs linear superposition to calculate frame element displacements for the given load combination

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetDisplacementsForLoadCombination(
    double Loc,
    LoadCombination comb,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetDisplacementsForLoadCombination ( _
    Loc As Double, _
    comb As LoadCombination, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetDisplacementsForLoadCombination(
    double Loc,
    LoadCombination^ comb,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

Loc
Type: System..::.Double
Location to calculate displacements at
comb
Type: Frame3D..::.LoadCombination
Load combination object
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values for the given load combination
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values for the given load combination
stepNr
Type: System..::.Int32
Step to get results at (for Time History Analysis only)

See Also

FrameSuperElement Class


GetInternalForcesForLoadCase Method

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.GetInternalForcesForLoadCase Method
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Gets the internal forces at the given location

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetInternalForcesForLoadCase(
    double Loc,
    string LoadCaseName,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetInternalForcesForLoadCase ( _
    Loc As Double, _
    LoadCaseName As String, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetInternalForcesForLoadCase(
    double Loc,
    String^ LoadCaseName,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

Loc
Type: System..::.Double
LoadCaseName
Type: System..::.String
Load case name
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values
stepNr
Type: System..::.Int32
Step number, needed for time history analysis only

See Also

FrameSuperElement Class


GetInternalForcesForLoadCombination Method

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.GetInternalForcesForLoadCombination Method
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Performs linear superposition to calculate frame element internal forces for the given load combination

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetInternalForcesForLoadCombination(
    double Loc,
    LoadCombination comb,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetInternalForcesForLoadCombination ( _
    Loc As Double, _
    comb As LoadCombination, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetInternalForcesForLoadCombination(
    double Loc,
    LoadCombination^ comb,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

Loc
Type: System..::.Double
Location to calculate displacements at
comb
Type: Frame3D..::.LoadCombination
Load combination object
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values for the given load combination
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values for the given load combination
stepNr
Type: System..::.Int32
Step to get results at (for Time History Analysis only)

See Also

FrameSuperElement Class


Length Method

[image]

ENGISSOL - 3D Frame Library
FrameSuperElement..::.Length Method
FrameSuperElement Class See Also Send Feedback
3D Frame Library
Element length

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Length()
Visual Basic (Declaration)
Public Function Length As Double
Visual C++
public:
double Length()

Return Value

See Also

FrameSuperElement Class


FrameSuperElementPointLoad Class

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad Class
Members See Also Send Feedback
3D Frame Library
Point loads collection for super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class FrameSuperElementPointLoad
Visual Basic (Declaration)
Public Class FrameSuperElementPointLoad
Visual C++
public ref class FrameSuperElementPointLoad

Inheritance Hierarchy

System..::.Object
Frame3D..::.FrameSuperElementPointLoad

See Also

FrameSuperElementPointLoad Members


FrameSuperElementPointLoad Members

[image] [image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad Members
FrameSuperElementPointLoad Class Constructors Fields See Also Send Feedback
3D Frame Library

The FrameSuperElementPointLoad type exposes the following members.

Constructors

Name | Description
FrameSuperElementPointLoad | Initializes a new instance of the FrameSuperElementPointLoad class

Fields

Name | Description
PointLoadsX | Point loads collection acting // to the x direction
PointLoadsY | Point loads collection acting // to the y direction
PointLoadsZ | Point loads collection acting // to the z direction
PointMomentsAboutX | Concentrated moments collection acting about to the x direction
PointMomentsAboutY | Concentrated moments collection acting about to the y direction
PointMomentsAboutZ | Concentrated moments collection acting about to the z direction

See Also

FrameSuperElementPointLoad Class


FrameSuperElementPointLoad Constructor

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad Constructor
FrameSuperElementPointLoad Class See Also Send Feedback
3D Frame Library
Initializes a new instance of the FrameSuperElementPointLoad class

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FrameSuperElementPointLoad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FrameSuperElementPointLoad()

See Also

FrameSuperElementPointLoad Class


FrameSuperElementPointLoad Fields

[image] [image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad Fields
FrameSuperElementPointLoad Class See Also Send Feedback
3D Frame Library

The FrameSuperElementPointLoad type exposes the following members.

Fields

Name | Description
PointLoadsX | Point loads collection acting // to the x direction
PointLoadsY | Point loads collection acting // to the y direction
PointLoadsZ | Point loads collection acting // to the z direction
PointMomentsAboutX | Concentrated moments collection acting about to the x direction
PointMomentsAboutY | Concentrated moments collection acting about to the y direction
PointMomentsAboutZ | Concentrated moments collection acting about to the z direction

See Also

FrameSuperElementPointLoad Class


PointLoadsX Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad..::.PointLoadsX Field
FrameSuperElementPointLoad Class See Also Send Feedback
3D Frame Library
Point loads collection acting // to the x direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperPointLoad> PointLoadsX
Visual Basic (Declaration)
Public PointLoadsX As List(Of SuperPointLoad)
Visual C++
public:
List<SuperPointLoad^>^ PointLoadsX

See Also

FrameSuperElementPointLoad Class


PointLoadsY Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad..::.PointLoadsY Field
FrameSuperElementPointLoad Class See Also Send Feedback
3D Frame Library
Point loads collection acting // to the y direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperPointLoad> PointLoadsY
Visual Basic (Declaration)
Public PointLoadsY As List(Of SuperPointLoad)
Visual C++
public:
List<SuperPointLoad^>^ PointLoadsY

See Also

FrameSuperElementPointLoad Class


PointLoadsZ Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad..::.PointLoadsZ Field
FrameSuperElementPointLoad Class See Also Send Feedback
3D Frame Library
Point loads collection acting // to the z direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperPointLoad> PointLoadsZ
Visual Basic (Declaration)
Public PointLoadsZ As List(Of SuperPointLoad)
Visual C++
public:
List<SuperPointLoad^>^ PointLoadsZ

See Also

FrameSuperElementPointLoad Class


PointMomentsAboutX Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad..::.PointMomentsAboutX Field
FrameSuperElementPointLoad Class See Also Send Feedback
3D Frame Library
Concentrated moments collection acting about to the x direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperPointLoad> PointMomentsAboutX
Visual Basic (Declaration)
Public PointMomentsAboutX As List(Of SuperPointLoad)
Visual C++
public:
List<SuperPointLoad^>^ PointMomentsAboutX

See Also

FrameSuperElementPointLoad Class


PointMomentsAboutY Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad..::.PointMomentsAboutY Field
FrameSuperElementPointLoad Class See Also Send Feedback
3D Frame Library
Concentrated moments collection acting about to the y direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperPointLoad> PointMomentsAboutY
Visual Basic (Declaration)
Public PointMomentsAboutY As List(Of SuperPointLoad)
Visual C++
public:
List<SuperPointLoad^>^ PointMomentsAboutY

See Also

FrameSuperElementPointLoad Class


PointMomentsAboutZ Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementPointLoad..::.PointMomentsAboutZ Field
FrameSuperElementPointLoad Class See Also Send Feedback
3D Frame Library
Concentrated moments collection acting about to the z direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperPointLoad> PointMomentsAboutZ
Visual Basic (Declaration)
Public PointMomentsAboutZ As List(Of SuperPointLoad)
Visual C++
public:
List<SuperPointLoad^>^ PointMomentsAboutZ

See Also

FrameSuperElementPointLoad Class


FrameSuperElementUniformLoad Class

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad Class
Members See Also Send Feedback
3D Frame Library
Uniform loads collection for super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class FrameSuperElementUniformLoad
Visual Basic (Declaration)
Public Class FrameSuperElementUniformLoad
Visual C++
public ref class FrameSuperElementUniformLoad

Inheritance Hierarchy

System..::.Object
Frame3D..::.FrameSuperElementUniformLoad

See Also

FrameSuperElementUniformLoad Members


FrameSuperElementUniformLoad Members

[image] [image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad Members
FrameSuperElementUniformLoad Class Constructors Fields See Also Send Feedback
3D Frame Library

The FrameSuperElementUniformLoad type exposes the following members.

Constructors

Name | Description
FrameSuperElementUniformLoad | Initializes a new instance of the FrameSuperElementUniformLoad class

Fields

Name | Description
DT_yy | Gradient temperature load that causes bending about local y-y axis
DT_zz | Gradient temperature load that causes bending about local z-z axis
DTc | Temperature difference load
UniformLoadsX | Uniform axial load in the x direction
UniformLoadsY | Uniform vertical loads collection acting // to the y direction
UniformLoadsZ | Uniform vertical loads collection acting // to the z direction

See Also

FrameSuperElementUniformLoad Class


FrameSuperElementUniformLoad Constructor

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad Constructor
FrameSuperElementUniformLoad Class See Also Send Feedback
3D Frame Library
Initializes a new instance of the FrameSuperElementUniformLoad class

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FrameSuperElementUniformLoad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FrameSuperElementUniformLoad()

See Also

FrameSuperElementUniformLoad Class


FrameSuperElementUniformLoad Fields

[image] [image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad Fields
FrameSuperElementUniformLoad Class See Also Send Feedback
3D Frame Library

The FrameSuperElementUniformLoad type exposes the following members.

Fields

Name | Description
DT_yy | Gradient temperature load that causes bending about local y-y axis
DT_zz | Gradient temperature load that causes bending about local z-z axis
DTc | Temperature difference load
UniformLoadsX | Uniform axial load in the x direction
UniformLoadsY | Uniform vertical loads collection acting // to the y direction
UniformLoadsZ | Uniform vertical loads collection acting // to the z direction

See Also

FrameSuperElementUniformLoad Class


DT_yy Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad..::.DT_yy Field
FrameSuperElementUniformLoad Class See Also Send Feedback
3D Frame Library
Gradient temperature load that causes bending about local y-y axis

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double DT_yy
Visual Basic (Declaration)
Public DT_yy As Double
Visual C++
public:
double DT_yy

See Also

FrameSuperElementUniformLoad Class


DT_zz Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad..::.DT_zz Field
FrameSuperElementUniformLoad Class See Also Send Feedback
3D Frame Library
Gradient temperature load that causes bending about local z-z axis

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double DT_zz
Visual Basic (Declaration)
Public DT_zz As Double
Visual C++
public:
double DT_zz

See Also

FrameSuperElementUniformLoad Class


DTc Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad..::.DTc Field
FrameSuperElementUniformLoad Class See Also Send Feedback
3D Frame Library
Temperature difference load

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double DTc
Visual Basic (Declaration)
Public DTc As Double
Visual C++
public:
double DTc

See Also

FrameSuperElementUniformLoad Class


UniformLoadsX Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad..::.UniformLoadsX Field
FrameSuperElementUniformLoad Class See Also Send Feedback
3D Frame Library
Uniform axial load in the x direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperUniformLoad> UniformLoadsX
Visual Basic (Declaration)
Public UniformLoadsX As List(Of SuperUniformLoad)
Visual C++
public:
List<SuperUniformLoad^>^ UniformLoadsX

See Also

FrameSuperElementUniformLoad Class


UniformLoadsY Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad..::.UniformLoadsY Field
FrameSuperElementUniformLoad Class See Also Send Feedback
3D Frame Library
Uniform vertical loads collection acting // to the y direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperUniformLoad> UniformLoadsY
Visual Basic (Declaration)
Public UniformLoadsY As List(Of SuperUniformLoad)
Visual C++
public:
List<SuperUniformLoad^>^ UniformLoadsY

See Also

FrameSuperElementUniformLoad Class


UniformLoadsZ Field

[image]

ENGISSOL - 3D Frame Library
FrameSuperElementUniformLoad..::.UniformLoadsZ Field
FrameSuperElementUniformLoad Class See Also Send Feedback
3D Frame Library
Uniform vertical loads collection acting // to the z direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperUniformLoad> UniformLoadsZ
Visual Basic (Declaration)
Public UniformLoadsZ As List(Of SuperUniformLoad)
Visual C++
public:
List<SuperUniformLoad^>^ UniformLoadsZ

See Also

FrameSuperElementUniformLoad Class


GeometricNonLinearCase Class

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase Class
Members See Also Send Feedback
3D Frame Library

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class GeometricNonLinearCase
Visual Basic (Declaration)
Public Class GeometricNonLinearCase
Visual C++
public ref class GeometricNonLinearCase

Inheritance Hierarchy

System..::.Object
Frame3D..::.GeometricNonLinearCase

See Also

GeometricNonLinearCase Members


GeometricNonLinearCase Members

[image] [image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase Members
GeometricNonLinearCase Class Constructors Fields See Also Send Feedback
3D Frame Library

The GeometricNonLinearCase type exposes the following members.

Constructors

Name | Description
GeometricNonLinearCase | Construction

Fields

Name | Description
ConvergenceTolerance | Convergence tolerance in terms of force
InputLoadCasesWithFactorOrCombos | LoadCaseWithFactor or LoadCombination objects
IterationsPerLoadStep | Maximum Iterations per load step
LoadSteps | Total Load steps Number
name | Geometrically Non Linear Case name
SaveResultsAtEachLoadStep | If true, results at each load step will be saved, otherwise only at the last load step will be saved
UpdateStiffnessMethod | Method used to update the global stiffness matrix

See Also

GeometricNonLinearCase Class


GeometricNonLinearCase Constructor

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase Constructor
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library
Construction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public GeometricNonLinearCase(
    string _name
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String _
)
Visual C++
public:
GeometricNonLinearCase(
    String^ _name
)

Parameters

_name
Type: System..::.String
Geometric non linear case name

See Also

GeometricNonLinearCase Class


GeometricNonLinearCase Fields

[image] [image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase Fields
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library

The GeometricNonLinearCase type exposes the following members.

Fields

Name | Description
ConvergenceTolerance | Convergence tolerance in terms of force
InputLoadCasesWithFactorOrCombos | LoadCaseWithFactor or LoadCombination objects
IterationsPerLoadStep | Maximum Iterations per load step
LoadSteps | Total Load steps Number
name | Geometrically Non Linear Case name
SaveResultsAtEachLoadStep | If true, results at each load step will be saved, otherwise only at the last load step will be saved
UpdateStiffnessMethod | Method used to update the global stiffness matrix

See Also

GeometricNonLinearCase Class


ConvergenceTolerance Field

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase..::.ConvergenceTolerance Field
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library
Convergence tolerance in terms of force

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double ConvergenceTolerance
Visual Basic (Declaration)
Public ConvergenceTolerance As Double
Visual C++
public:
double ConvergenceTolerance

See Also

GeometricNonLinearCase Class


InputLoadCasesWithFactorOrCombos Field

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase..::.InputLoadCasesWithFactorOrCombos Field
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library
LoadCaseWithFactor or LoadCombination objects

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public ArrayList InputLoadCasesWithFactorOrCombos
Visual Basic (Declaration)
Public InputLoadCasesWithFactorOrCombos As ArrayList
Visual C++
public:
ArrayList^ InputLoadCasesWithFactorOrCombos

See Also

GeometricNonLinearCase Class


IterationsPerLoadStep Field

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase..::.IterationsPerLoadStep Field
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library
Maximum Iterations per load step

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public int IterationsPerLoadStep
Visual Basic (Declaration)
Public IterationsPerLoadStep As Integer
Visual C++
public:
int IterationsPerLoadStep

See Also

GeometricNonLinearCase Class


LoadSteps Field

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase..::.LoadSteps Field
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library
Total Load steps Number

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public int LoadSteps
Visual Basic (Declaration)
Public LoadSteps As Integer
Visual C++
public:
int LoadSteps

See Also

GeometricNonLinearCase Class


name Field

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase..::.name Field
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library
Geometrically Non Linear Case name

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string name
Visual Basic (Declaration)
Public name As String
Visual C++
public:
String^ name

See Also

GeometricNonLinearCase Class


SaveResultsAtEachLoadStep Field

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase..::.SaveResultsAtEachLoadStep Field
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library
If true, results at each load step will be saved, otherwise only at the last load step will be saved

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool SaveResultsAtEachLoadStep
Visual Basic (Declaration)
Public SaveResultsAtEachLoadStep As Boolean
Visual C++
public:
bool SaveResultsAtEachLoadStep

See Also

GeometricNonLinearCase Class


UpdateStiffnessMethod Field

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase..::.UpdateStiffnessMethod Field
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library
Method used to update the global stiffness matrix

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public GeometricNonLinearCase..::.UpdateStiffnessMatrixMethod UpdateStiffnessMethod
Visual Basic (Declaration)
Public UpdateStiffnessMethod As GeometricNonLinearCase..::.UpdateStiffnessMatrixMethod
Visual C++
public:
GeometricNonLinearCase..::.UpdateStiffnessMatrixMethod UpdateStiffnessMethod

See Also

GeometricNonLinearCase Class


GeometricNonLinearCase.UpdateStiffnessMatrixMethod Enumeration

[image]

ENGISSOL - 3D Frame Library
GeometricNonLinearCase..::.UpdateStiffnessMatrixMethod Enumeration
GeometricNonLinearCase Class See Also Send Feedback
3D Frame Library
Enumerator with all possible cases for the update of the global stiffness matrix

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public enum UpdateStiffnessMatrixMethod
Visual Basic (Declaration)
Public Enumeration UpdateStiffnessMatrixMethod
Visual C++
public enum class UpdateStiffnessMatrixMethod

Members

Member name | Description
AfterEachIterationInLoadStep | Stiffness matrix is updated after each iteration inside one load step (Full Newton-Raphson method)
AfterEachLoadStep | Stiffness matrix is updated after each load step (constant for iteration in one load step, Modified Newton-Raphson method)
KeepConstant | Stiffness matrix is kept constant

See Also

Frame3D Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


GroundMotionDirection Enumeration

[image]

ENGISSOL - 3D Frame Library
GroundMotionDirection Enumeration
See Also Send Feedback
3D Frame Library

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public enum GroundMotionDirection
Visual Basic (Declaration)
Public Enumeration GroundMotionDirection
Visual C++
public enum class GroundMotionDirection

Members

Member name | Description
UX | Response spectrum direction //global X
UY | Response spectrum direction //global Y
UZ | Response spectrum direction //global Z

See Also

Frame3D Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


LinearLoadCaseForFloorDiaphragm Class

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm Class
Members See Also Send Feedback
3D Frame Library
Load Case class (linear), for example DEAD, LIVE etc. for a floor diaphragm

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class LinearLoadCaseForFloorDiaphragm
Visual Basic (Declaration)
Public Class LinearLoadCaseForFloorDiaphragm
Visual C++
public ref class LinearLoadCaseForFloorDiaphragm

Inheritance Hierarchy

System..::.Object
Frame3D..::.LinearLoadCaseForFloorDiaphragm

See Also

LinearLoadCaseForFloorDiaphragm Members


LinearLoadCaseForFloorDiaphragm Members

[image] [image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm Members
LinearLoadCaseForFloorDiaphragm Class Constructors Methods Fields See Also Send Feedback
3D Frame Library

The LinearLoadCaseForFloorDiaphragm type exposes the following members.

Constructors

Name | Description
LinearLoadCaseForFloorDiaphragm | Load case initialization

Methods

Name | Description
Equals | Loadcase Equals overriden function (Overrides Object..::.Equals(Object).)

Fields

Name | Description
Mz | Loads applied to the center of mass of the diaphragm
name | Load case name
Px | Loads applied to the center of mass of the diaphragm
Py | Loads applied to the center of mass of the diaphragm
pz | Uniform area load for mass calculation.
Type | Load case type

See Also

LinearLoadCaseForFloorDiaphragm Class


LinearLoadCaseForFloorDiaphragm Constructor

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm Constructor
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library
Load case initialization

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LinearLoadCaseForFloorDiaphragm(
    string _name,
    LoadCaseType _type
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String, _
    _type As LoadCaseType _
)
Visual C++
public:
LinearLoadCaseForFloorDiaphragm(
    String^ _name,
    LoadCaseType _type
)

Parameters

_name
Type: System..::.String
Load case name
_type
Type: Frame3D..::.LoadCaseType
Load case type

See Also

LinearLoadCaseForFloorDiaphragm Class


LinearLoadCaseForFloorDiaphragm Fields

[image] [image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm Fields
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library

The LinearLoadCaseForFloorDiaphragm type exposes the following members.

Fields

Name | Description
Mz | Loads applied to the center of mass of the diaphragm
name | Load case name
Px | Loads applied to the center of mass of the diaphragm
Py | Loads applied to the center of mass of the diaphragm
pz | Uniform area load for mass calculation.
Type | Load case type

See Also

LinearLoadCaseForFloorDiaphragm Class


Mz Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm..::.Mz Field
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library
Loads applied to the center of mass of the diaphragm

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Mz
Visual Basic (Declaration)
Public Mz As Double
Visual C++
public:
double Mz

See Also

LinearLoadCaseForFloorDiaphragm Class


name Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm..::.name Field
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library
Load case name

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string name
Visual Basic (Declaration)
Public name As String
Visual C++
public:
String^ name

See Also

LinearLoadCaseForFloorDiaphragm Class


Px Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm..::.Px Field
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library
Loads applied to the center of mass of the diaphragm

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Px
Visual Basic (Declaration)
Public Px As Double
Visual C++
public:
double Px

See Also

LinearLoadCaseForFloorDiaphragm Class


Py Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm..::.Py Field
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library
Loads applied to the center of mass of the diaphragm

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Py
Visual Basic (Declaration)
Public Py As Double
Visual C++
public:
double Py

See Also

LinearLoadCaseForFloorDiaphragm Class


pz Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm..::.pz Field
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library
Uniform area load for mass calculation.

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double pz
Visual Basic (Declaration)
Public pz As Double
Visual C++
public:
double pz

Remarks

Positive = Gravity direction. This load has to be applied to the perimetric beams as well. The library does not transfer it automatically!

See Also

LinearLoadCaseForFloorDiaphragm Class


Type Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm..::.Type Field
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library
Load case type

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadCaseType Type
Visual Basic (Declaration)
Public Type As LoadCaseType
Visual C++
public:
LoadCaseType Type

See Also

LinearLoadCaseForFloorDiaphragm Class


LinearLoadCaseForFloorDiaphragm Methods

[image] [image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm Methods
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library

The LinearLoadCaseForFloorDiaphragm type exposes the following members.

Methods

Name | Description
Equals | Loadcase Equals overriden function (Overrides Object..::.Equals(Object).)

See Also

LinearLoadCaseForFloorDiaphragm Class


Equals Method

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForFloorDiaphragm..::.Equals Method
LinearLoadCaseForFloorDiaphragm Class See Also Send Feedback
3D Frame Library
Loadcase Equals overriden function

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
A LinearLoadCaseForFloorDiaphragm or LoadCaseForModel object

Return Value

True if current instance is equal to obj object, otherwise false

See Also

LinearLoadCaseForFloorDiaphragm Class


LinearLoadCaseForSuperFrameElement Class

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement Class
Members See Also Send Feedback
3D Frame Library
Load Case class (linear), for example DEAD, LIVE etc. for super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class LinearLoadCaseForSuperFrameElement
Visual Basic (Declaration)
Public Class LinearLoadCaseForSuperFrameElement
Visual C++
public ref class LinearLoadCaseForSuperFrameElement

Inheritance Hierarchy

System..::.Object
Frame3D..::.LinearLoadCaseForSuperFrameElement

See Also

LinearLoadCaseForSuperFrameElement Members


LinearLoadCaseForSuperFrameElement Members

[image] [image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement Members
LinearLoadCaseForSuperFrameElement Class Constructors Methods Fields See Also Send Feedback
3D Frame Library

The LinearLoadCaseForSuperFrameElement type exposes the following members.

Constructors

Name | Description
LinearLoadCaseForSuperFrameElement | Load case initialization

Methods

Name | Description
Equals | Load case Equals overriden function (Overrides Object..::.Equals(Object).)

Fields

Name | Description
name | Load case name
PointLoad | Point loads with respect to the local coordinate system of the element
Type | Load case type
UniformLoad | Uniform loads with respect to the local coordinate system of the element

See Also

LinearLoadCaseForSuperFrameElement Class


LinearLoadCaseForSuperFrameElement Constructor

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement Constructor
LinearLoadCaseForSuperFrameElement Class See Also Send Feedback
3D Frame Library
Load case initialization

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LinearLoadCaseForSuperFrameElement(
    string _name,
    LoadCaseType _type
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String, _
    _type As LoadCaseType _
)
Visual C++
public:
LinearLoadCaseForSuperFrameElement(
    String^ _name,
    LoadCaseType _type
)

Parameters

_name
Type: System..::.String
Load case name
_type
Type: Frame3D..::.LoadCaseType
Load case type

See Also

LinearLoadCaseForSuperFrameElement Class


LinearLoadCaseForSuperFrameElement Fields

[image] [image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement Fields
LinearLoadCaseForSuperFrameElement Class See Also Send Feedback
3D Frame Library

The LinearLoadCaseForSuperFrameElement type exposes the following members.

Fields

Name | Description
name | Load case name
PointLoad | Point loads with respect to the local coordinate system of the element
Type | Load case type
UniformLoad | Uniform loads with respect to the local coordinate system of the element

See Also

LinearLoadCaseForSuperFrameElement Class


name Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement..::.name Field
LinearLoadCaseForSuperFrameElement Class See Also Send Feedback
3D Frame Library
Load case name

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string name
Visual Basic (Declaration)
Public name As String
Visual C++
public:
String^ name

See Also

LinearLoadCaseForSuperFrameElement Class


PointLoad Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement..::.PointLoad Field
LinearLoadCaseForSuperFrameElement Class See Also Send Feedback
3D Frame Library
Point loads with respect to the local coordinate system of the element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FrameSuperElementPointLoad PointLoad
Visual Basic (Declaration)
Public PointLoad As FrameSuperElementPointLoad
Visual C++
public:
FrameSuperElementPointLoad^ PointLoad

See Also

LinearLoadCaseForSuperFrameElement Class


Type Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement..::.Type Field
LinearLoadCaseForSuperFrameElement Class See Also Send Feedback
3D Frame Library
Load case type

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadCaseType Type
Visual Basic (Declaration)
Public Type As LoadCaseType
Visual C++
public:
LoadCaseType Type

See Also

LinearLoadCaseForSuperFrameElement Class


UniformLoad Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement..::.UniformLoad Field
LinearLoadCaseForSuperFrameElement Class See Also Send Feedback
3D Frame Library
Uniform loads with respect to the local coordinate system of the element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public FrameSuperElementUniformLoad UniformLoad
Visual Basic (Declaration)
Public UniformLoad As FrameSuperElementUniformLoad
Visual C++
public:
FrameSuperElementUniformLoad^ UniformLoad

See Also

LinearLoadCaseForSuperFrameElement Class


LinearLoadCaseForSuperFrameElement Methods

[image] [image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement Methods
LinearLoadCaseForSuperFrameElement Class See Also Send Feedback
3D Frame Library

The LinearLoadCaseForSuperFrameElement type exposes the following members.

Methods

Name | Description
Equals | Load case Equals overriden function (Overrides Object..::.Equals(Object).)

See Also

LinearLoadCaseForSuperFrameElement Class


Equals Method

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperFrameElement..::.Equals Method
LinearLoadCaseForSuperFrameElement Class See Also Send Feedback
3D Frame Library
Load case Equals overriden function

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
A LinearLoadCaseForSuperFrameElement or LoadCaseForModel object

Return Value

True if current instance is equal to obj object, otherwise false

See Also

LinearLoadCaseForSuperFrameElement Class


LinearLoadCaseForSuperNode Class

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode Class
Members See Also Send Feedback
3D Frame Library
Load Case class (linear), for example DEAD, LIVE etc. for a node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class LinearLoadCaseForSuperNode
Visual Basic (Declaration)
Public Class LinearLoadCaseForSuperNode
Visual C++
public ref class LinearLoadCaseForSuperNode

Inheritance Hierarchy

System..::.Object
Frame3D..::.LinearLoadCaseForSuperNode

See Also

LinearLoadCaseForSuperNode Members


LinearLoadCaseForSuperNode Members

[image] [image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode Members
LinearLoadCaseForSuperNode Class Constructors Methods Fields See Also Send Feedback
3D Frame Library

The LinearLoadCaseForSuperNode type exposes the following members.

Constructors

Name | Description
LinearLoadCaseForSuperNode | Load case initialization

Methods

Name | Description
Equals | Loadcase Equals overriden function (Overrides Object..::.Equals(Object).)

Fields

Name | Description
Mx | Nodal loads with respect to the global coordinate system
My | Nodal loads with respect to the global coordinate system
Mz | Nodal loads with respect to the global coordinate system
name | Load case name
Px | Nodal loads with respect to the global coordinate system
Py | Nodal loads with respect to the global coordinate system
Pz | Nodal loads with respect to the global coordinate system
Type | Load case type

See Also

LinearLoadCaseForSuperNode Class


LinearLoadCaseForSuperNode Constructor

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode Constructor
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Load case initialization

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LinearLoadCaseForSuperNode(
    string _name,
    LoadCaseType _type
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String, _
    _type As LoadCaseType _
)
Visual C++
public:
LinearLoadCaseForSuperNode(
    String^ _name,
    LoadCaseType _type
)

Parameters

_name
Type: System..::.String
Load case name
_type
Type: Frame3D..::.LoadCaseType
Load case type

See Also

LinearLoadCaseForSuperNode Class


LinearLoadCaseForSuperNode Fields

[image] [image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode Fields
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library

The LinearLoadCaseForSuperNode type exposes the following members.

Fields

Name | Description
Mx | Nodal loads with respect to the global coordinate system
My | Nodal loads with respect to the global coordinate system
Mz | Nodal loads with respect to the global coordinate system
name | Load case name
Px | Nodal loads with respect to the global coordinate system
Py | Nodal loads with respect to the global coordinate system
Pz | Nodal loads with respect to the global coordinate system
Type | Load case type

See Also

LinearLoadCaseForSuperNode Class


Mx Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode..::.Mx Field
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Nodal loads with respect to the global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Mx
Visual Basic (Declaration)
Public Mx As Double
Visual C++
public:
double Mx

See Also

LinearLoadCaseForSuperNode Class


My Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode..::.My Field
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Nodal loads with respect to the global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double My
Visual Basic (Declaration)
Public My As Double
Visual C++
public:
double My

See Also

LinearLoadCaseForSuperNode Class


Mz Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode..::.Mz Field
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Nodal loads with respect to the global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Mz
Visual Basic (Declaration)
Public Mz As Double
Visual C++
public:
double Mz

See Also

LinearLoadCaseForSuperNode Class


name Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode..::.name Field
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Load case name

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string name
Visual Basic (Declaration)
Public name As String
Visual C++
public:
String^ name

See Also

LinearLoadCaseForSuperNode Class


Px Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode..::.Px Field
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Nodal loads with respect to the global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Px
Visual Basic (Declaration)
Public Px As Double
Visual C++
public:
double Px

See Also

LinearLoadCaseForSuperNode Class


Py Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode..::.Py Field
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Nodal loads with respect to the global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Py
Visual Basic (Declaration)
Public Py As Double
Visual C++
public:
double Py

See Also

LinearLoadCaseForSuperNode Class


Pz Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode..::.Pz Field
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Nodal loads with respect to the global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Pz
Visual Basic (Declaration)
Public Pz As Double
Visual C++
public:
double Pz

See Also

LinearLoadCaseForSuperNode Class


Type Field

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode..::.Type Field
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Load case type

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadCaseType Type
Visual Basic (Declaration)
Public Type As LoadCaseType
Visual C++
public:
LoadCaseType Type

See Also

LinearLoadCaseForSuperNode Class


LinearLoadCaseForSuperNode Methods

[image] [image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode Methods
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library

The LinearLoadCaseForSuperNode type exposes the following members.

Methods

Name | Description
Equals | Loadcase Equals overriden function (Overrides Object..::.Equals(Object).)

See Also

LinearLoadCaseForSuperNode Class


Equals Method

[image]

ENGISSOL - 3D Frame Library
LinearLoadCaseForSuperNode..::.Equals Method
LinearLoadCaseForSuperNode Class See Also Send Feedback
3D Frame Library
Loadcase Equals overriden function

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
A LinearLoadCaseForSuperNode or LoadCaseForModel object

Return Value

True if current instance is equal to obj object, otherwise false

See Also

LinearLoadCaseForSuperNode Class


LoadCaseType Enumeration

[image]

ENGISSOL - 3D Frame Library
LoadCaseType Enumeration
See Also Send Feedback
3D Frame Library
Load case type

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public enum LoadCaseType
Visual Basic (Declaration)
Public Enumeration LoadCaseType
Visual C++
public enum class LoadCaseType

Members

Member name | Description
DEAD | Represents dead loads
LIVE | Represents live loads
SUPERDEAD | Represents additional dead loads
SNOW | Represents snow loads
WIND | Represents wind loads
QUAKE | Represents earthquake loads
CRANE | Represents crane loads
OTHER | Represents other loads

See Also

Frame3D Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


LoadCaseWithFactor Class

[image]

ENGISSOL - 3D Frame Library
LoadCaseWithFactor Class
Members See Also Send Feedback
3D Frame Library
Represents a load case with its corresponding factor for a load combination

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class LoadCaseWithFactor
Visual Basic (Declaration)
Public Class LoadCaseWithFactor
Visual C++
public ref class LoadCaseWithFactor

Inheritance Hierarchy

System..::.Object
Frame3D..::.LoadCaseWithFactor

See Also

LoadCaseWithFactor Members


LoadCaseWithFactor Members

[image] [image]

ENGISSOL - 3D Frame Library
LoadCaseWithFactor Members
LoadCaseWithFactor Class Constructors Fields See Also Send Feedback
3D Frame Library

The LoadCaseWithFactor type exposes the following members.

Constructors

Name | Description
LoadCaseWithFactor | Construction

Fields

Name | Description
Factor | Factor to multiply load case with
LoadCaseName | Name of the load case

See Also

LoadCaseWithFactor Class


LoadCaseWithFactor Constructor

[image]

ENGISSOL - 3D Frame Library
LoadCaseWithFactor Constructor
LoadCaseWithFactor Class See Also Send Feedback
3D Frame Library
Construction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadCaseWithFactor(
    string _LoadCaseName,
    double _Factor
)
Visual Basic (Declaration)
Public Sub New ( _
    _LoadCaseName As String, _
    _Factor As Double _
)
Visual C++
public:
LoadCaseWithFactor(
    String^ _LoadCaseName,
    double _Factor
)

Parameters

_LoadCaseName
Type: System..::.String
Load case name
_Factor
Type: System..::.Double
Load case factor for the load combination

See Also

LoadCaseWithFactor Class


LoadCaseWithFactor Fields

[image] [image]

ENGISSOL - 3D Frame Library
LoadCaseWithFactor Fields
LoadCaseWithFactor Class See Also Send Feedback
3D Frame Library

The LoadCaseWithFactor type exposes the following members.

Fields

Name | Description
Factor | Factor to multiply load case with
LoadCaseName | Name of the load case

See Also

LoadCaseWithFactor Class


Factor Field

[image]

ENGISSOL - 3D Frame Library
LoadCaseWithFactor..::.Factor Field
LoadCaseWithFactor Class See Also Send Feedback
3D Frame Library
Factor to multiply load case with

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Factor
Visual Basic (Declaration)
Public Factor As Double
Visual C++
public:
double Factor

See Also

LoadCaseWithFactor Class


LoadCaseName Field

[image]

ENGISSOL - 3D Frame Library
LoadCaseWithFactor..::.LoadCaseName Field
LoadCaseWithFactor Class See Also Send Feedback
3D Frame Library
Name of the load case

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string LoadCaseName
Visual Basic (Declaration)
Public LoadCaseName As String
Visual C++
public:
String^ LoadCaseName

See Also

LoadCaseWithFactor Class


LoadCombination Class

[image]

ENGISSOL - 3D Frame Library
LoadCombination Class
Members See Also Send Feedback
3D Frame Library
Represents a load combination

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class LoadCombination
Visual Basic (Declaration)
Public Class LoadCombination
Visual C++
public ref class LoadCombination

Inheritance Hierarchy

System..::.Object
Frame3D..::.LoadCombination

See Also

LoadCombination Members


LoadCombination Members

[image] [image]

ENGISSOL - 3D Frame Library
LoadCombination Members
LoadCombination Class Constructors Fields See Also Send Feedback
3D Frame Library

The LoadCombination type exposes the following members.

Constructors

Name | Description
LoadCombination | Construction

Fields

Name | Description
InputLoadCasesWithFactorOrCombos | LoadCaseWithFactor or LoadCombination objects
name | Load combination name, eg: DEAD
Type | Combination type of the load cases that belong to this load combination

See Also

LoadCombination Class


LoadCombination Constructor

[image]

ENGISSOL - 3D Frame Library
LoadCombination Constructor
LoadCombination Class See Also Send Feedback
3D Frame Library
Construction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadCombination(
    string _name,
    ComboType _type
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String, _
    _type As ComboType _
)
Visual C++
public:
LoadCombination(
    String^ _name,
    ComboType _type
)

Parameters

_name
Type: System..::.String
Load combination name, eg "1.35G + 1.50Q"
_type
Type: Frame3D..::.ComboType
Combination type of the load cases that belong to this load combination

See Also

LoadCombination Class


LoadCombination Fields

[image] [image]

ENGISSOL - 3D Frame Library
LoadCombination Fields
LoadCombination Class See Also Send Feedback
3D Frame Library

The LoadCombination type exposes the following members.

Fields

Name | Description
InputLoadCasesWithFactorOrCombos | LoadCaseWithFactor or LoadCombination objects
name | Load combination name, eg: DEAD
Type | Combination type of the load cases that belong to this load combination

See Also

LoadCombination Class


InputLoadCasesWithFactorOrCombos Field

[image]

ENGISSOL - 3D Frame Library
LoadCombination..::.InputLoadCasesWithFactorOrCombos Field
LoadCombination Class See Also Send Feedback
3D Frame Library
LoadCaseWithFactor or LoadCombination objects

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public ArrayList InputLoadCasesWithFactorOrCombos
Visual Basic (Declaration)
Public InputLoadCasesWithFactorOrCombos As ArrayList
Visual C++
public:
ArrayList^ InputLoadCasesWithFactorOrCombos

See Also

LoadCombination Class


name Field

[image]

ENGISSOL - 3D Frame Library
LoadCombination..::.name Field
LoadCombination Class See Also Send Feedback
3D Frame Library
Load combination name, eg: DEAD

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string name
Visual Basic (Declaration)
Public name As String
Visual C++
public:
String^ name

See Also

LoadCombination Class


Type Field

[image]

ENGISSOL - 3D Frame Library
LoadCombination..::.Type Field
LoadCombination Class See Also Send Feedback
3D Frame Library
Combination type of the load cases that belong to this load combination

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public ComboType Type
Visual Basic (Declaration)
Public Type As ComboType
Visual C++
public:
ComboType Type

See Also

LoadCombination Class


LoadCordinateSystem Enumeration

[image]

ENGISSOL - 3D Frame Library
LoadCordinateSystem Enumeration
See Also Send Feedback
3D Frame Library
Defines whether loads given with respect to the local or global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public enum LoadCordinateSystem
Visual Basic (Declaration)
Public Enumeration LoadCordinateSystem
Visual C++
public enum class LoadCordinateSystem

Members

Member name | Description
Local | Loads defined in local coordinate system
Global | Loads defined in global coordinate system
GlobalProjectionForUniformLoadsOnly | Loads defined in global coordinate system (projection on global axis)

See Also

Frame3D Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


LoadDefinitionFromStartingNode Enumeration

[image]

ENGISSOL - 3D Frame Library
LoadDefinitionFromStartingNode Enumeration
See Also Send Feedback
3D Frame Library
Defines how loads are given with respect to the starting node of the super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public enum LoadDefinitionFromStartingNode
Visual Basic (Declaration)
Public Enumeration LoadDefinitionFromStartingNode
Visual C++
public enum class LoadDefinitionFromStartingNode

Members

Member name | Description
Absolutely | Loads locations are given absolutely from the starting node
Relatively | Loads locations are given relatively from the starting node

See Also

Frame3D Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


Material Class

[image]

ENGISSOL - 3D Frame Library
Material Class
Members See Also Send Feedback
3D Frame Library
Material class

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class Material
Visual Basic (Declaration)
Public Class Material
Visual C++
public ref class Material

Inheritance Hierarchy

System..::.Object
Frame3D..::.Material

See Also

Material Members


Material Members

[image] [image]

ENGISSOL - 3D Frame Library
Material Members
Material Class Constructors Fields See Also Send Feedback
3D Frame Library

The Material type exposes the following members.

Constructors

Name | Description
Material | Initializes a new instance of the Material class

Fields

Name | Description
a | Thermal coefficient
Density | Material density (mass/volume units)
E | Elasticity modulus
G | Shear modulus
Name | Material name

See Also

Material Class


Material Constructor

[image]

ENGISSOL - 3D Frame Library
Material Constructor
Material Class See Also Send Feedback
3D Frame Library
Initializes a new instance of the Material class

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public Material()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Material()

See Also

Material Class


Material Fields

[image] [image]

ENGISSOL - 3D Frame Library
Material Fields
Material Class See Also Send Feedback
3D Frame Library

The Material type exposes the following members.

Fields

Name | Description
a | Thermal coefficient
Density | Material density (mass/volume units)
E | Elasticity modulus
G | Shear modulus
Name | Material name

See Also

Material Class


a Field

[image]

ENGISSOL - 3D Frame Library
Material..::.a Field
Material Class See Also Send Feedback
3D Frame Library
Thermal coefficient

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double a
Visual Basic (Declaration)
Public a As Double
Visual C++
public:
double a

See Also

Material Class


Density Field

[image]

ENGISSOL - 3D Frame Library
Material..::.Density Field
Material Class See Also Send Feedback
3D Frame Library
Material density (mass/volume units)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Density
Visual Basic (Declaration)
Public Density As Double
Visual C++
public:
double Density

See Also

Material Class


E Field

[image]

ENGISSOL - 3D Frame Library
Material..::.E Field
Material Class See Also Send Feedback
3D Frame Library
Elasticity modulus

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double E
Visual Basic (Declaration)
Public E As Double
Visual C++
public:
double E

See Also

Material Class


G Field

[image]

ENGISSOL - 3D Frame Library
Material..::.G Field
Material Class See Also Send Feedback
3D Frame Library
Shear modulus

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double G
Visual Basic (Declaration)
Public G As Double
Visual C++
public:
double G

See Also

Material Class


Name Field

[image]

ENGISSOL - 3D Frame Library
Material..::.Name Field
Material Class See Also Send Feedback
3D Frame Library
Material name

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string Name
Visual Basic (Declaration)
Public Name As String
Visual C++
public:
String^ Name

See Also

Material Class


MemberReleases Class

[image]

ENGISSOL - 3D Frame Library
MemberReleases Class
Members See Also Send Feedback
3D Frame Library
Degrees of freedom releases at an element node with respect to the local coordinate system of an element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class MemberReleases
Visual Basic (Declaration)
Public Class MemberReleases
Visual C++
public ref class MemberReleases

Inheritance Hierarchy

System..::.Object
Frame3D..::.MemberReleases

See Also

MemberReleases Members


MemberReleases Members

[image] [image]

ENGISSOL - 3D Frame Library
MemberReleases Members
MemberReleases Class Constructors Fields See Also Send Feedback
3D Frame Library

The MemberReleases type exposes the following members.

Constructors

Name | Description
MemberReleases | Initializes a new instance of the MemberReleases class

Fields

Name | Description
krx | Partial release stiffness (spring constants)
kry | Partial release stiffness (spring constants)
krz | Partial release stiffness (spring constants)
ktx | Partial release stiffness (spring constants)
kty | Partial release stiffness (spring constants)
ktz | Partial release stiffness (spring constants)
Name | Material name
rx | Full or partial dof releases
ry | Full or partial dof releases
rz | Full or partial dof releases
tx | Full or partial dof releases
ty | Full or partial dof releases
tz | Full or partial dof releases

See Also

MemberReleases Class


MemberReleases Constructor

[image]

ENGISSOL - 3D Frame Library
MemberReleases Constructor
MemberReleases Class See Also Send Feedback
3D Frame Library
Initializes a new instance of the MemberReleases class

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public MemberReleases()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberReleases()

See Also

MemberReleases Class


MemberReleases Fields

[image] [image]

ENGISSOL - 3D Frame Library
MemberReleases Fields
MemberReleases Class See Also Send Feedback
3D Frame Library

The MemberReleases type exposes the following members.

Fields

Name | Description
krx | Partial release stiffness (spring constants)
kry | Partial release stiffness (spring constants)
krz | Partial release stiffness (spring constants)
ktx | Partial release stiffness (spring constants)
kty | Partial release stiffness (spring constants)
ktz | Partial release stiffness (spring constants)
Name | Material name
rx | Full or partial dof releases
ry | Full or partial dof releases
rz | Full or partial dof releases
tx | Full or partial dof releases
ty | Full or partial dof releases
tz | Full or partial dof releases

See Also

MemberReleases Class


krx Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.krx Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Partial release stiffness (spring constants)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double krx
Visual Basic (Declaration)
Public krx As Double
Visual C++
public:
double krx

Remarks

Corresponding dof release tx, ty etc should be set to true in order to take into account the partial release stiffness

See Also

MemberReleases Class


kry Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.kry Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Partial release stiffness (spring constants)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double kry
Visual Basic (Declaration)
Public kry As Double
Visual C++
public:
double kry

Remarks

Corresponding dof release tx, ty etc should be set to true in order to take into account the partial release stiffness

See Also

MemberReleases Class


krz Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.krz Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Partial release stiffness (spring constants)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double krz
Visual Basic (Declaration)
Public krz As Double
Visual C++
public:
double krz

Remarks

Corresponding dof release tx, ty etc should be set to true in order to take into account the partial release stiffness

See Also

MemberReleases Class


ktx Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.ktx Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Partial release stiffness (spring constants)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double ktx
Visual Basic (Declaration)
Public ktx As Double
Visual C++
public:
double ktx

Remarks

Corresponding dof release tx, ty etc should be set to true in order to take into account the partial release stiffness

See Also

MemberReleases Class


kty Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.kty Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Partial release stiffness (spring constants)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double kty
Visual Basic (Declaration)
Public kty As Double
Visual C++
public:
double kty

Remarks

Corresponding dof release tx, ty etc should be set to true in order to take into account the partial release stiffness

See Also

MemberReleases Class


ktz Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.ktz Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Partial release stiffness (spring constants)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double ktz
Visual Basic (Declaration)
Public ktz As Double
Visual C++
public:
double ktz

Remarks

Corresponding dof release tx, ty etc should be set to true in order to take into account the partial release stiffness

See Also

MemberReleases Class


Name Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.Name Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Material name

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string Name
Visual Basic (Declaration)
Public Name As String
Visual C++
public:
String^ Name

See Also

MemberReleases Class


rx Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.rx Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Full or partial dof releases

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool rx
Visual Basic (Declaration)
Public rx As Boolean
Visual C++
public:
bool rx

See Also

MemberReleases Class


ry Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.ry Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Full or partial dof releases

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool ry
Visual Basic (Declaration)
Public ry As Boolean
Visual C++
public:
bool ry

See Also

MemberReleases Class


rz Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.rz Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Full or partial dof releases

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool rz
Visual Basic (Declaration)
Public rz As Boolean
Visual C++
public:
bool rz

See Also

MemberReleases Class


tx Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.tx Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Full or partial dof releases

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool tx
Visual Basic (Declaration)
Public tx As Boolean
Visual C++
public:
bool tx

See Also

MemberReleases Class


ty Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.ty Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Full or partial dof releases

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool ty
Visual Basic (Declaration)
Public ty As Boolean
Visual C++
public:
bool ty

See Also

MemberReleases Class


tz Field

[image]

ENGISSOL - 3D Frame Library
MemberReleases..::.tz Field
MemberReleases Class See Also Send Feedback
3D Frame Library
Full or partial dof releases

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool tz
Visual Basic (Declaration)
Public tz As Boolean
Visual C++
public:
bool tz

See Also

MemberReleases Class


MemberType Enumeration

[image]

ENGISSOL - 3D Frame Library
MemberType Enumeration
See Also Send Feedback
3D Frame Library
Frame super element type

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public enum MemberType
Visual Basic (Declaration)
Public Enumeration MemberType
Visual C++
public enum class MemberType

Members

Member name | Description
Beam | Represents a beam member
Brace | Represents a brace member
Column | Represents a column member

See Also

Frame3D Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


ModeComboType Enumeration

[image]

ENGISSOL - 3D Frame Library
ModeComboType Enumeration
See Also Send Feedback
3D Frame Library

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public enum ModeComboType
Visual Basic (Declaration)
Public Enumeration ModeComboType
Visual C++
public enum class ModeComboType

Members

Member name | Description
SRSS | SRSS modal combination
CQC | CQC modal combination

See Also

Frame3D Namespace
ENGINEERING SOFTWARE SOLUTIONS

Send comments on this topic to engissol@engissol.com

ENGISSOL 2010 Copyright


Model Class

[image]

ENGISSOL - 3D Frame Library
Model Class
Members See Also Send Feedback
3D Frame Library
Represents the entire static model

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class Model
Visual Basic (Declaration)
Public Class Model
Visual C++
public ref class Model

Inheritance Hierarchy

System..::.Object
Frame3D..::.Model

See Also

Model Members


Model Members

[image] [image]

ENGISSOL - 3D Frame Library
Model Members
Model Class Constructors Methods Fields See Also Send Feedback
3D Frame Library

The Model type exposes the following members.

Constructors

Name | Description
Model | Initializes a new instance of the Model class

Methods

Name | Description
Solve | This method solves the given finite element model under the given loads and boundary conditions

Fields

Name | Description
EffectiveMassUX | Effective modal mass in X direction for each mode
EffectiveMassUY | Effective modal mass in Y direction for each mode
EffectiveMassUZ | Effective modal mass in Z direction for each mode
FloorDiaphragms | Floor diaphragms
GeometricNonLinearCases | Geometric Non Linear cases
GroundMotionSystem | The coordinate system which corresponds to the ground motion (UX,UY,UZ), for response spectrum analysis only.
InputFiniteElements | Finite elements, eg: FrameSuperElement objects
InputNodes | Nodes
MassSourceCombination | Load combination that defines the mass source
Modes | Modal displacements of nodes
NrOfModesToFind | Number of modes to calculate
Periods | Periods of calculated modes
ResponseSpectrumCases | Response spectrum cases
TimeHistoryCases | Time history cases
TotalEffectiveMassUX | Total effective modal mass for all calculated modes in X direction
TotalEffectiveMassUY | Total effective modal mass for all calculated modes in Y direction
TotalEffectiveMassUZ | Total effective modal mass for all calculated modes in Z direction
TotalMassUX | Total mass for ground acceleration //x
TotalMassUY | Total mass for ground acceleration //y
TotalMassUZ | Total mass for ground acceleration //z

See Also

Model Class


Model Constructor

[image]

ENGISSOL - 3D Frame Library
Model Constructor
Model Class See Also Send Feedback
3D Frame Library
Initializes a new instance of the Model class

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public Model()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Model()

See Also

Model Class


Model Fields

[image] [image]

ENGISSOL - 3D Frame Library
Model Fields
Model Class See Also Send Feedback
3D Frame Library

The Model type exposes the following members.

Fields

Name | Description
EffectiveMassUX | Effective modal mass in X direction for each mode
EffectiveMassUY | Effective modal mass in Y direction for each mode
EffectiveMassUZ | Effective modal mass in Z direction for each mode
FloorDiaphragms | Floor diaphragms
GeometricNonLinearCases | Geometric Non Linear cases
GroundMotionSystem | The coordinate system which corresponds to the ground motion (UX,UY,UZ), for response spectrum analysis only.
InputFiniteElements | Finite elements, eg: FrameSuperElement objects
InputNodes | Nodes
MassSourceCombination | Load combination that defines the mass source
Modes | Modal displacements of nodes
NrOfModesToFind | Number of modes to calculate
Periods | Periods of calculated modes
ResponseSpectrumCases | Response spectrum cases
TimeHistoryCases | Time history cases
TotalEffectiveMassUX | Total effective modal mass for all calculated modes in X direction
TotalEffectiveMassUY | Total effective modal mass for all calculated modes in Y direction
TotalEffectiveMassUZ | Total effective modal mass for all calculated modes in Z direction
TotalMassUX | Total mass for ground acceleration //x
TotalMassUY | Total mass for ground acceleration //y
TotalMassUZ | Total mass for ground acceleration //z

See Also

Model Class


EffectiveMassUX Field

[image]

ENGISSOL - 3D Frame Library
Model..::.EffectiveMassUX Field
Model Class See Also Send Feedback
3D Frame Library
Effective modal mass in X direction for each mode

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double[] EffectiveMassUX
Visual Basic (Declaration)
Public EffectiveMassUX As Double()
Visual C++
public:
array<double>^ EffectiveMassUX

See Also

Model Class


EffectiveMassUY Field

[image]

ENGISSOL - 3D Frame Library
Model..::.EffectiveMassUY Field
Model Class See Also Send Feedback
3D Frame Library
Effective modal mass in Y direction for each mode

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double[] EffectiveMassUY
Visual Basic (Declaration)
Public EffectiveMassUY As Double()
Visual C++
public:
array<double>^ EffectiveMassUY

See Also

Model Class


EffectiveMassUZ Field

[image]

ENGISSOL - 3D Frame Library
Model..::.EffectiveMassUZ Field
Model Class See Also Send Feedback
3D Frame Library
Effective modal mass in Z direction for each mode

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double[] EffectiveMassUZ
Visual Basic (Declaration)
Public EffectiveMassUZ As Double()
Visual C++
public:
array<double>^ EffectiveMassUZ

See Also

Model Class


FloorDiaphragms Field

[image]

ENGISSOL - 3D Frame Library
Model..::.FloorDiaphragms Field
Model Class See Also Send Feedback
3D Frame Library
Floor diaphragms

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<FloorDiaphragm> FloorDiaphragms
Visual Basic (Declaration)
Public FloorDiaphragms As List(Of FloorDiaphragm)
Visual C++
public:
List<FloorDiaphragm^>^ FloorDiaphragms

See Also

Model Class


GeometricNonLinearCases Field

[image]

ENGISSOL - 3D Frame Library
Model..::.GeometricNonLinearCases Field
Model Class See Also Send Feedback
3D Frame Library
Geometric Non Linear cases

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<GeometricNonLinearCase> GeometricNonLinearCases
Visual Basic (Declaration)
Public GeometricNonLinearCases As List(Of GeometricNonLinearCase)
Visual C++
public:
List<GeometricNonLinearCase^>^ GeometricNonLinearCases

See Also

Model Class


GroundMotionSystem Field

[image]

ENGISSOL - 3D Frame Library
Model..::.GroundMotionSystem Field
Model Class See Also Send Feedback
3D Frame Library
The coordinate system which corresponds to the ground motion (UX,UY,UZ), for response spectrum analysis only.

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LocalCoordinateSystem GroundMotionSystem
Visual Basic (Declaration)
Public GroundMotionSystem As LocalCoordinateSystem
Visual C++
public:
LocalCoordinateSystem^ GroundMotionSystem

See Also

Model Class


InputFiniteElements Field

[image]

ENGISSOL - 3D Frame Library
Model..::.InputFiniteElements Field
Model Class See Also Send Feedback
3D Frame Library
Finite elements, eg: FrameSuperElement objects

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<FiniteElement> InputFiniteElements
Visual Basic (Declaration)
Public InputFiniteElements As List(Of FiniteElement)
Visual C++
public:
List<FiniteElement^>^ InputFiniteElements

See Also

Model Class


InputNodes Field

[image]

ENGISSOL - 3D Frame Library
Model..::.InputNodes Field
Model Class See Also Send Feedback
3D Frame Library
Nodes

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<SuperNode> InputNodes
Visual Basic (Declaration)
Public InputNodes As List(Of SuperNode)
Visual C++
public:
List<SuperNode^>^ InputNodes

See Also

Model Class


MassSourceCombination Field

[image]

ENGISSOL - 3D Frame Library
Model..::.MassSourceCombination Field
Model Class See Also Send Feedback
3D Frame Library
Load combination that defines the mass source

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadCombination MassSourceCombination
Visual Basic (Declaration)
Public MassSourceCombination As LoadCombination
Visual C++
public:
LoadCombination^ MassSourceCombination

Remarks

Only for diaphragm masses

See Also

Model Class


Modes Field

[image]

ENGISSOL - 3D Frame Library
Model..::.Modes Field
Model Class See Also Send Feedback
3D Frame Library
Modal displacements of nodes

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double[,] Modes
Visual Basic (Declaration)
Public Modes As Double(,)
Visual C++
public:
array<double,2>^ Modes

See Also

Model Class


NrOfModesToFind Field

[image]

ENGISSOL - 3D Frame Library
Model..::.NrOfModesToFind Field
Model Class See Also Send Feedback
3D Frame Library
Number of modes to calculate

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public int NrOfModesToFind
Visual Basic (Declaration)
Public NrOfModesToFind As Integer
Visual C++
public:
int NrOfModesToFind

See Also

Model Class


Periods Field

[image]

ENGISSOL - 3D Frame Library
Model..::.Periods Field
Model Class See Also Send Feedback
3D Frame Library
Periods of calculated modes

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double[] Periods
Visual Basic (Declaration)
Public Periods As Double()
Visual C++
public:
array<double>^ Periods

See Also

Model Class


ResponseSpectrumCases Field

[image]

ENGISSOL - 3D Frame Library
Model..::.ResponseSpectrumCases Field
Model Class See Also Send Feedback
3D Frame Library
Response spectrum cases

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<ResponseSpectrumCase> ResponseSpectrumCases
Visual Basic (Declaration)
Public ResponseSpectrumCases As List(Of ResponseSpectrumCase)
Visual C++
public:
List<ResponseSpectrumCase^>^ ResponseSpectrumCases

See Also

Model Class


TimeHistoryCases Field

[image]

ENGISSOL - 3D Frame Library
Model..::.TimeHistoryCases Field
Model Class See Also Send Feedback
3D Frame Library
Time history cases

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<TimeHistoryCase> TimeHistoryCases
Visual Basic (Declaration)
Public TimeHistoryCases As List(Of TimeHistoryCase)
Visual C++
public:
List<TimeHistoryCase^>^ TimeHistoryCases

See Also

Model Class


TotalEffectiveMassUX Field

[image]

ENGISSOL - 3D Frame Library
Model..::.TotalEffectiveMassUX Field
Model Class See Also Send Feedback
3D Frame Library
Total effective modal mass for all calculated modes in X direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double TotalEffectiveMassUX
Visual Basic (Declaration)
Public TotalEffectiveMassUX As Double
Visual C++
public:
double TotalEffectiveMassUX

See Also

Model Class


TotalEffectiveMassUY Field

[image]

ENGISSOL - 3D Frame Library
Model..::.TotalEffectiveMassUY Field
Model Class See Also Send Feedback
3D Frame Library
Total effective modal mass for all calculated modes in Y direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double TotalEffectiveMassUY
Visual Basic (Declaration)
Public TotalEffectiveMassUY As Double
Visual C++
public:
double TotalEffectiveMassUY

See Also

Model Class


TotalEffectiveMassUZ Field

[image]

ENGISSOL - 3D Frame Library
Model..::.TotalEffectiveMassUZ Field
Model Class See Also Send Feedback
3D Frame Library
Total effective modal mass for all calculated modes in Z direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double TotalEffectiveMassUZ
Visual Basic (Declaration)
Public TotalEffectiveMassUZ As Double
Visual C++
public:
double TotalEffectiveMassUZ

See Also

Model Class


TotalMassUX Field

[image]

ENGISSOL - 3D Frame Library
Model..::.TotalMassUX Field
Model Class See Also Send Feedback
3D Frame Library
Total mass for ground acceleration //x

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double TotalMassUX
Visual Basic (Declaration)
Public TotalMassUX As Double
Visual C++
public:
double TotalMassUX

See Also

Model Class


TotalMassUY Field

[image]

ENGISSOL - 3D Frame Library
Model..::.TotalMassUY Field
Model Class See Also Send Feedback
3D Frame Library
Total mass for ground acceleration //y

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double TotalMassUY
Visual Basic (Declaration)
Public TotalMassUY As Double
Visual C++
public:
double TotalMassUY

See Also

Model Class


TotalMassUZ Field

[image]

ENGISSOL - 3D Frame Library
Model..::.TotalMassUZ Field
Model Class See Also Send Feedback
3D Frame Library
Total mass for ground acceleration //z

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double TotalMassUZ
Visual Basic (Declaration)
Public TotalMassUZ As Double
Visual C++
public:
double TotalMassUZ

See Also

Model Class


Model Methods

[image] [image]

ENGISSOL - 3D Frame Library
Model Methods
Model Class See Also Send Feedback
3D Frame Library

The Model type exposes the following members.

Methods

Name | Description
Solve | This method solves the given finite element model under the given loads and boundary conditions

See Also

Model Class


Solve Method

[image]

ENGISSOL - 3D Frame Library
Model..::.Solve Method
Model Class See Also Send Feedback
3D Frame Library
This method solves the given finite element model under the given loads and boundary conditions

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void Solve()
Visual Basic (Declaration)
Public Sub Solve
Visual C++
public:
void Solve()

See Also

Model Class


ResponseSpectrumCase Class

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumCase Class
Members See Also Send Feedback
3D Frame Library
Represents a response spectrum case for a given ground acceleration direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class ResponseSpectrumCase
Visual Basic (Declaration)
Public Class ResponseSpectrumCase
Visual C++
public ref class ResponseSpectrumCase

Inheritance Hierarchy

System..::.Object
Frame3D..::.ResponseSpectrumCase

See Also

ResponseSpectrumCase Members


ResponseSpectrumCase Members

[image] [image]

ENGISSOL - 3D Frame Library
ResponseSpectrumCase Members
ResponseSpectrumCase Class Constructors Fields See Also Send Feedback
3D Frame Library

The ResponseSpectrumCase type exposes the following members.

Constructors

Name | Description
ResponseSpectrumCase | Initialization of a response spectrum case

Fields

Name | Description
DiaphragmEccentricityRatio | Ratio of diaphragm eccentricity
direction | Defines the ground acceleration direction for this case
name | Name of the response spectrum case
RSFunction | Defines the response spectrum function object for this case
Type | Defines how the different independent static-equivalent cases will be combined

See Also

ResponseSpectrumCase Class


ResponseSpectrumCase Constructor

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumCase Constructor
ResponseSpectrumCase Class See Also Send Feedback
3D Frame Library
Initialization of a response spectrum case

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public ResponseSpectrumCase(
    string _name,
    GroundMotionDirection _direction,
    ModeComboType _Type
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String, _
    _direction As GroundMotionDirection, _
    _Type As ModeComboType _
)
Visual C++
public:
ResponseSpectrumCase(
    String^ _name,
    GroundMotionDirection _direction,
    ModeComboType _Type
)

Parameters

_name
Type: System..::.String
Response spectrum case name
_direction
Type: Frame3D..::.GroundMotionDirection
Ground acceleration direction
_Type
Type: Frame3D..::.ModeComboType
Defines how the different independent static-equivalent cases will be combined

See Also

ResponseSpectrumCase Class


ResponseSpectrumCase Fields

[image] [image]

ENGISSOL - 3D Frame Library
ResponseSpectrumCase Fields
ResponseSpectrumCase Class See Also Send Feedback
3D Frame Library

The ResponseSpectrumCase type exposes the following members.

Fields

Name | Description
DiaphragmEccentricityRatio | Ratio of diaphragm eccentricity
direction | Defines the ground acceleration direction for this case
name | Name of the response spectrum case
RSFunction | Defines the response spectrum function object for this case
Type | Defines how the different independent static-equivalent cases will be combined

See Also

ResponseSpectrumCase Class


DiaphragmEccentricityRatio Field

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumCase..::.DiaphragmEccentricityRatio Field
ResponseSpectrumCase Class See Also Send Feedback
3D Frame Library
Ratio of diaphragm eccentricity

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double DiaphragmEccentricityRatio
Visual Basic (Declaration)
Public DiaphragmEccentricityRatio As Double
Visual C++
public:
double DiaphragmEccentricityRatio

Remarks

For the corresponding direction, for example if ResponseSpectrumDirection is UX, eccentricity will refer to y axis of the diaphragms

Can be positive or negative. Positive for eccentricities in the positive corresponding axis (for example x agis), otherwise negative

See Also

ResponseSpectrumCase Class


direction Field

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumCase..::.direction Field
ResponseSpectrumCase Class See Also Send Feedback
3D Frame Library
Defines the ground acceleration direction for this case

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public GroundMotionDirection direction
Visual Basic (Declaration)
Public direction As GroundMotionDirection
Visual C++
public:
GroundMotionDirection direction

See Also

ResponseSpectrumCase Class


name Field

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumCase..::.name Field
ResponseSpectrumCase Class See Also Send Feedback
3D Frame Library
Name of the response spectrum case

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string name
Visual Basic (Declaration)
Public name As String
Visual C++
public:
String^ name

See Also

ResponseSpectrumCase Class


RSFunction Field

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumCase..::.RSFunction Field
ResponseSpectrumCase Class See Also Send Feedback
3D Frame Library
Defines the response spectrum function object for this case

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public ResponseSpectrumFunction RSFunction
Visual Basic (Declaration)
Public RSFunction As ResponseSpectrumFunction
Visual C++
public:
ResponseSpectrumFunction^ RSFunction

See Also

ResponseSpectrumCase Class


Type Field

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumCase..::.Type Field
ResponseSpectrumCase Class See Also Send Feedback
3D Frame Library
Defines how the different independent static-equivalent cases will be combined

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public ModeComboType Type
Visual Basic (Declaration)
Public Type As ModeComboType
Visual C++
public:
ModeComboType Type

See Also

ResponseSpectrumCase Class


ResponseSpectrumFunction Class

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumFunction Class
Members See Also Send Feedback
3D Frame Library
Represents a response spectrum function

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class ResponseSpectrumFunction
Visual Basic (Declaration)
Public Class ResponseSpectrumFunction
Visual C++
public ref class ResponseSpectrumFunction

Inheritance Hierarchy

System..::.Object
Frame3D..::.ResponseSpectrumFunction

See Also

ResponseSpectrumFunction Members


ResponseSpectrumFunction Members

[image] [image]

ENGISSOL - 3D Frame Library
ResponseSpectrumFunction Members
ResponseSpectrumFunction Class Constructors Fields See Also Send Feedback
3D Frame Library

The ResponseSpectrumFunction type exposes the following members.

Constructors

Name | Description
ResponseSpectrumFunction | Response spectrum function construction

Fields

Name | Description
name | Response spectrum function name
RS_A | Accelerations of response spectrum points
RS_T | Periods of response spectrum points

See Also

ResponseSpectrumFunction Class


ResponseSpectrumFunction Constructor

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumFunction Constructor
ResponseSpectrumFunction Class See Also Send Feedback
3D Frame Library
Response spectrum function construction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public ResponseSpectrumFunction(
    string _name
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String _
)
Visual C++
public:
ResponseSpectrumFunction(
    String^ _name
)

Parameters

_name
Type: System..::.String
Response spectrum function name

See Also

ResponseSpectrumFunction Class


ResponseSpectrumFunction Fields

[image] [image]

ENGISSOL - 3D Frame Library
ResponseSpectrumFunction Fields
ResponseSpectrumFunction Class See Also Send Feedback
3D Frame Library

The ResponseSpectrumFunction type exposes the following members.

Fields

Name | Description
name | Response spectrum function name
RS_A | Accelerations of response spectrum points
RS_T | Periods of response spectrum points

See Also

ResponseSpectrumFunction Class


name Field

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumFunction..::.name Field
ResponseSpectrumFunction Class See Also Send Feedback
3D Frame Library
Response spectrum function name

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string name
Visual Basic (Declaration)
Public name As String
Visual C++
public:
String^ name

See Also

ResponseSpectrumFunction Class


RS_A Field

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumFunction..::.RS_A Field
ResponseSpectrumFunction Class See Also Send Feedback
3D Frame Library
Accelerations of response spectrum points

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double[] RS_A
Visual Basic (Declaration)
Public RS_A As Double()
Visual C++
public:
array<double>^ RS_A

See Also

ResponseSpectrumFunction Class


RS_T Field

[image]

ENGISSOL - 3D Frame Library
ResponseSpectrumFunction..::.RS_T Field
ResponseSpectrumFunction Class See Also Send Feedback
3D Frame Library
Periods of response spectrum points

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double[] RS_T
Visual Basic (Declaration)
Public RS_T As Double()
Visual C++
public:
array<double>^ RS_T

See Also

ResponseSpectrumFunction Class


SuperNode Class

[image]

ENGISSOL - 3D Frame Library
SuperNode Class
Members See Also Send Feedback
3D Frame Library
A super node represents a node in 3d space

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class SuperNode
Visual Basic (Declaration)
Public Class SuperNode
Visual C++
public ref class SuperNode

Remarks

A super node is used to define the edge nodes of the finite elements of the model

Inheritance Hierarchy

System..::.Object
Frame3D..::.SuperNode

See Also

SuperNode Members


SuperNode Members

[image] [image]

ENGISSOL - 3D Frame Library
SuperNode Members
SuperNode Class Constructors Methods Fields See Also Send Feedback
3D Frame Library

The SuperNode type exposes the following members.

Constructors

Name | Description
SuperNode | Overloaded.

Methods

Name | Description
Equals | SuperNode Equals overriden function (Overrides Object..::.Equals(Object).)
GetNodalDisplacementsForLoadCase | Gets nodal displacements with respect to the global coordinate system
GetNodalDisplacementsForLoadCombination | Performs linear superposition to calculate nodal displacements for the given load combination
GetReactionsForLoadCase | Gets nodal reactions with respect to the global coordinate system
GetReactionsForLoadCombination | Performs linear superposition to calculate reactions for the given load combination
GetSpringReactionsForLoadCase | Gets nodal spring reactions with respect to the global coordinate system
GetSpringReactionsForLoadCombination | Performs linear superposition to calculate spring reactions for the given load combination

Fields

Name | Description
AdditionalMassRX | Additional mass in corresponding direction
AdditionalMassRY | Additional mass in corresponding direction
AdditionalMassRZ | Additional mass in corresponding direction
AdditionalMassTX | Additional mass in corresponding direction
AdditionalMassTY | Additional mass in corresponding direction
AdditionalMassTZ | Additional mass in corresponding direction
dof1constraint | Nodal constraints
dof2constraint | Nodal constraints
dof3constraint | Nodal constraints
dof4constraint | Nodal constraints
dof5constraint | Nodal constraints
dof6constraint | Nodal constraints
init_rx | Predescribed nodal displacements
init_ry | Predescribed nodal displacements
init_rz | Predescribed nodal displacements
init_tx | Predescribed nodal displacements
init_ty | Predescribed nodal displacements
init_tz | Predescribed nodal displacements
Kdof1 | Spring constants (if any)
Kdof2 | Spring constants (if any)
Kdof3 | Spring constants (if any)
Kdof4 | Spring constants (if any)
Kdof5 | Spring constants (if any)
Kdof6 | Spring constants (if any)
LinearLoadCasesList | List of the linear load cases of the node
LocalSystem | The local coordinate system of the node
x | Node coordinates
y | Node coordinates
z | Node coordinates

See Also

SuperNode Class


SuperNode Constructor

[image] [image]

ENGISSOL - 3D Frame Library
SuperNode Constructor
SuperNode Class See Also Send Feedback
3D Frame Library

Overload List

Name | Description
SuperNode(Int32, Double, Double, Double) | Node object initialization
SuperNode(Int32, Double, Double, Double, LocalCoordinateSystem) | Node object initialization

See Also

SuperNode Class
SuperNode Members


SuperNode Constructor (Int32, Double, Double, Double)

[image]

ENGISSOL - 3D Frame Library
SuperNode Constructor (Int32, Double, Double, Double)
SuperNode Class See Also Send Feedback
3D Frame Library
Node object initialization

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public SuperNode(
    int _index,
    double _x,
    double _y,
    double _z
)
Visual Basic (Declaration)
Public Sub New ( _
    _index As Integer, _
    _x As Double, _
    _y As Double, _
    _z As Double _
)
Visual C++
public:
SuperNode(
    int _index,
    double _x,
    double _y,
    double _z
)

Parameters

_index
Type: System..::.Int32
Index, must be unique
_x
Type: System..::.Double
x coordinate in the global coordinate system
_y
Type: System..::.Double
y coordinate in the global coordinate system
_z
Type: System..::.Double
z coordinate in the global coordinate system

See Also

SuperNode Class
SuperNode Overload


SuperNode Constructor (Int32, Double, Double, Double, LocalCoordinateSystem)

[image]

ENGISSOL - 3D Frame Library
SuperNode Constructor (Int32, Double, Double, Double, LocalCoordinateSystem)
SuperNode Class See Also Send Feedback
3D Frame Library
Node object initialization

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public SuperNode(
    int _index,
    double _x,
    double _y,
    double _z,
    LocalCoordinateSystem _LocalSystem
)
Visual Basic (Declaration)
Public Sub New ( _
    _index As Integer, _
    _x As Double, _
    _y As Double, _
    _z As Double, _
    _LocalSystem As LocalCoordinateSystem _
)
Visual C++
public:
SuperNode(
    int _index,
    double _x,
    double _y,
    double _z,
    LocalCoordinateSystem^ _LocalSystem
)

Parameters

_index
Type: System..::.Int32
Index, must be unique
_x
Type: System..::.Double
x coordinate in the global coordinate system
_y
Type: System..::.Double
y coordinate in the global coordinate system
_z
Type: System..::.Double
z coordinate in the global coordinate system
_LocalSystem
Type: MathLib..::.LocalCoordinateSystem
Object that defines the local coordinate system of the node. If Node belongs to a floor diaphragm, its local system should coincide with the global one.

See Also

SuperNode Class
SuperNode Overload


SuperNode Fields

[image] [image]

ENGISSOL - 3D Frame Library
SuperNode Fields
SuperNode Class See Also Send Feedback
3D Frame Library

The SuperNode type exposes the following members.

Fields

Name | Description
AdditionalMassRX | Additional mass in corresponding direction
AdditionalMassRY | Additional mass in corresponding direction
AdditionalMassRZ | Additional mass in corresponding direction
AdditionalMassTX | Additional mass in corresponding direction
AdditionalMassTY | Additional mass in corresponding direction
AdditionalMassTZ | Additional mass in corresponding direction
dof1constraint | Nodal constraints
dof2constraint | Nodal constraints
dof3constraint | Nodal constraints
dof4constraint | Nodal constraints
dof5constraint | Nodal constraints
dof6constraint | Nodal constraints
init_rx | Predescribed nodal displacements
init_ry | Predescribed nodal displacements
init_rz | Predescribed nodal displacements
init_tx | Predescribed nodal displacements
init_ty | Predescribed nodal displacements
init_tz | Predescribed nodal displacements
Kdof1 | Spring constants (if any)
Kdof2 | Spring constants (if any)
Kdof3 | Spring constants (if any)
Kdof4 | Spring constants (if any)
Kdof5 | Spring constants (if any)
Kdof6 | Spring constants (if any)
LinearLoadCasesList | List of the linear load cases of the node
LocalSystem | The local coordinate system of the node
x | Node coordinates
y | Node coordinates
z | Node coordinates

See Also

SuperNode Class


AdditionalMassRX Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.AdditionalMassRX Field
SuperNode Class See Also Send Feedback
3D Frame Library
Additional mass in corresponding direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double AdditionalMassRX
Visual Basic (Declaration)
Public AdditionalMassRX As Double
Visual C++
public:
double AdditionalMassRX

See Also

SuperNode Class


AdditionalMassRY Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.AdditionalMassRY Field
SuperNode Class See Also Send Feedback
3D Frame Library
Additional mass in corresponding direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double AdditionalMassRY
Visual Basic (Declaration)
Public AdditionalMassRY As Double
Visual C++
public:
double AdditionalMassRY

See Also

SuperNode Class


AdditionalMassRZ Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.AdditionalMassRZ Field
SuperNode Class See Also Send Feedback
3D Frame Library
Additional mass in corresponding direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double AdditionalMassRZ
Visual Basic (Declaration)
Public AdditionalMassRZ As Double
Visual C++
public:
double AdditionalMassRZ

See Also

SuperNode Class


AdditionalMassTX Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.AdditionalMassTX Field
SuperNode Class See Also Send Feedback
3D Frame Library
Additional mass in corresponding direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double AdditionalMassTX
Visual Basic (Declaration)
Public AdditionalMassTX As Double
Visual C++
public:
double AdditionalMassTX

See Also

SuperNode Class


AdditionalMassTY Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.AdditionalMassTY Field
SuperNode Class See Also Send Feedback
3D Frame Library
Additional mass in corresponding direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double AdditionalMassTY
Visual Basic (Declaration)
Public AdditionalMassTY As Double
Visual C++
public:
double AdditionalMassTY

See Also

SuperNode Class


AdditionalMassTZ Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.AdditionalMassTZ Field
SuperNode Class See Also Send Feedback
3D Frame Library
Additional mass in corresponding direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double AdditionalMassTZ
Visual Basic (Declaration)
Public AdditionalMassTZ As Double
Visual C++
public:
double AdditionalMassTZ

See Also

SuperNode Class


dof1constraint Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.dof1constraint Field
SuperNode Class See Also Send Feedback
3D Frame Library
Nodal constraints

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool dof1constraint
Visual Basic (Declaration)
Public dof1constraint As Boolean
Visual C++
public:
bool dof1constraint

See Also

SuperNode Class


dof2constraint Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.dof2constraint Field
SuperNode Class See Also Send Feedback
3D Frame Library
Nodal constraints

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool dof2constraint
Visual Basic (Declaration)
Public dof2constraint As Boolean
Visual C++
public:
bool dof2constraint

See Also

SuperNode Class


dof3constraint Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.dof3constraint Field
SuperNode Class See Also Send Feedback
3D Frame Library
Nodal constraints

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool dof3constraint
Visual Basic (Declaration)
Public dof3constraint As Boolean
Visual C++
public:
bool dof3constraint

See Also

SuperNode Class


dof4constraint Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.dof4constraint Field
SuperNode Class See Also Send Feedback
3D Frame Library
Nodal constraints

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool dof4constraint
Visual Basic (Declaration)
Public dof4constraint As Boolean
Visual C++
public:
bool dof4constraint

See Also

SuperNode Class


dof5constraint Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.dof5constraint Field
SuperNode Class See Also Send Feedback
3D Frame Library
Nodal constraints

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool dof5constraint
Visual Basic (Declaration)
Public dof5constraint As Boolean
Visual C++
public:
bool dof5constraint

See Also

SuperNode Class


dof6constraint Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.dof6constraint Field
SuperNode Class See Also Send Feedback
3D Frame Library
Nodal constraints

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public bool dof6constraint
Visual Basic (Declaration)
Public dof6constraint As Boolean
Visual C++
public:
bool dof6constraint

See Also

SuperNode Class


init_rx Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.init_rx Field
SuperNode Class See Also Send Feedback
3D Frame Library
Predescribed nodal displacements

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double init_rx
Visual Basic (Declaration)
Public init_rx As Double
Visual C++
public:
double init_rx

Remarks

Corresponding degree of freedom should be constrained

See Also

SuperNode Class


init_ry Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.init_ry Field
SuperNode Class See Also Send Feedback
3D Frame Library
Predescribed nodal displacements

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double init_ry
Visual Basic (Declaration)
Public init_ry As Double
Visual C++
public:
double init_ry

Remarks

Corresponding degree of freedom should be constrained

See Also

SuperNode Class


init_rz Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.init_rz Field
SuperNode Class See Also Send Feedback
3D Frame Library
Predescribed nodal displacements

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double init_rz
Visual Basic (Declaration)
Public init_rz As Double
Visual C++
public:
double init_rz

Remarks

Corresponding degree of freedom should be constrained

See Also

SuperNode Class


init_tx Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.init_tx Field
SuperNode Class See Also Send Feedback
3D Frame Library
Predescribed nodal displacements

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double init_tx
Visual Basic (Declaration)
Public init_tx As Double
Visual C++
public:
double init_tx

Remarks

Corresponding degree of freedom should be constrained

See Also

SuperNode Class


init_ty Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.init_ty Field
SuperNode Class See Also Send Feedback
3D Frame Library
Predescribed nodal displacements

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double init_ty
Visual Basic (Declaration)
Public init_ty As Double
Visual C++
public:
double init_ty

Remarks

Corresponding degree of freedom should be constrained

See Also

SuperNode Class


init_tz Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.init_tz Field
SuperNode Class See Also Send Feedback
3D Frame Library
Predescribed nodal displacements

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double init_tz
Visual Basic (Declaration)
Public init_tz As Double
Visual C++
public:
double init_tz

Remarks

Corresponding degree of freedom should be constrained

See Also

SuperNode Class


Kdof1 Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.Kdof1 Field
SuperNode Class See Also Send Feedback
3D Frame Library
Spring constants (if any)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Kdof1
Visual Basic (Declaration)
Public Kdof1 As Double
Visual C++
public:
double Kdof1

Remarks

They represent the stiffness of a spring support at the cooresponding degree of freedom with respect to the global coordinate system

See Also

SuperNode Class


Kdof2 Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.Kdof2 Field
SuperNode Class See Also Send Feedback
3D Frame Library
Spring constants (if any)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Kdof2
Visual Basic (Declaration)
Public Kdof2 As Double
Visual C++
public:
double Kdof2

Remarks

They represent the stiffness of a spring support at the cooresponding degree of freedom with respect to the global coordinate system

See Also

SuperNode Class


Kdof3 Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.Kdof3 Field
SuperNode Class See Also Send Feedback
3D Frame Library
Spring constants (if any)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Kdof3
Visual Basic (Declaration)
Public Kdof3 As Double
Visual C++
public:
double Kdof3

Remarks

They represent the stiffness of a spring support at the cooresponding degree of freedom with respect to the global coordinate system

See Also

SuperNode Class


Kdof4 Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.Kdof4 Field
SuperNode Class See Also Send Feedback
3D Frame Library
Spring constants (if any)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Kdof4
Visual Basic (Declaration)
Public Kdof4 As Double
Visual C++
public:
double Kdof4

Remarks

They represent the stiffness of a spring support at the cooresponding degree of freedom with respect to the global coordinate system

See Also

SuperNode Class


Kdof5 Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.Kdof5 Field
SuperNode Class See Also Send Feedback
3D Frame Library
Spring constants (if any)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Kdof5
Visual Basic (Declaration)
Public Kdof5 As Double
Visual C++
public:
double Kdof5

Remarks

They represent the stiffness of a spring support at the cooresponding degree of freedom with respect to the global coordinate system

See Also

SuperNode Class


Kdof6 Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.Kdof6 Field
SuperNode Class See Also Send Feedback
3D Frame Library
Spring constants (if any)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Kdof6
Visual Basic (Declaration)
Public Kdof6 As Double
Visual C++
public:
double Kdof6

Remarks

They represent the stiffness of a spring support at the cooresponding degree of freedom with respect to the global coordinate system

See Also

SuperNode Class


LinearLoadCasesList Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.LinearLoadCasesList Field
SuperNode Class See Also Send Feedback
3D Frame Library
List of the linear load cases of the node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public List<LinearLoadCaseForSuperNode> LinearLoadCasesList
Visual Basic (Declaration)
Public LinearLoadCasesList As List(Of LinearLoadCaseForSuperNode)
Visual C++
public:
List<LinearLoadCaseForSuperNode^>^ LinearLoadCasesList

See Also

SuperNode Class


LocalSystem Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.LocalSystem Field
SuperNode Class See Also Send Feedback
3D Frame Library
The local coordinate system of the node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LocalCoordinateSystem LocalSystem
Visual Basic (Declaration)
Public LocalSystem As LocalCoordinateSystem
Visual C++
public:
LocalCoordinateSystem^ LocalSystem

See Also

SuperNode Class


x Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.x Field
SuperNode Class See Also Send Feedback
3D Frame Library
Node coordinates

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double x
Visual Basic (Declaration)
Public x As Double
Visual C++
public:
double x

See Also

SuperNode Class


y Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.y Field
SuperNode Class See Also Send Feedback
3D Frame Library
Node coordinates

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double y
Visual Basic (Declaration)
Public y As Double
Visual C++
public:
double y

See Also

SuperNode Class


z Field

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.z Field
SuperNode Class See Also Send Feedback
3D Frame Library
Node coordinates

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double z
Visual Basic (Declaration)
Public z As Double
Visual C++
public:
double z

See Also

SuperNode Class


SuperNode Methods

[image] [image]

ENGISSOL - 3D Frame Library
SuperNode Methods
SuperNode Class See Also Send Feedback
3D Frame Library

The SuperNode type exposes the following members.

Methods

Name | Description
Equals | SuperNode Equals overriden function (Overrides Object..::.Equals(Object).)
GetNodalDisplacementsForLoadCase | Gets nodal displacements with respect to the global coordinate system
GetNodalDisplacementsForLoadCombination | Performs linear superposition to calculate nodal displacements for the given load combination
GetReactionsForLoadCase | Gets nodal reactions with respect to the global coordinate system
GetReactionsForLoadCombination | Performs linear superposition to calculate reactions for the given load combination
GetSpringReactionsForLoadCase | Gets nodal spring reactions with respect to the global coordinate system
GetSpringReactionsForLoadCombination | Performs linear superposition to calculate spring reactions for the given load combination

See Also

SuperNode Class


Equals Method

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.Equals Method
SuperNode Class See Also Send Feedback
3D Frame Library
SuperNode Equals overriden function

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
A SuperNode object

Return Value

True if current instance is equal to obj object, otherwise false

See Also

SuperNode Class


GetNodalDisplacementsForLoadCase Method

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.GetNodalDisplacementsForLoadCase Method
SuperNode Class See Also Send Feedback
3D Frame Library
Gets nodal displacements with respect to the global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetNodalDisplacementsForLoadCase(
    string LoadCaseName,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetNodalDisplacementsForLoadCase ( _
    LoadCaseName As String, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetNodalDisplacementsForLoadCase(
    String^ LoadCaseName,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

LoadCaseName
Type: System..::.String
Load case name
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values
stepNr
Type: System..::.Int32
Step number, needed for time history analysis only

See Also

SuperNode Class


GetNodalDisplacementsForLoadCombination Method

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.GetNodalDisplacementsForLoadCombination Method
SuperNode Class See Also Send Feedback
3D Frame Library
Performs linear superposition to calculate nodal displacements for the given load combination

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetNodalDisplacementsForLoadCombination(
    LoadCombination comb,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetNodalDisplacementsForLoadCombination ( _
    comb As LoadCombination, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetNodalDisplacementsForLoadCombination(
    LoadCombination^ comb,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

comb
Type: Frame3D..::.LoadCombination
Load combination object
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values for the given load combination
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values for the given load combination
stepNr
Type: System..::.Int32
Step to get results at (for Time History Analysis only)

See Also

SuperNode Class


GetReactionsForLoadCase Method

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.GetReactionsForLoadCase Method
SuperNode Class See Also Send Feedback
3D Frame Library
Gets nodal reactions with respect to the global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetReactionsForLoadCase(
    string LoadCaseName,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetReactionsForLoadCase ( _
    LoadCaseName As String, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetReactionsForLoadCase(
    String^ LoadCaseName,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

LoadCaseName
Type: System..::.String
Load case name
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values
stepNr
Type: System..::.Int32
Step number, needed for time history analysis only

See Also

SuperNode Class


GetReactionsForLoadCombination Method

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.GetReactionsForLoadCombination Method
SuperNode Class See Also Send Feedback
3D Frame Library
Performs linear superposition to calculate reactions for the given load combination

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetReactionsForLoadCombination(
    LoadCombination comb,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetReactionsForLoadCombination ( _
    comb As LoadCombination, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetReactionsForLoadCombination(
    LoadCombination^ comb,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

comb
Type: Frame3D..::.LoadCombination
Load combination object
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values for the given load combination
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values for the given load combination
stepNr
Type: System..::.Int32
Step to get results at (for Time History Analysis only)

See Also

SuperNode Class


GetSpringReactionsForLoadCase Method

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.GetSpringReactionsForLoadCase Method
SuperNode Class See Also Send Feedback
3D Frame Library
Gets nodal spring reactions with respect to the global coordinate system

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetSpringReactionsForLoadCase(
    string LoadCaseName,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetSpringReactionsForLoadCase ( _
    LoadCaseName As String, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetSpringReactionsForLoadCase(
    String^ LoadCaseName,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

LoadCaseName
Type: System..::.String
Load case name
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values
stepNr
Type: System..::.Int32
Step number, needed for time history analysis only

See Also

SuperNode Class


GetSpringReactionsForLoadCombination Method

[image]

ENGISSOL - 3D Frame Library
SuperNode..::.GetSpringReactionsForLoadCombination Method
SuperNode Class See Also Send Feedback
3D Frame Library
Performs linear superposition to calculate spring reactions for the given load combination

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public void GetSpringReactionsForLoadCombination(
    LoadCombination comb,
    out double[] MinValues,
    out double[] MaxValues,
    int stepNr
)
Visual Basic (Declaration)
Public Sub GetSpringReactionsForLoadCombination ( _
    comb As LoadCombination, _
    <OutAttribute> ByRef MinValues As Double(), _
    <OutAttribute> ByRef MaxValues As Double(), _
    stepNr As Integer _
)
Visual C++
public:
void GetSpringReactionsForLoadCombination(
    LoadCombination^ comb,
    [OutAttribute] array<double>^% MinValues,
    [OutAttribute] array<double>^% MaxValues,
    int stepNr
)

Parameters

comb
Type: Frame3D..::.LoadCombination
Load combination object
MinValues
Type: array< System..::.Double >[]()[] %
Minimum values for the given load combination
MaxValues
Type: array< System..::.Double >[]()[] %
Maximum values for the given load combination
stepNr
Type: System..::.Int32
Step to get results at (for Time History Analysis only)

See Also

SuperNode Class


SuperPointLoad Class

[image]

ENGISSOL - 3D Frame Library
SuperPointLoad Class
Members See Also Send Feedback
3D Frame Library
Point load class for super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class SuperPointLoad
Visual Basic (Declaration)
Public Class SuperPointLoad
Visual C++
public ref class SuperPointLoad

Inheritance Hierarchy

System..::.Object
Frame3D..::.SuperPointLoad

See Also

SuperPointLoad Members


SuperPointLoad Members

[image] [image]

ENGISSOL - 3D Frame Library
SuperPointLoad Members
SuperPointLoad Class Constructors Fields Properties See Also Send Feedback
3D Frame Library

The SuperPointLoad type exposes the following members.

Constructors

Name | Description
SuperPointLoad | Initialization of Point load class for super frame element

Fields

Name | Description
P | Point load at a location within a super frame element
x | Location of the point load

Properties

Name | Description
GetLoadCordinateSystem | Read Only property to get current coordinate system for load definition
GetLoadDefinitionFormStartingNode | Read Only property to get current load definition from starting node

See Also

SuperPointLoad Class


SuperPointLoad Constructor

[image]

ENGISSOL - 3D Frame Library
SuperPointLoad Constructor
SuperPointLoad Class See Also Send Feedback
3D Frame Library
Initialization of Point load class for super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public SuperPointLoad(
    double _x,
    double _P,
    LoadDefinitionFromStartingNode _loadDef,
    LoadCordinateSystem _loadCordSys
)
Visual Basic (Declaration)
Public Sub New ( _
    _x As Double, _
    _P As Double, _
    _loadDef As LoadDefinitionFromStartingNode, _
    _loadCordSys As LoadCordinateSystem _
)
Visual C++
public:
SuperPointLoad(
    double _x,
    double _P,
    LoadDefinitionFromStartingNode _loadDef,
    LoadCordinateSystem _loadCordSys
)

Parameters

_x
Type: System..::.Double
Location of the point load
_P
Type: System..::.Double
Point load at a location within a super frame element
_loadDef
Type: Frame3D..::.LoadDefinitionFromStartingNode
Defines how loads are given with respect to the starting node
_loadCordSys
Type: Frame3D..::.LoadCordinateSystem
Defines whether loads given with respect to the local or global coordinate system

See Also

SuperPointLoad Class


SuperPointLoad Fields

[image] [image]

ENGISSOL - 3D Frame Library
SuperPointLoad Fields
SuperPointLoad Class See Also Send Feedback
3D Frame Library

The SuperPointLoad type exposes the following members.

Fields

Name | Description
P | Point load at a location within a super frame element
x | Location of the point load

See Also

SuperPointLoad Class


P Field

[image]

ENGISSOL - 3D Frame Library
SuperPointLoad..::.P Field
SuperPointLoad Class See Also Send Feedback
3D Frame Library
Point load at a location within a super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double P
Visual Basic (Declaration)
Public P As Double
Visual C++
public:
double P

See Also

SuperPointLoad Class


x Field

[image]

ENGISSOL - 3D Frame Library
SuperPointLoad..::.x Field
SuperPointLoad Class See Also Send Feedback
3D Frame Library
Location of the point load

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double x
Visual Basic (Declaration)
Public x As Double
Visual C++
public:
double x

See Also

SuperPointLoad Class


SuperPointLoad Properties

[image] [image]

ENGISSOL - 3D Frame Library
SuperPointLoad Properties
SuperPointLoad Class See Also Send Feedback
3D Frame Library

The SuperPointLoad type exposes the following members.

Properties

Name | Description
GetLoadCordinateSystem | Read Only property to get current coordinate system for load definition
GetLoadDefinitionFormStartingNode | Read Only property to get current load definition from starting node

See Also

SuperPointLoad Class


GetLoadCordinateSystem Property

[image]

ENGISSOL - 3D Frame Library
SuperPointLoad..::.GetLoadCordinateSystem Property
SuperPointLoad Class See Also Send Feedback
3D Frame Library
Read Only property to get current coordinate system for load definition

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadCordinateSystem GetLoadCordinateSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property GetLoadCordinateSystem As LoadCordinateSystem
Visual C++
public:
property LoadCordinateSystem GetLoadCordinateSystem {
    LoadCordinateSystem get ();
}

See Also

SuperPointLoad Class


GetLoadDefinitionFormStartingNode Property

[image]

ENGISSOL - 3D Frame Library
SuperPointLoad..::.GetLoadDefinitionFormStartingNode Property
SuperPointLoad Class See Also Send Feedback
3D Frame Library
Read Only property to get current load definition from starting node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadDefinitionFromStartingNode GetLoadDefinitionFormStartingNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property GetLoadDefinitionFormStartingNode As LoadDefinitionFromStartingNode
Visual C++
public:
property LoadDefinitionFromStartingNode GetLoadDefinitionFormStartingNode {
    LoadDefinitionFromStartingNode get ();
}

See Also

SuperPointLoad Class


SuperUniformLoad Class

[image]

ENGISSOL - 3D Frame Library
SuperUniformLoad Class
Members See Also Send Feedback
3D Frame Library
Uniform load class for super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class SuperUniformLoad
Visual Basic (Declaration)
Public Class SuperUniformLoad
Visual C++
public ref class SuperUniformLoad

Inheritance Hierarchy

System..::.Object
Frame3D..::.SuperUniformLoad

See Also

SuperUniformLoad Members


SuperUniformLoad Members

[image] [image]

ENGISSOL - 3D Frame Library
SuperUniformLoad Members
SuperUniformLoad Class Constructors Fields Properties See Also Send Feedback
3D Frame Library

The SuperUniformLoad type exposes the following members.

Constructors

Name | Description
SuperUniformLoad | Initialization of Uniform load class for super frame element

Fields

Name | Description
pA | Starting location load value (Force / Length)
pB | Ending location load value (Force / Length)
xA | Starting location of uniform load
xB | Ending location of uniform load

Properties

Name | Description
GetLoadCordinateSystem | Read Only property to get current coordinate system for load definition
GetLoadDefinitionFormStartingNode | Read Only property to get current load definition from starting node

See Also

SuperUniformLoad Class


SuperUniformLoad Constructor

[image]

ENGISSOL - 3D Frame Library
SuperUniformLoad Constructor
SuperUniformLoad Class See Also Send Feedback
3D Frame Library
Initialization of Uniform load class for super frame element

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public SuperUniformLoad(
    double _xA,
    double _xB,
    double _pA,
    double _pB,
    LoadDefinitionFromStartingNode _loadDef,
    LoadCordinateSystem _loadCordSys
)
Visual Basic (Declaration)
Public Sub New ( _
    _xA As Double, _
    _xB As Double, _
    _pA As Double, _
    _pB As Double, _
    _loadDef As LoadDefinitionFromStartingNode, _
    _loadCordSys As LoadCordinateSystem _
)
Visual C++
public:
SuperUniformLoad(
    double _xA,
    double _xB,
    double _pA,
    double _pB,
    LoadDefinitionFromStartingNode _loadDef,
    LoadCordinateSystem _loadCordSys
)

Parameters

_xA
Type: System..::.Double
Starting location, absolute value from starting node
_xB
Type: System..::.Double
Ending location, absolute value from starting node
_pA
Type: System..::.Double
Value at point A (Force / Length)
_pB
Type: System..::.Double
Value at point B (Force / Length)
_loadDef
Type: Frame3D..::.LoadDefinitionFromStartingNode
Loads definition from starting node of loaded frame super element (abolutely or relatively)
_loadCordSys
Type: Frame3D..::.LoadCordinateSystem
Defines whether loads given with respect to the local or global coordinate system

See Also

SuperUniformLoad Class


SuperUniformLoad Fields

[image] [image]

ENGISSOL - 3D Frame Library
SuperUniformLoad Fields
SuperUniformLoad Class See Also Send Feedback
3D Frame Library

The SuperUniformLoad type exposes the following members.

Fields

Name | Description
pA | Starting location load value (Force / Length)
pB | Ending location load value (Force / Length)
xA | Starting location of uniform load
xB | Ending location of uniform load

See Also

SuperUniformLoad Class


pA Field

[image]

ENGISSOL - 3D Frame Library
SuperUniformLoad..::.pA Field
SuperUniformLoad Class See Also Send Feedback
3D Frame Library
Starting location load value (Force / Length)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double pA
Visual Basic (Declaration)
Public pA As Double
Visual C++
public:
double pA

See Also

SuperUniformLoad Class


pB Field

[image]

ENGISSOL - 3D Frame Library
SuperUniformLoad..::.pB Field
SuperUniformLoad Class See Also Send Feedback
3D Frame Library
Ending location load value (Force / Length)

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double pB
Visual Basic (Declaration)
Public pB As Double
Visual C++
public:
double pB

See Also

SuperUniformLoad Class


xA Field

[image]

ENGISSOL - 3D Frame Library
SuperUniformLoad..::.xA Field
SuperUniformLoad Class See Also Send Feedback
3D Frame Library
Starting location of uniform load

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double xA
Visual Basic (Declaration)
Public xA As Double
Visual C++
public:
double xA

See Also

SuperUniformLoad Class


xB Field

[image]

ENGISSOL - 3D Frame Library
SuperUniformLoad..::.xB Field
SuperUniformLoad Class See Also Send Feedback
3D Frame Library
Ending location of uniform load

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double xB
Visual Basic (Declaration)
Public xB As Double
Visual C++
public:
double xB

See Also

SuperUniformLoad Class


SuperUniformLoad Properties

[image] [image]

ENGISSOL - 3D Frame Library
SuperUniformLoad Properties
SuperUniformLoad Class See Also Send Feedback
3D Frame Library

The SuperUniformLoad type exposes the following members.

Properties

Name | Description
GetLoadCordinateSystem | Read Only property to get current coordinate system for load definition
GetLoadDefinitionFormStartingNode | Read Only property to get current load definition from starting node

See Also

SuperUniformLoad Class


GetLoadCordinateSystem Property

[image]

ENGISSOL - 3D Frame Library
SuperUniformLoad..::.GetLoadCordinateSystem Property
SuperUniformLoad Class See Also Send Feedback
3D Frame Library
Read Only property to get current coordinate system for load definition

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadCordinateSystem GetLoadCordinateSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property GetLoadCordinateSystem As LoadCordinateSystem
Visual C++
public:
property LoadCordinateSystem GetLoadCordinateSystem {
    LoadCordinateSystem get ();
}

See Also

SuperUniformLoad Class


GetLoadDefinitionFormStartingNode Property

[image]

ENGISSOL - 3D Frame Library
SuperUniformLoad..::.GetLoadDefinitionFormStartingNode Property
SuperUniformLoad Class See Also Send Feedback
3D Frame Library
Read Only property to get current load definition from starting node

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LoadDefinitionFromStartingNode GetLoadDefinitionFormStartingNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property GetLoadDefinitionFormStartingNode As LoadDefinitionFromStartingNode
Visual C++
public:
property LoadDefinitionFromStartingNode GetLoadDefinitionFormStartingNode {
    LoadDefinitionFromStartingNode get ();
}

See Also

SuperUniformLoad Class


TimeHistoryCase Class

[image]

ENGISSOL - 3D Frame Library
TimeHistoryCase Class
Members See Also Send Feedback
3D Frame Library
Represents a time history case for a given ground acceleration direction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class TimeHistoryCase
Visual Basic (Declaration)
Public Class TimeHistoryCase
Visual C++
public ref class TimeHistoryCase

Inheritance Hierarchy

System..::.Object
Frame3D..::.TimeHistoryCase

See Also

TimeHistoryCase Members


TimeHistoryCase Members

[image] [image]

ENGISSOL - 3D Frame Library
TimeHistoryCase Members
TimeHistoryCase Class Constructors Fields See Also Send Feedback
3D Frame Library

The TimeHistoryCase type exposes the following members.

Constructors

Name | Description
TimeHistoryCase | Initialization of a time history case

Fields

Name | Description
direction | Defines the ground acceleration direction for this case
dt | Time step
name | Name of the time history case
steps | Total accelerogram steps, including step for t=0
THFunction | Defines the time history function object for this case
Type | Defines how the different independent static-equivalent cases will be combined

See Also

TimeHistoryCase Class


TimeHistoryCase Constructor

[image]

ENGISSOL - 3D Frame Library
TimeHistoryCase Constructor
TimeHistoryCase Class See Also Send Feedback
3D Frame Library
Initialization of a time history case

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public TimeHistoryCase(
    string _name,
    GroundMotionDirection _direction,
    ModeComboType _Type
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String, _
    _direction As GroundMotionDirection, _
    _Type As ModeComboType _
)
Visual C++
public:
TimeHistoryCase(
    String^ _name,
    GroundMotionDirection _direction,
    ModeComboType _Type
)

Parameters

_name
Type: System..::.String
Time history case name
_direction
Type: Frame3D..::.GroundMotionDirection
Ground acceleration direction
_Type
Type: Frame3D..::.ModeComboType
Defines how the different independent static-equivalent cases will be combined

See Also

TimeHistoryCase Class


TimeHistoryCase Fields

[image] [image]

ENGISSOL - 3D Frame Library
TimeHistoryCase Fields
TimeHistoryCase Class See Also Send Feedback
3D Frame Library

The TimeHistoryCase type exposes the following members.

Fields

Name | Description
direction | Defines the ground acceleration direction for this case
dt | Time step
name | Name of the time history case
steps | Total accelerogram steps, including step for t=0
THFunction | Defines the time history function object for this case
Type | Defines how the different independent static-equivalent cases will be combined

See Also

TimeHistoryCase Class


direction Field

[image]

ENGISSOL - 3D Frame Library
TimeHistoryCase..::.direction Field
TimeHistoryCase Class See Also Send Feedback
3D Frame Library
Defines the ground acceleration direction for this case

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public GroundMotionDirection direction
Visual Basic (Declaration)
Public direction As GroundMotionDirection
Visual C++
public:
GroundMotionDirection direction

See Also

TimeHistoryCase Class


dt Field

[image]

ENGISSOL - 3D Frame Library
TimeHistoryCase..::.dt Field
TimeHistoryCase Class See Also Send Feedback
3D Frame Library
Time step

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double dt
Visual Basic (Declaration)
Public dt As Double
Visual C++
public:
double dt

See Also

TimeHistoryCase Class


name Field

[image]

ENGISSOL - 3D Frame Library
TimeHistoryCase..::.name Field
TimeHistoryCase Class See Also Send Feedback
3D Frame Library
Name of the time history case

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string name
Visual Basic (Declaration)
Public name As String
Visual C++
public:
String^ name

See Also

TimeHistoryCase Class


steps Field

[image]

ENGISSOL - 3D Frame Library
TimeHistoryCase..::.steps Field
TimeHistoryCase Class See Also Send Feedback
3D Frame Library
Total accelerogram steps, including step for t=0

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public int steps
Visual Basic (Declaration)
Public steps As Integer
Visual C++
public:
int steps

See Also

TimeHistoryCase Class


THFunction Field

[image]

ENGISSOL - 3D Frame Library
TimeHistoryCase..::.THFunction Field
TimeHistoryCase Class See Also Send Feedback
3D Frame Library
Defines the time history function object for this case

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public TimeHistoryFunction THFunction
Visual Basic (Declaration)
Public THFunction As TimeHistoryFunction
Visual C++
public:
TimeHistoryFunction^ THFunction

See Also

TimeHistoryCase Class


Type Field

[image]

ENGISSOL - 3D Frame Library
TimeHistoryCase..::.Type Field
TimeHistoryCase Class See Also Send Feedback
3D Frame Library
Defines how the different independent static-equivalent cases will be combined

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public ModeComboType Type
Visual Basic (Declaration)
Public Type As ModeComboType
Visual C++
public:
ModeComboType Type

See Also

TimeHistoryCase Class


TimeHistoryFunction Class

[image]

ENGISSOL - 3D Frame Library
TimeHistoryFunction Class
Members See Also Send Feedback
3D Frame Library
Represents a time history function

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class TimeHistoryFunction
Visual Basic (Declaration)
Public Class TimeHistoryFunction
Visual C++
public ref class TimeHistoryFunction

Inheritance Hierarchy

System..::.Object
Frame3D..::.TimeHistoryFunction

See Also

TimeHistoryFunction Members


TimeHistoryFunction Members

[image] [image]

ENGISSOL - 3D Frame Library
TimeHistoryFunction Members
TimeHistoryFunction Class Constructors Fields See Also Send Feedback
3D Frame Library

The TimeHistoryFunction type exposes the following members.

Constructors

Name | Description
TimeHistoryFunction | Time history function construction

Fields

Name | Description
name | Time history function name
TH_A | Accelerations
TH_t | Seconds

See Also

TimeHistoryFunction Class


TimeHistoryFunction Constructor

[image]

ENGISSOL - 3D Frame Library
TimeHistoryFunction Constructor
TimeHistoryFunction Class See Also Send Feedback
3D Frame Library
Time history function construction

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public TimeHistoryFunction(
    string _name
)
Visual Basic (Declaration)
Public Sub New ( _
    _name As String _
)
Visual C++
public:
TimeHistoryFunction(
    String^ _name
)

Parameters

_name
Type: System..::.String
Time history function name

See Also

TimeHistoryFunction Class


TimeHistoryFunction Fields

[image] [image]

ENGISSOL - 3D Frame Library
TimeHistoryFunction Fields
TimeHistoryFunction Class See Also Send Feedback
3D Frame Library

The TimeHistoryFunction type exposes the following members.

Fields

Name | Description
name | Time history function name
TH_A | Accelerations
TH_t | Seconds

See Also

TimeHistoryFunction Class


name Field

[image]

ENGISSOL - 3D Frame Library
TimeHistoryFunction..::.name Field
TimeHistoryFunction Class See Also Send Feedback
3D Frame Library
Time history function name

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public string name
Visual Basic (Declaration)
Public name As String
Visual C++
public:
String^ name

See Also

TimeHistoryFunction Class


TH_A Field

[image]

ENGISSOL - 3D Frame Library
TimeHistoryFunction..::.TH_A Field
TimeHistoryFunction Class See Also Send Feedback
3D Frame Library
Accelerations

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double[] TH_A
Visual Basic (Declaration)
Public TH_A As Double()
Visual C++
public:
array<double>^ TH_A

See Also

TimeHistoryFunction Class


TH_t Field

[image]

ENGISSOL - 3D Frame Library
TimeHistoryFunction..::.TH_t Field
TimeHistoryFunction Class See Also Send Feedback
3D Frame Library
Seconds

Namespace: Frame3D
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double[] TH_t
Visual Basic (Declaration)
Public TH_t As Double()
Visual C++
public:
array<double>^ TH_t

See Also

TimeHistoryFunction Class


MathLib Namespace

[image]

ENGISSOL - 3D Frame Library
MathLib Namespace
Send Feedback
3D Frame Library

Classes

Class Description
Geometry
Geometry class
LocalCoordinateSystem
Definition of a local coordinate system

Remarks

This local coordinate system can be defined in two ways:

1. By defining two points on the local X axis (_StartingPointOfLocalXAxis, _EndingPointOfLocalXAxis) and a point (_PointInPlaneXY) in its local XY plane, or

2. By defining two points on the local X axis (_StartingPointOfLocalXAxis, _EndingPointOfLocalXAxis) and the rotation angle (_LocalAxisAngle) about its local X axis. Zero local axis angle means that the local Y axis coincides with global Y axis.

Structures

Structure | Description
Geometry..::.XY | Represents a point in 2d space
Geometry..::.XYZ | Represents a point in 3d space


Geometry Class

[image]

ENGISSOL - 3D Frame Library
Geometry Class
Members See Also Send Feedback
3D Frame Library
Geometry class

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class Geometry
Visual Basic (Declaration)
Public Class Geometry
Visual C++
public ref class Geometry

Inheritance Hierarchy

System..::.Object
MathLib..::.Geometry

See Also

Geometry Members
MathLib Namespace


Geometry Members

[image] [image]

ENGISSOL - 3D Frame Library
Geometry Members
Geometry Class Constructors See Also Send Feedback
3D Frame Library

The Geometry type exposes the following members.

Constructors

Name | Description
Geometry | Initializes a new instance of the Geometry class

See Also

Geometry Class
MathLib Namespace


Geometry Constructor

[image]

ENGISSOL - 3D Frame Library
Geometry Constructor
Geometry Class See Also Send Feedback
3D Frame Library
Initializes a new instance of the Geometry class

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public Geometry()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Geometry()

See Also

Geometry Class
MathLib Namespace


Geometry.XY Structure

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XY Structure
Geometry Class Members See Also Send Feedback
3D Frame Library
Represents a point in 2d space

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public struct XY
Visual Basic (Declaration)
Public Structure XY
Visual C++
public value class XY

See Also

Geometry..::.XY Members
MathLib Namespace


Geometry.XY Members

[image] [image]

ENGISSOL - 3D Frame Library
Geometry..::.XY Members
Geometry..::.XY Structure Constructors Methods Fields See Also Send Feedback
3D Frame Library

Geometry class

The Geometry..::.XY type exposes the following members.

Constructors

Name | Description
Geometry..::.XY | 2d vector construction

Methods

Name | Description
Magnitude | Distance from axes origin calculation

Fields

Name | Description
x | X coordinate
y | Y coordinate

See Also

Geometry..::.XY Structure
MathLib Namespace


Geometry.XY Constructor

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XY Constructor
Geometry..::.XY Structure See Also Send Feedback
3D Frame Library
2d vector construction

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public XY(
    double _x,
    double _y
)
Visual Basic (Declaration)
Public Sub New ( _
    _x As Double, _
    _y As Double _
)
Visual C++
public:
XY(
    double _x,
    double _y
)

Parameters

_x
Type: System..::.Double
x value
_y
Type: System..::.Double
y value

See Also

Geometry..::.XY Structure
MathLib Namespace


Geometry.XY Fields

[image] [image]

ENGISSOL - 3D Frame Library
Geometry..::.XY Fields
Geometry..::.XY Structure See Also Send Feedback
3D Frame Library

The Geometry..::.XY type exposes the following members.

Fields

Name | Description
x | X coordinate
y | Y coordinate

See Also

Geometry..::.XY Structure
MathLib Namespace


x Field

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XY..::.x Field
Geometry..::.XY Structure See Also Send Feedback
3D Frame Library
X coordinate

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double x
Visual Basic (Declaration)
Public x As Double
Visual C++
public:
double x

See Also

Geometry..::.XY Structure
MathLib Namespace


y Field

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XY..::.y Field
Geometry..::.XY Structure See Also Send Feedback
3D Frame Library
Y coordinate

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double y
Visual Basic (Declaration)
Public y As Double
Visual C++
public:
double y

See Also

Geometry..::.XY Structure
MathLib Namespace


Geometry.XY Methods

[image] [image]

ENGISSOL - 3D Frame Library
Geometry..::.XY Methods
Geometry..::.XY Structure See Also Send Feedback
3D Frame Library

The Geometry..::.XY type exposes the following members.

Methods

Name | Description
Magnitude | Distance from axes origin calculation

See Also

Geometry..::.XY Structure
MathLib Namespace


Magnitude Method

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XY..::.Magnitude Method
Geometry..::.XY Structure See Also Send Feedback
3D Frame Library
Distance from axes origin calculation

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double Magnitude()
Visual Basic (Declaration)
Public Function Magnitude As Double
Visual C++
public:
double Magnitude()

See Also

Geometry..::.XY Structure
MathLib Namespace


Geometry.XYZ Structure

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ Structure
Geometry Class Members See Also Send Feedback
3D Frame Library
Represents a point in 3d space

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public struct XYZ
Visual Basic (Declaration)
Public Structure XYZ
Visual C++
public value class XYZ

See Also

Geometry..::.XYZ Members
MathLib Namespace


Geometry.XYZ Members

[image] [image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ Members
Geometry..::.XYZ Structure Constructors Methods Fields See Also Send Feedback
3D Frame Library

Geometry class

The Geometry..::.XYZ type exposes the following members.

Constructors

Name | Description
Geometry..::.XYZ | 3d vector construction

Operators

Name | Description
Addition | 3d vectors addition
Division | 3d vector division by scalar
ExclusiveOr | 3d vectors cross product
Multiply | Overloaded.
Subtraction | 3d vectors substraction

Fields

Name | Description
x | X coordinate
y | Z coordinate
z | Y coordinate

See Also

Geometry..::.XYZ Structure
MathLib Namespace


Geometry.XYZ Constructor

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ Constructor
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
3d vector construction

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public XYZ(
    double _x,
    double _y,
    double _z
)
Visual Basic (Declaration)
Public Sub New ( _
    _x As Double, _
    _y As Double, _
    _z As Double _
)
Visual C++
public:
XYZ(
    double _x,
    double _y,
    double _z
)

Parameters

_x
Type: System..::.Double
x value
_y
Type: System..::.Double
y value
_z
Type: System..::.Double
z value

See Also

Geometry..::.XYZ Structure
MathLib Namespace


Geometry.XYZ Fields

[image] [image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ Fields
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library

The Geometry..::.XYZ type exposes the following members.

Fields

Name | Description
x | X coordinate
y | Z coordinate
z | Y coordinate

See Also

Geometry..::.XYZ Structure
MathLib Namespace


x Field

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.x Field
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
X coordinate

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double x
Visual Basic (Declaration)
Public x As Double
Visual C++
public:
double x

See Also

Geometry..::.XYZ Structure
MathLib Namespace


y Field

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.y Field
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
Z coordinate

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double y
Visual Basic (Declaration)
Public y As Double
Visual C++
public:
double y

See Also

Geometry..::.XYZ Structure
MathLib Namespace


z Field

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.z Field
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
Y coordinate

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public double z
Visual Basic (Declaration)
Public z As Double
Visual C++
public:
double z

See Also

Geometry..::.XYZ Structure
MathLib Namespace


Geometry.XYZ Methods

[image] [image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ Methods
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library

The Geometry..::.XYZ type exposes the following members.

Operators

Name | Description
Addition | 3d vectors addition
Division | 3d vector division by scalar
ExclusiveOr | 3d vectors cross product
Multiply | Overloaded.
Subtraction | 3d vectors substraction

See Also

Geometry..::.XYZ Structure
MathLib Namespace


Addition Operator

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.Addition Operator
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
3d vectors addition

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public static Geometry..::.XYZ operator +(
    Geometry..::.XYZ v1,
    Geometry..::.XYZ v2
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    v1 As Geometry..::.XYZ, _
    v2 As Geometry..::.XYZ _
) As Geometry..::.XYZ
Visual C++
public:
static Geometry..::.XYZ operator +(
    Geometry..::.XYZ v1,
    Geometry..::.XYZ v2
)

Parameters

v1
Type: MathLib..::.Geometry..::.XYZ
v2
Type: MathLib..::.Geometry..::.XYZ

See Also

Geometry..::.XYZ Structure
MathLib Namespace


Division Operator

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.Division Operator
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
3d vector division by scalar

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public static Geometry..::.XYZ operator /(
    Geometry..::.XYZ v,
    double lamda
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    v As Geometry..::.XYZ, _
    lamda As Double _
) As Geometry..::.XYZ
Visual C++
public:
static Geometry..::.XYZ operator /(
    Geometry..::.XYZ v,
    double lamda
)

Parameters

v
Type: MathLib..::.Geometry..::.XYZ
lamda
Type: System..::.Double

See Also

Geometry..::.XYZ Structure
MathLib Namespace


ExclusiveOr Operator

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.ExclusiveOr Operator
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
3d vectors cross product

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public static Geometry..::.XYZ operator ^(
    Geometry..::.XYZ u,
    Geometry..::.XYZ v
)
Visual Basic (Declaration)
Public Shared Operator Xor ( _
    u As Geometry..::.XYZ, _
    v As Geometry..::.XYZ _
) As Geometry..::.XYZ
Visual C++
public:
static Geometry..::.XYZ operator ^(
    Geometry..::.XYZ u,
    Geometry..::.XYZ v
)

Parameters

u
Type: MathLib..::.Geometry..::.XYZ
v
Type: MathLib..::.Geometry..::.XYZ

See Also

Geometry..::.XYZ Structure
MathLib Namespace


Multiply Method

[image] [image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.Multiply Method
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library

Overload List

Name | Description
Multiply(Geometry..::.XYZ, Geometry..::.XYZ) | 3d vectors inner product
Multiply(Geometry..::.XYZ, Double) | 3d vector product by scalar
Multiply(Double, Geometry..::.XYZ) | 3d vector product by scalar

See Also

Geometry..::.XYZ Structure
Geometry..::.XYZ Members
MathLib Namespace


Multiply Operator

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.Multiply Operator
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
3d vectors inner product

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public static double operator *(
    Geometry..::.XYZ v1,
    Geometry..::.XYZ v2
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    v1 As Geometry..::.XYZ, _
    v2 As Geometry..::.XYZ _
) As Double
Visual C++
public:
static double operator *(
    Geometry..::.XYZ v1,
    Geometry..::.XYZ v2
)

Parameters

v1
Type: MathLib..::.Geometry..::.XYZ
v2
Type: MathLib..::.Geometry..::.XYZ

See Also

Geometry..::.XYZ Structure
Multiply Overload
MathLib Namespace


Multiply Operator

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.Multiply Operator
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
3d vector product by scalar

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public static Geometry..::.XYZ operator *(
    Geometry..::.XYZ v,
    double lamda
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    v As Geometry..::.XYZ, _
    lamda As Double _
) As Geometry..::.XYZ
Visual C++
public:
static Geometry..::.XYZ operator *(
    Geometry..::.XYZ v,
    double lamda
)

Parameters

v
Type: MathLib..::.Geometry..::.XYZ
lamda
Type: System..::.Double

See Also

Geometry..::.XYZ Structure
Multiply Overload
MathLib Namespace


Multiply Operator

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.Multiply Operator
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
3d vector product by scalar

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public static Geometry..::.XYZ operator *(
    double lamda,
    Geometry..::.XYZ v
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    lamda As Double, _
    v As Geometry..::.XYZ _
) As Geometry..::.XYZ
Visual C++
public:
static Geometry..::.XYZ operator *(
    double lamda,
    Geometry..::.XYZ v
)

Parameters

lamda
Type: System..::.Double
v
Type: MathLib..::.Geometry..::.XYZ

See Also

Geometry..::.XYZ Structure
Multiply Overload
MathLib Namespace


Subtraction Operator

[image]

ENGISSOL - 3D Frame Library
Geometry..::.XYZ..::.Subtraction Operator
Geometry..::.XYZ Structure See Also Send Feedback
3D Frame Library
3d vectors substraction

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public static Geometry..::.XYZ operator -(
    Geometry..::.XYZ v1,
    Geometry..::.XYZ v2
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    v1 As Geometry..::.XYZ, _
    v2 As Geometry..::.XYZ _
) As Geometry..::.XYZ
Visual C++
public:
static Geometry..::.XYZ operator -(
    Geometry..::.XYZ v1,
    Geometry..::.XYZ v2
)

Parameters

v1
Type: MathLib..::.Geometry..::.XYZ
v2
Type: MathLib..::.Geometry..::.XYZ

See Also

Geometry..::.XYZ Structure
MathLib Namespace


LocalCoordinateSystem Class

[image]

ENGISSOL - 3D Frame Library
LocalCoordinateSystem Class
Members See Also Send Feedback
3D Frame Library
Definition of a local coordinate system

Remarks

This local coordinate system can be defined in two ways:

1. By defining two points on the local X axis (_StartingPointOfLocalXAxis, _EndingPointOfLocalXAxis) and a point (_PointInPlaneXY) in its local XY plane, or

2. By defining two points on the local X axis (_StartingPointOfLocalXAxis, _EndingPointOfLocalXAxis) and the rotation angle (_LocalAxisAngle) about its local X axis. Zero local axis angle means that the local Y axis coincides with global Y axis.

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public class LocalCoordinateSystem
Visual Basic (Declaration)
Public Class LocalCoordinateSystem
Visual C++
public ref class LocalCoordinateSystem

Inheritance Hierarchy

System..::.Object
MathLib..::.LocalCoordinateSystem

See Also

LocalCoordinateSystem Members
MathLib Namespace


LocalCoordinateSystem Members

[image] [image]

ENGISSOL - 3D Frame Library
LocalCoordinateSystem Members
LocalCoordinateSystem Class Constructors Fields See Also Send Feedback
3D Frame Library

The LocalCoordinateSystem type exposes the following members.

Constructors

Name | Description
LocalCoordinateSystem | Local coordinate system construction

Fields

Name | Description
EndingPointOfLocalXAxis |
PointInPlaneXY |
StartingPointOfLocalXAxis |

See Also

LocalCoordinateSystem Class
MathLib Namespace


LocalCoordinateSystem Constructor

[image]

ENGISSOL - 3D Frame Library
LocalCoordinateSystem Constructor
LocalCoordinateSystem Class See Also Send Feedback
3D Frame Library
Local coordinate system construction

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public LocalCoordinateSystem(
    Geometry..::.XYZ _StartingPointOfLocalXAxis,
    Geometry..::.XYZ _EndingPointOfLocalXAxis,
    Geometry..::.XYZ _PointInPlaneXY
)
Visual Basic (Declaration)
Public Sub New ( _
    _StartingPointOfLocalXAxis As Geometry..::.XYZ, _
    _EndingPointOfLocalXAxis As Geometry..::.XYZ, _
    _PointInPlaneXY As Geometry..::.XYZ _
)
Visual C++
public:
LocalCoordinateSystem(
    Geometry..::.XYZ _StartingPointOfLocalXAxis,
    Geometry..::.XYZ _EndingPointOfLocalXAxis,
    Geometry..::.XYZ _PointInPlaneXY
)

Parameters

_StartingPointOfLocalXAxis
Type: MathLib..::.Geometry..::.XYZ
First point on local X axis
_EndingPointOfLocalXAxis
Type: MathLib..::.Geometry..::.XYZ
Second point on local X axis
_PointInPlaneXY
Type: MathLib..::.Geometry..::.XYZ
Point in local XY plane

See Also

LocalCoordinateSystem Class
MathLib Namespace


LocalCoordinateSystem Fields

[image] [image]

ENGISSOL - 3D Frame Library
LocalCoordinateSystem Fields
LocalCoordinateSystem Class See Also Send Feedback
3D Frame Library

The LocalCoordinateSystem type exposes the following members.

Fields

Name | Description
EndingPointOfLocalXAxis |
PointInPlaneXY |
StartingPointOfLocalXAxis |

See Also

LocalCoordinateSystem Class
MathLib Namespace


EndingPointOfLocalXAxis Field

[image]

ENGISSOL - 3D Frame Library
LocalCoordinateSystem..::.EndingPointOfLocalXAxis Field
LocalCoordinateSystem Class See Also Send Feedback
3D Frame Library

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public Geometry..::.XYZ EndingPointOfLocalXAxis
Visual Basic (Declaration)
Public EndingPointOfLocalXAxis As Geometry..::.XYZ
Visual C++
public:
Geometry..::.XYZ EndingPointOfLocalXAxis

See Also

LocalCoordinateSystem Class
MathLib Namespace


PointInPlaneXY Field

[image]

ENGISSOL - 3D Frame Library
LocalCoordinateSystem..::.PointInPlaneXY Field
LocalCoordinateSystem Class See Also Send Feedback
3D Frame Library

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public Geometry..::.XYZ PointInPlaneXY
Visual Basic (Declaration)
Public PointInPlaneXY As Geometry..::.XYZ
Visual C++
public:
Geometry..::.XYZ PointInPlaneXY

See Also

LocalCoordinateSystem Class
MathLib Namespace


StartingPointOfLocalXAxis Field

[image]

ENGISSOL - 3D Frame Library
LocalCoordinateSystem..::.StartingPointOfLocalXAxis Field
LocalCoordinateSystem Class See Also Send Feedback
3D Frame Library

Namespace: MathLib
Assembly: Frame3D (in Frame3D.dll) Version: 1.0.3731.28669 (1.0.0.0)

Syntax

C#
public Geometry..::.XYZ StartingPointOfLocalXAxis
Visual Basic (Declaration)
Public StartingPointOfLocalXAxis As Geometry..::.XYZ
Visual C++
public:
Geometry..::.XYZ StartingPointOfLocalXAxis

See Also

LocalCoordinateSystem Class
MathLib Namespace